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Introduction

Welcome to Flash Professional CS5 & Flash Catalyst CS5 For Dummies,

your friendly Web animation companion. In this book, we explain in
plain English how to make the most of Flash and Catalyst to create stunning,
animated Web sites. We aim to give you all the information you need to start
using Flash and Catalyst right away — with no hassle.

About This Book

As though you hadn’t guessed, Flash Professional CS5 & Flash Catalyst CS5
For Dummies covers the powerful animation product Flash CS5 Professional,
from Adobe. (The preceding version was Adobe Flash CS4. You're holding the
seventh edition of this book.) Flash CS5 is the latest version of the popular
software used on some of the coolest Web sites on the planet. We also cover
Adobe Flash Catalyst, a brand new program that offers a new way to create
Web sites.

We comprehensively explain the Flash features, including

1 Working with the Flash screen, toolbars, and menus
1 Creating graphics and text in Flash

» Adding sound and video

1~ Using layers to organize your animation

v~ Creating symbols, which are objects that you save for repeated use and
animation

v Animating graphics (the key to Flash)

1~ Creating interactive Web sites
We also cover Flash Catalyst, including:

» Importing artwork from Adobe Photoshop and Illustrator
v~ Defining Web pages in Catalyst

1 Working with buttons and other user interface components
1 Creating artwork and text in Catalyst

» Importing sound, video, and SWF files

v Publishing your Web site
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How to Use This Book

You don’t have to read this book from cover to cover. We provide just the
information you need, when you need it. Start with the first three chapters.
Then play around with graphics until you create what you need for your Web
site. You might want to check out Chapter 6, on layers, to help you organize
it all, and Chapter 7, which covers symbols. Then feel free to jump right to
Chapter 9, on animation, to create your first real Flash movie. Chapter 13 tells
you how to get your movie on your Web site. Then fire up your browser, sit
back, and marvel.

You’ll want to check out other chapters when you need them so that you
can create text and buttons, add sound and video, and build an interactive
Web site. Chapter 12 provides some ideas for putting all the Flash features
together for your best Web site ever.

Are you a designer, first and foremost? Do you love Adobe Photoshop?
Then check out Chapters 14 and 15, which introduce you to Flash Catalyst.
This new program lets you create Flash Web sites in Adobe Photoshop or
Illustrator and use Catalyst to convert your artwork to a fully functioning
Web site.

Keep Flash Professional CS5 & Flash Catalyst CS5 For Dummies by your com-
puter while you work. You'll find that it’s a loyal helper.

Foolish Assumptions

We assume that you're not a master Flash developer. If you want to use Flash
to create high-quality Web sites and you’re not an expert animator, you’ll find
this book to be a great reference. Flash Professional CS5 & Flash Catalyst CS5
For Dummies is ideal for beginners who are just starting to use Flash or for
current Flash users who want to further hone their skills.

Because people usually add Flash movies to Web sites, we also assume that
you know some of the basics of Web site creation. You should know what
HyperText Markup Language (HTML) is and understand the process of creat-
ing and structuring HTML pages as well as uploading them to a Web site.

If you want some help on the topic of Web sites, you might want to take a
look at Web Design For Dummies, 2nd Edition, by Lisa Lopuck or Building Web
Sites All-in-One For Dummies, 2nd Edition, by Claudia Snell and Doug Sahlin.
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Conventions Used in This Book

Sometimes it helps to know why some text is bold and other text is italic so
that you can figure out what we're talking about. (A typographic convention
is not a convention of typographers meeting to discuss the latest typography
techniques.)

New terms are in italics to let you know that they're new. When we suggest
that you type something, we show you what we want you to type in bold.
Messages and other text that come from Flash, including programming code,
are in a special typeface, like this.

When we say something like “Choose Filem>Save As,” it means to click the File
menu at the top of your screen and then choose Save As from the menu that
opens. When we want you to use a toolbar or panel button (or tool), we tell
you to click it.

The Flash interface features an item for changing values that’s like a combo
text box and slider, except that there isn’t any text box when you first see it.
If you click the value, a box appears in which you can type and then press
Enter (Windows) or Return (Mac). Alternatively, you can also click and drag
upward or downward, like a traditional slider even though no slider is vis-
ible. Calling it a text box seems misleading because you don’t see a text box.
For this book, this is how we generally describe this way of doing things:
“Click the value, type a new value, and then press Enter (Windows) or Return
(Mac), or drag to specify a new value.”

How This Book Is Organized

We start by presenting an overview of the Flash universe and then continue
in the general order that you would use to create a Flash movie. More basic
material is at the beginning of the book, and more advanced material (but not
too advanced!) comes later.

To be more specific, this book is divided into seven parts (to represent the
seven states of consciousness — okay, we don’t have to get too cosmic here).
Each part contains two or more chapters that relate to that part. Each chap-
ter thoroughly covers one topic so that you don’t have to go searching all
over the cosmos to get the information you need.
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Part I: A Blast of Flash

Part I contains important introductory information about Flash. In Chapter
1, we tell you what Flash is all about, show you what the Flash screen looks
like, and explain how to get help when you need it most. You also find
instructions for starting a new movie and opening an existing movie, and
we give you a list of steps for creating your first animation. If you're new to
Flash, running through these steps will give you a great overview. Chapter 2
explains in more detail the steps for creating a Flash movie. We also explain
some basic concepts that all Flash users need to know.

Part 1I: 1,000 Pictures and 1,000 Words

Part Il explains all the tools available for creating graphics in Flash. Chapter 3
explains the unique drawing tools included in Flash. We also explain how to
import graphics if you don’t feel like creating your own. Chapter 4 shows you
how to edit and manipulate graphic objects, and Chapter 5 is all about creat-
ing text. Chapter 6 explains layers, which help you organize your graphics so
that they don’t interfere with each other.

Part 11]: Getting Symbolic

Symbols are graphical objects that you save to use again and again. Whenever
you want to place an object on a Web page more than once, you can save the
object as a symbol. You can also group together many individual objects,
making them useful when you want to manipulate, edit, or animate them

all at one time. Chapter 7 explains creating and editing symbols. Chapter 8
describes how to create buttons — not the kind that you sew, but rather the
kind that you click with your mouse.

Part IV: Total Flash-o-Rama

Part IV explains how to put all of your graphics together and make them
move. Chapter 9 covers animation in detail — from frame-by-frame anima-
tion to tweening, where Flash calculates the animation between your first and
last frames. Tween movement to make your objects move or morph into new
shapes. You can also tween color and transparency.

Chapter 10 shows how to create interactive Web sites that react to your view-
ers. For example, when a viewer clicks a button, Flash can jump to a different
part of a movie or go to a different Web page entirely. To create interactivity,
you use ActionScript, Flash’s JavaScript-like programming language. We tell
you how to put ActionScript to work.

Chapter 11 is about adding multimedia — sound, music, and video — to your
Flash movies and buttons.
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Part U: The Movie and the Web

This part helps you put all your animated graphics and cool buttons together
and publish your work on the Web. Chapter 12 outlines the various tech-
niques that you can use to create a great Web site by using only Flash.

Chapter 13 explains how to test your animation for speed and suitability for
all browsers and systems. Then we cover the details of publishing movies
as well as the other available formats, such as HTML and GIF. You can also
create projectors — movies that play themselves.

Part Vl: Building Web Sites Fast with Flash Catalyst

For designers who like to design Web sites, Catalyst is a dream come true.
Chapter 14 explains how to build Web sites in Photoshop or Illustrator,
import the file into Catalyst, and add elements such as buttons and check
boxes. We also show you how to add animation to the user interface.
Chapter 15 covers adding art, text, audio, video, and more.

Part VII: The Part of Tens

What’s a For Dummies book without The Part of Tens? Chapter 16 answers
some frequently asked questions about Flash and introduces some special
techniques, such as synchronizing sound with motion and rescaling the size
of your entire movie. Chapter 17 provides you with the ten best resources for
Flash (besides this book, of course). Chapter 18 points you to the work of ten
fabulous Flash Web designers

Icons Used in This Book

Icons help point out special information. For example, sometimes they tell you
that you don’t care about this information and can skip over it without fear.

This icon flags new features in Flash CS5. If you have been using Flash C54 or
even an earlier version, you may want to skim through this book and look for
this icon to help you quickly get up to speed in the new version.

Look for this icon to find all the goodies on the companion Web site, at www .
dummies.com/go/flashCs5£d. We include supporting files for many of our
examples so that you can try them out.

This icon alerts you to information that you need to keep in mind to avoid
wasting time or falling on your face.
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Flash has some advanced features you might want to know about — or skip
entirely. This icon lets you know when we throw the heavier stuff at you.

Tips help you finish your work more easily, quickly, or effectively. Don’t miss
out on these.

Uh-oh! “Watch out here!” is what this icon is telling you. If you skip this icon,
you never know what might happen.

Where to Go from Here

If you haven'’t already installed Flash, check out the complete instructions for
installing Flash on this book’s companion Web site, www . dummies.com/go/
flashcs5£d. Then open Flash, open this book, and plunge in.

Here’s some of the other cool stuff that you can find on the Flash Professional
CS5 & Flash Catalyst CS5 For Dummies companion Web site:

v~ A library of geometric, fanciful, and artistic vector graphics ready to be
instantly opened in any Flash movie

 Flash movies that you can dissect

Your own personal library of vector graphics

We created for you more than 50 vector graphics that you can use in your
Flash movies. Some are geometric shapes that are hard to create in Flash.

We added fun shapes . . . some practical and others whimsical, such as our
thought bubble and explosion. Finally, we included some art drawings of
everyday objects. We hope you like them! (Please keep in mind that these files
are provided for your personal use and are not to be sold or redistributed.)

To download the library of graphics, point your Web browser to www .
dummies.com/go/flashCS5fd and click the download link to down-
load the zip file for this book. When you unzip the file, you'll see a file
named Flash CS5 For Dummies Library.fla.All that you see when
you open this file in Flash is a blank screen. To see the graphics, choose
Windowr>Library. To use these shapes in another Flash file, choose Filew>
Import to Library and choose the file named Flash CS5 For Dummies
Library. fla from the location where you saved it on your computer.
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An even better idea is to copy the FLA file from wherever it is on your
computer to the Libraries subfolder of your Flash CS5 folder. (In Windows,
you find this at Program Files\Adobe\Adobe Flash CS5\en_US\
Configuration\Libraries on your hard drive. On a Mac, you find it in
Applications/Adobe Flash CS5/en_US/Configuration/Libraries
on your hard drive.) (The en_Us subfolder refers to the language, and may
differ for your installation.) Then you can access this file at any time by
choosing Window=>Common Libraries.

Flash movies galore

Throughout this book, we refer you to the companion Web site to look at
Flash movies as examples of the features we are explaining. These movies
are organized by chapter. They help you understand some of the more com-
plex capabilities of Flash that are hard to explain or show in a figure. Some of
these movies are real-world Flash movies that come from active Web sites.
Others are examples that we created for you to isolate a Flash feature. Either
way, we hope that you can use them to further your understanding of Flash.

To examine and use these movie files, you need to first download them

to your hard drive. Point your Web browser to www . dummies.com/go/
flashcs5£d and download the zipped file. When you unzip it, you can open
the file you want. Here are a few troubleshooting tips to keep in mind when
you use the Flash movie files provided on the Web site:

~ The Flash movie doesn’t play. Sometimes when you open a Flash movie
and try to play the animation, nothing happens. Choose Control=>Test
Movier>In Flash Professional to see the animation.

1~ The fonts look different. If some of the fonts required by the Flash files
aren’t available on your system, you might see less-than-satisfactory
substitutions when you play the Flash Player files. You might also see a
message asking you to substitute fonts. You can click Default or choose
any fonts you want.

We would love to hear your comments about this book. You can contact
Gurdy Leete at gleete@mum. edu or Ellen Finkelstein at el1len@ellen
finkelstein.com. Please note that we can’t provide technical support
on Flash. (If you need technical support, check out the resources we list in
Chapter 17.)

Enough of all this talk. It’s time to move into the real part of this book and
start creating cool Flash movies! Enjoy!

/
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Part |
A Blast of Flash

“You know, T’ve aked. gou a dozen times not to
animate the torches on our Web page,”




n this part, you discover what Flash can and
can’t do and start to make your way around
the Flash world. In Chapter 1, we introduce you to

Flash, show you what it looks like, and explain
how to use its toolbars, menus, and panels. You
find out about the Stage and the Timeline, two
central Flash concepts. Play your way through
your first animation to get firsthand experience in
the power of Flash.

In Chapter 2, you get an overview of the entire
process of creating a Flash animated movie, from
developing your concept to publishing your movie
in the format a browser can display. We explain
how to set properties that affect your movie as a
whole and how Flash works with various kinds of
graphics. We close with the steps for printing your
movie on paper. This part provides the foundation
for future success.

Ra nbow

The Box Office is
Now Open!
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Getting Acquainted with Flash CS5

In This Chapter

Introducing Flash

Figuring out what you can create with Flash CS5
Knowing when not to use Flash CS5

Starting Flash

Perusing the screen

Using Help

Creating your first animation

Closing Flash

Once upon a time in a galaxy that seems far, far away by now,
there was the Internet, which contained only plain,

unformatted text. Then came the Web, and we gained text
formatting and graphics. Then the Web grew up a little,
and Web page graphics got fancier with things such
as small animations in banner ads. But people, being
used to movies and TV, wanted an even more ani-
mated and interactive Web experience. Along came
Flash.

Ra nbow
Resources

Flash is the software that runs some of the coolest
Web sites around. When you surf the Web and see
sites that contain animation across the entire page

or buttons that do spectacular stunts when you click
them, you’re probably seeing some Flash magic. If you
create a Web site, you can use Flash to rev up the basics

and actively respond to users’ choices so that your view-

ers will say, “Wow!” Even a lot of video that you see on the
Internet, such as at YouTube.com, uses a compressed Flash video
format (FLV).

In this chapter, you find out what Flash is all about, what the Flash screen
looks like, and how to use Help. Then you create your first, simple animation
so that all the rest of this book makes sense.
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Want a great new way to create a Flash Web site without using Flash? Yes, it’s
possible! You can design the site in Adobe Photoshop or Illustrator and then
use Adobe Flash Catalyst to create the site. For more information, see Part VI.

Discovering Flash

WBER
éQ‘
&

Flash offers a powerful system for creating animation for the Web. In a nut-
shell, here’s an overview of how you use the system:

1. Create a Flash movie by creating graphics and animating them over the
duration of the movie.

Besides animated graphics, you can add navigational buttons, check
boxes, and other user interface elements. You can add a few Flash com-
ponents to a Web site or create an entire Web site.

2. Use the Publish command in Flash to publish the movie into a Flash
Player file that a browser can display.

At the same time, Flash creates the appropriate HyperText Markup
Language (HTML) code that you need for your Web page.

3. Insert HTML code into your HTML document that references the Flash
Player file.

This is similar to adding a graphic to a Web page. Or you can use the
HTML code alone as a new Web page for a fully Flashed page.

4. Upload the new or edited HTML document and the Flash Player file to
the location where you keep other files for your Web pages.

5. Open your browser, navigate to your Web page, and presto! — there’s
your cool animation, navigation, or other Flash element on your
Web page.

You need Flash Player to see the effects that Flash creates. These days, Flash
Player comes installed with most computer systems and browsers, so most
people can view Flash-driven Web sites immediately without any special
download or preparation. When you display a Web site that contains Flash
effects, your system uses Flash Player to play the animation. Users who don’t
have Flash Player can download it for free from Adobe at www.adobe . com/
go/flashplayer.

Web sites continue to grow more and more sophisticated. By using anima-
tion, special effects, and interactive techniques, you can distinguish your
Web site from the also-rans. Creating animation isn’t hard, and you don’t
have to be a professional graphic artist, either. Anyone can create simple
animations to enhance a Web site; it just takes a little time.
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To find great Web sites that use Flash, check out the Adobe site at www .
adobe.com/cfusion/showcase/index.cfm and look at some examples.
Don’t get discouraged by seeing some truly sophisticated results at these
sites. You can start with a simple, animated site and go from there. (Chapter
18 lists ten great Flash designers and where you can find their work.)

Understanding What Vou Can Create
with Flash CS5

You can use Flash CS5 to create simple animation to add to your Web page.
Or you can create an entire Web page or site with Flash and incorporate text,
graphics, interactive buttons, user interface components, and animation.

This book helps you use Flash to create a simple or complex Web site. The

following list describes some ways that you can manipulate text, graphics,
and sound by using Flash CS5:

1~ Create still or animated text on your Web page. You can choose to

stop the animation after a few seconds or repeat it while your viewers
view the page.

1~ Use Flash tools to create your own graphics for your Web page or to
import graphics. You can lay out an entire Web page graphically or add
graphics to only a part of a Web page, as shown in Figure 1-1.

Now Opent

Thanks to the New York Philharmonic, wow . nyphi 1 . org, for permission. Photo by Chris Lee
Figure 1-1: The New York Philharmonic Web site uses Flash to
create an ever-changing display on its home page.
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1~ Animate graphics and make objects appear and disappear by using
the transparency feature. Objects can move, get bigger or smaller, or
rotate. Flash also lets you morph — that is, transform — shapes into new
shapes.

v~ Fill shapes and text with gradients, which are colors that gradually
change into new colors. You can even fill shapes and text with bitmap
images that you import into Flash. For example, you could fill the let-
ters of your name with dozens of flowers. (You aren’t a flower child any
more?)

1 Create Web page buttons that not only lead your viewers wherever
you want them to go but also change shape or color at the same time.
You can make buttons change when you pass your mouse over them.
People who view your page can click a button to display a movie (anima-
tion) or start a small application.

1~ Add sound or video to your movie. It’s easy to add sound effects in
Flash. You can control how long the sound or music plays and whether
it loops to play continuously. You can play video files as well.

1 Create menus that viewers can use to navigate your site. You can
create navigation tools as well as forms, check boxes, and other inter-
face elements that look a lot more stylish than plain HTML ones.

As you can see, you can go far with Flash if you want. And why not? It’s
great fun!

Determining When Not to Use Flash CS5

If Flash CS5 is so wonderful, why doesn’t every Web site designer use it? Why
aren’t most Web sites created completely with Flash?

Here’s the other side of the story.

Although the vector graphics and animation of Flash load quickly, they don’t
load as quickly as plain text and simple graphics. Adding a movie to your
Web page adds to its loading time. There’s no point in using Flash if you want
simple pages consisting of mostly text and a few graphics that you want to
stay put and not move.

You can create certain graphic effects more easily by using bitmap graphics.
Painted brush stroke and textured effects are examples. Artists create these
types of graphics by using graphics editing software, and the results are bit-
maps. Similarly, to add photographs to your Web page, you need to insert
electronic image files. Flash creates vector graphics (defined mathematically),
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which are different from bitmap graphics (defined by lots of dots). However,
you can import bitmap graphics into Flash. Find out more about bitmap and
vector graphics in Chapter 2.

If you want simple animation, such as a few blinking dots or a marquee effect,
animated GIFs (the animated bitmap graphics that you often see on the Web)
might be smaller than Flash movies, so they load faster. You can create ani-
mated GIFs by using animated GIF editing software.

Some sites don’t lend themselves to animation. Animation can distract from
your content, and overdoing animation can make a serious site seem silly.
Animation is great, but it has its place. Also, although Flash has some fea-
tures that allow accessibility for people with disabilities, it still isn’t as acces-
sible as plain HTML. You need to determine whether animation is right for
your Web site.

Getting the Right Start

Well begun is half done, as the saying goes. The easiest way to begin using
Flash CS5 is with a shortcut or alias right on your desktop. Double-click the
Flash icon, and you’re on your way. (See the book’s companion Web site for
information on installing Flash.)

Starting Flash on a PC

Whether you installed Flash from the DVD or by downloading it from the
Adobe Web site onto your PC, you might or might not have a shortcut on
your desktop. To create one, choose Start=>All Programs=>Adobe Flash
Professional CS5. With your desktop visible, press the Ctrl key and drag the
Adobe Flash CS5 item onto the desktop.

To rename the shortcut, click the shortcut on your desktop. Then click the
text beneath the icon. Type Flash CS5 (or whatever you want) and press
Enter. Just double-click the icon to open Flash.

Starting Flash on a Mac

You might find it handy to add the Flash CS5 icon to your Dock for easy
launching. To do this, click the Finder icon on the extreme left of the Dock
to bring up a new Finder window. Navigate in the Finder window to the
Applications folder, and in the Applications folder, double-click the Adobe
Flash Professional CS5 folder to open it. Click and drag the Flash CS5 appli-
cation icon to the Dock. A copy of the Flash CS5 application icon appears
on the Dock.

15
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Creating a new movie

Files that you create by using Flash are commonly called movies. When you
start Flash, the startup screen appears (by default), as shown in Figure 1-2.
In the Create New section, click one of several options to immediately open
a new movie file. These options let you create movies for various types of
uses, such as mobile devices and further programming. For the purposes of
this book, we assume that you want to create a general-use movie using the
latest technology, which is the ActionScript 3.0 option. (ActionScript 3.0 is
the latest version of Flash’s programming language.)

If you already opened a movie and have the menus available, choose Filew>
New. In the New Document dialog box, select ActionScript 3.0 on the General
tab and then click OK. You usually start by creating or importing some graph-
ics. (To find out more about working with graphics, see Chapter 3.)

Create from Template Create New Learn

‘ Adhvertising ' ActionScript 3.0 .,j 1. Introducing Flash =

T Animation T ActionScript 2.0 || 2 symbols »

. Banners ‘ Adobe AR 2 ,J 3. Timelines and Animation »
' Media Playback ‘ iPhone J 4. Instance Names »

T Presentstions B Flashlied || 5 simple Interactivity »
‘ Sample Files 1 ActionScript Fils _‘J 6. &ctionScript =

Z Flash JavaScript File _J T.Waorking with Data »
Open a Recent ltem | Flash Project || & Buiding an Application
‘ ligature example.fia -_ ActionScript 3.0 Class l,j 9. Publishing for Mohile =
‘ mavie of the year fia 1 Action=cript 3.0 Interface _‘g 10. Publishing for AR =
9 open.. -.J 1. Adobe TV »
Extend

E Flash Exchange »

i‘_ Betting Stared - Adobe® CS Live online services
'i—\l He: Featresas Learn maore about the new Adobe CS Live
HJ Developers » online services, (FL,en_US,11.0)

LJ Designers =

|| Dontshow again

Figure 1-2: The Startup screen.
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Opemnq an emstmq movie

If you want to work on a movie that you already created when you first open
Flash, choose the movie from the Open a Recent Item section of the Startup
screen, or click Open to find the file. If you already opened a movie and

have the menus available, press Ctrl+O (Windows) or 8+0 (Mac) or choose
Filec>Open; then double-click the movie to open it. The first frame appears on
your screen, and you can edit the movie any way you want.

When you open more than one movie, you see a tab at the top for each
movie. You can click the tabs to move from movie to movie. The tabs appear
in the order you created or opened the movies.

Taking a Look Around

The Flash screen is different from screens in other programs that you might
be used to, so take the time to get to know it. You can also customize the
Flash screen. Figure 1-3 shows one possible display.

Edit bar Stage

Filename tab Menu bar Property inspector

PSS ¢ | (B

Tile Tt Ve s Modly Tet Commads | Conrol | Ovbug  Wandow  Help |

Lintithest-1 ¥
i soma 1 %, &, D -l & 7]
el AL A
B < LI i ?
_. Parvert Flash Flayar 10 il ‘;
“' Serigh) ActionSorgd 3.0 ‘:'
o O + I
) Frofle: Defit e N
[ AR Sattngs ;l'
] AticTet StngE Lat. I
¥ o PROGERTIES. &
s __| @
S 550 5 400 e [ eae) |€-l.
w1 ’
o VW HESTORY =
4
X
7
|
&
{1
7 .
e | F
=a0 w s o = » »B % %0 = m
B }:n-'v:s?
FSE | N L i s i @ o °|
Playhead Timeline Tools panel

Figure 1-3: The Flash screen.
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If your screen opens with several rectangular panels strewn about or docked
on various sides, don’t worry about them now. We explain how to open and
use these panels throughout this book, but you don’t need them for this
chapter. If they drive you crazy, right-click (Windows) or Control-click (Mac)
each panel’s title bar and choose Close or Close Group in the menu that
appears.

Tooling around the toolbars

Flash contains two toolbars in the Mac version: the Edit bar and the
Controller. In Windows, Flash also offers the Main toolbar. To display or hide
these toolbars, choose Windowr>Toolbars and click the toolbar that you
want to display or hide. Here is a description of the toolbars:

1 Main toolbar (Windows only): Contains commonly used commands,
such as Open, Save, and Print. By default, Flash does not display the
Main toolbar.

1~ Controller: Lets you control the playback of movies. For more informa-
tion, see Chapter 9.

v~ Edit bar: Helps you work with the symbols, scenes, and the user
interface (Ul). The bar, shown in Figure 1-3, appears below the menu.
It includes a button to access symbols (which we cover in Part 1), a
button for editing scenes, and a zoom control. We discuss the Timeline
later in the chapter, in the “Following a timeline” section. For detailed
information about the Timeline and scenes, see Chapter 9.

Using panels

Panels give you access to the many Flash tools and settings. You access the
panels from the Window menu. We discuss the specific panels throughout
this book. In this section, we explain how to keep control over your panels.

Most panels are dockable, which means they can sit at the side or bottom of
your Flash window without covering up your work and they fit together in a
group with other panels. You can also stack undocked panels on top of each
other. You control panels by doing the following:

~ Dock a panel. Drag it by its title bar to the side or bottom of your
screen. When you see a blue bar highlight, release the mouse button.
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1 Undock a panel. Drag it by its title bar.

* Open or close a panel. Choose it from the Window
menu.

1 Close an undocked panel. Click its Close button.

 Close a docked panel. Right-click (Windows) or
Control-click (Mac) its title bar and choose Close.

1~ Collapse a group of panels to icons. Click the
double right arrow at the top of the group of docked
panels.

You can also stack panels. Drag a panel (by its title bar)
to another panel to stack it below the first one. You can
also collapse or expand panels: A collapsed panel dis-
plays only its title bar, so it doesn’t take up much space.
Just click its title bar. Repeat the process to expand the
panel again.

A set of icon panels, shown in Figure 1-4, provides short-
cuts to often-used panels. You click the button to both
open and close its panel.

The Tools panel contains all the tools you need to

draw and edit objects. At the bottom of the Tools panel
are options that modify how the tools function. (See
Chapters 3 and 4 for a complete description of the Tools
panel.)

Chapter 1: Getting Acquainted with Flash CS5
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E——Swatches
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@——Actions

Figure 1-4: The icon
panels look like toolbar
buttons. Use them to
open and close panels.

The Property inspector, shown in Figure 1-5, is another important panel. This
panel displays information about selected objects, such as size, name, and
location. You can modify objects in the Property inspector as well. It’s con-
text sensitive, which means that its contents change according to what you're
doing. For example, if you select a graphic object, the Property inspector pro-
vides settings relating to that object, and you can use the Property inspector

to edit that object.

By default, the Property inspector is grouped with the Library (which we

explain in Chapter 2).

The Property inspector has several controls for changing its configuration:

19
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1~ Tab: Double-click the tab at the
top (which reads Properties)
to collapse the Property inspec-
tor completely (you see just the
tab); click the tab to restore it
to its full glory.

1~ Collapse to Icons button: Click
the small double arrows at the
top of the Property inspector to
switch between an icon and the
open state.

v~ Title bar: Click the gray bar at
the top to minimize or maximize
the Property inspector. In the
default configuration, the top
bar also applies to the Library.

Discovering the
Flash menus

Most drawing functions are available
only from the Tools panel. You often
use the Timeline for creating anima-
tion, as we discuss in the “Following
a timeline” section, later in this chap-
ter. Almost every other function in
Flash is on a menu somewhere. You
just need to find it. In general, we
discuss the specific menu functions
where appropriate throughout this
book. Table 1-1 offers an overview of
the menus.
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Figure 1-5: The Property inspector.

Table 1-1 Flash Menus

Menu UseltTo

Flash (Mac only) Set preferences, create keyboard shortcuts, and quit
Flash.

File Open and close files, save files, import and export files, print, pub-

lish movies for the Web, send a movie via e-mail, and quit Flash.
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Menu UseltTo

Edit Undo and redo commands; cut, copy, and paste to and from the
Clipboard; delete, duplicate, select, and deselect objects; find
and replace; copy and paste entire frames and motions on the
Timeline; edit symbols (see Chapter 7); set preferences (Windows
only); customize the Tools panel; map fonts; and create keyboard
shortcuts for commands (Windows only).

View Zoom in and out; show or hide the ruler, grid, and guides; choose
a preview mode; and specify snapping preferences for objects for
easy placement.

Insert Insert symbols (see Chapter 7); insert and delete Timeline features,
such as frames and keyframes (see Chapter 9); insert layers (see
Chapter 6); and add scenes (see Chapter 9).

Modify Modify symbols, bitmaps, shapes, frames, Timeline features and
effects, scenes, or the entire movie (the document). Transform,
align, group, and ungroup objects; arrange objects; and break
objects apart.

Text Format text, check spelling, and embed fonts.

Commands Reuse and manage saved commands. A command is any action
that you take in Flash, such as drawing or editing an object. You
can save commands from the History panel. (See Chapter 4.)

Control Control the playing of movies, test movies and scenes, access cer-
tain interactive functions, and mute sounds.

Debug Debug ActionScript code. (See Chapter 10.)

Window Open lots of things, including a duplicate window, panels that help

you control objects, the Library (see Chapter 2), windows for cre-
ating interactive controls (see Chapter 10), workspaces, and the
Movie Explorer (to help manage your movie — see Chapter 12).

Help You can find a wide variety of help resources, including Adobe
online forums.

Many menu commands offer keyboard shortcuts. You can also create your
own keyboard shortcuts. (See the bonus chapter, available at the book’s
companion Web site, www.dummies.com/go/flashcs5£d, for instruc-
tions.) The shortcuts are displayed on the menus, next to the command
name. Here are some of the most commonly used keyboard shortcuts.

v Ctrl+N (Windows) or 38+N (Mac): Open the New Document dialog box so
you can start a new movie.
v Ctrl+O (Windows) or 88+0 (Mac): Open an existing movie.

v Ctrl+S (Windows) or $8+S (Mac): Save your movie. Use this shortcut
often!

» Ctrl+Q (Windows) or 3+Q (Mac): Exit Flash.

21
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v Ctrl+X (Windows) or 8+X (Mac): Cut to the Clipboard. Chapter 4
explains more about using the Clipboard.

v Ctrl+C (Windows) or 8+C (Mac): Copy to the Clipboard.

v Ctrl+V (Windows) or 8+V (Mac): Paste from the Clipboard. The copy
goes at the center of the display.

1 Ctrl+Shift+V (Windows) or 8+Shift+V: Paste in Place (the same location
as the original).

v Ctrl+Z (Windows) or $8+Z (Mac): Undo. Would you believe that by
default Flash remembers your last 100 actions and can undo them? What
arelief! And if you choose Windowr>Other Panels->History, the History
panel lists each action so you know what the next Undo will undo. Think
of it as a journey into the long-forgotten past. (See Chapter 4 for more
on the History panel, and see the Bonus Chapter at the book’s compan-
ion Web site for details on customizing the number of Undos that Flash
remembers.)

v Ctrl+Y (Windows) or 88+Y (Mac): Redo. This redoes actions that you
undid by using the Undo command. (Got that?) This button remembers
just as many actions as the Undo command. If you undo more actions
than you want, Redo until you’re back where you want to be. Using the
Undo and Redo commands is like traveling through Flash time — and it
gives you lots of slack while you’re working.

We mention other keyboard shortcuts throughout this book when we discuss
their corresponding commands.

Although it’s not a shortcut, note that you can find the Zoom Control box

in the upper-right corner of the Stage — that is, when the Edit bar is open.
(Choose Window=>Toolbars=>Edit Bar if necessary.) Click the arrow and
choose a zoom factor to zoom in and out. Zooming doesn’t change the actual
size of objects — it just makes them look bigger or smaller.

You aren’t limited to the choices on the Zoom drop-down list. Type a number in
the Zoom Control box and press Enter (Windows) or Return (Mac) to set your
own zoom factor. For example, type 85 to set the zoom factor to 85%.

Customizing the workspace

For the best in customization, you can save any Neme: Default+eolor

layout of panels you like. Set up the panels and

choose Window=>WorkspaceroNew Workspace. In
the New Workspace dialog box that opens, shown
in Figure 1-6, give the layout a name and click Figure 1-6: Make your very own
OK. To restore that layout at any time, choose workspace.
Window=>Workspace and choose your very own

layout. Choose Window=>WorkspaceroManage Workspaces if you need to
rename or delete a workspace.

New Workspace
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You can access the same workspace features on the right side of the Menu
bar. It’s easy to choose a new workspace by just clicking the Workspace
drop-down list.

Staging your movies

The white box in the center of your screen is the Stage. Think of the Stage
as a movie screen where you place objects. You can place graphics and text
there and then animate them. Flash also plays back movies on the Stage.

Around the edge of the Stage is a gray area called the Pasteboard. You can
use the Pasteboard to store graphics that you plan to use soon but don’t
want on the Stage just yet. (For more permanent storage, use the Library,
as we explain in Chapter 2.) You can also store data and other nongraphical
content on the Pasteboard. Content that you put on the Pasteboard doesn’t
appear in your Flash movie.

Following a timeline

The Timeline window divides your movie into frames. Each frame represents
a tiny stretch of time, such as /4 of a second. Creating a movie is simply a
matter of assembling frames, which are then quickly played in order.

Chapter 9 explains in detail how to make using the Timeline completely pain-
less. For now, you should just understand the essentials. See Figure 1-7 for
the basic Timeline.

TIMELLINE
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Figure 1-7: The Timeline is your key to managing animation.

On the left side of the Timeline is the layer list. When you open a new movie,
you see only one layer, unimaginatively named Layer 1. A layer is like a sheet
of transparent acetate on which you draw objects. Layers help you keep
objects from running into each other, causing unfortunate, messy results.
You organize your entire movie by using layers. For example, if you want to
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keep some text constant throughout the movie but animate a bouncing dot,
you would give the dot its own layer and animate it on that layer. The layer
list has room for more layers, and you can add as many layers as you want.
(Chapter 6 gives you the lowdown on layers.)

You can drag the upper edge of the Timeline to make room for more layers.
Hover the mouse cursor over the top of the Timeline’s gray title bar until you
see the two-headed arrow and then drag upward.

To the right of Layer 1, you see a bunch of rectangles, each representing a
frame. (Actually, before you start using the Timeline, they’re just potential
frames, like unexposed frames on a roll of film.) By default, each frame lasts
%4 of a second. Each layer has its own row of frames because you can have
different animations or objects on each layer.

A keyframe is a frame that defines some change in your animation. In some
animations, every frame is a keyframe. Other animations need keyframes for
only the first and last frames.

The playhead indicates the current frame in the animation and consists of a
red rectangle as well as a vertical hairline that crosses a frame on all layers.
Before you create any animation, the playhead is always on Frame 1.

You don’t use the Timeline until you’re ready to animate. While you work,
however, you should organize your objects on separate layers. Don’t worry —
you can always move an object from one layer to another.

Next to the Timeline tab is the Motion Editor tab. We discuss the Motion
Editor in Chapter 9. For now, it’s good to know that the Motion Editor gives
you detailed control over your animations.

Getting Help in a Flash

This book is all that you need to start creating great animations, but we
would be remiss if we didn’t tell you about the Flash Help system. To use
Flash Help, choose Helpr>Flash Help.

Help’s multiple manuals

Flash Help contains three sections:

1~ Using Flash CS5 Professional is the main Help manual.

1~ ActionScript 3.0 Language and Components Reference is a manual on
the latest version of ActionScript, Flash’s programming language. (See
Chapter 10 to find out more.)
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You don’t need to program Flash to use it, if you are interested only in
graphics and animation.

1~ Additional Resources (adobe.com) brings you to the Adobe.com Search
Community Help page, where you can search through discussion groups
and other support resources.

To search for a term, click the Search button. Then type the term and click
Search. You can then choose from the list of topics.

Finding more help on the Web

Adobe offers support on its Web site. Choose Help=>Flash Support Center.
There, you can search the knowledge base and tutorials for answers to your
questions.

Try It — You'll Like [t

Perhaps by now you're getting impatient to try out Flash. Getting started is
easy. You collect a few ideas, put together some art, add animation, save
your movie, and publish it. Then you view it in a browser either online or
offline. That’s the gratifying part. In the following sections, you get to try out
Flash by working through a basic animation. The rest of the book explains
these concepts in more detail.

Conceiving your first animation

Suppose that you want to add an animated logo

to a home page that you already set up. You Rainbow
want the animation to run when the page loads

and then stop. Figure 1-8 shows the Rainbow

Resources company logo — unanimated, of

course — that you can find on this book’s Web

site, at www.dummies.com/go/flashcs5£d.

Suppose that you want the word Rainbow to Figure 1-8: A company logo that
fly into your page from the right and the word could stand some animation.
Resources to fly in from the left. At the same time,

you want the graphic to rotate 180 degrees. The following section shows you
how to create this animation.

Creating flashy drawings

You can use Flash to create a company logo, but importing one from this
book’s Web site is simpler. Often, you import existing graphics (such as a
company logo) from a file rather than create them from scratch. (Chapter 3
explains how to import and manipulate graphics.)
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&“ If you're going through the steps and make a mistake, choose Edit~>Undo (or

press Ctrl+Z or 8+Z) and try again. You can use Undo repeatedly to undo
several steps, if necessary.

To import the Rainbow Resources logo into Flash, follow these steps. (The
steps might vary if you're importing some other graphic in a different format.)
1. Start Flash.

See the instructions in the section “Starting Flash on a PC” or “Starting
Flash on a Mac,” earlier in this chapter, if you need help.

2. In the Create New section of the Startup screen, choose ActionScript 3.0.
You see a spanking-new movie on your screen.

3. Go to www.dummies.com/go/flashcs5£d and download the Bonus
Content, which contains the rainbow.gif image file.

You'll need to unzip the file and extract the image file. Extract this image
file to the location where you plan to save your Flash movie.

4. Choose File>Import=>Import to Stage.
The Import dialog box opens.

5. Browse the dialog box until you find rainbow.gif in the location
where you saved it, and then double-click the file to open it.

You see the logo onscreen. You need to break the logo into pieces and
make it a vector graphic so that you can animate sections of it separately.

6. Choose Modify->Bitmap> Trace Bitmap.
The Trace Bitmap dialog box appears.

7. In the Trace Bitmap dialog box, set the color threshold to 100, the
minimum area to 1, the corner threshold to Many Corners, and the
curve fit to Pixels. Click OK.

In our example, we chose to use settings that reproduce the bitmap
as faithfully as possible. Flash creates a vector graphic and breaks the
graphic into individual components. The entire graphic, however, is
selected.

8. Click anywhere outside the graphic to deselect it.

You have your logo! Now you need to set it up for animation.

Turning your objects into symbols

In the logo that you imported in the preceding section, each letter is a sepa-
rate object, which can get pretty confusing. Each line in the logo’s design

is also separate, but you want your words — and the little design — to stay
together. So, you must combine each word and the logo into a symbol. A
symbol helps keep objects together and is required for some kinds of anima-
tion. (See Chapter 7 for the scoop on symbols.)
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To turn the words and the logo into symbols, follow these steps:

1.

To get a better view of your image, click the Zoom Control drop-down
list (upper-right corner of the Stage area) and choose 200%.

If you don’t see the Zoom Control drop-down list, choose Window=>
Toolbars=>Edit Bar to display it.

Use the scroll bar to scroll the words of the logo into view, if necessary.

2. Click the Selection tool on the Tools panel if it’s not already selected.

3. Click the upper-right corner of

10.

the word Rainbow (just above
and to the right of the w) and R b
ow
X,

drag to the lower-left corner of
the first letter, R.

Dragging from right to left makes
it easier to avoid selecting the
logo at the same time. The entire
word should be selected. If it
isn’t, click outside the word and
try again. Your screen should

look like Figure 1-9. . . )
Figure 1-9: Selecting text to prepare it for

. Choose Modify->Convert to animation.

Symbol.

. In the Convert to Symbol dialog box, choose Graphic from the Type

drop-down list, enter Rainbow in the Name text box, and then click OK.

When you click OK, Flash places a box around the word so you can see
that it’s one object.

. Repeat the procedure outlined in Steps 3-5 with the word Resources.

In this case, you might want to start clicking and dragging from the
upper-left area of the word; then choose Modify=>Convert to Symbol
again, enter Resources in the Name text box, and click OK. Now all the
letters of the word Resources are a single object.

. Click above and to the left of the logo and drag to the lower right to

select the entire logo.

. Hold down the Shift key and click each word to remove both words

from the selection.

The design portion of the logo is selected.

. Choose Modify~>Convert to Symbol.

The Convert to Symbol dialog box opens.

Enter Lines in the Name text box, and then click OK in the Convert to
Symbol dialog box.

Flash creates a symbol from the lines of the logo’s design.
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See Chapter 7 to find out more about what symbols are and how to use them.
Symbols are important building blocks in Flash movies.

Putting your graphics on layers

You need to place different pieces on different layers when you’re animat-
ing. You use layers to organize your movie and keep shapes separate so that
they don’t interfere with each other. (See Chapter 6 for the complete story on
layers.)

To split your three symbols onto three separate layers, you can use a conve-
nient feature of Flash CS5: Distribute to Layers. Follow these steps:

1.
2.

. Click the Zoom Control drop-

Click the Selection tool on the Tools panel if it’s not already selected.

Drag diagonally across the entire logo, including the two words, to
select it.

You should see two rectangles inside one bigger rectangle. All three
objects in the logo are selected.

. Choose Modify= Timeliner> [ umiEunE | mouoNEmior [

Distribute to Layers.

= @8 Ol 5
You now have three new layers,
named Rainbow, Resources, al Layer 1 + « O
and Lines. The three objects of al >
the logo have been distributed al Rainbow + « O
to the three new layers and 2 Resources . - @
removed from Layer 1. Your

layer list should look like
Figure 1-10.

down list (at the upper-right
corner of the Stage area) and al O }
choose 100%.

(5]

. Click outside the Stage to dese- Figure 1-10: In addition to the original Layer 1,

lect any objects. you now have three new layers.

. To save the file, choose

Filer>Save and choose the same location you used for the rainbow.
gif image file.

We don’t recommend saving the file in the Flash CS5 program folder
because it might get lost among your Flash program files.

. Give your movie a name, such as movie of the year, and click Save.

Flash creates a file named movie of the year.fla.Flash adds .fla
for you because that’s the filename extension for Flash movies.

You’re now ready for the animation process.
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Making graphics move

We explain earlier in this chapter that your goal is to have the word Rainbow
fly in from the right and the word Resources fly in from the left. You also want
the graphic to rotate 180 degrees at the same time. What you see now is how
the animation should end — the last frame of the movie.

Now go back and create the beginning of your movie. Flash can fill in all the
blanks in between. This type of animation is called a motion tween. Follow
these steps to create the animation:

1. Right-click (Windows) or Control-click (Mac) the word Rainbow and
choose Create Motion Tween.

Oops! The other two symbols disappear! That’s okay. Flash created
the motion tween and automatically set the length of the animation to
24 frames, or one second (using the default setting of 24 frames to a
second). The playhead is now on Frame 24, but the other two symbols
don’t exist at the 24th frame yet. Note that the Rainbow row in the
Timeline turns blue to indicate that it has a motion tween.

2. Click Frame 1 on the Timeline.

You can click Frame 1 on any layer. Whew! The other two symbols
reappear.

3. Repeat Steps 1 and 2 for the word Resources and for the lines.

Your Timeline should now look like Figure 1-11. Be sure to click Frame 1
to place the playhead on that frame.

e | momoNEsOR |
s@apQO!l s 1w 15 20 Dzs
ql Laver 1 + o+« O l:,|
s 7 N,
H Resources o o+ Wi
B Rainbow e o Wiy
al a3 t mH ]2 2400fps 10

Figure 1-11: The Timeline indicates three motion tweens, each
lasting 24 frames.

4. To move the Rainbow symbol to its proper location for Frame 1, click
the Rainbow symbol, then press and hold down the Shift key while
you drag the word Rainbow to the right, just off the Stage into the
gray area.
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10.

11.

12.
13.

14.

15.

You might need to use the horizontal scroll bar or choose a lower zoom
percentage in the Zoom Control drop-down list to see the gray area.
Pressing Shift keeps the object from moving up or down while you drag
to the right. By clicking the first frame and moving the word, you set its
position at the beginning of the animation.

. To move the Rainbow symbol to its proper location for Frame 24 (the

end of the motion tween animation), click Frame 24 in the Rainbow
layer. Then press the Shift key and drag the Rainbow symbol back to
its original position.

You now see a dot in Frame 24 on the Rainbow layer. On the Stage, you
see a magenta line indicating the movement of the Rainbow symbol. The
motion tween is now complete.

. Click Frame 1 on the Resources layer.

The playhead is now on Frame 1, and the Resources symbol has a blue
selection border.

. Press the Shift key and drag the Resources symbol to the left, just off

the Stage.

. Click in Frame 24 on the Resources layer, press Shift, and then drag

the Resources symbol back to its original location.

You now see a dot in Frame 24 on the Resources layer and a horizontal
line on the Stage showing the motion of the Resources symbol. The
motion tween is now complete.

. To return to Frame 1 and select the Lines symbol, click in Frame 1 of

the Lines layer.

Choose Modify~ Transform=>Rotate 90° CW to rotate the design 90
degrees clockwise.

Repeat the Modify~> Transform=>Rotate 90° CW command to rotate the
design a total of 180 degrees.

This sets up the desired position of the Lines symbol at Frame 1.
Click Frame 24 of the Lines layer.

Again, choose Modify~>Transformr>Rotate 90° CW twice to rotate the
Lines symbol a total of 180 degrees.

Because you only rotated the Lines symbol — you didn’t move it — you
don’t see a line on the Stage.

If necessary, drag the horizontal scroll box until the Stage is in the
center of your screen.

Otherwise, you won’t be able to see the entire animation — and you
don’t want to miss this one!

Click the first frame of any layer.

This takes you to the start of your movie. Your screen should look like
the one shown in Figure 1-12.
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é Scene 1 5' 6)‘ ooz | -
Ra nbow [
Resources
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Figure 1-12: Before you run the animation, Rainbow appears to the right and Resources to
the left, and the Lines symbol is rotated.

16. Press Enter (Return) and watch the animation. (Start writing your
Academy Award acceptance speech.)

17. Save your movie again by choosing Filer>Save.

Publishing your first animation for posterity

You can’t watch the animation in a Web browser until you publish your
movie and insert it into an HTML document. To do so, follow these steps:

1. Click an empty area of the Stage to change the display of the Property
inspector.

If the Property inspector isn’t open, choose Windowr>Properties. You
may need to click the Property inspector’s label to expand it or bring it
to the forefront. You should see the Edit button in the Publish section.

31



32

Part I: A Blast of Flash

2. In the Property inspector, click the Edit button next to the Profile:
Default label.

The Publish Settings dialog box opens. (We cover publish settings in
detail in Chapter 13.)

3. Click the HTML tab.
4. Deselect the Loop check box in the Playback section.
We want the animation to play only once.
5. Click the Publish button, and then click OK to close the dialog box.

With scarcely a blip, Flash publishes your movie and creates two files,
named Movie of the Year.swf (assuming you used that name) and
Movie of the Year.html. They're in the same folder as your .fla
movie file. Movie of the Year.swf is the file that your browser
reads to play the animation. Movie of the Year.html contains the
HTML code required to display your movie on a Web page.

6. Open your Web browser.

7. Choose Filec>Open (or Open File) and find Movie of the Year.
html (or whatever you named your movie file).

You might need to click Browse and navigate to the file.
8. Double-click the file.

Your browser opens the HTML document and reads its instructions to
play the Flash movie.

9. Sit back and watch it roll.

Don’t blink, or you’ll miss it. (If you do miss it, click the Refresh or
Reload Current Page button in your browser.) You can see the movie in
Figure 1-13.

10. When you finish watching the movie, close your browser.

You can find the Movie of the Year files (. f1a, .html, and . swf) on this
book’s Web site, www . dummies.com/go/flashcs5£d.

Exiting Flash

When you finish creating something in Flash, choose Filew>Exit (Windows)
or Flashe>Quit (Mac). If you see a message asking whether you want to save
changes to the movie, click Yes if that’s what you want to do.
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Figure 1-13: The Movie of the Year animation in detail.
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Your Basic Flash

In This Chapter

Examining the big picture
Setting movie properties
Getting and managing graphics
Using templates

Printing your movie

' his chapter starts with an overview of the process of creating animation
in Flash. We then discuss some tools and features that are fundamental
to using Flash efficiently.

As you find out in this chapter, you can set the screen size and color,
frame rate, and measurement units for the Flash movie as a
whole. We also discuss the Library and how it’s a store-
house for images, symbols, video, and sound. Templates
enable you to create great movies without much work.
Finally, near the end of this chapter, we explain how
you can print a Flash movie.

Looking at the Big Picture

When you use Flash to create animation, you gener-
ally go through several steps of construction. The
steps might vary in their order, depending on your
situation. After you know the basics, you can start get-
ting creative and make your Web site rock. Here’s a typi-
cal path to add animation to an existing Web page:

1. Think about it. Noodle around, maybe make some doodles on a
napkin, collect a few ideas, and choose one or all of them.
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10.

. Set up your movie. Flash lets you choose the size and color of the Stage,

the speed of animation (number of frames per second), and other gen-
eral parameters that affect the entire Flash movie. See the next section
of this chapter for details.

. Add some graphics. You have to decide whether you want to create

graphics in Flash, create them in another graphics software package, or
import existing graphics. Your choice partly depends on how artistic
you are, whether you have other software available to you, and whether
you can find the right graphics elsewhere. You can also use a combina-
tion of sources, which is a common practice.

. Lay out your graphics the way you want your animation to start.

Here’s where you might want to scale, rotate, or otherwise fiddle with
your graphics. (Chapter 4 has more on transforming your graphics.)

. Add some text. Using Flash is a great way to get terrific text onto your

Web site. Add text (also called type); then reshape it, make it semi-
transparent (if you don’t want to be too obvious), add other effects, and
move it where you want it. (Check out Chapter 5 for typography tips.)

. Organize your text and graphics by using layers. Layers help you keep

track of what each graphic and text object does while you organize
everything into a powerful, coherent statement. Layers keep your anima-
tions from going bump in the night and getting entangled. After you have
some objects, create as many layers as you need and transfer your exist-
ing graphics and text to those layers. Or create the layers first and then
add your graphics and text on those layers. (See Chapter 6 for further
details on layers.)

. Turn a graphic into a symbol and multiply it all over the Stage.

Converting objects into symbols is a way to keep them from merging
with other objects. You also use symbols to keep the file size down, to
enable animation, and for interactivity. (Turn to Chapter 7 for more info
on symbols.)

. Design some buttons. You know those buttons you click on Web sites all

the time? The coolest ones are made in Flash. You can even create ani-
mated buttons. (Chapter 8 has more on buttons.)

. Animate! You can create your animation frame by frame or let Flash

fill in the animation between your first and last frames, which is called
tweening. Flash can tween motion, shapes, colors, and transparency,
which means that you can create some real magic. (See Chapter 9 for
more on animation and the section in Chapter 1 where we step you
through your first animation.)

Get interactive. You want to start a relationship with your viewers, so
you can create buttons, frames, and symbols that respond to your view-
ers’ actions. This is probably the most complex functionality of Flash,
but we make most of it seem easy. (Turn to Chapter 10 for additional
info on interactivity.)



Chapter 2: Your Basic Flash

11. Make it louder! Make it move! Who wants a quiet Web site? Add sound
to your movies or your buttons. You can also add video. (Check out
Chapter 11 for more on sound and video.)

12. Publish your magnum opus. Flash makes getting your movie to your
Web site easy by creating both the Flash Player (. swf) file and the
HyperText Markup Language (HTML) code for your Web page. Flash
has other options, too, so you can publish to other formats if you want.
(Chapter 12 explains how to put all the elements together, and Chapter
13 shows you how to publish your animation for the Web.)

Congratulations! You've completed your first Flash Web animation — in fantasy,
at least. The following sections cover some details about how to get started.

Setting the Stage

Before you create graphics and ani-
mate them — all that fun stuff — you
need to make some decisions about
the structure of your entire movie.
You should make these decisions
before you start because changing
midway can create problems.

The first step is to decide on the size
and color of your Stage and other
fundamental settings. Make sure
that the Property inspector is open.
(Choose Windowr>Properties.) When
the Stage is active (just click the
Stage), the Property inspector looks
like Figure 2-1.

Choosing the Stage color

You can set the color of the Stage to
create a colored background for your
entire movie. As with other settings,
you need to consider the context of
the Web page that will contain the
Flash movie. For example, you might
want to match the color of your Web
page’s background. If your Flash movie
will constitute the entire Web page, set
the Stage color to the color you want
for the Web page background.

rrovenes. ||
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Figure 2-1: You can change movie properties in
the Property inspector.
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To set the Stage color, click the Stage swatch in the Property inspector. Flash
opens the Color palette. Click the color you want.

Specifying the frame rate

Next to the FPS (frames per second) label, click the current value, specify
how many frames you want the Flash movie to play each second, and then
press Enter (Windows) or Return (Mac). A faster rate allows for smoother
animation but might present a performance problem on slower computers.
Chapter 9 explains more about this setting. The Flash default is 24 fps, which
is a good starting point. Beware that changing the frame rate midstream in
the creation process changes the rate of all the animation in your movie,
which might not give you the results you want.

Setting the Stage size

The Size label displays the current size of the Stage. By default, Flash uses a
Stage size of 550 pixels (px) wide x 400 px high. To determine the proper set-
ting, you need to know how your Flash movie will fit into your Web page or
site. The default fits on almost every-

one’s browser screen. However, you  (Decument setings =

might want to fit your movie into a pimersions: [EEE ] ity x D
small corner of a Web page — for [¥4 Adjust 3D Perspective Angle to preserve current stage prajection
example, into an animated logo in S R | G
a top corner of a page. In that case, O Contents
make the Stage smaller. S
Background color: ||
To change the Stage size, click the e
Edit button in the Properties sec- —

tion to open the Document Settings
dialog box, as shown in Figure 2-2. ) ) )
Type the dimensions that you want Figure 2-2: The Document Settings dialog box
in the Width and Height text boxes. sets the movie's overall parameters.

Flash offers three shortcuts for setting the Stage size in the Document
Settings dialog box:

1~ Match Default: This option is the default and sets the size of the Stage to
550 px x 400 px.

1~ Match Contents: Select this option to set the Stage size to the contents
of the Stage. Of course, for this to work, you need some objects on the
Stage. Flash creates a Stage size by placing equal space around all sides
of the entire contents of the Stage. If you want to create the smallest
possible Stage, place your objects in the upper-left corner and then
select Match Contents.
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1~ Match Printer: Select this option to set the Stage size according to the
paper size set in the Page Setup dialog box. (Choose Filer>Page Setup.)
On a Mac, the Print Margins dialog box (access by choosing File=>Print
Margins) also affects the paper size. Flash sets the size of the Stage to
the maximum possible area of the paper minus the margins. Later in this
chapter, in the section “Printing Your Movie,” we cover this dialog box
in more detail.

To change the units used for measuring the screen and objects, choose a unit
from the Ruler Units drop-down list.

Click the Make Default button to make your settings the default for all your
new Flash movies. When you finish setting document properties, click OK to
close the dialog box.

Adding Metadata

Q\GN- S Ta&

You can add metadata to your movies. Metadata — information embedded in
the movie — provides a way to include useful tags for your collaborators.

Flash uses the Adobe eXtensible Metadata Platform (XMP), which enables
you to embed the metadata into the file. Programmers can write software
that accesses the data to help keep track of workflow, manage rights, and
more.

To add metadata, choose Filew>File Info. The dialog box that opens has the
name of your movie in its title bar. You can use the various tabs to insert tags
and descriptions relating to your movie file. For example, on the Description
tab, you can include title, author, and description content. You can even click
the stars to give your movie a rating from one to five stars. You can choose
whether you want to include your metadata when you publish your movie.
For more information, see the section on publishing to SWF in Chapter 13.

Grabbing a Graphic

The next step when creating animation for your Web site is usually to create
or import graphics. Before you do that, however, you should know a little
about the different kinds of graphics you can use in a Flash movie.

Understanding vectors and bitmaps

If you know enough about graphics to understand the difference between
bitmap and vector graphics, feel free to skip this section. (We hope you
always feel free.)
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Bitmaps are created with lots of dots. Put them all together, and you get a
picture. Onscreen, they're displayed as pixels. As you can imagine, it can take
a large file to store the information about all the dots in a bitmap. Another
problem with bitmaps is that they don’t scale up well. If you try to enlarge a
bitmap, it starts to look grainy because you see all those dots (as in the right
example shown in Figure 2-3).

Figure 2-3: Vector graphics remain sharp and clear (left); bitmaps lose
focus when enlarged (right).

Vector graphics are defined with equations that specify lines, shapes, and
locations. Blank space doesn’t have to be recorded, and the equations are
particularly efficient at storing information. As a result, file sizes are usually
smaller than bitmap file sizes.

Vector graphics are infinitely scalable, either up or down. No matter how big
you make your graphic, it always looks perfect, as shown in the left example
in Figure 2-3. In fact, your graphic might even look better when it’s larger
because the curves are smoother.

Flash creates vector-based graphics. The small size of the files means that
Flash Player files load and play super-fast on a Web page. As you undoubt-
edly know, fast file loading means that your Web page viewers don’t have
to wait a long time to see your effects. That’s the advantage of Flash.
Nevertheless, you can create great graphics with bitmaps that you can’t
duplicate with vector graphics; we explain how to import bitmaps in
Chapter 3.
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Finding graphics

Okay, so you noodled and doodled and played around with some ideas for
your Flash animation and perhaps jotted down a few notes or maybe even
made a few sketches. You're ready to start building your Flash animation.
Alogical place to start is to collect some of the graphics that will serve as
building blocks in this process.

Where do you get them? You have several choices:
1 Create your graphics from scratch (if you feel artistic) by using the Flash

drawing tools that we describe in detail in Chapter 3.

1~ Create graphics in another graphics software package, such as Adobe
Fireworks, Photoshop, or Illustrator.

1 Import graphics from archives of art available on this book’s Web site,
from other places on the Web, or from digital (or scanned) photographs —
perhaps your own.

1 Combine any or all of these approaches.

You can also import video files. If you want to add video to your Flash
movies, see Chapter 11 for detailed instructions.

Going to the Library

Every graphic that you create in Flash is precious and deserves to be
archived in style. Each movie file that you create has a Library. The Library
saves the following types of objects so that they never get lost:

v Graphic, movie clip, and button symbols

» Sounds

 Imported bitmap graphics (but not vector graphics that you create in
Flash)

v Imported video files

You'll find yourself going to the Library often. Figure 2-4 shows a Library con-
taining symbols, video, a sound, and a bitmap.

To go to the Library of the current movie file, choose Windowr>Library. You
can also press Ctrl+L (Windows) or &+L (Mac). When you open the Library,
Flash creates a new window or adds the Library panel to the set of panels
that are already open, usually next to the Property inspector.
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Figure 2-4: You can store graphics, animation, buttons, sounds, and video files in your current
movie file's Library.

To use any object in the Library, follow these steps:
1. Select the layer on which you want to put the object or create a new
layer for the object.

2. Click the point on the Timeline where you want the object to start or
‘x‘gN\BEB appear.
<

The point that you click on the Timeline must be a keyframe. Chapter 9
explains keyframes in detail.
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3. Click and drag the object from its listing in the Library to the Stage.

You can also drag an object’s image from the preview box.

You can drag items to the Pasteboard, the gray area around the edge of the
Stage, until you're ready to use them.

Using folders

A Flash movie can contain dozens or even hundreds of symbols, so you need
to keep them organized. Flash provides several features to keep you from
tearing out your hair.

If you have more than a few symbols, you should organize them into folders.
To create a new folder, follow these steps:

1. Click the New Folder button at the bottom of the Library panel.
Flash creates a new folder.

2. Type a name that describes the type of symbols that you want to put
into the folder.

For example, you could create a folder named Intro and another one
named Conclusion.

3. Press Enter (Windows) or Return (Mac).

To put symbols into a folder, drag them to the folder. You can also move
symbols from one folder to another — just drag them. Note that folders exist
just to help keep you organized. You can move symbols from one folder to
another without affecting your movie.

To keep your symbol list from getting unwieldy, you can collapse folders.

A collapsed folder doesn’t display its contents. As soon as you need to see
what’s inside, you can expand the folder. Double-click a folder to either col-
lapse or expand it.

To quickly see the structure of your folders, click the Library’s Options
menu. Choose Collapse All Folders. You can also choose Expand All Folders
to see everything in the Library.

More Library housekeeping

By default, Flash alphabetizes items in the Library by name. However, you
might have different ideas. You can sort from A-Z (ascending) or from Z-A
(descending). You can also sort by any of the columns in the Library. To
change the direction of sorting (for any column in the Library), click the
heading of the column that you want to sort by. You can click the column
heading again to reverse the sort order.
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You can reorder the columns in the Library. Just drag a column’s name left or
right to the desired location. You can resize any column by dragging the
column heading’s divider to the left or right.

If the Library panel is docked, you can resize it by dragging its left border. If the
Library panel isn’t docked, you can drag the right border to resize the panel.

To rename any Library item, double-click the item’s name, type the new
name, and press Enter or Return. Don’t worry — the original filenames of
imported files remain unchanged at their original locations.

To duplicate an item, select the item. Then right-click (Windows) or Control-
click (Mac) and choose Duplicate. To delete an item, select the item and click
the Trash can (Delete) icon.

If you want to find out which items in the Library you aren’t using, look in the
third column (Use Count) for items with a zero-use count. After you know
which items you aren’t using, you can delete them.

You can update imported bitmaps and sounds if the original files have
changed. Select the file and choose Update in the Options menu of the
Library panel.

Using the Libraries of other movies

After you place objects in a file’s Library, you can use those objects in any
other Flash movie that you create. Just open the movie and display its
Library panel, and its Library’s contents are available for you to use in your
current movie.

Choose File>Import=>Open External Library to open the Library of another
Flash movie that isn’t open. A new Library panel opens for the other Flash
movie.

You can switch among the Libraries of open movies by using the drop-down
list at the top of the Library panel.

When you have libraries open from more than one Flash file, you can copy
symbols or anything else in a Library from one movie to another by simply
dragging them from one Library to another. Choose the Library that you want
to use, select an item, and drag it into the other Library. Easy!

To create a new symbol that goes directly into the Library (rather than

on the Stage), choose New Symbol from the Library Options menu in the
upper-right corner. (Refer to Figure 2-4.) The Create New Symbol dialog box
opens where you can name your symbol. Click OK, and you’re transported
to symbol-editing mode, where you can create your symbol as you normally
would. To return to your main movie, choose Edit=>Edit Document. For more
information on creating and editing symbols, see Chapter 7.
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Exploring the Flash stock Library

Flash comes with Libraries that contain an excellent assortment of

button symbols and sounds. They are worth looking through. Choose
Window=Common Libraries and choose Buttons or Sounds. (We cover using
sounds in Chapter 11.)

Using a Template

To help you create Flash movies more easily, Flash CS5 comes with templates
for common types of movies. Instructions are included on the templates.

To create a Flash movie from a template, choose Filer>New and click the
Templates tab. In the New from Template dialog box (see Figure 2-5), select a
category, select one of the templates, and then click OK.

New from Template =]

General | Templates

Preview:

Banners
120 x 600 Sk
Media Playback 'ﬁ = ysCraper

Presentations B 120590 Buttont

Sample Files 'm 125 = 125 Square Butkon

'ﬁ 160 x 600 Wide Skyscraper

P 150 % 150 Rectangle

Pl 234 2 60 Half Banner

Pl 240 = 400 vertical Rectangls

P 250 = 250 Square Pop-up

'm 300 x 250 Medium Fectangle

Pl 300 = 600 Half Page Description:

ﬁ 336 x 260 Large Rectangle Bannet with vertical stage size of .
T 465 x 60 Full Size 120% 240,

P 728 90 Leaderboard
P 5631 Microbar -

Figure 2-5: Use the New from Template dialog box to create a Flash
movie from a template.

For example, the advertising category offers movie sizes suitable for Web-
based ads. Here are a few of your options:
1~ 120 x 240 Vertical: This is a tower ad, 120 pixels wide x 240 pixels tall.
1 120 x 60 Button2: This is a small, vertical rectangular ad.
1~ 120 x 600 Skyscraper: This is another tower ad.
1 120 x 90 Button1: This is another vertical rectangular ad.
1 125 x 125 Square Button: This is a small square ad.

1~ 160 x 600 Wide Skyscraper: This is another tower ad but wider than the
previous ones.

b5
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When you open a new movie from Save as Template =
a template, you should save it as O qlalarts Preview;

a movie. This way, the template is

unchanged, and you are free to make
any Changes you want. Description: | flash-based -

webpage

Category:  webpage -

You can also save movies as tem-
plates. If you create a movie that you i
want to reuse in many variations,

choose Filer>Save as Template to
open the Save as Template dialog

box, as shown in Figure 2-6. (You Figure 2-6: The Save as Template dialog box
can ignore the warning that SWF saves your movies as templates.

history data will be cleared, and go
ahead and click the Save as Template
option.)

Type a name, choose a category, and enter a description for your template.
Then click Save. From now on, you can open your template like any of the
templates that come with Flash, just as we describe. Using templates can
save you lots of work!

To create your own category for templates, type a category name in the
Category list box instead of choosing one of the existing categories from
the list.

Printing Your Movie

Usually, you don’t print your movies — you publish them on the Web — but
you might want to collaborate on a movie with others who don’t have Flash.
(How unenlightened of them!) Or you might just want to analyze a movie on
paper, tack your animation frames on the wall, and rearrange their sequence.
In this type of situation, you can print frame by frame.

To print a movie, follow these steps:
1. To set page margins, choose Filem>Page Setup (Windows) or Filer>
Print Margins (Mac).

The Page Setup (Windows) or Print Margins (Mac) dialog box appears.
See Figure 2-7.

2. In the Margins section, set the margins.

You can probably keep the default margin settings.
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3. Select the Center check boxes  [Page Setwp
to center the printing hori-
zontally and vertically on the
page.

4. (Windows only) In the Paper
section, select the size of the
paper; define the paper source.

Margins {inches)

Left:  IhEd Right: 0.25

Top: 0,25 Botkom: 0,25

Center: [¥]Horizonkal V] vertical

Paper Crigntation

o
Usually, you can leave this sec- S © Landscape
tion as is because it’s based on
your printer’s default settings. ety

Frames: |First Frame Cnly  »|  Scaler 100 e
Layout: | Actual Size -

5. In the Layout section, click
the Frames drop-down list and
decide whether to print only

the first frame or all frames.

6. In the Layout section, click
the Layout drop-down list to Figure 2-7: Use the Page Setup dialog box to

choose from the following specify how to print your Flash movie.
options:

* Actual Size: Lets you choose a scale. This option prints one frame
to a page.

e Fit on One Page: Fits one frame on a page, scaling it to fit the paper.

e Storyboard-Boxes: Places several thumbnail sketches of your movie
on a page. You can specify how many frames that you want in a
row in the Frames Across text box. You might need to experiment
to get the right result. In the Frame Margin text box, enter the
space in pixels between the boxes. The Storyboard-Boxes option
places each frame in a box.

e Storyboard-Grid: Creates a grid of lines for your storyboard rather
than individual boxes around the frames. This option is just a
matter of aesthetics — don’t get too hung up over these choices.

e Storyboard-Blank: Leaves out the boxes or grid and just prints all
your frames in the storyboard. You have the same Frames Across
and Frame Margin settings as for the other storyboard options.

7. (Windows only) If you chose a Storyboard option, select the Label
Frames check box to give each frame a number.

8. (Mac only) When you finish setting your options, click OK; then
choose File->Page Setup.

In Windows, you skip this step because you already opened the Page
Setup dialog box in Step 1.
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9. In the Orientation section, select Portrait (taller rather than wider) or
Landscape (wider rather than taller).

10. (Mac only) In the Format section, choose your printer in the drop-
down list.

11. (Mac only) In the Paper Size section, select the size of the paper.
12. When you finish setting your options, click OK.
13. To print, choose File>Print.

Alternatively, you can press Ctrl+P (Windows) or 8+P (Mac). In
Windows, you choose the printer in the Name drop-down list in the Print
dialog box.

Figure 2-8 shows an example of the storyboard with the box option. The sto-
ryboard shows four frames across with a portrait orientation and includes
frame labels. You can find out more about the Flash Player’s special printing
capabilities in Chapter 13.

Scana 1 - 0¥ Srenel- 18

Figure 2-8: You can print a storyboard of your movie that displays a
thumbnail sketch of each frame.
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1,000 Pictures and
1,000 Words

The 5th Wave By Rich Tennant

“I’'m not sure— I like the mutual funds
with rotating dollar signs, although the

dancing stocks and bonds look good too.”




raphics are the basis of animation. Before

you can make anything move, you need to
create the graphics that form the building blocks
of your animation. Chapter 3 describes all the
types of graphics that you can use, from basic
shapes created in Flash to sophisticated imported
bitmap graphics. The Flash tools are quite capa-
ble, and you can create exciting effects with gradi-
ent fills, softened edges, the spray brush, the Deco
tool, and transparency. The Flash editing features,
as we describe in Chapter 4, offer more opportuni-
ties to create great-looking graphics — including
skewing objects, using the Distort and Envelope
options, and manipulating fills every which way.

In Chapter 5, you find ways to say great things
with flexible text options and formatting. You can
even break up text and animate it, letter by letter.
To keep all the pieces of your animation from
going completely out of control, in Chapter 6 you
see how to use layers to organize your movie
animation. You can use special layers to guide
drawing tasks and hide objects behind a mask.
(Peekaboo!)

Wnr do you improve your skiils?

 Da you

Improve?

try to improve?

» same negative
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Getting Graphic

In This Chapter
Using the Pencil tool

Drawing lines, rectangles, ovals, and more

Working with shapes

Making curves with the Pen tool

Getting creative with the Brush and Spray Brush tools
Finding more drawing tools

Filling shapes with the Paint Bucket tool

Making strokes with the Ink Bottle tool

Creating beautiful colors and fills

Using the precision tools

Importing graphics

n this chapter, you get down to the details of creating your own
graphics in Flash. The Flash graphics tools (found on the

Tools panel) offer you the capability to easily create inter-

esting and professional-looking shapes. You can also

import graphics created in other programs.

After you master all the techniques for drawing and
editing, you can create some very cool graphics.

If you're new to Flash, take the time to try out all
the tools and techniques until you feel comfortable
with them.

Sharpening Your Pencil

The Flash Pencil tool is designed to be used like a real

pencil to create freehand shapes. Whenever you want to create

a shape not available from other Flash tools (such as the Oval and
the Rectangle tools), you can use the Pencil. But the Pencil tool goes beyond
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aregular pencil’s capabilities by incorporating cool features that smooth or
straighten what you draw. In addition to those features, the Pencil also includes
the shape-recognition feature (perfect for those who are less artistic). Draw
something that approximates a triangle, and Flash forgivingly perfects it for
you. In this section, we explain exactly how to use this tool.

To start, click the Pencil tool on the Tools panel. To draw without changing

@ the Pencil modifier, move the cursor onto the Stage, click, and draw. After
you release the mouse button, Flash modifies the shape according to the
active modifier setting, as we explain in the next section.

Setting the Pencil modifier

When you choose the Pencil tool, the Options area at the bottom of the Tools
panel changes to display the drawing mode modifier for the Pencil tool.
Choose the mode you want from the Pencil Mode drop-down list. The Pencil
modifier has three drawing modes:

._I 1~ Straighten: Straightens lines and converts sloppy squares, rectangles,
circles, ellipses, and triangles to perfect ones.

S 1 Smooth: Smoothes out curved lines, eliminating unsightly bumps and
lumps. You can specify the amount of smoothing.

e%_ v~ Ink: Slightly smoothes and straightens your curves and lines but leaves
them mostly the way you drew them.

In Figure 3-1, on the left, you see a sloppy jagged line, perhaps a bolt of

lightning. See how the lightning looks after Flash modified it by using the
Straighten drawing mode to create perfectly straight lines?

Before After

Figure 3-1: Use the Straighten mode to draw straight lines.
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How to set smoothing and
shape-recognition preferences

You can tell Flash just how much you want it to
smooth or straighten curved lines when you draw
with the Pencil tool. Choose Edit=>Preferences
(Windows) or Flash=>Preferences (Mac) and
click the Drawing category. In the Smooth
Curves drop-down list, select one of the follow-
ing options:

1+~ Off: Flash doesn’t smooth or straighten at all.
+~ Rough: Flash smoothes or straightens only

slightly, honoring your own work as much
as possible.

+* Normal: Flash smoothes or straightens
a medium amount. Normal is the default
setting.

+~ Smooth: Flash smoothes and straightens
more so that you get fewer bumps and jolts.

In the same way, you can tell Flash how picky
you want it to be in recognizing lines, circles,
ovals, squares, rectangles, and arcs (90
degrees and 180 degrees). For lines, select Off,
Strict, Normal, or Tolerant from the Recognize
Lines drop-down list. Normal is the default. Use
Tolerant if you're a klutz; use Strict (or even Off)
if you don’t want Flash fiddling too much (or at
all) with your work. For other shapes and arcs,
select an option from the Recognize Shapes
drop-down list. You have the same Off, Strict,
Normal, and Tolerant options.

Suppose that you want to animate some waves on your Web site. You start
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to draw the outline of the waves. Figure 3-2 shows how the waves look before
and after Flash smoothes them out by using Smooth mode. For more complex
shapes, Ink mode helps you look good without taking away too much of your
own authorship.

QN YU\

Before After

Figure 3-2: Smooth mode makes you look like a real smoothie when it comes to drawing curves.
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Setting the stroke type

While drawing with the Pencil tool (and any of the other drawing tools), you
can also control the type of stroke (line style), its width (also called height
or weight), its cap (ending), and how it joins with other strokes. To modify

stroke settings, follow these steps:

1. Click the Pencil tool to make it active.

2. Open the Property inspector if it’s not open by choosing Window=>

Properties.

The Property inspector appears,
as shown in Figure 3-3. As we
explain in Chapter 1, the
Property inspector changes
depending on which tool is
active and which part of the
Flash window you’re using.

3. To change the line width, type
a new value in the Stroke text
box and press Enter/Return, or
drag the slider bar.

The first available stroke width
on the Style drop-down list is
Hairline, which creates a hair-
line-width line. Flash measures
weights (widths) of other line
types in points. You can create
a line up to 200 points wide.
(One point equals /% of an inch.)

4. Click the Style drop-down list
to display the available line

PROPERTIES

& Pendil Tool

== FILL AND STROKE

» il &
Stroke; [——o——
Shyle: |Solid lv] &
Scale: [ Hinting

Cap: =|

Jain: | w Miter: 3,00

= SMOOTHING

Smoathing: 50

Figure 3-3: Control line type and width.

styles and select a new line style.

You can choose from seven line styles, including dashed and dotted.

5. From the Scale drop-down list, select an option to control how lines scale.

The Scale options specify how the thickness of strokes scale if you
include them in a symbol and then scale the symbol. (We discuss sym-

bols in Chapter 7.)

e Normal: Thickness scales both horizontally and vertically.

® Horizontal: Thickness scales horizontally only. This applies to ver-
tical lines, so that they become thicker as you scale them.

e Vertical: Thickness scales vertically only. This applies to horizontal
lines so that they become thicker as you scale them.

e None: Lines don’t become thicker as you scale them.



Chapter 3: Getting Graphic 55

6. (Optional) Select the Hinting check box.

Stroke hinting makes slight adjustments to avoid blurry horizontal or
vertical lines. If your lines don’t look as clear as you’d like, try selecting
this option.

7. To control the endings of lines, click the Cap drop-down list and select
one of the styles:

¢ None: The end is square with no added

ending ]
e Round: A rounded cap is added to the

end of the line. The length of the cap is _

half the line’s width.

e Square: A squared cap is added to the _

end of the line. The length of the cap is

half the line’s width. See Figure 3-4.

Figure 3-4: These lines were all
drawn 88 pixels long, but the
bottom two lines have caps, so
they're longer.

8. Click the Join drop-down list and select
one of the styles (see Figure 3-5) to control
how lines look when they meet:

e Miter: A pointed corner
® Round: A rounded corner

e Bevel: A squared-off (beveled) corner

Miter Round Bevel

Figure 3-5: You can choose how lines meet. How romantic!

9. (Optional) In the Miter box, you can drag to change the value or click
and enter a value to help prevent beveling a miter join.

When you draw two lines that meet at a sharp angle with a miter join (a
sharp point), you might get a bevel instead. If you chose a miter join,
you can increase the value in the Miter text box to get a nice sharp point
where the two lines meet.
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You can create custom line styles, as well. In the Property inspector, click the
_,py Edit Stroke Style button to the right of the Style drop-down list. In the Stroke
Style dialog box that opens, you can create your own designer line styles.

Setting the color

_# When using the Pencil tool, you can set the color of the stroke in the Property
| inspector or in the Colors section of the Tools panel. In either location, click
the Stroke Color box to open the color palette and then select a color.

We explain more about using colors in the section “A Rainbow of Colors,”
later in this chapter.

Creating Shapely Shapes

In the preceding section, we explain that you can draw shapes by using the
Pencil tool. You can also draw lines, rectangles, squares, ovals, and circles

by using the shape tools. Use these tools when you want more control over
your shapes — for example, when you want to draw perfect circles, perfect
squares, and straight lines.

Line up

[_ To draw a line, choose the Line tool in the Tools panel. Click the Stage at the

E desired starting point of the line and drag to the ending point. Then release
the mouse button. To keep your lines at multiples of 45 degrees, press Shift
while dragging. Flash creates the line at the 45-degree angle closest to your
drag line.

When you use the Line tool, you can modify the line weight, style, and color
in the same way as for the Pencil tool, as we discuss in the preceding section.

Be square

To draw a rectangle, choose the Rectangle tool in the Tools panel. Click the
Stage at one corner of the rectangle and drag to the opposite corner. Then
release the mouse button. To create a square, press Shift as you drag.

()

“&N\BER The Rectangle tool is on a flyout toolbar on the Tools panel. The flyout dis-

plays the last tool you used, so you may not see the Rectangle tool. Instead,
you may see the Oval tool, the PolyStar tool, the Rectangle Primitive tool, or
the Oval Primitive tool. Click (with a long click) any one of these to display
the flyout, where you can find the Rectangle tool.

R
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When you click the Rectangle tool, you can modify the line weight, style, and
color of the rectangle in the same way that you can modify a line when you
use the Pencil tool. You can’t see the effect of caps when you create a rect-
angle because it’s a closed shape; however, if you later cut out part of the
rectangle, the remaining lines take on the cap you specified.

Unlike lines, rectangles contain fwo objects: the fill (the area inside the
stroke) and the stroke (the outline of the rectangle).

Flash provides the following tools for adjusting the settings for rectangles:

v~ Fill Color: Determines the color that fills the inside of the rectangle. You
can click the Fill Color box — either in the Property inspector or in the
Colors section of the Tools panel — and select one of the colors in the
palette that opens. You can also select from the gradients displayed at
the bottom of the palette. (See the section “A Rainbow of Colors,” later
in this chapter, for details about customizing colors and gradients.)

1~ Stroke Color: Determines the color of the stroke (the outline) of the
rectangle. Click the Stroke Color box — either in the Property inspector
or in the Colors section of the Tools panel — and select a color from the
palette.

+~ Black and White: Sets the stroke color to black and the fill color to
white. Click the Black and White button in the Colors section of the
Tools panel.

+* No Color: Sets either the stroke color or the fill color (whichever tool is
pressed) to no color. You have to click either the Stroke Color box or
the Fill Color box to find the No Color box in the upper-right corner of
the palette of colors.

1~ Swap Colors: Switches the stroke and fill colors.

1~ Rectangle Corner Radius: Creates a rectangle with rounded corners.
(It’s located in the Rectangle Options section of the Property inspector.)
By default, the Lock Corner Radius icon allows you to set one radius for
all four corners. However, you can click the icon to unlock the setting,
enabling you to separately enter a different value for each of the rectan-
gle’s corners in the Rectangle Corner Radius text box. The rectangle that
you draw has nicely rounded corners, as you specified. Use a value of 0
(zero) for a sharp corner. You can create cute cutout corners by using a
negative number for the radius, as shown in Figure 3-6.

You can specify the dimensions of the rectangle in advance. Select the
Rectangle tool, press Alt (Windows) or Option (Mac), and then click the
Stage. The Rectangle Settings dialog box opens, with Width and Height text
boxes that you can use to get exactly the size rectangle you want. You can
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also set a corner radius here. When
you click OK, the rectangle appears
immediately. You can then move it to
the location you want.

The Rectangle Primitive tool also
creates rectangles. For more infor-
mation, see “Getting primitive” later
in this chapter.

O

Be an egq O

To draw an oval, choose the Oval tool °
in the Tools panel. Click the Stage at
one corner of the oval and drag to
the opposite corner. (Ovals don’t
really have corners, but you'll get the
idea after you try one or two.) Then release the mouse button. To create a per-
fect circle, press and hold Shift while you drag.

Figure 3-6: Where did my corner go?

The Oval tool is on a flyout toolbar on the Tools panel. The flyout displays
the last tool you used, so you may not see the Oval tool. Instead, you may see
the Rectangle tool, the PolyStar tool, the Rectangle Primitive tool, or the Oval
Primitive tool. Click (with a long click) any one of these to display the flyout,
where you can find the Oval tool.

After you click the Oval tool, you can change the line color, type, and weight
in the same way as we describe for the Pencil tool, in the “Setting the stroke

type” section earlier in this chapter. You can set the colors as we describe in
the preceding section on drawing rectangles.

You can specify the exact width and height of the oval. Select the Oval tool,
press Alt (Windows) or Option (Mac), and then click the Stage. The Oval
Settings dialog box opens. Use the Width and Height text boxes to specify the
size you want, and then click OK to create the oval.

Go for the stars

The PolyStar tool is on the same flyout as the Rectangle and Oval tools. This
tool creates stars and polygons. Follow these steps:
1. Display the Property inspector.

Choose Windowr>Properties to display the inspector if it’s not already
open.
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@ 2. In the Tools panel’s Rectangle tool flyout, choose the PolyStar tool.

3. In the Property inspector, click the Options button to open the Tool
Settings dialog box.

4. In the Style drop-down list, choose Polygon or Star.
5. In the Number of Sides text box, enter a number.
The maximum number is 32, which is probably plenty.

6. In the Star Point Size text box, enter a value between 0 and 1 to indi-
cate the depth of the points.

A'lower value, such as 0.1, creates deeper points, making your star spiky
looking. A higher value, such as 0.8, creates shorter points. See Figure
3-7. This setting is irrelevant for polygons.

7. Drag on the screen to create the star or polygon.

Star Point Size = 0.1 Star Point Size =0.8

Figure 3-7: You can create a wide variety of stars.

Mixing and Matching Shapes

After you create shapes on the Stage, you need to understand what happens
when two objects touch. It’s a little weird, but you soon see how flexible the
Flash drawing tools are. Two basic rules exist about objects that touch.
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move one of the objects. Suppose that

you want to draw a broken heart. You

can draw the breaking line by using

the Pencil tool. You now have sev- Figure 3-8: Intersect any shape with a line,
eral objects, and you can easily move  and the line splits the shape and is itself
apart the two halves of the heart. In segmented.

the right-hand heart (see Figure 3-8),

we erased the line and separated the

halves of the heart.

Cutting up shapes

The first rule is that when you use the
Pencil or Line tool to draw a line that
intersects any other shape or line, the
line acts like a knife to cut the other
shape or line. The line you draw is
also cut into segments. You don'’t see
the effect until you try to select or

Placing objects on top of each other

The second rule about objects that touch is that when you place one shape

on top of another, the top shape replaces whatever is beneath it. Again, you
can see the results only when you try to select or move the shapes. But now
it gets a little complicated:

v~ If the two shapes are the same
color, they merge into one com-
bined shape.

v~ If the two shapes are different
colors, they remain separate.

Figure 3-9 shows a circle and a tri-
angle on the left. They are the same
color. On the right, you can see the
result after moving the circle down
over the triangle. Presto! It’s a scoop
of chocolate ice cream on a sugar
cone. If you try to select the shape,
it’s now one object.

Figure 3-9: Build complex shapes by combining

When you combine shapes of different basic shapes of the same color.

colors, you create cutouts. Rather
than adding the shapes together, the
top shape just replaces the area beneath it. Figure 3-10 shows how you can
create a cutout. We display the grid on the Stage (find more about that in
Chapter 4) so that you can see that the image on the right is a cutout.
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Figure 3-10: A cutout. There's a hole in the bucket!

To create a cutout effect, follow these steps:

1. Create two separate shapes of different colors.

2. Move one shape on top of another shape.

3. Deselect the shape that you moved by clicking anywhere off the shape.

4. Select the top shape again, and either drag it away from the bottom
shape to create the cutout or delete it.

See Chapter 4 for details on selecting and moving objects.

Keeping Objects Safe and Secure

What do you do if you want to put objects next to or on top of each other while
maintaining their integrity? Two methods of drawing keep your objects safe
from cutups, replacements, and cutouts. We discuss these in this section.

Using the object-drawing model

You can use the object-drawing model to keep your objects whole, no matter
what else they touch. When you draw using this model, objects maintain
their integrity — no dishonest objects here! Other objects on top of or
beneath these objects do not cut up, cut out, or merge with them.

To draw any object with the object-drawing model, follow these steps:

1. Choose any drawing tool in the Tools panel.

2. Click the Object Drawing modifier in the Options section so that the
button darkens.

You click the modifier again to turn off the Object Drawing modifier.

You can also press the J key to toggle the object-drawing model.
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3. Draw your object.

Your object now has a blue rectangular bounding box around it. This
bounding box is similar to the one you see when you turn objects into a
symbol (as we explain in Chapter 7) or group objects. (See Chapter 4 for
more information.)

If you change your mind and don’t want your object to stay separate from
touching objects, select the object and choose Modify=>Break Apart.

You can convert existing objects to object-drawing model shapes. Just select
the shape, and choose Modify=>Combine Objects=>Union.

Getting primitive

A special type of shape, a primitive, does not merge with other objects. These
objects act like objects that you draw using the object-drawing model. Two
primitives are available: a rectangle and an oval. These primitives allow you
to specify certain properties — parameters — that define their shape.

Creating a rectangle primitive

When you draw a rectangle primitive,
you can create a rounded rectangle
by specifying a radius for the corners.
Use the Rectangle Corner Radius

text box or slider bar in the Property
inspector to specify a value. But you
can do the same with the regular
Rectangle tool, as we describe earlier
in this chapter, so what’s the point?
The difference is how you can edit the Figure 3-11: Change the radius of a rectangle
radius of the corners, after you create primitive’s corners by dragging the corner
the rectangle. When you select a rect- markers.

angle primitive, you see markers at

the corners. You can drag these markers to change the corner radii, as shown
in Figure 3-11, or you can use the Rectangle Options section of the Property
inspector.

The other difference between a normal rectangle and a rectangle primitive
is that the primitive acts like objects that you draw using the object-drawing
model. You can’t merge it or cut it out. Similarly, when you select it, you see
a bounding box around the entire shape.

To draw a rectangle primitive, select the Rectangle Primitive tool in the
Tools panel. Display the Property inspector (choose Windowr>Properties)
and specify one or more corner radii in the Rectangle Options section, as
explained in the discussion of the Rectangle tool earlier in this chapter.
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Then click the Stage at one corner of the rectangle and drag to the opposite
corner. The rectangle is selected, so you can immediately drag the corners
to adjust them if you want. Whether you’'re changing the radius in the
Property inspector or dragging the rectangle itself, click the Lock Corner
Radius icon (to unlock the corners) in the Property inspector if you want to
change just one corner.

WBER The Rectangle Primitive tool is on a flyout toolbar on the Tools panel. The
flyout displays the last tool you used, so you may not see the Rectangle
Primitive tool. Instead, you may see the Rectangle tool, the Oval tool, the
PolyStar tool, or the Oval Primitive tool. Click (with a long click) any one of
these to display the flyout, where you can find the Rectangle Primitive tool.

Creating an oval primitive

To draw an Oval primitive, select the Oval Primitive tool in the Tools panel.
Display the Property inspector (choose Window=>Properties) and specify the
Start Angle, End Angle, Inner Radius, and whether the path should be closed,
as explained next. Then click the Stage at one corner of the oval and drag to
the opposite corner.

GMBER The Oval Primitive tool is on a flyout toolbar on the Tools panel. The flyout
displays the last tool you used, so you may not see the Oval Primitive tool.
Instead, you may see the Rectangle tool, the PolyStar tool, the Oval tool, or
the Rectangle Primitive tool. Click (with a long click) any one of these to dis-
play the flyout, where you can find the Oval Primitive tool.

When you draw an oval primitive, you can specify the following parameters
in the Property inspector:

1~ Start and End Angle: By separately specifying a start angle and an end
angle, you can create part of an oval (or circle), as shown in Figure 3-12.
When specifying angles, note that 0 degrees is to the right and that
degrees increase in a clockwise direction. In the Property inspector, enter
values in the Start Angle and End Angle text boxes, or drag the sliders.

+~ Inner Radius: By specifying a value from 0 to 99, you can indicate the
percentage of the oval’s fill that you want to remove, thereby creating a
donut (yum)! See Figure 3-12 for an example. Enter a value in the Inner
Radius text box, or drag the slider.

~ Close Path: Select this check box to include a fill as well as an outline
around the entire shape. (The Close Path check box is selected by
default.) Deselect the Close Path check box to omit the fill and draw an
outline only. If you used the Start Angle and End Angle controls to create
part of an oval or a circle, you get an unfilled shape when you deselect
the Close Path check box, as shown in Figure 3-12.
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Figure 3-12: | had a donut. A little creature came and ate a
bite. Then it went on to eat the rest, leaving only the outline!

When you deselect the Close Path check box to create an open oval, you
draw only the outline. What happens if you defined the oval without an out-
line? The entire object disappears! To get it back, choose Edit=>Undo and add
an outline. For detailed instructions, see the discussion of the Rectangle tool
earlier in this chapter.

Figure 3-12 shows oval primitives with the following parameters from left to
right: an inner radius; no inner radius, but start and end angles; a closed path
with an inner radius and start and end angles; and finally, an open path with
an inner radius and start and end angles. You can see that opening the path
removes the fill.

When you select a closed Oval Primitive, you see two markers, one at the
inner radius (or center, if the inner radius is 0) and one at the outer radius.
You can drag the inner radius to change it. Drag the outer radius marker to
change the start and end angles.

Creating Curves with the Pen

The Pen tool lets you draw Bezier curves, also called splines. Bezier curves
are named after the French mathematician Pierre Bézier, who first described
them. By using the Pen tool, you can create smooth curves that flow into
each other. You can also create straight lines.

You can set preferences for the Pen tool by choosing Edit=>Preferences
(Windows) or Flashm>Preferences (Mac) and clicking the Drawing category.
We suggest enabling the Show Pen Preview option to display a preview of the
line or curve while you draw. This setting helps you get a better idea of what
the result will be. Click OK when you finish setting your preferences.

To create a line or curve, choose the Pen tool in the Tools panel. What you
do next depends on whether you want to draw a straight line or a curve. The
following sections show you how to draw both.
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Drawing straight lines

To draw a straight line with the Pen tool, follow these steps:

1. To create a line segment, click the start point and then click the end
point.

2. Continue to add line segments by clicking additional points.
3. Double-click to complete the process.

Flash previews segments in a color that depends on the layer you're
working on — see the color of the square next to the current layer as
shown on the Timeline. (Chapter 6 explains layers in full.) When you
choose another tool or press the Esc key, Flash displays Beziers in the
current stroke color.

Close a figure by pointing near the start point. You see a small circle at the
cursor. Click the start point, and Flash closes the figure.

Drawing curves

Drawing curves with the Pen tool involves a couple of steps, depending on
the complexity of the curve that you want to create. The main principle to
understand is that you define the curve by specifying the location of anchor
points. Each anchor point controls a bend in the curve. To draw a curve with
the Pen tool, follow these steps:

1. Click where you want to start and drag the mouse in the desired direc-
tion. About one-half of the way to the next anchor point (the end of
the curve), release the mouse button, as shown in Figure 3-13(a).

You see tangent lines that define both the direction and length of each
part of the curve, as shown in Figure 3-13(b).

(a) (b) (c)

Figure 3-13: Drawing a curve with the Pen tool: 1, 2, 3, and you
have a big nose!
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2. To create one curve, move the mouse cursor to the desired end of the
curve; then double-click to end the curve, as shown in Figure 3-13(c).

If you set preferences to show a preview of the curve (as we explain
earlier in the section “Creating Curves with the Pen”), you also see a
stretchy line attached to your mouse cursor that previews the shape.

3. To continue to draw curves, again click and drag in the desired
direction, release the mouse button, and move the mouse cursor to
wherever you want the end of the next curve to be. Double-click to
end the curve.

For both lines and curves, you can press and hold Shift to constrain the lines
or curves (the tangent lines) to 45-degree angles. Drawing curves with the
Pen tool takes practice, but you'll soon get the hang of it. Of course, you can
easily modify your curves, as we explain in Chapter 4.

Getting Artistic with the Brush

¥4
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The Brush tool lets you create artistic effects that look like painting. You can
adjust the size and shape of the brush, and if you have a pressure-sensitive
pen and tablet, you can adjust the width of the stroke by changing the pres-
sure on the pen.

To paint with the Brush tool, select it on the Tools panel and then click and
drag anywhere on the Stage. Press and hold Shift while you brush to keep
your strokes either horizontal or vertical. The brush doesn’t have a stroke
(line) color. The brush creates only fills. Use the Fill Color swatch in the
Property inspector or in the Colors section of the Tools panel to select a fill
color.

The Brush tool is on a flyout toolbar on the Tools panel. The flyout displays
the last tool you used, so you may
not see the Brush tool. Instead, you 0 &L LockFin
may see the Spray Brush tool. Click
(with a long click) any one of these Brush Mode e .,—— Brush Size

to display the flyout, where you can g sh Shape
find the Brush tool. e 1L @__ Use Pressure
Use Tilt -ty

Figure 3-14: The Brush modifiers control how
the brush functions.

When you choose the Brush tool,
the Brush modifiers appear in the
Options section of the Tools panel,
as shown in Figure 3-14.




Brush Mode modifier
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The Brush Mode modifier determines how the brush relates to existing
objects on the Stage. Here are your choices for Brush Mode. (Figure 3-15

shows some examples.)

&~ Paint Normal: You just paint away, oblivious to anything else. Use this
setting when you don’t need to worry about other objects.

Original corn

Corn with worms -
Paint Normal

Corn with
bad kernels -
Paint Fills

Corn with
background -
Paint Behind

Sheath with
gray gradient -
Paint Selection

Corn with
bad kernels -
Paint Inside

Figure 3-15: Set the Brush mode when using the Brush tool to get the effect you want.

@ v~ PaintFills: You paint fills and empty areas of the Stage. The paint
doesn’t cover lines. Note that your lines seem to be covered while you
paint, but they reappear when you release the mouse button.
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‘o N Kd Paint Behind: You paint behind and around existing objects, but only in
blank areas of the Stage. While you paint, the brush seems to cover
everything, but your existing objects reappear when you release the
mouse button. You can messily paint over your objects, knowing that
they won'’t be affected.

@ v~ Paint Selection: You paint only a filled-in area that you previously
selected. While you paint, your existing objects are covered, but they
reappear when you release the mouse button. You don’t need to worry
about painting within the lines because Flash fills only the selected area.

(3  ~ Paint Inside: You paint inside lines. Only the fill where you start brush-
ing is painted. Paint Inside also paints an empty area on the Stage if (and
only if) that’s where you start brushing. Again, at first, the paint seems
to cover up everything, but when you release the mouse button, Flash
keeps your paint nice and neat, inside the lines — like every little kid
discovers in kindergarten.

Brush Size drop-down list

Click the Brush Size drop-down list and select a size
in the list of circles. This list defines the width of the
brush. If you use a Brush mode that helps you draw
neatly, such as Paint Selection, you don’t need to

be too concerned with the size of the brush. On the
other hand, if you're creating an artistic effect by
using Paint Normal mode, the width of the brush is
important.

Brush Shape drop-down list

Flash offers several brush shapes you can choose
from. Click the Brush Shape drop-down list and
select one of the shapes. Each shape produces a

different effect, especially when you paint at an Figure 3-16: Each brush
angle — you just need to try them out to see what shape creates a different
works best. Figure 3-16 shows a honey jar drawn effect — especially at the
with various brush shapes. ends of the stroke.

Pressure and Tilt modifiers

If you have a pressure-sensitive pen and tablet, Flash also displays a Pressure
modifier so that you can vary the width of your strokes according to the
pressure you put on your pen while you draw. Click the Use Pressure tool
(refer to Figure 3-14) to turn on this feature.
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Flash fully supports pressure-
sensitive pens and adds the ability
to use the opposite end of the pen
to erase — just like a real pencil.
Figure 3-17 shows this type of pen
and tablet.

A pressure-sensitive pen works
together with a tablet to help you
draw in Flash. The tablet tracks the
movement and pressure of the pen
while you draw. You can also use the
pen as a mouse to choose menu and
dialog box items. In other words, if
you want, you can use the pen for

all of your Flash work. Alternatively,
you can use the pen and tablet just
for drawing and use the mouse when
you want to work with menus and
dialog boxes.

Photo courtesy of Douglas Little of Wacom
Figure 3-17: This Wacom pen and tablet set is
easier to draw with than a mouse and enables
you to easily vary the brush width as you draw.

The Tilt modifier varies the angle of your brush stroke when you vary the
angle of the stylus on the tablet. For example, holding the stylus straight up
and down produces a different shape of brush stroke than the one you get if
you hold the stylus at a 45-degree angle to the tablet.

Use the Tilt modifier for fine control over your brush strokes. Click the Use
Tilt tool in the Options section of the Tools panel to turn on this feature.
You see the effect most clearly with a large brush size and one of the narrow
brush shapes. When you start to draw, change the angle of the stylus to the
tablet. Watch the cursor shape turn, giving you a hint as to the shape of the
brush stroke. Try brushing at a few angles to see how this works.

See the “A Rainbow of Colors” section, later in this chapter, for an explana-
tion of the Lock Fill modifier, one of the brush tool’s modifiers.

Brush smoothing

Smoothing brush strokes is similar to smoothing pencil strokes. You can
finely adjust how much your brush strokes are smoothed after you finish
drawing them. You can set smoothing anywhere from 0 to 100.

To set brush smoothing, follow these steps:

1. Click the Brush tool.
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2. Open the Property inspector if it’s not open. (Choose Windowr>
Properties.)

3. In the Smoothing section, enter a new Smoothing value or drag
upward or downward to set a new value.

The lower values change your strokes less. Therefore, if you set
Smoothing to 0, the brush stroke is closest to what you actually drew.
Lower values create more vectors, resulting in a larger file size for your
movie. The higher values smooth and simplify your strokes more.

Creating Graffiti with the Spray Brush

You can create the effect of spray paint, or stippling (filling an area with
dots), by using the Spray Brush tool.

The Spray Brush tool allows you to quickly fill up an area with polka dots of
any color. You can substitute a graphic or movie clip symbol in the Library
for the dots. (We discuss symbols
in Chapter 7.) Figure 3-18 shows a

flower that uses the Spray Brush tool
in several places.
|
yg‘ To create a spray of dots using the ¥

default settings, click the Spray

Brush tool on the Tools panel and s
drag anywhere on the Stage to place -
the dots. You specify the color of the

dots by opening the Property inspec- ?{
tor (choose Windowr>Properties), |
and clicking the color swatch in the

Symbol section.

“&N\BEI; The Spray Brush tool is on a flyout
& toolbar on the Tools panel. The
flyout displays the last tool you
used, so you may not see the Spray
Brush tool. Instead, you may see the
Brush tool. Click (with a long click) either of these to display the flyout,
where you can find the Spray Brush tool.

Figure 3-18: The Spray Brush tool easily adds a
fine level of decoration.

Setting symbol properties
You can specify your own symbol to use in place of the dots. Because you

can’t control the spacing between the dots, simple symbols work best. To
use your own symbol, follow these steps:
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1. Create a symbol, or import one into the Library. (We explain all about
symbols in Chapter 7.)

2. Click the Spray Brush tool in the Tools panel.

3. Open the Property inspector (Window=>Properties) if it’s not already
open. In the Symbol section, click the Edit button.

The Select Symbol dialog box opens.
4. Choose the symbol you want to use and then click OK.

5. If desired, enter new values for Scale Width and Scale Height in the
Property inspector.

Scaling enables you to use large symbols in your spray. For example
you can scale the width and \
height to 15%. You can also
scale upward by using values
of more than 100%.

6. To create a variety of sizes,
select the Random Scaling
check box.

7. To rotate the symbol around
your cursor as you drag, select
the Rotate Symbol check box.

8. To randomly rotate the symbol,
select the Random Rotation
check box.

9. Drag on the Screen to place
the spray.

Figure 3-19 shows a raindrop
symbol using random scaling. Figure 3-19: It's raining, it's pouring.

The Spray Brush tool makes it easy to quickly add hundreds of dots or
instances of your symbol to your movie. This can make the movie balloon in
size quickly. Check your movie size before and after, and don’t go overboard!

Setting brush properties

You have control over the width, height, and angle of the brush, whether
you use the default dots or your own symbol. To set brush properties, follow
these steps.

/1
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1. Click the Spray Brush tool in the Tools panel.

2. Open the Property inspector (Windowr>Properties) if it is not already
open.

3. In the Symbol section, click the Edit button to choose a symbol in the
Library. (See Chapter 7 for more about symbols.)

4. Also in the Symbol section, you can select check boxes for random
scaling, rotating a symbol, or adding random rotation.

5. In the Brush section, enter a value for the Width.

The width is the horizontal dimension. If you drag vertically when you
place the spray, the resulting shape is the width that you specified.

6. Enter a value for the Height.

The height is the vertical dimension. If you drag horizontally when you
place the spray, the resulting shape is the height that you specified.

7. To specify an angle, enter a Brush Angle value.

8. Drag on the Stage to place the spray.

Working with Spray Brush dots

It could get very difficult to delete some of those dots if they were all individ-
ual objects! Luckily, when you create a spray, they’re grouped as one object.
(We discuss groups in Chapter 4.) With the Selection tool active, click inside
a group of dots, and you’ll see a blue border. You can press Del(ete) to delete
them, or you can drag them to move them. If you really do want individual
objects, select them and choose Modify=>Break Apart. For more information
on editing objects, see Chapter 4.

Pouring on the Paint

The Paint Bucket tool creates fills that fill shapes with color. You might want
to fill an enclosed area that you created with the Line or Pencil tool. You can
also fill enclosed shapes created with the Pen or Brush tool, which we dis-
cuss earlier in this chapter. The Paint Bucket tool is also handy for changing
existing fills. You can change the color as well as fiddle around with gradient
and bitmap fills. (See Chapter 4 for more on editing fills.)

To use the Paint Bucket, choose it in the Tools panel. Set the color by click-
ing the Fill Color tool and selecting a color. Alternatively, you can use the Fill
Color swatch in the Property inspector.
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The Paint Bucket tool is on a flyout toolbar on the Tools panel. The flyout
displays the last tool you used, so you may not see the Paint Bucket tool.
Instead, you may see the Ink Bottle tool. Click (with a long click) either of
these to display the flyout, where you can find the Paint Bucket tool.

Flash can fill areas that aren’t completely closed. The Gap Size modifier (in
the Options section of the Tools
panel) determines how large of a

gap Flash will overlook to fill in an
almost enclosed area. Choices range
from Don’t Close Gaps to Close Large
Gaps. Because small and large are
relative terms, you might have to
experiment to get the result you
want. After you choose an option
from the Gap Size modifier, click any
enclosed or almost enclosed area to
fill it, as shown in Figure 3-20.

After you use the Paint Bucket to fill

a shape created with another tool,

you can delete the outline of Figure 3-20: Fill areas that aren’t completely
the shape and keep just the fill. closed by using the Gap Size modifier.

Strokes, Ink

.

©,

<MBER
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You use the Ink Bottle tool to create an outline on an existing shape. You can
use the Ink Bottle tool also to change an existing line, or stroke.

To use the Ink Bottle tool, click it on the Tools panel. Click the Stroke Color
tool to select a color. Use the Property inspector, as we explain earlier in this
chapter (in the discussion of the Pencil tool) to select a line thickness and
line style. Then click anywhere on the shape. If the shape has no existing line,
Flash adds the line. If the shape has a line, Flash changes its color, width, or
style to the settings you specified in the Property inspector.

The Ink Bottle tool is on a flyout toolbar on the Tools panel. The flyout dis-
plays the last tool you used, so you may not see the Ink Bottle tool. Instead,
you may see the Paint Bucket tool. Click (with a long click) to display the
flyout, where you can find the Ink Bottle tool.

/3
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A Rainbow of Colors

Flash offers you lots of color options. By default, Flash uses a palette of
colors that are “Web safe” but these days, when almost all computers can
displays millions of colors, you can create your own colors. So, feel free to
experiment!

Solid citizens

When you choose either the Stroke Color or Fill Color tool, Flash opens the
current color palette, which is the active set of colors that Flash uses.

Creating new colors or editing existing colors
Flash provides two ways for you to specify your own colors:

1 Choose the Stroke Color or Fill Color tool in the Tools panel and click
the Colors Window button in the upper-right corner of the palette to
open the Color dialog box.

1 Choose Window=>Color to open the Color panel.

These two methods duplicate each other; here, we explain how to use the
0 Color panel, which is shown in Figure 3-21.
<\
If you select an object before you use the Color panel, when you change the
color in the panel, the object’s color changes immediately to the new color.

To create a new color or edit an existing color in the Color panel, follow these
steps:

1. Click the Stroke Color or Fill Color icon to specify which color you
‘g&u\BEn want to change — stroke or fill.
<
&

Click the icon to the left of the Stroke Color or Fill Color box — not the
box itself. (If you click the box, you open the color palette.)

2. Type the color specs in the text boxes, use the sliders (click the cur-
rent value) to drag to the desired color, or find a color in the color
space that’s close to the one that you want. Then click that color.

You can specify a color using any of three methods. RGB specifies a
color according to red, green, and blue components; HSB specifies a
color by hue, saturation, and brightness. You can also define a color by
using hexadecimal notation, which is the color system used on the Web.
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Figure 3-21: Use the Color panel to create your own colors.
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You can click any HSB or RGB specification and use the vertical slider to

vary its value from zero to its highest possible value.

3. Set the level of opacity/transparency (also called alpha) by using the

Alpha (A) slider/text box.

A setting of 0% is completely transparent, and 100% is opaque.

Chapter 3: Getting Graphic
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4. If you want to create a new color swatch, click the Options menu icon
and choose Add Swatch.

Flash saves the new color to the color palette so that you can access
it from the Stroke Color or Fill Color boxes on the Tools panel, the
Property inspector, and the Swatches panel. If you like it, save it!

Managing colors

If you've added or changed colors, you can save this new palette. (A palette

is a set of colors.) You can then save the palette for use in other Flash movies
or import a color palette from another Flash movie (so that you don’t have
to bother creating the colors again). Color palettes are saved as .c1r files
and are called Flash color set files. To save a color palette, choose Save
Colors from the Swatches option menu. (Choose Window=>Swatches to open
the Swatches panel and then click the Options menu icon in the upper-right
corner of the panel to display the menu.) In the Export Color Swatch dialog
box, choose a location for the file, name it, and click Save.

Adobe Fireworks and Photoshop use Color Table files (. act files), and Flash
can save and import these as well. To save your color palette as an . act file,
choose Color Table (*.act) from the Save as Type drop-down list in the
Export Color Swatch dialog box.

To import a color palette that you've saved, use the Options menu of the
Swatches panel. Choose Add Colors if you want to append this imported pal-
ette to an existing palette. Choose Replace Colors if you want the imported
palette to replace an existing palette. You can use the same Swatches panel
Options menu to manage your color palettes. Choose from the following
options:

~ Duplicate Swatch: Creates a duplicate of a swatch. Do this when you
want to create your own color and use an existing color as a basis.
1~ Delete Swatch: Deletes a color.

1~ Load Default Colors: Replaces the active color palette with the Flash
default palette.

1~ Save as Default: Saves the active color palette as the default palette for
any new Flash movies that you create.

1~ Clear Colors: Clears all colors except black and white — for when you
really want to start from scratch.

1 Web 216: Loads the legacy Web-safe, 216-color palette.
1~ Sort by Color: Sorts the display of colors by luminosity.
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Using color themes

If you would like some help gathering a palette of compatible colors

for a project, kuler colors can come to the rescue. Kuler is an Adobe-
supported online collection of color themes, available independently

at http://kuler.adobe.com. Kuler is also a community, so you can
upload your themes to share with others. From within Flash, choose
Window=>Extensionst>Kuler to open the kuler panel. Figure 3-22 shows the
Create tab. (You may have to register with an Adobe ID to access kuler.)

Use the Browse tab to find color themes that you like. From the Choose
Which Themes You Wish to Display drop-down list, you can display themes
by Highest Rated, Most Popular, Newest, Random, Saved (by you), and
Custom (saved custom searches).

When you find a theme that you like, choose it and click the Add Selected
Theme to Swatches button to add the colors to your Swatches panel. To edit
a theme so that it’s more to your liking, choose the theme and click the Edit
Theme in Create Tab button. You can also find these options by clicking the
arrow on the right side of any theme, after you choose the theme.

The Create tab is where you get creative, of course. Start by selecting one of
the harmony rules. A harmony rule is a principle that governs how the colors
in the theme relate to each other. For example, the Shades harmony rule
results in colors that are all lighter and darker versions of the same color. If
you want free rein, choose Custom.

You can double-click a theme on the Browse tab to open it on the Create tab.

To edit a color theme, choose a color swatch in the kuler panel to highlight
that color’s position in the color wheel. Then drag the position marker
around to change the color, or inward/outward to make it lighter or darker.
Alternatively, you can enter RGB values, use the RGB sliders, or enter a hexa-
decimal value in the Hexadecimal Code text box.

Click a color in the theme and click the Bull’s-Eye button to make that color
the base color. The base color is important when you choose a harmony rule
other than Custom because all of the other colors relate to the base color
according to the rule that you have chosen.

When you’re done creating a beautiful color theme, don’t forget to click

the Save Theme button to name and save your theme. You can then find
that theme by clicking the Browse tab and choosing Saved from the Choose
Which Themes You Wish to Display drop-down list.

/7
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Color in Theme, including base color
RGB specifications Brightness

Color wheel Select Rule

| about| | Bowss | Creme |

Slectfue: | Trad =

Set Fill Color Upload Theme| | Add a Color to the Theme

to Kuler )
Set Stroke Color Remove This Color from the Theme

Affect Colors According to Harmony Rule|  Hexadecimal code

Add This Theme to Swatches

Figure 3-22: The kuler panel is the place to go for mixing and matching colors.
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You can also quickly add the colors to the Swatches panel by clicking the
Add This Theme to Swatches button. Finally, be a good community member
and share with others — click the Share This Theme button to upload the
theme to the kuler Web site so that others can use it.

Gradient colors

So you’re bored with solid colors and
want something more interesting.
Gradients are combinations of two

or more colors that gradually blend
from one to another. Flash can create
gradients of as many as 16 colors —
quite a feat. The gradient can be
linear or radial (concentric), as shown
in Figure 3-23.

Flash offers a few standard gradients
that you can find at the bottom of
the color palette. But you often need
a more customized look, and Flash Figure 3-23: Linear and radial gradients make
has the tools to create just about your graphics more interesting than plain solid
any gradient you want. colors.

Linear gradient Radial gradient

Radial gradients look best on curved objects. A circle can suddenly look like
a sphere when you fill it with a radial gradient. If you put white at the center
of a radial gradient, it gives the impression of light highlights. Linear gradi-
ents look best on straight objects.

To create your own gradient, follow these steps:

1. Choose Windowr>Color to open the Color panel. (Refer to Figure 3-21.)
Then choose Linear Gradient or Radial Gradient from the Color Type
drop-down list.

You see a gradient bar at the bottom of the panel with color pointers
that specify the colors of the gradient and where the gradient changes
from one color to the next.

If you select a fill before you use the Color panel, the object’s fill color
changes immediately when you change the gradient in the Color panel.

2. To use an existing gradient as a starting point, click the Fill Color box
on the Tools panel and choose a gradient from the bottom of the color
palette.

You can also choose Windowr>Swatches to open the Swatches panel
and choose a gradient from the bottom of the color palette there.
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3. To specify the color for each color pointer, click and hold the pointer
and then release the mouse button. (This is like a long mouse click.)
When the color swatches appear, select a color.

You can click the Fill Color box and select an existing color from the
color palette or specify a new color by using the methods we describe in
the earlier section, “Creating new colors or editing existing colors.”

Note that when you click a pointer, its point turns black to indicate that
it’s the active pointer. The square beneath the point displays the color
pointer’s current color.

4. To change the number of colors in the gradient, add or delete color
pointers.

To add a color pointer, click where you want the pointer to appear,
just below the gradient bar. To delete a color pointer, drag it off the
gradient bar.

5. To adjust where the color changes, drag a color pointer to the left or
right.

6. To add control over how colors are applied to a selected shape
beyond the gradient, click a Flow button to define one of the follow-
ing overflow modes:

e Extend Color: Extends the last or outermost gradient color past the
end of the gradient

e Reflect Color: Fills the shape by mirroring the gradient pattern
* Repeat Color: Repeats the gradient from beginning to end

To use these effects, fill a shape with a gradient and then use the
Gradient Transform tool to reduce the size of the gradient so that it no
longer completely fills the shape. (We discuss the Gradient Transform
tool in Chapter 4.) Then try out the three overflow modes to see the
results.

Select the Linear RGB check box to create a gradient that complies with
Scalable Vector Graphics (SVG) standards. SVG is an XML language for
describing 2D graphics.

7. To save the gradient, click the Options menu icon in the upper-right
corner of the Color panel and choose Add Swatch.

The new gradient now appears in the color palette of the Fill Color box on the
Tools panel and in the Swatches panel. Go ahead and use the Paint Bucket
tool to fill something with it!

You can also move a gradient’s center and focal points, change its width and
height, rotate it, scale it, skew it, and tile it. See Chapter 4 for more on editing
gradients.
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Bitmap fills

You can create the coolest, weirdest fills by
importing a bitmap graphic and using the bitmap
to fill any shape. For a hypothetical Web site
protesting genetically engineered foods, for
example, we could find a bitmap of a bug (rep-
resenting the Bt bacteria genetically engineered
into corn) and use it to fill a graphic of corn.
Figure 3-24 shows the result.

To use a bitmap graphic to fill a shape, follow
these steps:

1. Create the object or shape that you want
to fill.

2. Select the fill.

3. If you haven’t already imported the
bitmap, choose File=>Import=>Import to ) ]
Library, choose the bitmap you want, and  Figure 3-24: You can fill any

then click Open/Import. shape with a bitmap, repeated
over and over and over.

We explain more about importing graphics
in the section “The Import Business — Using Outside Graphics,” at the
end of this chapter.

4. From the Color panel, choose Bitmap Fill from the Color Type drop-
down list and choose your bitmap from the swatches that appear at
the bottom of the panel.

Flash applies the bitmap to the selected fill. You may need to scale the
bitmap. See the section on transforming fills in Chapter 4
for details.

If the Fill swatch in the Property inspector or the Tools panel already shows
the bitmap fill you want, you can use the Paint Bucket tool to fill any enclosed
area with that fill. You can also choose the Brush tool and brush with the
bitmap. Use a brush size that’s thick enough to clearly show the bitmap.

Locking a fill

Flash has another trick up its sleeve for gradient or bitmap fills. A locked fill
looks as though the fill is behind your objects and the objects are just uncover-
ing the fill. As a result, if you use the same fill for several objects, Flash locks
the position of the fill across the entire drawing surface instead of fixing the fill
individually for each object. Figure 3-25 shows an example of a locked fill. In
this figure, you see some windows and portholes filled with a locked bitmap of
the sky. Doesn’t it look as though the sky is really outside the windows?
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Figure 3-25: When you lock a fill, the fill's pattern continues
across the Stage but appears only where you use it.

To lock a fill, choose the Brush tool or the Paint Bucket tool with a gradient
or bitmap fill, as we explain in the two preceding sections. Then click the
Lock Fill modifier in the Options section of the Tools panel. Start painting
where you want to place the center of the fill and continue to other areas.

(e

Pattern fills

If you like a decorative look, you can use the Deco tool to create a number of
ffects.
¢ATURE pattern e
é&
Flash CS5 adds 10 new effects for a total of 13 options.

@g

Each type of pattern offers you lots of flexibility, so you can really let your
creative juices flow!

QNING/ The Deco tool creates lots of objects! Sometimes, they’re grouped so that you
& can click any one to select them all and then delete or move them. (We dis-
cuss groups in Chapter 4.) Other times, you end up with many individual
objects, so be careful where you put them. They can quickly take over the
world — and make your Flash file size huge!

et To use the Deco tool, click the Deco tool on the Tools panel. Then choose the
‘.}"' pattern effect you want from the Drawing Effect section of the Property
inspector. (Choose Window=>Properties.) These effects are described in the
following sections.

Vine fill
The Vine fill creates a vine of flowers and leaves. To create a vine, choose
the Deco tool on the Tools panel and then choose Vine Fill from the Drawing
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Effect drop-down list in the Property inspector. Click once anywhere on the
Stage, or click inside a closed shape to fill that shape. Figure 3-26 shows the
vine with pink flowers and green leaves.

Figure 3-26: One click covered the entire wall. If only putting
up wallpaper were so easy!

In the Property inspector, you can vary the vine in the following ways:

1~ Leaf: Click the color swatch to choose another color or click the Edit
button to choose a graphic or movie clip symbol from the Library to
replace the leaf with another symbol. (We explain how to create sym-
bols in Chapter 7.)

1~ Flower: Click the color swatch to choose another color or click the Edit
button to choose a graphic or movie clip symbol from the Library to
replace the flower with another symbol.

1~ Branch Angle: Specify a new angle to change the angle of the branches.
This is like rotating the pattern.

+~ Branch Color: Click the color swatch to change the color of the
branches

~ Pattern Scale: Enter a value to scale the entire pattern. You can scale
both up (more than 100%) for a less busy look and down (less than 100%).

1~ Segment Length: Enter a value to set the length between the leaf and
flower nodes.
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» Animate Pattern: Select the Animate Pattern check box to automati-
cally animate the drawing of the vine so that each section goes to a new
keyframe in the Timeline. Instant animation! (We explain animation in
Chapter 9.)

+~ Frame Step: Enter a value to specify how many frames you want to
include for each second of the animation.

Grid filt
The Grid fill creates a simple, rectangular array. By default, it uses a black
square as the arrayed object. You can include as many as four tiles by check-
ing them in the Property inspector (Window=>Properties). In the same loca-
tion, you can vary the pattern:

1~ Color or Symbol: For each tile, click the Color swatch to change the
color or click the Edit button to choose a graphic or movie clip symbol
from the Library.

1~ Pattern: In the Advanced Options section, choose Tile Pattern (rows
and columns), Brick Pattern (alternate rows
shifted), or Floor Pattern (diagonal columns
and rows). You can also select the Paint over
Edge check box to spill outside a closed area
and the Random Order check box to mix up
the order of the tiles.

~ Horizontal Spacing: Enter a value to set the
horizontal spacing.

1~ Vertical Spacing: Enter a value to set the A 0060H b
vertical spacing. O 6 6008 D
~ Pattern Scale: Enter a percent to scale the W EEEN

object that you're arraying and, therefore,
the entire pattern.

Figure 3-27 shows a grid pattern. We thought the

black square was pretty boring, so we filled a Figure 3-27: Droplets within a
big drop with little droplets and chose the Brick  drop.

Pattern option.

Symmetry brush

The Symmetry brush creates four types of symmetrical designs. To choose
one, click the Deco tool on the Tools panel and display the Property inspec-
tor (Window=>Properties). Use the default black square or click the color
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swatch to choose another color. Alternatively, click the Edit button to choose
a graphic or movie clip symbol. (We explain symbols in Chapter 7.) Then
choose one of the following from the Advanced Options drop-down list:

1~ Reflect Across Line: Displays a vertical green line with a rotation handle
at one end and a moving handle at the other. Drag the rotation handle
to rotate the line. Drag the moving handle to move the line. Click on one
side of the line to place the specified object, and you automatically get a
mirror image on the other side of the line.

1~ Reflect Across Point: Displays a green circle. Click on one side of the
circle to place the specified object, and you automatically get a mirror
image on the other side of the point.

1~ Rotate Around: Displays two

green lines. One line is like the ~
line for the Reflect Across Line A0 =
symmetry; the other appears y F ™)
at an angle that determines y )
the number of objects placed > G-
around the point. You can drag i, "3 3-8
the end of the second line to ' )
change the angle. Click on one ’ O ’
side of the vertical line, and you Ny :
get a radial pattern around the 3 3
central point. You can continue = . P
to place more objects, as shown Fa £
in Figure 3-28. N

v Grid Translation: Displays a
horizontal and a vertical axis
with handles near the axes’ Figure 3-28: With two clicks, we created this
origin that let you change the radial pattern of flowers.
distance and angle of the grid.
Click to create a grid pattern.

3D Brush

The 3D Brush works like the Spray Brush tool; you drag to fill an area. The
default shape is small squares, like the Grid fill. You can select up to four
objects. In each case, you can use the default shape (and click the color swatch
to choose a color), or click Edit and choose a symbol from the Library.

The 3D Brush places the objects so that some seem to be in front of others,
resulting in a 3D effect. In the Advanced Options section, you can set the
following.
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1 Max. Objects: Type a number or click and drag up or down. The maxi-
mum (and default) is 10,000!

1~ Spray Area: Click and type a number or drag up or down. This setting
affects the width of the spray.

1~ Perspective: Select this check box to apply a perspective angle to the
collection of objects.

1~ Distance Scale: Sets the distance range, meaning the intensity of the 3D
effect.

1~ Random Scale Range: Creates random sizes of your objects. You con-
trol the range of sizes.

1 Random Rotation Range: Creates random rotations of your objects. You
control the range of rotation.

Building Brush

The Building Brush creates skyscrapers, and you can choose from four types.
We get the best results when we drag upward with the brush; that’s how you

make your skyscraper rise to the sky. Use the Building Size text box/slider to

specify the width of the skyscraper.

Decorated Brush

Amazingly, the Decorated Brush
effect has 20 (count 'em, 20!") deco-
rations. We don’t need to list them
for you because you can click the
drop-down list in the Advanced
Options section and see them for
yourself. Figure 3-29 shows a sam-
pling. Needless to say, we ran out
of room! In the same section, you
can choose the pattern color, size,
and width.

Y33y

U LTLHJ_E 1

) . . Figure 3-29: The Decorated brush offers
Fire animation borders galore.

This Deco tool not only creates fire:

It animates it. Don’t let it burn a hole in your screen! We got the best results
when we dragged horizontally while placing the fire. Also try simply clicking
to place the flame. In the Advanced Options section, you can choose the
following:
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v~ Fire Size: Enter a value from 50% to 250%, or drag up or down to change
the value.

v~ Fire Speed: Enter a speed from 50% to 200%, or drag up or down to
change the value.

 Fire Duration: Enter the number of frames, from 10 to 200, that the ani-
mation will cover. For more information on animation and frames, see
Chapter 9.

» End Animation: Select the End Animation check box to create an anima-
tion that totally consumes the flames, leaving nothing left.

+~ Flame Color: Click the color swatch to choose a new color.
+* Flame Core Color: Click the color swatch to choose a new color.
v~ Fire Spark: Click and type a number or drag the slider to specify the

amount of sparks that fly off the flame. The available range is from 0 to 10.

Try the Fire animation in a new Flash movie. Specify the settings, drag some
flames on the Stage, and then press Enter to play the animation. Hot stuff!

Flame Brush

The Flame Brush creates flame-like images that we don’t think look very
much like flames. The only two settings are the Flame Size (from 2 to 20
pixels) and the Flame Color. Whichever color you choose, you’ll also see
other colors in your flames. Drag the brush on the Stage to place the flames.

Flower Brush

The Flower Brush creates amazingly lush flowers, leaves, and fruit. Optionally,
you can add branches, which look vine-like. You can draw four types of flow-
ers. In the Advanced Options section, specify the following settings:

1~ Flower Type: Choose Garden Flower, Rose, Poinsettia, or Berry from the
drop-down list.
* Flower Color: Choose from the color swatch.

~ Flower Size: Click and enter a value from 50% to 200% (for truly humon-
gous flowers), or use the slider to drag up or down.

1 Leaf Color: Choose from the color swatch.

1~ Leaf Size: Click and enter a value from 50% to 200%, or use the slider to
drag up or down.

* Fruit Color: Choose from the color swatch.
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Select the Branch check box to add a branch element and then choose its
color from the color swatch.

Figure 3-30 shows a trellis covered with the four types of flowers.

Figure 3-30: It looks like summertime, but what are the poinsettias
doing there?

Lightning Brush

The Lightning Brush creates awesome lightning, animated or still. Use this
brush against a dark background to create a night sky effect. In the Advanced
Options section, customize your lighting as follows:

1~ Lightning Color: Click the swatch to choose a color, such as white or
yellow.

1~ Lighting Scale: Choose a size from 10% to 100%. You could use a lower
percentage to show lightning that’s far away.

v~ Animation: Select the check box to create a cool lightning animation.

1~ Beam Width: The beam is the main line of the lightning. Other lines
extend from the beam, like branches from the trunk of a tree. Click and
enter a width from 1px to 20 px, or drag the slider to adjust the value.

1 Complexity: The complexity determines how many lines extend from
the main beam. You can set a value from 0% (just the beam) to 100% (for
a full light show).
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Particle System

The Particle System effect creates a waterfall-like cascade of boxes (or any
symbol that you choose) and animates them. On one hand, you can control
many aspects of this effect; on the other hand, the effect looks out of control
no matter what choices you make.

Select the Particle 1 check box so that you have at least one particle. The
default shape is a little square. Click the color swatch to change the color.
If you click the Edit button, you can choose a symbol from the Library. (See
Chapter 7 for more on symbols.) Select the Particle 2 check box to add
another square (you'll probably want to change the color) or symbol.

You can specify the following settings in the Advanced Options section:

~ Total Length: Click and enter the number of frames to define the length
of the animation. You can choose a number from 1 to 200.

1~ Particle Generation: Click and enter the number of frames to define how
long you want new particles to appear. You can choose a number from 0
to 200, but if you choose 0, nothing happens!

1~ Rate per Frame: Click and enter the number of particles that you want
to create per frame. Higher numbers create a more complex cascade.

1~ Life Span: After a while, the particles die. Click and enter the number of
frames you want the particles to last.

v~ Initial Speed: The particles move! Click and enter an initial speed in pixels.

v~ Initial Size: Click and enter the initial size of the particles, from 10%
to 200%.

v Minimum Initial Direction: Because the particles move, they also have a
direction. You can create a smaller or larger range of direction. Click and
enter the minimum initial direction, in degrees.

1 Maximum Initial Direction: Click and enter the maximum initial direc-
tion, in degrees.

1 Gravity: The particles fall, too. The higher the gravity (in pixels), the
longer the cascading effect. You can choose a number from -20 to 20. If
you use a negative number, the particles rise, rather than fall.

+~ Rotation Rate: You can rotate the particles. Click and enter a number in
degrees, from -180 to +180.

Smoke Animation

The Smoke Animation effect doesn’t look much like smoke; instead, it creates
gray balls that change shape and rise slightly. Some of the balls fade out.
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In the Advanced Options section, you can change the size, speed, duration,
and color of the smoke. You can also set the background color. Select the
End Animation check box to greatly multiply the length of the animation and
make all the smoke balls disappear.

Tree Brush

The Tree Brush enables you to draw 20 kinds of trees, some of which aren’t
trees at all. Some of the trees you can draw are an apricot tree, a Christmas
tree, a ginkgo tree, and a maple tree. Some of the non-trees are a vine, a
garden plant, and grass. In the Advanced Options section, you can choose
the type of plant, and set the tree scale, branch color, leaf color, and flower/
fruit color. For trees that don’t have flowers or fruit, the latter setting is
meaningless. Getting your tree to look like a tree is somewhat difficult. In
most cases, you should start from the bottom and drag upward to grow your
tree. Try dragging at various speeds until you get the result that you want.

Drawing Precisely

\\3

If drawing in Flash seems too loosey-goosey to you, you need to know about a
few features that can help you draw more precisely. Other programs do offer
more precise tools, but Flash might have the tools you need.

The ruler rules

To help you get your bearings, you can choose Viewr>Rulers to display the
Flash ruler along the top and left side of the Stage, as shown in Figure 3-31.

To give yourself more room to work while you create drawing objects on
the Stage, you can hide the Timeline by choosing Window=>Timeline. Do the
same to display the Timeline again when you need to work with layers or
start animating your work.

By default, the ruler is measured in pixels. Computer screens are measured
by how many pixels they display horizontally and vertically. Pixels are useful
for Web site work because Web browsers work with only this unit. A pixel,
however, is not a fixed physical size because it depends on the resolution
capacity and settings of your screen. You might find it easier to think in
inches or millimeters.

You can set the ruler to the unit of measurement that is most helpful to you.
Choose Modify=>Document to open the Document Settings dialog box. In the
Ruler Units drop-down list, choose one of the units (pixels, inches, inches
[decimal], points, centimeters, or millimeters) and then click OK.
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Figure 3-31: Display the ruler to help you draw more precisely; for more
control, drag guides onto the Stage.

When the ruler is displayed, lines appear on the top and side rulers when-
ever you drag an object — either while creating it or editing it. For example,
when you drag to create a rectangle, you see a line on each ruler telling you
where you started and where you ended up. If you're moving the rectangle,
Flash displays two lines on each ruler indicating the outside dimensions of
the rectangle. You can easily move the rectangle 1 inch — or 50 px — to the
left by looking at the lines on the top ruler.

Using guides

Guides help you lay out the Stage more precisely. Guides (refer to Figure 3-31)
are horizontal and vertical lines that you can use as drawing aids while you
work. Don’t worry — guides never appear in the published Flash Player file.
To use the guides, you must display the rulers, as we describe in the preced-
ing section.

To display the guides, you need to drag them from the rulers. Drag from the left
ruler to create a vertical guide, and drag from the top ruler to create a horizon-
tal guide. (If you still don’t see the guides, choose Viewr>Guides>Show Guides
and make sure that there’s a check next to the Show Guides menu item.)



92

Part Il: 1,000 Pictures and 1,000 Words

[

To customize the guides, choose Viewr>Guides>Edit Guides to open the
Guides dialog box, where you can choose the guide color or clear all the
guides. To force objects to snap (attach) to the guides, select the Snap to
Guides check box in the Guides dialog box. You can use the Snap Accuracy
drop-down list in the Guides dialog box to choose how precisely Flash snaps
to the guides. To lock the guides so that they don’t move while you work,
choose Viewr>Guides=>Lock Guides. To remove an individual guide, drag it
back to its vertical or horizontal ruler.

Working with the grid

You can display a grid on the Stage to help you draw more accurately and
gauge distances. The grid exists only to guide you — it never appears when the
movie is printed or published on a Web site. Simply displaying the grid doesn’t
constrain your objects to points on the grid. Use the grid by itself when you
want a visual guide for drawing, sizing, moving, and laying out the Stage.

To display the grid, choose Viewr>Grid>Show Grid. Use the same command
to hide the grid again. You can set the size of the grid squares and change the
color of the grid lines in the Grid dialog box. To open the dialog box, choose
Viewr>Gride>Edit Grid.

You can change the units of measurement used for the grid by choosing
Modify=>Document. In the Modify Document dialog box, select the unit that
you want in the Ruler Units drop-down list and then click OK.

Snapping turtle

When you want even more precision, you can turn on snapping. Snapping
tells Flash to snap objects to the intersections on the grid or to other objects.
Usually, you want the grid on when you use snapping so that you can see the
snap points.

To turn on snapping, choose the Selection tool and click the Snap to Objects
modifier in the Options section of the Tools panel or choose Viewr>
Snappingr>Snap to Objects. To snap to the grid, choose Viewr>Snapping=
Snap to Grid. Use the same method to turn snapping off again.

Snapping pulls your cursor to the grid points and to existing objects while
you work. You can take advantage of snapping both while drawing new
objects and editing existing objects. When you have snapping on and select
an object, Flash displays a small, black circle and snaps the circle to the grid
points.
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Setting snap-to-grid preferences

You can get downright picky about how Flash snaps to grid points. Do you
want the end of a line (for example) to always snap, or should it snap only if
it’s close to a grid point or an existing object? To set your preferences,
choose Viewr>Grid=>Edit Grid. In the Snap Accuracy drop-down list, select
one of the options, which range from Must Be Close to Always Snap.

Setting snap-to-objects preferences

Because snapping applies to objects as well as grid points, you can sepa-
rately set how Flash snaps to objects. Choose Edit=>Preferences (Windows)
or Flash=>Preferences (Mac) and then click the Drawing category. From

the Connect Lines drop-down list, select Must Be Close, Normal, or Can

Be Distant. Although Flash calls this the Connect Lines setting, it affects
rectangles and ovals as well as the lines you draw with the Line and Pencil
tools.

This setting also affects how Flash recognizes horizontal and vertical lines
and makes them perfectly horizontal or vertical. For example, the Can Be
Distant setting adjusts a more angled line than the Must Be Close setting.

Pixel, pixel on the wall

If the grid isn’t precise enough, you can snap to pixels. Choose Viewr>
Snappingr>Snap to Pixels to toggle snapping to pixels. If Snap to Pixels is
on, Flash automatically displays the pixel grid when you zoom in to 400% or
higher. With Snap to Pixels on, you can snap all objects that you create or
move to the pixel grid.

a\\J

When Snap to Pixels is on, you can press the C key to temporarily turn off
pixel snapping. In the same situation, you can hold down the X key to tempo-
rarily hide the pixel grid (but not while you’re in the process of drawing).

You can also precisely align existing objects. For more information, see
Chapter 4.

The Import Business — Using Outside Graphics

So maybe you’re the lazy type — or totally without artistic talent — and
you really need help. Flash hasn’t given up on you completely. Rather
than create your own graphics, you can use the work of others. Although
Flash creates vector-based graphics, it can import both bitmap and vector
graphic files.
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When using others’ artwork, be careful about copyright issues. For example,
some graphics available on the Web can be used for personal, but not com-
mercial, purposes. Most Web sites that offer graphics for downloading offer a
policy explaining how you can use their graphics.

Importing graphics

To import a graphic file, follow these steps:

1. Choose File>Import=>Import to Stage.

The Import dialog box opens.
2. In the dialog box, locate and choose the file that you want.
3. Click Open/Import to open the file.

The file appears on the Stage. If the file is a bitmap, it also goes into the
Library. To import a graphic file directly into the Library without dis-
playing it on the Stage, choose Filew>Import=>Import to Library.

A cool feature of Flash is its capability to recognize and import sequences of
images. If the image file that you choose in the Import dialog box ends with
a number — and other files in the same folder have the same name but end
with consecutive numbers (for example, animall.png, animal?2.png, and
so on) — Flash asks whether you want to import the entire sequence of files.
Click Yes to import the sequence. Flash imports the images as successive
frames on the active layer so that you can use them as the basis for anima-
tion. (Chapter 9 explains more about frames and animation.) Table 3-1 pro-
vides a list of the types of files you can import into Flash.

Table 3-1 Files That Flash Can Import

File Type Windows Mac
Adobe lllustrator (. ai) through version CS5 X X
AutoCAD DXF (. dxf); 2D only X X
Bitmap (. bmp) X X*
Enhanced Metafile (. emf) X

Flash Player 6/7 (. swf) X X
FutureSplash Player (. sp1) X X
GIF/animated GIF (. gif) X X
JPEG (. jpg) X X
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File Type Windows Mac
MacPaint (. pntg)* X
Photoshop (.psd) X
PICT(.pct, .pic)*

PNG (.png)

QuickTime image (. gt if)*

Silicon Graphics Image (. sgi)*

Targa (. tgal)*
TIFF (. tif)*
Windows Metafile (. wmf)

*Only if QuickTime 4 or later is installed

XXX | X | X|X|X|X

XX | X[ X|X|X

You can also simply copy and paste graphics. From the other applica-
tion, copy the graphic to the Clipboard; then return to Flash and choose
Edit->Paste. However, in some cases, you might lose transparency when
using this method. See Chapter 13 for details on exporting objects.

Flash CS5 offers special controls for importing Photoshop and Illustrator
files. For Photoshop files, you can import the layers intact. When you import
the file, a dialog box opens where you can specify which layers you want to
keep. You can convert layers to Flash layers or to keyframes. For each layer,
you decide whether to import the layer with editable layer styles or as a flat-
tened (simple) image. For Illustrator files, you can maintain the ability to edit
text and paths in Flash. These and other controls give you a huge amount of
power over the result of the import. Choose Edit=> Preferences and choose
PSD File Importer or Al File Importer to set default settings when you import
these files. You can change these settings whenever you import a file.

Using imported graphics

Vector graphics from any drawing program become a grouped object

that you can use like any other Flash object. The .wmf format, which is a
Windows vector graphics format, also imports in this way. These formats
work especially well when imported into Flash. You can sometimes find . wmf
graphics in clip art collections and on the Web.

You can import text from a text editor, and Flash turns it into a Flash text
object so that you can edit and format it within Flash. See Chapter 5 for more
on text.
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When you import a bitmap graphic, you often need to take some steps before
you can use the graphic in your Flash file. You can manipulate your graphics
in several ways to make them more Flash friendly:

1~ Delete the background. Some files may include a rectangular back-
ground you don’t want. To get rid of that background, deselect the
imported object, select just the rectangular background, and press
Delete. If that doesn’t work, read on.

1 Ungroup the graphic. Ungrouping separates grouped elements into
individual elements. Ungrouping retains most of the features of your
graphic. Select the graphic and choose Modify=>Ungroup. If you find that
you still can’t work with your graphic properly, read the next item.

1~ Break apart the graphic. Break imported graphics to separate them into
ungrouped, editable elements. Breaking apart is useful for reducing the
file size of graphics that you import. Breaking apart converts bitmaps to
fills, converts text to letters and outlines, and breaks the link between an
OLE (Object Linking and Embedding) object and its source application.
In other words, the Break Apart command is a powerful tool. Select the
graphic and choose Modify=>Break Apart. You may have to repeat the
process to break the graphic completely apart.

1~ Trace the bitmap. Flash can work magic. If you want total control within
Flash, convert a bitmap to a vector graphic.

To trace a bitmap, follow these steps:

1. Import the bitmap — don’t deselect it or perform any other action on it.
2. Choose Modify=>Bitmap~>Trace Bitmap.
The Trace Bitmap dialog box opens.

3. In the Color Threshold text box, type a number to represent the
threshold.

The higher the number, the fewer the colors you get in the final vector
graphic. For close results, try a value of 10.

4. In the Minimum Area box, type a number to represent the number of
nearby pixels that Flash considers when assigning a color to a pixel.

For greatest fidelity, try a value of 1.

5. From the Curve Fit drop-down list, select an option to represent how
smoothly Flash draws the outlines.

For the most exact results, select Pixels.
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6. From the Corner Threshold drop-down list, select an option to repre-
sent how Flash reproduces sharp edges.

For sharpest results, choose Many Corners.
7. Click OK to close the Trace Bitmap dialog box, and then deselect the
graphic to see the result.

Figure 3-32 shows the result on our hummingbird photograph.

~

Figure 3-32: You can convert complex hitmaps to vector
drawings.

When you import a bitmap graphic, Flash places it in the current movie’s
Library. For best results, don’t delete the original graphic from the Library,
even if you have modified it. Flash continues to refer to the graphic after you
have converted it to a symbol. (Chapter 2 explains all about the Library. See
Chapter 7 for our total wisdom on symbols.)

Whether you created your graphics in Flash or imported them, you probably
need to edit them in many ways. Chapter 4 explains the details of editing
objects.
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You Are the Object Editor

In This Chapter

Selecting objects

Manipulating objects (moving, copying, deleting, and erasing)
Reshaping shapes and working with fills

Transferring properties to other objects

Transforming objects (scaling, rotating, skewing, and flipping)
Combining and breaking apart objects

Changing object order

Undoing, redoing, and reusing actions

rlis chapter tells you all you need to know about editing objects.
You can manipulate objects in a zillion ways to suit your
artistic fancy. The Flash editing tools can give you precisely
the results that you want. Sometimes you need to edit
because you made a mistake (rarely, of course), but
often, editing is just part of the creation process. You
might also need to alter imported graphics so that
they fit into the scheme of things.

Selecting Objects

Before you can edit any object on the Stage, you
need to select it. Flash offers many ways to select
objects. After you get the hang of using the Flash selec-
tion tools, you'll find them efficient and easy to use.
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Selecting with the Selection tool

To select an object, click the Selection tool (the dark-colored arrow in the
Tools panel) and click the object. That sounds pretty basic. But just when
you thought it was safe to skip the rest of this section, we add some ifs and
buts, so read on.

What defines an object? A shape that includes an outline (also called a line
or a stroke) and a fill (such as a filled-in circle) has two objects — the outline

and the fill.
s&mBEn Most of these selection guidelines don’t work when you use the object-
& drawing model for creating objects. When you use the object-drawing model

to draw an object (such as a rectangle), both the stroke and the fill are con-
sidered one object, so you can’t select the stroke or the fill individually. (We
explain the object-drawing model in Chapter 3.) The same holds true for sym-
bols, which we cover in Chapter 7.

Here are some pointers for selecting objects:

1~ If the object doesn’t have an outline and is just a fill, you're home free.
Click the object with the Selection tool, and it’s selected.

1~ If the object has an outline and a fill, clicking the fill selects only the
fill. The outline remains deselected. To select both the fill and the out-
line, double-click the object.

~ To select the entire object, you can use the Selection tool to create
a selection box. Click at one corner and drag to an opposite corner,
making sure that the bounding box com- _
pletely encloses the object or objects that [- — "\>

you want to select, as shown in Figure 4-1.

1~ To select just an outline, click the outline ‘
with the Selection tool. Still, you never know \f /
when an outline is really several objects, like k — 4
the one in Figure 4-1, which is made up of ()
several curves. To select the entire outline, =
double-click it. Q

1~ To select several unconnected objects, select
one object, press and hold the Shift key, and k.
select additional objects. When you press
Shift, you can add to already selected objects Figure 4-1: Create a bounding
and select as many objects as you want. box with the Selection tool.
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To deselect all selected objects, click any blank area. If you selected several
objects and want to deselect one object, press Shift and click that object.

<P So you’re happily drawing away, using the various drawing tools. Then you
want to select one of the objects, but you forget to change to the Selection
tool. Oops! You draw another object by accident. Inmediately choose
Edite>Undo. Then use one of the Flash shortcuts:

1~ Press the V key to switch to the Selection tool.

1 To temporarily switch to the Selection tool while you’re using another
tool, hold Ctrl (Windows) or 8 (Mac) while you select an object or
objects.

Lassoing your objects

For you rodeo types, you can lasso your objects so that they can’t escape. The
Lasso tool creates a customized selection area and selects everything inside, as
well as self-contained objects (such as object-drawing model objects, symbols,
and text) that cross the lasso line. Use the Lasso tool when you want to select a
number of objects that are near other objects that you want to remain free.

To lasso objects, click the Lasso tool on the Tools panel.

[

To lasso freehand, make sure that
the Polygon Mode modifier (in the
Options section of the Tools panel) is
not selected. Click anywhere on the
Stage and drag around the objects
that you want to select. Flash cre-
ates a selection area while you drag.
Release the mouse button close to
where you started it to close the las-
so’s loop, as shown in Figure 4-2.

Figure 4-2: Lasso freehand to select only the
objects you want.

You might find that freehand lasso-
ing is hard to control. If you tend
to inadvertently cut across objects
rather than glide around them, use the Polygon Mode modifier to draw
polygons instead — like a lasso with a very stiff rope.

To lasso by using straight lines, follow these steps:

1. Click to choose the Lasso tool.

%2 2. Click the Polygon Mode modifier in the Options section of the Tools
o panel.
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3. Click where you want the first line of the polygon to start.
4. Click again where you want the first line to end.
5. Continue to click, creating line segments as you go.

6. Double-click when you finish lassoing the objects.

Selecting everything in one fell swoop

Suppose that you want to select or deselect all objects at one time. Flash has
some handy shortcuts to help you do that:

1~ To select everything: Press Ctrl+A (Windows) or 8+A (Mac). Or, choose
Edit=>Select All. The Select All command selects all objects on all layers
except for objects on locked or hidden layers. (See Chapter 6 for an
explanation of layers.)

1~ To select everything on one layer: Click the layer name.

1 To deselect everything: The easiest method is to click off the Stage or
on any blank area of the Stage. Alternatively, you can press Ctrl+Shift+A
(Windows) or 38+Shift+A (Mac). Or, choose Edit=>Deselect All. The
Deselect All command deselects all objects on all layers.

To lock a group or symbol so that you can’t select or edit it, select the group
or symbol and choose Modify=>Arranger>Lock. To unlock a group or symbol,
choose Modify=>Arranger>Unlock All. (See the section “Getting Grouped,”

later in this chapter, to find out about groups. Chapter 7 is all about symbols.)

Moving, Copying, Deleting, and Erasing

The most common changes that you make to objects are to move, copy,
delete, and erase them. Usually, these are straightforward tasks — but Flash
has a few tricks up its sleeve, so keep on truckin’.

Movin’ on down the road

Before you can move an object, you have to select it. After you select your
object or objects, place the mouse cursor over any selected object until your
cursor displays the dreaded four-headed arrow. (Okay, most people don’t
dread it at all.) Then click and drag to wherever you're going. Press Shift
while you drag to constrain the movement to a 45-degree angle. (Lines and
strokes don’t show the four-headed arrow until you drag them.)
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Moving precisely with Snap Align

When you drag an object, you see vertical and horizontal dashed lines when
your object approaches existing objects. This Snap Align feature displays

temporary dashed lines when you move objects to show you when the edges
of objects are aligned, both vertically and horizontally, with existing objects.

Snap alignment is great for quickly aligning two
objects without using the Align panel. While you
drag a selected object, the dashed lines appear
when you move an object in alignment with an
existing object, as shown in Figure 4-3. You also
see the lines when you drag an object close to any
edge of the Stage.

To turn on snap alignment (although it is on by

default), choose Viewr>Snapping~>Snap Align.

You see a check mark next to the Snap Align item.

Repeat the process to turn off snap alignment. Figure 4-3: The Snap Align feature
displays alignment between

You can customize your snap alignment objects while you move them.

settings. Choose View=>Snapping=

Edit Snapping to open the Edit

Snapping dialog box. Then click Edit Snapping

[==]
the Advanced button to expand the -
. P v I
dialog box, as shown in Figure 4-4. = Snapmgn_
[ snap ta crid
In the Edit Snapping dialog box, you ¥ Snap to Guides
can also turn on snap alignment for [ Snap to Pixels
the centers of objects — for easy [ snap to Obijects
centering of objects — by selecting o
. Wanced v
both check boxes in the Center
Alignment section. Snap align settings
Stage border:

Flash assumes that a border exists
around the edge of the Stage. To

Ohject spacing:

change the border width, type a dif- Horizontal: 0 Fx |
ferent number in the Stage Border vertical0px |

box. To change the precision for
alignment between objects, type
a number in the Horizontal and [ Horizontal center ignment
Vertical boxes in the Object Spacing [ Wertical center alignment

section of the dialog box. Click OK

when you're finished to close the
dialog box. Figure 4-4: Make your snap alignments snap to

your orders.

Center alignrment:
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You can also use the grid and turn on the snapping feature for moving and
copying objects. (See Chapter 3 to find out about the grid and snapping.) For
example, you can attach one object to another by moving your first object until
it snaps to the second, using the small black circle at the cursor as a guide.

The Snap Align feature aligns objects by their edges. Object snapping aligns
objects by their transformation point. See the “Changing the Transformation
Point” section, later in this chapter, for more information.

You can also use the four arrow keys on your keyboard to move a selected
object or objects. Each press of an arrow key moves the selection one screen
pixel in the direction of the arrow. Press Shift plus an arrow key to move the
selection by 10 screen pixels.

Moving with the Clipboard

You can move an object by cutting to the Clipboard and pasting if you want
to move the object to another layer, scene, file, or application. After you
select the object or objects, choose Edit>Cut. Alternatively, press Ctrl+X
(Windows) or 8+X (Mac). Choose another layer or scene or open another file
and do one of the following:

1~ To paste the selection in the center of the display: Choose Edit=>Paste,
or press Ctrl+V (Windows) or 8+V (Mac).

~ To paste the selection in the same position relative to the Stage:
Choose Edit=>Paste in Place, or press Ctrl+Shift+V (Windows) or
38 +Shift+V (Mac).

Moving with the Property inspector
If you want to place objects precisely, use the m
Property inspector. After you select an object or
objects, choose Window=>Properties, as shown in
Figure 4-5.

Shape

= POSITION AND SIZE

X 3510 ¥ 1620

Use the X and Y values to specify the location. The
X setting specifies horizontal distance and the Y
setting specifies vertical distance — and both are
measured from the top-left corner of the Stage. To
change a value, click it, type a new one, and then  Figure 4-5: Use the Property
press Enter; or, drag the value up or down. inspector to place objects

precisely.

&2 w: 143.0 He 100,0

[> FILL AND STROKE

Moving with the Info panel

You can also use the Info panel to specify the X and Y positions of objects.
Choose Windowr>Info to open the panel, as shown in Figure 4-6. You can use
the grid next to the X and Y text boxes to specify whether you’re measuring
either from the upper-left corner or the center of the selection. Just click
the grid to toggle between the two options. Flash uses the units you specify
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in the Document Settings dialog box. (See the
section in Chapter 3 on drawing precisely for
information on setting the units.) Then enter
the desired X and Y location in the X and Y text
boxes.

Remember that moving an object onto another
existing object on the same layer may do one of
the following:

Figure 4-6: The Info panel.

v~ Join it, if the objects are the same color

v~ Cut it out, if the objects are different colors — unless you drew the object in
object-drawing mode or you used a primitive shape (oval or rectangle)

See the section in Chapter 3 on mixing and matching shapes for more
information.

Aligning objects with the Align panel

The Snap Align feature, as we explain in the “Moving precisely with Snap Align”
section, earlier in this chapter, is the quick way to align objects. However, for
more options and precision, use the Align panel. The Align panel gives you the
tools to line up two or more objects vertically or horizontally and also lets you
put equal space between three or more objects. Align and space objects to
make your Flash movie look professional, as opposed to something that you
might create at 3 a.m. when your vision is too blurry for you to see straight.

To align objects, select the objects and choose =
Window=>Align to open the Align panel, as shown | **"

in Figure 4-7. In the panel, choose the option that Aligr:

you want for aligning or distributing objects. For B & & @4 b
example, you can align objects along their tops, Distribute:

their left sides, or any other direction. You can T == b oo ogd
match the size of objects (resize them) by using P ey Spate:

the Match Size buttons, or you can make the 2 5 % & i
spaces between objects the same with the Space -

buttons. Experiment with the options in this [ align to stage

panel until you get the results that you want.

Figure 4-7: Use the Align panel
to line up and evenly distribute
objects.

To perfectly center one object on the Stage:

1. Select it and open the Align panel.
2. Click the To Stage button.

3. Click both the Align Vertical Center and the Align Horizontal Center
buttons.

Flash centers the object on the Stage.
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A quicker way is to cut and paste the object because Flash automatically
pastes objects at the center of the display (which is at the middle of the Stage
if you haven’t panned or scrolled the display).

If you use the To Stage button, be sure to deselect it when you’re finished
because it can cause unexpected results the next time you use it.

Copying objects

After you spend loads of time creating a cool graphic, you might want to copy
it all over the place. The easiest way is to clone it directly by dragging. Just
select the object and press Ctrl (Windows) or Option (Mac) while you drag.
Flash makes a copy and moves it wherever you drag.

You can also copy objects to the Clipboard. Select an object or objects and
then choose Edit=>Copy or press Ctrl+C (Windows) or 8+C (Mac). You can
paste the selection on the same layer or move it to another layer, scene, or
file by using one of these techniques:

1~ To paste the selection in the center of the display: Choose Edit=>Paste,
or press Ctrl+V (Windows) or 8+V (Mac).

 To paste the selection in the same position relative to the Stage:
Choose Edit=>Paste in Place. If you're on the same layer, scene, and file,
you now have two copies, one on top of the other. The new object is
selected, so you can immediately drag it to a new location.

Because Flash pastes objects from the Clipboard to the exact center of the dis-
play, cutting and pasting is a great technique for centering objects on top of each
other. For example, if you want to create two concentric circles, one on top of
the other, create the circles in separate locations. Cut and paste the larger circle
first and the smaller circle second. You now have perfect concentric circles, as
shown in Figure 4-8, and you can move them together to the
desired location. This technique works only if the Stage is at
the center of your display — that is, if you haven’t scrolled
the display.

When you paste a new object, be sure to move the new
object right away if it covers an existing object on the
same layer. If you deselect the new object, it either joins
the existing object (if the objects are the same color) or

cuts it out (if they’re different colors). Of course, that Figure 4-8: Perfectly
might be your intention. See the section in Chapter 3 concentric circles
on mixing and matching shapes for more information, create a bull's-eye!

including how to avoid this joining and cutout behavior.
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Makin’ objects go away
Making objects go away is easy. Just select them and press Delete or
Backspace (Clear on a Mac).

Erasing objects

Erasing objects is like using a blackboard eraser (remember those?) or pencil
eraser. Flash erases, pixel by pixel, where you erase. Luckily, Flash offers
some tools that help you control the process.

7| To erase objects, choose the Eraser tool on the Tools panel. Click and drag
~ across any object to erase where you drag. The eraser erases objects drawn
with or without object-drawing model on. However, it does not erase grouped
objects, symbols, or text. (We cover grouping later in this chapter. We cover
o text in Chapter 5 and symbols in Chapter 6.)
To erase all the objects on the Stage — and even objects off the Stage —
double-click the Eraser tool. All gone!

@ You can control how the eraser works. You can set the size and shape of the
eraser. For example, if you need to get into a small spot, make the eraser
smaller. To set the size, click the Eraser Shape button in the Options section
of the Tools panel. In the drop-down list that appears, you can choose a
circle or square shape, and both shapes come in several sizes.

©

You can specify several eraser modes to fine-tune your results. To set the Eraser
Mode modifier, click the Eraser Mode button to display the following options:

+~ Erase Normal: Dragging erases strokes and fills wherever you drag.

v~ Erase Fills: You can erase only fills, so you can messily drag over strokes
without harming them. The strokes look like they’re erased as you drag,
but they magically reappear when you release your mouse button.

+~ Erase Lines: You can erase only strokes, so you can messily drag over
fills without harming them. The fills look like they’re erased as you drag,
but they magically reappear when you release your mouse button.

1~ Erase Selected Fills: Select fills before you start. Then, dragging erases
only the fills you selected and nothing else.

1~ Erase Inside: If you start dragging on a fill, you erase only that fill. All
other fills are immune. If you start dragging in an empty area, nothing
happens at all. This mode does not affect strokes.

(&) The Faucet modifier is like using the Delete key for fills and strokes. Choose
— the Eraser tool, click the Faucet modifier, and click any fill or stroke to
instantly delete it. You don’t even have to select the object first.
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Making Shapes More Shapely

Suppose that you created an object and now you want to tweak it a bit. Flash
has many techniques to help you perfect your artwork, and you can modify
both lines and fills.

Reshaping shapes and outlines

The Selection tool can do more than select objects. It can also reshape them
as long as you didn’t create them by using the object-drawing model or a
primitive shape. When you reshape with the Selection tool, you do not select
the object.

To reshape an outline or a fill, choose the Selection tool and place the mouse
k cursor near the object or on the edge of the object:

1~ If you see a corner next to the
cursor, you can move, lengthen,
or shorten an end point, as
shown on the left side of
Figure 4-9.

v~ If you see a curve next to the
cursor, you can reshape a
curve, as shown on the right
side of Figure 4-9.

Click and drag in the desired direc-  Figure 4-9: The Selection tool modifies end
tion. Flash temporarily displays a points and curves.

black drag line to show you what the

result will look like when you release

the mouse button. If you don’t like the result, choose Edit>Undo — or press
Ctrl+Z (Windows) or 8+Z (Mac) — and try again.

Like with drawing, you might find it helpful to increase the zoom factor. Try
editing at 200% or 400%.

Using the Subselection tool

You can use the Subselection tool to reshape individual strokes or fills cre-
ated by using the Pen, Pencil, Brush, Line, Oval, or Rectangle tools. When you
use the Subselection tool, you move anchor points, which are small circles
that appear on the object. To use the Subselection tool, follow these steps:
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X 1. Choose the Subselection tool (the light-colored arrow in the Tools panel).
2. Click the stroke (outline) or fill to display the anchor points.

3. Hover the cursor over an anchor point to see the anchor cursor, a
small circle.

4. Click and drag the anchor
point to modify the shape.

Sometimes, you need to click an

anchor point before dragging I
it to tell Flash that you want to

move it. ———

5. To change the direction of a N
curve, click any anchor point /)
to display tangent lines and -
drag the tangent line handles —__ _——

(the little dots at the ends of
the tangent lines), as shown Figure 4-10: Subtle changes are easy with the
in Figure 4-10. Subselection tool.

The tangent lines indicate the direction of the curve. See the section in
Chapter 3 on drawing curves with the Pen tool for information on anchor
points and tangent lines.

<P If you use the Subselection tool to click a graphic and points aren’t displayed
on its edges, you might have grouped the graphic (as we describe later in
this chapter), or you might have created it with the object-drawing model,
or maybe you didn’t create it with the Pen, Pencil, Brush, Line, Oval, or
Rectangle tool. Try choosing Modify=>Ungroup or Modify=>Break Apart and
then using the Subselection tool.

You can also delete anchor points. Flash reshapes the shape without that
anchor point. Select the object with the Subselection tool, select an anchor
point, and then press Backspace or Delete.

When you use the Subselection tool on an oval or rectangle primitive, you
can change only its parametric properties. For example, you can change
the corner radius of a primitive rectangle. To do so, you need to drag at
one of the corners. For a primitive oval, you can change the inner radius,
start angle, and end angle; you need to drag from the center or the right
quadrant.
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Adjusting curves with the Pen tool

You can make adjustments to objects that you drew with the Pen tool. Click
the Pen tool and then click the object. You now see anchor points along the
curves and lines. Here’s what you can do:

1 Add an anchor point. Hover the cursor over any place that doesn’t
already have one. You see a little plus sign. Just click wherever you want
to add the point. Alternatively, click and hold the Pen tool to display the
flyout and choose the Add Anchor Point tool.

1~ Delete an anchor point. Hover the cursor over any anchor point. You
see a little minus sign. Click the anchor point. Alternatively, click and
hold the Pen tool to display the flyout and choose the Delete Anchor
Point tool.

1~ Convert an anchor point. Anchor points can be curve points or corner
points. To convert from one to the other, click and hold the Pen tool to
display the flyout and choose the Convert Anchor Point tool. Then click
any object you created with the Pen tool and click an anchor point. If
you’re converting to a curve point, immediately drag to position the tan-
gent line handles.

Freely transforming and distorting shapes

For way-cool distortions and reshapings, use the Free Transform tool, with
its Distort & Envelope options. The Free Transform tool can work its magic
on objects, groups, instances, or text blocks. In addition to its special

ability to create distortions, it’s flexible enough to

move, rotate, scale, and skew objects. Flash has other — m— g B sy
tools that rotate, scale, and skew — we cover them B
later in this chapter.

To use the Free Transform tool, select an object,
symbol instance, group, or text block. (See Chapter 7
for more about symbols. We discuss groups later in this
chapter.) Click the Free Transform tool in the Tools

panel. The object displays a bounding box with handles
and a transformation point, shown as a circle at the Figure 4-11: We love the
center of the bounding box, as shown in Figure 4-11. Free Transform tool!

You can perform the following transformations on the selected object:

1 Move. Place the cursor on the object itself; when you see the four-
headed arrow, click and drag to move the selected object.
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1~ Set the center for rotation and scaling. Place the cursor on the transfor-
mation point; when you see the small circle, you can drag the circle at
the center of the bounding box to move the transformation point. The
transformation point is the base point used for the current rotation or
scaling operation.

~ Rotate. Place the cursor just outside any corner handle; when you see
the circular arrow, drag the object to rotate it around the transforma-
tion point.

Press Shift while you drag to constrain the rotation to 45-degree incre-
ments. Press Alt (Windows) or Option (Mac) while you drag to rotate
around the diagonally opposite corner from your cursor.

1~ Scale both dimensions. Place the cursor on any corner handle; when
you see the broken, two-headed arrow, drag inward or outward. Press
Shift while you drag to ensure that the object is scaled proportionally
without being distorted.

You can select as many objects as you want, and Flash scales them all.
When you select more than one object, Flash places the handles around
an imaginary bounding box that encompasses all the objects. Sometimes
you might not get exactly the result you want with this method, so check
carefully.

1~ Scale one dimension. Place the cursor on any side handle; when you
see the two-headed arrow, drag inward or outward to scale in the direc-
tion that you're dragging.

1~ Skew. Place the cursor anywhere on the bounding box except the handles;
when you see the parallel lines, drag in any direction. (We cover skewing in
more detail in the “Getting skewy” section, later in this chapter.)

In the following sections, you find out about the more exciting transforma-
tions that you can create with the Free Transform tool.

Tapering objects

You can turn a square into a trapezoid
by tapering. When you taper, you use
the Free Transform tool to drag a corner
handle. While you drag, the adjoining
corner moves an equal distance in the . . .
opposite direction, as shown in Figure
4-12. You can taper any shape except
rectangle and oval primitives.

Figure 4-12: Tapering turns a square into
a trapezoid.

111
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@ To taper, press Ctrl+Shift (Windows) or 8+Shift (Mac) while you drag on a
corner handle of the bounding box. You can also use the Distort option of the
Free Transform tool: Click the Distort button in the Options section of the
Tools panel and press Shift while you drag any corner handle. (This tech-
nique is ideal for people who have trouble pressing both Shift and Ctrl or 88
at the same time.)

Distorting objects

For even weirder effects, you can dis- i
tort shapes (objects) — but not primi- e‘ :
tives, symbols, symbol instances, text, !

or groups. When you distort an object,
you change the shape of the bound-
ing box, and the shape is stretched in
the same amount and direction as the  Figure 4-13: Drag the bounding box into a
bounding box, as shown in Figure 4-13. new shape; the object follows suit.

To distort shapes with the Free Transform tool, press Ctrl (Windows) or 38
(Mac) and drag either a corner or a side handle on the bounding box. To use
the menu, choose Modify=>Transformr>Distort.

Stretching the envelope

You can make even more refined changes in the shape of the bounding box
by using the Envelope command. With this option, the bounding box takes on
editing points like you see when you use the Pen tool. As you drag the points,
tangent lines appear, as shown in Figure 4-14.

.
7

& o
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,

e

Figure 4-14: The oval is like taffy when you push the envelope.

To use the Envelope command, select an object — a shape — but not a symbol,
instance, text, or group. Click the Free Transform button on the Tools palette
and then click the Envelope button in the Options area. (To use the menu,
choose Modify=>Transform=>Envelope.) Drag any of the points in or out and then
drag the end of any of the tangent lines to change the direction of the curve.

To end a free transformation, click anywhere off the selected object.
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Straightening lines and curving curves

Just like you can straighten and smooth strokes by using the Straighten and
Smooth modifiers of the Pencil tool, respectively, you can straighten and
smooth strokes and fills of existing objects. (See Chapter 3 for more about
the Pencil tool.)

You can activate the Straighten and Smooth modifiers repeatedly and watch
while Flash slightly reshapes your strokes or fills each time. Eventually, Flash
reaches a point where it can’t smooth or straighten anymore.

Choose Edit>Preferences and then choose the Drawing category to adjust
how Flash calculates the straightening and smoothing. Change the Smooth
Curves and Recognize Shapes settings.

To straighten a stroke, follow these steps:

1. Select the object.
It’s often useful to select several connected strokes.
2. Choose Modify=>Shaper>Advanced Straighten.

3. In the Advanced Straighten dialog box that appears, select the
Preview check box to see whether you like the result before closing
the dialog box.

4. Click the value to the right of the Straighten Strength text box and then
drag the slider upward. Release the mouse button to see the results.

5. Continue to try various strengths until you find the one that works
for you.

Flash straightens out curves and recognizes shapes, if appropriate.
6. Click OK to close the Advanced Straighten dialog box.
A simpler way to straighten an object is to select it with the Selection tool

active and repeatedly click the Straighten modifier button in the Options sec-
tion of the Tools panel.

Smooth softens curves and reduces the number of segments that create a
curve. To smooth a curve, follow these steps:

1. Select the object.
It’s often useful to select several connected strokes.
2. Choose Modify=>Shaper>Advanced Smooth.

The Advanced Smooth dialog box appears, as shown in Figure 4-15.
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W

3. Select the Preview check Advanced Smooth ==

box to see whether you like

¥ Smoath angle belovw:

the result before closing the R Smecth anelebelon: 4

dialog box. [ Smaoth angle above: 110
4. Click the value to the right of smoathing strenath:izy

the Smoothing Strength text [ Preview

box and then drag the slider

upward. Release the mouse Figure 4-15: Use the Advanced Smooth dialog

button to see the results. box to be a smooth operator.

5. If you want, adjust the angles,
above and below which the smoothing applies by entering angle values
in the Smooth Angle Below and Smooth Angle Above text boxes.

You can clear one of the check boxes (but not both) to restrict smooth-
ing to only below or only above a certain angle.

6. Continue to try various strengths until you find the one that works
for you.

7. Click OK to close the Advanced Smooth text box.

A simpler way to smooth an object is to select it with the Selection tool active
and repeatedly click the Smooth modifier button in the Options section of the
Tools panel.

Modifying line endings

You can use line caps to customize the ends of lines that you draw. (See the
section on setting the stroke type in Chapter 3 for details on caps.) You can
change existing line caps. You can also choose a join style for the meeting
point of two lines. Select a line and display the Property inspector. (Choose
Windowr>Properties.) Select a new option in the Cap or Join drop-down list.
You'll notice the effect more on wide lines.

Optimizing curves

Flash offers a technique for curves called optimizing. Optimizing reduces the
number of individual elements in a curve, thus reducing the size of your file
and resulting in faster download times on your Web site. You can optimize
repeatedly, just as you can with smoothing and straightening. Optimizing
works best for complex art created with many lines and curves. The visual
result is somewhat like smoothing but might be subtler.

To optimize, select the object or objects and choose Modify=>Shaper>Optimize.
Flash opens the Optimize Curves dialog box, as shown in Figure 4-16.
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As you can see in the dialog box, Optimize Curves =
you can specify an Optimization o

. Optimization Skrength: _OK
Strength to determine how much B
Flash optimizes curves. Select the [ show totsls message
Preview check box to see the result

without dismissing the dialog box. S

If you mangle your work too much

on the first try, undo it and try Figure 4-16: Optimize to reduce the number
again with a different setting. You of curves.

can select the Show Totals Message
check box to see how many curves Flash cut out and the percentage of opti-
mization that number represents. Click OK to close the dialog box.

Be careful to check the results after optimizing. Flash sometimes eliminates
small objects that you may want to retain. If you don’t like the results of
optimizing, choose Edit=>Undo.

Expanding and contracting fills

You can expand and contract shapes. Expanding and contracting works
best on shapes with no stroke (outline) because Flash deletes the out-
line when executing the command. If you want to expand or contract a
shape with a stroke, scale it. We explain scaling later in this chapter in the
“Scaling, scaling . . .” section. The advantage of expanding and contracting
is that you can specify a change in size in terms of pixels.

To expand or contract a shape, select it and Expand Fill B3
choose Modify=>Shaper>Expand Fill. The Expand Distance: (M | [ & ]
Fill dialog box appears, as shown in Figure 4-17. © Expand
Type a number in the Distance box, using the Dirsction; "' =P
units that you have set for the entire movie. By O fnset

default, movies are measured in pixels. (See the

section in Chapter 3 on drawing precisely for the Figure 4-17: The Expand Fill
details on setting movie units.) dialog box.

To expand a shape, select the Expand option. To contract a shape, select the
Inset option. Then click OK.

Softening edges

Softening edges is another shape-modification tool. You can soften edges
of a shape to get a graphic to look like you created it in a bitmap image
editor, such as Adobe Photoshop. Figure 4-18 shows some text before and
after its edges are softened. Note that adding softened edges can increase
your file size.
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Figure 4-18: Soften the edges of objects to create cool effects.

You can create this effect by breaking apart the text twice before softening
the edges. We discuss breaking apart objects later in this chapter; Chapter 5
explains more specifically about breaking apart text into editable shapes.

To soften edges, select the object or
objects and choose Modify=>
Shaper>Soften Fill Edges. Flash opens
the Soften Fill Edges dialog box, as
shown in Figure 4-19.

To soften edges, follow these steps:

1. Set the distance, which is the
width of the softened edge.

The distance is measured in
pixels unless you have changed

Soften Fill Edges ==
Distance:|4 P | | k. |
Mumber of steps:|4 | | Cancel |

Direction: (&) Expand
) Inset

Figure 4-19: Soften up your boss. . . uh,
graphics.

the document units. (See the section in Chapter 3 on drawing precisely for
information on setting the units in the Document Properties dialog box.)

2. Select the number of steps, which means the number of curves that
Flash uses to create the softened edge.

Try the Flash default first and change it if you don'’t like the result. You
can increase the number to get a smoother effect.

3. Select the Expand option to create the softened edge outside the

shape or the Inset option to create the softened edge within the shape.

4. Click OK to create the softened edge.

Your shape is still selected, so click anywhere outside it to see the
result. If you don't like it, press Ctrl+Z (Windows) or 8+Z (Mac) and try
again using different options.

You can also create soft edges by using gradients that blend into the Stage
color or with partially transparent colors. Chapter 3 explains more about
using colors. In addition, Flash has a blur filter that you can use on text,
movie clip symbols, and buttons. Chapter 7 describes filters.
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Converting lines to fills

Flash offers lots of great ways to fill a shape — for example, with gradients
and bitmap images. But what about those boring strokes or outlines? You can
convert lines to fills and make them fun, fun, fun. (See Chapter 3 for an expla-
nation of fills, including gradients and bitmap images.)

Mind you, there’s not much point in converting a line to a fill if it’s so thin
that no one would ever see a fill in it. Figure 4-20 shows some waves we cre-
ated by using the Pencil tool and a 10 point-wide line. We converted the line
to afill and then used the Paint Bucket tool to fill the line with a gradient.

Figure 4-20: Change the line to a fill and use the Paint Bucket tool to change the fill.

To convert a line to a fill, select the line and choose Modify=>Shaper>Convert
Lines to Fills. You don’t see any visible difference when you deselect the line,
but now you can change the fill to anything you want.

Transforming Fills

The Gradient Transform tool offers a unique way to edit gradient and bitmap
fills. You can perform the following changes to a fill:

» Move its center point.

1 Change its width or height.

1~ Rotate it.

1 Scale it.

v~ Tile it.

1 Change the radius of a radial gradient.

1 Move the focus of a radial gradient.

1~ Skew (slant) it.
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From this list, you can see that there’s no point in fiddling with solid fills. They
would look the same no matter what direction, size, or scale they were. (See the
section in Chapter 3 on colors for colorful coverage of gradient and bitmap fills.)

E To edit a fill, choose the Gradient Transform tool. This tool is well hidden;
you’ll find it by clicking (and holding) the Free Transform tool on the Tools
panel to open the submenu. Click any gradient or bitmap fill. Flash places an
editing boundary and editing handles around the fill. The editing boundary
varies with the type of fill — bitmap, linear gradient, or radial gradient, as
shown in Figure 4-21.

Bitmap Linear gradient Radial gradient

Figure 4-21: The Gradient Transform tool places an editing boundary around the fill.

After you have a fill with an editing boundary, you're ready to go ahead and
fiddle with the fills. Here’s how to make changes:

1~ Move the center of a fill. Drag the center point, marked by a small circle
at the center of the fill. You can move a center fill to move the center of
aradial gradient, move the stripes of a linear gradient, or place a bitmap
off center.

1~ Move the focal point of a fill. Drag the focal point, marked by a triangle
along the center line of a radial gradient. For example, moving the focal
point makes the apparent direction of light move from side to side in a
radial gradient with a lightly colored center.

1 Change the width of a fill. Drag the square handle on one side of the
editing boundary. To change the height of a fill, drag the handle on the
bottom of the editing boundary. If a fill doesn’t have one of these han-
dles, you can’t edit the fill that way. Changing the width of a linear fill
that’s perpendicular to the direction of its stripes is the same as scaling
the fill — the stripes get wider (or narrower).
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+~ Rotate a fill. Drag the rotation handle, which is a small circle just out-
side the corner of the editing boundary. On a radial gradient, use the
bottom of the three handles on the circumference of the boundary.

1~ Scale a fill. To scale a bitmap = =
fill, drag the circular handle at “‘J L""J ‘
the lower-left corner of the
editing boundary — inward
to scale down and outward
to scale up. To scale a radial
gradient, drag the middle
circular handle on the editing
boundary. Figure 4-22 shows a
bitmap gradient at its original

Figure 4-22: Scale a bitmap fill to make it larger

size and scaled down. Flash or smaller.
tiles the bitmap if you scale
down significantly.
QNING/ If you scale down a bitmap so that you see many tiles,
Ry the next time that you want to edit the bitmap, Flash

places an editing boundary around each tile so that you
have to edit each one individually. That could take a long
time! If you want to edit a bitmap in several ways, save
scaling down for last.

1~ Skew (slant) a fill. Drag one of the rhombus-shaped Figure 4-23:
handles on the top or side of the editing boundary. You Skew a bitmap
can skew only if the fill is a bitmap. Skewing is different fill for really

from rotating because the bitmap is distorted. Figure 4-23  weird results.
shows an example of a skewed bitmap.

Later in this chapter, we explain how to rotate, scale, and skew entire objects.

Transferring Properties

You can use the Eyedropper tool to copy stroke and fill properties from one
object to another. (See the section on bitmap fills in Chapter 3 for instruc-
tions on using the Eyedropper tool to create bitmap fills.)

To transfer properties, follow these steps:

(# 1. Click the Eyedropper tool.

2. Click an outline or a fill.

If you click an outline, Flash activates the Ink Bottle tool. If you select
a fill, Flash activates the Paint Bucket tool and turns on the Lock Fill
modifier. (For more information on the Lock Fill modifier, see the
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section in Chapter 3 that discusses locking a fill.) If you don’t want
a locked fill, click the Lock Fill modifier in the Options section of the
Tools panel to deselect it.

3. Click another outline or fill.

Flash transfers the properties of the original outline or fill to the new object.

Finding and Replacing Objects

One way to change an object is to change its properties. You can find graph-
ics objects by color or bitmap and then replace the color or bitmap. For
example, you can easily change every blue fill or stroke to red if your Web
color scheme changes.

You can find and replace according to color, bitmap, text, and font
(Chapter 5); sound; or video (Chapter 11). You can also find and replace
symbols (Chapter 7).

To find and replace objects, choose Edit>Find and Replace to open the Find
and Replace dialog box, as shown in Figure 4-24.

In the Search In drop-down list, choose to search in the entire Flash movie

document or only in the current scene. (See Chapter 9 for a full explanation
of scenes.)

HND AND REPLACE

Search in: [CurrantDﬂcumant ‘] [ Find Mext ]

e [ -]
Color: H
Replace all
Replace with:
Calor: H
Text
Fills
Strokes
[ Live edit

Matched Items Type

Scene 'Scene 1 -> Layer Layer 1 Shape Fill Color

Ready,

Figure 4-24: The Find and Replace dialog box finds lost sheep and
can change their color.
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In the For drop-down list, select what you want to find: text, font, color,

symbol, sound, video, or bitmap. The dialog box changes according to the

choice you make. For example, to find and replace a color, follow these steps:
1. Click Color from the For drop-down list.

2. Click the top Color button and select a color that exists in your
document.

3. Click the Replace with Color button and select the replacement color
that you want.

4. Mark one or more of the three check boxes — Fills, Strokes, and Text —
to define what type of objects you want to find.

5. Click Find Next to find the next occurrence of the color or click Find
All to find every object with that color.

6. Click Replace to replace the color of the currently selected object or
click Replace All to replace the color of every object.

7. Click the Close button of the dialog box to return to your movie.

Find and Replace is an efficient way to make mass changes of color, text,
symbols, sound, video, or bitmaps.

Transforming Objects

\\3

Earlier in this chapter, in the “Freely transforming and distorting shapes” sec-
tion, we explain how you can use the Free Transform tool to reshape objects.
You can do many of the same tasks by using the Transform command.

To scale, rotate, and flip objects, choose Modify=>Transform and then choose
one of the submenu commands. When you scale, rotate, or skew an object,
Flash kindly remembers the object’s qualities so that you can return the
object to the state it was in before you fiddled around with it.

Scaling, scaling . . .

Most of the time, scaling by using the Free Transform tool (as we describe
earlier in this chapter) is the easiest, fastest way to go. When you want more
precision, however, scale the selected object in the Property inspector.
Choose Window=>Properties. Change the value in the W (width) box, the H
(height) box, or both.

To make sure that the proportions of the object stay the same, click the
padlock next to the W and H values so that it looks locked. When you change
either the W or the H value, the other box adjusts proportionally.
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For yet more scaling options, select an

TRANSFORM

object and choose Window=>Transform
to open the Transform panel, as shown in - ose 4 1152% &= g
Figure 4-25. O Rotate
)
The controls in the Transform panel work & Slf; 0E
only if an object is selected. If you forgot |
to select an object, you don’t need to close 3D Ratation
the panel; just select an object. BRSO RRE @ e
3D Center poink
To scale the selected object or objects, ©HRE VR 2 Ad
click the Scale Width (left) value and type G

a scale value between 1 and 1000 and |
press Enter (Return), or drag the number
up or down to change its value. Any value
less than 100 reduces the size of the

object, so a value of 10 creates a new
object at 10 percent of the original object,
and a value of 1000 multiplies the object’s
size by a factor of 10. By default, the
Constrain icon is closed, meaning that
changing the width also changes the height.

Duplicate Selection and Transform
Remove Transformation

Figure 4-25: Use the Transform panel
to scale, rotate, and skew objects with
great precision.

To make a copy of an object at

a scaled size, click the Duplicate
Selection and Transform button (the
left button in the lower-right corner
of the panel) before scaling. The copy
appears on top of the original object
but is selected so that you can move
it immediately if you want. Figure 4-26
shows an example of how you can
use scaling and copying together to
create the impression of objects at
varying distances. After you make the
copy, just move it to a new location.
When you're finished, click the Close button of the Transform panel to close it.

Figure 4-26: The brain creatures are attacking!

To return the object to its original properties before transformation, click the
Remove Transform button at the lower-right corner of the Transform panel.

‘Round and ’round and ’round we rotate

Most of the time, you can probably use the Free Transform tool to rotate
objects, as we explain earlier in this chapter. If you want to rotate something
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by an exact number of degrees, such as 20 degrees, use the Transform panel.
Select the object and choose Windowr>Transform to open the Transform
panel. (Refer to Figure 4-25.)

To rotate the selected object or objects clockwise, type a value between

1 and 359, or drag the number up or down to change its value. To rotate
counterclockwise, specify a value between -1 and -359. Then press Enter or
Return.

If you don't like the results, click the Remove Transform button (in the lower-
right corner of the panel) and try again.

To make a copy of an object at a different rotation, click Duplicate Selection
and Transform (the left button in the lower-right corner of the panel) before
specifying the rotation. The copy appears on top of the original object but is
selected so that you can immediately move it.

If you want to rotate a section by 90 degrees by using the menu, do the
following:

1~ To rotate right (clockwise): Choose Modify=~>Transformr>Rotate 90° CW.

1~ To rotate left (counterclockwise): Choose Modify=> Transformr>Rotate
90° CCW.

When you rotate, Flash rotates the object around its center. To rotate around
a different point on the object, you can convert the object to a group or
symbol and change its registration point, the point on an object that Flash ref-
erences when rotating. See the section later in this chapter on changing the
transformation point, which also discusses registration points.

You can create groovy circular patterns
by using the rotate and copy functions,
as shown in Figure 4-27. Unless the
object you're working with is completely
symmetrical, you need to change the
registration point.

Getting skewy

Skewing is a variation of rotating. Rather
than rotate an entire object, you slant it
horizontally, vertically, or both. Skewing
a square creates a rhombus (diamond).
In Figure 4-28, you see a simple arrow
before and after skewing.

Figure 4-27: Rotate and copy an object
at the same time to add flower power to
your site.
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Figure 4-28: A skewed arrow looks like it's in a hurry.

The easiest way to skew objects is by using the Free Transform tool. Just
select an object, choose the Free Transform tool, and drag along one of the
sides of the boundary.

Usually, you can eyeball the skewing process. If you want precision or to
combine skewing with scaling, use the Transform panel. Select the object
and choose Windowr>Transform to open the Transform panel. To skew the
selected object or objects, click the Skew option.

Use the left box to skew horizontally. To skew clockwise, click the current
value and then either type a value between 1 and 89 or drag up. To skew
counterclockwise, click the current value and then either type a value
between -1 and -89 or drag down. Then press Enter or Return.

To skew vertically, click the current value and then either type a value in the
right box or drag up or down. Positive values skew clockwise, and negative
values skew counterclockwise. If that sounds confusing, just try something
and see whether you like it. If you don’t, click Remove Transform (the button
in the lower-right corner of the panel) and try again.

To make a copy of an object at a skewed angle, click the Duplicate Selection
and Transform button (the left button in the lower-right corner of the panel)
before starting the skewing operation. The copy appears on top of the origi-
nal object but is selected so that you can move it immediately.

Flippety, floppety

Flipping reverses an object so that you have a mirror image of your original
object. You can flip both horizontally (left to right or vice versa) and verti-
cally (up to down or vice versa). Flash flips objects about their center so that
they stay in their original position on the Stage.
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Figure 4-29 shows a curlicue design in its original form, flipped horizontally
and flipped vertically. If you flip an object horizontally and then vertically,
you end up with an object that has been mirrored in both directions.

=D G

Original Flipped vertically
Flipped horizontally Flipped both horizontally

and vertically

Figure 4-29: You can flip objects vertically, horizontally, or both.

To flip an object, select it and choose Modify=>Transform=>Flip Vertical or
Flip Horizontal. To flip an object in both directions, flip it in one direction and
then in the other.

To create symmetrical objects, you need to change the object’s registra-
tion point from the center to one side or corner. Later in this chapter, in the
“Changing the Transformation Point” section, we explain how to use flipping
to create symmetrical objects.

Combining Objects

WMBER
@ﬁ
&

You can combine objects in various ways to create new and more interesting
shapes. You can perform the following actions:

+~ Union: Combines two objects into one object. The effect is similar to
grouping objects, which we cover in the next section of this chapter. (In
fact, you can use the Ungroup command to separate the objects again.)
Combining two objects puts a boundary around them, like the boundary
you see when you use the object-drawing model. To combine objects,
select them and choose Modify=>Combine Objects=>Union.

See the section on keeping objects safe and secure in Chapter 3 for more
information on how to use the object-drawing model.
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+~ Intersect: Creates a shape that is the
intersection of two overlapping shapes;
the shape that remains is from the
top object, as shown in Figure 4-30.
However, this works only with objects
that you create by using the object-
drawing model. (We explain the object-
drawing model in Chapter 3.) To inter-
sect objects, select them and choose
Modify=>Combine Objects=Intersect.

Figure 4-30: A quarter-circle is all
that's left after using the Intersect
~ Punch: Removes the object on top feature.
from an object beneath it. This opera-
tion requires two objects that you drew by using the object-drawing
model. If you put a smaller circle on top of a larger circle, the Punch
feature is like punching a hole in the larger circle (but it doesn’t
hurt). Select two overlapping objects and choose Modify=>Combine
Objects=>Punch.

1 Crop: Creates a shape that is the intersection of two partially over-
lapping shapes that you created by using the object-drawing model;
removes any part of the bottom object that extends beyond the
shape of the top object. Select two overlapping objects and choose
Modify=>Combine Objects=>Crop.

Getting Grouped

When you know how to create objects, you can get carried away and create
so many objects on the Stage that they’re hard to manage. You might want
to move a number of objects at once. Although you can select them all and
move them, that technique might not be enough. For example, you might
inadvertently leave behind one piece and discover that it’s hard to move that
piece in the same way that you moved the rest. That’s why Flash provides
grouping. You select multiple objects and group them once. From then on,
you can select them with one click. If you move one of the grouped objects,
the rest come along for the ride.

In Flash, grouping has an additional advantage: If you put objects on top

of each other, they merge if they’re the same color, or they create cutouts

if they’re different colors, unless you draw them using the object-drawing
model or a primitive shape. One way that you can avoid such friendly behav-
ior and keep the integrity of objects is to group them. (You can also put them
on different layers, as we explain in Chapter 6, or you can turn them into sym-
bols, as we explain in Chapter 7.)
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Grouping objects is easy. Select them and choose Modify=>Group. You
shortcut types can press Ctrl+G (Windows) or 8+G (Mac). When you group
objects and select them, all the objects are surrounded by one blue selection
border.

After you group objects, you can ungroup them at any time. Select the group
and choose Modify=>Ungroup. You can also break apart a group. See the dis-
cussion later in this chapter on breaking apart objects.

If you want to edit an element of the group without ungrouping first, Flash
lets you do so. To edit without ungrouping, follow these steps:
1. Using the Selection tool, double-click any object in the group.

Flash dims other objects on the Stage and displays the Group symbol
above the Stage.

2. Edit any of the group components.
You'll probably have to deselect the objects that you don’t want to edit.
3. Return to regular editing mode.

Double-click any blank area with the Selection tool, click the current
Scene symbol to the left of the Group symbol, or click the Back arrow to
the left of the scene symbol.

Changing the Transformation Point

When Flash rotates or scales an object, it uses a transformation point as a
reference. This point is generally the center of the object. For positioning and
certain transformations of lines and shapes, Flash uses the upper-left corner.
You might find that the point Flash uses isn’t suitable for your needs. For
example, you might want to rotate an object around its lower-left corner. For
a single rotation or scaling of a simple graphic object, use the Free Transform
tool and drag the transformation point — the little circle — to the desired
location. If you deselect and reselect the object, you see that the circle has
returned to its original central position.

Changing the transformation point is useful when you want to create sym-
metrical objects by flipping. To use flipping to create symmetrical objects,
follow these steps:

1. Select the object.

2. Click the Free Transform tool and drag the transformation point to
one edge of the object, from where you want to mirror the object.
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3. Choose Edit=>Copy to copy the object to the Clipboard.
4. Choose Edit=>Paste in Place to paste the copy on top of the original.
5. Choose Modify~> Transformr>Flip Vertical or Flip Horizontal.

You see your original and the copy. The copy has been flipped so that
it’s a mirror image of its original.

6. (Optional) To create a four-way symmetrical object, group the origi-
nal and mirrored objects (as we explain in the previous section) and
change the transformation point to one side of the combined group.
Then repeat Steps 3, 4, and 5, this time flipping in the other direction.

Figure 4-31 shows a weird creature created by copying, changing the
transformation point, and then flipping.
The straight lines assist in placing the
transformation point accurately.

Groups, symbol instances, text, and
bitmaps have a registration point, which
Flash uses to animate and transform these
objects. When you use the Free Transform
tool to move the circle on these objects,  Figure 4-31: Create scary, symmetrical
the circle keeps its position even after creatures by manipulating the

you deselect and reselect it. To move transformation point.

registration point, follow these steps:

1. Select a group, symbol instance, text object, or bitmap.
2. Click the Free Transform tool.

Flash displays a small circle at the transformation point.
3. Drag the circle to the desired location.

4. Click anywhere else on the Stage to hide the registration point.

To return the registration point to its original position, double-click it.

Breaking Apart Objects

With the Break Apart command, you can break apart text, groups, instances
of symbols, and bitmaps into separate objects that you can edit individu-
ally. To break apart one of these types of objects, select it and choose
Modify=>Break Apart.
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What happens to your objects when you break them apart? Do they splatter
all over the Stage? Here’s what happens when you break apart the following
objects:

1~ Text: Flash divides the words into individual letters, each one a separate
object. If you use the Break Apart command a second time on one of the
letters, the letter becomes a shape that you can modify like any other
shape.

<P Break apart blocks of text and then choose Modify=>Timelinesw>
Distribute to Layers to animate individual letters. See Chapter 5 for more
information about text and Chapter 6 for more on layers.

1~ Shapes created in the object-drawing model: The shape loses its
object-drawing model status, as if you had drawn it without using the
object-drawing model.

* Groups: Flash breaks up the group into its component parts. The result
is the same as ungrouping.

1~ Instances of symbols: The symbol becomes a shape. (Symbols are cov-
ered fully in Chapter 7.)

v~ Bitmaps: Flash converts the bitmap to a fill. You can then erase parts
of it.

Establishing Order on the Stage

Flash stacks objects in the order in which you create them. If you draw a
circle and then an overlapping square, the square looks like it’s on top of the
circle because you created it more recently.

If you place an object on top of another object, the two objects become one if
they’re the same color. If they're different colors, the top object cuts out the
underlying object.
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One exception is if you use the object-drawing model to draw the objects.
Oval and rectangle primitives are another exception. A different way to
keep the integrity of objects is by grouping them or turning them into sym-
bols. (Symbols are covered in Chapter 7.) Groups, object-drawing model
shapes, primitives, and symbols are always stacked on top of regular
objects. Therefore, to move objects above existing groups or symbols, you
need to group them or convert them to a symbol. You might also need to
turn some imported graphics into a symbol or group before you can move
them in the stack.
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If you draw an object and it immediately disappears beneath another object,
it’s often because you tried to draw the object on top of a group, primitive, or
symbol. Group the object or change it to a symbol if it must be on top.

Another way to reorder objects is to put them on different layers. You can
then reorder the objects by reordering their layers. (See Chapter 6 for the
details.)

As long as you have objects that can maintain their
integrity, you can change their stacking order. You
can move them up or down in the stack or from the
top or bottom of the stack — all within the same
layer. To change the stacking order of an object,
select the object and choose Modify=>Arrange. Then
choose one of these options:

+~ Bring to Front: Brings the selected object to
the tippy-top of the stack.

1~ Bring Forward: Brings the selected object up
one level.

 Send Backward: Moves the selected object
down one level.

+~ Send to Back: Sends the selected object
down, down, down to the bottom of the

stack.
Figure 4-32: The big, old-
Figure 4-32 shows an example of two objects fashioned bitmap star and the
stacked in different ways: a big bitmap star and a  small, up-and-coming vector
small vector star. star vying to be in front.

Undoing, Redoing, and Reusing

Sometimes you do something in Flash and decide that it’s a mistake. Oops!
For this situation, you can undo actions. You can even redo the actions that
you undid. Finally, if you're environmentally conscious, you can reuse earlier
actions to avoid wasting any more of your energy.

Undoing actions

To undo your last action, choose Edit=>Undo or press Ctrl+Z (Windows) or
#8+Z (Mac). You can continue this process for a very long time. This is the
familiar — and default — type of undo, and Flash calls it document-level undo.
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To set the number of undo steps that Flash remembers, follow these steps:

1. Choose Edit=>Preferences (Windows) or Flash=>Preferences (Mac).

2. In the Preferences dialog box that appears, click the General category.
3. From the Undo drop-down list, select Document-Level Undo.
4.

In the text box just below the Undo drop-down list, enter the number
of undo actions you want Flash to track.

The default is 100, and the allowable range is from 2-300.

Later in this chapter, in the “Reusing actions with the History panel” section,
we explain another way to undo actions.

Redoing actions

Maybe you were right the first time. After you undo an action, suppose that
you want to redo it. You can do that, too. To redo actions, choose Edit=>Redo
or press Ctrl+Y (Windows) or 38+Y (Mac).

If you haven’t undone anything, you can use the same command (and key-
board shortcut) to repeat your last action, in which case it’s called the
Repeat command.

Using object-level undo and redo

Generally, undos and redos apply to every action you take in Flash. But some-
times you might find object-level undo and redo more helpful.

Object-level undo applies only to editing symbols, which we cover in
Chapter 7. When you use object-level undo and redo, Flash remembers
actions by symbol. Therefore, when you’re editing a symbol, using the
Undo command applies only to changes that you made to that symbol,
even though you have made other changes to your movie in the mean-
time. If you use a lot of symbols, object-level undo offers you more flex-
ibility. Object-level redo works in the same way.

You can use only one type of undo and redo at a time. To use object-level
undo and redo, choose Edit=>Preferences (Windows) or Flashr>Preferences
(Mac). Select the General category. In the Undo drop-down list, select Object-
level Undo. You see a message explaining that switching from one type of
undo to another will delete your current undo history. Flash can keep track
of only one stream at a time. Click OK to close the message and click OK
again to close the Preferences dialog box.

Deleting your current history is not generally a problem. But if you are in
the middle of a long, complicated experiment and might need to undo many
steps, choose another time to switch.

131



’32 Part II: 1,000 Pictures and 1,000 Words

Reusing actions with the History panel

If you make several changes to an object and would like to make the same
changes to other objects, you can save time and increase accuracy by saving
and reusing the steps for the operations that you perform. Flash tracks the
steps in the History panel.

The History panel lists every command that =
you perform in Flash during one session. When s

you save and close the file, the history list isn’t %1 Scale y

saved for the next time. Choose Windowr>Other g?lﬁ'et ]
. . 3 22leck Layers
Panels=>History and the History panel appears, T Change TUF Text

as shown in Figure 4-33. The shortcut is Ctrl+F10
(Windows) or 8+F10 (Mac).

&3 5et TLF Paragraph Format
k Change Selection

k Maove |_|
You can use the History panel to troubleshoot | select none s
recent steps, repeat steps, undo steps, or save renlay B

steps as commands for future use.

By default, Flash records up to 100 steps in the ~ Figure 4-33: The History panel
History panel. You can change the number of keeps track of everything you do.
steps recorded by choosing Edit=>Preferences

(Windows) or Flash=>Preferences (Mac) to open the Preferences dialog box.
On the General tab, change the value for Undo levels. If you want to be able
to go back and save earlier steps as commands, you probably need to record
more than the default 100 steps.

Undoing steps

One of the simplest things that you can do in the History panel is to undo one
or more operations. You can also undo operations by choosing Edit>Undo,
but you can see more specific descriptions of the operation. For example,

the Move operation appears in the History panel as Move {x:0, y:~103.6}. To
view the specifics, right-click (Windows) or Control-click (Mac) any history
item and choose Vieww>Arguments in Panel. With these details, you can more
easily predict the result of undoing an operation.

You undo steps by using the slider on the left side of the History panel:

+~ Undo the last operation that you performed. Drag the slider up one step.

~ Undo several steps. Drag the slider to the step above the first step that
you want to undo. For example, if you want to undo three steps, drag the
slider up three steps — it’s now next to the step previous to the one that
you undid. This is the last step that has still been executed. You can also
click to the left of a step, along the slider. The slider scrolls up to that
step and undoes all the later steps.
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When you undo a step, the step appears dimmed in the History panel.

Replaying a step

You can repeat any command from any time during a Flash session. For
example, if you filled an object with a specific color, you can fill another
object with the same color, even if you have performed other operations in
the meantime.

To replay a step, click the step itself (not the left side of the step along the
slider) in the History panel. Then click the Replay button. (You can’t replay
every step; such steps display a red X. If the Replay button is not active when
you click a step, you can’t replay that step.) If you want to replay the step on
a different object, first select that object, and then click the Replay button.

Copying steps
You might want to keep a list of certain steps or use them in a different

movie. Select one or more steps in the History panel and click the Copy
Selected Steps to the Clipboard button.

To use these steps in another Flash movie, open the movie and choose
Edit=>Paste in Center. To apply the steps to an object, select the object first.

Flash copies the step or steps as JavaScript code. Therefore, when you
paste the step or steps into a word processor or text editor, you see the
JavaScript code, which looks more complex than the step listed in the
History panel. Usually, you can figure out what it means, even if you don’t
know JavaScript. For example, Fi1l1l Color: '#0000£f£f' appears as
fl.getDocumentDOM () .setFillColor ('#0000£ff") ;.

Saving commands

If you want to save a step or set of steps to use the next time that you open the
movie, save a command. Saving a command is even useful if you want to re-
execute some steps several times later in the same session because scrolling
back to find the exact steps that you want to reuse can be time consuming.

To save a command, follow these steps:

1. In the History panel, select the steps that you want to save.

You can drag along the step names (not along the left side, where the
slider is). You can also use the usual methods of selecting multiple
objects in a list. Click the first object, press Shift and click the last, or
press and hold Ctrl (Windows) or 88 (Mac) and click each step that you
want to select.
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To see more details about the commands, click the Options menu button
(in the upper-right corner of the panel), and choose Viewr>Arguments in
Panel.

2. Click the Save Selected Steps as a Command button.

This button is in the lower-right corner of the History panel. The Save as
Command dialog box opens.

3. Enter a name for the command.

You can simply summarize the steps. For example, you might name a
command £i11 blue, rotate 90.

4. Click OK to close the dialog box.

hanage Saved Cormmands..

Get More Commands..,

When you save a command, it appears on the
Commands menu. The menu in Figure 4-34
shows the command Fill blue #99ffff,
which fills any selected shape with blue. To use

Run Command...

Copy Font Mame for ActionScript
Copy Motion as XML
Export Motion XML

that command, you simply select a shape and Fill blue #93fFF

then choose Commands=Fill blue #99ffff. Presto! Import Mation Xk

It’s all finished. As you can imagine, you can

combine complex commands and save them Figure 4-34: Saved commands
to automate the authoring process of creating appear on the Commands menu.

Flash movies.

Clearing the History panel

If you don’t want the History panel to record everything that you do — perhaps
it makes you feel as if you don’t have any privacy left anymore — you can clear
the history list. Clearing the history list doesn’t undo any steps. To clear the
History panel, click the Options menu button at the upper-right corner of the
panel and choose Clear History. Then click Yes.

For good Commands menu housekeeping, choose Commands=>Manage Saved
Commands to open the Manage Saved Commands dialog box. In this dialog
box, you can delete or rename a selected command. When you're finished,
click OK to close the Manage Saved Commands dialog box.
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What's Your Type?

In This Chapter

Creating, editing, and formatting text

Using cool text effects

LVe assume that occasionally you want to say something on your Web
site, so this chapter covers text in all its forms and formats. You can

use Flash to create the text for your Web pages if you want (although you
don’t have to). But if you want flashy text effects, Flash is definitely the way
to go.

Typography is the art or process of arranging text on a page, and basically
that’s what this chapter is all about. Many graphics programs call text type. We
use the words interchangeably here — we don’t care what you call it.

. Gragose with
Presenting Your Text e
The majority of text on most Web sites is formatted SRTEEES Ol
by using HyperText Markup Language (HTML) and IIpTrETEs” (
Cascading Style Sheet (CSS) coding to set the font, f
size, and color of the text. Using HTML and CSS Grow your brain i
code ?s id‘eal for larger amounts of text b(?cause the with our brain Fﬁﬂ:
code is fairly easy to create and loads quickly. teasers! ﬂ e‘
For smaller amounts of text that you want to have . Unravel haﬂ:""g g
special formatting or effects, Flash offers more “iddles, and cut your ¢
options than HTML. Of course, if you want to animate =th on curious
your text, you can use Flash. For example, an animated wdrums!

logo usually includes not only the graphic art but also the
name of the organization, which is, of course, text.
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Here are some innovative things you can do with text:

1 Rotate, scale, skew, or flip text without losing the ability to edit the text.

v Turn text into shapes and modify them any way you want. However,
after you turn text into shapes, you can’t edit the text characters by
simply typing. Figure 5-1 shows some text that was modified this way.

1~ Create transparent type.

)
1~ Create hyperlinked text that sends the user’s s "I’ I n g

browser to another Web page when the user

clicks the text.

Figure 5-1: You can turn text
into a shape and modify it to
your heart’s content.

~ Enable viewers to control some aspect of the
movie by entering text in a text box.

1~ Load text, such as sports scores or current
weather, dynamically from a server.

1~ Connect text in two text blocks so that the text flows automatically from
one to the other.

Creating text

Creating text in Flash, using the default settings, is simple. Follow these steps:

T 1. Click the Text tool on the Tools panel.
2. Specify the text starting point on the Stage.

e To specify the width of the text, click the Stage on the left edge
where you want your text to start and then drag to the right to
the width that you want. Flash places a square block handle in the
upper-right corner of the text block.

e To create a text block that expands while you type, just click the
Stage at the desired starting point. Flash places a round block
handle in the upper-right corner of the text block.

3. Start typing.

To force a return to the left margin after you type one or more lines,
press Enter or Return. Otherwise, if you specified a width, the text wraps
to the next line when it fills up that width.

4. After you finish typing, click anywhere off the Stage to deselect the text.

If you got long-winded, you might not see all of your text because the
text block isn’t high enough. Use the top or bottom handle to drag out-
ward and increase the text block’s height until you can see everything
you typed.
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Congratulations — you just said something! We hope it was worthwhile.

Editing text

After you type text, it never fails that you want to change it. Editing text is easy
in Flash, but you first have to select the text. Here are the selection techniques:

1 To edit an entire text block: Click the Selection tool and then click the
text. Flash places a selection border around the text. You can move,
rotate, and scale all the text in a text block this way, just like you would
with any other object. For example, you can use the Free Transform tool
to scale the text.

1 To edit the content of the text itself: Double-click the text with the
Selection tool active. (Or click the Text tool and then click the text.)
Flash switches to the Text tool automatically and places the text cursor
where you clicked or double-clicked the text, more or less.

1~ To select a character or characters individually: Click the Text tool and
drag across one or more characters. Do this when you want to edit only
those characters.

1~ To select a word: Click the Text tool and double-click any word to select it.

1~ To select a string of words or block of text: Click the Text tool, click at
the beginning of the text you want to select, and then Shift-click at the
end of the desired selection.

1~ To select all the text in a text block: Click the Text tool, click in a text
block, and then press Ctrl+A (Windows) or 8+A (Mac).

To change the content of the text, select the characters or words that you
want to change, as we explain in the preceding list. Type to replace the
selected text. Other text-editing techniques are the same as in your word pro-
cessor. For example, you can press the Delete key (Windows) to delete char-
acters to the right of the text cursor or press the Backspace key (Windows)
or Delete key (Mac) to delete characters to the left of the cursor.

Checking spelling
Spell checking works like the spell checker in your word processor, so you'll

probably find it easy to use. This feature shows Adobe’s commitment to
reducing typos on the Web!

The first step is to set up the parameters for spell checking. Choose Text=
Spelling Setup to open the Spelling Setup dialog box, as shown in Figure 5-2.
If the Check Spelling item isn’t available on the Text menu, you need to open
this dialog box and close it again.
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The Spelling Setup dialog box has
three sections:

* Document Options: Choose

which parts of a movie that you
want to check. For example, you

may not want to spell check
symbol and bitmap names.

~ Personal Dictionary: You can
change the location of the file
that holds words that you add

to the dictionary. Click the Edit

Personal Dictionary button to

add words directly. Otherwise,

you add words when you are

checking the spelling of specific

text.

1 Checking Options: Set options
that define how spell check-
ing works. For example, you
can choose to ignore words in
uppercase or with numbers.

You can also choose which language

dictionaries you want to use in the
Dictionaries list (in the upper-right
corner of the Spelling Setup dialog
box).

Spelling Setup
Document options
[ Check kext fields content
[ Cherk scene and layer names
[ Check Frame labels/comments
[ Check strings in ActionScript
[ Cherk symbolfbitmap names
[ Check current scene onlby
[ Check single letter text Fields
[ Shiaw in Mavie Explorer panel

[ select ket on stage

Personal dickionary

Dictianaries

M adobe

[¥ American English

[ Brazilian Portuguese

[ Eritish English

[ Canadian

[] catalan

[ Danish

[ Dutch

[ Finnish

[ French

[ German (Classic Spelling)
[ German (Mew Speling) —
[] Therian Partuguese
[ Italian

D

Path:lC:\UserleIIenlAppDataanaming\Adnbe\Cnmmnn\Persnl‘l [

Checking options
[ Ignore non-alphabetic words

[ Ignare words with numbers

[ Ignare words in UPPERCASE

[ lanore possessives in words

[ Tlgnare internetifile sddresses

[ Ignore words with MIxedCasE

[ Tgnare First letter capped words

Edit Personal Dickionary

[ Find duplicats words

[ Split contracted words

[ 5plit hyphenated words

[ split words (Getman, Finnish)
[ suggest split words

[ Suagest phonetic matches

[ suagest typographical matches

Figure 5-2: Use the Spelling Setup dialog box

to specify how spell checking works.

When you're finished, click OK to return to your movie. You're now ready to

check spelling.

To check spelling, you can select text if you want to check just that text, or

leave all the text deselected to check

the entire movie. Choose Textw>
Check Spelling to open the Check
Spelling dialog box, as shown in
Figure 5-3.

If you selected text, Flash checks

that text first and then asks whether

you want to check the rest of the
document. Click Yes to continue or
click No to end the spell check. For
each misspelled word, you can do
one of the following:

Check Spelling =
‘word nok Found {text field):
[1s & B world out there! | [ addtoPersonal |
Change to:[aroovy | [ Ignare ]
Suggestions: | groowy [~ Ignare Al
qoofy
-
goony
goosy Change Al
gooey
N !

Figure 5-3: The Check Spelling dialog box.
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1 Choose one of the suggestions and then click Change to change that
instance of the word.

1 Choose one of the suggestions and then click Change All to change all
instances of the word.

v~ Click Ignore to go to the next misspelled word.

1~ Click Ignore All to ignore all instances of that word and go to the next
misspelled word.

1~ Click Delete to delete the word.
v Click Add to Personal to add the word to the Personal Dictionary so that
it won’t appear as misspelled in the future.

To finish spell checking, click Close. You may see a message (before or after
you choose Check Spelling from the menu) asking whether you want to start
from the beginning of the document. Click Yes to do so. When spell checking
is complete, you see a Spelling Check Completed message. Click OK to return
to your movie.

Finding and replacing text
If you need to change all instances of the word big to large, for example, you're
in luck. The Find and Replace feature comes to the rescue. In Chapter 4, we
discuss how to find and replace color. Here we explain the steps (which are
similar) for finding and replacing text:

1. Choose Edit~>Find and Replace.

The Find and Replace dialog box appears.

. In the For drop-down list, choose Text.
. In the Text box, enter the text that you want to find.

. In the Replace with Text box, enter the replacement text.

1 = W N

. (Optional) Enable one or more of the three check boxes on the left to
define what type of text you want to find: Whole Word, Match Case,
and Regular Expressions.

Regular expressions are formulas you use to locate specific text patterns
in a text string. Regular expressions are beyond the scope of this book,
but you can find a good tutorial at www.regular-expressions.info/
tutorial.html.

6. (Optional) Select one or more of the check boxes on the right to define
where you want Flash to look for text.

e Text Field Contents searches text objects.

e Frames/Layers/Parameters 1ooks for frame labels and scene names
(see Chapter 9), layer names (see Chapter 6), and component
parameters (see Chapter 10).
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e Strings in ActionScript looks for text in ActionScript.
e ActionScript looks for all ActionScript code.
7. To edit each object on the Stage, select the Live Edit check box.

Flash highlights the text on the Stage and you type the replacement text
there.

8. Click the appropriate button as needed:
¢ Click Find Next to find the next occurrence of the text.
e Click Find All to find all occurrences of the text.
e Click Replace to replace the currently selected object.

e Click Replace All to replace all instances of that text.

When Flash finds the specified text, the box at the bottom of the Find and
Replace dialog box displays its location and type along with the entire text so
that you can see the context of the text you're replacing. You can resize the
Find and Replace dialog box as well as the columns in the list of found items.
When you're finished, click the Close button in the Find and Replace dialog
box to return to your movie.

Setting text attributes

Of course, you don’t always want to use the Flash default font and size for
your Web site. Boring! You can set the attributes before you start typing
or edit the attributes of existing text. To edit existing text, double-click the
text block and then select the characters or words you want to format.

To either set or edit attributes of text, display the Property inspector
(Windowr>Properties).

Text Layout Framework (TLF) text offers many cool features that you don’t get
with Classic text, the text that Flash used before TLF. For details, see the fol-
lowing discussion. We note where the settings differ for the two types of text.

Figure 5-4 shows the Property inspector when some TLF text is selected. The
Property inspector changes slightly, depending upon which type of text you
select.

Specifying the type of text

At the top of the Property inspector is the Instance Name text box. An
instance name identifies the text object so that you can refer to the text in
ActionScript. (See Chapter 10 for the scoop on ActionScript.) Instance names
are handy because the contents of the text field can change while your Flash
movie is playing. However, if you give your text field an instance name, you
can always refer to it in your ActionScript even though you don’t know the
contents of the text field ahead of time.
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Text engine
PROPERTIES
[<Instance Mame> |
[TLF Text —t——+—Text type
[ Selectable | v-|J —Text
e ARACTER <| orientation
Family: |Verdana | v I Font famlly
Font style — Style: [Eold [=][ Embed... | Embed fonts
Font size — Size: 14,0pt  Leading: 143 [ % [+ Leading (line spacing)
Font color — color: [l Tracking: 0 Tracking (horizontal spacing)
Highlight color ———— Highiight: ™ futo kern Kerning
Anti-aliasing Anti-alias: | Readabilty Ix]
Character rotation ———retation: [ Auta I»] [Z][E][T]]

Hyperlink —

Word breaking ——

Paragraph alignment —
Left (Start) margin —
First line indentation —

Spacing before —
paragraphs

Maximum characters
for Editable/Input text —
Number of columns —
Text block padding—

Text block border —

=7 ADYANCED CHARACTER

— Link: |

Targek:

Underscore, Strikethrough,
Superscript, and Subscript

Case: | Diefault

Digit: Case: | Default

Digit Width: | Default

Ligatures: | Cornrman

Hyperlink target

Break: | Auko |v |
Baseline Shift: 0,0 pt | > ||
Locale: | English |« |
=7 PARAGRAPH
algn: [ E =] =] Last line alignment
— Margins: 4 0,0px nght (End) margin
Indent: "= 0.0px .
Spacing: T2 0,0px A= 0.0px SpaCIng after
paragraphs
Text Justify: | ‘Word spacing | I Full justification
= CONTAINER AND FLOW method
Biehavior: | TMultiline no wrap [ I Multiline text flow
s chars: BE=== Vertical justification
Columns: [[T] B - o Column gutter width
Padding: L: 2.0px R 2.0px
{ € 1 z0px B: 2,0px
J Pt & [ Text block fill

Ist Line Offset——istLine Offset: [ Auto

(from the top
of the text block)

[

Figure 5-4: The Property inspector is the place to liven up your text.
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The Instance Name text box disappears if you choose Classic Text from the
Text Engine drop-down list just below (described next) and then choose

Static Text.

The Text Engine drop-down list has two options, TLF Text and Classic Text.
You get great extra features with TLF text, but you may want to use Classic
text for a while to maintain compatibility with older versions of the Flash

player. Only Flash Player 10 and later can display TLF text properly.

The next item is the Text Type drop-down list. (It’s a good thing the Flash

creators didn’t call it the Type Type drop-down list.) This list offers different
options for TLF and Classic text, but the results are similar:

1 TLF Text Type drop-down list: Specify how the text will function on a
Web site. You can create three types of TLF text:

e Read Only: To disallow any interaction with the text, choose Read-
Only. You would use this option when you simply want users to
read the text, not to select and copy, or change it.

e Selectable: If you want users of your Web site to be able to select
text and copy it to the Clipboard, make the text selectable. If you're
providing data from an external source (such as a Web server) or
an internal source (such as ActionScript), you might want users
to be able to select and copy the text to use elsewhere. Selectable
text is often used for data such as sports scores, current weather,
and stock prices.

e Fditable: You want users to be able to edit the text. Normally, you
would add some ActionScript that would interact with the text that
users type. For example, typing a color might change the color of
an image.

1~ Classic Text Type drop-down list: You can create three types of Classic
text:

e Static text: Regular text that doesn’t change or do anything
although you can animate it. (This is like the Read Only option for
TLF text.)

e Dynamic text: Text that changes based on available data. (This is
like the Selectable option for TLF text.)

e Input text: Text that viewers can edit. You can use input text, for
example, for forms and surveys or to interactively create values
that affect the movie. (This is like the Editable option for TLF text.)

For Classic text, you can separately use the Selectable button at the bottom of
the Character section of the Property inspector to make the text selectable.

The last item in the top section of the Property inspector is the Change
Orientation of Text drop-down list, from which you can choose from Horizontal
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or Vertical (ideal for certain Asian languages), as
shown in Figure 5-5.

Formatting text with good character

The Character section of the Properties inspector
doesn’t make sure that what you write reflects
your good character, but it can make your char-
acters look good. To choose a font for selected
text, choose from the Family drop-down list, which
helpfully provides a sample of the font. Some fonts
also let you choose a style from the Style drop-
down list: Regular, Italic, Bold, or Bold Italic.

Click the Embed button to open the Font
Embedding dialog box. You embed fonts to make
sure that they’ll show up properly even on com-
puters that don’t have the fonts you use.
Embedding fonts is not new, but this new dialog
box makes it easier to embed the fonts you need
for your entire movie.
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Figure 5-5: Try vertical text
for a change of direction.

On the left of the Font Embedding dialog box, click the Add button to add
fonts, or click the Minus button to delete selected fonts from the list. On the
right, you can give fonts easy-to-remember names and specify whether to
include the entire font (all characters) for a selected font or only a subset (to
reduce the size of your file). Click OK when you're done.

Also in the Character section of the Property inspector, you can change sev-

eral important font settings:

v~ Size: Click, type a font size, and press Enter, or drag the slider to the

desired value.

1 Leading: Leading (rhymes with head-ing) is line spacing. To change the

leading, click and enter a new
value or drag the slider. To the
right, you can use the drop-
down list to specify leading by
percent (%) or points (pt). The
value you specify affects an
entire line of text, even if you
select only a word or character.
(For Classic text, you'll find this
setting in the Paragraph section,
where it’s called Line Spacing.)
Figure 5-6 shows you the effects

The more text
you write, the
less likely that
people will

read all of it.

The more text
you write, the
less likely that
people will
read all of it.

of different leading values. Figure 5-6: You can make more text look like
less with some leading magic.
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You may choose to measure leading (line spacing) in points (pt, /% of an
inch) because font size is measured in points. For example, if your text is
18 pt high and you want to double-space the lines, use a leading of 18 pt
to create a space exactly one line high between lines of text.

1~ Text color: Click the Text (Fill) Color swatch to open the color palette,

and select a color. (For more information on colors, see Chapter 3.) The
first concern is that the text is legible against its background. Also con-
sider that text is often unreadable in front of complex graphic images,
no matter what the color.

1~ Tracking: Tracking is the horizontal spacing between all the letters.

Perhaps you need the text to fit into a tight space, or you want to
stretch it out without changing the font size. Figure 5-7 shows some
text with various tracking settings. To change tracking, type a value in
the Tracking item and press Enter or drag the slider bar to the desired
value. For Classic text, this item is called Letter Spacing.

Split the scene Split the scene
and leave it clean and leave it

o~

e

m
-l

Spiit the scene and Split the scene and
leave it clean leave it clean

Figure 5-7: Stretched and condensed text.

v~ Highlight: You can highlight the background behind text with any color

you want. Highlighted text looks like you drew over it with a semi-trans-
parent highlighting marker. To highlight text, click the Highlight color
swatch and choose a color from the color palette. You can also adjust
the Alpha (opacity) or remove a highlight (choose the white box with a
red diagonal line through it). Because selected text is already high-
lighted, you need to deselect the text (click off the Stage) to see the
result. You can’t highlight Classic text.

You can also select fonts, font sizes, and font styles directly from the Text
menu. This menu is devoted entirely to helping you format your text.
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1~ Kerning reduces the spacing between certain VAC ATl ON

letters, such as Vand A. Because of the diagonal

line on the A and V, without kerning, the letters

might look too far apart. Figure 5-8 shows an VACATI 0 N
example of text with and without kerning. By Figure 5-8: The first
default, Flash uses a font’s kerning information,
which is embedded in the font definition. With
smaller font sizes, kerning can make text hard
to read, so you can turn it off. To turn off kerning, select the charac-
ters that you want to adjust and clear the Auto Kern check box in the
Property inspector.

line uses kerning; the
second line doesn't.

v Anti-aliasing is a method of making text look smoother — reducing the
jaggies that sometimes create stair-like lines on text. Anti-aliasing is
especially helpful for smaller font sizes. You have three anti-aliasing
options:

¢ Readibility: If you're worried about the jaggies, try choosing the
Readability option from the Anti-Alias drop-down list. This option
embeds the fonts.

¢ Use Device Fonts: If you're worried about file size, you can use
device fonts, which are fonts that are always available on the user’s
computer. For more information on the Use Device Fonts option,
see the sidebar, “Using device fonts.”

e Animation: Use the Animation option to ignore alignment and
kerning information and embed font outlines. The result is a
smoother animation.

The way that your type looks on the Stage is only an approximation of how it
will look when you publish or export your movie. To see a more accurate ren-
dering of how your type will look when you publish or export it, view your
movie by choosing Control=>Test Movier>In Flash Professional.

You can rotate individual characters. We’re not sure why you’d want to do
this because it will probably give your viewers a pain in the neck from look-
ing at the screen sideways. Actually, some of these settings are especially
valuable when you’re working with certain Asian languages that are written
vertically. To rotate text, select it and choose 270° from the drop-down list.
You can also choose 0° or Auto. You can’t rotate individual characters of
Classic text in the Property inspector.

The last settings in the Character section of the Property inspector offers
four buttons to create underlined, struck through, superscript, and subscript
text. For Classic text, you can select the Superscript or Subscript button, but
you need to first deselect the Selectable button to the left.

145



’ 46 Part II: 1,000 Pictures and 1,000 Words

Using device fonts

If you'd like a space-saving alternative to
embedding your fonts, you can use Flash's three
device fonts that the Flash Player always con-
verts to the closest available font on the local
computer:

» _sans: A sans serif font similar to Arial
(Windows) and Helvetica (Mac).

v _serif: A serif font similar to Times New
Roman (Windows) and Times (Mac).

¥ _typewriter: Afontthatlooks like it has
been typed on a typewriter. (Are you old
enough to remember what thatis?) It's simi-
lar to Courier New (Windows) and Courier
(Mac).

When you use device fonts, your resulting pub-
lished movies are smaller, so download time is
shorter. With device fonts, your text also might
be more legible in text sizes less than 10 pt. To
use device fonts, specify one of the device fonts
from the top of the Family drop-down list in the
Property inspector, and then deselect the text.
Then select Use Device Fonts from the Anti-
Alias drop-down list in the Property inspector.
(If you're using Classic text, this setting applies
only to horizontal static text.) When you publish
your movie, select the Device Font check box
on the HTML tab (Windows only) of the Publish
Settings dialog box. Chapter 13 tells you more
about publishing settings.

For Classic text, at the end of the Character section, click the Selectable
button to create text that users can select. The Render Text as HTML button
preserves formatting, such as fonts and hyperlinks, with certain HTML tags.
You need to create the formatting by using ActionScript.

Finally, if you're creating input Classic text, click the Show Border around
Text button to display a black border and a white background for the text

field. This border helps users know where to enter text in an input text block.
Then use the Maximum Characters item in the Options section to specify the
maximum allowable characters that users can input. For example, you could
limit a ZIP code to five digits.

Setting advanced character properties

When you select TLF text, you see an Advanced Character section in the
Property inspector. Most of the settings in this section aren’t available for
Classic text.

The first two boxes let you hyperlink text and set the target: how the hyper-
link’s address opens. Enter a URL (Web address) and then choose one of
the targets; the most common are _self (same window or tab) and _blank
(new window or tab). Flash underlines the text. For Classic text, you'll find
these two text boxes in the Options section of the Property inspector.

You can then set the following advanced properties for TLF text:
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1~ Case: Choose Upper Case, Lower Case, Caps to Small Caps, or Lower
Case to Small Caps. The font needs to support small caps for the last
two options to work.

1~ Digit Case: This setting affects numbers. Some fonts have options to
display numbers either all the same height (the Lining option) or with
ascenders that rise higher and descenders that drop lower (the Old
Style option). The Default option keeps the numbers according to the
default setting in the font.

v~ Digit Width: You can choose from Default, Proportional, or Tabular
options.

1~ Ligatures: Ligatures are combinations of letters that sometimes have varia-
tions that help them fit together better. A common example is fi, in which
the i’s dot is omitted. To be able
to see ligatures, the font you're
using must contain them. Two
examples are Bickham Script Pro
and Hypatica Sans Pro. You can
choose Minimum, Common (such
as fi and fl), Uncommon, or Exotic
(such as ct and st).

~ Break: This option determines
how words break when the text is too wide for the text block. Auto
doesn’t break up any words, All places each letter on its own line, Any
breaks words as needed for a fairly straight right margin. The No Break
option is to maintain compatibility with previous versions.

1~ Baseline Shift: You can move
the text above or below the
baseline. Click and enter a
value or use the slider. From

wrw do you improve your skills?
# Do you always try to Improve?

the drop-down list to the right, # Did you recelve some negative
choose to specify the value N i s

in points (pt) or by percent- improve by your boss?

age (%). You can also choose +.0idyoul ses suiracne whio fa

) . great skill and become inspired to
Superscript or Subscript. In improve?

Figure 5-9, we created a drop-
cap for first letter (W) with a
negative baseline shift.

Figure 5-9: You can create a drop-cap effect
by lowering the baseline for a letter. Margin
and indent values align the bulleted text.

1 Locale: You can choose from
a huge selection of languages.
The locale affects justification
rules in a text block. If you're
writing in Urdu, you probably want your justification rules to be appro-
priate for Urdu.
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Flash usually stores outlines of the text in your movie when you publish or
export it, so your audience will see your fonts in your movie even if those
fonts are not installed on your audience’s computer. However, not all fonts
displayed in Flash can be stored as outlines when you publish or export your
movie. To test whether Flash can export a font with a movie, choose View=>
Preview Moder>Anti-Alias Text. If the text appears jagged, Flash cannot
export the text with the movie. If you want to use type in a font that Flash
can’t export, you can break apart the type into shapes, as we describe at the
end of this chapter. However, this option increases the size of your movie file
and makes the text no longer editable.

Setting up paragraph formats

In the Paragraph section of the Property inspector, you can set paragraph
attributes such as alignment, margins, indents, and paragraph spacing. Use
these settings whenever you type more than one line of text. (You are getting
long winded, aren’t you!) Select the paragraph before making changes. You
have the following options:

v~ Align: You can align text along the left margin or right margin of the text
block. You can also center text. You can create an even edge along both
margins, called full justification or justified text. By default, text is left
aligned. Click the button that shows the alignment you want.

Three new choices allow you to place the last line of the paragraph at
the left, center, or right. The last line is usually less than the full width
of the text block.

1 Margins: The margin is the space between the text block border and
your text. By default, the margin is 0 pixels. You can increase the margin
to guarantee some space around the text. You can set only the left
(Start) and right (End) margins (not the top or bottom ones). To set a
margin, click either the Start or End Margin item. Enter a value in pixels
and press Enter or click and drag in either direction.

~ Indent: Indentation creates an indented first line. It’s equivalent to
placing a tab at the beginning of a paragraph. (Remember your sixth-
grade teacher who told you to always start each paragraph with an
indent?) To indent the first line, type a value for the First Line Indent
item or click the value and drag up or down. Figure 5-9 uses a larger
left margin and a negative indent value (to create an outdent) to align
the bulleted text.

1~ Spacing: Use the Space before Paragraph item to add space before
each paragraph. You use the Space after Paragraph item to add space
after each paragraph. If you use both, the numbers are added together
between paragraphs. Click, enter a value, and press Enter, or drag in
either direction. (This setting isn’t available for Classic text.)
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1~ Text Justify: Fully justified text usually adds extra space between the
words to fill out the lines of text. However, you may want to add extra
space between the letters. Choose between the Word Spacing and Letter
Spacing options.

If you're creating Classic text, you change the line spacing in the Paragraph
section. Click the Line Spacing item, enter a value and press Enter, or drag in
either direction. For TLF text, you use the Leading item in the Character sec-
tion, as described in the previous section of this chapter.

Flash remembers paragraph properties from movie to movie. When you
change paragraph properties for one movie, those properties rear their ugly
heads in your next movie. If your text automatically indents at the beginning
of paragraphs or has extra space between the paragraphs, check the
Paragraph section of the Property inspector.

Going with the flow

TLF text (but not Classic text) lets you easily create columns, flow text from
one text block to another, and more. Most of the features in this section are
new. The Container and Flow section of the Property inspector enables you
to use these features:

+~ Behavior: This item controls how words wrap to the next line. By
default, if you have more text than can fit in the text block’s width, the
words wrap (the Multiline option). You can also choose Single Line (no
wrapping), Multiline No Wrap (you must press Enter to get a new line),
and Password (shows asterisks). (The Password option is available
when you create editable text, as we describe earlier in this chapter.)

This setting also applies to your published movie. For example, if you
create editable text, you might let users write a short novel in an input
box. In that case, you certainly want the text to wrap, because who ever
heard of a novel all on one line? The Password setting would be an obvi-
ous choice in a text box where you are requesting a password from your
Web site’s viewers.

1 Maximum Characters: This setting applies only to Editable text (called
Input text if you're using Classic text) and specifies the maximum allow-
able characters that users can type in a text box. For example, you
could limit a ZIP code to five digits. For Classic text, this setting is in the
Options section.

1~ Vertical alignment: You can control where your text sits vertically in the
text block. Your options are Top, Center, Bottom, and Justify. Justified
text spreads out to take up the entire text block, in effect changing the
leading (line spacing). Classic text doesn'’t offer this setting.
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1 Column gutters: The gutter is the width between the columns. Click,
enter a value in pixels, and press Enter, or drag the slider.

Grapple with Grapple with Unravel baffling
enigmas and enigmas and riddles, and cut
master our master our your teeth on
mysteries! mysteries! curious

Grow your brain Grow your brain conundrums.
with our brain with our brain Crack our puzzles
teasers! teasers! and decipher our
Unravel baffling codes!

riddles, and cut

your teeth on

curious

conundrums.

Crack our puzzles

and decipher our ‘

codes! ‘ ‘

Figure 5-10: You can use your space in more ways when you
have the option to create columns.

+* Columns: Columns are new and available only for TLF text. Click, enter
the number of columns you want, and press Enter, or drag the slider.
Figure 5-10 shows some text in one column on the left and two columns
on the right.

1 Padding: Padding is the space between the text and the border of the
text block. It’s like a margin except that you can set it in all four direc-
tions. Padding isn’t available for Classic text. Use the L (left), R (right), T
(top), and B (bottom) items to enter the padding in pixels.

1~ Container border color: If you're using TLF text, you can give the text
block (also called a container) a border, as you see in Figure 5-10. Click
the Container Border Color swatch and choose a color or use the swatch
with the red, diagonal line to remove the border. When you add a
border, the padding (just discussed) becomes more important because
a little white space between the border and the text helps legibility.

1~ Container background color: Your text block can have a background
(fill) color, but be sure that the background doesn’t interfere with
your text. Click the Container Background Color swatch and choose
a color or use the swatch with the red, diagonal line to remove the
background.

1~ 1st Line Offset: You can add space between the top of the text block
and the text using the Padding feature (described earlier in this list),
but the 1st Line Offset drop-down list offers a more flexible way to
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add space at the top. Choose Ascent to count to the top of the high-
est letter. Choose Line Height to include the normal spacing between
the lines of text. The Auto option automatically generates a value that
seems to be similar to Ascent. Then choose the pt item to display a
value where you can click, enter an offset value in points, and press
Enter, or drag the slider.

Specifying text block properties

Some text settings are available when you select the text block, as opposed
to text within the text block. The distinction isn’t always intuitive and to con-
fuse matters, many settings appear in the Property inspector in both cases.
In this section, we cover settings that you can specify only when you select
the text block.

Setting position and size

The Position and Size section of the Property inspector is no different for
a text block than for any other object that you might select. Here, you can
specify the X (horizontal) and Y (vertical) position, measured from the
upper-left corner of the Stage. You can change the size of the text block
by adjusting the W (width) and H (height) values. Of course, you can just
select the text block and drag, but these settings offer you much more
precision. For each setting, click, type a value, and press Enter, or drag
the slider.

Specifying 3D position and view

The 3D Position and View section determines how the text looks in 3D space.
For example, by increasing the Z value, you can make the text look smaller,
as if it is farther away. For more information, see “Changing 3D position and
rotation” in Chapter 7.

You can apply color effects, such as transparency, brightness, and tints to
text. You can also add blends, which affect how overlapping text blends.
Because these effects also apply to certain types of symbols, we cover them
in Chapter 7. Finally, you can add cool effects, called filters, to text. For more
on filters, see the end of this chapter.

Flowing text from one container to another

The main purpose for the new text container settings is to flow text from one
text block to another. If you move or resize either text block, the text reflows,
adjusting to the new situation. To link two text blocks, follow these steps:

1. Choose the Text tool in the Tools panel. Drag from left to right to
define the desired width.
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2. Type your text.

Type enough text so that you can’t see it all. You can resize the height
by dragging on the top or bottom handles, but you want some text to be
hidden so that it can flow to the second text block.

3. Repeat Step 1 to create a second text block.

Don’t type text in the second text block because the text will flow from
the first text block.

4. Click the Selection tool in the Tools panel and select the first text
block.

You see two small boxes on the text block’s border. The left box, called
the in port, flows text into the text block; the right box, called the out
port, flows text out of it.

5. Click the out port on the text block’s border.

You see a special cursor, as shown in Figure 5-11. As you move the
cursor away from the box, it changes to look like a box with text inside.

[T]Grapple with
enigmas and
master our
mysteries!

Grow your brain o
with our brain
teasers!

Unravel baffling|
riddles, and cut Bl

Figure 5-11: Flow text from one container to another.

6. Click inside the second text block.

The text flows to the second text block, and you see a line connecting
the outgoing box of the first text block and the incoming box of the
second text block, as shown in Figure 5-12.

7. To get the text just the way you want it, resize one or both of the text
blocks by dragging the top or bottom square handles, as shown in
Figure 5-13.
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'-J]Grapple with [!}iddles, and cut
enigmas and your teeth on
master our curious
mysteries! conundrums.

Grow your brain Crack our puzzles
with our brain and decipher our
teasers! codes!

Unravel baffling [T] E_[]

Figure 5-12: After clicking inside the second text block,
the text flows from the first text block.

[I]Grapple with H':Unra!ur-sel baffling
enigmas and riddles, and cut
master our your teeth on
mysteries! curious
Grow your brain conundrums.
with our brain Crack our puzzles
teasers! and decipher our

Bl | codes!

i

Figure 5-13: The text now flows nicely and doesn’t
confuse the brain.

Creating Cool Text Effects

Flash wouldn’t be worth its salt if you couldn’t create some flashy effects
with text. You can manipulate text in several ways:

1~ Transform text just like other objects. In other words, you can scale,
rotate, skew, and flip text. Select the text block (not the text itself) first.
(Chapter 4 explains the many ways that you can transform objects.)
Figure 5-14 shows an example of skewed text.

1~ Convert type to shapes by breaking it apart. Select the text and choose
Modify=>Break Apart. Flash creates separate shapes from each letter
so that you can then edit the text in the same way that you edit shapes.
However, you can no longer edit the text as text, so check your words
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Figure 5-1 for an example of text GFZ0/E WITS
turned into shapes.) EVHGIAS T J
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If you're creating Classic text, the first mpysresess ﬂa‘faﬂd (
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vidual letters. Use the command again, | teasers! dg‘ y

: Unravel baffling
and letters are turned into shapes. siddias, and tatyour I’d

1+~ Apply special graphic effects (called |teeth on curious
filters) to text. Select the text block o
for TLF text (but select the text
itself for Classic text) and expand
the Filters section of the Property
inspector. Click the Add Filter button rectangles.
at the bottom and choose one (or
more) of the following filters: Drop Shadow, Blur, Glow, Bevel, Gradient
Glow, Gradient Bevel, or Adjust Color. Each filter has a number of set-
tings that you can adjust to get just the right effect. Figure 5-15 shows
these effects in the order listed here.

Figure 5-14: This text is skewed to
match the angles of the skewed

You can animate text to your heart’s content. To animate text, you usually
break it apart so that you can move letters individually. You can then use
the Modify=Timeline=>Distribute to Layers command to put each letter on a
separate layer. After that, you can animate each letter. (See Chapter 9 for the
details on animation.)

Am | seeing douhle?

Iy my vision blurred?

I'm getting a weird, glowy feeling
I51T COMING AT ME?

Is it coming,or dping?.
WHich ey, Which <o)

Is it a picture?

Figure 5-15: Filters are shortcuts to cool looking (but not necessarily
legible) text.
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Layering It On

In This Chapter

Creating layers
Modifying layers
Using guide layers

Creating holes with mask layers

Fash lets you organize objects on the Stage in layers. Layers keep objects
separated from each other. Flash either combines or creates cutouts
when two objects overlap if you don’t use the object-drawing model (as we
explain in Chapter 3). By placing the two objects on different layers, though,
you avoid this behavior yet retain the appearance of overlapping objects. In
addition, by rearranging your layers, you can easily rearrange the order of
your objects — that is, which objects appear to be on top and which

appear to be on the bottom.

Layers are also necessary for error-free animation. To
move one object across the Stage in front of other
objects, such as a background, you need to put the
moving object on its own layer. If you want to ani-
mate several objects across the Stage, put each
object on a separate layer.

You can hide layers. Flash doesn’t display objects
on hidden layers. Hidden layers are great for hiding
some objects temporarily while you figure out what
to do with all the rest of the stuff on the Stage.

Finally, you use layers as a storage place for sounds and

ActionScript code. (See Chapter 10 to find out more about

ActionScript.) For example, you can name a layer Music and put

your music there. Then you can easily find the music if you want to change
it. Layers provide a great way to keep the various components of your movie
organized. In this chapter, you get all the information you need to use layers
effectively.
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Creating Layers

Flash lists layers at the left side of the Timeline. New movies start out with
one layer, named Layer 1. You can, and should, change the name of this layer
and new layers to something more descriptive, as shown in Figure 6-1.

Active layer
= @ Ol 5 10 15 20 I:FS 30 35 40 45 50 55
o] Laver 1 « « O 0| =]
- b a.
& Resources « O
& Rainbow v s lis
al 1 t W Rl 2400fs 105 [N ¥ |

Figure 6-1: Flash keeps you organized by listing all your layers.

If you're the organized type, think about your animation in advance and
decide which layers you need. However, animations often don’t work out the
way you plan, and you might find yourself creating layers after you create
objects. Either way, your method for creating layers is the same.

To create a layer, click the New Layer
button at the bottom of the layer list
(or choose Insert>Timeliner>Layer).
Flash displays the new layer above

TIMELIME

the active layer and makes the new
layer active, as shown in Figure 6-2.
To name the layer, double-click its
name, type something meaningful,

al
al ball P

Figure 6-2: A new layer.

and then press Enter (Windows) or
Return (Mac).

Using layers

Any object that you create goes on the active layer. You can tell which layer is
active because it’s highlighted and has a pencil icon next to its name. (Refer to
the Lines layer in Figure 6-1.) To change the active layer, just click any inactive
layer’s name. You can also click anywhere in the layer’s row on the Timeline.
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To help make your work easier, Flash automatically changes the active layer
to match any object that you select. So, if you're working on a layer named
Text and then select a shape on a layer named Shapes, Flash automatically
activates the Shapes layer. Any new objects that you create are now on the
Shapes layer. Of course, if that’s not the layer you want, switch to any other
layer at any time by clicking its name.

When you click a layer to make it active, Flash selects all the objects on that
layer that exist in the current frame. (Even if a layer is already active, you
can click its name to select all its objects.) This feature is helpful for work-
ing with all the objects on a layer and discovering which objects a layer
contains. If you don’t want the objects selected, click anywhere there’s not
an object.

Because in many cases, each animated object needs to be on its own layer,
you often need to distribute objects to their own layers. Select the objects
and choose Modify= Timeline=>Distribute to Layers. This command saves
lots of work!

Changing layer states

Besides being active or inactive, layers have three states that determine how
objects on that layer function or look; you can

1 Show or hide a layer.
v Lock or unlock it.

v Display objects on a layer as outlines.

Use these states to help you organize how you work. The more objects and
more layers that you have, the more you need to use these layer states.

Above the layer list, on the right side, you see an eye, a lock, and a box.
These aren’t mystical symbols. The following sections explain what they are
and how to use them.

Show/Hide

Use the Show/Hide icon (as shown at the left) to hide all objects on a layer
(also called hiding a layer), reducing clutter while you work. To hide a layer,
click below the Show/Hide icon on that layer’s row. Flash places a red X
under the eye icon. All the objects on that layer disappear. Click the X to get
them back again. To hide (or show) all the objects on the Stage, click the
Show/Hide icon itself.
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Keep in mind, however, that you can’t work on a hidden layer. And, don’t
forget hidden layers because by default, they do appear in your published
movies. (For information about specifying whether hidden layers appear in
published movies, see Chapter 13.)

To show or hide all layers except one, Alt-click (Windows) or Option-click
(Mac) below the Show/Hide icon on that layer’s row. You can also right-click
(Windows) or Control-click (Mac) a layer and choose Hide Others from the
contextual menu that appears.

Lock/Unlock

Use Lock/Unlock to prevent objects from being edited by locking their
layers. Lock a layer when you want to avoid changing objects by mistake.
To lock a layer, click below the lock icon on that layer’s row. Flash places
a lock in the layer’s row. Click the lock to unlock the layer again. The lock
disappears, and you can now edit objects on that layer. You can lock all
layers by clicking the lock icon directly. Click the lock icon again to unlock
all the layers.

To lock or unlock all layers except one layer, Alt-click (Windows) or Option-
click (Mac) below the lock icon on that layer’s row. You can also right-click
(Windows) or Control-click (Mac) a layer and choose Lock Others in the
contextual menu.

Outlines

Use Outlines to display objects as outlines of different colors. Outlines help
you see which layer objects are on because each layer uses a different color,
as shown in Figure 6-3. To display outlines, follow these steps:

1. Click below the Outlines (box) icon on that layer’s row.

Flash puts a colored box in the layer’s row, and all objects on that layer
are now shown as outlines in that color. (Text is still filled in, however.)

2. Click the box to display objects on that layer normally.

To display all layers as outlines, click the Outlines icon directly. Click it again
to see your objects as normal. You can work on outlined layers, but all new
objects appear as outlines, so telling how they appear when displayed nor-
mally is difficult.

To display all layers as outlines except for one layer, Alt-click (Windows) or
Option-click (Mac) below the Outline icon on that layer’s row.
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Figure 6-3: All the objects on the Stage are shown as outlines except
for text.

Getting Those Layers Right
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Good layer housekeeping can help keep you sane. Delete layers that you

no longer need. Rename layers when their content changes. Copy layers
with their entire contents rather than re-create them from scratch. Here, we
explain how to keep control over layers.

You can select more than one layer at a time. To select a contiguous group,
click the first layer, hold down the Shift key, and then click the last layer in
the group. To select more than one layer when they’re not all together in a

group, click the first layer, press and hold Ctrl (Windows) or 8 (Mac), and

then click any additional layers that you want to select.

Deleting layers

When you work, you might find that a layer no longer has any objects. It’s a
layer without a purpose in life, so delete it. Select the layer and click the
Trash can icon at the bottom of the layer list. You can also drag the layer to
the Trash can (Delete) icon.

When you delete a layer, you delete everything on the layer. However, some
objects on a layer might not be visible because you see only what exists on
the Stage in the current frame. For example, if you introduce a circle in Frame
15 of a layer named Circle but you're in Frame 1, you don’t see that circle.
Deleting the Circle layer, however, deletes the circle although you can’t see
it. (We discuss frames in more detail in Chapter 9.)

To check for objects on a layer, right-click the layer and choose Hide Others
from the contextual menu. Click the first frame on the Timeline and then
press Enter (Windows) or Return (Mac) to run any existing animation.
Objects on that layer appear during the animation, if they exist.
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Copying layers

You can copy a layer, along with its entire contents, throughout all frames. If
you create a great bouncing ball but now want two balls, copy the layer. You
can then modify the position of the second ball throughout the Timeline with-
out having to re-create the ball itself. Now you have two bouncing balls.

To copy and paste a layer, follow these steps:

1. Click the layer name to select the layer.

2. Choose Edit~>Timeline~>Copy Frames.

3. Click the New Layer button to create a new layer.
E 4. Click the new layer to make its frames active.
5

. Choose Edit~> Timeline>Paste Frames.

Renaming layers

Rename a layer whenever you want. By default, Flash names layers Layer 1,
Layer 2, and so on. When you use a layer, rename it to reflect its contents. To
rename a layer, double-click the layer name and type a new name. Then press
Enter (Windows) or Return (Mac).

Reordering layers

In Chapter 4, we explain how to change the order
of objects on the Stage when they’re on the

same layer. When objects are on different layers, e
though, a new rule applies: The order of the : ;
layers indicates the display order of objects on
the Stage. Therefore, objects on the uppermost
layer in the list are always on top, objects on the
second layer appear one level down, and so on.
Objects on the last layer in the list appear on the
bottom level of the Stage, behind everything else.

In fact, a simple and effective way to control object
stacking is to put objects on different layers and
then move the layers higher or lower in the layer
list. To move a layer, just click and drag it within
the layer list to the desired position. Figure 6-4
shows an example before and after moving a layer.
The ball and the oval are on different layers.

The top image looks a little odd, but when you Figure 6-4: Change layer order
reorder the layers, their objects are reordered as  to change the object order on
well — you can then see a ball and its shadow. those layers.
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Changing the layer order can help you more easily select and edit objects
that are covered by other objects. Simply drag the layer to the top of the list,
and the objects in that list then appear on top. When you finish editing the
objects, drag the layer back to its original location.

Organizing layers

Sometimes layers can get out of hand. You might have several layers with
sounds on them or several layers for each animation. Tame those layers by
putting them into folders. Instant organization! For example, you could create
a Sounds folder and folders for each animation group.

To create a folder, click the New Folder icon below the layer list. You see a
new folder just above the active layer. Name the folder the same way you
name a layer: Double-click it, type the name, and then press Enter (Windows)
or Return (Mac). You can distinguish a folder from a layer by its folder icon.

After you have a folder, you fill it up with layers by dragging layers into it.
Click and drag a layer just under the folder’s name and then release the
mouse button. At the same time, the layer’s name becomes indented so that
you can easily tell that it’s in a folder, as shown in Figure 6-5.
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Figure 6-5: Put your layers into folders to keep yourself organized.

You can even put folders in folders. Just drag one folder into another. A
folder within a folder is a nested folder, and the folder that it’s in is the
parent folder.
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Here are some other things that you can do with folders:

+~ Remove a folder from a folder. Drag the nested folder above its parent
folder.

1 Remove a layer from a folder. Drag the layer above the folder name or
to another location where it doesn’t darken a folder.

1~ Collapse or expand individual folders. Click the folder’s arrow, at the
left of its icon.

1~ Expand or collapse all folders. Right-click (Windows) or Control-click
(Mac) and then choose Expand All Folders or Collapse All Folders from
the contextual menu.

1~ Hide or lock an entire folder and its layers. You can hide or lock a
folder just like you hide or lock a layer. (See the “Changing layer states”
section, earlier in this chapter.) Click below the eye (Show/Hide) or lock
(Lock/Unlock) icon on the folder’s row.

1~ Reorder folders. You can change the order of folders, which automati-
cally changes the order of the layers that they contain. Just drag any
folder up or down. For more information, see the preceding section.

+~ Copy the contents of a folder to another folder. To make a quick short-
cut for copying layers and their contents, you can copy folders. Collapse
the folder and click the folder name. Choose Edit=>Timeline~>Copy
Frames, and then create a new folder. With the new folder active, choose
Edit=>Timeliner>Paste Frames.

1~ Delete folders. Delete folders the same way you delete layers. Select the
folder and then click the Trash can icon.

Deleting a folder deletes all layers in the folder and everything on those
layers. Luckily, Flash warns you before you take the plunge.

Modifying layer properties

You can use the Layer Properties dialog box, as shown in Figure 6-6, to
change certain layer properties, such as the color used for the layer’s out-
lines and the layer height. Most settings, however, are easily accessible from
the layer list. Select a layer (or a folder) and choose Modify=>Timeliner>Layer
Properties to open the Layer Properties dialog box.

Here’s how to use this dialog box to get the most from your layers:

1 The Name text box displays the current name of the layer. You can
rename the layer here if you want.

1~ Change the layer states by selecting (or deselecting) the appropriate
check boxes. Usually, you change these states directly in the layer list,
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as we explain earlier in this
chapter, in the “Changing layer
states” section.

+* You can change the type of
layer (guide or mask) by choos-
ing from the list of layer types.
We cover guide and mask layers
later in this chapter.

» You can change the color that
Flash uses when the layer is
displayed as outlines. Click
the Outline Color swatch and
choose another color in the
color palette.

1~ Select the View Layer as
Outlines check box to turn on

outlines. As we explain earlier in
this section, you can accomplish

Layer Properties (==
Name:m | | ok I
M show [ Lock

Type: (=) Mormal
) Mask.
(O Masked
) Folder
() Guide

outline color: [

[ Wiew layer as autlines

Laver height:| 100% |+

Figure 6-6: Fine-tune layer settings here.

this task easily from the layer listing.

 You can change the layer height to two or three times the normal
height. One reason to change the height of a layer is to more easily view
sound waves on a layer that contains a sound. Open the Layer Height

drop-down list and choose a value.

After you finish using the Layer Properties dialog box, click OK.

Another reason to display a larger layer height is to see larger previews of
your keyframes in the Timeline. (Click the Options menu in the upper-right
corner of the Timeline and choose Preview or Preview in Context from the

pop-up menu.)

Working with Guide Layers

A guide layer is a layer that’s invisible in the final, published animation. You
can use guide layers for the following purposes:

1~ Layout: Although you can display onscreen guides to help you draw
precisely (as we describe in Chapter 3), you can also place gridlines
on guide layers to help you lay out the Stage, as shown in Figure 6-7.
Graphic designers use these types of gridlines to figure out how to
create a balanced, pleasing effect in their art.
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 Drawing: You can import a bitmap graphic onto a guide layer and draw
over the graphic on a regular layer by using the Flash drawing tools.
This technique of drawing over a graphic can be a big help when creat-
ing your artwork.

In previous versions of Flash, guide layers also allowed you to guide an
animated object along a path. You don’t need guide layers for this pur-
pose any more. However, you can still create the type of tween used in
previous versions; it’s called a Classic Tween. For more information on
animation, see Chapter 9.
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Figure 6-7: A grid on a guide layer helps you lay out your design.

Of course, you could use a regular layer and then erase whatever you
don’t want to appear in the final movie. But if you need to go back and
make changes, you would have to create the guide layer again. Using a
guide layer gives you the flexibility of keeping the layer in the movie file,
knowing that it will never appear in the published animation.

Hidden layers appear in the published SWF file, but guide layers don’t
appear.

To create a guide layer, create a new layer. Then right-click (Windows) or
Control-click (Mac) and choose Guide from the contextual menu. The layer is
now a guide layer. Use the same procedure to convert a guide layer back to a
regular layer.



Opening Windows with Mask Layers

A mask layer hides every object on
its related layers except those inside
a filled shape or text object. You can
use mask layers to create peepholes
or spotlight effects. Figure 6-8 shows
a keyhole shape on a mask layer that
hides the entire scene except for the
part within the keyhole. The Indian
bazaar scene is a rectangle much
larger than the section displayed
through the keyhole.

Creating a mask effect

Follow these steps to create a mask
layer, the object on the mask layer,
and the objects behind the mask
layer:

Figure 6-8: You can use a mask layer to create
a hole through which you can see the layer or

1. Create the objects that you
layers below.

want to show through the hole
in the mask layer.

These objects can be on one or more layers. Place all the layers that you
want to be masked next to each other and at the top of the layer list.

button to create a new layer at the top of the list.

E 2. Select the topmost layer in the layer list and then click the New Layer

This layer will become the mask layer.

3. Create, insert, or import one filled shape, text, or an instance of a
symbol on the new layer.

See Chapter 7 for more about symbols.

The filled part of the shape, text, or instance will become the hole. In
other words, it will be transparent. For an example, see the keyhole
shape in Figure 6-8. Unfilled portions of the object will become opaque,
so everything will become the opposite of its current state.

4. Right-click (Windows) or Control-click (Mac) the layer’s name and
then choose Mask from the contextual menu.

Flash turns the layer into a mask layer and locks the mask layer as well
as the layer just below it in the layer list. The masked layer is indented
in the layer list. You see the mask effect displayed. (To link more than
one layer to the mask layer, see the next section, “Editing mask layers.”)
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Editing mask layers

Because Flash locks both the mask layer and the layer or layers that are
masked, you cannot edit them until you unlock them. Click the lock icon
above the layer list to unlock all the layers, or unlock the mask and masked
layers only. Flash removes the mask effect. After you finish editing the layers,
lock them again to redisplay the mask effect.

When you create a mask layer, Flash links only the layer directly below it to
the mask layer. A layer linked to a mask layer is masked. If you place objects
that you want to be masked on several layers, you need to change the prop-
erty of all those layers from normal to masked.

All the layers that you want to be masked must be directly under the mask
layer.

Here’s how to link a layer to a mask layer:

 Drag a normal layer directly below a mask layer, and Flash links it to the
mask layer in addition to existing masked layers. Then lock the layer.

1~ Right-click (Windows) or Control-click (Mac) the layer and choose
Properties. Then select the Mask option in the Layer Properties dialog
box. Then lock the layer.

Similarly, you can unlink a layer from its mask layer by using one of these
methods:

v~ Drag the linked layer above the mask layer.

1 Right-click (Windows) or Control-click (Mac) the layer and choose
Properties. Then select the Normal option in the Layer Properties
dialog box.

Mask layers are more fun when you animate them. You can move them,
change their sizes, and change their shapes. If you create a keyhole like the
one shown in Figure 6-8, you can move the keyhole past the masked layers,
revealing what lies beneath while the keyhole moves. You can use the same
technique to create an effect of a spotlight moving around a stage, revealing
whatever it lights up. (Chapter 9 covers animation.)
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ymbols can represent the deeper levels of

life, and Flash symbols let you get down deep
into the mechanics of animation. In this part, you
discover three kinds of symbols — graphic sym-
bols, button symbols, and movie clip symbols —
and how to use them.

Manipulating symbols is a critical feature of Flash.
Symbols enable you to easily place duplicate
graphics in your movie without significantly
increasing the movie’s size, and symbols are nec-
essary when you start to animate. This part of the
book also gives you the lowdown on buttons,
which are central to the Web lifestyle in the 21st
century. Flash lets you create buttons that change
when you pass the mouse cursor over them and
again when you click them. You can even make
animated buttons. Part Ill provides you with the
basis for creating great animations.
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Heavy Symbolism

In This Chapter

Exploring types of symbols
Making symbols

Creating instances

Fash offers a way to simplify your work, using symbols. A symbol can be
any object or combination of objects, animation, or a button. When you
create a symbol, the objects (or animation or button) become one object.
Sounds like grouping, yes? (If you've already read Chapter 4, you know what
we mean.) The difference is that Flash stores the definition of the symbol

in the Library. (To open the Library, choose Window=>Library.) From the
Library, you can now effortlessly insert multiple copies of the symbol into
your movie. Each copy is called an instance.

Besides making your life easier when you want to use a set
of objects more than once, the use of symbols signifi-
cantly reduces the size of your files. Instead of storing
each instance that you use, Flash stores one defini-
tion for the symbol and refers to that definition each
time you display an instance of the symbol. You

can place symbols inside other symbols, which

is called nesting. Used this way, symbols are the
building blocks for complex graphics and anima-

tion. Motion-tweened animation requires symbols,
groups, or text, so you often create symbols when
preparing to animate. (Chapter 9 explains tweened
animation.)

So, symbols are all-around good guys, and you should use
them as much as possible.
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Understanding Symbol Types

Flash offers three types of symbols: graphic, movie clip, and button. Each
type is made up of one or more objects or animation, but each type has a
different purpose. Understanding these types is important to understanding
symbols and Flash animation in general.

Using graphic symbols

Graphic symbols are the simplest and most obvious type of symbol. When
you create a Flash movie, you create objects on the Stage. Some objects may
remain still, such as backgrounds. Other objects are animated — after all,
what would Flash be without animation? Use graphic symbols for collections
of static objects or for simple animation. Figure 7-1 shows a graphic symbol
created from several curves and circles.

You create graphic symbols to reduce the size

of your file and to make it easier to add multiple
copies of a graphic to your movie. Symbols are
stored in the Library and are available to not only
the movie in which you create them but also to
any other movie. You don’t have to re-create the
wheel.

Flash ignores sounds and ActionScript inside
graphic symbols. ActionScript code (which we
explain in detail in Chapter 10) is the key to creat-
ing interactive movies. For that reason, don’t use  Figure 7-1: A graphic symbol,
graphic symbols if you want to use ActionScript created from several objects,
to directly control them — use movie clip sym- has a single selection border.
bols instead.

Using movie clip symbols

A movie clip is like a movie within your movie that you can manipulate by
using interactive controls (which you can read about in Chapter 10). Movie
clips are crucial for complex animation and especially for interactive anima-
tion. A movie clip has its own Timeline independent of the movie’s main
Timeline. For example, you can go to a movie clip at any point in the movie,
play it, and then return to where you left off on the Timeline. You can also
attach movie clips to buttons. We explain how to create movie clips in this
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chapter; Chapter 8 discusses using movie clips with buttons. Chapter 9
covers using movie clips in animation, and Chapter 10 explains how to use
and control movie clips by using interactive controls.

Flash comes with a library of components, which are special movie clips that
allow you to add user-interface elements — such as radio buttons, check
boxes, and scroll bars — to your movies. Choose Window=>Components,
expand the User Interface item, and drag one of your choices to the Stage.
Then use the Component Parameters section of the Property inspector
(choose Window=>Properties if you need to open the Property inspector) to
set the parameters of the component. For example, you can choose the
CheckBox item and then specify its label and other properties. For more
information on components, see Chapter 12.

Using button symbols

Button symbols create buttons — those little graphics that you click on Web
pages to take you to other pages on the site or the Internet. In Flash, you

can use buttons for this type of navigation, but you can also use buttons to
interact with your site. For example, you can let viewers decide whether they
want to see a movie — when they click the button, the movie starts. You can
also use advanced scripting to create buttons that control interactive games
and other viewer activities. However you want to use buttons, button sym-
bols are the way to start. You can add movie clips and interactive controls to
buttons. Find out about buttons in Chapter 8.

Creating Symbols

For graphic symbols and button symbols, usually you create the objects that
you need and then turn them into a symbol. The same is true of movie clips if
they are static and you use ActionScript to control them. However, when you
use a movie clip as a type of animation, you can use one of two approaches:

1 Create an animation on the Stage and then convert it to a movie clip
symbol.
1~ Create the movie clip symbol, create the initial objects, and then create

the animation.

In the next few sections, we explain the various ways of creating symbols, for
whichever purpose you want to use them.
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Each type of symbol has its own icon that’s used in the Library. The following
table shows what type of symbol each icon represents:

Symbol What It Represents

ke
& Button
@ Graphic

Creating symbols from existing objects

To create a symbol from unanimated objects you've already created, follow
these steps:

Movie clip

1. On the Stage, select the objects that you want to convert to a symbol.
2. Choose Modify~>Convert to Symbol, or press F8.

The Convert to Symbol dialog box opens, as shown in Figure 7-2.

3. In the Name text box, type a Convert to Symbol =
name for the symbol. Hame: [Bymbol o]
A common convention is to Tops: Mot d Lu] Regitrater:
name the symbol in a way that’s | e oo
unique and also indicates the Bt -

symbol type. For example, btn_
help could be the name for a
button symbol that will become
a Help button on a Web site.

Figure 7-2: The Convert to Symbol dialog box.

4. In the Type list, select the type of symbol you want to create: graphic,
button, or movie clip.

5. Click the Folder link to specify where to store the symbol in the
Library.

The default option puts the symbol in the Library root. When you click
the Folder link, the Move to Folder dialog box opens. You can choose the
Existing Folder option and choose a folder that you created in the Library.
(We explain how to create folders in the Library in Chapter 2.) You can
even use the New Folder option and create a new folder on the spot. Click
Select to close the dialog box.

6. Choose the desired registration point in the Registration grid.
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The registration point determines how Flash applies certain transforma-
tions, such as rotation, to the symbol. (See Chapter 4 for a discussion
of registration points.) The default registration point is at the upper-left
corner of the symbol.

. Click OK to create the symbol and close the dialog box.

The objects that you selected become one object, indicated by a single
selection border around all the objects. Flash also stores the symbol in
the Library. (Chapter 2 explains how to use the Library.)

Creating empty symbols
Rather than create a symbol from existing objects, you can create an empty

symbol and then create the objects for the symbol. If you know in advance
that you want to create a symbol, you can use this method.

To create an empty symbol, follow these steps:

1.

With no objects selected, choose Insert=>New Symbol, or press Ctrl+F8
(Windows) or 38+F8 (Mac).

The Create New Symbol dialog box opens.

2. In the Name text box, type a name for the symbol.

3. In the Type list, select the type of symbol you want to create —

graphic, button, or movie clip — and then click OK.

Flash switches to symbol-editing mode, which we describe in the section
“Editing symbols,” later in this chapter.

. Create the objects or animation for the symbol in the same way you

do in regular movie-editing mode.

. Choose Edit>Edit Document to leave symbol-editing mode and return

to your movie.

Your new symbol disappears! Don’t worry — Flash saved the symbol in
the Library. To find out how to insert an instance of the symbol on the
Stage, see the “Inserting instances” section.

Converting an animation to a movie clip symbol

You can create a movie clip symbol by converting regular animation to a
movie clip. Use this method when you already have the animation created on
the Timeline. To convert an animation on the Stage to a movie clip symbol,
follow these steps:

1. On the layer listing, select all layers containing the animation by click-

ing the first layer and pressing Shift while you click the last layer in
the group.
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Alternatively, you can press Ctrl (Windows) or 8 (Mac) and click
additional layers.

. On the Timeline, right-click (Windows) or Control-click (Mac) and

choose Copy Frames to copy all the frames of the animation to the
Clipboard.

Alternatively, you can choose Edit=>Timeline=>Copy Frames.

. With no objects selected (click somewhere off the Stage to be sure that

no objects are selected), choose Insert->New Symbol.

The Create New Symbol dialog box opens.

4. In the Name text box, type a name for the movie clip.

. In the Type list, select Movie Clip as the type of symbol. Then click OK.

Flash switches to symbol-editing mode so that you can edit the symbol.

. Click the first frame of the Timeline to set the start of the movie clip

symbol.

. Choose Edit~>Timeline~>Paste Frames to paste the animation into the

Timeline and create the symbol.

You now see the animation on your screen in symbol-editing mode, as
shown in Figure 7-3. We discuss editing symbols later in this chapter.
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Figure 7-3: If you want lots of fruit trucks, turn the animation into a movie clip symbol.
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8. To return to the main movie and Timeline, choose Edit=>Edit
Document.

9. To delete the animation from the main movie (now that you’ve saved
it in a movie clip), select all layers as you did in Step 1 and choose
Edit~>Timeliner>Remove Frames.

You can delete the animation from the main movie because your Library
now has a movie clip that contains that animation. When you choose the
movie clip in the Library panel, you can click the small Play button in the
upper-right corner of the Library panel’s window to play the animation.

Creating a symbol by duplicating a symbol

One more way to create a graphic, button, or movie symbol is to duplicate an
existing symbol. To duplicate a symbol, follow these steps:

1. Open the Library. (Choose Window=>Library.)

2. Select the symbol that you want to duplicate.

3. Click the Options menu in the upper-right corner of the Library
window and choose Duplicate.

Flash opens the Duplicate Symbol dialog box.

4. In the Name text box, type a name for the duplicate. Select the type of
symbol that you want to create if you want a different kind from the
original.

5. Click OK to close the dialog box and create the duplicate symbol.

Modifying Symbols

Flash is a master of flexibility, and sometimes you need to make changes. Of
course, you can change symbols after you create them. Here we explain the
procedures you need to know.

Changing the properties of a symbol
You might need to change a symbol’s properties. For example, you might

create a graphic symbol and then realize that you need it to be a movie clip.
No problem!

To change the properties of a symbol, follow these steps:

1. Choose Windowr>Library to open the Library.

2. Right-click (Windows) or Control-click (Mac) the symbol’s icon (not its
name) and choose Properties.
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The Symbol Properties dialog box opens.

3. If the symbol is a graphic, button, or movie clip, select the type of
symbol that you want in the Type list and then click OK.

Note that this change doesn’t affect symbols that you've already
inserted on the Stage.

Editing symbols

An instance is a copy of a symbol that you insert into your movie. Part of the
power of symbols lies in their control over instances. If you edit a symbol,
Flash updates all instances of that symbol in the movie. You can change a
symbol once and save yourself the time of creating the same change for every
instance of that symbol. For that reason, it’s worthwhile to make a symbol
whenever you want to use a certain shape or group of shapes more than once.

You can edit a symbol in three modes:

1~ Edit in symbol-editing mode. Switches you to symbol-editing mode.
You see only the symbol. Right-click (Windows) or Control-click (Mac) a
selected symbol and choose Edit.

1~ Edit in place. Lets you edit a symbol while still viewing other objects on
the Stage. Other objects are dimmed while you edit the symbol. Right-
click (Windows) or Control-click (Mac) a selected symbol and choose
Edit in Place.

1~ Edit in a new window. Opens a new window where you can edit your
symbol. You see only the symbol. Right-click (Windows) or Control-click
(Mac) a selected symbol and choose Edit in New Window.

The value of editing in place is that you can see how your change works with
the rest of the objects that you have on the Stage. For example, if you want to
make your symbol bigger, you may need to make sure that it doesn’t obscure
some nearby text. However, if you have lots of stuff on the Stage, editing in
symbol-editing mode or in a new window can help you focus more easily on
the symbol itself.

To edit a symbol, follow these steps:

1. Select any instance of the symbol on the Stage.

2. Right-click (Windows) or Control-click (Mac) the instance and choose
Edit, Edit in Place, or Edit in New Window.

Choosing Edit puts you into symbol-editing mode. Flash displays the
symbol name at the top of the screen. If you choose Edit in Place, other
objects are dimmed, as shown in Figure 7-4.
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This kaleidoscope animation is on B
the companion Web site at www . :
dummies.com/go/flashcs5fd.

3. Edit the symbol in any way you
want.

4. After you finish editing, do the
following:

e If you chose Edit or Edit in Place,
click the scene name to the left
of the symbol name or choose
Edit=>Edit Document.

° If}.fou chosg Edit in New Figure 7-4: One symbol, which includes a
Window, click the Close wedge and some circles, is being edited.
button.

You are now back in your main movie.

Using Symbols from Other Movies

After you create a symbol and store it in the Library, you can use that Library
in any other movie. You can also open the Library from any other movie and
use its symbols in your current movie.

If the other movie is open and its Library is open, you can access that mov-
ie’s Library from within your current movie. Libraries of any open movie are
available from any other open movie. Just choose that other movie in the
drop-down list at the top of the Library panel. (Choose Window=>Library to
open the Library.)

To use a symbol from the Library of another movie that is closed, follow
these steps:
1. Choose File~>Import~>Open External Library.
The Open as Library dialog box opens.
2. Select the movie file.
3. Click Open.

Flash displays the Library of the other movie in a new Library window.
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The new Library might hide your current movie’s Library. Just drag the new
Library by its title bar so that it rests under the current Library until it docks
there. In the new Library, many Options menu items and icons are disabled
to prevent you from making changes in the other movie’s file.

To use a symbol from the other Library, drag the symbol onto the Stage.
When you do this, Flash places a copy of the symbol in the current movie’s
Library. (See Chapter 2 for more information about the Library.)

You can also update or replace any graphic, button, or movie clip symbol in
your movie’s Library with the content of a symbol from any other Library on
your hard drive or network. Accessing a symbol in this way is called author-

time sharing of symbols or assets.

When you share a symbol while you're creating a movie (during authoring), the
symbol in your current movie keeps its original name, but the contents take
on the properties of the symbol you're sharing. If you have already replaced

a symbol and the outside symbol changes (because it has been edited), use
author-time sharing to update the symbol in your current drawing.

To update or replace a graphic, button, or movie clip symbol in your movie
with the properties of another symbol, follow these steps:

1. Open the Library (choose Window=>Library) and select the symbol
you want to update or replace.

2. From the Library Options menu, choose Properties.
The Symbol Properties dialog box opens.

3. Click Advanced, if necessary, to see the expanded dialog box. In the
Source section, click Browse.

The Locate FLA File dialog box opens.

4. Navigate to the movie (. £1a) file that contains the symbol you want to
use. Select it and click Open.

The Select Symbol dialog box opens; see Figure 7-5. You see a list of the
symbols in the movie that you selected.

5. Choose a symbol and click OK.

When you choose a symbol, you see a preview in the preview box, so
you can easily find the symbol you want, as shown in Figure 7-5. When
you click OK, you’re back in the Symbol Properties dialog box.
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Figure 7-5: Choose another symbol to take on its properties.

6. In the Source section of the Symbol Properties dialog box, select the
Always Update Before Publish check box if you want to automatically
update the symbol if the original has changed.

Enable this check box to create a link between the source symbol and
the symbol in your current movie.

7. Click OK.

You now have a symbol in your Library that has its original name but looks
like the symbol you chose from the other movie.

Using the Flash Library

Flash comes with three common libraries you can use. To access these librar-
ies, choose Windowr>Common Libraries and then select the one you want.
Flash includes buttons, sounds, and classes (building blocks for developing
ActionScript applications). These libraries are also a good place to pick up
ideas and see what you can create in Flash.

Using the Flash For Dummies Library

The Flash Libraries contain some good examples, but they miss many basic
shapes and simple objects, some of which are hard to draw in Flash. We
decided to fill in the gaps! We created a Library of art, geometric shapes, and
fun shapes that you can use in your movies. You’'ll find 79 items in all!l The
Flash For Dummies Library is named Flash CS5 For Dummies Library.
fla. You can find it at www.dummies.com/go/flashcs5£d.
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To use this Library, go to www . dummies.com/go/flashcs5£fd and download
Flash For Dummies Library.fla.In Windows, download it to the
Program Files\Adobe\Adobe Flash CS5\en_US\Configuration\
Libraries folder on your hard drive. (The en_uUs folder indicates an English
version of Flash.) On the Mac, download it to the Applications/Adobe
Flash CS4/Configuration/Libraries folder on your hard drive.

After that, you can open this Library the same way you open other common
Libraries: Choose Window=>Common Libraries=>Flash CS5 For Dummies
Library.fla. We hope you enjoy it!

Working with Instances, for Instance

<MBER
S

After you create a symbol, you can use it in many ways. You can insert it in
your movie, inside other symbols, or even in other movies. Each copy of the
symbol is called an instance. You can change the properties of an instance so
that it differs from its parent symbol. For example, you can change the color
of an instance — the original symbol remains unchanged.

Inserting instances
To insert an instance of a symbol, follow these steps:

1. Choose Windowr>Library (Ctrl+L or F11 for Windows or 38+L or F11
for the Mac) to open the Library, as shown in Figure 7-6.

2. In the layer list, choose the layer where you want the instance to be
placed.

See Chapter 6 for the full story on layers.

3. Click a keyframe on the Timeline where you want the instance to be
placed.

Flash places instances only in keyframes (frames that define a change in
your animation). If you don’t select a keyframe, Flash puts the instance
in the first keyframe to the left of the current frame. (See Chapter 9 for
more about keyframes.)

4. Drag the symbol from the Library to the Stage.

You can drag from the list of items or directly from the preview at the
top of the Library.



When you insert a graphic instance, you need

to consider how it fits in your entire animation.
For example, the instance might be the starting
point for some animation, or it might be part of
the background that remains static throughout
the animation. Perhaps you want the instance to
suddenly appear at some point in the animation.
If the instance contains animation, you need to
insert it at its proper starting point. (Chapter

9 explains how to copy graphics across any
number of frames to create a static background
and covers the entire topic of animation in
detail.) A movie clip instance, however, takes

up only one frame on the Timeline. It plays

and loops automatically unless you create
ActionScript code to control it. (Chapter 10
talks about ActionScript.)

Editing instances

A symbol’s children don’t have to be carbon
copies of their parents, thank goodness.
Instances of a symbol can differ from their parent
symbol by color, type, and play mode. You can
also rotate, scale, or skew an instance, leaving
the parent symbol unchanged.

When you edit an instance, Flash remembers the
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Figure 7-6: Insert an instance
of a symbol by dragging it from

the Library.

changes. If you later edit the symbol, Flash doesn’t forget the changes you
made to the instance. Suppose that you create a red circle graphic symbol,
and then you create several instances of it and change one instance to
pink. Then you edit the (still red!) circle symbol to change it to an oval. All
the instances are now ovals, but the one you turned pink is still pink. The
instance’s shape has been updated, but the pink color remains.

In the Property inspector (choose Windowr>Properties) you can change an
instance’s color (or tint), brightness, or transparency, giving you some useful
control over the appearance of your instances. To change an instance’s
color, brightness, or transparency, follow these steps:

1. Select the instance.

2. Choose Windowr>Properties to open the Property inspector.
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3. Expand the Color Effect section and select one of these options in the
Style drop-down list:

e None: Adds no color effect.
e Brightness: Changes the lightness or darkness of the instance.
e Tint: Changes the color of the instance.
e Advanced: Changes both the color and the alpha.
e Alpha: Changes the opacity/transparency of the instance.
4. Make the desired changes, as we explain in the next few sections.

You see the changes that you make in the Property inspector immedi-
ately in your selected instance.

Changing brightness

When you choose Brightness in the Style drop-down list, a text box and a
slider appear. Type a brightness percentage or drag the slider and see the
result in the symbol instance. High brightness makes the image light, and
100% brightness makes the instance white. (It disappears if you have a white
background!) Low brightness makes the image dark; 0% percent brightness
turns the instance black.

Changing tint

When you choose Tint from the Style drop-down list, you can choose the color
and then the amount of the color (the tint), by percentage, that you want to
apply. Figure 7-7 shows the controls for this option. You can select a color by
clicking the Tint Color swatch and choosing from the color swatches, by drag-
ging the sliders, or by typing red, green, and blue values (if you know them).

Specify the percentage of the color you want to apply by typing a value in the
Tint Amount text box or by dragging the slider to choose a percentage. When
the percentage is set to 100%, the instance changes to the color you speci-
fied. If the percentage is set to 0%, Flash leaves the instance unchanged.

The Flash method of specifying a color gives you great flexibility and preci-
sion. You can choose a color and use the tint control to create a meld of the
current color and your chosen color.

Changing color and transparency at the same time

Select Advanced from the Style drop-down menu to change the red, green,
and blue color values and the transparency at the same time. Figure 7-8
shows the controls, which are complex.
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Use the controls on the left to
specify the color or transparency as
a specific percentage of the current
value. Use the controls on the right
to change the color or transparency
to a specific, absolute amount. Flash
calculates the new color value by
multiplying the current value by the
percentage you specified and then
adding the value from the right side.
As you can see, this method provides
lots of control — but it might make
you crazy first.

To simply change both the color and
the transparency of an instance,
choose Tint from the Style drop-
down list to change the color and
then choose Advanced, changing
only the left Alpha setting.

Changing transparency

Choose Alpha from the Style drop-

down menu to change the transpar-
ency of an instance. (Alpha enables
levels of transparency, and you can
think of the term as somewhat syn-
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onymous to opacity.) Use the slider or Figure 7-7: Changing the tint used on a symbol
type a value in the text box. A value of instance.

0 means that your instance becomes
completely transparent: In that case,
when you return to the Stage, all you
see is the selection border and the
small plus sign that marks the sym-
bol’s registration point. When you
deselect the instance, you see abso-
lutely nothing! (Chapter 4 explains
more about a symbol’s registration
point, including how to move it. See
the section on groups.)
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Figure 7-8: The Advanced controls for
instances.
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Partial transparency lets your background show through. A partially trans-
parent instance blends in with your background, creating a softer effect.
However, transparency is a complex feature and can slow down the loading
and playing of a movie.

Adding filters and blends

You can apply special graphic effects called filters to text, buttons, and
movie clips — but not to graphic symbols. Select the item and expand the
Filters section of the Property inspector, if necessary. Click the Add Filter
button and choose one (or more) of the following filters: Drop Shadow,
Blur, Glow, Bevel, Gradient Glow, Gradient Bevel, or Adjust Color. The
Filters section then displays further controls so that you can specify how
you want the filter to look. You can get some cool effects this way. You can
even add multiple filters to an object.

The Adjust Color filter is a way to change a symbol’s brightness and tint in
one place. Instead of choosing the color from a color swatch, as described
previously in the “Changing tint” section, you adjust contrast, saturation, and
hue values.

To apply filter settings from one object to another, you can copy and paste
one or more filters.

To copy and paste filters, follow these steps:

1. Select the object that has the filter (or filters) that you want.

2. In the Filters section of the Property inspector, select the filter that
you want to copy.

3. Click the Clipboard button. From the pop-up menu, choose Copy
Selected or Copy All.

4. Select the object that you want to have the filters.
5. Click the Clipboard button. From the pop-up menu, choose Paste.

You can also apply blending modes to movie clips. Blending modes determine
how movie clips that overlap blend with each other at the point of overlap.
To apply a blend, select a movie clip instance (one that overlaps another
instance) and adjust the color and transparency as we explain in the previ-
ous sections. Then choose a blend mode from the Blending drop-down list

of the Property inspector’s Display section. The results depend a lot on the
colors and alpha of the overlapping symbols. You can choose from the fol-
lowing blending modes:
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1 Normal: The default; applies colors with no change.

v~ Layer: Enables you to stack symbols on top of each other with no
change in their color.

1~ Darken: Replaces areas lighter than the blend color, leaving the darker
colors unchanged.

1 Multiply: Multiplies the color of the selected symbol and the overlap
color mix (the blend color), resulting in a darker color.

1~ Lighten: Replaces darker areas, leaving the lighter color.

1 Screen: Multiplies the inverse of the blend color and the symbol’s color,
giving a bleaching effect.

1 Overlay: Blends the two layers by multiplying or screening the colors.
1~ Hard Light: Creates a spotlight effect.

1~ Add: Creates a lightening dissolve effect.

1~ Subtract: Creates a darkening dissolve effect.

1~ Difference: Subtracts the colors, with a negative-like effect.

v~ Invert: Inverts the color of the selected symbol.

v~ Alpha: Applies an alpha mask, making the symbol transparent.

v~ Erase: Removes all color, effectively making the selected symbol
disappear!

Changing an instance’s type

The instance type — graphic, movie clip, or button — comes from the
symbol type, but you might want to change it. For example, if you created
some animation and saved it as a graphic symbol, you might want to use it as
a movie clip. Rather than change the symbol type, you can change only the
type of the instance that you have inserted.

To change the instance type, follow these steps:

1. Select the instance.
2. Choose Windowr>Properties to open the Property inspector.

3. From the Instance Behavior drop-down list, in the top section of the
Property inspector, select one of the following types:

e Graphic: If the graphic contains animation, select Graphic from
the Instance Behavior drop-down list. Then determine how
the animation will run by expanding the Looping section of the
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Property inspector. From the Options drop-down list, choose one
of the following:

Loop plays the animation contained in the instance over and over
during the frames occupied by the instance.

Play Once plays the animation one time from the frame you specify.

Single Frame displays any one frame of the animation. In other
words, the animation doesn’t play; you specify which frame the
movie displays.

* Button: To create a button, select Button from the Instance
Behavior drop-down list. Then specify how the button will func-
tion in the Tracking section of the Property inspector. From the
Options drop-down list, select Track as Button if you're creating
single buttons. Select Track as Menu if you're creating pop-up
menus. You can specify an Instance Name in the Instance Name
text box at the top of the Property inspector.

e Movie Clip: To create a movie clip, select Movie Clip from the
Instance Behavior drop-down list. Then specify an Instance name
in the Instance Name text box at the top of the Property inspector.
You use this name with certain ActionScript controls so that you
can refer to and control the instance. (For more information about
ActionScript, see Chapter 10.)

If you select a movie clip or button instance, you can select the Cache as
Bitmap check box in the Property inspector. Runtime bitmap caching opti-
mizes playback of a Flash movie in a browser. Use bitmap caching only when
you have a complex background that remains the same throughout the
movie. By storing the background as a bitmap, the Flash player can play the
animation faster and more smoothly because it doesn’t have to redraw the
image throughout the movie.

Replacing an instance

Suppose that you create a complex animation with bouncing bunnies all over
the Stage. Suddenly your boss decides that some of the bouncing bunnies
should be bouncing squirrels instead. Meanwhile, you had already edited all
the bunnies to make them different sizes and colors. You need a way to replace
some of the bunnies with squirrels without losing their sizes and colors.

To replace an instance, follow these steps:

1. Create the squirrel symbol (or whichever new symbol you need).
Flash stores the new symbol in the Library.

2. Select an instance of the bunny — that is, your original instance — on
the Stage.
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3. Choose Window=>Properties to open the Property inspector.

4. Click the Swap Symbol button to open the Swap Symbol dialog box, as
shown in Figure 7-9.

Swap Symbol ==l
& e
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R bu‘v [54] Resources
[E5]

Figure 7-9: The Swap Symbol dialog box makes life easy when you
change your mind.

5. In the dialog box, select the squirrel or any other symbol.
6. Click OK to swap the symbols and close the Swap Symbol dialog box.

Flash retains your color effects and size changes but changes the symbol.

Unfortunately, you must repeat this process for all the bunnies you want to
change on the Stage, but it’s better than reinserting all your instances and
re-creating the instance changes.

If your boss actually wants you to change all the bunnies to squirrels, your
job is much simpler. Just edit the bunny symbol (as we describe in the
“Editing symbols” section, earlier in this chapter) to replace the bunny image
with a squirrel. Then all the instances of that symbol instantly change to
squirrels yet retain the color effects and size changes that you gave them
while they were still bunnies.

Duplicate a symbol when you want to use one symbol as a springboard for
creating a new symbol. Follow the instructions in the “Creating Symbols”
section, earlier in this chapter. Make any changes that you want to the new
symbol and place instances on the Stage.

Breaking apart an instance

You can break apart an instance into its component objects. The original
symbol remains in the movie’s Library. You might want to use the instance as
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a starting point for creating a completely new symbol, or you might want to
animate the components of the symbol so that they move separately. Other
instances remain unchanged.

To break apart an instance, select it and choose Modify=>Break Apart. If an
instance contains symbols or grouped objects within it, you can use the
Break Apart command again to break apart those internal objects as well.

Changing 3D position and rotation

You can move and rotate movie clip instances in 3D space. (Other symbols
aren’t invited to this 3D party!) When you change a movie clip instance in this
way, it’s considered a 3D object. This feature let’s you create the appearance
of depth and adds to the realism of your movies.

When you use Flash’s 3D features, you must publish your movie using the
Flash Player 10 (or later) and ActionScript 3.0 settings. Earlier versions of the
Flash Player and ActionScript don’t support these 3D features. For more
information on publish settings, see Chapter 13.

Moving movie clip instances

You can move movie clip instances in all three directions (called translation),
using the 3D Translation tool. Of course, moving an object in the X (hori-
zontal) and Y (vertical) directions doesn’t require a special tool; however,
you often want to move a movie clip instance in all three directions at once,
so the 3D Translation tool is very handy. Figure 7-10 shows an instance of a
movie clip before using the 3D Translation tool (on the left) and after moving
it toward the viewer (on the right).

The 3D Translation tool has two modes:

1 Global mode: Moves the movie clip relative to the Stage. The 3D
Translation tool defaults to Global mode.

1~ Local mode: Moves a nested movie clip relative to its parent movie clip.

Q— y-axis (vertical)
- x-axis (horizontal)

Figure 7-10: The 3D Translation tool moves movie clips in
all three directions.
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Here’s how to move a movie clip instance:

1. Choose the 3D Translation tool from the Tools panel.

The 3D Translation tool is part of a flyout that also contains the 3D
Rotation tool. If necessary, click and hold the 3D Rotation tool (dis-
cussed next) and then choose the 3D Translation tool from the flyout.

2. Click an instance of a movie clip symbol on the Stage.
The 3D axis appears on the movie clip.

3. Set the mode, global or local, using the Global Transform button in
the Options section of the Tools panel.

Select the Global Transform button to use global mode. Deselect the
button to use local mode.

4. To move the movie clip, do one of the following:

¢ To move the movie clip horizontally, drag the red x-axis arrow to
the left or right. (The cursor shows a small “x” while you drag.)

* To move the movie clip vertically, drag the green y-axis arrow up
or down. (The cursor shows a small “y” as you drag.)

¢ To move the movie clip in the z direction (toward or away from
the viewer), drag the black dot at the center of the axes up (away
from the viewer) or down (toward the viewer). (The cursor shows
a small “z” as you drag.) If you move the movie clip toward you, it
appears larger; if you move it away from you, it appears smaller.

Note that if you rotate the movie clip instance so that you're not looking
directly down at it, as we explain in the next section, you see a z axis, rather
than just a dot.

For greater control over 3D position, you can use the Property inspector.
Display the Property inspector (Windowr>Properties) and select a movie clip
instance. Expand the 3D Position and View section to display the controls. To
change one of these controls, click the current value and type a new value or
drag up or down on the value. You can set the following controls:

1 X: The horizontal position on the Stage of the movie clip instance.

v~ Y: The vertical position on the Stage of the movie clip instance.

v~ Z: The z axis position of the movie clip instance. Values less than (0 are
closer to the viewer; the instance looks larger. Values higher than 0 are
farther away and look smaller.

The W value is the perspective width. It shows how wide the object looks.
The H value is the perspective height and shows how high the object
looks. These values are for information only; you can’t change them.
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1~ Perspective Angle: The apparent angle of view. This value works like a
camera lens’ angle of view. The default value is 55°, which is a normal
camera lens. Values can range from 1° to 179°. A higher value makes
the object appear closer; a lower value makes the object appear farther
away. Try adjusting the value. With certain types of rotation, the results
can be positively weird!

1+ Vanishing Point X Position: The horizontal position of the z axis.

1~ Vanishing Point Y Position: The vertical position of the z axis.
The location of the vanishing point controls how an object moves along the
z axis. The vanishing point affects all movie clips on the Stage that have a 3D

transformation or rotation. By default, the vanishing point is at the center of
the Stage.

Rotating movie clip instances

You can rotate the position of a movie clip instance in all three directions
using the 3D Rotation tool. Like with translation, described just previously,
you can rotate globally or locally. Figure 7-11 shows a movie clip instance in
its initial state (on top) and rotated in all three directions (on the bottom).

axis

axis

axis

and y-axis in rotation together

Figure 7-11: The 3D Rotation tool lets you drag your
movie clips any which way.



Chapter 7: Heavy Symbolism ’ 9 ’

Follow these steps to rotate your movie clip instance:

g 1. Choose the 3D Rotation tool from the Tools panel.

The 3D Rotation tool is part of a flyout that also contains the 3D
Translation tool. If necessary, click and hold the 3D Translation tool
(just discussed) and then choose the 3D Rotation tool from the flyout.

2. Click an instance of a movie clip on the Stage.

The 3D Rotation control appears on the movie clip instance. If the con-
trol appears in a different location, double-click the control’s center
point to move it back to the selected instance.

3. Set the mode, global or local, using the Global Transform button in
the Options section of the Tools panel.

Select the Global Transform button to use global mode. Deselect the
button to use local mode.

4. To rotate the movie clip instance, do one of the following:

e To rotate the movie clip around the red x axis, drag the x-axis
control.

e To rotate the movie clip around the green y axis, drag the y-axis
control

* To rotate the movie clip 