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Introduction

Hundreds of free programs exist that have similar functionality to proprietary software. 

Here are some of the ones we cover in this book:

Free Program Proprietary

LibreOffice Microsoft Office

Firefox Edge/Internet Explorer

Gimp Adobe Photoshop

Inkscape Adobe Illustrator

Dia Visio

GnuCash Quicken

Audacity Many audio editors

OpenShot Many video editors

LibreOffice Microsoft Access

In many cases, these free programs are better quality and have more features than 

their expensive counterparts. So, why aren’t they used more? It’s because the companies 

that make free software spend $0 on marketing. Microsoft and other companies spend 

millions.

Personally, I haven’t paid for any software program in the past 20 years, until buying 

a copy of Microsoft Windows to write this book. As such, I haven’t missed anything.

Proprietary software is written by people who want money. If a feature is not going 

to bring in money, it doesn’t get produced. Free software is written by people who want 

programs that work. Because they are using the programs, the features they choose to 

implement are the ones that are most beneficial to the people using them.

Thus, free software is sometimes on the cutting edge of technology. For example, 

tabbed browsing first appeared in Firefox in 2001 (back when it was called Mozilla). 

Microsoft eventually decided to copy this useful feature and include it in its Edge and 

Internet Explorer browsers. 
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You will find that the software introduced in this book is not only cheap but highly 

useful. You are encouraged to download and try the programs presented for free.  

The publisher’s web site at www.apress.com contains links to the various programs 

described as well as the examples used in this book.

—Steve Oualline

Introduction

http://www.apress.com/
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CHAPTER 1

Web Browsing with  
Firefox
Web browsing is the most common activity that users do on computers. Unfortunately, 

the web browser that comes with Windows is limited, insecure, and not private. 

Fortunately, there is an open source web browser that is available for free, Firefox, which 

doesn’t have these problems.

In this chapter, we discuss the most useful advanced features of this browser.

•	 Tab muting: This is a way of silencing the autoplay videos and ads, as 

well as anything else you want to silence.

•	 Private browsing: This is the ability to browse the Web without being 

tracked.

•	 Tab and bookmark synchronization: This feature makes sure that you 

have the same information on both your home and office computers.

•	 Reading mode: This is a way of displaying a screen without the clutter.

•	 Ad blocking: You can install an add-on to block ads from appearing 

on your screen.

•	 Video downloader: You can download videos from YouTube or other 

places for later viewing.

Note  Google Chrome is another popular open source web browser with a 
comparable set of features, but our preference is Firefox, so we’ll focus on that.
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�Getting Firefox
You can download the Firefox browser by searching for Firefox in a different browser and 

clicking Download in the search results. Or you can go straight to www.mozilla.org and 

then click Get Firefox Today Link. Firefox will detect your language settings and give you 

a download customized for your language.

After downloading the file, run it (you’ll probably have to tell the Windows security 

system that you do really want to run the program). Then select all the defaults during 

installation, with one exception. When it comes to making Firefox your default browser, 

we suggest you answer no. We’ve encountered programs, especially those made by 

Microsoft, that get upset if you change this setting.

If you want to create an account, you can do so now. However, you can also wait until 

you get to the “Setting Up an Account” section, where we cover account creation and 

what you can do with a Firefox account.

�Using Mute Tabs
The Web can be a wonderful place, but video ads that play automatically can be annoying. 

Firefox has a nice feature called tab muting that allows you to shut off the annoying ads, 

videos, and other sounds without having to turn off the sound for your entire browser.

You will find a small speaker icon that appears on any tab playing sound, as shown in 

Figure 1-1.

Click this icon, and you will see a line across the speaker icon to indicate that the 

sound is muted, as shown in Figure 1-2. The absence of a loud and annoying sales pitch 

is a good indicator that the tab muting feature is working.

Figure 1-1.  Speaker icon

Figure 1-2.  Mute tab

Chapter 1  Web Browsing with Firefox 
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The speaker appears only when the tab is playing sound. You can mute silent tabs 

that might play sound in the future by right-clicking the tab and selecting Mute Tab, as 

shown in Figure 1-3.

Although simple, this control is extremely useful when it comes to browsing the Web.

�Browsing Privately
The Internet has lots of techniques to track you as you browse. But sometimes you don’t 

want “big data” looking over your shoulder. That’s where private browsing comes in. It 

prevents the browser, and to some extent the Internet, from remembering what you were 

doing while online.

For example, you’ve probably noticed that after making a big purchase, such as 

buying a 3D printer, you’ll get bombarded with ads for 3D printers. That’s because 

advertisers go to a great deal of trouble to track every web page you visit and target you 

with ads for what you just bought. It’s annoying.

The browser also remembers your history and uses it to supply helpful suggestions 

when you are entering web addresses.

If you don’t want someone to know where you’ve been browsing, you need  

private mode.

Private mode does have one drawback. If for some reason the browser crashes, it will 

not remember what tabs you had open before the crash. This is by design; no record of 

what’s going on in a private window is recorded. This also means your private pages are 

not shared between computers.

Figure 1-3.  Mute tab

Chapter 1  Web Browsing with Firefox 
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However, not everything is totally secret. If you bookmark a page, that bookmark will 

be available after the private session is closed. Downloaded files are not erased (just the 

fact you visited a downloaded page is forgotten).

Private browsing is useful if you don’t want people to know you’ve been at certain 

sites. In some countries, this means going to blogs or sites that discuss things your 

government doesn’t approve of. In other cases, it could be because you need to search 

the Web for a private matter. Or it could be just because you don’t want “big data” 

tracking you and selling your information to people for targeted ads or some other 

reason.

�Starting Private Browsing
To open a private window in Firefox, follow these steps:

	 1.	 Start Firefox normally.

	 2.	 Click the Menu icon (the three lines).

	 3.	 Click the New Private Window button, as shown in Figure 1-4.

Figure 1-4.  Creating a private window

Chapter 1  Web Browsing with Firefox 
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You can tell that you are in a private window because there is a little mask in the 

upper-left corner of the browser. The big purple screen saying that you are now browsing 

privately is a big giveaway too, as shown in Figure 1-5.

�Synchronizing Tabs and Bookmarks
Suppose you find that perfect recipe online and want to transfer this bookmark to your 

home computer. With bookmark synchronization, bookmarks you make on any machine 

with synchronization enabled are automatically transferred to all other machines using 

the same synchronization account.

In another example, let’s say you get up in the morning and start to work on five 

different projects using five different tabs in your browser. But then you have to take your 

daughter to school and go to work. You’d like to continue at the office where you left off 

at home, but you need those open tabs to do this. With tab synchronization, you can grab 

the open tab list from one machine and transfer it to another.

To do this, you’ll need to set up an account in Firefox. The process is simple, and the 

result is that your browsing sessions are now portable between machines.

Figure 1-5.  Private window

Chapter 1  Web Browsing with Firefox 
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�Setting Up an Account
First you need to create an account or sign in to an existing account. Start by clicking the 

Menu icon and then select Sign in to Sync, as shown in Figure 1-6.

A welcome screen appears, as shown in Figure 1-7. If you don’t have an account, 

click Create Account. If you do, skip down to where you sign in for the second time.

Figure 1-6.  Signing in to sync

Chapter 1  Web Browsing with Firefox 
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The next screen (shown in Figure 1-8) asks for the information needed to create the 

account. Fill it in and click “Create account.”

Figure 1-7.  Signing in

Chapter 1  Web Browsing with Firefox 
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You now go to a screen asking what you want to sync, as shown in Figure 1-9. 

You probably want everything, so just click “Save settings.”

Figure 1-8.  Account creation information request screen

Chapter 1  Web Browsing with Firefox 
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To make sure you are who you say you are, the system will send you a confirmation 

e-mail. We used a Gmail account for this example, so it gives us the option to go our 

Gmail box directly, as shown in Figure 1-10.

Figure 1-9.  Saving your settings, the final account creation step

Chapter 1  Web Browsing with Firefox 
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Now all that’s needed is to open the message and confirm the account, as shown in 

Figure 1-11.

Figure 1-10.  Opening the Gmail screen

Chapter 1  Web Browsing with Firefox 
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Finally, you are done creating the account and receive the confirmation screen, as 

shown in Figure 1-12.

Figure 1-11.  Verification e-mail

Chapter 1  Web Browsing with Firefox 
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�Performing the Synchronization
Now surf the Web, find lots of interesting places, and bookmark them. Firefox will 

automatically upload your changes to the Firefox Sync Server on its own internal 

schedule. If you are nervous and want to make sure your changes are uploaded, click the 

Menu icon and then click the Manual Sync icon (the circling arrows) next to the account 

name (e-mail address), as shown in Figure 1-13.

Figure 1-12.  Confirmation

Chapter 1  Web Browsing with Firefox 
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Now go to another computer, set up Firefox, and sign on to your sync account. Take 

a look at your bookmarks. Notice that they are the same as your original machine. They 

have moved from one machine to the other.

Now click the Menu icon and Synced Tabs again (as shown in Figure 1-13).

Firefox displays a list of tabs on the other computer, as shown in Figure 1-14. In this 

example, the other computer is named “user2-PC,” and we’ve opened a lot of tabs on our 

favorite publisher’s web site.

Figure 1-13.  Manual Sync icon

Chapter 1  Web Browsing with Firefox 
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Click any of those tabs, and the page will appear in your local browser. 

�Using Reading Mode in Firefox
On some web pages you will find a banner ad at the top, a navigation bar under that, 

advertisements on the left, links to related stores on the right, and the actual text you 

want to read in the middle as an afterthought. Firefox has a feature called reading mode, 

which is designed to put the text you want to read front and center on the screen and get 

rid of all the other garbage.

Figure 1-14.  Tabs from the other computer

Chapter 1  Web Browsing with Firefox 
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Figure 1-15 shows a typical web article. You will notice that there is some clutter on 

the page from the junk important marketing information on the side.

Now click the Reading Mode icon at the top of the page. This causes Firefox to 

reformat the article to make readable, removing all the clutter in the process, as shown in 

Figure 1-16.

Figure 1-15.  Typical article

Chapter 1  Web Browsing with Firefox 
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As you can see, Firefox removes all the extra junk on the page and gives you a nice, 

clean article, making it much easier to read.

�Blocking Ads
An ad blocker keeps ads from appearing on your screen and has two advantages. 

The first is that the clutter on the screen is reduced. The second is that you use less 

bandwidth and therefore your pages load faster. Let's start by going to http://simple-

adblock.com/faq/testing-your-adblocker/, as shown in Figure 1-17.

Figure 1-16.  Reading mode view of the same page

Chapter 1  Web Browsing with Firefox 
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This page is filled with two big “ads” that say “Not working.” (This is not the most 

effective product name in the world, but it does get the point across.)

Notice that the top of the screen contains a real ad for Adblock Plus for Internet 
Explorer. Figure 1-17 was taken on Windows 10, which uses the Edge browser and 
doesn’t have Internet Explorer installed.

Now we show how to install an ad blocker and see what happens to this page.

�Getting the Ad Blocker
To install an ad blocker extension, click the Menu icon and then Add-ons, as shown in 

Figure 1-18.

Figure 1-17.  “Ad”-filled web pages

Chapter 1  Web Browsing with Firefox 
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This brings you to the screen shown in Figure 1-19, which lists the add-ons Firefox 

thinks you might want to install. But the ad blocker is not there. So, scroll to the end and 

click “See more add-ons!”

Figure 1-18.  Getting to the add-ons

Chapter 1  Web Browsing with Firefox 
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The next screen allows you to enter a search term. Enter ad blocker and click the 

arrow to perform a search, as shown in Figure 1-20.

Figure 1-19.  Getting more add-ons

Figure 1-20.  Add-on search/install page

Chapter 1  Web Browsing with Firefox 
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Click Add to Firefox to install the extension called Ad-Blocker. A confirmation 

window will appear, as shown in Figure 1-21. Click Install.

This brings up the Ad-Blocker home page, as shown in Figure 1-22.

Now go back to the ad test page at http://simple-adblock.com/faq/testing-

your-adblocker/. All those red “ads” will have turned to green, indicating that ads are 

being blocked, as shown in Figure 1-23.

Figure 1-21.  Confirmation screen

Figure 1-22.  Ad-Blocker home page

Chapter 1  Web Browsing with Firefox 
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Some web operators are getting smart. They detect ad blockers and refuse to show 

you their content until you turn them off. To disable the blocker for a single page, click the 

down arrow next to the blocker icon and select “Disable on this page only.” Figure 1-24 

shows you the steps.

Figure 1-23.  No more ads

Figure 1-24.  Disabling some ad blocking

Chapter 1  Web Browsing with Firefox 
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�Using Video DownloadHelper
Video DownloadHelper is an add-on designed to combat the “pausing” that occurs 

when you download shows, and it works on YouTube and most other steaming 

providers. It also lets you download videos for offline use when you don’t have access to 

the Internet.

For example, have you ever started watching a movie from a slow server in another 

country and have to deal with the video continually pausing? Video DownloadHelper 

lets you download your shows and watch them offline with no buffering.

�Getting Video DownloadHelper
You can get Video DownloadHelper for Firefox via the Add-ons menu using the same 

techniques you used to get Ad-Blocker. Searching for videodownload helper in the 

extension manager results in the screen shown in Figure 1-25.

After installation, you will be taken to the Video DownloadHelper home page, as 

shown in Figure 1-26.

Figure 1-25.  Search results with Video DownloadHelper

Chapter 1  Web Browsing with Firefox 



23

Now let’s go to a web page with video content, such as YouTube, as shown in 

Figure 1-27.

Figure 1-26.  Video DownloadHelper home page

Figure 1-27.  A popular video web site (source: public domain)

Chapter 1  Web Browsing with Firefox 
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Let’s play a video. Notice that the Video DownloaderHelper icon becomes active 

(changes to a color icon). Click this icon to bring up the download menu. It lists the 

various videos that are available. Click a selection to download it. This will open a dialog 

asking you where to save the result, as shown in Figure 1-28.

Sometimes the Video DownloaderHelper needs the help of an external program to 

convert the video. When that happens, a pop-up dialog (Figure 1-29) will appear asking 

you to install it.

Figure 1-28.  “Save file” dialog

Figure 1-29.  Converter request

Chapter 1  Web Browsing with Firefox 
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Clicking “Install converter” takes you to the screen in Figure 1-30, which allows you 

to download the given program.

After downloading, click the Download icon and select the ConverterHelper.exe 

entry to install it, as shown in Figure 1-31.

Figure 1-30.  Download page

Chapter 1  Web Browsing with Firefox 
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Now all you have to do is to start a video, and you can download it. Then close the 

window (but not the browser) and let the download finish. Watch it at your leisure. This 

avoids the buffering problem and other issues caused by slow servers and a long Internet 

connection to Hong Kong, for example.

�Using Other Firefox Features
There are lots of other features available for Firefox. It has been designed to be highly 

customizable and highly extensible. In fact, you can customize its appearance until it’s 

almost unrecognizable.

There are thousands of add-ons, including custom search tools, download managers, 

games, and translation tools.

�Summary
The best thing about Firefox is that it was written by people who want a good web 

browser, not one designed by a marketing department and not one designed to steer you 

toward certain web pages or search results. The designers wanted a web browser to make 

web surfing better. For the most part, the Firefox designers have succeeded in that goal.

Figure 1-31.  Installing the helper
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PART I

LibreOffice
LibreOffice is an office suite with a set of features similar to Microsoft Office. For the 

most part, you’ll be hard-pressed to find a useful feature of Microsoft Office that’s 

not in LibreOffice. The converse is not true. There are useful features contained in 

LibreOffice not available in Microsoft Office such as the sidebar, gallery, and integrated 

database. (That’s not to say that Microsoft Office doesn’t have functions that are not in 

LibreOffice. But we have yet to find a useful feature of Microsoft Office that LibreOffice 

does not have.)

LibreOffice has an interesting history that shows you how an open source program 

can survive and grow even in the midst of turbulent times. LibreOffice started out 

as StarOffice, a proprietary Microsoft Office replacement designed to work on many 

different types of systems, not just Microsoft Windows. As a commercial product, it never 

really was a big success.

Sun Microsystems bought StarOffice and ported it to Sun’s SPARC line of 

computers. Sun changed the name to OpenOffice and made it open source, meaning 

it was freely available to everyone. Sun gave it away because it was in the business 

of selling SPARC systems, not software, and the company figured it could sell more 

SPARCs if it had an office suite for its processors. Unfortunately, Sun didn’t sell 

enough systems and got bought by Oracle at a fire-sale price. Oracle didn’t care much 

for OpenOffice and basically turned its back on people who wanted to contribute 

improvements to this program.
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Since OpenOffice was an open source project, users could copy it and produce their 

own version, with one exception, the word OpenOffice. That one word was trademarked 

by Oracle and couldn’t be copied. So, everything but the name was copied in a process 

called forking, and a new name was chosen: LibreOffice. All those people who had their 

improvements ignored for OpenOffice submitted them to the LibreOffice project where 

most of them were accepted. The result was the much-improved office suite that we 

describe in this book. The history of LibreOffice shows how powerful the open source 

development model is. No one really “owns” the software.

You can download LibreOffice at www.libreoffice.org. After downloading it, 
run the installer, and select all the defaults for the installation.

Part I  LibreOffice
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CHAPTER 2

Getting Started with 
LibreOffice Writer 
LibreOffice Writer is the word processing component of LibreOffice. It does pretty much 

everything useful that Microsoft Word does. It’s been used to write everything from  

one-page letters to 800-page books. As a matter of fact, this book was originally written 

using LibreOffice.

You will your adventure with LibreOffice by creating a party invitation. During this 

process, you will learn about the following:

•	 Getting started with LibreOffice

•	 Selecting fonts

•	 Setting font sizes

•	 Coloring text and backgrounds

•	 Coloring paragraphs

•	 Aligning paragraphs with left, right, and center justification

•	 Inserting graphics into your documents

Figure 2-1 shows the party invitation you will create.
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Note  If you have a printed copy of this book, you will be unable to see the 
horrible color choices we’ve made in this document. You can download the actual 
sample invitation from the book’s web site https://www.apress.com/us/
book/9781484230749.

�Starting LibreOffice
To start LibreOffice on Windows, click Start ➤ LibreOffice ➤ LibreOffice Writer.

To start LibreOffice on an Apple system, go to the Finder, select Applications, and 

then click LibreOffice. From the initial window, select File ➤ New ➤ Text Document.

The blank document screen will appear, as shown in Figure 2-2.

Figure 2-1.  Party invitation

Chapter 2  Getting Started with LibreOffice Writer 
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Figure 2-3 shows the components of the screen.

Figure 2-2.  Initial LibreOffice Writer screen

Figure 2-3.  LibreOffice Writer screen components

Chapter 2  Getting Started with LibreOffice Writer 
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At the top is the menu bar with its pull-down menus, similar to most applications 

you’re probably familiar with. Below that you have your typical toolbar that contains 

icons for common operations.

At the top of the document is the ruler. This shows you where your margins and tabs 

are located. On the right side, you’ll see something different: the Proprieties panel. The 

Properties panel lets you view and set the proprieties of the text you are working on. On 

the right side of that is the sidebar. You’ll learn how to use this a little later in the book. 

Finally, at the bottom of the screen is the status bar.

�Creating a Party Invite
Enough with the explanation—it’s time to party. Click inside the representation of the 

page. The insert cursor (a vertical bar) should appear. Now type Party. Figure 2-4 shows 

the results.

One thing to notice is that the word Party is little and rather plain. Drag the cursor 

over the word Party to highlight it. Now go to the Font pull-down menu on the toolbar 

and select 48. This will change the size of the word Party to 48 points. Figure 2-5 shows 

the result.

Figure 2-4.  After typing Party

Chapter 2  Getting Started with LibreOffice Writer 
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If you want to change the style of the text to bold, click the Bold icon in the toolbar. 

To turn off the bold, click the Bold icon again. There are similar icons for italics, 

underline, and strike-through, as shown in Figure 2-6.

But the text appears to be a little plain. With the word Party still highlighted, click 

the Background Color icon to change the background color to yellow. Now click the 

Text Color icon to turn the text a rust color. The resulting color combination is quite 

noticeable even if a little garish. Figure 2-7 shows the result.

Figure 2-5.  A font size of 48 points

Figure 2-6.  Text style icons

Chapter 2  Getting Started with LibreOffice Writer 
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Now type Party again. You want this text to be a different color, so select it with the 

cursor, and this time click the little arrow next to the Background Color icon, as shown in 

Figure 2-8. In this example, we picked light purple, but you can pick any ugly color you 

want. You can do the same thing for the text color. (Again, click the little arrow, not the 

icon itself.) In this example, we decided to use cyan, so we have cyan on purple.

Figure 2-7.  Result of the color change

Figure 2-8.  Color selector menu

Chapter 2  Getting Started with LibreOffice Writer 
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Since this going to be a great party, let’s mention it three times. Type Party one more 

time and select a new set of “interesting” colors for the text and background.

Now let’s center the text by going to the Proprieties panel on the right and, in the 

Paragraph section, clicking the Center icon, as shown in Figure 2-9.

The text is now centered, but it’s too close to the top of the page. Let’s move it down 

1 inch by going to the Properties panel. (If you don’t see the Properties panel, click the 

wrench in the sidebar to display it.) In the Paragraph settings, there is a box called “Space 

above paragraph.” Change that from 0.00" to 1.00" and press Enter to set it. Now the 

“Party Party Party” paragraph is properly positioned. Figure 2-10 shows the result.

Figure 2-9.  Center icon

Chapter 2  Getting Started with LibreOffice Writer 
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�Adding the “No Good Reason” Paragraph
You’ve played around with changing the text’s background. In this section, you’ll change 

the paragraph’s background, which produces a slightly different effect.

Press Enter to start the next paragraph. Also, let’s change the text color to black and 

the background color to no fill (the check box at the top of the pull-down).

For this paragraph you want the point size to be a little bigger, so let’s select 72 from 

the Font pull-down. Type Party for No Good Reason for the name of the party. Keep 

the 1-inch space above the previous paragraph since that’s a good spacing for this 

paragraph.

Now let’s change the background color of the paragraph. Click the Background 

Color selector in the Paragraph section of the Proprieties panel, as shown in Figure 2-11. 

(While you’re there, you can scratch your head at LibreOffice’s choice of icons.) Clicking 

the icon causes a pop-up to appear showing you a choice of colors. In this example, we 

chose mustard yellow.

Figure 2-10.  The party in its proper place

Chapter 2  Getting Started with LibreOffice Writer 
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Notice that the paragraph’s background color extends from margin to margin. The 

text background color stays with the text. In the “Party Party Party” paragraph, the space 

on both sides of the paragraph is white, while on the new paragraph, it’s yellow.

�Indenting and Justifying a Paragraph
You’ve used the default margins and centered things in the previous paragraphs. In this 

section, you’ll use indentation and justification to put paragraphs at different locations 

across the page.

Press Enter to go to the next paragraph. This is going to be a normal paragraph 

consisting of the single word When with a colon after it. You’ll notice you have the same 

paragraph background color, space above, and font size as the previous paragraph. This 

is not what you want; you just want a normal paragraph. Click the Style list and select 

Default Style. LibreOffice will reset all the paragraph and font values to their defaults for 

this style, as shown in Figure 2-12.

Figure 2-11.  Paragraph background

Chapter 2  Getting Started with LibreOffice Writer 
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You may have noticed that the Style list was already set to Default Style. But by 

reselecting it, you cleared all the custom settings, resulting in the type of paragraph you want.

Now you can type When: and press Enter.

The paragraph after that should be indented a little (0.5"). There are multiple ways 

of doing this. The first is to grab the margin indicator on the ruler and move it. There is 

an Increase Indent icon that increases the indentation by a fixed amount. If LibreOffice’s 

idea of a “good indent amount” does not suit you, you can set it using the “Before text” 

blank in the Properties panel.

�Indention Method 1: Moving the Indicator
You can select the bottom margin indicator and drag it to the right to about the half-inch 

mark, as shown in Figure 2-13.

Figure 2-12.  Default style

Figure 2-13.  Moving the margin

Chapter 2  Getting Started with LibreOffice Writer 
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Moving the bottom marker will move both the top and bottom markers and thus 

affect both the first line (top marker) and subsequent lines (bottom marker).

�Indention Method 2: Increasing the Indent
There is an icon in the Paragraph section of the Properties panel called Increase Indent, 

as shown in Figure 2-14. Clicking that icon will increase the current indent by 0.5".

�Indention Method 3: Setting the Before Text Indent
Also in the Paragraph section of the Properties panel is a Before Text Indent setting, 

as shown in Figure 2-15. Enter 0.5" and press Enter to set the value.

Figure 2-14.  Increasing the indent

Chapter 2  Getting Started with LibreOffice Writer 
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No matter which way you do it, you’ll get an indented paragraph. Let’s type two 

paragraphs describing the time: Saturday and July 7. Figure 2-16 shows the results.

Figure 2-15.  Setting the before text indent

Chapter 2  Getting Started with LibreOffice Writer 
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�Creating the “Where” Section
Now let’s type the word Where with a colon after it. But the word Where: is not where 

you want it to be. It’s sitting on the left side, and you want it more to the right. To move it, 

drag the lower margin indicator on the ruler to the right until it’s about 75 percent of the 

way across the page. Figure 2-17 illustrates this process.

Now you can enter the Where: line.

Figure 2-16.  Invitation with date added
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You want the actual address to be lined up on the right side. So, let’s click the Align 

Right icon to make this happen. Actually, there are two Align Right icons; there is one  

on the toolbar and one on the Properties panel, as shown in Figure 2-18. Either one  

will work.

Now let’s enter the address. Figure 2-19 shows the result.

Figure 2-17.  Dragging the margin

Figure 2-18.  Align Right settings

Chapter 2  Getting Started with LibreOffice Writer 
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�Adding Graphics
Now let’s decorate things by adding graphics. Click the Gallery icon located on the right 

sidebar. See Figure 2-20.

Figure 2-19.  Final text

Figure 2-20.  Gallery icon

Chapter 2  Getting Started with LibreOffice Writer 
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The Proprieties panel disappears and is replaced by the Gallery. A quick search 

through the list of themes yields nothing that looks like it might have a balloon it, so let’s 

click the Properties icon to restore the Properties panel.

Now bring up your browser and do a Google search for balloon free clip art. Clicking 

images displays a set of possible graphics, as shown in Figure 2-21.

Click one and then select View Image. Right-click the image and select Copy Image. 

Now you can go back to the party invitation and move the cursor to the beginning. 

(Click to the left of the P in our first Party). Select Edit ➤ Paste from the menu bar or just 

press Ctrl+V. The balloon appears in the document, as shown in Figure 2-22.

Figure 2-21.  Balloons

Chapter 2  Getting Started with LibreOffice Writer 
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The size of the image is a way too big. Let’s position the cursor over one of the green 

handles. It will change into a resize cursor. If you are on a corner, the cursor looks like an 

arrow pointing to the corner. If you are on a middle resize handle, the cursor turns into a 

double-ended arrow. You can now drag the handle to increase or decrease the size of the 

balloon, as shown in Figure 2-23.

Figure 2-22.  Balloon pasted
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Notice that the picture maintains the same aspect ratio, meaning that it does stretch 

or distort. This is the default in LibreOffice. If you want to stretch the picture in one 

direction only, you need to hold down the Shift key while resizing.

You need to move the image where you want it to be and change its size. But before 

you do that, you need to change its anchor point. The anchor point controls where the 

image appears on the page. Right now it’s set to Paragraph, meaning if the paragraph it is 

attached to moves, the image moves.

Right-click the image and select Anchor ➤ To Page. This makes the image stick to 

wherever you want it on the page, as shown in Figure 2-24.

Figure 2-23.  Resizing an image
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Now let’s move the cursor over the image. It will change from a pointer to a hand. 

You can now drag the image any place on the page you want it to be. In this example, 

that’s the upper-right corner, as shown in Figure 2-25.

Figure 2-24.  Anchoring an image on a page

Chapter 2  Getting Started with LibreOffice Writer 
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You’ll notice that the text keeps moving out of the way of the figure. You don’t want that 

because you put the text in the proper place when you created it. You can fix that by selecting 

the figure, right-clicking, and selecting Wrap ➤ Wrap Through, as shown in Figure 2-26.

Figure 2-25.  Image in its proper location

Figure 2-26.  Wrapping through

Chapter 2  Getting Started with LibreOffice Writer 
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You now have the image the right shape and size. Let’s duplicate it by selecting it and 

then copying it (press Ctrl+C or select Edit ➤ Copy). Click outside the margin to deselect 

the image you just copied. (This is important because if you don’t deselect it, then when 

you paste, you will overwrite the original image.) Now you can paste in your copy (press 

Ctrl+V or select Edit ➤ Paste). Now you can move it to the right side of the screen.

Things look better when they are symmetrical, and this image is facing the wrong 

way. So, let’s fix that by selecting from the menu Format ➤ Flip ➤ Flip Horizontally, as 

shown in Figure 2-27.

Now you can move it by dragging it with the cursor and change the size using the 

resize handles as you did with the first balloon.

Now you are ready to party, except for the details…printing 100 copies of the 

invitation, handing them out, buying the food and drink, reserving the location, inviting 

the people, and everything else. But the invitation is ready!

Figure 2-27.  Flipping an image vertically
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�Summary
The party invitation was designed to be a fun introduction to the basics of LibreOffice 

Writer. There’s a lot you can play around with in this word processor. In the next few 

chapters, you’ll take a look at how to do useful work with this tool.

For now, if you’re interested, you can explore some of the more frivolous aspects of 

this program, including the following:

•	 Fontworks: Creating fancy text effects

•	 Gradients: Changing color backgrounds

•	 Drawing tools: Drawing things on your document

Since this is not a 400-page book on LibreOffice, we’ll let you explore these topics on 

your own.

Chapter 2  Getting Started with LibreOffice Writer 
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CHAPTER 3

Writing Business Letters 
with LibreOffice Writer
In the previous chapter, you learned the basics (and a few fun features) of LibreOffice by 

creating your party invitation. Now you’ll put LibreOffice to work. In this chapter, you’ll 

learn how to write a business letter with LibreOffice Writer.

Specifically, you’ll do the following:

•	 Create and use custom styles

•	 Apply indents

•	 Format paragraphs

•	 Format pages

�Creating a Business Letter
In this section, you’ll create a simple business letter similar to the one shown in Figure 3-1  

(although we hope your letter will cover a different subject matter).
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�Creating the “From” Section
Let’s start with a new document. Open LibreOffice and select File ➤ New Text 

Document. You’ll notice that the “From” section is formatted with these attributes:

•	 Paragraphs are indented 4.5".

•	 There is no space between paragraphs.

Since you have more than one paragraph, you’ll define your own paragraph style. 

You will reuse this style later in the chapter.

Start by opening the Properties panel and clicking the New Style icon (Figure 3-2).

Figure 3-1.  Business letter

Chapter 3  Writing Business Letters with LibreOffice Writer
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The Create Style dialog appears. Enter a name for the new style such as From 
Address and then click OK. Figure 3-3 illustrates these steps.

Figure 3-2.  New Style icon

Figure 3-3.  Create Style dialog

Now you need to update the paragraph settings to reflect the style you want. The 

settings that need changing are listed in the Properties panel. They are as follows:

•	 Before Text Indent: 4.5"

•	 Above Paragraph Spacing: 0.0"

•	 Below Paragraph Spacing: 0.0"

Chapter 3  Writing Business Letters with LibreOffice Writer
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Figure 3-4 shows the location of these settings.

Figure 3-4.  Paragraph settings

So far you’ve changed the properties just for the current paragraph. You want to 

change the properties for every paragraph of this style, so click the Update Style icon to 

change the From Address style, as shown in Figure 3-5.

Chapter 3  Writing Business Letters with LibreOffice Writer
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Now let’s enter the “From” information, as shown in Figure 3-6.

Figure 3-5.  Update Style icon

Figure 3-6.  “From” section complete

Chapter 3  Writing Business Letters with LibreOffice Writer
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�Creating the “To” Section
The “To” section is just like the “From” section only you need to define a different text 

style. In this case, it’s just like the From Address style only with a Before Text Indent 

setting of 0.00". The steps to create this style are as follows:

	 1.	 Click New Style.

	 2.	 Enter the name To address for the style name. Click OK.

	 3.	 Change the Before Text Indent setting to 0.00".

	 4.	 Click Update Style.

�Completing the “Dear” Line and Text Body
Now you need to write the “Dear” line and the body of the text. You want some blank 

space between the last line of the address and the “Dear” line, so let’s change the Below 

Paragraph Spacing setting to 0.14". Do not click Update Style because you want the 

change to affect this paragraph only. Now you can enter your “Dear” line. The screen 

should now look similar to Figure 3-7.

Figure 3-7.  “Dear” line
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From the Style pull-down, select the style Text Body for the body of the letter. There 

are actually two Style pull-downs, as shown in Figure 3-8; either one will work.

Figure 3-8.  Changing a style

The default Text Body style does not provide enough space between paragraphs. 

Change the Below Paragraph Space setting to 0.14" and click Update Style. Next type the 

body text of the letter. Figure 3-9 shows the result.

Chapter 3  Writing Business Letters with LibreOffice Writer
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Now all you need is the ending. For this you indent the same amount as the “From” 

section, so let’s reuse that style. Select the style From Address from either of the two pull-

downs and type Sincerely. Figure 3-10 shows the result.

Figure 3-9.  Body of the letter

Figure 3-10.  Finishing up

Chapter 3  Writing Business Letters with LibreOffice Writer
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You want about three to five lines of blank space below this line for the signature. 

Ideally, you should change the Below Paragraph Space setting. But this time, let’s cheat 

and just press Enter three times. Then enter your name for the signature.

You can see the final result in Figure 3-11.

Figure 3-11.  Finished letter

�Creating an Envelope
Now you need an envelope to go with your letter. After all, a letter such as this one should 

not arrive in a handwritten envelope. To start, select File ➤ New Text Document to get a 

blank document.

By default, the paper size is that of a standard letter. You want an envelope, so you 

need to change the page format; select Format ➤ Page, as shown in Figure 3-12.

Chapter 3  Writing Business Letters with LibreOffice Writer
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This brings up the Page Style Default Style dialog. Click the Page tab to select the 

paper size, as shown in Figure 3-13.

Figure 3-12.  Changing the page format
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For Format, select an envelope size. In this case, this is a standard business envelope, 

so select #10 Envelope. For Orientation, select Landscape. (Otherwise, you would have 

a tall, narrow envelope.) The page margins default to ones that look nice on a letter but 

lousy on an envelope. Change all to 0.50". See Figure 3-14 for details.

Figure 3-13.  Setting the page style
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Click OK and then enter the “From” and “To” addresses using the techniques just 

covered. To save time, you can copy and paste them from the original letter, which brings 

along the styles too. Because this is a letter, the From Address style works for the “To” 

address lines, and the To Address style works for the “From” address lines. (Try playing 

around with the software to understand this better.)

Figure 3-15 shows the completed envelope.

Figure 3-14.  Page style settings

Chapter 3  Writing Business Letters with LibreOffice Writer
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�Summary
In this chapter, you continued working with LibreOffice. The skills you learned here work 

for letters, memos, agendas, and other short business documents. In the next chapter, 

you’ll learn how to produce longer works.

Figure 3-15.  Final envelope
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CHAPTER 4

Writing a Report 
with LibreOffice Writer
In this chapter, you will write a college-level report. This report will have all the bells 

and whistles needed to impress the instructor and get a good grade. These include the 

following and more:

•	 Bullet lists

•	 Footnotes

•	 Quotes

•	 End notes/bibliography

•	 Tables

•	 Graphics

In this chapter, you will create a report about how to write a report. Unlike most 

college reports (we hope), the quotes and sources will be made up.

�Starting the Report
Begin by running LibreOffice Writer and selecting File ➤ New ➤ Text Document. Now 

every good report should start with a good title. From the Style selection box in the 

upper-right corner, select the Title style and then type in the title of the report:  

A statistical analysis of the structure of college essays and their relationship to the 
grade received. Long-winded perhaps, but that certainly is an A or at least A- paper 

based on the title. Figure 4-1 shows the result.
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Now let’s get to the next line by pressing Enter. This is where you put the author’s 

information. Let’s select the Subtitle style from the Style pull-down and type the author’s 

name. You will get something that looks like Figure 4-2.

Figure 4-1.  The title

Figure 4-2.  Author’s name

For this particular report, you will use structured numbered headings. It’s a school 

requirement we just made up so we could show you structured headings.

Chapter 4  Writing a Report with LibreOffice Writer
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Press Enter to go to the next line, and select the style Heading 1. Enter Level 1 
Heading for the text of this heading (not the most imaginative heading, but it does get 

the point across). Now, click the number icon, just a little left of center on the toolbar. 

Figure 4-3 shows the numbered heading.

Figure 4-3.  Heading 1 style

Let’s add a couple more headings. The first one is a Heading 2 paragraph, and 

the one after that is Heading 3. In Figure 4-4 you can see that LibreOffice has added 

structured numbers to the paragraphs.

Figure 4-4.  Structured numbers
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Try as you might, you can’t make an essay entirely of headings. You’ll have to add 

some text. Let’s write a sentence or two under the first heading. So, type some text: This 
paper discusses the relationship between measurable structural elements of an 
essay and a student’s grade.

The report now looks like Figure 4-5.

Figure 4-5.  Report with paragraph added

�Adding Footnotes
Professors like footnotes, so let’s add a footnote just after the word structural in the 

sentence you just typed. First move the cursor to just after the word and click after 

structural. Now select Insert ➤ Footnote or Endnote ➤ Footnote. You’ll notice that 

the cursor jumps to the bottom of the page and lets you type in your footnote. See 

Figures 4-6 and 4-7 for the results.
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�Adding Quotes: Styles and Custom Styles
Since you are writing a college paper, you need a few quotes. Not only do professors 

like quotes, but they let you reach your page count without having to write your own 

material. (To save time and effort, we will make up our own.)

Figure 4-6.  Inserting a footnote

Figure 4-7.  Footnote at the bottom of the page
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According to the style guide supplied by the teacher, “Quotation paragraphs should 

be indented half an inch from the regular text on both the left and right sides. Text should 

appear in italics.”

When you look through your list of styles, you won’t see one labeled Quote. Selecting 

More Styles brings up the Styles and Formatting panel, as shown in Figure 4-8.

Figure 4-8.  More Styles option

There is one labeled Quotations, but that indents the wrong amount and uses the 

wrong font. So, you’ll have to make a quote style yourself.

Click the Properties icon (the wrench) to open the Properties panel. Then move the 

margins in 0.50" (on both sides) and make the font italic. Figure 4-9 shows you where the 

controls are.
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Now click the New Style icon and give your new style the name Quote. Figure 4-10 

shows this process.

Figure 4-9.  Adjusting the paragraph and font

Figure 4-10.  New style
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Now you can type in the quote:

Quotes are the key to writing an authoritative sounding paper. If other 
people reinforce your ideas then it makes it sound like you know what 
you are talking about.

After entering the quote, you need an attribution line. Type Steve Oualline for the 

attribution and then click the Align Right icon to move the text to the right. Then click 

New Style and enter the name Quote Who. Figure 4-11 illustrates the basic steps.

Figure 4-11.  Creating the Quote Who style

By default, the next paragraph after a Quote Who paragraph is a Quote Who 

paragraph. Instead, you want it to be the Text Body style. Select Format ➤ Styles or press 

F11 to bring up the Style list. Locate the Quote Who style, right-click, and select Modify. 

Figure 4-12 shows the significant steps.
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The style modification dialog will appear. Click the Organizer tab. Then use the “Next 

style” pull-down to select Text Body (the default text format), as shown in Figure 4-13.

Figure 4-12.  Modifying the style
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Click OK to save your changes. Now when you press Enter after the Quote Who 

paragraph, the paragraph style will change to Text Body.

�Adding End Notes
The quote needs a bibliography entry. That means an end note. Place the cursor just 

after the attribution, at the end of the line, and select Insert ➤ Footnote and Endnote ➤ 

Endnote. Figure 4-14 shows the operation.

Figure 4-13.  Style modification
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The end note marker is inserted, and you are taken to the end of the document 

where you can enter your end note, as shown in Figure 4-15.

Figure 4-14.  Inserting an end note

Figure 4-15.  Entering the end note
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�Formatting Footnotes and Endnotes
You may have noticed that footnotes are numbered 1, 2, 3, …, and endnotes are 

numbered 1, 2, 3, …. This may lead to some confusion because you have a footnote 

numbered 1 and an endnote numbered 1 on the same page. You need to change the 

numbering of one of these items.

The Format menu item contains commands that format just about everything except 

footnotes and endnotes. To format them, you need to select Tools ➤ Footnotes and 

Endnotes, as shown in Figure 4-16.

Figure 4-16.  Footnotes and Endnotes menu item

This brings up a dialog that allows you to modify the way footnotes work. Click the 

Footnotes tab and then change Numbering to “a, b, c, …” and change Counting to  

“Per page,” as demonstrated by Figure 4-17. Finally, click OK.
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Now the footnotes and endnotes look different. And everyone can tell it’s a great 

paper because you’ve got them both.

�Adding Tables
Any good report should have a few tables. They are nice ways of presenting a lot of data 

in an organized format. They stand out in a report and tell your professor “Hey, this guy 

has got a lot of data,” whether your data is useful or not.

To create a table, select Table ➤ Insert Table, as shown in Figure 4-18.

Figure 4-17.  Footnotes/Endnotes Settings dialog
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The Insert Table dialog appears. Let’s leave the defaults as they are. Specifically, you 

want to create a table with two rows and two columns. (You can adjust this later.) Click 

the Insert button to create the table, as shown in Figure 4-19.

Figure 4-18.  Inserting a table

Figure 4-19.  Inserting a table
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Now let’s enter some data. Specifically, type the following and press Tab (not Enter) 

after each line:

Length<tab>

Grade<tab>

24<tab>

A+

Note that after each Tab, you go to the next cell in the table. Figure 4-20 displays 

the results.

Figure 4-20.  Table entry
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Now let’s press Tab again. A new row opens. Continue to enter data until the table 

looks like this:

Length Grade

24 A+

19 A

18 B

16 C

9 F

The problem with this table is that you have a lot of white space. Let’s fix that. First 

select the table by clicking Table ➤ Select ➤ Table, as demonstrated in Figure 4-21.

Figure 4-21.  Selecting a table
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Now let’s adjust the column size with Table ➤ Size ➤ Optimal Column Width, as 

shown in Figure 4-22.

Figure 4-22.  Adjusting the column size

The result is a much nicer-looking table (Figure 4-23).
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�Inserting Graphics
Pictures are nice in reports because humans are graphical animals and respond to 

pictures better than words. Besides, graphics are an easy way of increasing the page 

count without having to write anything.

Let’s start by adding a cute picture of a kitten to the paper. We’re not sure how this 

fits into the theme of the subject, but a cute kitten can’t hurt, so take a look at the one in 

Figure 4-24 that we’ve added to the report.

Figure 4-23.  Nice table
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To insert a figure into the report, copy it to the clipboard, click where you want the 

picture to be, and select Edit ➤ Paste. Then click the picture to select it, right-click, and 

select Anchor ➤ As Character. We covered this in Chapter 2 if you need a more visual 

explanation.

However, since this is a serious report and the people reading it might not 

understand what they are looking at, let’s add a few graphics. First bring up the Drawing 

toolbar using the command View ➤ Toolbar ➤ Drawing, as shown in Figure 4-25.

Figure 4-24.  A sneaky way of getting a cute kitten into the book
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Click the circle on the Drawing toolbar; then click the upper left of the cat’s face and 

drag the cursor to the lower right. A circle will be generated covering up the cat’s face, as 

illustrated by the ugly picture in Figure 4-26.

Figure 4-25.  Drawing toolbar

Figure 4-26.  Circle drawn
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Now let’s bring the kitten back. In the Properties panel, under Area, change Fill 

to None. Under Line, change Width to 2.3 and Color to a yellow. The result is a circle 

around a kitten’s face, as shown in Figure 4-27.

Figure 4-27.  Cat with circle

Now let’s click the Callout icon and draw a square to the right of the picture about a 

half-inch high and 2 inches wide, as shown in Figure 4-28.
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Now drag the handle for the callout pointer (the little yellow dot) to the circle. Click 

the callout and enter the text Cute Kitten. Figure 4-29 shows the labeled kitten. Click 

outside the caption to stop editing it. Double-click it if you want to change the text.

Figure 4-29.  Labeled kitten

Figure 4-28.  Creating the callout
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�Summary
We’ve only touched on a fraction of the features available in LibreOffice yet you’ve been 

able to produce a report that pretty much has everything, including footnotes, endnotes, 

tables, custom paragraph styles, pictures, and graphics. About the only thing it doesn’t 

have is any meaningful content. But as they say in college, “The proof is left to the 

student.”
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CHAPTER 5

Working with 
Spreadsheets in 
LibreOffice Calc
In the 1970s a fellow by the name of Dan Bricklin was at Harvard watching a professor 

teach finance. The professor had written a grid of numbers on the blackboard and was 

explaining some sort of financial model. When he changed a number, he had to erase 

and recalculate all the numbers that depended on it.

Dan thought that it would be nice to write a program that did that automatically,  

and the first spreadsheet, called VisiCalc, was born. In 1979 it became available for the 

Apple II. It was an instant hit, causing some people to buy a $2,000 computer just to run 

a $100 copy of VisiCalc.

Since then, many people have copied the concept, and today spreadsheets are an 

essential business tool.

In this chapter, we will introduce you to the basics of LibreOffice Calc. You will learn 

how to do the following:

•	 Use basic spreadsheet functions

•	 Balance a checkbook

•	 Use multiple sheets

•	 Use more complex formulas to create a budget

•	 Use cut and paste to put a spreadsheet inside a text document to 

create an invoice

If you haven’t done so already, download and install the LibreOffice program from 

www.libreoffice.org. During the installation, just select the defaults for each option.

http://www.libreoffice.org/
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�Balancing Your Checkbook
You will start by balancing your checkbook. This is the process by which you write down 

all your withdrawals and deposits and add them up. Then you try to figure out why you 

think you have $83,237.92 in the account while your bank lists the balance as $0.98.

Start the program LibreOffice Calc, or start LibreOffice and select New ➤ Spreadsheet. 

You’ll see a blank spreadsheet, as shown in Figure 5-1.

You’ll notice that the program displays a grid of cells. The first cell is A1 in the  

upper-left corner, and then going across, they are A2, A3, A4, and so on. This will be 

important later.

Figure 5-1.  Initial Calc screen
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You will want a set of headings for your checkbook, so let’s start by typing in the 

following:

Date

Check Number

Description

Amount

Balance

After each entry, press Tab. Do not press Enter. If you make a mistake, just click in 

middle of a cell to start over in that cell. The result should look something like Figure 5-2.

You’ll notice that things are getting a little crowded, especially in the Check Number 

column. Let’s spread things out a little. Place the cursor on the line between the C and D 

columns and drag the line to the right to give you more room for the description. Now do 

the same for the check number.

Figure 5-2.  Headings entered
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Figure 5-3 shows the result.

Now let’s give the headings a little “oomph.” Click 1 on the left side to select the 

row and click the Bold icon to turn the text bold. Figure 5-4 shows the nicer-looking 

headings.

Next, let’s enter some data. Click in C2 and enter Initial balance. Now go to E2 and 

enter what’s in the bank, 1234.50. As you can see in Figure 5-5, something does not look 

right in cell E2. You are missing the 0 at the end.

Figure 5-3.  Spreadsheet after column adjustments

Figure 5-4.  Bold headings
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The program thinks you are dealing with simple numbers and is displaying .50 as .5. 

People usually want to use two decimal points when working with money, so you need 

to change the way Calc formats the cells. You will do this for both columns D and E since 

both contain money. Click the D in the column headings and then Shift+click E. Both 

should be selected, as shown in Figure 5-6.

Figure 5-5.  Initial balance: funny money

Figure 5-6.  Formatting the row
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Now right-click and select Format Cells.

This opens the Format Cells dialog, as shown in Figure 5-7.

In the Category column, select Currency. The Format pull-down allows you to select 

different currency symbols. The default for this installation is the U.S. dollar ($), so leave 

that alone. (Your installation may have a different default depending on your Locale 

settings.) Let’s keep the format simple, so select -$1,234.00. This displays the dollars and 

cents and uses a minus (-) sign to indicate negative.

Click OK to format the cells. Now let’s enter some data, as shown here:

A3 1/1/2017

B3 0063

C3 Fred’s Diner

D3 -4.75

E3 =E2+D3

Figure 5-7.  Formatting cells
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Figure 5-8 shows the result after typing =E2+D3 and just before pressing Enter.

Now press Enter to register the contents of your last cell. Notice that the contents 

change the value of the calculation. If you click the cell, you’ll see the original formula in 

the input line at the top of the sheet.

You’ll also notice that although you entered 1/1/2017, the spreadsheet reformatted it 

to 01/01/17. You can change this by changing the format of this column to another date 

format.

The check number 0063 got changed as well. Formatting won’t help this problem. 

Instead, you need to tell LibreOffice that this text is not a number. Let’s go back to that 

cell and enter a single quote mark (’) and the number. This is what it looks like:

'0063

There are two key characters that LibreOffice Calc looks for at the beginning of any 

entry. The first is a single quote, which indicates text. The second is an equal (=) sign, 

which indicates a formula. Anything else causes LibreOffice to guess at the type of data 

that’s being entered.

Figure 5-9 shows the result of the fixes.

Figure 5-8.  Your first check
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Now’s let’s add a new check to the spreadsheet, as shown in Figure 5-10.

Figure 5-9.  Corrected entries

Figure 5-10.  Second check
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After entering the information shown in Figure 5-10, put the cursor in E3 and select 

Edit ➤ Copy. (Or press Ctrl+C.) Now put the cursor in E4 and select Edit ➤ Paste (or 

press Ctrl+V). The result is that a new balance is computed, as shown in Figure 5-11.

Notice that in the input bar the formula has been adjusted. Now all you have to do 

is repeat the process each time a check is written or a deposit is made, and you have 

yourself an automatic checkbook.

�Creating a Double-Entry Checkbook
A classic ledger system has two entry columns, one for deposits and one for withdrawals. 

Let’s change your checkbook spreadsheet to handle these two types of entries.

Let’s start by adding a column for deposits. Right-click the Amount column and 

select Insert Column Left, as shown in Figure 5-12.

Figure 5-11.  New balance
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Now you have a new column. Change the heading of the new column to Deposit 

and the old one, currently marked Amount, to Withdrawal. The result should look like 

Figure 5-13.

Figure 5-12.  Inserting a column for deposits
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Change the format of the new column (Deposit) to money like you did with the other 

money columns.

Change the amounts in cells E3 and E4 to positive numbers. Specifically, change  

the formula in cell F3 to F2+D3-E3. In other words, the new balance (the current cell) 

equals the old balance (F2) + deposits (D3) – withdrawals (E3). Then copy the formula 

from F3 to F4.

Now let’s add a new line to the bottom because you just got a check in from your 

employer. For the date, let’s use 1/5/17. For the description, enter Pay and put 1000 in 

the Deposit column. Copy cell F4 and paste it into F5 to complete the line, and you get 

the spreadsheet in Figure 5-14.

Figure 5-13.  New column headings

Chapter 5  Working with Spreadsheets in LibreOffice Calc



100

�Creating a Budget
In this section, you’ll create a simple budget in a spreadsheet. Actually, you will make 

an over-simplified budget. A full budget is a wonderfully complex thing that covers 

everything you could possibly spend money on. In this section, we’ll show you the 

concepts needed to make a budget and leave the details to you and whatever financial 

advice you can find through Google.

The basic idea of a budget is to show what income you have and what you are 

spending your money on. Ideally, the former is bigger than the latter. If not, you use the 

budget to make adjustments.

�Creating a Basic Budget
Let’s start by creating a spreadsheet with some basic information in it. On the left you 

will have income. On the right you will have spending with some basic entries. Your 

basic spreadsheet will look like Figure 5-15.

Figure 5-14.  Completed checkbook spreadsheet
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Note A t this time, we have not filled in any of the cells containing formulas.

Let’s start by cleaning up the headings. The Income section covers columns A and B. 

Let’s get the heading to cover these columns as well. First click cell A1, then Shift+click A2, 

and finally select Merge Cells, as shown in Figure 5-16.

Figure 5-15.  Basic budget
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Let’s center the text by clicking cell A1 (or should we call it AB1?) and clicking the 

Center icon in the toolbar.

Now let’s do the same thing to the Spending cell. Click D1, Shift+click G1, right-click, 

and select Merge Cells. Now center this text.

While you are at it, let’s change the background to light yellow to make the section 

headings stand out. You can do this by clicking the Background Color icon. You now 

have a spreadsheet that looks something like Figure 5-17.

Figure 5-16.  Merging cells
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�Computing Totals
It’s time to compute some totals. You can get the total income by clicking cell B5 and 

clicking the Sum icon on the toolbar. LibreOffice will make an intelligent guess at what 

you want to add up. In this case, it thinks you want to add the column starting with B3 

and ending with B4, so it fills in the formula as =SUM(B3:B4). It also draws a line around 

the cells it is going to sum up to give you a visual indication of what’s happening, as 

shown in Figure 5-18.

Figure 5-17.  Spreadsheet with headings
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Press Enter to accept this guess.

Now let’s add sums to the spending columns (actual and budgeted). Figure 5-19 

shows the result that includes the entry of some actual numbers.

Figure 5-18.  Summing up
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Now let’s see how well you stuck to your budget. Click cell G3 and enter the formula 

for the percent spent. That is, enter =E3/D3. The answer is 1. But you want a percentage. 

So, click the G3 cell to select it again, and click the “percent” symbol to turn the number 

into a percentage (100%), as shown in Figure 5-20.

Figure 5-19.  Budget with totals
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Copy and paste the formula from G3 into G4, G5, and G6. Uh-oh, you’re over budget. 

Figure 5-21 shows the damage.

Figure 5-20.  Percentage
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It looks like one problem area is food, so to meet your budget for next month, all you 

have to do is stop eating…or maybe stop eating out so much.

So far, we’ve covered just the month of January. What about next month and beyond? 

Let’s work on it.

�Setting Up Multiple Sheets
Spreadsheets have a concept of multiple pages or sheets. So far, you have only one sheet, 

called imaginatively Sheet1. Let’s rename it to Jan17 and then copy it to a Feb17 sheet.

Right-click the sheet tab and select Rename Sheet, as demonstrated in Figure 5-22.

Figure 5-21.  Final single-month budget
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The Rename Sheet dialog appears, as shown in Figure 5-23. Enter Jan17 and click OK 

to rename the sheet.

Notice that the sheet name on the bottom tab is different. Now right-click the tab 

again, and as shown in Figure 5-24, select Move or Copy Sheet.

Figure 5-22.  Renaming a sheet

Figure 5-23.  Rename Sheet dialog
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The Move/Copy Sheet dialog appears, as shown in Figure 5-25. In this case, Copy is 

already selected for you. (It’s hard to change the sheet order in a one-sheet spreadsheet, 

so the Copy choice is forced upon you.) The document you want to copy into is the 

current document, so do not change the “To document” setting. Leave the “Insert 

before” setting at Jan17. You always want your newest budget to appear on top. Change 

the name to Feb17 and click OK.

Figure 5-24.  Getting ready to copy the sheet
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The new sheet, Feb17, appears on top. Now let’s fill in the numbers for February. Since 

it is a short month, you spent less, so you can be proud of the numbers in Figure 5-26.

Figure 5-25.  Move/Copy Sheet dialog

Figure 5-26.  February’s numbers
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Now let’s add a section in which you reference last month’s numbers. Figure 5-27 

shows the spreadsheet after entering the headings and the row label for Jan17. Note you 

have to put a single quote at the beginning of Jan17; otherwise, LibreOffice will think it’s 

a date and format at as 1/1/17.

Under Spent (cell B9), type = and nothing else.

Now you need to get the value of the total spent from Jan17. But it’s not a cell on the 

current sheet, so there is no A1, B2 type reference that you can use. But LibreOffice will 

fill in the cell reference automatically for you.

Click Jan17 to go to the Jan17 sheet and then click the F6 cell to select the total. 

Notice that the input bar now reads =Jan17.F6 and the cell is bordered with a purple 

rectangle. See Figure 5-28 for details.

Figure 5-27.  Starting to reference previous months
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No go back to the original sheet (Feb17) and press Enter. The value of that cell is 

automatically filled in. You can repeat this for the “% Budget” value as well.

Now all you need to do is create a “Feb 2017” line below the “Jan 2017” line and you 

have section giving you a two-month comparison of your spending. Figure 5-29 displays 

the final result.

Figure 5-28.  Referencing the Jan17 value
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�Creating Charts
Now let’s insert a chart. There’s no good reason for inserting a chart in this budget, but 

we haven’t demonstrated the graphics features of LibreOffice Calc yet, so why not? First 

select cells D3 through D5 by clicking D3 and then Shift+clicking D5. Now let’s select 

cells F3 to F5 by Ctrl+clicking each of the three cells. Finally, as shown in Figure 5-30, you 

select Insert ➤ Chart.

Figure 5-29.  Two months budgeted
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The Chart Wizard shown in Figure 5-31 appears. Under Choose a Chart Type, select 

Pie and then click Finish.

Figure 5-30.  Starting to insert a chart
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Note that LibreOffice Calc has a complex charting system with hundreds of options. 

Going through them all would take another book. We’re after a quick-and-dirty chart, so 

we’re taking a lot of the defaults here.

After clicking Finish, the chart is inserted. Figure 5-32 shows you that the default 

location is right over your important data. So, you need to use the cursor to grab the edge 

of the chart and move it down.

Figure 5-31.  Chart Wizard

Chapter 5  Working with Spreadsheets in LibreOffice Calc



116

Dragging the chart down exposes all those lovely numbers that you worked so hard 

to come up, as shown in Figure 5-33. It also shows that we are paying far too much for 

housing, which should be no more than one-third of the budget. But that’s what we get 

for residing in such a grand fictional house. We probably should adjust our imagination 

and move into a less expensive home.

Figure 5-32.  Chart inserted
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�Summary
LibreOffice Calc provides a full-featured spreadsheet. In this chapter, we covered 

the basic concepts that you’ll encounter in most simple spreadsheets. As you can 

see, LibreOffice Calc has all the useful features of the more expensive, proprietary 

spreadsheets but without the cost (and without the advertising budget).

Figure 5-33.  Final budget
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CHAPTER 6

Creating Presentations 
with LibreOffice Impress
Doing something well is half the battle. Selling it is the other half. That means getting in 

from of a room and telling people how great your idea is. Humans are visual animals. 

They react to pictures much better than words, which is the reason people use slide 

presentations.

LibreOffice Impress lets you create great multimedia slides containing not only 

words and pictures but animation and sound. In this chapter, you’ll create a presentation 

called “How to Make Great Presentations.”

In this chapter, you’ll learn the following:

•	 How to make slides

•	 How to add graphics

•	 How to animate the elements of a slide

•	 How to create slide transitions

•	 How to use the presenter’s console

What you’ll not learn is how to include meaningful content in your presentation. But 

given the quality of most presentations, decent content is not a requirement.

�Creating a Presentation
Start LibreOffice and select File ➤ New ➤ Presentation. A blank presentation will appear 

and immediately be covered up by the Select a Template dialog, as shown in Figure 6-1.
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LibreOffice comes with a nice set of good-looking templates. More are available 

from various web sites on the Internet. All have one thing in common, which is a fancy 

background that makes the presentation look good.

Unfortunately, this fancy background obscures the various elements described 

in this book, and for the purpose of illustrating the features of LibreOffice, a blank 

background is better. So, click Cancel to start with a clean slate. The result, in all its 

boring glory, looks like Figure 6-2.

Figure 6-1.  Selecting a template
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On the left you’ll see the list of slides. In this case, one slide is in the list. In the 

middle is the slide itself. On the right is the Properties panel. Since you don’t care about 

the Slide section of this panel, click the minus (-) sign next to the word Slide to collapse 

the section, as shown in Figure 6-3.

Figure 6-2.  Initial Impress screen

Figure 6-3.  Section collapsed
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The Properties panel on the right shows the various layouts available. This is the  

title slide, so let’s select the layout with the big title in the middle. Next, click in the 

middle of the slide where the helpful message “Click to add Text” appears and enter the 

title Great Presentation.

The default font size leaves a lot of white space around the text. This is not a great 

presentation; it’s a great presentation! So, to show your greatness, you need to drag the 

cursor over the text to select it and then click the Increase Font Size icon a number of times 

until the title matches the greatness of your ego. Figure 6-4 shows just how big our ego is.

�Adding Graphics
A big font doesn’t show the true greatness, though. Let’s add some graphics to make 

things better. Click the triangle next to the arrow icon to bring up a selection of arrows. 

Click the big right arrow and then drag the mouse diagonally to draw a big arrow, as 

shown in Figure 6-5.

Figure 6-4.  Expanding the font size to fit our ego
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The arrow doesn’t point to the big title. Let’s fix that now. Right-click the arrow and 

select Position and Size, as shown in Figure 6-6.

Figure 6-5.  Creating the arrow

Figure 6-6.  Position and Size menu item
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A Position and Size dialog (Figure 6-7) appears. Click the Rotation tab, go down to 

the “Default settings” circle, and drag the indicator up so the arrow points to the title. 

Then click OK to set the rotation.

As you can see in Figure 6-8, the arrow now points to the title. Let’s now click the fill 

color in the Properties panel’s Area section and change the color to orange. The title is 

starting to look a little exciting.

Figure 6-7.  Changing the rotation
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You want three more arrows, so let’s copy and paste, paste, paste. Then move the 

arrows where you want them and change their angles and area colors. The four-arrow 

version of the title should look like Figure 6-9.

Figure 6-8.  Title with arrow

Figure 6-9.  Final title page
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Let’s start the first content slide by selecting Slide ➤ New. This slide will contain a 

little content, so click the “Title, Content” slide layout indicated by Figure 6-10.

For the title, enter A Joke. For the content, enter these lines:

The second best selling type of books are diet books

The best selling type is related—

Cookbooks

With good timing, this joke is actually funny; in print, not so much. Figure 6-11 shows 

the “funny” slide.

Figure 6-10.  Starting a new “Title, Content” slide

Chapter 6  Creating Presentations with LibreOffice Impress



127

Now let’s get rid of the bullets by selecting the three joke paragraphs and clicking the 

Toggle Bullet icon in the Paragraph section of the Properties panel.

The way to tell this joke is as follows:

“The second best selling type of books are diet books.”

Wait a couple of beats.

“The best selling type is related…”

Pause.

“…cookbooks.”

If you just show the slide with the text all at once, it loses a lot of its humor. But if you 

can present it with this comedic timing, you have a much more powerful joke.

What you need to do is to bring in each of the paragraphs one at a time. Motion, or 

animation, is needed to make the presentation much more effective.

Figure 6-11.  Joking
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�Adding Animation
Drag the cursor over the entire joke to select it. Then click the green plus (+) sign, as 

shown in Figure 6-12, to add animation to the selected paragraphs.

The animation sequence and type will be displayed in the Animation panel, as 

shown in Figure 6-13.

Figure 6-12.  Adding animation
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Select the first paragraph in the Animation box. Notice that the Effect setting is Basic/

Appear. Change this to Basic/Fly In. Leave Start set to “On click” and Direction set to 

“From bottom.” Figure 6-14 shows you the settings.

Figure 6-13.  Animation panel

Figure 6-14.  Animation settings for the first paragraph
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Now click the second paragraph. Change Effect to Basic/Fly In and change Start to 

“On click.” Do the same thing for the third paragraph. Now select Slide Show ➤ Start 

from current Slide, as illustrated in Figure 6-15.

A slide will be displayed, but only the title of the slide will appear (see Figure 6-16).

Figure 6-15.  Starting the slide show

Figure 6-16.  Starting the slide
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Click to bring up the next part. You’ll see “The second…” fly up the page to its place. 

Figure 6-17 shows the result.

The next click brings up the “The best…” line, which you can see in Figure 6-18.

Let’s now pause and give the audience time to guess at what the answer is. Then click 

one more time to bring up the full joke, as shown in Figure 6-19.

Figure 6-17.  After the first click

Figure 6-18.  The result of the second click
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Feel free to experiment with different types of effects. There are lots to choose from, 

and most of the animations work with all types of graphics cards. Some require more 

power and others don’t. But experimentation is the best way of seeing what’s going on, 

especially because this book is limited to static images.

Clicking the red “X” icon below the animation list will delete the selected animation. 

Also, there are up and down arrows that allow you to reorder the items in case you feel 

the joke is better if you tell the punch line first.

�Adding Slide Transitions
You have seen how paragraph animations make your presentation more powerful. You’ll 

now animate the transition between slides, which gives your presentation a bit of zing.

Click the Slide Transition icon on the right (see Figure 6-20).

Figure 6-19.  Third click and full joke
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In the Slide Transition list, click Wipe to select a slide transition, as shown in 

Figure 6-21. Impress will show you a preview of the transition. Now when you start the 

side show from the beginning, the second slide will appear with a “wipe” effect. Play 

around with the other transitions; the effects are quite interesting.

Figure 6-20.  Animation controls and Slide Transition icon

Figure 6-21.  Slide transition
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�Adding Sound
One way of spicing up a presentation is with sound. In this presentation, you’re going to 

show a picture of failure with a “wah wah waaah” sound playing. Let’s start by creating a 

slide called “Mistakes Happen” and then insert a picture of the Tacoma Narrows Bridge 

that collapsed in 1940. You can see the results in Figure 6-22.

Now let’s make the picture interactive. Right-click the image and select Interaction, 

as shown in Figure 6-23.

Figure 6-22.  A big mistake
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The Interaction dialog will appear, as shown in Figure 6-24.

Figure 6-23.  Creating an interaction

Figure 6-24.  Interaction dialog

Chapter 6  Creating Presentations with LibreOffice Impress



136

Select “Play audio.” This causes an Audio field to appear at the bottom, which allows 

you to select an audio file on your computer, as shown in Figure 6-25. After selecting a 

file, click OK to dismiss the dialog.

Now when you go into the slide show and click the picture, the sound in your audio 

file will play; we’ve selected a “wah wah waaah” sound for this example.

Note that clicking the image does not advance to the next slide like it normally 

would. If you want to do that, you need to move the cursor off the image and click the 

border or title.

Or you can use the handy gadgets in the presenter’s console, which happens to be 

discussed in the next section.

Figure 6-25.  Selecting an audio file
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�Working in the Presenter’s Console
The big day has arrived. You are going to give your presentation. First, you get to the 

room an hour early and spend 59.5 minutes trying to debug the projector system. 

Connecting the projector to the computer gives you two monitors. One, the small one, 

is built into your laptop. The other is the projector that is going to display your work to 

thousands of people.

LibreOffice Impress can make use of both projectors. Let’s start the slide show with 

Slide Show ➤ Start from first Slide, as illustrated in Figure 6-26.

The first slide will be displayed on the projector. On the laptop screen, you’ll get the 

presenter’s console, as shown in Figure 6-27.

Figure 6-26.  Starting the slide show
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The majority of the screen is taken up with the current slide. This is the same thing 

the audience is seeing now. On the right you have the next slide. That way, you can get 

ready what you will say next.

LibreOffice may sometimes pick the wrong screen. In other words it will put the 

presentation on the laptop screen and the presenter’s screen on the projector. If this 

happens there is an Exchange button that will switch the views so the audience sees the 

presentation and the presenter sees the Presenter’s console.

Most of the other controls are simple. There’s an elapsed timer showing you how 

long you’ve been talking, a couple of buttons to change the layout, and a Help button.

�Summary
You now have all the elements of a great presentation. It has a beautiful title screen  

with stunning slide transitions. This is followed by an amazing joke to break the ice that 

uses animation to deliver the punch line. In fact, you have just about everything…except 

any real content. Well, this book would not be any fun if we didn’t leave something for 

you to do.

Figure 6-27.  Presenter’s console
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CHAPTER 7

Using LibreOffice Base 
for Database Management
LibreOffice has the ability to take data from a Calc spreadsheet and use it to create a 

mass mailing (often called a mail merge). That works well if your list contains 1 to 1,000 

people. But what if it grows larger? Say 100,000 recipients?

LibreOffice comes with a database comparable to the Microsoft Access “database”1 

and SQL Server, called LibreOffice Base. It does a good job until your list starts to reach 

the 1,000,000 mark. At that point, you’re going to need a more professional database 

such as PostgreSQL.

In this chapter, we’ll keep things simple. You’ll learn the following:

•	 How to import data into Calc

•	 How to use Calc and Writer to perform a mail merge

•	 How to create an empty database in Base and populate it with Calc data

•	 How to create a quick custom query in Base

•	 How to create a form letter using the results of your query

�Importing Data into Calc
Let’s start with a list of names. You can get this list from a nice web site called  

www.generatedata.com. Save the list of names in a file called addr.csv. Although the 

extension stands for “comma-separated values,” the fields are really separated by a 

vertical bar (|). Also, the first row contains the column names, which we later call  

1�Every database professional we know puts Microsoft Access in the quote marks when talking 
about it. They don’t consider it a real database.

http://www.generatedata.com/


140

field names just to be consistent. These field names and the name of the file are all one 

word and lowercase. This makes it easy to use them later.

The first thing you need to do is start LibreOffice and open the file (select File ➤ Open). 

If you just open it using the defaults, the file will be opened in LibreOffice Writer. You 

need to go to the file type pull-down and select Text CSV (*.csv). It sounds simple, but the 

pull-down contains a lot of file types, and it takes a bit of scrolling and treasure hunting 

to find the right one. Figure 7-1 shows the hidden treasure: Text CSV (*.csv).

When you click Open, LibreOffice opens the Text Import dialog, as shown in 

Figure 7-2. As mentioned, the fields in the file are separated by a vertical bar (|). So, you 

need to deselect the Tab, Comma, Semicolon, and Space options. Then select Other and 

put a vertical bar (|) in the blank field. The preview panel at the bottom gives you some 

idea of how your data will be processed. Clicking OK brings up the spreadsheet.

Figure 7-1.  Opening the file
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Let’s save the spreadsheet as the file addr.ods. Don’t forget to set the file type, as 

shown in Figure 7-3.

Figure 7-2.  Import dialog
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�Creating the Form Letter
Now let’s create a form letter as a LibreOffice Word document. Select File ➤ New Text 

Document. You’ll enter your name and address, and then it’s time for the addressee.

You need to connect the spreadsheet you are using to LibreOffice as a data source or 

database. Select Edit ➤ Exchange Database, as shown in Figure 7-4.

Figure 7-3.  Saving the file
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Let’s address some terminology before we go any further, specifically, the terms 

spreadsheet and database. LibreOffice lets you use a nicely formatted spreadsheet as a 

small database. Therefore, in many dialogs where you are asked to select a database, 

you are actually selecting a spreadsheet. You can think of the terms as the same in 

LibreOffice. In addition, the first row of the example spreadsheet contains column 

names. In a database, they are called field names. Finally, a spreadsheet sheet is the same 

as a database table (see Table 7-1).

After you select Edit ➤ Exchange Database, the Exchange Databases dialog appears. 

The database (spreadsheet) you want is not there, so click Browse, as shown in Figure 7-5.

Figure 7-4.  Making a database connection

Table 7-1.  Spreadsheet/Database Translation Table

Spreadsheet Term Database Term

Spreadsheet Database

Column name Field

Sheet Table
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Using the file open dialog, you can find the spreadsheet file (addr.ods) and open it. 

LibreOffice returns to the Exchange Databases dialog only now the “addr” database will 

appear in the Available Databases column, as shown in Figure 7-6.

Figure 7-5.  Exchange databases

Figure 7-6.  Database list now includes “addr”
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Click Close to finish the dialog. Now you need to insert data from the database into 

the form letter. This is done through fields. A field is something in the document that will 

be replaced by real data. For example, the field Page Number is replaced by the current 

page number.

In this case, you want to get fields from the database. So, start by selecting Insert ➤ 

Field ➤ More Fields to bring up the field list, as shown in Figure 7-7.

In the Fields dialog, select the Database tab. The “addr” database is listed on the 

right. Click the plus (+) sign to expand it, and you’ll see a data section.

Figure 7-7.  Inserting a field
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On the left, select “Mail merge fields.” On the right, click the plus (+) sign next to data 

to expand the list. Select “first,” which is the first name of the person you are writing to, as 

shown in Figure 7-8.

Click Insert to insert the field in the document. As you can see in Figure 7-9, a gray 

“<first>” was inserted in the document. This indicates that the program will take an entry 

from the column “first” and insert it here.

Figure 7-8.  Selecting fields
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Now type a space and insert the rest of the fields: last, address, city, state, and zip. 

Add a “Dear” line with another “first” field, and you get Figure 7-10.

Figure 7-9.  Field inserted

Figure 7-10.  Letter with fields
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Now you have to type the rest of the text. Figure 7-11 shows the final form letter.

Let’s save the letter and then select File ➤ Print. LibreOffice notices that this is a mail 

merge document and displays the dialog in Figure 7-12, which asks you if you want to 

print a form letter.

Of course, you do—that’s why you’re reading this chapter. Click Yes.

Figure 7-11.  Finished letter

Figure 7-12.  Form letter dialog
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The Mail Merge dialog appears, as shown in Figure 7-13. This dialog allows you to 

print to a physical printer or a file. You want to print a big PDF file that you can take 

down to the school’s office and let them print some copies on the fast printer.

If you select Print to File, the only file formats you can print to are document formats 

such as LibreOffice or Microsoft Word. It’s not obvious, but to save the result to PDF file, 

you need to select Printer.

When you click OK, LibreOffice will go through a frenzy of computation creating 

your 100 form letters all the while displaying the progress dialog shown in Figure 7-14.

Figure 7-13.  Mail Merge dialog

Figure 7-14.  Telling you the program is busy making letters
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This screen will eventually disappear and be replaced by the Print dialog in Figure 7-15.

Select the printer called Microsoft Print to PDF to save the file as a PDF and then 

click OK to bring up a dialog asking you what file you want to save the results to. The final 

file will be 100 pages long, with one page for each name in your list.

Figure 7-15.  Print dialog
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�Using LibreOffice Base
A spreadsheet is fine for saving 100 names. In fact, it’s not too bad for 1,000. For 10,000 

names, though, it gets a little difficult to use, and at 100,000 names, forget about it. For 

that many names, you need a database. LibreOffice has one called LibreOffice Base. It’s a 

decent small database that can handle pretty much anything a person can throw at it.

�Java
Before you can use LibreOffice Base, you must install Java. You can download it from 

www.java.com. Again, install it by selecting all the defaults except when the “Get the 

best…” dialog, as shown in Figure 7-16, appears.

Click “Do not update browser settings”  and then Next. After you finish installing 

Java, exit LibreOffice and restart it.

Figure 7-16.  “Can I take over your browser?”
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�Creating a Database
To create a database, select File ➤ New ➤ Database, as shown in Figure 7-17.

The Database Wizard, as shown in Figure 7-18, will appear. LibreOffice has the 

ability to act as the front end for a variety of databases. You can create a new connection 

between LibreOffice by opening the file or connecting to a database server. You want a 

new database, so select “Create a new database.” Leave the Embedded Database type 

alone, especially since there is only one choice.

Figure 7-17.  Creating a database
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Finally, click Next.

Figure 7-18.  Database Wizard
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The next screen gives you a chance to register the database (make it available for 

mail merge) and specify whether you want to open the new database (you do). Click 

Finish to create the database, as shown in Figure 7-19.

Figure 7-19.  Creating the database
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LibreOffice prompts for the name of the new database so it can save it. In this case, 

let’s enter address_database. LibreOffice will display a window like Figure 7-20, which 

contains the empty database.

Figure 7-20.  Blank database
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Let’s go back to your spreadsheet. You need to copy the data from the spreadsheet 

into the database. First select all the data with Edit ➤ Select All and then copy it with 

Edit ➤ Copy, as shown in Figure 7-21.

Figure 7-21.  Copying the database
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Now go back to the database window. Select Edit ➤ Paste, as shown in Figure 7-22.

The Copy Table dialog will appear, as shown in Figure 7-23. For the table name, enter 

address_table (it makes queries easier if the name is all lowercase and has no spaces in it). 

Leave “Use first list as column names” selected, select “Create new field as primary key” 

to number each row, and then click Create.

Figure 7-22.  Pasting in the new table
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The new table appears in the database window, as shown in Figure 7-24.

Figure 7-23.  Creating the table

Figure 7-24.  New table
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You can use the Exchange Database feature of your form letter to get its data from 

this table. But you have a database, so let’s use it. Getting information out of a database 

is done through something called a query. Let’s see whether you can create a query that 

returns just those people whose first name begins with A. Start by clicking the Queries 

icon, as illustrated in Figure 7-25.

Next select Create Query in Design View. This opens the Add Table or Query dialog, 

as shown in Figure 7-26.

Figure 7-25.  Starting the query

Figure 7-26.  Add Table or Query dialog
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Since you have only one table, called “address_table,” let’s select that. Clicking Add 

will add it to list of tables in the Design View window, as shown in Figure 7-27.

You now need to enter the column values.

Figure 7-27.  Design View
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�First Column
For Field, enter *. The asterisk (*) means all fields of the table. To make sure the database 

knows which table you are referring to, it will add the name “address_table.” at the 

beginning. (You are using only one table for this query, but you could use more.)

The Table value will be filled in automatically.

Next select Visible to indicate that the results are to be displayed in the query.

�Second Column
The field is “first.” You are going to use the entries where the first name starts with A, so 

under Criterion enter LIKE ‘A%’. (The A% is enclosed in straight single quotes.) The LIKE 

operation is one that’s special to database queries and says to match the string on the 

right side, assuming that % matches any number of characters.

Do not select Visibility. The column is already brought in by *, and you don’t need it 

a second time.

�Third Column
For this column, the field is “last.” Select Ascending for the Sort item. Again, make sure 

Visible is deselected.

You’ll sort by last name. This column tells the database to do just that.

�Fourth Column
For this column, the field is “first,” the sort is Ascending, and it is not visible. If two names 

are the same, then the sort order will look at this field second. So, “Smith, Bob” will come 

before “Smith, Yani.”

The completed form should look like Figure 7-28.
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Figure 7-28.  Completed query design
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Now let’s select File ➤ Save. Figure 7-29 shows the Save As dialog that appears. Let’s 

save this query under the name A list.

Let’s go back to the form letter and select Edit ➤ Exchange Databases. As Figure 7-30 

shows, the query is now one of the data sources you can select.

Figure 7-29.  Saving the query

Figure 7-30.  Using a query as a data source
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Now when you run the form letter using the procedure described, you’ll get just the 

names that begin with A.

�Summary
LibreOffice is an adequate light database, but it does take a little getting used to before it 

is truly easy to use.

In this chapter, you saw how to connect the database to LibreOffice Writer to 

produce form letters. Unlike most commercial software, LibreOffice does not try to lock 

you into its proprietary system. You can, with a little work, interface to stronger and 

more professional databases such as PostgreSQL, MariaDB, and the big commercial one 

whose name we won’t mention.

The key here is that there are people out there who want nice office tools, and 

they are willing to write them or pay to get them written. The result is software like 

LibreOffice, which has all the useful features you find in Microsoft Office without the 

bloat and vendor lock-in.
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Graphics and Multimedia
In this part of the book, we first cover graphics, starting with digital photography and 

raster images. The Gnu Image Manipulation Program (Gimp) was designed to allow 

users to work with such images. It is somewhat comparable to Adobe Photoshop but has 

gone beyond this program in many places. Next, we review Inkscape, a drawing and 

illustration program. Finally, we cover Dia, a diagram editor.

Next, we move on to multimedia, starting with audio. The Audacity audio editor is 

considered one of the best in the world and has won several awards. After audio, we 

cover video editing. Computers have finally become powerful enough to do real-time 

video editing, although the technology is still in the early stages of development. The 

OpenShot video editor is one of the better ones available, so you’ll learn how to use it to 

create a YouTube video.

Finally, if you still use DVDs, you can learn about the DVDStyler program.  

This program lets you easily create nice-looking DVD images suitable for burning or 

distributing as an ISO image.

As computer technology advances, the quality of free software advances as well. With 

older technologies such as still pictures and audio, free software is as good if not better 

than its commercial counterparts. With newer video-editing technology, it may not be as 

good as the commercial stuff yet, but it’s almost there and catching up fast. Either way, 

you can find many excellent, free, open source tools to use in your daily work.
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CHAPTER 8

Getting Started with GIMP
GIMP is a high-quality, full-featured, image manipulation program. The program is free, 

but it comes with minimal documentation. This is both good and bad. It’s bad if you 

want to use the more advanced features, but it’s good for authors who write books like 

this one to fill the documentation gap. In this chapter, you’ll explore some of the basic 

uses of this program that you might encounter if you are editing your personal photos. 

These include the following:

•	 Rotating pictures

•	 Managing files

•	 Cropping images

•	 Adjusting brightness

•	 Correcting colors

You can download GIMP from www.gimp.org. To install it, just run the installer.

�Using GIMP
When you first start GIMP, you’ll see a splash screen, as shown in Figure 8-1. The 

program then takes some time getting together all the files and plug-ins it uses.

http://www.gimp.org/
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Note  GIMP caches the information it finds the first time it starts, so it won’t take 
quite as long on subsequent starts.

Once GIMP starts, it displays three windows, as shown in Figure 8-2.

Figure 8-1.  Splash screen

Figure 8-2.  Initial GIMP windows
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Close the two windows on the sides; you don’t need them for this tutorial. (You can 

get them back anytime you need them.)

�Rotating Images
Select an image from your computer that needs to be rotated and load it into GIMP by 

selecting File ➤ Open. The picture will display in the main editing window, as shown in 

Figure 8-3.

Figure 8-3.  Bad picture positioning
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To fix the photo’s rotation, select Image ➤ Transform ➤ Rotate 90° counter-

clockwise, as shown in Figure 8-4. If you want finer-grained control, you can select Tools 

➤ Transform Tools ➤ Rotate. But 90 degrees is good enough for now and covers most 

cases anyway.

Figure 8-4.  Rotating the image
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Figure 8-5 shows the result.

Figure 8-5.  Image after rotation
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�Managing Files
XCF is GIMP’s native file format, which makes it the best one suited for working within 

this program. Unfortunately, most other programs that display images do not support 

XCF, so you’ll more than likely want to convert the file to a more universal format, such 

as JPEG, PNG, or TIF. To do so, you must use Export rather than Save. Otherwise, you 

will get an error message stating that “The given filename cannot be used for saving.” 

However, be aware that by changing the format, you will lose some of the image’s 

properties.

The following are some of the options you can choose when working with your 

images:

•	 Save a file in GIMP’s native format (XCF). Select File ➤ Save, and it 

will be saved as XCF and readable only by GIMP.

•	 Change an existing XCF file to a standard format (JPEG, PNG, or TIF). 

Select File ➤ Overwrite <file name>, as shown in Figure 8-6.

•	 Save an image in a standard format (JPEG, PNG, or TIF). Select File ➤ 

Export As (Figure 8-6).

•	 You will need to fill in the name of the file name for export. The 

extension of this fill determine the type of image being saved. Enter 

the name of the file name (with extension) click Export as shown in 

Figure 8-7. In this example we used the extension “.jpg” for a JPEG 

type file (widely used industry standard for photographs).

•	 An option window specific to the file type you select will appear 

(Figure 8-8). In this case, the image is exported as a JPEG file. Unless 

you have specific changes, leave the defaults as is and click Export.
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Figure 8-6.  Overwriting and exporting menu items
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Figure 8-7.  Specifying the file to export

Figure 8-8.  File options 
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�Cropping an Image
In this example, the image shows the fare box, which is what you want. It also shows a 

good hunk of the garage, which you don’t want. Let’s see if you can concentrate the focus 

on the box by cropping the image. Figure 8-9 shows the command needed; it’s Tools ➤ 

Transform Tools ➤ Crop.

The cursor changes to a white cross with a knife. Drag the cursor across the picture 

you want to keep, similar to what’s shown in Figure 8-10.

Figure 8-9.  Cropping the picture
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Four white boxes will show up in the corners. (Only one is visible in Figure 8-10 

because we are still performing the initial drag.) You can drag these in and out to get the 

cropping perfect.

Click inside a square to perform the crop and get something that looks like 

Figure 8-11.

Figure 8-10.  Performing the crop
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This is a little small for the screen, so let’s zoom in.

You can use the menu View ➤ Zoom ➤ Zoom In a number of times, but that is 

slow. The shortcut key is +, so let’s press that a number of times until the picture fills the 

screen, as shown in Figure 8-12.

Figure 8-11.  Cropped picture
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Now let’s save it with File ➤ Export as right-way-up.jpg. So, now you have nicely 

cropped image with really bad color. Well, we could have shot the picture in the day 

without backlight in the first place, but where’s the fun in that? If we had done that, we 

wouldn’t have needed GIMP to come to the rescue.

Figure 8-12.  Zoomed and cropped image
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�Fixing the Color
We’re not sure how well the picture is going to show up in black and white, but take our 

word for it, the picture is very dark. You need to fix that. Let’s try the simple way first, with 

Tools ➤ Color Tools ➤ Brightness-Contrast, as shown in Figure 8-13.

Figure 8-13.  Getting to the Brightness-Contract control
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Figure 8-14 lets you change the brightness and contrast of the image. Let’s play 

around a little with the sliders and see whether you can make the picture better. By 

judiciously setting the controls, you can change the color from bad to lousy. To apply 

these changes, click OK. In this case, though, you want to try a different tool, so click 

Cancel to undo the changes.

Figure 8-14.  Brightness-Contrast dialog
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Let’s try a better tool. Select Tools ➤ Color Tools ➤ Curves, as displayed in Figure 8-15.

Figure 8-15.  Selecting the Curves tool
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This brings up the Curves dialog (Figure 8-16) that shows a histogram of the colors in 

the image. In this case, the image has a lot more dark colors, which is why there is a peak 

to the left. If you pull up the line with your cursor, it will brighten that section of the color 

space. Experiment with various line placements to find one that is suitable.

Click OK to set the colors.

Figure 8-16.  Color curves
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The image now looks like Figure 8-17. So, by using GIMP, you have taken the picture 

from very bad through lousy to poor.

�Using Filters
This chapter wouldn’t be complete if we didn’t mention filters. GIMP has a lot of filters, 

and most of them are useful. We will demonstrate one and hope the effect makes it 

through the printing process to the book. If not, download the pictures from the web site 

(www.apress.com) to see what we mean.

Figure 8-17.  There are limits to what can be done with a poor-quality picture
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The filter we are going to show how to use is called Clothify (Figure 8-18). In other 

words, it makes a nice image look like it was painted on cloth. To get the full effect of this 

filter, you can start by zooming in a little. Then select Filters ➤ Artistic ➤ Clothify.

Figure 8-18.  Selecting the Clothify filter
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Figure 8-19 shows the Clothify dialog that appears. You can play around with the 

settings later; for now, let’s use the defaults and click OK.

Clicking OK causes the image to be run through the filter, resulting in Figure 8-20.

Figure 8-19.  Clothify dialog
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�Summary
GIMP has many different tools for making your pictures look better, a surprising number 

that make them look strange, and a few that make them look worse. You can explore 

these tools on your own to see what each of them does.

In this chapter, we covered the tools that help casual camera users improve their 

photos and then store them in the Pictures folder.

Figure 8-20.  Cloth image
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CHAPTER 9

Drawing with Inkscape
Inkscape is a Scalable Vector Graphics (SVG) editor. Most images you see on a computer 

are raster images made up of a bunch of dots. In other words, the lines you see on the 

page are really a series of small dots. If you zoom a lot, you’ll see a rough line consisting 

of a bunch of big dots.

SVG graphics contain a description of the image. For example, a line on the page 

consists of a command to the program such as “Draw a line of 1.0 width from point (0, 0) 

to point (6, 3).”

You can use Inkscape to create drawings for sign, billboards, and other large-

format printing. It’s also useful for generating files for laser cutters. That’s because the 

description of an image consists of its path, and a laser cutter can easily move a laser 

along a path. With raster images, the laser cutter would have to shoot a bunch of holes in 

the material and hope they connect up enough to make a cut part.

�Getting Started with Inkscape
Download Inkscape from http://inkscape.org. (Download the .mis package for the 

best results.) Run the installer and accept the defaults.

When you first start Inkscape, zoom the drawing page until the paper fits the 

window. It sounds simple; just click the Zoom button, as shown in Figure 9-1, until you 

get the right size. Inkscape has a hair-trigger zoom. It can go from 50 percent to 1,000 

percent in less than a second. Every time we’ve used it, we’ve had to go back and forth a 

couple of times to get it right.

http://inkscape.org/
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�Drawing a Rose
In this chapter, we will show how to draw a rose. The goal is to introduce you to the basic 

controls used in Inkscape. This includes drawing simple shapes, using various types of 

fills and brushes, and using other editing tools.

Figure 9-1.  Zooming in on the page

Chapter 9  Drawing with Inkscape



189

�Drawing the First Shapes
The top of the rose is a circle. Click Circle/Ellipse tool to select that shape. By default 

Inkscape will let you draw an ellipse of whatever height or width you want. If you want a 

circle, you need to constrain the drawing so that the width and the height are equal. This 

is done by holding down the Ctrl key while drawing.

To draw, click the corner of the circle and then drag the cursor to the other corner, as 

shown in Figure 9-2.

Figure 9-2.  Drawing the circle
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The circle is black, but a rose is red. You need to fix this problem. You can change the 

properties of this circle by selecting Object ➤ Fill and Stroke, as shown in Figure 9-3.

Figure 9-3.  Opening the Fill and Stroke panel
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Now let’s change the color of the line (stroke) by clicking the Stroke Path tab and 

changing the color to black. Figure 9-5 shows the result.

The Fill and Stroke panel will appear to the right, as shown in Figure 9-4. You want 

this to be a circle with nothing inside, so click the No Paint icon in the dialog to turn off  

the fill.

Figure 9-4.  Turning off the fill
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From the top, the inside of the rose looks like a spiral. To draw this, you need to click 

the Spiral tool and drag it to the middle of the circle, as shown in Figure 9-6. The handles 

(boxes) on the end of the line allow you to extend or trim the spiral as needed. We think 

it looks better a little trimmed.

Figure 9-5.  Setting the stroke to a solid black
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Once you get the spiral to be the right shape, you need to get it to be the right size. 

Click the Select Tool to enter select mode and then click the object to bring up the resize 

handles, as shown in Figure 9-7. You can move these handles to resize the object.

Figure 9-6.  Creating the spiral
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Also, you can move the object by moving the cursor to one edge. When it turns into a 

hand, you can drag the object where you want it. In this case, drag it to the middle of the 

circle.

�Tweaking the Shape
Now things are going to get a little tricky. As it stands now, the spiral is a simple line. You 

are going to make it sexy.

To do this, you will create a thin ellipse and map it to the spiral.

The first step is to create a thin ellipse, as shown in Figure 9-8. To do this, click the 

Circle/Ellipse Tool and drag the mouse to create the shape.

Figure 9-7.  Getting the size and placement right for the spiral
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Now you run into a little problem with Inkscape. There are things called paths and 

things called objects. You’ve got a bunch of objects, and the operations you are about to 

do work only on paths. So, you need to convert your objects to paths.

Figure 9-8.  Skinny ellipse
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First select everything with Edit ➤ Select All, as illustrated in Figure 9-9.

Figure 9-9.  The Select All menu item
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Now convert all the objects to paths with the command Path ➤ Object to Path, as 

shown in Figure 9-10.

Figure 9-10.  Object to Path menu item
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With that bit of bookkeeping out of the way, you can now take the small ellipse and 

use it to shape your spiral. First you need to deselect everything, select the Select tool, 

and then click outside all of the objects. Next, click the skinny ellipse. Copy it to the 

clipboard with Edit ➤ Copy. Figure 9-11 shows this process.

Figure 9-11.  Copying the skinny ellipse
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Click the spiral to select it, as illustrated in Figure 9-12.

Figure 9-12.  Selecting the spiral
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Currently you don’t have any path effects defined, so the list in the panel at the top 

right is empty. Let’s add one by clicking the plus (+) sign located in this panel, which 

Figure 9-14 locates for you.

Now you are going to apply the skinny ellipse shape to the spiral path. You start with 

Path ➤ Path Effects, as shown in Figure 9-13.

Figure 9-13.  Path Effects menu item
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Figure 9-14.  Adding a path effect

A pop-up appears, as shown in Figure 9-15. Select Pattern Along Path and click Add.

Figure 9-16 shows how to select Paste Path.
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Figure 9-15.  Path effect selection

Figure 9-16.  Selecting Paste Path
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�Cleaning It Up
Now you have nice path for the inside of your rose. Let’s get rid of some clutter. Click the 

Close icon in the Path Effects panel and then the Close icon in the Fill and Stroke panel.

Delete the ellipse and zoom in so you can better see the top of the rose. When done, 

your screen should look like Figure 9-17.

Figure 9-17.  Cleaned-up rose top
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The spiral is much too fat for this use. Let’s fix it. You can start by bringing up the 

Path Effect panel using the command Object ➤ Path Effects. The width (shown in 

Figure 9-18) needs to be smaller, so set it to 0.500 (or whatever looks good for your rose).

Figure 9-18.  Setting the width of the pattern
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Now close the panel. Make sure the spiral is still selected. You want the fill to be 

black, so bring up the Fill and Stroke panel with Object ➤ Fill and Stroke.

Select the Fill tab, set the fill type to a color, and then select black for the color. 

Figure 9-19 shows the result.

Figure 9-19.  Filling the spiral with black

Close the Fill and Stroke panel and then select both objects, the spiral and the circle. 

Flatten them by moving the bottom up. Figure 9-20 shows the result.
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�Drawing the Body of the Rose
Now you will draw the body of the rose. It won’t look much like a rose at first, but you’ll 

improve on it soon.

Zoom out a little and click the Pen tool. Before you draw the lines, you will change 

the shape of the pen to Triangle Out. The pen is designed to draw curves and straight 

lines. You want only straight lines here.

So, click the left side of the rose top and draw a slated line to the bottom of the 

triangle, as shown in Figure 9-21. Click twice here. If you click once, the tool will assume 

you want curves. Twice indicates a sharp turn.

Figure 9-20.  Flattened circle and spiral
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Now go up to the top of the rose and click the right side.

Now you want to change the width of the line. Click the Edit Paths by Node tool. 

Small purple handles will appear at the ends of the lines. They are hard to see, especially 

if you have the black-and-white copy of the book, so look to Figure 9-22 to help you find 

them. Select the one at the top right and drag it out to make the line wider.

Figure 9-21.  Drawing the beginnings of the body

Chapter 9  Drawing with Inkscape



208

Now you will change the triangle, which doesn’t look like a rose, to a curved shape 

that does. The Edit Path by Nodes tool should still be in effect. Grab one of the triangle 

lines in the middle and drag it outward. It will curve out, and the shape will start to look 

something like a rose, as shown in Figure 9-23.

Figure 9-22.  Making the line wider
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Now let’s make the bowl of the rose a little taller. Using the Select Tool (at the top left 

of the toolbar), select the bowl and drag the bottom down. Figure 9-24 shows the result. 

(We adjusted the zoom a little too.)

Figure 9-23.  Forming the bowl of the rose
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�Adding Color
Now you need to make the rose red. Unfortunately, the path used to make the bowl has an 

effect associated with it that prevents you from filling it. (It’s a silly restriction, we know.)

So, you will create two bowls. One will have a nice black line showing the rose, and 

the other will provide the red body.

Start by right-clicking the object and selecting Duplicate, as shown in Figure 9-25.

Figure 9-24.  Stretching the bowl
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Bring up the Path Effects panel with the command Path ➤ Path Effects. Figure 9-26 

shows this process.

Figure 9-25.  Duplicating the bowl
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Click the minus (-) sign to remove the effect, as shown in Figure 9-27. (This works on 

only one of the two bowls; the result will be hidden by the duplicate bowl.)

Figure 9-26.  Path Effects menu item
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It’s time to do the red fill. You need the Stroke and Fill panel, so execute Object ➤ 

Stroke and Fill. Select the Fill tab, a solid color, and the color red. Figure 9-28 shows the 

result.

Figure 9-27.  Removing the effect
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As you can see, your duplicate object is now red and covering all the other objects.

You need the fill to be behind the patterns, not on top of them. Select Object ➤ 

Lower to Bottom, as shown in Figure 9-29.

Figure 9-28.  Red fill
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The result is a nice-looking bowl. The top needs some work, however. Let’s select the 

circle (now an oval) and use the command Object ➤ Fill and Stroke to bring up the Fill 

and Stroke panel.

We’ve already covered how to make the stroke small. To make it bolder, just increase 

the width. Also, fill the circle with red, just like the bowl, as shown in Figure 9-30.

Figure 9-29.  Lowering the object
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�Adding a Detail Line
Now you are going to add a detail line on the bowl of the rose, as shown in Figure 9-31. 

Perform the following steps:

	 1.	 Select the Pen tool.

	 2.	 Click near the top of the bowl to start drawing a line.

	 3.	 Move the mouse straight down about halfway down the bowl. 

Click to anchor a curve.

	 4.	 Go down and to the right to generate a small curve. Double-click 

to complete the line.

	 5.	 Select the Node Edit Tool.

	 6.	 Move the purple handles out to widen the line.

Figure 9-30.  Coloring complete
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Select the Pen tool, and starting at the top, drag straight down. Then move to the left 

to create a curve.

After drawing, select the curve and move the purple node out to form a thick line.

�Adding a Stem
To finish this drawing, you will add a stem. This is the same thing as the highlight line, 

but you will go in the opposite direction. Also, the stem is longer, as shown in Figure 9-32.

Follow these steps:

	 1.	 Zoom out.

	 2.	 Select the Pen tool.

	 3.	 Starting from just below the top, click once to start the line.

	 4.	 Go halfway down and click to set the curve.

	 5.	 Move to the left and double-click to finish the line.

	 6.	 Select the Edit Path by Nodes tool.

	 7.	 Move the purple handle out to expand the line.

Figure 9-31.  Drawing a highlight line
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Now select the stem and use Object ➤ Lower to Bottom to hide it. Figure 9-33 shows 

the final rose.

Figure 9-32.  Stem
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�Summary
Inkscape is one of the better and more widely used SVG editors. With it, you can easily 

design high-quality yet very flexible art, such as the rose you drew in this chapter. The 

goal of the chapter was to introduce you to the basic controls used in Inkscape; you 

learned to draw simple shapes, use various types of fills and brushes, and use other 

editing tools.

We barely scratched the surface, though, because there are many more tools that we 

just don’t have space to cover here. Please check the online resources for other features 

of Inkscape such as using gradients to add shadows to the rose, layers, patterns, and lots 

of extensions.

Figure 9-33.  Final rose
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CHAPTER 10

Using Dia Diagram Editor
Humans are visual animals. They remember pictures a lot better than words. As such,  

it is useful to use diagrams to quickly display information. Thus, you need a good 

diagram editor.

The Dia Diagram Editor program is such an editor and is similar to Microsoft Visio.

Diagrams are used for things such as process flow (flowcharts), network layout, 

organization charts, and maps. In fact, one of the most famous diagrams is of the London 

Underground tube system. The diagram is considered one of the finest examples of the 

art, presenting the traveler with the information needed in a clear and concise manner 

while eliminating irrelevant details.

In this chapter, you will discover how to create simple diagrams and thus distill 

complex information into a simple visual presentation.

�Creating a Flowchart
Download Dia from http://dia-installer.de/. Run the installer and select the defaults. 

Once it starts, an initial, blank diagram screen will appear, as shown in Figure 10-1.

http://dia-installer.de/
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On the left side are the tools you can use to make a diagram. Below that is a sheet 

selector area that allows you to select what symbols to use. Below that are the symbols 

themselves. The middle of the screen shows the current diagram.

For this exercise, you will create a flowchart telling you what to do in case of fire. 

(Somehow the letters from the Hilltop Elementary School in previous chapters gave us 

the idea.)

Figure 10-1.  Initial Dia screen
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Let’s start by dragging a start/stop node (the one that looks like a hot dog) from the 

sheet selector area to the middle of the screen, as shown in Figure 10-2.

Note T he Dia tooltip calls this a Terminal Interrupt, but we think start/stop node is 
easier to remember.

Figure 10-2.  Start/start node
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Drag one of the handles sideways to make the symbol wider and type Start inside it. 

Figure 10-3 shows the result.

Disclaimer T his is not a procedure approved by the fire department or any fire 
professional. Its sole purpose is to demonstrate how Dia Diagram Editor works, not 
to describe emergency procedures.

Figure 10-3.  Start node in place
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Next let’s add a decision box (the diamond shape) to the flowchart, as shown in 

Figure 10-4. Enter the text Understand Disclaimer?.

Now let’s connect the start with the disclaimer. Click the “zig-zag line” symbol and 

then click the bottom middle of the start/stop node. The program will start to draw a line. 

Go down to the point of the disclaimer. There are some subtle things to watch out for.

Figure 10-4.  Decision box added
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First, there are connection points on each of the nodes. These show up when the 

mouse is over the node and look like little green squares. Second, when you are actually 

connecting to a node, the node will highlight itself. In Figure 10-5, the decision node is 

highlighted in red, even if you can’t see it in the black-and-white illustration.

Figure 10-5.  Connecting the two nodes
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The start/stop node would look nicer over the decision node. So, drag it over to 

fix the problem. As you drag, you’ll notice that since the two nodes are connected, the 

connector is automatically adjusted to the new position. Figure 10-6 shows the result.

Figure 10-6.  Position adjustment

Chapter 10  Using Dia Diagram Editor



228

Now let’s add the letter N near the right side of the decision box. Click the Text tool, click 

just above the right corner of the decision box, and type N. Figure 10-7 shows the result.

Figure 10-7.  Adding “N”
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Let’s continue by dragging an operation box over to the right and labeling it Read the 
disclaimer. Add a connector from our “N” decision to the box. The result should look 

something like Figure 10-8. Let’s also add a connector from the top of the box back to the 

line above the decision box.

Figure 10-8.  Adding an operation node
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Now let’s fill in the rest of the chart by following these steps:

	 1.	 Add the letter Y to the bottom of the decision box.

	 2.	 Put an operation box below it with this text: Shout ‘Fire’ in a loud 

voice.

	 3.	 Add a second operation box with this text: Get out very fast.

	 4.	 Add a final start/stop node that says Done.

	 5.	 Add connectors for all these nodes.

Figure 10-9 shows the result so far.

Figure 10-9.  Finished diagram, almost
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There is just one remaining problem. The blue lines indicate page boundaries, so 

this diagram takes up multiple pages. You want it on one page. To fix this, let’s select File 

➤ Page Setup, as shown in Figure 10-10.

Figure 10-10.  Page Setup menu item
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The Page Setup dialog appears, as shown in Figure 10-11.

We’re in the United States, so first change the paper size to Letter. Next go to the 

Scaling section, click “Fit to,” and set the parameters to 1 by 1.

Click OK. Notice that the page boundaries have shifted, as shown in Figure 10-12. 

This diagram is now on one page.

Figure 10-11.  Page Setup dialog
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Now all you have to do is execute File ➤ Save and you’ve got the procedure for what 

to do in case of fire. In practice, you probably want to add a few steps, run it by a safety 

office, and print up some posters. The procedure is the same even if the content isn’t.

Figure 10-12.  Final diagram
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�Creating an Electrical Diagram
You’ve just completed a flowchart, so now let’s try creating an electrical diagram. Pretend 

you work as a volunteer signal maintainer at the Orange Empire Railroad Museum and 

you’re creating a wiring diagram for one of the signals.

You start by bringing up the electrical symbols sheet by going to the sheet selector 

and selecting Other Sheets ➤ Electrical, as shown in Figure 10-13.

Figure 10-13.  Bringing in the electrical symbols
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At the center of the signal is a relay. You construct this from a relay command organ 

(horizontal) and a normally open contact. Figure 10-14 shows the results.

Note  Because of the way railroad relays are constructed, the contacts go under 
the coils as shown, not on top as would be the case with any other type of relay.

Now you need to connect the contacts with the railroad signal. Unfortunately, Dia 

does not have a railroad signal symbol set (yet), so you’re going to have to make do. Let’s 

use a bell.

Figure 10-14.  Relay
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However, there isn’t a bell in this symbol sheet, and an exhaustive search of the other 

sheet leaves you without a bell.

So, what do you do? Go to the Internet and search for Dia symbol bell. You found a 

page with the Liberty Bell on it, so refine your search to Dia diagram symbol bell.

This takes you to an add-on sheet for Dia for electronic symbols, which is displayed 

in Figure 10-15.

Scrolling down, you can see that, yes, there is a bell symbol on this sheet. Looking 

at the text you see that there is a helper program called diashapes that will do the 

downloading and installation for you.

Let’s click that link and then download and install the software.

Figure 10-15.  Electronical sheet add-on
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When run, diashapes displays a list of all the available shape sheets and asks you if 

you want to download them, as shown in Figure 10-16.

Since you have lots of disk space and there aren’t that many shape sheets, you’ll 

leave them all selected and click Install. When done, the program shows you a dialog 

telling you it installed 21 new sheets, as shown in Figure 10-17. Your number may vary 

because there may be more added after the time this book was written.

Figure 10-16.  Diashapes

Figure 10-17.  Sheets installed
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You have to exit and restart Dia to see the new sheets.

Once you restart, from the sheet selector, select Other Sheets ➤ Electronics. 

Figure 10-18 shows you that you now have a bell.

Figure 10-18.  Bell
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Let’s drag in the bell and a connecting line. From the result in Figure 10-19, you can 

see that you have a problem. The line has an arrow on it.

Figure 10-19.  Bell with arrow
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Right-click the line to bring up the context menu and select Properties, as shown in 

Figure 10-20.

Figure 10-20.  Properties
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The Properties dialog appears. Change the line ending from an arrow to a line and 

click OK. Figure 10-21 maps out the controls.

Figure 10-21.  Properties
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This takes care of this line, but what about the next one you draw? Let’s go to the 

default line properties on the bottom of the toolbox and change the right line ending to 

“no arrow,” as shown in Figure 10-22.

Figure 10-22.  Line ending
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Now let’s draw the rest of the diagram using the tools and techniques you’ve seen so 

far. The only tricky part is when you want to add a resistor. That’s in the Circuit symbol 

sheet. As a final step, you want to put a box around the relay. Draw it in, and you’ll see 

you get the unpleasant result shown in Figure 10-23.

Figure 10-23.  Box
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You need to make it transparent. Also, you need the line to be dotted. So, by righting-

clicking the box, you can go to the Properties dialog, as shown in Figure 10-24.

Now the box looks wonderful. Let’s add a few labels to be even more helpful. 

Figure 10-25 shows the grand result.

Figure 10-24.  Properties
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Congratulations, the result is a decent-looking diagram.

Figure 10-25.  Final diagram
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�Summary
Dia comes with hundreds of shapes to support all sorts of diagrams, such as the 

following:

•	 UML diagrams for program design

•	 Computer network layouts

•	 Family trees

•	 Chemistry diagrams

•	 Civil engineering diagrams

•	 Organization charts

Although a simple tool, Dia can be used to take complex information and present it 

in a nice diagram that should make things easier to understand.

Chapter 10  Using Dia Diagram Editor



247
© Steve Oualline and Grace Oualline 2018 
S. Oualline and G. Oualline, Practical Free Alternatives to Commercial Software,  
https://doi.org/10.1007/978-1-4842-3075-6_11

CHAPTER 11

Using GnuCash
GnuCash is a simple-to-use accounting program. It has several advantages over a 

spreadsheet, such as reconciliation and check printing. Also, one of its chief advantages 

is that it is simple and easy to use.

In this chapter, you will learn the following:

•	 How to create a checking account

•	 How to enter checks

•	 How to create a memo line

•	 How to print checks

•	 How to create a savings account

•	 How to reconcile your bank statement

•	 How to schedule payments

You can download GnuCash from http://gnucash.org. Follow the usual installation 

instructions: download the file, run it, and accept all the defaults.

http://gnucash.org/
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You’ll also notice the first time you start the program, it starts slowly. It has a lot of 

initialization to do. The next time you start the program, it will be much faster.

Figure 11-1.  Tip Of The Day dialog

�Creating a Checking Account
Let’s start by creating a new checking account. When you first start GnuCash, it displays 

a GnuCash Tip Of The Day dialog, as shown in Figure 11-1. Like most tips, it’s not that 

useful, so click Close.
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You need to create a new account. If you are running GnuCash for the first time, it 

will automatically start the New Account Wizard. If not, from the main window, select 

File ➤ New File, as shown in Figure 11-2.

Figure 11-2.  Main window
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The New Account Wizard starts and displays the information screen shown in 

Figure 11-3. Click Forward to continue.

Figure 11-3.  New Account Wizard, first screen
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Next the system wants to know what currency you use. Since we are in the United 

States, we’re going to use the United States dollar, as shown in Figure 11-4. Again, click 

Forward to continue.

Figure 11-4.  Currency type
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The next screen, as shown in Figure 11-5, allows you to set options for your set of 

accounts (called a book in GnuCash terms). In this example, you are not doing anything 

fancy, so leave the defaults alone and click Forward.

Figure 11-5.  Book options
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Now you need to select what type of accounts you are creating, as shown in 

Figure 11-6. At the top of the list is Simple Checkbook. Select that and click Forward. 

(You are permitted at this point to wonder how many steps are left in this wizard! Don’t 

worry, you’re almost there.)

Figure 11-6.  Selecting account types
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Now you come to the screen where you get a list of accounts and can set the initial 

value of your checking account, as shown in Figure 11-7. In this case, let’s say you have 

$3,000 in the bank, so click next to the Checking Account entry and enter 3000. Then 

click Forward.

Figure 11-7.  Account setup
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Finally, you reach the Finish Account Setup screen, as shown in Figure 11-8. Rejoice 

and click Apply.

One more screen appears so that you can save your work, as shown in Figure 11-9. 

Enter a file name and click Save As.

Figure 11-8.  The end of the wizard

Figure 11-9.  Saving the file
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Finally, after much effort and lots of wizard work, you have reached the Accounts 

screen, as shown in Figure 11-10. Initially you won’t see your checking account, but 

by clicking the triangles next to Assets and then Current Assents, you can expand the 

hierarchy and see your new checking account.

Figure 11-10.  Accounts screen
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Click Checking Account to select it, as shown in Figure 11-11, and then click the 

Open button to open the account.

The ledger appears, as shown in Figure 11-12.

Figure 11-11.  Opening an account

Figure 11-12.  Ledger window
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�Writing Checks
Now let’s write a check for your monthly rent. There’s already a blank entry at the bottom 

of the ledger, so click in the Date field to select the date. Set the date of the check in the 

calendar that appears.

The Num field is next. Press Tab to go to it and enter the check number, 100. Press 

Tab to go to the next field, Description. Enter the name of the payee. Go to Transfer by 

pressing Tab. Leave the default here and press Tab. This is not a deposit, so press Tab to 

go to Withdrawal and enter the amount, 1000.

Press Tab again, and the balance is computed. Press it once more and a new line 

opens so you can start the process all over again. Figure 11-13 shows the result.

Figure 11-13.  New check
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Now let’s add a few more checks, as shown in Figure 11-14.

�Working with a Memo Line
By default your ledger displays information in a compact format. This leaves you no 

room for a “memo” line. Say you want to put something like “April Rent” on your rent 

check for April. To do this, select View ➤ Double Line, as shown in Figure 11-15.

Figure 11-14.  Checkbook with a few checks written

Figure 11-15.  Selecting Double Line
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This gives you the expanded ledger shown in Figure 11-16 and allows you a place to 

enter the memo.

To turn it off, simply select View ➤ Double Line again.

�Printing Checks
Adding checks to the ledger is only half the battle. You need to print them as well. One 

way is to hand-write them, but if you have a computer, why not let the computer do 

it? To print a check, click the check in the ledger and select File ➤ Print Checks, as 

demonstrated in Figure 11-17.

Figure 11-16.  Double lines for each entry
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The Print Check dialog appears, as shown in Figure 11-17. At the top there is a 

“Check format” pull-down that allows you to select from several different types of 

standard laser printer check formats. For example, in Figure 11-18, we have selected 

Dulex(tm) Personal Checks US Letter.

Figure 11-17.  Printing a check

Figure 11-18.  Selecting a check format
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The dialog also lets you choose whether the check is on the top, middle, or bottom of 

the paper. Click Print to print the check.

Note I f you are printing checks for the first time, we suggest you make several 
copies of a blank check to practice on before using the real thing. Sometimes the 
positioning of the various fields is off.

�Creating a Savings Account
Let’s say you have a savings account as well. Because this is not part of the simple 

checking account setup, you need to add it. In the main window, click the Accounts tab 

and then the New icon on the toolbar, as shown in Figure 11-19.

Figure 11-19.  Creating an account
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The New Account dialog appears, as shown in Figure 11-20. For the account name, 

enter Savings. For Parent Account, select Current Assets. Click the Opening Balance tab 

to go to the next screen.

Figure 11-20.  New Account dialog
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After clicking Opening Balance, you will see the screen shown in Figure 11-21 where 

you can enter this information and then click OK. Don’t worry if you forget the opening 

balance; you can always add a ledger entry for the opening amount.

Figure 11-21.  Opening Balance setting
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Now you will see the familiar Accounts screen (Figure 11-22). Select Savings and 

then click Open to get to the ledger for your new account.

Now let’s add an entry to indicate a savings-to-checking transfer, as shown in 

Figure 11-23. Set the field values as follows:

Date: Leave the default for today.

Num: Leave this blank.

Description: Enter Savings ➤ Checking.

Transfer: Click the pull-down and select Current Assets: Checking 

Account.

Increase: Leave this blank.

Decrease: Enter 3000.

Figure 11-22.  Account list with savings account
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Now let’s go back to the Accounts tab and open your checking account. Figure 11-24 

shows you that a new entry has been added for the transfer you just made.

Figure 11-24.  Checking account with transfer

Figure 11-23.  Savings ledger
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�Reconciling Checks
Every month you get a statement from the bank indicating how much money they think 

you have in the bank. Sometimes it’s the same amount as you think you have in the 

bank. So, every month you need to go through the process of reconciliation to correct any 

errors you’ve made in your ledger. (The bank never makes an error.)

To start the reconciliation process, click the Reconcile icon, as shown in Figure 11-25.

Figure 11-25.  Starting the reconciliation process
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A Reconcile dialog appears (Figure 11-26.) This gives you a chance to enter the date 

of the statement as well as the ending balance. It also gives you an excellent example of 

what happens when you try to put a long title in a small dialog.

Another dialog appears also titled Reconcile. (We’ll call the one in Figure 11-26 the 

“big” Reconcile dialog.) It lists the unreconciled transactions and gives you a chance to 

add them to the statement by checking them off.

If you check off the correct items, the Ending Balance and Reconcile Balance values 

should be the same. If they aren’t, you can go back into the ledger and fix any mistake 

you made and try again.

Figure 11-26.  Reconcile dialog
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�Scheduling Checks
Unfortunately, paying rent is not a one-time occurrence. You need to do it every month. 

Let’s tell GnuCash about this so it can schedule a payment every month. Click in the rent 

entry and then click the Schedule tool. Figure 11-27 illustrates this process.

Figure 11-27.  Starting the scheduling process
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The Make Scheduled Transaction dialog, as shown in Figure 11-28, appears. Initially 

it will try to schedule the transaction as Daily. Your landlord is greedy but not that 

greedy. He wants his rent monthly. So, change Frequency to Monthly. Also, you want 

checks to be written on the first of the month, so start the series on May 1 (5/1/2017) 

by changing Start Date. The schedule on the right side will change to reflect your new 

schedule. Clicking OK stores the schedule.

Figure 11-28.  Making a scheduled transaction
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Now let’s wait until May 1 passes. Let’s see whether any scheduled transactions are 

pending by selecting Actions ➤ Scheduled Transactions ➤ Since Last Run, as shown in 

Figure 11-29.

Figure 11-29.  Checking for scheduled transactions
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The Since Last Run dialog appears, as shown in Figure 11-30. Your rent check is 

marked To-Create. Let’s create all the pending transactions by clicking OK.

The dialog disappears, and you now have a rent transaction in the ledger  

(Figure 11-31). All you have to do is change the check number and print it.

Figure 11-30.  Since Last Run dialog

Figure 11-31.  Ledger with scheduled transaction
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�Summary
GnuCash is actually a pretty good basic accounting program, which means that it has 

tons more features than covered here. It can handle not only basic accounts such as 

checking and savings but also investments, loans, and many other types of items.

It also has a reporting system so you can generate a variety of reports, such as 

tracking income and expenses. If you have the accounting knowledge to use it, this 

program is more than enough for home use.
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CHAPTER 12

Editing Audio with  
Audacity
Computers and the Internet have revolutionized the music business. Before the Internet, 

you had to go to a record store or use mail order to get a song. Now you just download it 

from your favorite online store.

Audio recording and processing have undergone a revolution as well. What used to 

take a studio full of expensive equipment now can be done with a personal computer 

and in real time.

In this chapter, you will learn the following:

•	 How to convert between various audio encoding formats

•	 How to dice, slice, and splice together audio clips

•	 How to mix audio tracks to add background music to a voice file

�A Half-Hour of Hell for 60 Seconds of Air Time
One of the authors of this book (Steve Oualline) used to write fiction and sold nothing. 

But one of his stories was selected for a local authors’ show on KPBS, San Diego’s 

public radio station, and he got to read his story for on-air broadcast. Getting selected 

was one of the happiest moments of his life. Reading his story into a microphone was 

one of the worst.
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The story started like this:

Howard knew he was in trouble when he opened the front door and saw his 
wife, Yvonne, crying. “Oh, Howard,” she sobbed, “I wanted to surprise you 
tonight and cook you a spaghetti dinner just like I did ten years ago when 
you proposed to me, but I can’t.”1

That’s not how it was recorded. The recording took place in a small studio. Steve sat 

in front of a microphone with the host. In the booth behind him sat the producer who 

spoke to him through earphones. The recording session went like this:

Steve: “Howard knew he was in when he opened.”

Producer: “You missed a word, try again.”

Steve: “Howard knew he was in trouble when…”

Producer: “Too wooden. We need more feeling.”

Steve: “Howard knew he was in trouble…”

Producer: “Too fast. Start again.”

Steve: “Howard knew he was in trouble when he opened the front 

door and saw his wife, Yvonne, crying. <pause> Was that OK?”

Producer: “Keep going.”

Steve is happy to report that he did get better as he went along (although it went 

from being abysmal to being just plain lousy). The entire ordeal with like doing a 

performance with a heckler in your ear. The only bright spot, aside from getting his 

work on the radio, was that although he had to put up with the producer, he had to put 

up with me.

Needless to say, the producer had to do a bit of editing. For that he used a $20,000 

professional sound mixer/editor. You’re going to do the same thing with a personal 

computer and some free software.

1�The entire short story is available on Apress.com. After 20 years, it deserves to be published 
somehow.
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�Getting Started with Audacity
Audacity is an open source audio editor. It would have been an ideal tool for the producer 

at KPBS to use to cut out 95 percent of the recording session he couldn’t use, if it had 

existed at the time. It allows you to record from a variety of media, edit soundtracks, add 

effects and filters, and generally do a lots of other fancy audio-editing stuff.

You can download it from www.audacityteam.org/. To install it, run the file and 

accept the defaults.

When you start the program, the splash screen appears, as shown in Figure 12-1. It 

gives you some pointers to where you might find help. Click OK to dismiss the dialog.

Figure 12-1.  Audacity splash screen

The main editing window will open. Initially the soundtracks will be empty. If you 

record some audio or load some audio files, they will appear in the window, as shown in 

Figure 12-2.
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If you have a built-in microphone on your computer, you can use it to record 

some audio. This is a demonstration sound file, not a production sound file. If you are 

recording audio for real, get a decent microphone.

Start by clicking the red Record button and begin to speak. To stop recording, click 

the square stop button.

To save your file, select File ➤ Export Audio, as shown in Figure 12-3. (Don’t use File 

➤ Save because this saves the editing project.)

Figure 12-2.  Audacity editing window with sound
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If you want to follow along with the original sound file, you can download it from 

Apress.com. The clip we recorded has some deliberate mistakes (and probably some 

inadvertent ones).

The Export Audio dialog appears, as shown in Figure 12-4. Enter the file name in the 

“File name” field and use the “Save as type” pull-down to select MP3 Files. (The MP3 

format is the most common compressed audio format.)

Figure 12-3.  Exporting audio
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Clicking Save starts the save process, but there is a problem. The program needs an 

audio converter called LAME to create MP3 files, so a dialog pops up, warning you of this 

fact, as shown in Figure 12-5. You need LAME, so click Download.

Figure 12-4.  Export Audio dialog

Figure 12-5.  Locate LAME dialog
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OPEN SOURCE NAMING

A lot of work goes into the choice of a name for a commercial product. After all, a lot of money is 

going to be spent marketing the name to the masses and telling the world how great this product 

is. The name will even be trademarked so no one else can use it. Companies have been known 

to hire poets at great expense just to come up with the perfect name for a new product.

Open source project makers tend to adopt cute names. This started with the first series of 

software tools called the GNU project. GNU stood for Gnu is Not Unix. In other words, it’s a 

recursive name.

You will be using the popular MP3 encoder called LAME. This stands for LAME Ain't an MP3 

Encoder. (Let’s see, bad grammar, a recursive name, and slightly misleading—it’s the perfect 

open source project name.)

Obviously, calling a program LAME is not designed to sell a lot of programs. It’s almost as bad 

as calling a car “No Goes.”2

The Download button takes you to the web page shown in Figure 12-6. We are on a 

Windows machine, so we will follow the link “LAME installation section.”

Figure 12-6.  LAME installation page

2�Va is Spanish translates to “goes” in English. This explains why the Chevy Nova sells poorly in 
Spanish-speaking countries.
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This takes you to the screen shown in Figure 12-7, which is a more detailed page on 

where to get LAME.

Figure 12-7.  More detailed LAME installation page

Clicking the link takes you to the download page for LAME, as shown in 

Figure 12-8. Scrolling down a little, you see where you can download the installer for 

LAME. Download the file, run it, and accept all the defaults for the installation.
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Figure 12-8.  LAME download

Once the LAME encoder is installed, you are back at the Local LAME dialog and can 

click OK. The MP3 file format contains not only audio but some metadata as well. This 

includes the artist, song name, album, and other information. When you click OK, the 

Edit Metadata Tags dialog appears, as shown in Figure 12-9. Since you care about the 

audio only, you won’t set any tags here. Click OK.
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Figure 12-9.  Edit Metadata Tags dialog

At this point, Audacity starts encoding the file and pops up a window showing the 

progress of the operation. For our 25.5-second audio file, this happens quickly.

Now you are back at the editing window, as shown in Figure 12-10. You need to locate 

the point where the good portion of the audio starts. So, click Play and listen to the audio. 

As the audio plays, a line will move across the screen showing where you are in the file. (In 

Figure 12-10, it’s a little past 5.0.) There’s a green triangle pointing to the line as well.
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Figure 12-10.  Playback

During playback of the example file provided on Apress, you will notice that you 

want to throw away the first attempt of the sentence. In fact, all the audio up to the 

12-second mark is garbage. So, you can use the horizontal scroll bar at the bottom to 

position the screen to that point, as shown in Figure 12-11.
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Figure 12-11.  The 12-second mark

The waveforms show you that right around 12.4 is when the good stuff begins. Let’s 

take the cursor and click just before the good stuff starts and drag it all the way to the left. 

The selected audio will be highlighted, as shown in Figure 12-12.
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Figure 12-12.  Highlighting the junk
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To get rid of the unwanted audio, select Edit ➤ Cut, as shown in Figure 12-13.

Figure 12-13.  Cutting the audio

Scrolling to the other end of the audio, you can use the same technique to clip 

out the last few seconds of silence. Finally, let’s export the audio (using the procedure 

outlined earlier) to 01-story-good.mp3.

This gives you a basic, clean voice track. So, with a few simple edits, you were able to 

make it sound great. Now let’s add some musical enhancements to make it a bit fancy.

�Adding a Musical Introduction
You will enhance the story by adding a musical introduction. The first step is to find 

suitable music. For that you are going to look for an old instrumental, something like 

classical music or something from the 1920s or 1930s for which the copyright has 

long expired.
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For this piece, which is comedy, “Dance of the Cuckoos” would be appropriate. You 

probably know it as the Laurel and Hardy theme song.

You want only the first few seconds of the song, so let’s do the following using the 

steps outlined earlier:

	 1.	 Select File ➤ New to start a new project in a new window.

	 2.	 Click the Play button to hear the first few seconds of the piece and 

determine where the first musical phrase ends.

	 3.	 Drag the selection tool over the rest of the song to select it.

	 4.	 Select Edit ➤ Delete to delete it, leaving you with just the 

beginning.

Now let’s add the music to the story. Select all of the remaining song with Edit ➤ 

Select All, as shown in Figure 12-14.

Figure 12-14.  Selecting all
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Now let’s use Edit ➤ Copy to copy the song to the clipboard, as shown in Figure 12-15.

Figure 12-15.  Copying to the clipboard

Chapter 12  Editing Audio with Audacity 



291

You need to put this song at the beginning of the story. Go to the story window and 

click the Rewind button to move the cursor to the beginning of the track, as shown in 

Figure 12-16.

Figure 12-16.  Rewind button
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You can now insert the musical introduction at the beginning by selecting Edit ➤ 

Paste, which is so aptly demonstrated in Figure 12-17.

Figure 12-17.  Pasting in the music
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The waveform in the result looks a little different than it did in the original, as shown 

in Figure 12-18. That’s because the scale has changed.

Figure 12-18.  Result after pasting
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Clicking the Play button, you can hear the result:

DA-T-DA DA-T-DA DA-DA-DA DA DA Howard came home

There is a rather abrupt transition between the music and the voice. Let’s fix that by 

having the music fade out just before the start of the voice section. Drag the cursor over 

the last few seconds of the song to select it, as shown in Figure 12-19.

Figure 12-19.  Selecting something to fade
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Fading out is an effect that can be applied to your selection by selecting Effect ➤ 

Fade Out, as shown in Figure 12-20.

Figure 12-20.  Fading out
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As you can see from the resulting waveform, as shown in Figure 12-21, the musical 

introduction fades out and then the story begins.

Figure 12-21.  Fading out

As you can see, Audacity has lots of effects. Play with them to see what they do. Our 

favorite is Wahwah. When applied to “Dance of the Cuckoo,” it makes the song sound 

like the musicians were slightly drunk when they were playing.
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�Adding Background Music
Rather than use the music as an introduction, let’s use it as background music to the 

entire story. If it is not still on your clipboard, redo the steps just demonstrated to copy it 

so you can paste it in as the background.

For the background, you will add a new track to the story. When playing the story, 

Audacity will mix these tracks together. Select the command Tracks ➤ Add New ➤ 

Stereo Track to add the track to the story, as shown in Figure 12-22.

Figure 12-22.  Adding a new track
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The track appears below the current track. Let’s use Edit ➤ Paste to dump the music 

into this location.

By default, the new trace is muted. That’s why the audio is gray. Click the Mute 

button for this track twice to unmute it, as shown in Figure 12-23. (The second click is 

required because of the strange way it was muted when pasted.)

Figure 12-23.  Clicking Mute

Clicking Play lets you hear the voice and the music. And boy, do you hear the music! 

It’s actually hard to hear the words. You wanted background music, not overpowering 

music, so you need to do some edits.

Select all the sound in the track, but drag the selection tool over it. Now you need 

to apply an effect to reduce the sound. It would make sense to call the effect Volume 

or Reduce Sound, but sometimes common sense and UI design diverge. To make 

something quieter, you apply the Amplify effect, as shown in Figure 12-24.
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The Amplify dialog appears, as shown in Figure 12-25. Move the slider to the left turn 

down the music.

Figure 12-24.  Using Amplify

Figure 12-25.  Amplify dialog
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Click OK to lock in the change. As Figure 12-26 shows, the waveforms in the 

music tracks are now much smaller. Clicking Play lets you hear the results, which are 

surprisingly lousy. But it does demonstrate how to add background music to a track, 

which was the goal of the exercise.

Figure 12-26.  Background music in the background

Now you can export the audio so you can share it with friends and have good laugh 

at the result. Audacity does warn you that the soundtracks will be mixed in the result, but 

that’s a good thing because you just went through all this trouble to get them mixed.
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�Summary
In this chapter, you learned how to use a few of the features of Audacity. There are many 

more effects that you can play with. Also, you can mix more than just two tracks. There’s 

even a DTMF generator so you can use Audacity to dial your phone.

This chapter covered the basic and most useful features. But there are lots of online 

tutorials, web forums, books, and other resources available if you want to explore further.

Chapter 12  Editing Audio with Audacity 
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CHAPTER 13

Editing Videos with  
OpenShot
There are several good open source video editors. Some provide basic editing. Others 

provide all sorts of effects and transitions. The OpenShot editor provides a nice balance 

between features and usability.

In this chapter, you will learn the following:

•	 How to convert video files from one format to another

•	 How to combine short video clips into a full-length video

•	 How to create stills

•	 How to add transitions

You can download OpenShot from http://openshot.org/. Run the file and accept 

the defaults.

�Converting Video Files
When we started writing this chapter, we tried directly editing the video files (MOD 

files) produced by our camera. However, OpenShot was prone to random freezes. So, we 

went to the Internet and scanned the forums to see whether anyone else had seen this 

problem. It turns out that they had. OpenShot on Windows doesn’t work well with the 

MOD file format we were using. We needed to convert the files to another format for the 

problem to go away.

The program HandBrake has only one job, video conversion. And it does it pretty 

well; it can handle all the common video formats and most of the uncommon ones. 

You can download the program from https://handbrake.fr/. Installation consists of 

running the downloaded file and selecting all the defaults.

http://openshot.org/
https://handbrake.fr/
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Say you want to convert every video that you shot and downloaded to your 

computer; in other words, you want to do a batch conversion. Open the Preferences 

dialog by selecting Tools ➤ Preferences, as shown in Figure 13-1.

Figure 13-1.  Opening the Preferences dialog

Chapter 13  Editing Videos with OpenShot 



305

Figure 13-2 shows the Preferences dialog. Click Output Files in the first column 

to select the Output Files section and then use the Browse button to select the output 

directory. This directory should be different from the one containing the input files.  

In this example, we’ve created a directory named hand.out to receive the files.

Figure 13-2.  Setting the default path for output
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Figure 13-3.  Starting the conversion process

Clicking Back returns you to the main window, as shown in Figure 13-3. Let’s start 

the process of converting the files by clicking Open Source.
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The program can process a single file or an entire directory with multiple files.  

In this example, you want every file you downloaded from your camera, so select Folder 

(Batch Scans), as shown in Figure 13-4.

Figure 13-4.  Starting a batch scan
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The program will display a selection dialog allowing you to select the folder with the 

files in it. When you click Select Folder, a progress dialog (Figure 13-5) appears.

Figure 13-5.  Progress dialog
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There’s one more step needed to get the files into the system. When you get back to 

the main window, you need to click the triangle next to Add to Queue and select Add All, 

as illustrated in Figure 13-6.

Figure 13-6.  Adding all the files

Chapter 13  Editing Videos with OpenShot 



310

The program now displays a warning concerning the addition of subtitles, as shown 

in Figure 13-7. In this example, we have no subtitles, but if you do, they could be added 

in OpenShot; click Yes to continue.

Figure 13-7.  Subtitle warning dialog

We have added eight jobs to the queue to do a direct conversion. In other words, we 

want the resulting video to have the same resolution and frame rate as the original. For 

that reason, you leave the output settings alone. The only reason you would want to play 

with these settings is if you were reducing the resolution or frames per second so as to 

make the video smaller. For example, if you were e-mailing the videos or displaying them 

on the Web, you would want a small file size.
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Let’s do a quick check to make sure you have everything by clicking Show Queue in 

the main window. The Queue dialog will pop up, as shown in Figure 13-8. Everything 

looks in place, so let’s close the window.

Figure 13-8.  Job queue
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It’s time to do the conversion, so click Start Queue, and the conversion begins, as 

shown in Figure 13-9.

Figure 13-9.  Showing and starting the queue

The encoding begins. This takes quite a bit of processing, so feel free to go for coffee. 

Actually, it wouldn’t hurt to have a quick lunch too.
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Figure 13-10 shows HandBrake working on the files.

Figure 13-10.  The encoding in progress

When the system is finished, the resulting files will all be in the hand.out directory 

ready for use with OpenShot.

Chapter 13  Editing Videos with OpenShot 
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�Importing the Media
When OpenShot starts, it displays a pop-up window asking if you want to go through the 

tutorial. Let’s dismiss the tutorial by clicking Hide Tutorial, as shown in Figure 13-11. 

You can always go back and view it by selecting Help ➤ Tutorial.

Figure 13-11.  OpenShot initial screen

The layout of the panels needs work. The tracks are difficult to see. So, grab the 

handle between the tracks at the top of the screen and drag it up.

Now you need some media, so click the Import Media icon (the plus sign).

Chapter 13  Editing Videos with OpenShot 



315

A file selection dialog appears. You want all your video files, so click the first file, 

Shift+click the last one, and select Open. Figure 13-12 illustrates these steps.

The following examples use some video files that we shot to explain how an antique 

Johnson farebox works. You can download these files from https://www.apress.com/

us/book/9781484230749 to follow along with the steps.

Figure 13-12.  Opening video files
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The files are now loaded into the Project Files panel, as shown in Figure 13-13. 

However, they are shown as thumbnails. It’s going to be easier to work with them  

if you display them as a list, so right-click inside the Project Files panel and select  

Details View.

Figure 13-13.  Video files imported
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At the bottom of the screen are the video tracks, as shown in Figure 13-14. This is a 

new project, so OpenShot gives you five blank tracks. Two is all you need, so let’s simplify 

things. Right-click Track 4 and select Remove Track. Do the same thing for Track 3 and 

Track 2 as well.

Figure 13-14.  Removing excess tracks

In our example, the Project Files list contains every clip we brought in, including a 

huge number of flubs. You now want to get rid of the ones you don’t need, so right-click 

each clip and select Preview File, as shown in Figure 13-15.
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Figure 13-15.  Starting a preview

The Preview window appears, letting you see what’s in the clip, as shown in 

Figure 13-16.

Figure 13-16.  Preview window
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In our example, we want to remove the clip Mov6a-6.m4v because this clip is not 

going to make it into the final production.

Right-click and select Remove from Project, as you can see in Figure 13-17.

Figure 13-17.  Removing a file from the project

That’s not the only bad file, so we’ve previewed each one and decided if we want to 

keep it or remove it. Here is the list of files:

Mov062-1.m4v Remove

Mov063-2.m4v Remove

Mov064-3.m4v Keep (first good scene)

Mov066-4.m4v Keep (second good scene)

Mov068-5.m4v Keep (third good scene)

Mov06a-6.m4v Remove

Mov06b-7.m4v Remove

Mov06c-8.m4v Keep (fourth good scene)
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During the preview process, we kept track of which file is first, second, third, and 

fourth. Now we will show how to build the video. The first piece is the file Mov63-3.m4k, 

so let’s drag it from the media list down to Track 0, as shown in Figure 13-18.

Figure 13-18.  Putting the first video on the track
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This track needs some precise editing. You aren’t going to be able to make 

subsecond edits at this level of zoom, so click the + icon on the zoom until you see 5 

seconds for the time scale. Figure 13-19 shows the results. Now you can see what’s in the 

video by clicking Play on the main video window. The timeline will move across the track 

indicating where you are.

Figure 13-19.  Zoom and play

Chapter 13  Editing Videos with OpenShot 



322

At this point, the good stuff is to the left of the marker, and the bad stuff is to the right. 

As Figure 13-21 shows, to drop the bad stuff, right-click the marker and select Slice  

All ➤ Keep Left Side.

In our example, we want to position the marker just after I finish talking and just 

before telling the cameraman “Stop.” To get things exact, you may have to play around 

with the marker. If you move it back, say to the 00:00:40 mark, and hit Play, the video will 

start from that location. Through trial and error, you should be able to locate the precise 

location you want around the 00:00:43 mark in this clip, as shown in Figure 13-20.

Figure 13-20.  The dividing line between good and bad
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Figure 13-21.  Getting rid of the bad stuff

Figure 13-22.  Bad stuff trimmed

As you can see in Figure 13-22, the right side has disappeared.
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Now let’s drag the second clip, Moc66-4.m4k, and bump it up against the right side 

of the previous clip. Again, you need to trim off the tail end. Repeat this for the clips 

Mov068-5.m4v and Mov06c-8.m4v, giving this project the appearance of Figure 13-23.

Figure 13-23.  All four clips put together
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Now you need to turn this project into a video, so select File ➤ Export Video, as 

shown in Figure 13-24.

Figure 13-24.  Exporting the video
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The Export Video dialog appears. The original video was shot at 720×480 at 30 frames 

per second. (You can right-click any clip and select Properties to verify this.) You want 

the output to have the same quality, so select DV/DVD NTSC (720×480) for the video 

profile and then click Export Video, as shown in Figure 13-25.

Figure 13-25.  Export settings

The program puts all the video clips together and writes the result to the file 

Johnson.m4k. The speed leaves much to be desired, especially on our cheap laptop, so 

this is another time when you can go for coffee.
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�Lessons Learned
During the shooting of this video, we learned a few lessons that don’t have to do with 

video editing but are useful when you are creating a video. Here are some tips when 

shooting video:

•	 If you have a high-definition video camera and a low-resolution 

video camera, don’t put the low resolution on top of the video camera 

box. It will be the first one you grab when you start filming.

•	 If your subject is green, it’s not a good idea to stick it in front of a 

green bush. This makes it hard to see.

•	 A good microphone is key. That’s why we bought an expensive 

HD video camera; it had a connection for a wireless microphone. 

Without it, you hear a lot of wind, noise, and background sounds.

•	 Consider recording the sound separately. If you don’t need to see a 

speaker in this video, OpenShot lets you put a video clip on Track 0 

and mute it. Then you put an audio track on Track 1, and they will be 

combined. (See Chapter 12 for how to make a good audio clip.)

•	 There’s a reason Hollywood uses marker boards (the thing they 

“clap” at the beginning of shots). Consider using something similar 

to identify the beginning and end of each clip. The sound does not 

show up in the Video Preview window (especially if you’re stopped). 

Pictures do.

�Adding a Title
Now let’s play with the more advanced features of OpenShot. First, let’s use the  

Files ➤ Save Project As menu item to save the project under Johnson_play.

Now let’s create a title sequence by selecting Title ➤ Titles from the menu bar, as 

shown Figure 13-26.
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The Titles dialog appears, as shown in Figure 13-27. Let’s select a good template to 

use for the title.

Figure 13-26.  Creating a title

Figure 13-27.  Titles dialog
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Use the Bar 2 template. For the empty fields, use these values:

File Name: JohnsonTitle

Line 1: Johnson Farebox

Line 2: How it works

Click Save to finish. You’ll notice that a new item, the title, has been added to the 

Project Files list, as shown in Figure 13-28.

Figure 13-28.  New project file

Drag the title down to the beginning of Track 0. You can drag the end of the image to 

the left or right to make the selection longer or short.

It would be nice if there was a way of moving all the clips on a track to the right. In 

fact, several people have requested this feature in the OpenShot forums, but it’s not 

available yet.
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�Creating Titles
OpenShot has the ability to let you do quite a bit of editing with your titles by using 

Inkscape. (See Chapter 9.) However, you have to configure the system so that it knows 

how to start this program. This task is a little beyond the scope of this book. If you want, 

you can point Inkscape at the image itself and edit it directly.

There is also the ability to generate animated titles with a 3D animation system 

called Bender. Again, the installation and configuration of this software are beyond the 

scope of this book.

�Creating Stills and Transitions
Now you’ll add a still picture to a video. First, import a photograph to the Project Files 

panel. Next, drag it down to your timeline between the last two clips. Also, let’s adjust it 

for time so it’s about eight seconds long.

Figure 13-29.  Video clip with title

So, we will show how to do this the hard way. Drag the first clip down from Track 1 

to Track 0 and position it just after the title. Do the same thing for the other three tracks. 

The result, shown in Figure 13-29, is a new video clip with a title.
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Figure 13-30 shows the results.

Figure 13-30.  Video with still added

Now when you play the video, the still you just added will be shown between clips. 

This is boring, so let’s add some more exciting stuff.

Click the Transitions tab and drag the Circle Out to In transition over the still. You’ll 

notice that if you put the preview timer right in the middle of the transition, there’s a dark 

spot in the middle of the picture, as shown in Figure 13-31. This starts out large and gets 

smaller until it disappears.
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�Looking at Advanced Features
There are lots of more advanced features that we don’t have space to cover here. Here are 

just a few:

•	 Picture in picture

•	 Subtitles

•	 Graphic overlays

•	 Adding a voice track

For us, we’ve produced only one YouTube video and it has received a total of nine 

views. We’ve got a long way to go before we become Internet stars.

�Summary
OpenShot is a good basic video editor. It has enough features to make interesting videos 

yet not so many that you spend a tremendous amount of time trying to figure out where 

the feature you want is located.

Figure 13-31.  Adding a transition
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CHAPTER 14

Creating DVDs 
with DVDStyler
Now that you have created a video (see Chapter 13), you’ll learn how to turn it into a 

DVD. The DVD will be split into individual chapters and also have a Play All button for 

those who want to watch the entire video. After creating the DVD, you will have a file you 

can put on a USB stick and send to your friends and relatives, or you can burn the file 

onto a real DVD for playing on a computer or that antique machine called a DVD player.

�Getting Started with DVDStyler
DVDStyler is a basic DVD creation program. It gives you the ability to create simple 

DVDs with features such as chapters, menus, and other basic elements. It’s not as full 

featured as some other DVD creators, but they tend to be so complex that it is difficult for 

a novice to do simple things. DVDStyler lets you create something that looks good and 

works well without hassling you with 5,000 different options.
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You can download the program from www.dvdstyler.org. To install it, it’s the same 

ol’ drill: download, run, and accept the defaults. The download page even has a nice ad-

blocking detector, as shown in Figure 14-1.

Since FossHub has been so nice to give us DVDStyler for free, we’re going to send in 

a few bucks. Feel free to join us.

�Preparing the Video Clips
Before you start, you need four video clips containing the four segments you put together 

in the previous chapter. We’ll leave it to you to use OpenShot to transform those clips 

into something useful and store them in the files J Part1.mp4, J Part2.mp4, J Part3.

mp4, and J Part4.mp4.

Figure 14-1.  Ad blocker detected
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�Using DVDStyler
When DVDStyler starts, it displays a Welcome dialog. This lets you define the project 

or open an existing project. This video is going to be about the farebox shown in earlier 

chapters, so enter Johnson farebox for the label. If you are in the United States, you 

should make your DVD in the NTSC format, so select that option. Finally, click OK to 

start the project, as shown in Figure 14-2.

Figure 14-2.  Welcome dialog
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You will see a dialog (Figure 14-3) asking you to select a template for the menu 

screen. Enter Johnson Farebox Operation in the Caption field. For Template, just select 

the first one since none of them really looks like what you want. Finally, click OK to finish 

the selection process.

Figure 14-3.  Selecting a template
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The main window appears, as shown in Figure 14-4. It shows you a list of 

backgrounds (which you don’t care about for this example) on the left and the first menu 

on the right. The menu looks OK, so click the second menu screen at the bottom to take 

a look at that. Also, click the File Browser on the left and go to the directory containing 

your files.

Figure 14-4.  Initial editing window
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Let’s now add the video to the menu. Drag the video J part1.mp4 to the first square 

in the menu, as shown in Figure 14-5.

Figure 14-5.  Adding a video to the menu
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The program will pop up a warning dialog asking if you want the video converted, as 

shown in Figure 14-6. Click Yes.

Repeat the dragging process for the other three videos. The result will look like 

Figure 14-7.

Figure 14-6.  Conversion question

Figure 14-7.  Completed project
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Now is a good time to save your project by selecting File ➤ Save, as shown in 

Figure 14-8.

Figure 14-8.  Final project
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Now let’s create the DVD by selecting File ➤ Burn, as shown in Figure 14-9.

Figure 14-9.  Burning the DVD
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The Burn dialog appears, as shown in Figure 14-10. This allows you to create an 

image file (called an iso file) or burn the DVD using an attached DVD burner. In this case, 

that option is grayed out since we don’t have a DVD on this laptop.

So, for this example, we’ll leave “create iso image” selected, put the file name in the 

“Save to” field, and click Start.

Figure 14-10.  Burn dialog
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A Generate DVD window appears and displays the progress of the burn, as shown 

in Figure 14-11. It contains lots of helpful details mostly of use to the developer of this 

software but not to you. This will take a while, so go for coffee.

Figure 14-11.  Generate DVD dialog
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We see you’re back from coffee. Don’t spill it on the keyboard. If you took long 

enough, the DVD generation is finished, and you’ll see a message on the bottom 

indicating success, as shown in Figure 14-12. Close the dialog.

�Summary
DVDStyler is a good tool for making basic DVD videos. There are more advanced 

authoring tools out there, such as DVDAuthor, but they have steeper learning curves that 

must be overcome to work them. DVDStyler has a nice balance between features and 

usability that should satisfy most users.

Figure 14-12.  Success
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Cloud-Based Services
In 1995, Sun Microsystems had a “brilliant” idea. Back then, computers cost $500 to 

$10,000, and this was when $500 was a lot of money. Putting a computer on the desk of 

everyone in an office was a considerable expense. So, Sun created the idea of a thin 

client, which is a small computer with just enough CPU power to connect to a big server. 

The thin client would handle the display and the keyboard, and the big server would do 

all the work. That way, Sun would sell lots of big servers.

It was an idea ahead of its time…way ahead of its time. No one wanted to spend 

the money for the big servers and for the people to keep the big servers running, so 

Sun’s idea never caught on, that is, until Google had a similar idea. Google realized 

that there is money in data, specifically, data that can be used to help create targeted 

advertisements. So, Google said, we’ll make the big servers and keep them running for 

you, and all you have to do is give us all your data and let us scan it1 so we can see what 

sort of advertisements are best suited to you. Google started with Gmail, a cloud-based 

mail that you can read through your browser. It followed this up with Google Docs, a 

word processor; Google Sheets, a spreadsheet program; and other services. Then Google 

noticed that people didn’t need a PC with Windows to access these online servers, so the 

company encouraged people to use Chromebooks, a minimal laptop with just enough 

power to browse the Web and use Google’s applications. Chromebooks were introduced 

in 2011, which was 16 years after Sun tried to introduce the idea (and well after Sun went 

out of business).

1�If you read the click-through license agreement that comes with your Google account, it says 
Google can do automated scanning. Google’s employees can’t manually read your documents, 
but its robots can, provided all individual identification is removed.
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�Cloud vs. Local Applications
The advantage of cloud services is that your data is available wherever there is an 

Internet connection. The disadvantage is that if you have no Internet connection, you 

have no data.

The cloud lets several people work on the same document or spreadsheet at the 

same time. We’re not sure whether that is good or bad. We’ve seen documents written by 

a group of 15 engineers, and they would have created something better and faster if they 

had gotten rid of 12 of them.

Cloud-based applications suffer from three difficulties. First, they have to download 

a set of program files to your computer every time they run. Second, to keep these 

program files a reasonable size, they generally don’t have as many features as their local 

counterparts. Finally, another issue is that your data is in the hands of someone else. 

That someone else could pull the plug at any time, leaving you with nothing. (Needless 

to say, frequent backups are highly recommended.)

Cloud-based applications are great for educational environments. They make sure 

that all the students share their homework assignments with the teacher, and no one has 

to turn in anything on paper, saving countless trees.

For business, the security and document control policy of cloud-based applications 

may prohibit some people from using them. Some companies, such as defense 

contractors, do not permit employees to have an Internet connection at work.

We’ve found the cloud to be good for mail (Gmail) because Google’s analytical 

abilities help keep spam out of inboxes, and it allows you to get e-mail pretty much 

everywhere. You can also use Google Sheets to track personal goals, such as your weight, 

and update your weight history using a PC or Android phone. Whatever you decide, 

there are lots of free cloud-based and local open source applications to do these kinds of 

tasks. All you need to do is pick the one that works best for you.

Part III  Cloud-Based Services
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CHAPTER 15

Using Gmail
Gmail is Google’s free e-mail program. The major reason we use is because it is great at 

eliminating span. Also, it’s free, it works well, and you don’t have to set up your own mail 

server to use it.

In this chapter, we will cover the basics of using the system as well as the use of the 

“star” flag for important messages. We’ll also discuss the tagging system, which allows 

you to organize your e-mails so you can make sense of all the messages you get.

Security is also a major concern. The best way to keep yourself secure is to avoid 

anything that may compromise your system. We will discuss some of what these are. 

As part of the effort to keep you safe, we’ll take a look at a new Gmail feature called 

Authentication for Verified Senders, which tries to make sure that the person you are 

talking to is who you think he is.

�Getting Started with Gmail
To begin using Gmail, go to http://gmail.google.com. The start screen gives you the 

option to sign in if you have an account or create an account if you do not, as shown in 

Figure 15-1.

http://gmail.google.com/
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After signing in, the top-level screen will appear, as shown in Figure 15-2.

Figure 15-1.  Gmail start screen
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To send an e-mail, click the Compose button. To read an e-mail, click the e-mail.

Go ahead and click Compose to send a message to yourself. The new message dialog 

appears, as shown in Figure 15-3.

Figure 15-2.  Gmail top-level screen

Figure 15-3.  New message
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First, you fill out the e-mail address of the person getting the message. Next, you add 

a subject line and some text and click Send to send the message. The message will appear 

in your Inbox, as shown in Figure 15-4, although it might take a couple of minutes.

Figure 15-4.  Message received
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There is a little icon next to the message indicating that it is a personal message. If 

it is an important message, you can mark it as important by clicking the star next to the 

message. When you click Refresh, the message jumps up from the bottom section to the 

first where all the important messages go. Figure 15-5 shows you what’s important and 

what’s not.

Figure 15-5.  Important message at the top
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�Tagging Messages
One of Gmail’s nicer features is the ability to tag messages. A message can have multiple 

tags. A message might be tagged Personal and Travel, for example. In this example all 

our messages are tagged with Inbo”. Let’s take the first one and move it to the Personal 

tag, thus removing it from Inbox.

Select the check box next to the message, click the Move To icon, and select Personal 

following the guide in Figure 15-6.

Figure 15-6.  Tagging something as Personal
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Figure 15-7 shows you that the message has disappeared and that the Personal tag 

now has one unread message in it. Click Personal to see all the messages associated with 

that tag.

Figure 15-7.  After moving the message
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Figure 15-8 shows the result of clicking Personal.

�Making Sure Your Email Is Secure
E-mail is one of the most common ways that you will be attacked by hackers. That’s 

because it’s easy to send and easy to forge. A hacker will try to get you to do one of the 

through e-mail:

•	 Download and execute a program.

•	 Click a link where you can enter your account name and password to 

an online account or other personal information.

•	 Send them personal information.

•	 Transfer money to a company or account.

Figure 15-8.  Personal messages
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A typical e-mail scam will appear to be a message from eBay indicating that your 

account have been frozen until you go to a given web site and update your account 

information. The web site might even have eBay in its name, such as ebay.scamartist.com. 

If you click the link, you’ll see an eBay logo and a familiar looking sign-on page. This is run 

by the scammer who will use the information you provide to take over your account and 

ripoff as many people as he can before your account is really susupended.

John Podesta fell victim to a scam of this type. He got en e-mail from a scammer 

claiming to be Google and asking him to go to a web site and enter his e-mail and 

password. This is resulted in the raiding of his e-mail account and the publishing of 

many of his e-mail messages in the national new media.

Google tries to keep you safe from the most common scams, but the hackers are 

always coming up with new ones. Good safety practices mean that you should follow 

these tips:

•	 Never click a link inside an e-mail. If eBay or Google asks you to do 

something to your account, enter company’s address in the address 

bar of your browser.

•	 Never run a program that arrives in an e-mail unless you both know 

the person sending it and are expecting the program.

•	 Never undertake any financial transaction based solely on an e-mail, 

no matter who it is from. Confirm everything using a method such as 

phone or fax that does not involve e-mail.

�Authentication Icon for Verified Senders
To help cut down on the illegal e-mail traffic, Google has implemented an experimental 

features called Authentication icon for verified senders”. When you turn this feature on, 

messages from certain senders will be displayed with a little “key” icon indicating that 

they came from a verified sender.

Warning  Do not rely on this feature to be 100 percent authoritative. Any 
authentication system can be fooled. Also, this feature is experimental. It may go 
away at any time.
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To enable this feature, click the Settings icon and then select Settings from the menu, 

as shown in Figure 15-9.

Now select the Labs tab, scroll down, and click Enable for the “Authentication icon 

for verified senders” setting, as shown in Figure 15-10.

Figure 15-9.  Opening Settings
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�Summary
Google provides an excellent mail server. Because it is heavily used, Google is 

continually improving this system and adding more features.

Spend time going through the online help to look for them. These include e-mail 

filtering, vacation replies, and integration with Android and iPhone phones.

But the major feature of Gmail is that it is a good solid mailer with basic features the 

are easy to use.

Figure 15-10.  Enabling the “Authentication icon for verified senders” setting
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CHAPTER 16

Using Google Docs
Google Docs is an online word processor similar to Microsoft Word or LibreOffice Writer. 

The major difference is that instead of your files residing on your computer, they reside 

in the cloud in Google’s online storage system (Google Drive).

The main advantage of having your documents online is that they are available to 

any computer with a browser. The main disadvantage is that if you don’t have an Internet 

connection, you don’t have access to your documents. Also, both LibreOffice Writer and 

Microsoft Word have advanced features not available on Google Docs.

Where Google Docs works well is in educational settings. Students can share their 

papers with the teacher, and the teacher can add comments to a paper online without 

having to go to the trouble of actually sharing a physical file. The bad news is that it 

makes the “Dog ate my homework” excuse impossible.

Although Google Docs does not have all the features you might want in a word 

processor, it does have enough to create simple documents for school or personal use.

In this chapter, you will learn the following:

•	 How to get started with Google Docs

•	 How to create a simple letter

•	 How to print

•	 How to share and collaborate

•	 How to do voice typing

�Getting Started with Google Docs
To get started, go to http://docs.google.com in your browser. You may need to sign in 

with your Google account, but you will eventually get to the top-level screen.

http://docs.google.com/
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�Writing a Simple Letter
Let’s start by composing a letter. There is a template for letters, so let’s click that and start 

a new document, as shown in Figure 16-1.

Figure 16-1.  Selecting the Letter template in Google Docs
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The template looks like the document shown in Figure 16-2.

Figure 16-2.  Letter template
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Now all you have to do is replace the content with your own. Also, the template has 

rather big margins. You might want to use more of the paper than they let you by default. 

You can expand the right margin about 2 inches to the right by dragging the right margin 

indicator to where you want it. This gives you the full width of the document to work in. 

Figure 16-3 shows a work in progress.

Figure 16-3.  Writing the letter
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�Printing
When you’re done typing, you may need to print the letter. Unfortunately, printing 

directly from this document to your printer is not possible. What happens when you 

select File ➤ Print is that Google Docs generates a PDF file so you can download it. The 

download dialog, as shown in Figure 16-4, lets you open the PDF in the file viewer. In this 

example, the file viewer is the one that comes with Windows 8 and Windows 10 called 

TWINUI.1

When the document viewer pops up, you can use it to print the document.

Figure 16-5 shows our example letter.

1�This stands for Tablet and WINdows User Face. (It’s a name only a programmer could love.)

Figure 16-4.  Download dialog
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Figure 16-5.  Full letter
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�Finishing the Document
You probably don’t want to call your letter Letter (the default name), so you can rename 

it by selecting File ➤ Rename, as shown in Figure 16-6.

Figure 16-6.  Renaming a file
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The name of the file is now editable, so let’s change it to Hill-1 and press Enter, as 

shown in Figure 16-7.

�Voice Typing
Google Docs has one potentially useful feature that’s not available in LibreOffice Writer. 

The “voice typing” feature uses Google Voice recognition software to do the typing for 

you…mostly. There is only drawback: it’s available only if you are using Google Chrome 

as your browser.

Figure 16-7.  Renaming the file to Hill-1
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You can download Google Chrome from http://google.com/chrome. The browser 

has a similar set of features to Firefox. To use voice typing, start Chrome and go to your 

documents at http://docs.google.com. Open your document and select Tools ➤ Voice 

Typing, as shown in Figure 16-8.

Figure 16-8.  Starting the voice typing feature
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A microphone icon appears, as shown Figure 16-9. Click this icon to turn on voice 

typing.

Figure 16-9.  Clicking the microphone icon
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Since you now have voice typing running, you might as well use it to write 

something. Figure 16-10 shows our result.

We learned several things from dictating this paragraph. First, if you stumble over 

your words, voice typing will faithfully record your stumbles. Second, it transcribes the 

words, not the implied punctuation. You actually have to say things like “period” and 

“comma.”

Also, to get a new paragraph, you say “enter” and not “paragraph” or “return.”

Figure 16-10.  The result of voice typing
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�Sharing Documents
As you’ll learn more about in Chapter 17, you can share documents with anyone who has 

an e-mail account and a browser. To share a document, select File ➤ Share, as shown in 

Figure 16-11.

Figure 16-11.  Selecting the Share menu item
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This brings up the “Share with others” dialog, as shown in Figure 16-12. For simple 

sharing, just enter the e-mail addresses of anyone with whom you want to share the 

document.

When you click Send, Google will send that person an e-mail with a link to your 

document and give the person permission to perform edits on it. Figure 16-13 shows a 

typical e-mail.

Figure 16-12.  Sharing with others
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When the person you shared the document with clicks this link, the document will 

open in Google Docs allowing the person to edit it. You’ve still got the document in 

your Google Drive, so any changes the person makes will show up in your version of the 

document. This is useful for collaboration where one person writes the document and 

another corrects it.

Lack of Advanced Features G oogle Docs is a good program for writing simple 
documents. However, it does not have several features that you need for more 
complex documents such as references, a table of contents, indices, and similar 
features.

Its advantages are that you can access your documents anywhere there is an 
Internet connection and that multiple people can work on the same document at 
once.

Figure 16-13.  E-mail link

Chapter 16  Using Google Docs



373

�Summary
Google has tried to create a cloud-based system to replace Microsoft Office. Google Docs 

is a nice start, but it has a long way to go. Although it’s good for basic documents, it lacks 

sufficient features to be used for professional work with complex documentation needs.

As for which word processor tool is best, that depends on your circumstances. 

Google Docs is useful when capturing the initial information. For example, you can use 

it on your phone to dictate text and then download that text to your local computer for 

editing with LibreOffice Writer.

Students often use Google Docs exclusively because their schools mandate it. They 

like the collaboration tools it provides.

So, as to which is the best tool, it all depends on what features you value. There are 

lots of choices out there, and many of them are free.

Chapter 16  Using Google Docs
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CHAPTER 17

Using Google Backup  
and Sync
Originally Google Drive was just a cloud-based disk drive. It was just like a regular disk 

drive, except it stored documents in the cloud to make them available to any system with 

an Internet connection. This also meant that if you didn’t have an Internet connection, 

you didn’t have access to your data.

Later Google Drive became Google Backup and Sync. This system lets you have 

a directory that is replicated across all of your computers and the cloud. This means 

you have access to your files even if there is no Internet. If you make changes to a local 

copy, Google will copy it to the cloud version of Google Drive and then to all your other 

computers connected to the Internet. In other words, it looks to you like you have single 

shared directory across all your computers.

The advantage of this is that you don’t have to keep moving files from system to 

system to work on them. In our case, this book is stored on a USB drive that moves 

from place to place. If we had used Google Backup and Sync, we could have all these 

files stored on all our computers and not worry about forgetting the USB drive when 

changing computers.

Google Backup and Sync also has the ability to back up your important files. (You 

select the directory that’s important.)

Warning  Google Backup and Sync is a free service, and there is nothing you 
can do if Google decides to turn it off tomorrow. Do not keep your only copy of 
important data on Google servers.
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In this chapter, you will learn the following:

•	 How to install Google Backup and Sync

•	 How to share files using a Google Drive folder

•	 How to back up important folders

•	 How to share files

�Installing Google Backup and Sync
Google Drive has a web interface as well as an application that integrates Google Drive 

with the Windows File Explorer. Start by going to http://drive.google.com and signing 

in. The initial screen will look different if you already have a Gmail account and have 

used it in this browser. But after a few prompts, you’ll arrive at the screen shown in 

Figure 17-1.

Figure 17-1.  Getting the application
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Now let’s get the Google Drive application by selecting Settings ➤ Download Backup 

and Sync for Windows.
The download page will appear, as shown in Figure 17-2. Click the Download button 

in the Personal Use section.

Figure 17-2.  Download page
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Next you have to agree to the terms of service; once you’ve done that, the download 

will begin. After downloading the program, start it by clicking Get Started, as shown in 

Figure 17-3.

Figure 17-3.  Initial installation window
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If you’re not already signed in to Google, you need to do so now, as shown in 

Figure 17-4.

Figure 17-4.  Signing in to Google 
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The next screen, as shown in Figure 17-5, tells you what the screen after that does, so 

click Got It to continue.

Figure 17-5.  Clicking Got It
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The next screen lets you select the folders to be automatically backed up, as shown in 

Figure 17-6. By default these include Pictures, Documents, and Desktop. When backed 

up, these files will occupy their own folder on the Google Drive web site and are not 

downloaded to your other computers.

This is different from the Google Drive folder on your computer that will be 

synchronized with the Google Drive cloud storage and all your other computers. (That is 

done automatically and does not need to be configured.)

Also, note that we’ve named the computer My Laptop. That name will be useful 

when trying to find the backup on the Google Drive web site.

If you have folders with really important files, add them here. When you are done, 

click Next.

Another information screen appears telling you what’s about to come. Click Got It.

Figure 17-6.  Selecting a folder
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Finally, you get to the Drive part of Google Backup and Sync, as shown in Figure 17-7. 

This lets you synchronize the cloud version of Google Drive with your local Google Drive 

folder. Since this is the first time you’ve set this up, there is not much to sync, but click 

Start anyway.

Figure 17-7.  Synchronization process
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The confirmation window appears, as shown in Figure 17-8. Click Continue to start 

the process.

When you’re done, close the final window. Now start the Windows File Explorer. 

You’ll notice that you have a new item in the “Quick access” section named Google 

Drive, as shown in Figure 17-9. Select it, and you’ll see the files on your drive.

Figure 17-8.  Confirmation window

Figure 17-9.  File Explorer with Google Drive
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Now you can treat this as pretty much a normal drive, although one that’s a little 

slow. In particular, as shown in Figure 17-10, you can drag files from one File Explorer 

window to another to copy files.

Drag and drop to add files (just like any other folder only slower).

Figure 17-10.  Using drag and drop to copy a file
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After a few seconds, the file will appear in your web view as well, as shown in 

Figure 17-11.

Figure 17-11.  Web interface to Google Drive

Chapter 17  Using Google Backup and Sync 



386

�Sharing Files
Say we want to share this chapter of the book with our editors. So, we need to tell Google 

Drive that we want to share it with them. We start with the steps in Figure 17-12, which 

consist of right-clicking the document and selecting Share.

Figure 17-12.  Sharing a document
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The “Share with others” window appears, as shown in Figure 17-13.

There are two ways of sharing a file. The first gives Google a list of people to share 

it with. That works only if they all have Google accounts. The second is to create a 

shareable link. This is less secure because anyone with the link can view the document. 

Let’s use this method here, so click “Get shareable link.”

The magic link is copied to the clipboard, and sharing is enabled. You can now 

e-mail this to other people so they can view the document.

Figure 17-13.  Sharing with others

Chapter 17  Using Google Backup and Sync 



388

�Using the Backup and Sync Controls
You may notice a small icon in the lower right of your screen. Figure 17-14 shows where 

this is located.

Clicking this icon brings up the Backup and Sync control panel, which shows you the 

progress of any synchronization that is being done. It also contains icons that will take 

you directly to your Google Drive (local copy) and Google Drive (web copy).

�Summary
Google has tried to make Google Drive as simple and as easy to use as a regular disk 

drive. There are a few more advanced features to explore such as version control and 

document conversion, but for the most part Google Drive is easy to get started with.

Figure 17-14.  Opening the Backup and Sync controls
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CHAPTER 18

Using Google Sheets
Google Sheets is an online spreadsheet program. Its main advantage is that it is on the 

Internet. That means you can access it from anywhere. There are even phone apps that 

let you access it through your smartphone, which makes it useful for storing numbers as 

they are generated.

In this chapter, you will learn the basics of Google Sheets, including the following:

•	 Getting started

•	 Creating a basic cost estimation spreadsheet

•	 Creating titles

•	 Creating a chart

�Getting Started with Google Sheets
To get to Google Sheets, go to http://sheets.google.com. Android and Apple users can 

download it from their phone’s online store. After signing on, you’ll see a startup screen 

similar to Figure 18-1.

http://sheets.google.com/


390

�Creating a Spreadsheet
As you know from previous chapter examples, the Working Farm Museum needs to 

recover from a school visit. Let’s create a basic worksheet to see how much money this is 

going to cost Farmer Brown.

Figure 18-1.  Google Sheets startup screen
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Google Sheets comes with a rich set of templates. You will use the simplest for this 

example, the Blank template. Clicking Blank takes you to the initial spreadsheet in 

Figure 18-2.

Figure 18-2.  Initial spreadsheet
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�Creating Titles
You want to create a nice title for your spreadsheet, one that spans multiple columns. So, 

you need to merge cells A1 through D1. Start by clicking A1 and then dragging the cursor 

to D1, as shown in Figure 18-3.

Figure 18-3.  Selecting four cells
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Now let’s select Format ➤ Merge Cells ➤ Merge all, as shown in Figure 18-4. The 

cells will be combined.

Figure 18-4.  Merging the cell
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You now have a four-column cell in which to type the title: Working Farm Recovery 
Costs. After entering this text, select it and click the Bold icon to make it bold. Then 

select the arrow next to the text alignment icon and select Center. Figure 18-5 shows the 

steps.

On the next line, cell B1, enter the label Labor and make it bold as well.

Figure 18-5.  Setting up the title
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Starting with C1, let’s add the headings Task, Hours, Rate, and Cost. Since the Task 

column is going to be a bit longer than the others, you can make it wider by dragging the 

bar between the A and B columns to the right. Figure 18-6 details these steps.

Now let’s put in the first task. The data for the cells is as follows:

A4: Enter Securing existing site.

B4: Enter 20.

C4: Enter 15.00.

D4: Enter =B4*C4.

Figure 18-6.  Adding the headings
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Figure 18-7 shows the results.

Figure 18-7.  Entering the first task
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You’ll notice that you don’t get a rate of $15.00; you get a rate of 15. You need to tell 

Google Sheets that you are dealing with money, so select column C by clicking it and 

selecting Format ➤ Number ➤ Currency. Figure 18-8 shows this process, but you’ll have 

to trust us when we tell you that column C is highlighted because the menu covers it up.

Figure 18-8.  Formatting the columns
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Do the same for column D. Figure 18-9 shows the result of the formatting. We’ve also 

filled in a few more tasks in the figure. Remember, the contents of D5 should be =B5*C5, 

and D6 should be =B6*C6.

You are now positioned on cell D7. This will contain the labor total. To generate the 

total, click the arrow next to the Sum icon and select SUM.

A “helpful” dialog appears. To tell the system what values to add up, click cell D4 and 

drag the cursor down to cell D6, as shown in Figure 18-10.

Figure 18-9.  More tasks
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Figure 18-11 shows the result after pressing Enter.

Figure 18-10.  Selecting what to add up

Figure 18-11.  Spreadsheet with sum
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Now you’ll add a couple more sections for Buildings and Services, as shown in 

Figure 18-12.

During this process we’ve changed the format of a few cells. This was accomplished 

by selecting the cells and executing the command Format ➤ Number ➤ Currency.

Figure 18-12.  Spreadsheet after additional sections have been added
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Now let’s add a Summary section and compute a grand total for everything you’ve 

done so far. Figure 18-13 shows the result.

Figure 18-13.  Adding a Summary section
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Since every good spreadsheet must have a chart, let’s add one. Click in cell A26 to 

select Labor and then Shift+click in cell B28 to select a 2×3 square of values. Figure 18-14 

shows the result.

�Creating a Chart
Let’s now create the chart by selecting Insert ➤ Chart, as shown in Figure 18-15.

Figure 18-14.  Chart data selected
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A chart appears right over most of the important data, and a chart editor dialog 

appears. Figure 18-16 shows the mess.

Figure 18-15.  Inserting a chart

Figure 18-16.  Chart inserted
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Close the chart editor by clicking the X button. Now use the handles of the chart to 

drag the chart into a nice location below the data. The result should look something like 

Figure 18-17.

Now you can rename the spreadsheet (File ➤ Rename) to something decent, such as 

Farm Recovery, and then print or share it as needed.

�Summary
Google Sheets is a good, basic spreadsheet program. It doesn’t have as many features 

as LibreOffice Calc or Microsoft Excel, but it does have all the features that a simple 

spreadsheet needs. You might find it ideal when you need to access data from your 

phone. The nice thing is that you have a choice; in addition, both Google Sheets and 

LibreOffice Calc are free.

Figure 18-17.  Final spreadsheet
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CHAPTER 19

Playing Games
This book would be incomplete without talking about some games. There are lots of 

open source games that are fun and free to download. Table 19-1 lists some of the best 

ones, and they are discussed further in the following sections.

Table 19-1.  Game Summary

Game Download Recommended Age Complexity Learning Curve

SuperTuxKart https://

supertuxkart.net/

Download

Young Simple Low

Xonotic www.xonotic.org Preteen and teens Slightly 

complex

Low

2048 https://

gabrielecirulli.

github.io/2048/

All Simple Low

Torcs http://torcs.

sourceforge.net/

index.php?artid=3&na

me=Sections&op=viewa

rticle

Teens and young 

adults

Slightly 

complex

Medium

FlightGear www.flightgear.org/

download/main-

program/

Adult Complex High

Neverball http://neverball.

org/download.php

Kids and teens Simple Low

(continued)
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�Who Is Tux, and Why Is He Everywhere?
Before starting, we need to explain why a lot of the games have Tux in their names. Tux, 

pictured in Figure 19-1, is a penguin who is the mascot of Linux. Linux is a popular open 

source operating system, so many game designers decide to honor this penguin by 

having him be a main character in their work. So, if you see Tux, the game is probably 

open source.

Figure 19-1.  Tux

Game Download Recommended Age Complexity Learning Curve

Teeworlds www.teeworlds.

com/?page=downloads

Kids and young Adults Simple Low

0 A.D. https://play0ad.com/

download/

Young adults and 

adults

Slightly 

complex

Medium

OpenTTD https://www.openttd.

org/en/download-

stable

Adults Slightly 

complex

High

SuperTux http://supertux.

github.io/download.

html

Kids and teens Simple Low

Table 19-1.  (continued)
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�SuperTuxKart
SuperTuxKart is a racing game a lot like Mario Kart, except everyone is an animal, and 

the main character is a penguin. In Figure 19-2, you can see a typical game screen. To 

download and set up the game, go to https://supertuxkart.net/Download.

The goal of the game is to race against the other players and win the race. There are 

three different modes: story mode, single/multiplayer, and login.

Story mode plays some videos before and after races. This gives the game a story. 

The main plot is that, Tuc, the King of Karts, has kidnapped the Great Wise One, the 

leader of a village that Tux lives in. Tuc says that if Tux can beat him in racing, then he 

will release the Great Wise One. If Tux loses, then the Great Wise One will be served for 

dinner at Tuc’s castle.

Single and multiplayer modes are the same thing, except there are no videos. You 

can play with up to four different players and can play with joysticks or the keyboard.

Login is where you connect to the Internet and race against other people in real time.

Figure 19-2.  SuperTuxKart
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Overall, it is a decent game. The quality of animations is lacking, but you can still  

tell what is going on. We recommend this to children or adults but not for teenagers,  

who would like more detailed animations like in Torcs (described later). Overall, it is a 

well-developed game.

�Xonotic
Xonotic is a first-person shooting game. You run around with a gun and shoot at your 

enemies, as shown in Figure 19-3. This game is designed for the older kids, mainly teens, 

and uses a lot of graphics, so it may slow down your computer if you are using a laptop. 

You can download it from www.xonotic.org.

There are two different modes, single player and multiplayer. In single player mode, 

one person is connected through the computer to other players on the Internet. In 

multiplayer mode, more than one person can be connected through a single computer. 

The controls are fairly simple and self-explanatory, and you can figure out how the 

Figure 19-3.  Running and shooting
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games work within seconds. There are many different terrains so you will never get 

bored with the layout. There are also a variety of guns that have their own distinct power. 

For example, one gun shoots fire and blows up your opponent. Another gun shoots 

six electric balls, which spread out so you can get your opponent even when they are 

moving.

Overall, it is a good game if you don’t get motion sickness.

�2048
2048 is a simple yet addicting game. The goal of the game is to combine similar blocks 

next to each other into one block containing the number 2048. You can move the blocks 

up, down, left, and right. Each block has a number on it. For example, a “2” block can 

merge with another “2” block, which creates a “4” block. This game is good for phones, 

as shown in Figure 19-4. You can play it at https://gabrielecirulli.github.io/2048/, 

or you can download it from any app store for free.

We recommend this game to anyone. It is an easy game to play and can be rewarding 

when you finally get the tiles to display 2048.

Figure 19-4.  2048
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�Torcs
Torcs is another racing simulator, like SuperTuxKart, but with more detailed graphics 

designed for more mature players. Its home page is at http://torcs.sourceforge.

You control your car with the arrow keys, and you can choose from a variety of car 

models and tracks, as shown in Figure 19-5. Torcs stands for Texas Off-Road Champion 

Series. This game has been used as a research platform for many things car related, such 

as the use of AI programs in cars.

This game is a lot of fun for those who feel like they’re too old for SuperTuxKart and 

Mario Kart and want something a bit more challenging.

�FlightGear
FlightGear is a flying simulator, where you fly your own plane. You can download it at 

www.flightgear.org/download/main-program/. It is a detailed game, where you start 

out in the cockpit of the plane, such as the one shown in Figure 19-6, and use controls 

that are similar to those in a real plane.

Figure 19-5.  The race track
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You can also create your own flying environment, as well as choose the type of plane 

you want to fly. Scenery and planes have to be downloaded separately. The game comes 

with a long manual on how to fly the plane, so if you want to play this game properly, 

you’ll need commitment. There are many fun and different types of planes; for example, 

you could fly a space shuttle. It is a rocket ship that you get to drive into orbit, but it lands 

like a brick, which is really challenging.

This game requires a lot of CPU power. When we ran it on a laptop, the system became 

very “laggy.” We suggest downloading this on a stronger computer with a good CPU.

This game is good for young wanna-be pilots or if you are looking into flying and 

want to see how a plane is operated. Overall, it is a more complicated and technical 

game but can be fun once you learn how to play it.

�Neverball
Neverball is a game a where you guide a ball through crazy courses and get it to the 

target. You can install it at http://neverball.org/download.php.

The player gets to customize their ball and choose from a variety of levels. There are 

many fun and different levels of games. Some courses look like the inside of a ping-pong 

machine, shown in Figure 19-7, while others have portals that teleport the ball. Others 

are like a puzzle, where you have to figure it out before you can win.

Figure 19-6.  The cockpit
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The goal is simple: try to get the ball to the target. For the controls, you just use the 

keyboard arrows to tilt the screen in the direction you want the ball to go. You can also 

collect coins, which are good for the store, where you can buy different skins for your ball.

Overall, this game has great graphics and is fun for all ages. It comes with seemingly 

endless levels, so this game will keep you occupied for a long time.

�Teeworlds
Teeworlds is a simple, cartoon, multiplayer shooting game. You can find it at https://

www.teeworlds.com/?page=downloads. The main goal of the game is to try to be the last 

one standing, so you basically shoot everyone else until they are all dead.

It has a two-dimensional course that you can explore. There are a variety of different 

guns to use, along with different terrains and games. One game you can play is called 

capture the flag, shown in Figure 19-8, where there are two teams. Your team’s mission 

is to try to take the other team’s flag while protecting your flag from the other team. 

Different terrains can consist of the desert, grass, jungle, snow, and much more.

Figure 19-7.  Ping-pong machine in Neverball
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This game is great for anyone who loves shooting games but hates the motion sickness 

that most 3D shooting games give you. It is good if you want a simple, friendly game.

�0 A.D.
0 A.D. is a game based on the year 0 A.D., where you build civilizations and practice 

strategy in ancient warfare. You can get it at https://play0ad.com/download/.

In the game, you have a certain territory where you can construct your buildings. 

Figure 19-9 shows a typical layout. You can expand your territory by leveling up or by 

building next to the border. Each type of building supports different things. There are the 

village buildings to sustain the people. Housing supports population. A mill is used to 

collect wood, metal, and stone for building. Farmstead and corrals are for growing and 

breeding animals for food. Docks are to build ships for fish, trade, and warfare.

Figure 19-8.  Playing capture the flag
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There are also a variety of military buildings to protect the people. Barracks are 

where citizens train and become soldiers. A temple trains healers, who heal the soldiers 

during battle. A defense tower shoots at enemies close by. You can also build walls and 

fortresses for defense.

This game is lots of fun for those who love strategy games and building their own 

civilizations.

�OpenTTD
OpenTTD is a strategy business simulator where you make money by transporting 

customers using different routes and different modes of transportation, as shown in 

Figure 19-10. You can download it at https://www.openttd.org/en/download-stable.

Figure 19-9.  A normal day 2,000 years ago
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Figure 19-10.  A day at work

The main goal of this game is to get as much money as you can by starting a 

transportation business. There are many factors needed to win this game, such as where 

to put the routes that your vehicle will travel and how much to charge for one trip. The 

game comes with a long manual that tells you how to place different modes of transport. 

There are four modes you can choose from: road, railroad, ship, and airplane. You can 

also earn extra money by using your business for a shipping and postal service.

Overall, this game is for those who love to strategize and build their own businesses. 

We recommend this to someone who has a lot of patience because it takes a long time to 

grow your business.

�SuperTux
SuperTux is a lot like Super Smash Bros., except the main character is a penguin. You 

run and jump, collect power-ups, and defeat the evil snowballs. You can download the 

software at http://supertux.github.io/download.html. The main goal of the game is 

to guide Tux through the level and get to the end.

If you took Super Mario Bros. and turned it into a second graphic penguin game, 

then you would have SuperTux. Everything is identical, all the way down to the powers 

and the enemies.
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There is unique feature that you don’t have in most proprietary games, that is, debug 

mode. This mode allows you to “debug” the program by giving Tux special powers, like 

being invincible. Although designed for people working on making the program better, it 

doesn’t stop people from using it to “cheat” and reach the highest level without having to 

bother getting really good at the game.

We recommend this game to anyone who loves adventure games and wants to play 

an open source version of Super Mario Bros.

�Summary
Supposedly there aren’t a lot of open source games available. That may be true, but 

there are enough fun ones out there to keep anyone entertained. Many of the simulation 

games are made by people fanatical on making the most realistic game out there. That’s 

why you have a game like FlightGear, which gives you the ability to fly a Wright biplane 

and a space shuttle.
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create, 262–263
new account dialog, 263–264
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select check format, 262
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top-level screen, 359
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setting up, 394
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rose drawing (see Rose drawing)
zoom drawing page, 187–188
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headings entered, 91
initial balance, 92–93
initial Calc screen, 90
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converting video files
adding all files, 309
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conversion process, 306
default path for  

output, 306
encoding in progress, 313
HandBrake program, 303
job queue, 310
MOD file, 303
Preferences dialog, 304–305
Progress dialog, 308
starting queue, 312
subtitle warning, 310

importing media
Export Video dialog, 326
first video on track, 320
good and bad stuff, 322–323
initial screen, 314
opening video files, 315
Preview window, 318
removing excess tracks, 317
removing file  

from project, 319
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zoom and play, 321
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OpenTTD, 414–415
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Center icon, 35
color selector menu, 34

creating “Where” section
Align Right settings, 42
dragging the margin, 42
final text, 43
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anchor point controls, 46
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wrapping through, 48
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SuperTux, 415
SuperTuxKart, 407
Teeworlds, 412–413
Torcs, 410
Tux, 406
Xonotic, 408–409

Presentations, LibreOffice Impress
animation
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after first click, 131
first paragraph, 129
panel, 128–129
result of second click, 131
slide show, 130
third click and full joke, 131–132
title of slide, 130
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font size, 122
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arrow icon, 122–123
final title page, 125
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Position and Size menu item, 123
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title with arrow, 124–125
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Properties panel, 122
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description, 65
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settings dialog, 77
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settings dialog, 77
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cute kitten, 82–83
Drawing toolbar, 83–84
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Heading 1 style, 67
quotes

creating, Quote Who style, 72
More Styles option, 70
new style, 71
paragraph and font, adjusting, 71
Properties icon, 70
style guide, 70
style modification, 72–74

structured numbers, 67
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tables
adjusting, column size, 81
enter data, press tab, 79
entry, 79
inserting, 78
nice, 81–82
rows, 80
selecting, 80

title, 65–66
Rose drawing

add color
duplicating bowl, 210–211
lowering object, 214–215
path effects, 211
red fill, 214
remove effects, 212–213

add detail line, 216–217
add stem, 217–219
cleaned-up rose top, 203
filling spiral with black, 205
flattened circle, 205–206
form bowl, 209
line wider, 207–208
set width pattern, 204–205
shapes

click circle/ellipse tool, 189–190
create spiral, 192–193
fill and stroke panel, 190
stroke to solid black, 191–192
turn off fill, 191

stretch bowl, 209–210
tweaking shapes

copying skinny ellipse, 198–199
path effects, 200–202
path menu item, 197
select all menu item, 196

select spiral, 199–200
skinny ellipse, 194–195

S
SuperTux, 415–416
SuperTuxKart, 407–408

T, U
Tab and bookmark synchronization, 

Firefox
Manual Sync icon, 12–13
set up an account

account creation information 
request screen, 8

confirmation, 11
e-mail verification, 11
Gmail account, 9
save settings, 8
sign in, 6
signing in to sync, 6

tabs from other computer, 13–14
Teeworlds, 412–413
The cockpit, 411
Torcs, 410
Tux, 406

V
Video clips, DVDStyler

add video to menu, 338–339
burn dialog, 342–343
burn video, 341–342
editing window, 337–338
generating DVD dialog, 343
save project, 340–341
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select template, 336–337
success message, 344
warning dialog, 339
welcome dialog, 335–336

Video DownloadHelper
ConverterHelper.exe, 25
converter request, 24
download page, 25
home page, 22
installing, 26
save file dialog, 24

searching, 22
YouTube, 22–23

W
Web browsing, see Firefox
Wipe effect, 133

X, Y, Z
Xonotic, 408–409
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