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Introduction

When Visual Basic first appeared, it revolutionized Windows programming. By handling many of the
tedious details of processing Windows events, it enabled programmers to focus on application details
instead of Windows programming trivia.

Unfortunately, early versions of Visual Basic had a few drawbacks. Protection from the underlying
Windows details came at the price of reduced flexibility. Using Visual Basic meant you didn’t need to
mess with the sticky details of Windows event loops, but it also made working directly with those
events more difficult when you really wanted to. Advanced programmers could still pry off the cover
and work at this lower level, but this was somewhat dangerous. If your code didn’t handle all the details
correctly, it could crash the program and possibly Windows itself.

Visual Basic also followed a path different from that taken by other Windows programming languages
such as C++. It provided a more productive development environment and a generally more intuitive
syntax. Its syntax for object-oriented development was more restrictive, however. A developer could still
build safe, reliable, extensible applications, but it took some experience and care.

Visual Studio .NET addressed many of these shortcomings. It merged the Visual Basic and C++ develop-
ment environments into an even more powerful tool. It added the C# language (pronounced “C-sharp”)
and gave all three a common underlying run-time language called Common Language Runtime (CLR).
Visual Basic .NET incorporated changes to bring the language more into line with CLR and the other
languages. It included more structured error handling, new syntax for declaring and initializing vari-
ables, overloaded functions and subroutines, and a more powerful model for creating classes that
include true inheritance.

Visual Basic 2005 adds new features that make Visual Basic a more powerful language than ever. It
includes new language features such as unsigned data types, operator overloading, and short-circuit
logical operators; object-oriented enhancements such as more flexible property procedure accessibility,
generics, and custom events; and coding improvements such as Extensible Markup Language (XML)
comments, better IntelliSense, and code snippets.

Visual Basic 2005 is the language’s second major release. Most of the obvious bugs in the first release
(surprisingly few for such a major reshaping of the language) have been ironed out, so there has never
been a better time to learn the language. The first release has proven stable and the current release brings
new capabilities to Visual Basic programmers. Developers waiting to see what would become of Visual
Basic .NET have their answer: it is here to stay.

Should You Use Visual Basic .NET?

A Visual Basic programmer’s joke asks, “What’s the difference between Visual Basic .NET and C#?
About three months!” The implication is that Visual Basic .NET syntax is easier to understand, and
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building applications with it is faster. Similarly, C# programmers have their jokes about Visual Basic
.NET, implying that C# is more powerful.

In fact, Visual Basic .NET is not a whole lot easier to use than C#, and C# is not significantly more power-
ful. The basic form of the two languages is very similar. Aside from a few stylistic differences (Visual
Basic is line-oriented; C# uses lots of braces and semicolons), the languages are comparable. Both use the
Visual Studio development environment, both provide access to the NET Framework of support classes
and tools, and both provide similar syntax for performing basic programming tasks.

In fact, the languages are so similar that many of Microsoft’s Web pages lump the two together. For exam-
ple, the page http://msdn.microsoft.com/library/en-us/vbcon/html/vboriWhatsNewVB70.asp
is titled “What’s New in Visual Basic and Visual C#.”

The main difference between these languages is one of style. If you have experience with previous ver-
sions of Visual Basic, you will probably find Visual Basic .NET easier to get used to. If you have experi-
ence with C++ or Java, you will probably find C# (or Visual C++ or Visual J#) easy to learn.

Visual Basic does have some ties with other Microsoft products. For example, ASP uses Visual Basic to
create interactive Web pages. Microsoft Office applications (Word, Excel, PowerPoint, and so forth) and
many third-party tools use Visual Basic for Applications (VBA) as a macro programming language. If
you know Visual Basic, you have a head start in using these other languages. Active Server Pages (ASP)
and Visual Basic for Application (VBA) are based on pre-.NET versions of Visual Basic, so you won't
instantly know how to use them, but you’ll have a big advantage if you need to learn ASP or VBA.

If you are new to programming, either Visual Basic .NET or C# is a good choice. I think Visual Basic
.NET may be a little easier to learn, but I may be slightly biased because I've been using Visual Basic
lately. You won't be making a big mistake either way, and you can easily switch later. Of course, if you
have already bought this book, you should stick with Visual Basic to get the most benefit.

Who Should Read This Book

Vi

This book is intended for programmers of all levels. It describes the Visual Basic .NET language from
scratch, so you don’t need experience with previous versions of the language. The book also covers
many intermediate and advanced topics. It covers topics in enough depth that even experienced devel-
opers will discover new tips, tricks, and language details. After you have mastered the language, you
may still find useful tidbits throughout the book, and the reference appendices will help you look up
easily forgotten details.

The chapters move quickly through the more introductory material. If you have never programmed
before and are intimidated by computers, then you might want to read a more introductory book first. If
you are a beginner whos not afraid of the computer, then you should have few problems learning Visual
Basic .NET from this book.

If you have programmed in any other language, then fundamentals such as variable declarations, data
types, and arrays should be familiar to you, so you should have no problem with this book. The index
and reference appendices should be particularly useful in helping you translate from the languages you
already know into the corresponding Visual Basic syntax.
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How This Book Is Organized

You could divide the chapters in this book into four parts plus appendices. The chapters in each part are
described here. If you are an experienced programmer, you can use these descriptions to decide which
chapters to skim and which to read in detail.

Part I: Getting Started

The chapters in this part of the book explain the basics of Visual Basic .NET programming. They describe
the development environment, basic program syntax, and how to interact with standard controls. More
advanced topics include how to build custom controls and how to implement drag and drop.

Chapter 1, “IDE,” describes the integrated development environment (IDE). It explains the IDE’s win-
dows and how to customize the IDE. It also explains tools that provide help while you're programming
such features as the Object Browser and the code window’s Intellisense.

Chapter 2, “Controls in General,” describes general control concepts. It explains how to add controls to a
form, how to read and change a control’s properties at design time and at run time, and how to use
some of the more complicated control properties (such as Dock and Anchor). This chapter shows how to
catch and respond to events, and how to change event handlers in code.

Chapter 3, “Program and Module Structure,” analyzes a simple Visual Basic program and explains the
structure created by Visual Studio. It describes the program’s code regions and comments, and tells how
you can use similar techniques to make your code more readable and manageable.

Chapter 4, “Data Types, Variables, and Constants,” explains the standard data types provided by Visual
Basic. It shows how to declare and initialize variables and constants, and explains variable scope. It dis-
cusses value and reference types, passing parameters by value or reference, and creating parameter vari-
ables on the fly. It also explains how to create arrays, enumerated types, and structures.

Chapter 5, “Operators,” describes the operators a program uses to perform calculations. These include
mathematical operators (+, *, \), string operators (&), and Boolean operators (And, Or). The chapter
explains operator precedence and type conversion issues that arise when an expression combines more
than one type of operator (for example, arithmetic and Boolean).

Chapter 6, “Subroutines and Functions,” explains how you can use subroutines and functions to break a
program into manageable pieces. It describes routine overloading and scope.

Chapter 7, “Program Control Statements,” describes the statements that a Visual Basic program uses to
control code execution. These include decision statements (If Then Else, Select Case, IIF, Choose)
and looping statements (For Next, For Each, Do While, While Do, Repeat Until).

Chapter 8, “Error Handling,” explains error handling and debugging techniques. It describes the Try
Catch structured error handler in addition to the older On Error statement inherited from earlier ver-
sions of Visual Basic. It discusses typical actions a program might take when it catches an error. It also
describes techniques for preventing errors and making errors more obvious when they do occur.

Chapter 9, “Introduction to Windows Forms Controls,” explains the Visual Basic’s standard controls that
you can use on Windows forms. It describes the most useful properties, methods, and events provided

vii
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by these controls, and it gives examples showing how to use them. It also describes cases where these
controls rely on each other. For example, several controls such as the ToolBar obtain images from an
associated ImageList control.

Chapter 10, “Forms,” explains typical uses of forms. It tells how to build partially transparent forms for
use as splash, login, and About forms. It describes form cursors and icons, how to override WndProc to
intercept a form’s Windows messages, how to make a Multiple Document Interface (MDI) application,
and how to implement a Most Recently Used (MRU) file list. It does not cover all of the Form object’s
properties, methods, and events in detail; those are described in Appendix H, “Form Objects.”

Chapter 11, “Database Controls and Objects,” explains how to use Visual Basic’s standard database con-
trols. These include database connection components that handle connections to a database, Dataset
components that hold data within an application, and data adapter controls that move data between
data connections and DataSets.

Chapter 12, “Custom Controls,” explains how to build your own customized controls that you can then
use in other applications. It covers the three main methods for creating a custom control: derivation,
composition, and building from scratch. This chapter also provides several examples that you can use as
a starting point for controls of your own.

Chapter 13, “Drag and Drop, and the Clipboard,” explains how a Visual Basic program can support
drag-and-drop operations. It tells how your program can start a drag to another application, how to
respond to drag operations started by another application, and how to receive a drop from another
application. This chapter also explains how a program can copy data to and from the clipboard. Using
the clipboard is similar to certain types of drag-and-drop operations, so these topics fit naturally in
one chapter.

Part II: Object-Oriented Programming

viii

The chapters in this part of the book explain fundamental concepts in object-oriented programming
(OOP) with Visual Basic. It also describes some of the more important classes and objects that you can
use when building an application.

Chapter 14, “OOP Concepts,” explains the fundamental ideas behind object-oriented programming. It
describes the three main features of OOP: encapsulation, polymorphism, and inheritance. It explains the
benefits of these features and tells how you can take advantage of them in Visual Basic.

Chapter 15, “Classes and Structures,” explains how to declare and use classes and structures. It explains
what classes and structures are, and it describes their differences. It shows the basic declaration syntax
and tells how to create instances of classes and structures. It also explains some of the trickier class
issues (such as private class scope, declaring events, and shared variables and methods).

Chapter 16, “Namespaces,” explains namespaces. It tells how Visual Studio uses namespaces to catego-
rize code and to prevent name collisions. It describes a project’s root namespace, tells how Visual Basic
uses namespaces to resolve names (such as function and class names), and tells how you can add names-
paces to an application yourself.

Chapter 17, “Collection Classes,” explains classes included in Visual Studio that you can use to hold
groups of objects. It describes the various collection, dictionary, queue, and stack classes; tells how to
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make strongly typed versions of those classes; and gives some guidance on deciding which class to use
under different circumstances.

Chapter 18, “Generics,” explains templates that you can use to build new classes designed to work with
specific data types. For example, you can build a generic binary tree and then later use it to build classes
to represent binary trees of customer orders, employees, or work items.

Part Ill: Graphics

The chapters in this part of the book describe graphics in Visual Basic .NET. They explain the Graphics

Device Interface+ (GDI+) routines that programs use to draw images in Visual Basic. They explain how
to draw lines and text; how to draw and fill circles and other shapes; and how to load, manipulate, and
save bitmap images. This part also explains how to generate printed output and how to send reports to
the screen or to the printer.

Chapter 19, “Drawing Basics,” explains the fundamentals of drawing graphics in Visual Basic .NET. It
describes the graphics namespaces and the classes they contain. It describes the most important of these
classes, Graphics, in detail. It also describes the Paint event handler and other events that a program
should use to keep its graphics up to date.

Chapter 20, “Brushes, Pens, and Paths,” explains the most important graphics classes after Graphics:
pen and Brush. It tells how you can use Pens to draw solid lines, dashed lines, lines with custom

dash patterns, and lines with custom lengthwise stripe patterns. It tells how to use Brushes to fill areas
with colors, hatch patterns, linear color gradients, color gradients that follow a path, and tiled images.
This chapter also describes the GraphicsPath class, which represents a series of lines, shapes, curves,
and text.

Chapter 21, “Text,” explains how to draw strings of text. It shows how to create different kinds of fonts,
determine exactly how big text will be when drawn in a particular font, and use GDI+ functions to make
positioning text simple. It shows how to use a StringFormat object to determine how text is aligned,
wrapped, and trimmed, and how to read and define tab stops.

Chapter 22, “Image Processing,” explains how to load, modify, and save image files. It shows how to
read and write the pixels in an image, and how to save the result in different file formats such as

BMP GIF, and JPEG. It tells how to use images to provide auto-redraw features, and how to manipulate
an image pixel by pixel, both using a Bitmap’s GetPixel and SetPixel methods and using “unsafe”
access techniques that make pixel manipulation much faster than is possible with normal GDI+ methods.

Chapter 23, “Printing,” explains different ways that a program can send output to the printer. It shows
how you can use the PrintDocument object to generate printout data. You can then use the
PrintDocument to print the data immediately, use a PrintDialog control to let the user select the
printer and set its characteristics, or use a PrintPreviewDialog control to let the user preview the
results before printing.

Chapter 24, “Reporting,” provides an introduction to Crystal Reports, a tool that makes generating
reports in Visual Basic relatively easy. The chapter explains the basics of Crystal Reports and steps
through an example that builds a simple report.
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Part IV: Interacting with the Environment

The chapters in this part of the book explain how an application can interact with its environment. They
show how the program can save and load data in external sources (such as the System Registry, resource
files, and text files); work with the computer’s screen, keyboard, and mouse; and interact with the user
through standard dialog controls.

Chapter 25, “Configuration and Resources,” describes some of the ways that a Visual Basic program can
store configuration and resource values for use at run time. Some of the most useful of these include
environment variables, the Registry, configuration files, and resource files.

Chapter 26, “Streams,” explains the classes that a Visual Basic application can use to work with stream
data. Some of these classes are FileStream, MemoryStream, Buf feredStream, TextReader, and
TextWriter.

Chapter 27, “File-System Objects,” describes classes that let a Visual Basic application interact with the
file system. These include classes such as Directory, DirectoryInfo, File, and FileInfo that make
it easy to create, examine, move, rename, and delete directories and files.

Chapter 28, “Useful Namespaces,” describes some of the most commonly useful namespaces defined by
the NET Framework. It provides a brief overview of some of the most important System namespaces
and gives more detailed examples that demonstrate regular expressions, XML, cryptography, reflection,
threading, and Direct3D.

Appendixes

The book’s appendices provide a categorized reference of the Visual Basic .NET language. You can use
them to quickly review the syntax of a particular command, select from among several overloaded ver-
sions of a routine, or refresh your memory of what a particular class can do. The chapters earlier in the
book give more context, explaining how to perform specific tasks and why one approach might be pre-
ferred over another.

Appendix A, “Useful Control Properties, Methods, and Events,” describes properties, methods, and
events that are useful with many different kinds of controls.

Appendix B, “Variable Declarations and Data Types,” summarizes the syntax for declaring variables. It
also gives the sizes and ranges of allowed values for the fundamental data types.

Appendix C, “Operators,” summarizes the standard operators such as +, <<, OrElse, and Like. It also
gives the syntax for operator overloading.

Appendix D, “Subroutine and Function Declarations,” summarizes the syntax for subroutine, function,
and property procedure declarations.

Appendix E, “Control Statements,” summarizes statements that control program flow such as If Then,
Select Case, and looping statements.

Appendix F, “Error Handling,” summarizes both structured and “classic” error handling. It describes
some useful exception classes and gives an example showing how to build a custom exception class.
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Appendix G, “Standard Controls and Components,” describes standard components provided by Visual
Basic .NET. It explains the properties, methods, and events that I have found most useful when working
with these components.

Appendix H, “Form Objects,” describes forms. In a very real sense, forms are just another type of com-
ponent. They play such a key role in Visual Basic applications, however, that they deserve special atten-
tion in their own appendix.

Appendix I, “Classes and Structures,” summarizes the syntax for declaring classes and structures, and
defining their constructors and events.

Appendix ], “Generics,” summarizes the syntax for declaring generic classes.

Appendix K, “Graphics,” summarizes the objects used to generate graphics in Visual Basic .NET. It cov-
ers the most useful graphics namespaces.

Appendix L, “Useful Exception Classes,” lists some of the more useful exception classes defined by
Visual Basic. You may want to throw these exceptions in your own code.

Appendix M, “Date and Time Format Specifiers,” summarizes specifier characters that you can use to
format dates and times. For example, they let you display a time using a 12-hour or 24-hour clock.

Appendix N, “Other Format Specifiers,” summarizes formatting for numbers and enumerated types.

Appendix O, “The application Class,” summarizes the Application class that provides properties
and methods for controlling the current application.

Appendix P, “The My Namespace,” describes the My namespace, which provides shortcuts to useful
features scattered around other parts of the NET Framework. It provides shortcuts for working with the
application, computer hardware, application forms, resources, and the current user.

Appendix Q, “Streams,” summarizes Visual Basic’s stream classes such as Stream, FileStream,
MemoryStream, TextReader, CryptoStream, and so forth.

Appendix R, “File-System Classes,” summarizes methods that an application can use to learn about and
manipulate the file system. It explains classic Visual Basic methods such as FreeFile, WriteLine, and
ChDir, as well as newer NET Framework classes such as FileSystem, Directory, and File.

How to Use This Book

If you are an experienced Visual Basic .NET programmer, you may want to skim the language basics
covered in the first parts of the book. You may find a few new features that have appeared in Visual
Basic 2005, so you probably shouldn’t skip these chapters entirely, but most of the basic language fea-
tures are the same as in previous versions.

Intermediate programmers and those with less experience with Visual Basic .NET should take these

chapters a bit more slowly. The chapters in Part II, “Object-Oriented Programming,” cover particularly
tricky topics. Learning all the variations on inheritance and interfaces can be rather confusing.

Xi
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Beginners should spend more time on these first chapters because they set the stage for the material that
follows. It will be a lot easier for you to follow a discussion of file management or regular expressions if
you are not confused by the error-handling code that the examples take for granted.

Programming is a skill best learned by doing. You can pick up the book and read through it quickly if
you like, but the information is more likely to stick if you open the Visual Basic .NET development envi-
ronment and experiment with some programs of your own. Normally, when I read a new programming
book, I work through every example myself, modifying the code to see what happens if I try different
things not covered by the author. I experiment with new variations and pay particular attention to
errors, which are hard to cover completely in a book. It’s one thing to read about strongly typed collec-
tions; it’s another to build one yourself using data that is meaningful to you.

Learning by doing may encourage you to skip sections of the book. For example, Chapter 1 covers the
interactive development environment in detail. After you've read for a while, you may want to skip
some sections and start experimenting with the environment on your own. I encourage you to do so.
Lessons learned by doing stick better than those learned by reading. Later, when you have some experi-
ence with the development environment, you can go back and examine Chapter 1 in more detail to learn
more advanced customization techniques.

The final part of the book is a Visual Basic .NET reference. These appendices present more concise, cate-
gorized information about the language. You can use these appendices to recall the details of specific
operations. For example, you can read Chapter 9 to learn which controls are useful for different pur-
poses. Then use Appendix G to learn about specific controls” properties, methods, and events.

Throughout your work, you can also refer to the appendices to get information on specific classes, con-
trols, and syntax. For example, you can quickly find the syntax for declaring a generic class in Appendix
J. If you need more information on generics, you can find it in Chapter 18 or the online help. If you just
need to refresh your memory of the basic syntax, however, scanning Appendix J will be faster.

Necessary Equipment

Xii

To read this book and understand the examples, you will need no special equipment. To use Visual Basic
.NET and to run the examples found on the book’s Web page, you need any computer that can reason-
ably run Visual Basic .NET. That means a reasonably modern, fast computer with a lot of memory. See
the Visual Basic .NET documentation for Microsoft’s exact requirements and recommendations.

To build Visual Basic .NET programs, you will also need a copy of Visual Basic .NET. Don’t bother trying
to run the examples shown here if you have a pre- NET version of Visual Basic such as Visual Basic 6.
The changes between Visual Basic 6 and Visual Basic .NET are huge, and many Visual Basic .NET con-
cepts don’t translate well into Visual Basic 6. With some experience in C#, it would be much easier to
translate programs into that language.

Much of the Visual Basic 2005 release is compatible with Visual Basic .NET 2003 and earlier versions of
Visual Basic .NET, however, so you can make many of the examples work with earlier versions of Visual
Basic .NET. You will not be able to load the example programs downloaded from the book’s Web site,
however. You will need to copy and paste the significant portions of the code into your version of Visual
Basic .NET.
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The Book’s Web Site

On the book’s Web site, www . vb-helper.com/vb_prog_ref.htm, you can do the following:

QO  Download the examples in this book

Q  Download other Visual Basic programming examples

Q  View updates and corrections

O  Read other readers’ comments and suggestions
This book was written using beta versions of Visual Basic 2005. Microsoft often makes changes between
beta versions and the final release (the whole point of the betas is to identify areas that need fixing or

modification) and sometimes even produces patch releases shortly after the main product rollout. The
book’s Web page will include any modifications that the examples need to handle those changes.

If you have corrections or comments of your own, please send them to me at RodStephens@vb-helper.
com. [ will do my best to keep the Web site as up to date as possible.

Xiii
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This chapter describes Visual Studio’s integrated development environment (IDE). It explains the
most important windows, menus, and toolbars that make up the environment, and shows how to
customize them to suit your personal preferences. It also explains some of the tools that provide
help while you are writing Visual Basic applications.

Even if you are an experienced Visual Basic programmer, you should at least skim this material.
The IDE is extremely complex and provides hundreds (if not thousands) of commands, menus,
toolbars, windows, context menus, and other tools for editing, running, and debugging Visual
Basic projects. Even if you have used the IDE for a long time, there are sure to be some features
that you have overlooked. This chapter describes some of the most important of those features,
and you may discover something useful that you've never noticed before.

Even after you've read this chapter, you should periodically spend some time wandering through
the IDE to see what you’ve missed. Every month or so, spend a few minutes exploring the menus
and right-clicking on things to see what their context menus contain. As you become a more profi-
cient Visual Basic programmer, you will find uses for tools that you may have previously dis-
missed or failed to understand.

It is important to remember that the Visual Studio IDE is extremely customizable. You can move,
hide, or modify the menus, toolbars, and windows; create your own toolbars; dock, undock, or
rearrange the toolbars and windows; and change the behavior of the built-in text editors (change
their indentation, colors for different kinds of text, and so forth).

These capabilities let you display the features you need the most and hide those that are unneces-
sary for a particular situation. If you need to use the Properties window, you can display it. If you
want to make room for a very wide form, you can make it short and wide, and move it to the bot-
tom of the screen. If you have a collection of favorite tools and possibly some you have written
yourself, you can put them all in one convenient toolbar. Or you can have several toolbars for
working with code, forms in general, and database forms in particular.

This chapter describes the basic Visual Studio development environment as it is initially installed.
Because Visual Studio is so flexible, your development environment may not look like the one
described here. After you've moved things around a bit to suit your personal preferences, your
menus and toolbars may not contain the same commands described here, and other windows may
be in different locations or missing entirely.
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To avoid confusion, you should probably not customize the IDE’s basic menus and toolbars too much.
Removing the help commands from the Help menu and adding them to the Edit menu will only cause
confusion later. It’s less confusing to leave the menus more or less alone. Hide any toolbars you don’t
want and create new customized toolbars to suit your needs. Then you can find the original standard
toolbars if you decide you need them later. The section “Customize” later in this chapter has more to say
about rearranging the IDE’s components.

This chapter describes the Visual Studio IDE. Before you can understand how to use the IDE to manage
Visual Basic projects and solutions, however, you should know what projects and solutions are.

Projects and Solutions

A project is a group of files that produces some specific output. This output may be a compiled exe-
cutable program, a dynamic-link library (DLL) of classes for use by other projects, or a custom control
for use on other Windows forms.

A solution is a group of one or more projects that should be managed together. For example, suppose that
you are building a server application that provides access to your order database. You are also building a
client program that each of your sales representatives will use to query the server application. Because
these two projects are closely related, it might make sense to manage them in a single solution. When
you open the solution, you get instant access to all the files in both projects.

Both projects and solutions can include associated files that are useful for building the application but
that do not become part of a final compiled product. For example, a project might include the applica-
tion’s proposal and architecture documents. These are not included in the compiled code, but it is useful
to associate them with the project.

When you open the project, Visual Studio lists those documents along with the program files. If you
double-click one of these documents, Visual Studio opens the file using an appropriate application.
For example, if you double-click a file with a .doc extension, Visual Studio normally opens it with
Microsoft Word.

To associate one of these files with a project or solution, right-click the project in the Solution Explorer
(more on the Solution Explorer shortly). Select the Add command’s Add New Item entry, and use the
resulting dialog to select the file you want to add.

Often a Visual Basic solution contains a single project. If you just want to build a small executable pro-
gram, you probably don’t need to include other programming projects in the solution.

Another common scenario is to place Visual Basic code in one project and to place documentation (such
as project specifications and progress reports) in another project within the same solution. This keeps the
documentation handy whenever you are working on the application but keeps it separate enough that it
doesn’t clutter the Visual Studio windows when you want to work with the code.

While you can add any file to a project or solution, it’s not a good idea to load dozens of unrelated files.
While you may sometimes want to refer to an unrelated file while working on a project, the extra clutter
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brings additional chances for confusion. It will be less confusing to shrink the Visual Basic IDE to an icon
and open the file using an external editor such as Word or WordPad. If you won't use a file very often
with the project, don’t add it to the project.

IDE Overview

Figure 1-1 shows the IDE immediately after starting a new project. The IDE is extremely configurable, so
it may not look much like Figure 1-1 after you have rearranged things to your own liking.

If you don’t have a reason to modify the IDE’s basic arrangement, you should probably leave it alone.
Then when you read a magazine article that tells you to use the Project menu’s Add Reference com-
mand, the command will be where it should be. Using the standard IDE layout also reduces confusion
when you need to consult with another developer. It’s a lot easier to share tips about using the Format
menu if you haven’t removed that menu from the IDE.
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Figure 1-1: Initially the IDE looks more or less like this.
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The key pieces of the IDE are labeled with numbers in Figure 1-1. The following list briefly describes
each of these pieces.

Qa

(1) Menus — The menus contain standard Visual Studio commands. These generally manipu-
late the current solution and the modules it contains, although you can customize the menus as
needed. Visual Studio changes the menus, and their contents depending on the object you cur-
rently have selected. In Figure 1-1, a Form Designer (marked with the number 4) is open so the
IDE is displaying the menus for editing forms.

(2) Toolbars — Toolbars contain tools that you can use to perform frequently needed actions.
The same commands may be available in menus, but they are easier and faster to use in tool-
bars. The IDE defines several standard toolbars such as Formatting, Debug, and Image Editor.
You can also build your own custom toolbars to hold your favorite tools. Visual Studio changes
the toolbars displayed to match the object you currently have selected.

(3) Toolbox — The Toolbox contains tools appropriate for the item that you currently have
selected and for the project type that you are working on. In Figure 1-1, a Form Designer is
selected in a Windows Forms application so the Toolbox contains tools appropriate for a Form
Designer. These include Windows Forms controls and components, plus tools in the other
Toolbox tabs: Crystal Reports, Data, and Components (plus the General tab is scrolled off the
bottom of the Toolbox). You can add other customized tabs to the Toolbox to hold your favorite
controls and components. Other project types may display other tools. For example, a Web proj-
ect would display Web controls and components instead of Windows Forms components.

(4) Form Designer — A Form Designer lets you modify the graphical design of a form. Select a
control tool from the Toolbox, and click and drag to place an instance of the control on the form.
Use the Properties window (marked with the number 6) to change the new control’s properties.
In Figure 1-1, no control is selected, so the Properties window shows the form'’s properties.

(5) Solution Explorer — The Solution Explorer lets you manage the files associated with the cur-
rent solution. For example, in Figure 1-1, you could select Form1.vb in the Project Explorer and
then click the View Code button (the icon third from the right at the top of the Solution Explorer)
to open the form’s code editor. You can also right-click an object in the Solution Explorer to get a
list of appropriate commands for that object.

(6) Properties — The Properties window lets you change an object’s properties at design time.
When you select an object in a form designer or in the Solution Explorer, the Properties window
displays that object’s properties. To change a property’s value, simply click the property and
enter the new value.

(7) Error List — The Error List window shows errors and warnings in the current project. For
example, if a variable is used and not declared, this list will say so.

If you look at the bottom of Figure 1-1, you'll notice that the Toolbox and Error List windows each have
a series of tabs. The Toolbox’s other tab displays the Document Outline window, which displays an out-
line view of a project showing its forms and components.

The Error List window’s Output tab shows output printed by the application. Usually an application
interacts with the user through its forms and dialogs, but it can display information here to help you
debug the code. The Output window also shows informational messages generated by the IDE. For
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example, when you compile an application, the IDE sends messages here to tell you what it is doing and
whether it succeeded.

The following sections describe the major pieces of the IDE in more detail.

Menus

The IDE’s menus contain standard Visual Studio commands. These are generally commands that manip-
ulate the project and the modules it contains. Some of the concepts are similar to those used by any
Windows application (File\New, File\Save, Help\Contents), but many of the details are specific to
Visual Studio programming, so the following sections describe them in a bit more detail.

The menus are customizable, so you can add, remove, and rearrange the menus and the items they con-
tain. This can be quite confusing, however, if you later need to find a command that you have removed
from its normal place in the menus. Some developers place extra commands in standard menus, particu-
larly the Tools menu, but it is generally risky to remove standard menu items. Usually it is safest to leave
the standard menus alone and make custom toolbars to hold customizations. For more information on
this, see the section “Customize” later in this chapter.

Many of the menus’ most useful commands are also available in other ways. Many provide shortcut key
combinations that make using them quick and easy. For example, Ctrl-N opens the New Project dialog
just as if you had selected the File\New Project menu command. If you find yourself using the same
command very frequently, look in the menu and learn its keyboard shortcut to save time later.

Many menu commands are also available in standard toolbars. For example, the Debug toolbar contains
many of the same commands that are in the Debug menu. If you use a set of menu commands fre-
quently, you may want to display the corresponding toolbar to make using the commands easier.

Visual Studio also provides many commands through context menus. For example, if you right-click on
a project in the Solution Explorer, the context menu includes an Add Reference command that displays
the Add Reference dialog just as if you had invoked Project\ Add Reference. Often it is easier to find a
command by right-clicking an object related to whatever you want to do than it is to wander through
the menus.

The following sections describe the general layout of the standard menus. You might want to open the
menus in Visual Studio as you read these sections, so you can follow along.

Note that Visual Studio displays different menus and different commands in menus depending on what
editor is active. For example, when you have a form open in the form editor, Visual Studio displays a
Format menu that you can use to arrange controls on the form. When you have a code editor open, the
Format menu is hidden because it doesn’t apply to code.

File
The File menu, shown in Figure 1-2, contains commands that deal with creating, opening, saving, and
closing projects and project files.
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Figure 1-2: The File menu holds commands that deal with the solution and its files.

Following is a description of the commands contained in the File menu and its submenus:

Qa

New — The New submenu shown in Figure 1-2 contains commands that let you create a new
Visual Basic project, Web site project (generally ASPNET or a Web Service), or file (text file,
bitmap, Visual Basic class, icon, and many others). The Project From Existing Code command cre-
ates a new project and puts all of the files in a directory in it, optionally including subdirectories.

New\File — The New submenu’s File command displays the dialog shown in Figure 1-3. The
IDE uses integrated editors to let you edit the new file. For example, the simple bitmap editor
lets you set a bitmap’s size, change its number of colors, and draw on it. When you close the file,
Visual Studio asks if you want to save the file and lets you decide where to put it. Note that this
doesn’t automatically add the file to your current project. You can save the file and use the
Project\ Add Existing Item command if you want to do so.

Open — The Open submenu contains commands that let you open a project or solution, Web
site, or file. The Convert command displays the Convert dialog shown in Figure 1-4. From this
dialog, you can launch the Visual Basic 2005 Upgrade Wizard, which can help you convert
Visual Basic 6 programs to Visual Basic 2005.

Close — This command closes the current editor. In Figure 1-2, Form1 is open in the form
designer editor. This command would close this editor.
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Figure 1-3: The File\New\File command displays this dialog to let you select the new file’s type.
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Converts a Visual Basic 6.0 project to a Visual Basic 2005 project

- Addto current solution

% Create new solution
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Figure 1-4: The File\Open\Convert command displays this dialog
to help you convert Visual Basic 6 applications to Visual Basic 2005.

Close Project — This command closes the entire project and all of the files it contains. If you
have a solution open, this command is labeled Close Solution.

Save Form1.vb — This command saves the currently open file, in this example, Form1.vb.

Save Form1.vb As — This command lets you save the currently open file in a new file.

Save All — This command saves all modified files.

Export Template — This command displays the dialog shown in Figure 1-5. The Export Template
Wizard lets you create project or item templates that you can use later.
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Figure 1-5: The File\Export Template command displays this dialog to help you create project or
items templates that you can easily use in other projects.

Q  Page Setup and Print — The Page Setup and Print commands let you configure printer settings
and print the current document. These commands are enabled only when it makes sense to
print the current file. For example, if you are viewing a source code file or a configuration file
(which is XML text), you can use these commands. If you are viewing bitmap or a form in
design mode, these commands are disabled.

Q  Recent Files and Recent Projects — The Recent Files and Recent Projects submenus let you quickly
reopen files, projects, and solutions that you have opened recently.

Edit

The Edit menu, shown in Figure 1-6, contains commands that deal with manipulating text and other
objects. These include standard commands such as the Undo, Redo, Copy, Cut, and Paste commands
that you've seen in other Windows applications.

Following is a description of other commands associated with the Edit menu:

Q  Cycle Clipboard Ring — The clipboard ring contains the last several items that you copied into
the clipboard. This command copies the previous clipboard ring item to the current location.
By using this command repeatedly, you can cycle through the items until you find the one
you want.
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Figure 1-6: The Edit menu holds commands that deal with manipulating text and other objects.

a

Find and Replace\Quick Find — This command displays a find dialog where you can search the
project for specific text. A drop-down lets you indicate whether the search should include only
the current document, all open documents, the current project, or the entire solution. Options let
you determine such things as whether the text must match case or whole words.

Find and Replace\Quick Replace — This command displays the same dialog as the Quick except
with some extra controls. It includes a text box where you can specify replacement text, and but-
tons that let you replace the currently found text or all occurrences of the text.

Find and Replace\Find in Files — This command is similar to Quick Find except that it displays
its results as a list in a new window. Double-click on an entry in the list to view the occurrence
in its file.

Find and Replace\Replace in Files — This command is similar to Quick Replace except that it dis-
plays its results as a list in a new window.

Go To — This command lets you jump to a particular line number in the current file.

Advanced — The Advanced submenu contains commands for performing more complex docu-
ment formatting such as converting text to upper- or lowercase, controlling word wrap, and
commenting, and uncommenting code.
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Q

to the next or previous bookmark.

outlining on and off.

Bookmarks — The Bookmarks submenu lets you add, remove, and clear bookmarks, and move
Outlining — The Outlining submenu lets you expand or collapse sections of code, and turn

IntelliSense — The IntelliSense gives access to IntelliSense features. For example, its List

Members command makes IntelliSense display the current object’s properties, methods,
and events.

View

The View menu, shown in Figure 1-7, contains commands that let you hide or display different windows
and toolbars in the Visual Studio IDE.
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Figure 1-7: The View menu lets you show and hide IDE windows and toolbars.
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Following is a description of commands associated with the View menu:

a

Q

Code — The Code command opens the selected file in a code editor window. For example, to edit
a form’s code, you can click on the form in the Solution Explorer and then select View\Code.

Designer — The Designer command opens the selected file in a graphical editor if one is defined
for that type of file. For example, if the file is a form, Visual Studio opens it in a graphical form
editor. If the file is a class module or a code module, the View menu hides this command because
Visual Studio doesn’t have a graphical editor for those file types.

Open — Opents the selected item with its default editor.

Open With — Opens the selected item with an editor of your choosing. For example, you could
open a form’s code with a text editor.

Standard windows — The next several commands shown in Figure 1-7 display the standard IDE
windows Solution Explorer, Class View, Resource View, Server Explorer, Properties Window,
Bookmark Window, Object Browser, Toolbox, Start Page, and Property Manager. These com-
mands are handy if you have hidden one of the windows and want to get it back. The most use-
ful of these windows are described later in this chapter.

Web Browser — The Web Browser submenu lets you display and manage a Web Browser within
the IDE. When the Web Browser is visible, the IDE displays a Web toolbar that lets you enter a
URL, jump to one of your favorite links, or add the current page to your Web favorites. The Web
Browser is particular useful for debugging Web applications because it lets you see what Web
pages will look like before you publish them.

Other Windows — The Other Windows submenu lists other standard menus that are not listed
in the View menu itself. These include the Macro Explorer, Document Outline, Task List, Error
List, Command Window, Output, Code Definition Window, and Object Test Bench. It also
includes find results windows that list the results of searches you make using the Edit\Find and
Replace commands.

Tab Order — If a form contains controls, the Tab Order command displays the tab order on top
of each control. You can click on the controls in the order you want them to have to set their tab
order’s quickly and easily.

Toolbars — The Toolbars submenu lets you toggle the currently defined toolbars to hide or dis-
play them. This submenu lists the standard toolbars in addition to any custom toolbars you
have created.

Full Screen — The Full Screen command hides all toolbars and windows except for any editor
windows that you currently have open. It also hides the Windows taskbar so that the IDE occu-
pies as much space as possible. This gives you the most space possible for working with the files
you have open. The command adds a small box to the title bar containing a Full Screen button
that you can click to end full-screen mode.

Navigate Backward, Navigate Forward — These commands let you move back and forth through
the last several locations you visited.

Next Task, Previous Task — These commands move through the items in the Task List.

Property Pages — This command displays the current item’s property pages. For example, if you
select an application in Solution Explorer, this command displays the application’s property
pages similar to those shown in Figure 1-8.
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Figure 1-8: The View menu’s Property Pages command displays an application’s property pages.

Project

The Project menu shown in Figure 1-9 contains commands that let you add and remove items to and
from the project. Which commands are available depends on the currently selected item.

Following is a description of commands associated with the Project menu:

Q  New items — The first several commands let you add new items to the project. These com-
mands are fairly self-explanatory. For example, the Add Class command adds a new class mod-
ule to the project. Later chapters explain how to use each of these file types.

Q  Add New Item — The Add New Item command displays the dialog shown in Figure 1-10. The
dialog lets you select from a wide assortment of items such as text files, bitmap files, and class
modules.

Q  Add Existing Item — The Add Existing Item command lets you browse for a file and add it to
the project.

Q  Exclude From Project — This command removes the selected item from the project. Note that
this does not delete the item’s file; it just removes it from the project.
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Figure 1-9: The Project menu lets you add files and references to the currently selec