
ptg

www.allitebooks.com

http://www.allitebooks.org


ptg

Que Publishing, 800 East 96th Street, Indianapolis, IN 46240 USA

Steve Johnson

Perspection, Inc.

Adobe®

Flash® Professional CS5

 From the Library of Wow! eBook

www.allitebooks.com

http://www.allitebooks.org


ptg

Adobe® Flash® Professional CS5 On Demand

Copyright © 2010 by Perspection, Inc.

All rights reserved. No part of this book shall be reproduced, stored in a 
retrieval system, or transmitted by any means, electronic, mechanical, photo-
copying, recording, or otherwise, without written permission from the publish-
er. No patent liability is assumed with respect to the use of the information 
contained herein. Although every precaution has been taken in the prepara-
tion of this book, the publisher and author assume no responsibility for errors 
or omissions. Nor is any liability assumed for damages resulting from the use 
of the information contained herein.

Library of Congress Cataloging-in-Publication Data is on file

ISBN-13: 978-0-7897-4443-2

ISBN-10: 0-7897-4443-0

Printed and bound in the United States of America 
First Printing: May 2010

13  12  11  10             4  3  2  1  

Que Publishing offers excellent discounts on this book when ordered 
in quantity for bulk purchases or special sales. 

For information, please contact: U.S. Corporate and Government Sales

1-800-382-3419 or corpsales@pearsontechgroup.com

For sales outside the U.S., please contact: International Sales

1-317-428-3341 or International@pearsontechgroup.com

Trademarks
All terms mentioned in this book that are known to be trademarks or service 
marks have been appropriately capitalized. Que cannot attest to the accuracy 
of this information. Use of a term in this book should not be regarded as 
affecting the validity of any trademark or service mark. 

Adobe, the Adobe logo, Acrobat, Bridge, Device Central, Dreamweaver, 
Extension Manager, Flash, InDesign, Illustrator, PageMaker, Photoshop, 
Photoshop Elements, and Version Cue are registered trademarks of Adobe 
System Incorporated. Apple, Mac OS, and Macintosh are trademarks of Apple 
Computer, Inc. Microsoft and the Microsoft Office logo are registered trade-
marks of Microsoft Corporation in the United States and/or other countries.

Warning and Disclaimer
Every effort has been made to make this book as complete and as accurate as 
possible, but no warranty or fitness is implied. The authors and the publishers 
shall have neither liability nor responsibility to any person or entity with 
respect to any loss or damage arising from the information contained in this 
book.

Publisher
Paul Boger 

Associate Publisher
Greg Wiegand 

Acquisitions Editor
Laura Norman

Managing Editor
Steve Johnson 

Author
Steve Johnson 

Contributor
Matthew David 

Technical Editor
Matthew David 

Page Layout
Beth Teyler 
James Teyler

Interior Designers
Steve Johnson 
Marian Hartsough

Photographs
Tracy Teyler 

Indexer
Katherine Stimson 

Proofreader
Beth Teyler 

Team Coordinator
Cindy Teeters

www.allitebooks.com

http://www.allitebooks.org


ptg

iii

Acknowledgements

a

a
Perspection, Inc.
Adobe Flash Professional CS5 On Demand has been created by the professional 
trainers and writers at Perspection, Inc. to the standards you’ve come to expect 
from Que publishing. Together, we are pleased to present this training book.

Perspection, Inc. is a software training company committed to providing information 
and training to help people use software more effectively in order to communicate, 
make decisions, and solve problems. Perspection writes and produces software 
training books, and develops multimedia and Web-based training. Since 1991, we 
have written more than 100 computer books, with several bestsellers to our credit, 
and sold over 5 million books. 

This book incorporates Perspection’s training expertise to ensure that you’ll receive 
the maximum return on your time. You’ll focus on the tasks and skills that increase 
productivity while working at your own pace and convenience.

We invite you to visit the Perspection Web site at:

www.perspection.com

Acknowledgements
The task of creating any book requires the talents of many hard-working people 
pulling together to meet impossible deadlines and untold stresses. We’d like to 
thank the outstanding team responsible for making this book possible: the writer, 
Steve Johnson; the contributing writer and technical editor, Matthew David; the pro-
duction editors, James Teyler and Beth Teyler; proofreader, Beth Teyler; and the 
indexer, Katherine Stimson. 

At Que publishing, we’d like to thank Greg Wiegand and Laura Norman for the 
opportunity to undertake this project, Cindy Teeters for administrative support, and 
Sandra Schroeder for your production expertise and support.

Perspection

 From the Library of Wow! eBook

www.allitebooks.com

www.perspection.com
http://www.allitebooks.org


ptg

iv

aa

About The Author
Steve Johnson has written more than 50 books on a variety of computer software, 
including Adobe Photoshop CS4, Adobe Flash CS4, Adobe Dreamweaver CS4, 
Adobe InDesign CS4, Adobe Illustrator CS4, Microsoft Windows 7, Microsoft Office 
2007, Microsoft Office 2008 for the Macintosh, and Apple Mac OS X Snow Leopard. 
In 1991, after working for Apple Computer and Microsoft, Steve founded Perspec-
tion, Inc., which writes and produces software training. When he is not staying up 
late writing, he enjoys playing golf, gardening, and spending time with his wife, 
Holly, and three children, JP, Brett, and Hannah. Steve and his family live in Pleasan-
ton, California, but can also be found visiting family all over the western United 
States.

 From the Library of Wow! eBook

www.allitebooks.com

http://www.allitebooks.org


ptg

Acknowledgements v

a

We Want To Hear From You!
As the reader of this book, you are our most important critic and commentator. We 
value your opinion and want to know what we’re doing right, what we could do bet-
ter, what areas you’d like to see us publish in, and any other words of 
wisdom you’re willing to pass our way. 

As an associate publisher for Que, I welcome your comments. You can email or 
write me directly to let me know what you did or didn’t like about this book—as well 
as what we can do to make our books better.

Please note that I cannot help you with technical problems related to the topic 
of this book. We do have a User Services group, however, where I will forward 
specific technical questions related to the book.

When you write, please be sure to include this book’s title and author as well as 
your name, email address, and phone number. I will carefully review your com-
ments and share them with the author and editors who worked on the book.

Email: feedback@quepublishing.com

Mail: Greg Wiegand 
Que Publishing 
800 East 96th Street 
Indianapolis, IN 46240 USA

For more information about this book or another Que title, visit our Web site at 
quepublishing.com/register. Type the ISBN (excluding hyphens) or the title of a book 
in the Search field to find the page you’re looking for.

 From the Library of Wow! eBook

www.allitebooks.com

http://www.allitebooks.org


ptg

This page intentionally left blank 

 From the Library of Wow! eBook

www.allitebooks.com

http://www.allitebooks.org


ptg

vii

Contents

c

c
Introduction xvii

Getting Started with Flash CS5 1

Preparing to Install Flash 2
Installing Flash 3
Starting Flash 4 New!

Viewing the Flash Window 6
Creating a Project Plan 8
Building a Flash Project 10
Creating a New Document 12
Creating a New Document from a Template 13 New!

Opening an Existing Document 14
Changing Document Properties 16
Working with Document Windows 18
Saving a Document 20 New!

Saving a Document in Different Formats 22
Getting Help While You Work 24 New!

Getting Online Updates and Support 26 New!

Finishing Up 28

Working Within the Flash Environment 29

Examining the Flash Window 30
Using the Timeline 32 New!

Working with Layers 34
Viewing Layers 36
Organizing Layers 38
Changing Layer Properties 40
Using Guide Layers 41
Working with Frames 42
Working with Scenes 44
Using the Edit Bar 46
Using the Main Toolbar 48

2

1

 From the Library of Wow! eBook

www.allitebooks.com

http://www.allitebooks.org


ptg

viii

c

Resizing Panels 49
Using the Tools Panel 50
Working with Panels 52
Docking and Undocking Panels 54
Grouping and Ungrouping Panels 55
Creating a Workspace 56
Creating Keyboard Shortcuts 58
Setting General Preferences 60
Setting Text Preferences 62 New!

Setting Clipboard Preferences 63
Setting Warning Preferences 64 New!

Working with Page Setup in Macintosh 66
Working with Page Setup in Windows 68
Printing a Document in Macintosh 70
Printing a Document in Windows 72

Creating Graphics 73

Working with Object Drawing 74
Drawing with the Line Tool 75
Drawing with the Pencil Tool 76
Drawing Shapes with the Rectangle and Oval Tools 78
Using the Polystar Tool 80
Understanding Selections 81
Selecting Strokes with the Selection Tool 82
Selecting Strokes and Fills with the Selection Tool 84
Making Selections with the Lasso Tool 85
Zooming In and Out with the Magnifying Glass 86
Moving Around with the Hand Tool 88 New!

Displaying Rulers 89
Using Grids and Guides 90
Modifying Grid and Guide Settings 92
Using Snap Align 94
Changing Stroke and Fill Colors 96
Creating Custom Colors 98 New!

Adding Colors Using the Kuler Panel 100
Editing Strokes with the Ink Bottle 102
Editing Fills with the Paint Bucket 103
Editing Strokes and Fills with the Eyedropper 104
Creating Gradients 105 New!

Using the Fill Lock 106

3

 From the Library of Wow! eBook

www.allitebooks.com

http://www.allitebooks.org


ptg

Contents ix

c

Using Paint Brush Modes 107
Using the Spray Brush Tool 108
Using the Deco Tool 109 New!

Drawing with the Pen Tool 110
Drawing Curves with the Pen Tool 112
Modifying Shapes with the Selection Tool 114
Modifying Shapes with the Subselection Tool 116
Using the Free Transform Tool 118
Using Transform Options for Shapes 120
Transforming Gradient Fills 121
Moving and Rotating Objects in 3D Space 122
Changing the Perspective Angle in 3D Space 124
Adjusting the Vanishing Point in 3D Space 125
Cutting and Pasting Graphics Between Layers 126
Working with Graphics on Different Layers 128
Distributing Graphics to Layers 129
Changing Drawing Settings 130

Working with Groups, Symbols, and Instances 131

Creating Groups 132
Arranging Multiple Groups 133
Opening the Library Panel 134
Working with the Library Panel 136
Creating Symbols 138
Editing in Symbol Mode 140
Creating Instances 142
Changing Symbol and Instance Type 144
Swapping Symbol Instances 146
Using Graphic Symbols 148
Using Button Symbols 150
Enabling and Disabling Buttons 152
Creating Invisible Buttons 153
Using Movie Clip Symbols 154
Breaking Symbols Apart 155
Modifying Instance Properties 156
Modifying Instance Color Styles and Blends 158
Using Advanced Color Options 160
Using 9-Slice Scaling on a Movie Clip Symbol 161
Setting Highlight Color Preferences 162

4

 From the Library of Wow! eBook

www.allitebooks.com

http://www.allitebooks.org


ptg

x

c

Working with Text 163

Creating Classic Static Text 164
Creating TLF Text 165 New!

Linking Text Together 166 New!

Changing Font Type, Style, Size, and Color 168 New!

Modifying Tracking and Kerning 170 New!

Changing Text Alignment 172 New!

Creating Text Columns 174 New!

Changing Text Direction 175 New!

Changing Text Orientation 176 New!

Changing Advanced Text Options 178 New!

Using Break Apart to Modify Characters 180
Using Anti-Alias Text 182 New!

Using Font Mapping 183
Setting Device Fonts Versus Embedded Fonts 184 New!

Creating Dynamic Text and Input Text 186
Checking Spelling 188
Using Find and Replace 190
Using Cascading Style Sheets with HTML 191

Importing Graphics 193

Understanding Vector and Bitmap Graphics 194
Examining Import File Formats 195 New!

Setting Illustrator Import Preferences 196
Setting Photoshop Import Preferences 198
Importing Photoshop and Illustrator Files 200
Importing Bitmaps 202
Importing Fireworks PNG Files 204
Importing Multiple Files 206
Copying Images from Other Programs 207
Editing Bitmaps in an Outside Editor 208 New!

Setting Bitmap Compression 210
Using Break Apart to Create Fill Patterns 211
Modifying a Bitmap Fill 212
Editing a Bitmap with the Magic Wand 214
Using Trace Bitmap to Create Vector Shapes 216

Creating Frame�by�Frame Animation 217

Understanding Frame-by-Frame Animation 218
Creating Keyframes 220

7

6

5

 From the Library of Wow! eBook



ptg

Contents xi

c

Converting Frames to Keyframes 222
Using Frame-Based Versus Span-Based Selection 223
Clearing Keyframes Versus Removing Frames 224
Editing Keyframes 226
Creating a Simple Frame-by-Frame Animation 228
Playing an Animation 230
Using Onion Skinning 232
Modifying Onion Skin Markers 234
Editing Multiple Frames 236

Animating with Motion Tweening 237

Understanding Motion Tweening 238
Applying Motion Tween Presets 240
Creating a Motion Tween 242
Adjusting Motion Tween Properties 243
Editing Motion Tween Properties with the Motion Editor 244 
Adding Color Effects and Filters 246
Working with Property Keyframes 248
Editing the Path of a Motion Tween 249
Copying Motion as ActionScript 250

Animating with Classic Tweening 251

Working with Classic Tweening 252
Understanding Frame and Instance Properties 253
Creating a Classic Tween 254
Adjusting Classic Tween Properties 256
Copying and Pasting a Tween 258
Changing the Length of a Tween 260
Changing the Frame Rate 262
Reversing Frames 263
Adding and Removing Keyframes from a Classic Tween 264 
Scaling and Rotating a Classic Tween 266
Adding Color Effects to a Classic Tween 268
Creating a Classic Motion Guide Layer 269
Animating Along a Classic Motion Guide 270
Orienting Objects to a Classic Motion Path 271
Easing In and Out of a Classic Tween 272

Animating with Shape Tweening 273

Using Shape Tweening 274
Creating a Shape Tween Form 276

10

9

8

 From the Library of Wow! eBook



ptg

xii

c

Adding and Removing Keyframes from a Shape Tween 278
Changing Shape Positions with Shape Tweening 280 
Changing Shape Position and Form Simultaneously 282
Adjusting Shape Tween Properties 284 
Changing Shape Tweening Color and Alpha Options 285
Using Shape Hints 286
Creating Animation Using ActionScript 288
Using Inverse Kinematics 289
Adding Bones to an Armature 290
Editing Armatures and Bones 292 New!

Binding Bones 294

Creating Masks 295

Understanding Masks 296
Creating a Mask Layer 298
Drawing a Mask 300
Activating a Mask 301
Editing a Mask 302
Removing a Mask 303
Adding Layers to a Mask 304
Animating a Mask Layer 306

Working with Sounds 307

Importing Audio 308
Using Audio on the Timeline 310
Loading a Sound from a Shared Library 312
Using Audio with ActionScript 314
Loading a Streaming MP3 File 316
Syncing Sounds to the Timeline 318
Adding Effects and Looping Sounds 319
Publishing Documents Containing Audio 320
Editing Sounds 322
Editing Sounds Using Soundbooth 323

Working with Video 325

Using the Video Import Wizard 326 New!

Working with Video on the Stage 328 New!

Working with Video on the Timeline 330
Using Movie Clips with Video Files 331
Adding Cue Points to a Video 332 New!

Using Video with ActionScript 334

13

12

11

 From the Library of Wow! eBook



ptg

Contents xiii

c

Controlling Video Through Movie Clips 336
Using the FLV Playback Component 338
Working with the Video Encoder 340
Working with Alpha Channel Masks 342
Exporting as a QuickTime Video 344
Exporting as a FLV File 346

Using Basic ActionScripts 347

Viewing the Actions Panel 348
Setting ActionScript Preferences 349 New!

Understanding Properties and Methods 350
Applying Properties and Methods to an Object 351
Using Dot Syntax 352
Understanding Data Types 353
Using Functions 354
Using Conditional Statements 355
Attaching a Mouse Event to a Button 356
Working with Frame Events 357
Working with Clip Events 358
Attaching a Clip Event to a Movie Clip 359
Working with Loops 360
Using For Loops 361
Working with ActionScript Behaviors 362

Working with ActionScript 3.0 363

Using Object-Oriented Programming 364 
Enabling Flash to Execute Solutions Faster with AVM 2.0 365 
Using ActionScript 3.0 366
Changing ActionScript 3.0 Settings 368
Inserting Code with Code Hints 370 New!

Inserting and Creating Code Snippets 372 New!

Developing Solutions Built with the DOM3 Event Model 374 
Working with Classes 375
Working with Objects and Classes 376
Using Namespaces in your Projects 378
Controlling Data 380
Manipulating XML with E4X 381
Using Regular Expressions 382
Controlling Text 383
Drawing with the Shape Class 384

15

14

 From the Library of Wow! eBook



ptg

xiv

c

Developing iPhone Applications 385

Becoming an Apple Certified Developer 386 New!

Registering an iPhone and Other Apple Testing Devices 388 New!

Creating App ID’s 389 New!

Creating a Developers Provisioning Profiles 390 New!

Creating and Publishing an iPhone App 392 New!

Controlling the Accelerometer 394 New!

Saving Images to the Camera Roll 395 New!

Understanding the Limits of Flash 396 New!

Identifying Devices to Deploy an Ad Hoc App 397 New!

Creating an Ad Hoc Distribution Profile 398 New!

Packaging an Ad Hoc App 399 New!

Packaging an App for the iTunes App Store 400 New!

Using iTunes Connect to Publish an App 402 New!

Using Screen Orientation in an App 406 New!

Using Geolocation in an App 407 New!

Using Multitouch in an App 408 New!

Debugging a Movie 409

Debugging Concepts 410
Debugging with the ActionScript Editor 412 New!

Using the Movie Explorer 414
Debugging for ActionScript 3.0 416
Resolving Compiler Errors 418 New!

Debugging for ActionScript 2.0 420
Viewing Variables 421
Adding Variables to the Watch List 422
Viewing Properties 423
Setting Breakpoints 424
Stepping Through Code 425
Debugging Manually 426

Adding and Modifying Components 427

Understanding Basic Components 428 New!

Using the Component Inspector 430 New!

Adding a Text Input 432
Adding a Combo Text Box 434
Adding a Check Box 436
Adding a Radio Button 438
Adding a Text Area 440

18

17

16

 From the Library of Wow! eBook



ptg

Contents xv

c

Adding a Button 442
Adding a List 444
Adding a Label 446
Adding a Data Grid 448
Using a Local Data Provider 450
Adding a Loader 451
Adding a Numeric Stepper 452
Adding a Progress Bar 454
Adding a Scroll Pane 456
Creating Bindings 458
Modifying Bindings 460
Modifying Schema 462
Modifying Component Attributes 463
Using Components to Build a Form 464

Automating Your Work 465

Examining the History Panel 466
Using the History Panel 467
Working with Object-Level Undo Mode 468
Undoing and Redoing Steps 470
Replaying Steps 472
Saving Steps and Using Commands 474
Copying Steps Between Documents 476

Publishing a Movie 477

Publishing Considerations 478
Modifying Publish Settings 479
Specifying Flash Options 480
Specifying Adobe AIR Options 482 New!

Inserting File Information 484
Specifying HTML Options 486 New!

Specifying GIF Options 488
Specifying PNG Options 490
Specifying JPEG Options 492
Creating a Windows or Macintosh Projector 493
Creating a Publishing Profile 494
Editing Profile Properties 495
Exporting and Importing a Profile 496
Duplicating a Profile 498
Previewing a Movie 499
Testing a Movie 500 New!

20

19

 From the Library of Wow! eBook



ptg

xvi

c

Using the Bandwidth Profiler 501
Exporting a Movie to Different Formats 502
Printing from the Flash Player 504

Working with Projects and Other Programs 505

Working with Adobe Flash Builder 506 New!

Exchanging Content with Adobe FXG 508 New!

Creating an Adobe AIR Application 510 New!

Creating Content for a Mobile Device 512
Mapping MIDI Sounds on a Mobile Device 514
Creating and Managing a Project 516
Managing Project Files 518
Testing a Project 520
Sending a Document Using E-mail 521
Exploring CS Live Services 522 New!

Sharing My Screen 523 New!

Use Adobe Extension Manager 524

New Features 525 New!

Adobe Certified Expert 529
Index 535

21

 From the Library of Wow! eBook



ptg

xvii

Introduction

Welcome to Adobe Flash Professional CS5 On Demand, a 
visual quick reference book that shows you how to work 
efficiently with Flash.  This book provides complete coverage 
of basic to advanced Flash skills.

How This Book Works
You don’t have to read this book in any particular order. 
We’ve designed the book so that you can jump in, get the 
information you need, and jump out. However, the book does 
follow a logical progression from simple tasks to more com-
plex ones. Each task is presented on no more than two facing 
pages, which lets you focus on a single task without having 
to turn the page. To find the information that you need, just 
look up the task in the table of contents or index, and turn to 
the page listed. Read the task introduction, follow the step-
by-step instructions in the left column along with screen illus-
trations in the right column, and you’re done.

What’s New
If you’re searching for what’s new in Flash CS5, just look for 
the icon: New!. The new icon appears in the table of contents 
and throughout this book so you can quickly and easily iden-
tify a new or improved feature in Flash. A complete descrip-
tion of each new feature appears in the New Features guide 
in the back of this book.

Keyboard Shortcuts
Most menu commands have a keyboard equivalent, such as 
Ctrl+P (Win) or A+P (Mac), as a quicker alternative to using 
the mouse. A complete list of keyboard shortcuts is available 
on the Web at www.perspection.com.

How You’ll Learn

How This Book Works

What’s New

Keyboard Shortcuts

Step-by-Step Instructions

Real World Examples

Workshops

Adobe Certified Expert

Get More on the Web
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Step-by-Step 
Instructions
This book provides concise step-
by-step instructions that show you 
“how” to accomplish a task. Each 
set of instructions includes illus-
trations that directly correspond to 
the easy-to-read steps. Also 
included in the text are time-
savers, tables, and sidebars to 
help you work more efficiently or 
to teach you more in-depth infor-
mation. A “Did You Know?” pro-
vides tips and techniques to help 
you work smarter, while a “See 
Also” leads you to other parts of 
the book containing related infor-
mation about the task. 

Real World Examples
This book uses real world exam-
ple files to give you a context in 
which to use the task. By using 
the example files, you won’t waste 
time looking for or creating sam-
ple files. You get a start file and a 
result file, so you can compare 
your work. Not every topic needs 
an example file, such as changing 
options, so we provide a complete 
list of the example files used 
throughout the book. The example 
files that you need for project 
tasks along with a complete file 
list are available on the Web at 
www.perspection.com.

Real world 
examples help 
you apply what 
you’ve learned 
to other tasks.

Illustrations
match the 
numbered 
steps.

Numbered 
steps guide 
you through 
each task.

Did You Know? alerts 
you to tips, techniques 
and related information.

See Also points you to 
related information in 
the book.

Easy-to-follow 
introductions 
focus on a 
single concept.
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The Workshops 
walk you through 
in-depth projects 
to help you put 
Flash to work.

Introduction xix

Workshops
This book shows you how to put 
together the individual step-by-
step tasks into in-depth projects 
with the Workshop. You start each 
project with a sample file, work 
through the steps, and then com-
pare your results with a project 
results file at the end. The Work-
shop projects and associated files 
are available on the Web at 
www.perspection.com.

Adobe Certified Expert
This book prepares you fully for 
the Adobe Certified Expert (ACE) 
exam for Adobe Flash CS5. Each 
Adobe Certified Expert certifica-
tion level has a set of objectives, 
which are organized into broader 
skill sets. To prepare for the certifi-
cation exam, you should review 
and perform each task identified 
with an ACE objective to confirm 
that you can meet the require-
ments for the exam. Information 
about the ACE program is avail-
able in the back of this book. The 
Adobe Certified Expert objectives 
and the specific pages that cover 
them are available on the Web at 
www.perspection.com.
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Get More on the Web
In addition to the information in 
this book, you can also get more 
information on the Web to help 
you get up-to-speed faster with 
Flash CS5. Some of the informa-
tion includes: 

Transition Helpers
◆ Only New Features.

Download and print the new 
feature tasks as a quick and 
easy guide.

Productivity Tools
◆ Keyboard Shortcuts.

Download a list of keyboard 
shortcuts to learn faster ways 
to get the job done. 

More Content
◆ Photographs. Download 

photographs and other 
graphics to use in your Flash 
documents.

◆ More Content. Download 
new content developed after 
publication.

You can access these additional 
resources on the Web at 
www.queondemand.com or 
www.perspection.com.

Additional 
content 
is available 
on the Web. 

Additional 
content 
is available 
on the Web. 
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Getting Started with 
Flash CS5

Introduction

Flash is an application for developing rich content, user 
interfaces, and Web applications. Adobe Flash Professional 
CS5 allows designers and developers to integrate video, 
text, audio, and graphics into rich experiences that deliver 
superior results for interactive marketing and presentations, 
e-learning, and application user interfaces. Most major com-
mercial Web sites have implemented Flash content because of 
its cross-platform consistency, rich graphics capabilities, and 
small file sizes. 

After you create and fine-tune multimedia content in 
Flash, you can deliver it on the Web within a browser using 
the Flash Player. Flash Player is a software product devel-
oped by Adobe for browsers on the Macintosh and Windows. 
Flash is the world’s most pervasive software platform, used 
by millions of professionals and reaching more than 97% of 
Web-enabled desktops worldwide, as well as a wide range of 
consumer electronic devices, such as PDAs and mobile 
phones. You can also deliver Flash content as a separate 
application using AIR or an application on an Apple iPhone.

Flash operates virtually the same on both Macintosh and 
Windows versions, except for a few keyboard commands 
that have equivalent functions. You use the [Ctrl] and [Alt] 
keys in Windows, and the A and [Option] keys on a 
Macintosh computer. Also, the term popup on the Macintosh 
and list arrow in Windows refer to the same type of option. 1

1
What You’ll Do

Prepare to Install Flash

Install and Start Flash

View the Flash Window

Create a Project Plan

Build a Flash Project

Create a New Document

Create a New Document from 
a Template

Open an Existing Document

Change Document Properties

Work with Document Windows

Save a Document

Save a Document in Different Formats

Get Help While You Work

Get Online Updates and Support

Finish Up

1
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System Requirements

Before you can install Flash Professional CS5 
and development content, you need to make 
sure your computer meets the minimum sys-
tem requirements. You can create Flash con-
tent on Windows and Macintosh computers. 
As a Flash developer, you also need to be 
aware of the system requirements for viewers 
of your Flash movies in a browser using the 
Adobe Flash Player. Web users need to down-
load and install the player in order to view 
and interact with Flash content. The Flash 
Player is free and widely distributed over the 
Web at www.adobe.com.

Some Flash CS5 features require the latest 
version of QuickTime. During the installation, 
use the Recommended installation type to 
install the required components. You can 
obtain the latest version of QuickTime at 
www.quicktime.com.

For Windows Computers

You need to have a computer with the follow-
ing minimum configuration:

◆ Intel Pentium 4, Centrino, Xeon, or 
Core Duo processor or equivalent. 

◆ 1 GB of RAM (2 GB recommended).

◆ 2.5 GB available disk space. 

◆ 16-bit (thousands of colors), 1024 x 
768 resolution. 

◆ Microsoft Windows XP with Service 
Pack 3 or higher; Windows Vista with
Service Pack 1, Windows 7. 

◆ Internet or phone connection required 
for activation. 

◆ QuickTime 7.x or higher; DirectX 
version 9.0c or higher. 

For Macintosh Computers

You need to have a computer with the follow-
ing minimum configuration:

◆ Multicore Intel-based Macintosh. 

◆ 1 GB of RAM (2 GB recommended).

◆ 2.5 GB available disk space. 

◆ 16-bit (thousands of colors), 1024 x 
768 resolution. 

◆ Mac OS X 10.5.x, or later. 

◆ Internet or phone connection required 
for activation. 

◆ QuickTime 7.x or higher. 

For Viewers in a Browser

Your visitors need to have a computer with 
the Flash Player and the following minimum 
configuration:

◆ For Windows 98/Me. Internet Explorer
5.5, Netscape 7.x, Mozilla 1.x, Firefox
1.x, AOL 9, or Opera 7.11. 

◆ For Windows 2000. Internet Explorer 
5.x, Netscape 7.x, Mozilla 1.x, Firefox
1.x, CompuServe 7, AOL 9, or Opera
7.11. 

◆ For Windows 7/Vista/XP/Windows 
2003 Server. Internet Explorer 6.0, 
Netscape 7.x, Mozilla 1.x, CompuServe 
7, Firefox 1.x, AOL 9, or Opera 7.11. 

◆ For Macintosh OS X 10.1.x - Mac X
10.4.x. Safari 2.x, Internet Explorer 5.2, 
Netscape 7.x, Mozilla 1.x, Firefox 1.x, 
AOL for OS X, Opera 6, or Safari 1.x. 

Preparing to Install Flash
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To perform a standard application install, insert the Adobe Flash 
Professional CS5 installation disc into the drive on your computer, and 
then follow the on-screen instructions. Because the setup process is 
different for Macintosh OS X and Windows platforms, general steps are 
provided to help you get started, and the on-screen instructions will 
guide you through the rest. Make sure to have your serial number handy 
because you'll be asked to enter it during the installation process. If 
you're updating from a previous version of Flash, you'll be required to 
verify the older version with your serial number for the previous version. 
The Flash installation includes all the components you need, including 
the Flash Player 10, to develop Flash content. The Flash Player is soft-
ware installed on a user’s computer that allows them to view published 
Flash movies (SWFs) in a Web page or through the player.

Installing Flash

Install Flash Professional CS5

Insert the Flash Professional CS5 
DVD into your DVD ROM drive, or 
download the software online to 
your hard disk.

If necessary, double-click the DVD 
icon or open the folder with the 
downloaded software, and then 
double-click the setup icon.

Follow the on-screen instructions 
to install the product; the installer 
asks you to read and accept a 
licensing agreement, enter a serial 
number, indicate the language you 
want, enter or create an Adobe ID 
or skip the step, and specify where 
you want to install the software.

3

2

1

3

2

Did You Know?
Most Adobe applications can be 
downloaded. It's all very simple, you 
go to www.adobe.com, click the 
Products menu item, and then select 
the application you want to purchase. 
You will need a credit card (of course), 
and a lot of bandwidth.
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You can start Flash in several ways, depending on the platform you are 
using. When you start Flash, the computer displays a splash screen and 
then the Flash window. When you start a new Flash session or close all 
documents, a Welcome screen appears in the Document window, pro-
viding easy access links to open a document, open a recent item, cre-
ate new documents, create new documents from template, and display 
online video tutorials to help you get started. You can also use links to 
access many Flash related Adobe Web sites, including Adobe CS Live 
Online Services (New!) and Adobe Flash Exchange, where you can 
download additional applications and information.

Starting Flash

Start Flash in Windows

Click Start on the taskbar.

Point to All Programs (which 
changes to Back).

Point to an Adobe Collection CS5 
menu, if needed.

Click Adobe Flash Professional 
CS5.

If you’re starting Flash 
Professional CS5 for the first time, 
you might be prompted to specify 
the following:

◆ Enter or create an Adobe ID to 
register the product, click 
Submit, and then click Done.

The Flash Professional CS5 
window opens, displaying the 
Welcome screen.

5

4

3

2

1

Welcome 
screen

Did You Know?
You can hide the Welcome screen. On 
the Welcome screen, select the Don’t 
Show Again check box.

You can set launch preferences to 
customize how Flash starts. Click the 
Flash (Mac) or Edit (Win) menu, click 
Preferences, click the General cate-
gory, select an option from the On 
Launch list arrow, and then click OK.

4 2

Don’t Show Again check box

 From the Library of Wow! eBook



ptg

Chapter 1 Getting Started with Flash CS5 5

Start Flash in Macintosh

Open the Applications folder 
(located on the main hard drive).

Double-click the Adobe Flash CS5 
folder.

Double-click the Adobe Flash CS5 
application icon.

If you’re starting Flash CS5 for the 
first time, you might be prompted 
to specify the following:

◆ Enter or create an Adobe ID to 
register the product, click 
Submit, and then click Done.

The Flash Professional CS5 
window opens, displaying the 
Welcome screen.

4

3

2

1 
3

1

Shortcut for Adobe Flash CS5

Did You Know?
You can create a shortcut on the 
Macintosh. Drag and drop the Flash 
application to the bottom of the monitor 
screen, and then add it to the dock.

You can work in other programs as 
Flash starts up. When you start Flash, 
the Welcome screen no longer stays in 
front, so you can work in other pro-
grams (New!). 

Launching Flash and Opening a Document

You can also start Flash and open a Flash document at the same time. 
Double-click the Flash file icon in Windows Explorer (Win) or in a 
Macintosh folder (Mac). You can identify a Flash document by the file 
icon or FLA file extension. A file extension is a three-letter suffix at 
the end of a filename that identifies the file type for the operating sys-
tem. The Macintosh doesn't need to use file extensions, but added 
the feature to promote cross platform use. In the Mac Operating 
System (OS) 10 or later, you have the option to show or hide file 
extensions. When you are working on both platforms, using file 
extensions on the Macintosh allows Windows and Flash to recognize 
and open the files.

For Your Information
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Tools Panel
Contains 
drawing and 
other related 
tools to 
create and 
manipulate 
graphics.

Property Inspector
Displays information about the properties and 

attributes of tools and graphic elements. 

Viewing the Flash Window

Panel Windows
Gives you access to authoring tools 
and attribute settings for elements.

Welcome 
screen

Provides 
easy access

links to 
create and 
open Flash

documents.
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Document Window
Displays open Flash 
documents, which include an 
Edit bar, Timeline and Stage.

Edit Bar
Displays what editing mode you 
are working in and allows you to 
switch scenes.

Stage
Provides a place to compose the 
content for individual frames, 
which includes drawing artwork 
or arranging imported graphics. 

Timeline
Gives you a visual represent-
ation of every frame, layer and 
scene in the document. 
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Before you begin to create a movie in Flash, 
it's important to develop a project plan first. 
The project plan provides a site map for you 
to follow as you build your project in Flash. 
Without a project plan, you'll inevitably hit 
road blocks, which will cause you to waste 
time redesigning all of or portions of the 
movie. Planning a movie project involves 
determining its purpose, identifying the audi-
ence, logically developing the content, organ-
izing the structure of the content, developing 
the layout and design, and identifying the 
delivery computer system.  With a project 
plan in place, you'll be ready to create a 
movie in Flash. 

Plan a Movie
Creating a movie can take a long time; it's 
worth the effort to plan carefully. The ten-
dency for most first-time Flash developers is 
to start creating a movie without carefully 
planning the project. Before you begin, you 
need to develop and follow a plan. Otherwise, 
you might end up spending a lot of time fix-
ing or completely changing parts of the 
movie, which you could have avoided from 
the beginning. You need to figure out the goal 
of the project, the look and feel of your pro-
duction, its length and size, how it will inter-
act with the viewer, and how and for whom it 
will be distributed. 

When planning a movie, it's important to 
accomplish the following:

Determine the purpose

Is it for training? Sales? Entertainment? 
Informing? The answer will determine the 
types of features you may want to include or 
exclude in the movie. If the purpose is to cre-
ate a training site, you might want to include 
simple navigation, easy-to-use instructional 
material, and a help system. On the other

hand, if the purpose is to create a sales pro-
motion, you might want to include eye-catch-
ing graphics, videos, and audio to get users' 
attention and draw them into the presenta-
tion.

Identify the audience

How you create your movie will depend on 
how you classify the intended audience. If the 
intended audience consists of novice com-
puter users, you will have to concentrate on 
making the navigational controls and layout 
as simple to use as possible. If the users are 
experienced computer users, you can include 
more advanced features and interactions. 

Develop the content and organize the 
structure

The most beneficial planning tools for the 
multimedia developer are the script and 
schematic flowchart. The script tells the story 
of your movie production in text form. Just 
like in the movies, a script is used to describe 
each section, to list audio or video, and to 
provide a basis for the text that will appear 
onscreen. Schematic flowcharts are the best 
way to sketch the navigational structure of a 
movie and make sure that each of the sec-
tions is properly connected. After you have 
the script and schematic flowchart mapped 
out on paper, you will quickly see the correla-
tion between what you have developed and 
what you will begin to set up in Flash.

Develop the layout and design of the 
movie

The storyboard tells the story of your movie 
in visual form. It helps you design the layout 
of each screen in your movie. The storyboard 
follows the script and develops visual frames 
of the movie's main transitional points, which 
help you develop the Flash media elements 

Creating a Project Plan
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you will use to create your movie. A story-
board can take a long time to develop, but the 
media elements you assemble and create in 
the process will shorten the overall develop-
ment time. As you develop your layout and 
design, be sure to keep:

◆ Navigation easy to understand and 
consistent from page to page, such as
navigation bars or drop-down menus 

◆ Text easy to read 

◆ Sound and animation limited

◆ Movie file sizes as small as possible 
for fast downloads. Break up large files
into small ones for easy management

◆ Color consistent and appropriate for 
the audience

◆ Content accessible to users with visual 
or auditory impairments

Identify the delivery computer system and 
browser to be used for playback

Some computers are more up-to-date than 
others. You need to determine the minimum

computer hardware and software require-
ments in which your movie will be delivered. 
The hardware and software requirements will 
determine what types of media you can use 
and how the movie will play back. 

Some hardware requirements you need to 
consider for the delivery computer system are
(1) CPU (central processing unit), which deter-
mines the speed with which your computer 
can compute data; (2) RAM (system memory), 
which determines how fast files load and how 
smoothly they run; (3) Sound cards, which 
determine if you can use sound files; (4) Video 
cards, which determine the quality and speed 
of the graphic and video display, and (5) 
Monitor resolution, which determines the 
color display (number of available colors), 
size (1024 x 768 is typical, while 1440 x 900 is 
becoming more and more available), and 
overall look of your movie.

Some software requirements you need to 
consider are the operating system version 
and supported browser type and version. See 
“Preparing to Install Flash” on page 2 for spe-
cific details about these requirements.

Sample script Sample flowchart
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After you develop a project plan, you can use 
Flash to create a movie according to the plan. 
Creating a movie involves six main steps: set-
ting up movie properties, assembling media 
elements, positioning the media elements on 
the Stage and sequencing them in the 
Timeline, adding custom functionality and 
interactive elements, previewing and testing 
the movie, and finally publishing or exporting 
the movie for distribution. 

Build a Movie with Flash
Before you start creating a movie using Flash 
based on your project plan, it's important to 
understand the process of developing Flash 
software. The basic steps for developing inter-
active multimedia software with Flash are 
listed below.

Step 1: Set up document properties

Before you start a Flash project, you need to 
create a new document and set up initial doc-
ument properties, such as the user’s viewable 
screen size, for how your movie looks and 
operates. It is important to specify document 
property settings that affect the entire movie 
at the beginning of the project, such as how 
colors are defined and the size and location of 
the Stage, so you don't have to redesign the 
movie later. 

Step 2: Create or import media elements

Media elements include graphics, images, 
buttons, videos, sounds, and text. You can cre-
ate new media elements in Flash or import 
ones that have already been developed. Flash 
provides several tools for creating media ele-
ments, including shape and paint tools, and 
text creation tools. You can also add media 
elements from the Library, a media storage 
area. Media elements are either static or 
dynamic. Static media is an element, such as

text or graphics, created or imported into a 
movie that doesn’t change unless the author 
makes the change and republishes the movie. 
Dynamic media is an element, such as data, 
MP3 sound, a JPEG image, or Flash Live 
Video (FLV) video, stored outside of the pub-
lished movie and loaded when needed or 
changed by scripting, which makes updating 
easy, keeps file sizes down, and provides per-
sonalized information to the user.

Step 3: Position the elements on the Stage 
and sequence them in the Timeline

The Stage is the viewing area you use to dis-
play where media elements appear in a 
movie, and the Timeline is the area you use to 
organize what you want to occur at the time 
and duration you specify. You use the Stage to 
create the look and feel for your production; 
you use the Stage and Timeline together to 
arrange the media elements in space and 
time. The Stage represents the media ele-
ments' position in space (where) and the 
Timeline represents the media elements' 
position in time (when).

Step 4: Add navigational components, 
interactive behaviors, and motion effects

Scripting allows you to add custom function-
ality to your movie, such as moving objects 
on the Stage, formatting text, storing and 
managing information, performing mathe-
matical operations, and controlling the movie 
in response to specific conditions and events, 
such as a mouse click. In Flash, scripts are 
written in ActionScript, a Flash-specific pro-
gramming language. To help you get started 
scripting and save you some time, Flash 
comes with built-in components, and scripts 
called behaviors. Components are elements 
you can use to quickly create a user interface. 
For example, components can include 

Building a Flash Project
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buttons, arrows, or other navigation elements 
that move the viewer to different parts of a 
movie or to different locations on the Web. 
After you add a component, you can use 
behaviors to add functionality to the compo-
nent to make it do what you want. In addition 
to behaviors, you can use built-in Timeline 
effects to add motion to elements. As you 
build in movie navigation and organization, 
it’s good design to break up large projects 
into smaller movies, which can be quickly 
accessed from a main movie. This keeps 
Internet download times to a minimum, and it 
makes projects easier to update, and more 
manageable for a team to produce. 

Step 5: Preview and test the movie

After you create your project, you use one of

the Test Movie commands to preview and test 
the movie to make sure it runs the way you 
want it to. It's important to test the functional-
ity of your movie early and often during the 
development process to catch problems while 
they are still minor. 

Step 6: Publish the document as a movie 
file for use over the Internet

When the movie runs the way you want it to, 
you can publish your production as a Flash 
movie that viewers can play on a Web page, 
using a browser with the Flash Player. Flash 
publishes the movie file (.swf) and creates an 
HTML file with information to display the 
movie file. Viewers can't change the movies in 
the SWF format; they can only play them.

Step 2: Create 
or import

media 
elements

Step 4: Add navigational components, 
interactive behaviors, and motion effects

Step 1: Setup 
document 
properties

Step 6: Publish the 
document as a 
movie

Step 5: Preview and test the movie 

Step 3: Position the elements on the Stage 
and sequence them in the Timeline 
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A file in Flash is called a document. Flash documents, which have the 
FLA filename extension, contain all the information required to develop, 
design, and test interactive content. Flash documents are not the same 
as the movies you play with the Flash Player. Instead, you publish your 
Flash documents as Flash movies, which have the SWF filename exten-
sion and contain only the information needed to display the movie. A 
new Flash document is based on the scripting language you want to 
use, either ActionScript 2.0 or ActionScript 3.0. You can create new doc-
uments in several ways including using the New command on the File 
menu and the New Document task pane. When you open a new Flash 
document, it’s blank, ready for you to create or insert text, graphics, and 
other media content. By default, the first Flash document is titled 
Untitled1. Flash numbers new documents consecutively. You can open 
and work on as many new documents as you have memory (RAM) for. 

Creating a New
Document

Create a New Blank Document

Click the File menu, and then 
click New.

TIMESAVER Click Flash 
Document on the Welcome screen 
to create a new blank document.

Click the General tab.

Click ActionScript 3.0 or 
ActionScript 2.0.

IMPORTANT ActionScript 2.0 
and ActionScript 3.0 are not 
compatible with each other. 
ActionScript 3.0 is recommended.

◆ If you want to create a specific 
type of document, click the type 
you want.

Click OK.4

3

2

1 
2 3

4

Did You Know?
You can open a new window with a 
copy of the current document. Create 
or open the Flash document you want 
to open in a new window, click the 
Window menu, and then click 
Duplicate Window.

Creating New Documents for Other Purposes
In addition to creating FLA documents in ActionScript 2.0 or 3.0 for 
the Flash Player, you can also create FLA documents to publish 
applications for Adobe AIR 2.0 (for Mac, Windows, and Linux), 
iPhone OS (for iPhone, iTouch, and iPad devices) (New!), Flash Lite 
4 (a Flash player for less power and memory-constraint devices), 
and Adobe Device Central (for mobile devices). 

For Your Information

Documents with the FLA extension

Document with other extensions
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Creating a New 
Document from a 
Template

Create a New Document from a 
Template

Click the File menu, and then 
click New.

TIMESAVER Click a template 
category on the Welcome screen 
to open the New From Template 
dialog box, where you can select 
a template.

Click the Templates tab.

Click a template category.

Click the template you want to 
use.

View the templates in the Preview 
box and read the description.

Click OK.6

5

4

3

2

1

Flash makes it easy to create many common documents based on a 
template. A template opens a Flash document (such as an animation or 
set of menus) with predefined formatting and placeholder text, graph-
ics, and actionscripts. The templates make it easy to create common 
types of Flash projects. Flash comes with a set of templates, which 
includes the following categories (New!): Advertising, Animation, 
Banners, Media Playback, Presentations, and Sample Files. When you 
select a template category, a list of templates appears. Select a tem-
plate to display a brief description. If you can’t find the template you 
want, you can check the Adobe Flash Support Center Online Web site 
for more. 

5

2

4 63

See Also
See “Saving a Document in Different 
Formats” on page 22 for information on 
saving a document as a template.
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You can open an existing document file and the Flash program at one 
time, or you can open the file from within Flash. In Flash, you can use 
the Welcome screen, Open commands on the File menu, or Adobe 
Bridge CS5 (a stand-alone file management program that comes with 
Flash CS5) to open Flash documents, scripts, and movies in several for-
mats. The default file format for Flash is FLA. However, the internal for-
mat of an FLA file is XFL (eXtensible Form Language) (New!). XFL 
allows you to exchange file content between programs, such as Adobe 
InDesign and Adobe After Effects. You can also open an XFL file as you 
would an FLA file. When you open a document, a tab appears across 
the top of the Document window, which you can click to display it.

Opening an 
Existing Document

Open a Flash Document

Click the File menu, and then click 
Open.

TIMESAVER Click Open or a 
recently opened Flash document 
name on the Welcome screen to 
open a document.

To open a specific type of Flash 
file, click the File as type list arrow 
(Win), or the File type popup 
(Mac), and then select the file 
format you want.

Navigate to the drive or folder 
where the file is located.

Click the document file you want 
to open.

Click Open.5

4

3

2

1

3 5

2

Did You Know?
You can view what is inside of an XFL 
file. An XFL file is essentially a ZIP 
package containing the XML and the 
assets for a FLA file. To view the actual 
XML and assets of the FLA file, change 
the .XFL file extension to .ZIP and unzip 
the folder.

Format Description

ActionScript (.as) A file to store ActionScript code for a 
Flash document.

XFL (.xfl, .xml) A packaged XML representation of a FLA 
file along with the assets for that file.

Communications (.asc) A file to store ActionScript code on a 
computer with Flash Communication Server.

FLA Document (.fla) A Flash document you create and save 
in Flash authoring environment.

JavaScript (.jsfl) A separate file with JavaScript code to add 
new functionality to Flash.

Flash Movie (.swf) A compressed movie file you publish in the 
Flash authoring environment. 

Other Dynamics
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Open a Recently Opened 
Document

Click the File menu, and then point 
to Open Recent.

Click the document you want to 
open.

Browse Documents in 
Adobe Bridge

Click the File menu, and then click 
Browse in Bridge.

Adobe Bridge CS5 opens, 
displaying files and folder on your 
computer.

Select a workspace display to 
view your files the way you want.

Navigate to the drive or folder 
where the Flash file is located.

To open a Flash file, double-click 
the file icon.

When you’re done, click the File 
menu, and then click Return to 
Adobe Flash.

TIMESAVER Press A+Option 
(Mac) or Ctrl+Alt+O (Win).

5

4

3

2

1

2

1

1

2

Did You Know?
You can open a recent file quickly 
from the Start menu (Win). Click the 
Start button, point to Adobe Flash 
Professional CS5 (7), Recent Items 
(Vista) or My Recent Documents (XP), 
and then click the file name you want 
to open.

4

5 3 2
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When you create a new Flash document or open an existing one, you 
need to set up or change the document properties. You set document 
properties at the beginning of the project to make basic decisions 
about how your movie looks and operates. You use the Document 
Properties dialog box or the Property Inspector to specify document 
property settings that affect the entire movie, such as the background 
color, the size and location of the Stage, the frame rate—the number of 
frames per second in which the computer plays an animation, and the 
unit of measure for rulers. These settings apply only to the current doc-
ument unless you set Flash defaults to apply to every document. You 
can use the Properties command on the Window menu to display the 
Property Inspector, which appears vertically on the screen.

Changing Document 
Properties

View Document Properties

Click the Selection tool on the 
Tools panel.

Click the Window menu, and then 
click Properties to open the 
Property Inspector.

TIMESAVER Press A+F3 
(Mac) or Ctrl+F3 (Win).

View the document properties at 
the top of the Property Inspector:

◆ Stage Size. The current size 
appears in the button label.

◆ Background Color. The color of 
the Stage background.

◆ Frame Rate. The speed at 
which the movie runs.

3

2

1 
1

3

Document name

Did You Know?
You can change the background color 
quickly in the Property Inspector. Open 
the Property Inspector, click the 
Background color box, and then select 
a color from the panel.

You can change the frame rate quickly 
in the Property Inspector. Open the 
Property Inspector, and then enter the 
number of animation frames to be dis-
played every second in the Frame Rate 
box.
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Change Document Properties

Create or open a document.

Click the Modify menu, and then 
click Document.

TIMESAVER Click the Size 
button in the Property Inspector or 
double-click the frame-rate box in 
the Status bar on the Timeline.

To set the Stage dimensions, do 
one of the following:

◆ Specify size in pixels. Enter 
values in the Width and Height
boxes. The default size is 550 x
400 pixels.

◆ Set size to an equal space 
around content. Click Contents.

◆ Set size to the maximum print 
area. Click Printer.

◆ Set size to default setting. Click
Default.

Click the Background Color box, 
and then select a color.

Enter a frame rate. For most 
computers playing from the Web, 8 
fps (frames per second) to 24 fps is 
adequate. The default is 24 fps.

To specify the unit of measure for 
rulers, click the Ruler Units popup, 
and then select an option.

To set properties for all new 
documents, click Make Default.

Click OK.8

7

6

5

4

3

2

1

3

7

Improving Searchability by Internet Search 
Engines
When you add a title and description to Flash document properties, 
you’re making it easier for Internet search engines to categorize the 
content in your Flash movie file (.swf). The title and description 
boxes are metadata properties for the SWF file format. The Internet 
uses metadata as a standard format for gathering and transferring 
data.  When you enter a title and description, use descriptive key-
words that reflect the type of user you want to attract to your Web 
site.

For Your Information

See Also
See “Displaying Rulers” on page 89 for 
information on using rulers.

64

8
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When you open multiple documents, you can use the Window menu or 
tabs at the top of the Document window to switch between them. You 
can click a tab name to switch and activate the document. By default, 
tabs are displayed in the order in which you open or create documents. 
When you want to move or copy information between documents, it’s 
easier to display several Document windows on the screen at the same 
time and move them around. However, you must make the window 
active to work in it. Each tab also includes a Close button to quickly 
close a document. If the document view is too small or large, you can 
change it to suite your needs.

Working with 
Document Windows

Switch Between Multiple 
Documents

Open more than one document.

Click a tab name to switch to the 
document.

TIMESAVER Press Ctrl+Tab or 
Ctrl+Shift+Tab to cycle to the tab 
you want.

◆ You can also click the Window 
menu, and then click a 
document name at the bottom 
of the menu.

2

1

2
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Change the Document View

Open more than one document.

Click the View Size list arrow in 
the Edit bar, and then select a view 
size: Fit in Window, Show Frame, 
Show All, or a percentage.

◆ You can also enter a custom 
percentage in the View Size 
box, and then press Enter (Win) 
or Return (Mac).

To display the document window 
in the full screen, click the 
Window menu, and then click 
Hide Panels.

◆ To show panels, click the 
Window menu, and then click 
Show Panels.

TIMESAVER Press F4 to toggle 
between Hide/Show Panels.

Move Document Windows 
Around

Open more than one document.

Do either of the following: 

◆ Rearrange the order of tabbed 
documents. Drag a windows’ 
tab to a new location.

◆ Dock or undock a document 
window. Drag the window’s tab 
out of the group or into the 
group.

2

1

3

2

1 3

panels hidden

2

2 Undocked document window
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When you save a Flash CS5 document within the authoring environ-
ment, the document is saved in the FLA format. If you want to display a 
document in the Adobe Flash Player, you need to publish or export the 
document in the SWF format. When you save a new document, you 
give it a name and specify the location in which to save the file. Name 
your documents clearly so you can easily locate them later. An unsaved 
Flash file displays an asterisk (*) after the name in the document name 
tab. To retain older versions of a document as you update it, use the 
Save As command and give each new version a new number with the 
old name, such as project1, project2 and so forth. In addition to saving 
files in the FLA format, you can also save flash content in the XFL 
(eXtensible Form Language) format (New!) as an uncompressed Flash 
document for use in other programs, such as Adobe InDesign and 
Adobe After Effects. 

Saving a Document

Save a Document in the Flash 
Format

Click the File menu‚ and then click 
Save.

If you are saving a document for 
the first time, continue. Otherwise, 
Flash saves the current document.

◆ To save a file with a different 
name, click the File menu, and 
then click Save As.

Type the new file name.

Navigate to the drive or folder 
location where you want to save 
the document.

Click Save.

If the file was created in Flash 
CS4, click Save or Cancel to 
convert it to Flash CS5.

5

4

3

2

1

3

5

2

Did You Know?
You can revert to the last saved ver-
sion of a document. Click the File 
menu, and then click Revert.

You can save more than one document 
at a time. Click the File menu, and then 
click Save All.

4
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Save a Document in the Flash 
CS5 Uncompressed Format

Click the File menu, and then click 
Save As.

Click the Format popup (Mac) or 
Save As Type list arrow (Win), 
and then click Flash CS5 
Uncompressed Document (*.xfl).

Type the new file name. 

Navigate to the drive or folder 
location where you want to save 
the document. 

Click Save.

A folder with the Flash document 
file name is created in the 
specified location containing the 
XML (Extensible Markup 
Language) and the assets for the 
FLA file (New!).

5

4

3

2

1

5

Did You Know?
You can move or copy a file quickly in 
a dialog box (Win). In the Open or 
Save As dialog box, right-click the file 
you want to move or copy, click Cut or 
Copy, open the folder where you want 
to paste the file, right-click a blank 
area, and then click Paste. 

There is a difference between Save 
and Save As. When you save an exist-
ing document using the Save com-
mand, Flash performs a quick save, 
which appends new content to the 
existing file. When you save a new 
document using the Save As com-
mand, Flash performs a complete save, 
which saves and compacts the content 
into a small file. 

Using an XFL Flash Uncompressed Document
In Flash CS5, you can save a Flash document (FLA) as a Flash 
uncompressed document (XFL) (New!). An XFL file is essentially a 
folder containing separate files, including XML files and other asset 
files for the FLA file. The XML (Extensible Markup Language) file con-
tains the document information for your Flash project. XML uses a 
standard set of rules for encoding information so  other programs can 
use it. You can use a Flash uncompressed document in the XFL for-
mat in other programs, such as Adobe InDesign and Adobe After 
Effects. If you use other development programs like Flypaper, you 
can use the XFL format to work on the document in both programs. 
To view the actual XML and assets of the FLA file, open the folder in 
Windows Explorer (Win) or Finder (Mac). Since all the assets for a 
FLA file are in a folder, you can also edit the individual files, such as 
an XML document, or a graphic file, in other programs, such a 
word-processing or graphics program. With live update (New!) 
with XFL files, you can edit any asset from an uncompressed XFL 
document while the document is open in Flash. When you finish 
editing and save an asset, the changes are automatically updated 
in Flash.

For Your Information

4

2

3
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A file type specifies the document format (for example, a template) as 
well as the program and version in which the file was created (for 
example, Flash CS5). You might want to change the type if you’re creat-
ing a custom template or sharing files with someone who has an earlier 
version of Flash, such as Flash CS4. You use the Save As dialog box to 
change the file type for a document. The Format popup (Mac) or Save 
As Type list arrow (Win) displays a list of the available formats for 
Flash.

Saving a Document 
in Different Formats

Save a Document in the Flash 
CS4 Format

Click the File menu, and then click 
Save As.

Click the Format popup (Mac) or 
Save As Type list arrow (Win), and 
then click Flash CS4 Document
(*.fla).

Type the new file name. 

Navigate to the drive or folder 
location where you want to save 
the document. 

Click Save.5

4

3

2

1

4

2

5

Did You Know?
You can delete a file in a dialog box 
(Win). In the Open or Save As dialog 
box, right click the file you want to 
delete, and then click Delete.

3
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Save a Document as a Template

Click the File menu, and then click 
Save as Template.

If a warning dialog box appears, 
click Save As Template.

Type a name for the new template.

Click the Category list arrow, and 
then click a category template.

Type a description for the new 
template.

Click Save.

If the file was created in Flash 
CS4, click Save or Cancel to 
convert it to Flash CS5.

7

6

5

4

3

2

1

3 4

5 6

7

See Also
See “Creating a New Document from a 
Template” on page 13 for information 
on creating a new document from a 
Flash template.

2
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At some time, everyone has a question or two about using a program. 
When you start Flash Help, the Adobe Community Help window opens 
(New!), displaying help categories and topics. You can search product 
help from Local Help, Community Help, or Adobe.com by using keywords 
or phrases or browsing through a list of categories and topics to locate 
specific information. Local Help accesses product help on your local 
computer, Community Help accesses product help online, and 
Adobe.com accesses related help information on Adobe.com. When you 
perform a search using keywords or phrases, a list of possible answers 
is shown from the search location with the most likely responses at the 
top. Along with help text, some help topics include links to text and 
video tutorials. In addition, comments and ratings from users are avail-
able to help guide you to an answer. You can add feedback and sugges-
tions by signing in to Adobe.com using an Adobe ID.

Getting Help While 
You Work

Get Help Information

Click the Help menu, and then 
click Flash Help.

TIMESAVER Press F1 (Win) or 
A+/ (Mac).

The Adobe Community Help 
window opens, displaying 
product help information.

If you want help with ActionScript, 
Flash Development, or other 
support resources, click the 
appropriate link.

Click Help categories (plus sign 
icons) until you display the topic 
you want.

◆ What’s New. Click What’s new 
in Adobe Flash Professional 
CS5 under Using Flash 
Professional CS5.

Click the topic you want. 

Read the topic, and if you want, 
click any links to get information 
on related topics or definitions. 

When you’re done, click the Close 
button (Win) or click the Adobe 
Help menu (Mac), and then click 
Quit Adobe Help.

6

5

4

3

2

1 1

2

3

6

4

Click to collapse/ 
expand panel

Click to open help in a PDF 
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Help Commands Description

Flash Help Access Flash Help window

Flash Support Center Access Flash support on the Web

Adobe Product Improvement Participate in the direction of future 
Program versions of Adobe products

Flash Exchange Access Flash downloadable 
applications

Omniture Access information about the Omniture 
company on the Web

Manage Extensions Access Flash extension information

Adobe Online Forums Access user conversations on the Web

Flash Help Commands

Search for Help Information

In Flash, on the Application bar, 
type one or more keywords in the 
Search box, and then press Enter 
(Win) or Return (Mac). 

◆ You can also click the Help 
menu, and then click Flash 
Help to open Help and use the 
Search box.

The Adobe Community Help 
window opens, displaying a list of 
topics that match the keywords 
you entered in the Search box.

To search another CS product, 
click the Select Product list arrow, 
and then select a CS product. 

To refine a search, click Search 
Options to expand it, and then 
select any of the following options:

◆ Search Location. Select Local
Help, Community Help, or 
Adobe.com.

◆ Filter Results. For Adobe.com, 
select a filter option.

Click the link to the topic you want 
from the search list of results. 

Click a link or scroll to display a 
topic, and then read the topic. If 
you want, click any links to get 
information on related topics or 
definitions.

◆ Next and Previous Topics. Click 
the Previous or Next button on 
the right side of the Help web 
page.

When you’re done, click the Close 
button (Win) or click the Adobe 
Help menu (Mac), and then click 
Quit Adobe Help.

6

5

4

3

2

1

4

1

623

5

Search results

 From the Library of Wow! eBook



ptg

26 Chapter 1

Adobe offers a quick and easy way to update Flash CS5 and other CS5 
related programs with any new software downloads directly from Flash 
using the Help menu. Adobe can notify you of updates in the menu bar 
(New!). If you need more detailed information about a Flash task or fea-
ture, you can find out the latest information on the Web from the Adobe 
Flash Support Center and Flash Exchange Web sites. The Adobe Flash 
Support Center provides technical notes, documentation updates, and 
links to additional resources in the Flash community, while the Adobe 
Flash Exchange allows you to download additional applications and 
commands that other Flash users have developed and posted to extend 
the functionality of Flash. Some of the posted items are free while other 
charge a fee. You can access the Flash Support Center and the Flash 
Exchange from within Flash using commands on the Help menu.

Getting Online 
Updates and Support

Get Product Updates Online

Click the Help menu, and then 
click Updates.

Flash checks your software with 
the latest available version and 
automatically updates it.

To manually check, click the 
Check For New Updates button.

To change preferences, click 
Preferences, select the update 
options you want, and then click 
Done.

Click Quit.4

3

2

1

2

Did You Know?
You can register to receive notices 
about upgrades and new products. If 
you haven’t already registered during 
installation, click the Help menu, click 
Product Registration, and then follow 
the online instructions.

You can deactivate and activate Flash 
using the Help menu. If you have Flash 
installed on two computers, yet only 
have one license, you can use the 
Deactivate and Activate commands on 
the Help menu to go between the com-
puters.

3

4
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Get Online Support Information

Click the Help menu, and then 
click Flash Support Center.

Your Web browser opens, 
displaying the Adobe support Web 
site.

Search on the Web site for the 
help information you need.

When you’re done, close your 
Web browser. 

Get Resources from the 
Flash Exchange

Click the Help menu, and then 
click Flash Exchange.

Your Web browser opens, 
displaying the Adobe support Web 
site.

Search on the Web site for the 
help information you need, or click 
the Product popup, and then 
select a product to display the 
resource types you need.

Scroll through the list, and then 
follow the on-screen instructions 
to download and purchase (if 
necessary) the resources you 
want.

When you’re done, close your 
Web browser. 

4

3

2

1

3

2

1

4

3
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After you work on a document, you can close the document by closing 
the document or by exiting Flash. You should save the document before 
closing it. Exiting Flash closes the current document and the Flash 
program and returns you to the desktop. You can use the Exit command 
on the File menu (Win) or Quit Flash command on the Flash menu (Mac) 
to close a document and exit Flash, or you can use the Close button on 
the Flash Document tab. If you try to close a document without saving 
your final changes, a dialog box opens, asking if you want to do so.

Finishing Up

Close a Document

Click the Close button on the 
Document tab, or click the File 
menu, and then click Close.

TIMESAVER Press A+W 
(Mac) or Ctrl+W (Win) to close a 
document. Click the File menu, and 
then click Close All to close all 
open documents.

If necessary, click Yes to save any 
changes you made to your open 
documents before the program 
quits.

Exit Flash

Choose one of the following:

◆ Click the Flash menu, and then 
click Quit Flash (Mac).

◆ Click the Close button, or click 
the File menu, and then click 
Exit (Win).

If necessary, click Yes to save any 
changes you made to your open 
documents before the program 
quits.

2

1

2

1 
1

1 Exit (Win)

Document tab Close button

Click to exit (Win)
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Working Within the Flash 
Environment

Introduction

Getting to know the Flash authoring environment makes you 
more effective and efficient as you create movies. You’ll get 
to know the parts of the Flash window, which include the 
Timeline, Stage, panels, and Property Inspector. 

The Tools panel, also known as the Toolbox, contains tools 
that you can use to draw, paint, select, and modify artwork. 
The Timeline represents the overall structure of a Flash docu-
ment and controls the content. The Timeline consists of lay-
ers, frames, and scenes that make up a Flash document. 
Layers are like transparent sheets stacked on top of one 
another. Each layer can contain different images that appear 
on the Stage. A frame displays content at a specific moment 
on the Stage. The order in which frames appear in the 
Timeline determines the order in which they appear in the 
document. As you play a document, the playhead moves 
through the Timeline displaying the current frame with each 
layer on the Stage. If a project requires many animation 
sequences with hundreds of frames, you can organize the 
animations into scenes to make them easier to work with and 
manage. Below the Timeline is the Stage, which provides a 
place to compose the content for individual frames. Panels 
are windows that allow you to view, organize, and change 
elements and related options in a document. The Property 
Inspector is a specialized panel that allows you to change 
object-specific attributes and options.

Flash uses built-in keyboard shortcuts designed specifi-
cally for Flash. The built-in keyboard shortcuts are organized 
into sets, which you can duplicate and customize to create 
your own personalized set. Flash allows to you set prefer-
ences to customize the way you work in the program. As you 
design and develop a movie, you can print frames to review 
your work. 2

2
What You’ll Do

Examine the Flash Window

Use the Timeline

Work with Layers

View and Organize Layers

Change Layer Properties

Use Guide Layers

Work with Frames

Work with Scenes

Use the Edit Bar and Main Toolbar

Resize Panels

Use the Tools Panel

Work with Panels

Dock and Undock Panels

Group and Ungroup Panels

Create a Workspace

Create Keyboard Shortcuts

Set Flash Preferences

Work with Page Setup

Print a Document

29
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When you start Flash, the program window 
displays several windows of varying sizes you 
can use to create a movie. These windows 
include the Timeline/Stage, various panels, 
and the Property Inspector. Depending on 
your installation and previous program usage, 
not all of these windows may appear, or addi-
tional ones may be visible. You'll do the bulk 
of your work in Flash with these windows. 

In Flash, windows appear in the work-
space with a title bar, such as the Timeline 
window, or in a panel. A panel is a window 
you can collapse, expand, and group with 
other panels, known as a panel group, to 
improve accessibility and workflow. A panel 
appears with a shaded header bar, which 
includes the window title and additional 
options. A panel group consists of either indi-
vidual panels stacked one on top of the other

Examining the Flash Window

Document Window
Displays open Flash 

documents, which includes a
Timeline, Edit bar, and Stage.

Timeline
Gives you a visual represent-
ation of every frame, layer 
and scene in the document. 

Stage
Provides a place to compose the 

content for individual frames,
which includes drawing artwork 
or arranging imported graphics. 

Panel 
Windows 
Gives you 
access to 
authoring 
tools and 
attribute 
settings 
for 
elements.

Property Inspector
Displays information about the 
properties and attributes of 
tools and graphic elements. 

Tools Panel
Contains 

drawing and
other related 

tools to
create and 
manipulate

graphics.

Main Toolbar
Contains buttons for commonly 
used commands. Point to a 
button to display a Tooltip.

Search Box
Allows you to search Adobe 
Community Help online. 
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or related panels organized together with 
tabs, such as the Components panel, to navi-
gate from one panel to another. The Flash 
window displays the menu bar at the top.  The 
menu bar also contains a Workspace menu, 
Search box, CS Live menu, Close button, and 
resizing buttons. 

A menu is a list of commands that you use 
to accomplish specific tasks. A command is a 
directive that accesses a feature of a program. 
Flash has its own set of menus, which are 
located on the menu bar along the top of the 
Flash window. On a menu, a check mark iden-
tifies a feature that is currently selected (that 
is, the feature is enabled or on). To disable 
(turn off) the feature, you click the command 
again to remove the check mark. A menu can 
contain several check-marked features. A bul-
let (Win) or diamond (Mac) also indicates that 
an option is enabled, but a menu can contain 
only one bullet-or diamond-marked feature 
per menu section. To disable a command with 
a bullet or diamond next to it, you must select 
a different option in the section on the menu.

When you perform a command frequently, 
it's faster, and sometimes more convenient, to 
use a shortcut key, which is a keyboard alter-
native to using the mouse. When a shortcut 
key is available, it is listed beside the com-
mand on the menu, such as A+F3 (Mac) or 
Ctrl+F3 (Win) for the Properties command on 
the Window menu.

Flash (for Windows) also includes a Main 
toolbar. The Main toolbar contains buttons for 
the most frequently used commands. Clicking 
a button on a toolbar is often faster than click-
ing a menu and then clicking a command. 
When you position the pointer over a button, 
a tooltip appears, displaying the button name.

The Tools panel contains a set of tools you 
can use to create shapes, such as lines, rec-

tangles, rounded rectangles, and ellipses. You 
can fill shapes with a color, pattern, or custom 
tile. The shapes and buttons you create in 
Flash are saved as media elements in the 
layers.

The Document window displays open 
Flash documents, which include a Timeline, 
Edit bar, and Stage. Flash (for Windows) also 
includes tabs to make it easier to switch back 
and forth between documents. At the top of 
the Document window is the Edit bar. The Edit 
bar displays what editing mode you are work-
ing in, and allows you to switch scenes.

The Timeline organizes and controls 
media elements over a linear timeline in rows 
called channels and in columns called frames. 
The Timeline displays a movie's Timeline and 
monitors the playback frame-by-frame. A 
frame represents a single point in a movie. 
The Timeline includes layers that control dif-
ferent parts of the movie. 

The Stage is the visible portion of a movie, 
on which you determine where your media 
elements appear. The Stage is the rectangle 
area below the Timeline where you place 
graphic content, including vector art, text 
boxes, buttons, imported bitmap graphics, or 
audio and video clips. You can define the 
properties of your Stage, such as its size and 
color. 

The Property Inspector provides a conven-
ient way to view and change attributes of any 
selected object or multiple objects on the 
Stage in your movie. After you select an 
object, relevant commands and associated 
fields for it appear in the Property Inspector. 
You can apply filters, such as gradient con-
trols to text, buttons, and movie clips. In addi-
tion, you can display the Property Inspector 
horizontally (like previous versions of Flash) 
or vertically.

 From the Library of Wow! eBook



ptg

32 Chapter 2

Using the Timeline

Change the Timeline Display

◆ To lengthen or shorten layer name 
fields, drag the bar separating the 
layer names and the frames in the 
Timeline.  

◆ To heighten or shorten the 
Timeline, drag the bar separating 
the Timeline and the Stage.  

◆ To hide or show the Timeline 
panel, click the gray bar to the 
right of the Timeline tab.  

Resize the Timeline Display

Do one of the following:  

◆ If the Timeline is docked to the 
program window, drag the bar 
separating the Timeline from 
the program window.  

◆ If the Timeline is not docked to 
the program window, drag the 
size box in the lower right 
corner.  

1

The Timeline represents the overall structure of a Flash document and 
controls the content. The Timeline consists of layers, frames, and 
scenes that make up a Flash document. Layers appear on the left side 
of the Timeline and frames contained in each layer appear in a row to 
the right of the layer. The Timeline header above the frames displays 
the frame numbers. At the bottom of the Timeline, a Status bar appears, 
displaying the current frame indicator, the current rate indicator, and 
the elapsed time indicator. Sometimes it is hard to work with frames in 
a small view in the Timeline. You can change the size of frames and dis-
play frames with tinted cells. In addition, you can display thumbnail 
previews of frame content, which is useful for viewing animations.

Drag to 
change length 
of layer name 
fields.

Drag edge to 
change height 
of Timeline.

Drag to resize 
Timeline.
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Change the Display of Frames in 
the Timeline

Click the Frame View button in the 
Timeline.

Select one of the following options 
from the list:

◆ To change the width of frame 
cells, click Tiny, Small, Normal, 
Medium, or Large.

◆ To display thumbnails of the 
content of each frame scaled to 
fit the Timeline frames, click 
Preview.

◆ To display thumbnails of each 
full frame, click Preview In 
Context.

This is useful for viewing 
animation movement within 
their frames.

◆ To decrease the height of frame 
cell rows, click Short.

◆ To turn frame sequence tinting 
on and off, click Tinted Frames.

◆ To disregard audio in the 
Timeline, click Scrub Audio 
(New!).

◆ To close the current tab, click 
Close. To close all the tabs, 
click Close Group.

2

1

2

Preview in 
frame view

See Also
See “Working with Panels” on page 52 
for information on using the Timeline 
panel.

1
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Working with Layers

Create a New Layer

Click the layer or folder above 
which you want to insert a layer.

Click the New Layer button at the 
bottom of the Timeline.

The new layer appears above the 
selected layer.

Create a New Layer Folder

Click the layer or folder above 
which you want to insert a layer 
folder.

Click the New Folder button at the 
bottom of the Timeline.

The new layer folder appears 
above the selected layer.

2

1

2

1

Layers are like transparent sheets stacked on top of one another. Each 
layer can contain different images that appear on the Stage. You can 
draw and edit objects on one layer without affecting objects on another 
layer. Layers in a document are listed in the left column of the Timeline. 
Before you can work with a layer, you need to select it, or make it 
active. A pencil icon next to a layer or layer folder indicates it is active. 
Only one layer can be active at a time, even though you can select 
more than one layer. A new document comes with one layer, but you 
can add more to organize content on the Stage. As you create multiple 
layers of related content, you can create layer folders to make it easier 
to manage the layers.

2

New layer

1

2

New layer folder

1

Active layer

Did You Know?
Flash names layers in order based on 
the highest number. If you add Layers 2 
and 3, and then delete Layer 2. The 
next time you add a layer, Flash names 
it Layer 4.
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Rename a Layer or Folder

Double-click the name of a layer 
or folder.

Type a name.

Press Return (Mac) or Enter (Win).

Delete a Layer or Folder

Select the layer or folder you want 
to delete.

Click the Delete button at the 
bottom of the Timeline.

2

1

3

2

1 
2

1

2

1

Did You Know?
There are several ways to select a 
layer. You can click the name of a layer 
or folder in the Timeline, click a frame 
in the Timeline of the layer you want to 
select, or select an object on the Stage 
that is located on the layer you want to 
select.

You can select multiple layers. To 
select contiguous layers or folders, 
click the first layer or folder, and then 
Shift+click the last layer or folder. To 
select noncontiguous layers or folders, 
A+click (Mac) or Ctrl+click (Win) the 
layers or folders you want to select.
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Viewing Layers

Show or Hide a Layer or Folder

Do one of the following:

◆ Click the Eye column to the 
right of the layer or folder to 
show or hide it.

◆ Click the Eye icon to show or 
hide all layers or folders.

◆ Option+click (Mac) or Alt+click 
(Win) in the Eye column to the 
right of a layer or folder to 
show or hide all other layers or 
folders.

Lock or Unlock Layers 
or Folders

Do one of the following:

◆ Click in the Lock column to 
the right of the layer or folder 
to lock or unlock it.

◆ Click the Lock icon to lock or 
unlock all layers or folders.

◆ Option+click (Mac) or Alt+click 
(Win) in the Lock column to the 
right of a layer or folder to lock 
or unlock all other layers or 
folders.

1

1

Flash includes controls (Eye, Lock, and Outline icons) in the layers sec-
tion of the Timeline that allow you to quickly hide, show, lock, or unlock 
layers and layer folders, and display objects on a layer as colored out-
lines. Using colored outlines makes it easier to distinguish in which 
layer an object appears. When you hide a layer or folder with the Eye 
icon, a red X appears next to the name. When you lock a layer or folder 
with the Lock icon, a padlock appears next to the name. When you dis-
play layers as colored outlines with the Outline icon, a frame appears 
next to the name. When you change a folder, the controls affect all lay-
ers within a folder.

1

1

Lock icon

Eye icon
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View the Contents of a Layer 
as Outlines

Do one of the following:

◆ Click the Outline column to the 
right of the layer’s name to 
display its objects as outlines.

◆ Click the Outline icon to display 
objects on all layers as 
outlines.

◆ Option+click (Mac) or Alt+click 
(Win) in the Outline column to 
the right of a layer to display 
objects on all other layers as 
outlines.

1

View 
contents 
as outline

Outline icon

View 
contents 
not as 
outline

Outline 
column 
icon

See Also
See “Changing Layer Properties” on 
page 40 for information on changing 
the outline color.

Did You Know?
Hidden layers are visible when you 
publish a document. When you publish 
a Flash document as a SWF movie, hid-
den layers are visible in the Flash 
movie file.

1
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In much the same way you organize files on your computer, you can 
use similar concepts to organize layers and layer folders in a docu-
ment. You can expand or collapse a layer folder to show or hide its con-
tents. You can also move a layer or folder into a layer folder or to 
another place in the layers list. Layer folders can contain layers and 
other layer folders. In addition, you can copy a layer or copy the con-
tents of a layer folder. 

Organizing Layers

Expand or Collapse a 
Layer Folder

Do one of the following:

◆ Click the triangle to the left of 
the folder name to expand or 
collapse the folder.  

◆ Control+click (Mac) or right-
click (Win) any layer, and then 
click Expand All Folders or 
Collapse All Folders.

Move a Layer or Layer Folder 

◆ To move a layer or folder into a 
layer folder, drag the layer or 
folder to the destination layer 
folder name in the Timeline. 

◆ To move a layer or folder to 
another location, drag the layer or 
folder to a new position in the 
Timeline.  

1

Collapsed layer folder1

Layers in the folder

Drag Controls layer to the Behind Scenes folder
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Copy a Layer

Click the layer you want to select.

Click the Edit menu, point to 
Timeline, and then click Copy 
Frames.

Click the New Layer button.

Click the new layer to select it.

Click the Edit menu, point to 
Timeline, and then click Paste 
Frames.

Copy the Contents of a 
Layer Folder

If necessary, click the triangle to 
the left of the folder name to 
collapse it.

Click the folder layer to select the 
entire folder.

Click the Edit menu, point to 
Timeline, and then click Copy 
Frames.

Select the layer below where you 
want to copy the layer folder.

Click the New Folder button.

Click the new layer folder to 
select it.

Click the Edit menu, point to 
Timeline, and then click Paste 
Frames.

7

6

5

4

3

2

1

5

4

3

2

1

3

1 4

1 4

6

2

5
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The Layer Properties dialog box makes it easy to changes several layer 
options at once. You can change a layer name, show or lock a layer, 
change a layer type or outline color, and modify the layer height to 
show more information in the Timeline. Setting layer properties of a 
folder automatically sets the properties for all the layers within that 
folder. 

Changing Layer 
Properties

Change Layer Properties

Select the layer in the Timeline.

Click the Modify menu, point to 
Timeline, and then click Layer 
Properties.

Select from the following options:

◆ Name. Enter a new name.

◆ Show. Select this check box to 
show the layer.

◆ Lock. Select this check box to 
lock the layer or clear it to 
unlock the layer.

◆ Type. Select a layer option: 
Normal, Mask, Masked, Folder, 
or Guide.

◆ Outline Color. Click the Color 
box, and then select a color.

◆ View Layer As Outlines. Select 
this check box to view the layer 
as outlines.

◆ Layer Height. Click the list 
arrow, and then select a 
percentage to display more 
information in the Timeline.

Click OK.4

3

2

1

3

4

Layer Description

Normal The default layer type.

Mask Mask layers hide and reveal portions of linked layers 
that lie directly beneath the mask layer.

Masked Masked layers contain elements that can be hidden or 
revealed by a mask layer.

Folder Folder layers allow you to organize layers.

Guide There are two types of guide layers: guides and motion 
guides. Guides help you place and align objects on the 
Stage, motion guides designate a path that an animated 
object follows. Guided layers contain objects that follow 
an animation path. You need to link the guided layer to 
the motion guide.

Layer Types
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Using Guide Layers

Create a Guide Layer

Click the layer you want to convert 
to a guide layer.

Control+click (Mac) or right-click 
(Win) the selected layer, and then 
click Guide.

2

1

Guide layers help you draw and align objects on layers that appear on 
the Stage. After you create a guide layer, you can align objects on 
other layers to objects you create on the guide layer. You can make any 
layer a guide layer. You can also create a motion guide layer to control 
the movement of objects in a motion tweened animation.

Aligning 
objects using 
the guide layer.

1

2
Did You Know?

You can change a guide layer back to 
a normal layer. Control (Mac) or right-
click (Win) the selected layer, and then 
click Guide.

You can convert a guide layer to a 
motion guide layer. Drag a normal 
layer onto a guide layer.

See Also
See “Using Snap Align” on page 94 for 
information on snapping items you 
draw or drag to snap to lines or 
shapes.
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Working with Frames

Select One or More Frames

◆ To select one frame, click on the 
frame.

IMPORTANT If the Span 
Based Selection preference is 
turned on, clicking a frame selects 
the entire frame sequence 
between two keyframes.

◆ To select multiple contiguous 
frames, click the first frame in the 
sequence, hold down Shift, and 
then click the last frame in the 
sequence.

◆ To select multiple noncontiguous 
frames, A+click (Mac) or 
Ctrl+click (Win) the frames you 
want to select.

A frame displays content at a specific moment on the Stage. The order 
in which frames appear in the Timeline determines the order in which 
they appear in the document. The Timeline displays each frame in 
sequential order from 1 to the end of the document. As you play a doc-
ument, the playhead moves through the Timeline displaying the current 
frame with each layer on the Stage. When you work with frames, you 
can select, insert, delete, and move frames in the Timeline. When you 
move frames in the Timeline, you can place them on the same layer or 
a different layer. If you want to display a specific frame in a document, 
you can move the playhead to the frame in the Timeline to display the 
frame content on the Stage. Another type of frame is called a keyframe. 
A keyframe defines a change in an animation or uses actions to modify 
a document.

Select one frame

Select multiple contiguous frames

Select multiple noncontiguous frames

Playhead

See Also
See “Using the Timeline” on page 32 
for information on changing the view 
size of frames in the Timeline.

Did You Know?
You can center the Timeline on the 
current frame. Click the Center Frame 
button at the bottom of the Timeline.
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Insert a Frame

Click the frame’s location in the 
Timeline header, or drag the 
playhead to the frame where you 
want to insert a frame.

Click the Insert menu, point to 
Timeline, and then click Frame.

Delete Frames

Select the frame, keyframe, or 
sequence you want to delete.

Click the Edit menu, point to 
Timeline, and then click Remove 
Frames.

2

1

2

1

1

2

Did You Know?
You can move a frame sequence or 
keyframe. Drag the frame sequence or 
keyframe to another location in the 
Timeline.

You can copy a frame sequence or 
keyframe. Option+drag (Mac) or 
Alt+drag (Win) the frame sequence or 
keyframe to another location in the 
Timeline.

Did You Know?
You can add labels to frames to refer-
ence in ActionScripts. In the Timeline, 
select the frame you want. In the 
Property Inspector, enter a name in the 
Name box under Label.

1
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Working with Scenes

Open the Scene Panel and 
Select a Scene

Click the Window menu, point to 
Other Panels, and then click 
Scene.

TIMESAVER Press Shift+F2.

A list of scenes appears in order in 
the panel. In a new document, the 
Scene panel displays only the 
default Scene 1.

Click the scene you want to 
display.

Add a Scene

If necessary, open the Scene 
panel.

Click the Add Scene button in the 
Scene panel.

2

1

2

1

If a project requires a lot of animations with hundreds of frames, you 
can organize the animations into scenes to make them easier to work 
with and manage. The Scene panel makes it easy to display the number 
of scenes in the document, select current scenes for editing, create 
new scenes, duplicate scenes, delete scenes, and reorder them. You 
can also use the Edit bar to select a scene to edit. When you select a 
scene, Flash displays it on the Stage. When you publish a document as 
a movie, the scenes play in order unless you add interactivity to play 
them differently. Be aware that scenes are treated like self-contained 
movies, so transitions between scenes with interactivity may not be 
seamless.

2

2

New scene 

Did You Know?
Flash names scenes in order based on 
the highest number. If you add Scenes 
2 and 3, and then delete Scene 2, the 
next time you add a scene, Flash 
names it Scene 4.
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Rename a Scene

If necessary, open the Scene 
panel.

Double-click the scene you want 
to rename.

Type a new name.

Press Return (Mac) or Enter (Win).

Delete a Scene

If necessary, open the Scene 
panel.

Click the scene you want to delete.

Click the Delete Scene button in 
the Scene panel.

Click OK to confirm the deletion.

TIMESAVER If you don’t want 
to display the Confirmation dialog 
box, press A+click (Mac) or 
Ctrl+click (Win) the Delete Scene 
button.

4

3

2

1

4

3

2

1 
2 3

3

2

Did You Know?
You can undo the deletion of a scene.
If you mistakenly delete a scene, you 
can undo; press A+Z (Mac) or 
Ctrl+Z (Win).

You can reorder scenes in the Scene 
panel. In the Scene panel, drag a 
selected scene up or down in the list.

Playing and Testing Scenes
After you finish creating and working with scenes in a Flash docu-
ment, you can quickly playback all the scenes in Flash or test a 
scene in a browser with commands on the Control menu. To play-
back all scenes in the order in which they appear in the Scenes 
panel, click the Control menu, and then click Play All Scenes. To test 
the active scene, click the Control menu, and then click Test Scene. 
To change the settings for the SWF file created using the Test 
Scene command, use the Publish Settings command on the File 
menu.

For Your Information
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Using the Edit Bar

Show and Hide the Edit Bar

◆ To display the Edit bar, click the 
Window menu, point to Toolbars, 
and then click Edit Bar to select 
the check mark.

◆ To hide the Edit bar, click the 
Window menu, point to Toolbars, 
and then click Edit Bar to deselect 
the check mark.

The Edit bar contains controls and information for editing scenes and 
symbols, and for changing the view size of the Stage. The Edit bar lets 
you know what editing mode you are working in and allows you to switch 
scenes. The Scene button allows you to edit a scene in document-editing 
mode, while the Symbol button allows you to edit symbols in the symbol-
editing mode. The Back button on the Edit bar returns you to document-
editing mode.

Click to select (show) or 
deselect (hide) the check mark.

Current scene or symbol being edited

Edit 
bar

Back button
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Change View Size of the Stage

Click the View Size list arrow in 
the Edit bar, and then select a view 
size percentage or an option:  

◆ Fit To Window

◆ Show Frame 

◆ Show All 

Select a Scene or Symbol to Edit

◆ To select a scene, click the Edit 
Scene button in the Edit bar, and 
then select a scene from the list.

◆ To select a symbol, click the Edit 
Symbol button in the Edit bar, and 
then select a symbol from the list.

1
Select and type a 
view percentage

1

Edit Symbol buttonEdit Scene button

Did You Know?
You can use the Hand tool to move the 
Stage to change the view. Click the 
Hand tool (H) on the Tools panel, and 
then drag the Stage to change the 
view.
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Using the Main 
Toolbar

Show and Hide the Main
Toolbar in Windows

◆ To display the Main toolbar, click 
the Window menu, point to 
Toolbars, and then click Main to 
select the check mark.

◆ To hide the Main toolbar, click the 
Window menu, point to Toolbars, 
and then click Main to deselect 
the check mark.

If you use Windows, you can display and use the Main toolbar above 
the Document menu window to quickly access common document and 
object-related commands, such as New, Open, Save, Print, Cut, Copy, 
Paste, Redo, Undo, Snap To Objects, Smooth, Straighten, Rotate And 
Skew, Scale, and Align. When you’re finished working with the Main 
toolbar, you can hide it to create more workspace.

Click to select (show) or 
deselect (hide) the check mark.

Main 
toolbar

Did You Know?
You can use Undo and Redo com-
mands on the menu bar. The Undo and 
Redo commands on the Edit menu 
undo (returns you to a previous point) 
and redo (re-performs commands you 
undid) actions you’ve taken in a docu-
ment. The names of the Undo and Redo 
commands change to reflect the cur-
rent action. 

Flash supports 100 undo and redo 
levels. To change the number of undo 
levels, click the Edit (Win) or Flash 
(Mac) menu, click the General tab, 
specify a number in the Undo Levels 
box, and then click OK. The lower the 
number of levels, the less amount of 
memory the program needs to run.
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Resizing Panels

Minimize and Maximize Panels

To minimize or maximize a docking 
channel, click the Double-arrow 
button at the top of the panel 
group.

The double-arrow direction 
indicates whether the panel 
minimizes or maximizes. 

For example, if the double-arrow 
points to the left of the Tools panel 
that means when you click it the 
Tools panel minimizes. If the 
double-arrow points to the right 
that means when you click it the 
Tools panel maximizes.

1

If you need more workspace, you can use the double-arrow button (at 
the top of a panel group) to quickly minimize a panel group, such as the 
Tools panel or Property Inspector. When you click the double-arrow 
button, the panel group collapses to icons, which increases the size of 
the workspace. You can click the icons to display the panel. When you 
click the double-arrow button again, the panel group reopens. If you 
need to increase or decrease the size of a docking panel, you can drag 
the resize bar at the top-left side of the panel group to resize it as you 
would any window.

Double-arrow button; 
maximized panel

Double-arrow button; 
minimized panel

Drag to resize panel
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Using the Tools Panel

Show and Hide the Tools Panel

◆ To display the Tools panel, click 
the Window menu, and then click 
Tools to select the check mark.

◆ To hide the Tools panel, click the 
Window menu, and then click 
Tools to deselect the check mark. 

◆ To collapse and expand the Tools 
panel between one and two 
columns, click the double-arrows 
at the top of the Tools panel. 

The Tools panel, also known as the Toolbox, contains tools that you can 
use to draw, paint, select, and modify artwork. The Tools panel is 
divided into 4 main sections: (1) the first section at the top contains 
selection and transform tools; (2) the next section contains tools for 
drawing, painting, and adding text; (3) the next selection contains tools 
for changing, modifying, drawing and painting; and (4) the last section 
contains additional tool options for zooming and panning in the program 
window, changing stroke and fill colors, and selecting other options. 
You can show or hide the Tools panel as necessary and customize the 
Tools panel to display the tools you use most often. You can now 
expand and collapse the Tools panel to switch between one and two 
columns of tools. When you customize the Tools panel, you can display 
more than one tool in a location. The top tool in the group appears with 
an arrow in the lower right corner of its icon. When you click and hold 
the pointer on the top tool, the other tools in the group appear in a pop-
up menu. When you select a tool from the group, it appears in the Tools 
panel as the top tool.

Click to select (show) or 
deselect (hide) the check mark.

Click to expand and collapse 
Tools panel

Tools panel

Did You Know?
You can move the Tools panel. Drag 
the title bar or textured area at the top 
of the Tools panel to the desired 
location.
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Customize the Tools Panel

Click the Flash (Mac) or Edit menu 
(Win), and then click Customize 
Tools Panel.

Click a tool in the Tools panel 
graphic.

To add a tool, select the tool in the 
Available Tools list, and then click 
Add.

TIMESAVER You can add more 
than one tool to a location.

To remove a tool, select the tool in 
the Current Selection list, and then 
click Remove.

Click OK.5

4

3

2

1

5

2 3

4

Did You Know?
You can restore the Tools panel to the 
default layout. Click the Flash (Mac) or 
Edit menu (Win), click Customize Tools 
Panel, click Restore Defaults, and then 
click OK.

You can identify keyboard shortcuts 
for the Tools panel. In the Customize 
Tools Panel dialog box, the letter in 
parenthesis indicates the keyboard 
shortcut.

Creating Tools

Flash lets you design your own Tools, using the JSFL language. In 
addition you can download tools created by other authors at the 
Adobe Exchange at http://www.adobe.com/cfusion/exchange 
/index.cfm. Although Adobe has yet to properly document the JSFL 
language, point your browser to http://www.dynamicflash.co.uk/jsfl/ 
for a look at how JSFL is implemented in the Flash environment.

For Your Information
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Working with Panels

Open and Close a Panel

Click the Window menu.

Do one of the following:

◆ Click a panel name, such as 
Properties, Timeline, Tools, and 
Library.

◆ Point to a panel category, such 
as Other Panels, and then click 
a panel name. 

TIMESAVER To close a panel, 
click the Close button on the panel 
or the tab you want.

Collapse and Expand a Panel

To collapse or expand an open 
panel, click the header bar or 
double-click the title tab on the 
header bar of the panel.

TIMESAVER To hide and show 
all panels, click the Window menu, 
and then click Hide Panels.

TIMESAVER To Auto-Collapse 
Icon Panels or Auto-Show Hidden 
Panels, right-click (Win) or option-
click (Mac), and then select a 
command.

1

2

1

Panels are windows that allow you to view, organize, and change ele-
ments and related options in a document. In Flash, you work with sev-
eral panel windows at one time. Instead of continually moving, resizing, 
or opening and closing windows, you can collapse or expand individual 
panels within a window with a single click to save space. A panel 
appears with a header, which includes the tab titles and three accessi-
bility options: the Minimize/Maximize button, the Close button, and an 
Options menu. The entire set of panels includes a double arrow you 
can use the collapse and expand the entire panel between icons with 
text and full panels. You use the Minimize/Maximize button to collapse 
or expand panels. The Options menu provides you with panel specific 
commands, including group, rename, maximize, close a panel, and use 
the Help system.

Panels on Window menu

1

More panels on Window 
submenu

Collapsed panels

Expanded panel

1
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Collapse and Expand the Panel 
Set Between Icons and Panels

◆ To collapse the panel set to icons 
with text, click the double arrow 
pointing right (Collapse to Icons) at 
the top of the panels.

◆ To expand the panel set from icons 
with text to full panels, click the 
double arrow pointing left (Expand 
Dock) at the top of the panels.

◆ To have an expanded panel icon 
automatically collapse or hide 
when you click away, right-click 
(Win) or control-click (Mac) a 
panel, and then click Auto-
Collapse Icon Panels or Auto-
Show Hidden Panels.

Use the Panel Options Menu

Open or expand a panel.

Click the Options button on the 
right side of the panel header bar.  

Click a command from the list 
(commands vary). Common 
commands include:

◆ Help. Accesses Flash Help.

◆ Close. Closes the currently 
displayed tab in the panel.

◆ Close Group. Closes all the tabs 
in the panel.

3

2

1

3

Click to collapse the 
panel set

1

Click to expand the 
panel set

2
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Docking and 
Undocking Panels

Dock a Panel

Position the pointer on the panel 
tab or panel set header bar.

Drag the window away from the 
panel to a panel.

◆ Add to Panel. Drag to a panel 
until a blue rectangle appears 
around the panel.

◆ Append to Panel. Drag to a 
panel until a blue line appears 
along the side of the panel.

Undock a Panel

Position the pointer on the panel 
tab or panel set header bar.

Drag the window away from the 
panel to an empty area of the 
Flash window.

2

1

2

1

You can dock and undock, or temporarily attach and detach, panels or 
panel groups. You can display panels using the Window menu, and then 
drag them around the program window to dock or undock them to other 
panels. You can even drag the Property Inspector panel to display it hor-
izontally or vertically. However, document panels and the Stage cannot 
be docked. When you drag a panel over a dockable area, an outline 
around the target dock appears. When you release the mouse button, 
the panel snaps to the dockable area and stays there until you move it. 
You can even drag a panel tab to a new position. If you attempt to dock 
a panel over an undockable area, no outline appears. 

2

21

1
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Grouping and 
Ungrouping Panels

Group Panels Together

Position the pointer on the panel 
tab or panel set header bar.

Drag the window away from the 
panel to another panel window.

◆ Add to Panel. Drag to a panel 
until a blue rectangle appears 
around the panel.

◆ Append to Panel. Drag to a 
panel until a blue line appears 
along the side of the panel.

Ungroup Panels

Position the pointer on the panel 
tab or panel set header bar.

Drag the window away from the 
panel to an empty area of the 
Flash window.

2

1

2

1

You can group panels together to improve organization and workflow. 
When you group panels together, you can stack one on top of the other, 
or group related panels together as a tabbed panel group, such as the 
Component Inspector panel. You can add a panel to an existing panel 
group or you can create a new panel group. If you no longer need pan-
els grouped together, you can ungroup them. You can use the panel tab 
to group or ungroup as well as dock or undock panel windows. 

2

12

1
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Creating a Workspace

Create a Workspace

Open and position the panels you 
want to include in a panel set.

Click the Workspace menu (the 
menu name displays the current 
workspace), and then click New 
Workspace.

◆ You can also click the Window 
menu, point to Workspace, and 
then click New Workspace.

The New Workspace dialog box 
opens.

Type a name in the Name box.

Click OK.

The panel set is now saved.

Display a Workspace

Click the Workspace menu (the 
menu name displays the current 
workspace), and then select a 
panel option:

◆ Custom panel name. Displays a 
custom panel layout that you 
created.

◆ Animator, Classic, Debug, 
Designer, Developer, Essentials, 
or Small Screen. Displays panel 
layouts created by Adobe for 
specific purposes in Flash.

1

4

3

2

1

As you work with Flash, you'll open, close, and move around windows 
and panels to meet your individual needs. After you customize the Flash 
workspace, you can save the location of windows and panels as a 
workspace, or custom panel set, which you can display by using the 
Workspace menu on the Applications bar or the Workspaces submenu 
on the Window menu. You can create custom workspaces, or use a 
workspace provided by Flash, which are designed for space and work-
flow efficiency. The built-in workspaces include Classic, Debug, 
Designer, Developer, or Essentials. If you no longer use a custom work-
space, you can remove it at any time. You can also rename a custom 
workspace to improve recognition.

1

34

Custom panel

1

2

Workspace menu
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Delete a Workspace

Click the Window menu, point to 
Workspace, and then click 
Manage Workspaces.

The Manage Workspaces dialog 
box opens.

Select the panel set you want to 
delete.

Click Delete.

Click Yes to confirm the deletion.

Click OK.

The panel set is now deleted.

Rename a Workspace

Click the Window menu, point to 
Workspace, and then click 
Manage Workspaces.

The Manage Workspaces dialog 
box opens.

Select the panel set you want to 
rename.

Click Rename.

Type a new name, and then click 
OK.

The panel set is now renamed.

Click OK.5

4

3

2

1

5

4

3

2

1

5

3

2

5

3

2

Did You Know?
You can hide all panels. Click the 
Window menu, and then click Hide 
Panels to select the check mark.
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Creating Keyboard 
Shortcuts

Create a Keyboard Shortcut Set

Click the Flash (Mac) or Edit (Win) 
menu, and then click Keyboard 
Shortcuts.

Click the Current Set popup, and 
then select a set.

Click the Duplicate Set button.

Type a name for the new shortcut 
set.

Click OK.5

4

3

2

1

Flash uses built-in keyboard shortcuts designed specifically for Flash. A 
complete list of the keyboard shortcuts is available in the back of this 
book. The built-in keyboard shortcuts are organized into sets, which 
you can duplicate and customize to create your own personalized set. 
If you use other programs, such as Adobe Illustrator or Adobe 
Photoshop, and you are more comfortable using their keyboard short-
cuts for common commands, you can select a built-in keyboard short-
cut set from any of the graphics programs to use in Flash.

4

Delete 
button

2

5

3

Did You Know?
You can delete a custom keyboard 
shortcut set. Click the Flash (Mac) or 
Edit (Win) menu, click Keyboard 
Shortcuts, select a shortcut set from 
the Current Set popup, and then click 
the Delete button. You cannot delete a 
built-in keyboard shortcut set that 
comes with Flash.

You can rename a custom keyboard 
shortcut set. Click the Flash (Mac) or 
Edit (Win) menu, click Keyboard 
Shortcuts, select a shortcut set from 
the Current Set popup, click the 
Rename Set button, enter a new name, 
and then click OK. You cannot rename 
a built-in keyboard shortcut set that 
comes with Flash.
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Add or Remove a Keyboard 
Shortcut

Click the Flash (Mac) or Edit (Win) 
menu, and then click Keyboard 
Shortcuts.

Click the Current Set popup, and 
then select the set in which you 
want to change.

Click the Commands popup, and 
then select a shortcut category, 
such as Drawing Menu 
Commands, Drawing Tools, Test 
Movie Menu Commands, and 
Workplace Accessibility 
Commands.

Select the command for which you 
want to add or remove a shortcut 
in the Commands list.

Do the following:

◆ To add a shortcut, click the Add 
Shortcut (+) button, and then 
press the key combination to 
enter the new shortcut key in 
the Press Key box.

◆ To remove a shortcut, click the 
Remove Shortcut (-) button.

Click Change.

To add or remove additional 
shortcuts, repeat Steps 2-6.

Click OK.8

7

6

5

4

3

2

1

2

5

8Keyboard shortcut

4

3

6

Export keyboard shortcuts as HTML

You can now export Flash keyboard shortcuts as an HTML file that 
you can view and print using a standard Web browser. To export the 
keyboard shortcuts, click the Flash (Mac) or Edit (Win) menu, click 
Keyboard Shortcuts, click the Current Set list arrow, select the set 
you want, click the Export Set As HTML button, enter a file name, 
specify a location, and then click Save.

For Your Information
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Setting General 
Preferences

Set General Preferences

Click the Flash (Mac) or Edit (Win) 
menu, and then click Preferences.

Click the General category.

Select from the following options:

◆ On Launch. Select an option to 
specify which document opens 
when you start the program.

◆ Welcome Screen.

◆ New Document.

◆ Last Documents Open. 

◆ No Document.

◆ Undo Levels. Select Document 
or Object-level Undo, and then 
enter a value from 2 to 300 to 
set the number of undo/redo 
levels. The default level is 100.

◆ Open Test Movie In Tabs.
Select this check box to have 
Flash open a test movie in 
document tab.

◆ Auto-Collapse Icon Panels. 
Select this check box to 
automatically collapse the 
panel set to Icons only.

◆ Shift Select. Select or deselect 
this check box to control the 
selection of multiple elements.

3

2

1

Flash allows you to set general preferences to customize the way you 
work in the program. You can specify what you want to display or open 
when you launch Flash. Some of the preferences allow you to specify 
the number of undo levels, enable multiple selection, show tooltips, 
open documents and test movies in tabs, enable span-based selection 
in the Timeline, make the first frame of each scene in a document a 
named anchor, and select a specific selection highlight color for differ-
ent element types, such as drawings, groups, and symbols. You can 
also set Project preferences for closing and saving project files. In 
Flash, the Preferences dialog box is reorganized with new categories 
and options for ease of use, such as having have Flash open a new 
document tab instead of opening in its own window.  

2

3
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◆ Show Tooltips. Select to display 
tooltips when the pointer points 
to a button or control.

◆ Contact-Sensitive Selection 
and Lasso Tools. For the object 
drawing model, select to select 
objects when any part of the 
marquee touches it. Clear it to 
select objects that are 
completely enclosed by the 
marquee. Points within the 
selection will be selected.

◆ Show Axes For 3D Movie Clips. 
Select to show axes for 3d 
movie clips.

◆ Span Based Selection. Select 
to use span-based selection 
instead of frame-based 
selection.

◆ Named Anchor On Scene. 
Select to make the first frame of 
each scene in a document a 
named anchor. 

◆ Highlight Color. Select the Use 
Layer Color option to use the 
current layer’s outline color, or 
select the option, and then 
select a color for Drawing 
objects, Drawing primitives, 
groups, symbols, and other 
elements.

◆ Printing (Win). Select the 
Disable PostScript check box if 
you have problems printing to a 
postscript printer.

Click OK.4

3

4

Setting Drawing Model Options

You can draw shapes in Flash using two main drawing models: 
Merge Drawing and Object Drawing. Merge Drawing model automat-
ically merges shapes that you draw when you overlap them. If you 
select a shape that has been merged with another, and move it, the 
shape below it is moved too. For example, if you draw a square and 
overlay a circle on top of it, and then select the circle and move it, 
the portion of the square that overlaid the circle is removed. Object 
Drawing model allows you to draw shapes as separate objects that 
do not automatically merge together when overlaid. This lets you 
overlap shapes without altering their appearance should you choose 
to move them apart, or rearrange their appearance. Flash creates 
each shape as a separate object that you can individually manipulate. 
When you select a shape created using the Object Drawing model, 
Flash surrounds the shape with a rectangular bounding box. You can 
use the Pointer tool to move the object by clicking the bounding box 
and dragging the shape anywhere you’d like to position it on the 
Stage. You can now extend the Object Drawing mode by creating 
primitive rectangles and ovals in Primitive mode, which allows you to 
edit properties in the Property Inspector and specify the corner 
radius of rectangles and inner radius of ovals. This makes it easy to 
create pie wedges, round off corners, and other shapes.

For Your Information
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Setting Text 
Preferences

Set Text Preferences

Click the Flash (Mac) or Edit (Win) 
menu, and then click Preferences.

Click the Text category.

Select from the following options:

◆ Show Asian Text Options. Select 
to show Asian text options in the 
Property Inspector (New!).

◆ Show Right-To-Left Text Options. 
Select to show Direction options 
in the Property Inspector (New!).

◆ Font Mapping Default. Click the 
list arrow, and then select a font 
to use when substituting missing 
fonts. Click the Style list arrow, 
and then select a font style.

◆ Show For Missing Fonts. Select 
to show the Font Mapping dialog 
box.

◆ Vertical Text options.

◆ Default Text Orientation.
Select to make default 
orientation vertical, which 
is useful for Asian fonts. 

◆ Right To Left Text Flow.
Select to reverse the default 
text direction. 

◆ No Kerning. Select to turn 
off kerning for vertical text.

◆ Input Method. Select the Text 
Input Window check box (Mac) 
or language option to select a 
language type.  

◆ Font Menus. Select check boxes 
and option to show fonts in 
menus.

Click OK.4

3

2

1

When you edit or work with text in a Flash document, you can specify 
text related preferences. You can select a font to use when substituting 
missing fonts, or select text orientation options, which is useful when 
using English (horizontal) or Asian (vertical) language fonts. In addition, 
you can select a language as an input method.

2

3

4
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Setting Clipboard 
Preferences

Set Clipboard Preferences

Click the Flash (Mac) or Edit (Win) 
menu, and then click Preferences.

Click the Clipboard category.

Select from the following options:

◆ Bitmaps (Win). Select options 
for Color Depth and Resolution 
to specify these parameters for 
bitmaps copied to the 
Clipboard. Select Smooth to 
apply anti-aliasing. Enter a 
value in the Size Limit box to 
specify the amount of RAM that 
is used when placing a bitmap 
on the Clipboard.

◆ PICT Settings (Mac). Select 
Objects to preserve data 
copied to the Clipboard as a 
vector graphic, or select one of 
the bitmap formats to convert 
the image. Enter a value for 
Resolution. Select the Include 
Postscript check box to include 
Postscript data. For gradients, 
select an option to specify 
quality in the PICT.

◆ Gradient quality. Select an 
option to specify the quality of 
gradient fills placed in the 
Windows Metafile. 

Click OK.4

3

2

1

When you copy or cut graphics to the Clipboard, you can set prefer-
ences to determine how you want to paste the graphic into a Flash 
document. The preference options give you control over the size and 
quality of the graphics you insert in a document. If you are using 
Windows, the Clipboard preferences include options for bitmaps and 
gradients in the Windows Metafile format. If you are using a 
Macintosh, the Clipboard preferences include options for the PICT 
format.

Macintosh options

3 Windows
options

2

3

4
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Setting Warning 
Preferences

Set Warning Preferences

Click the Flash (Mac) or Edit (Win) 
menu, and then click Preferences.

Click the Warnings category.

Select from the following options:

◆ Warn On Save For Adobe Flash 
CS4 Compatibility. When you 
save documents with content 
features specific to Flash CS5.

◆ Warn On URL Changes In 
Launch And Edit. If the URL for 
a document has changed.

◆ Warn On Inserting Frames 
When Importing Content. When 
Flash inserts frames while you 
import audio or video files.

◆ Warn On Encoding Conflicts 
When Exporting ActionScript 
Files. When you create a 
document with different 
language characters for export.

◆ Warn On Conversion Of Effect 
Graphic Objects. When you 
attempt to edit a symbol with 
effects applied to it.

◆ Warn on sites with overlapped 
root folder. When you create a 
site in which the local root 
folder overlaps another site.

◆ Warn On Behavior Symbol 
Conversion. When you convert 
a symbol with a behavior 
attached to a symbol of a 
different type.

◆ Warn On Symbol Conversion. 
When you convert a symbol to 
a symbol of a different type.

3

2

1

Flash provides warning messages when you perform actions that might 
create problems for your document or lose important data. The warn-
ings help you avoid compatibility problems with Flash CS4 and charac-
ter corruption from encoding, which lets you know about missing fonts, 
URL changes, and symbol conversion. Additional warnings let you know 
when importing audio and video content inserts frames and when 
motion frames or target objects contain ActionScript. 

2

3
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◆ Warn On Automatically
Converting From Drawing Object 
To Group. When you convert an 
object drawn in Object Drawing 
mode to a group.

◆ Warn On Automatically 
Converting Objects To Drawing 
Objects.

◆ Show Incompatibility Warnings
On Feature Controls. When 
controls are not supported by 
the Flash Player version 
specified in Publish Settings. 

◆ Warn On Automatically 
Generating ActionScript Classes 
For Timelines. When you don’t 
create a class, Flash does.

◆ Warn On Compiled Clips 
Defining ActionScript Classes 
For Symbols. When you try to 
create ActionScript classes for 
symbols.

◆ Warn On Converting Multiple 
Selection To Symbol For Tween. 
When you don’t have a symbol 
to create a tween.

◆ Warn On Replacing Current
Tween Target. When you try to 
replace the current tween target

◆ Warn On Motion Frame Contains 
ActionScript.

◆ Warn On Motion Target Object 
Contains ActionScript.

◆ Warn On IK Bones Not Showing.

◆ Warn On Text Needs Embedded
Font. When a font is not avail-
able on your computer (New!).

◆ Warn On Clearing SWF History 
When Saving Template (New!).

◆ Warn On RSL Preloading Causes 
All Content To Download Before 
The First Frame Will Play 
(New!).

◆ Warn On Remove Default Value 
From RSL List (New!).

Click OK.4

3

4
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You can use the Page Setup dialog box in Macintosh to select the size 
and location in the printer of the paper you want to use. You can also 
select the page orientation (portrait or landscape) that best fits the 
entire document or any selection. Portrait orients the page vertically 
(taller than it is wide) and landscape orients the page horizontally 
(wider than it is tall). When you shift between the two, the margin set-
tings automatically change. Margins are the blank spaces between the 
edges of a page and the image. The printer only prints within these 
margins. You can use the Print Margins dialog box to change margins 
and layout. The layout options allow you to specify the frames you want 
to print, and the frame size and display on the page. 

Working with Page 
Setup in Macintosh

Work with Page Setup 
in Macintosh

Open a document.

Click the File menu, and then click 
Page Setup.

Click the Settings list arrow, and 
then click Page Attributes.

Select from the various Page 
Attributes options:

◆ Format For. Click the Format For 
list arrow, and then select a 
printer. If your printer is not 
accessible from the list, click 
the Edit Printer List, and then 
add your printer (you may need 
the printer disc, or access to 
the Internet, to load the latest 
drivers).

◆ Paper Size. Click the Paper Size 
list arrow, and then select from 
the available options. The 
default printer will determine 
the available paper sizes.

◆ Orientation. Click the Portrait, 
Landscape Left, or Landscape 
Right button.

◆ Scale. Enter a percentage 
value to increase (over 100) or 
decrease (under 100) the size of 
the printed document.

Click OK.5

4

3

2

1

4

3
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Change Print Margins and 
Layout in Macintosh

Open a document.

Click the File menu, and then click 
Print Margins.

Enter Left, Right, Top, and Bottom 
page margins, and then select the 
Center check boxes to center 
material on the page.

Select from the Layout options:

◆ Frames. Click the Frames list 
arrow, and then click First 
Frame Only or All Frames.

◆ Layout. Click the Layout list 
arrow, and then select a layout 
option: Actual Size, Fit On One 
Page, or one of the Storyboard 
options.

◆ Scale. Enter a scale 
percentage value.

Click OK.5

4

3

2

1

3

4
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You can use the Page Setup dialog box in Windows to select the size 
and location in the printer of the paper you want to use. You can also 
select the page orientation (portrait or landscape) that best fits the 
entire document or any selection. When you shift between the two, the 
margin settings automatically change. Margins are the blank spaces 
between the edges of a page and the image. You can also change page 
layout options, which allow you to specify the frames you want to print, 
and the frame size and display on the page. The printer only prints 
within these margins. Different printer models support different options 
and features; the available options depend on your printer and printer 
drivers.

Working with Page 
Setup in Windows

Work with Page Setup 
in Windows

Open a document.

Click the File menu, and then click 
Page Setup.

Select from the various Page 
Setup options:

◆ Margins. Enter Left, Right, Top, 
and Bottom page margins, and 
then select the check boxes to 
center material on the page.

◆ Size. Click the Size list arrow, 
and then select from the 
available options.

◆ Source. Click the Source list 
arrow, and then select from the 
available options.

◆ Orientation. Click the Portrait or 
Landscape option.

Select from the Layout options:

◆ Frames. Click the Frames list 
arrow, and then click First 
Frame Only or All Frames.

◆ Layout. Click the Layout list 
arrow, and then select a layout 
option.

◆ Scale. Enter a scale 
percentage value.

Click OK.5

4

3

2

1

4

3

5

 From the Library of Wow! eBook



ptg

Chapter 2 Working Within the Flash Environment 69

Set Printer Properties in 
Page Setup

Open a document.

Click the File menu, and then click 
Print.

TIMESAVER Press A+P 
(Mac) or Ctrl+P (Win).

Click the Name list arrow, and then 
select the printer you want to use.

Click Properties.

Select the printer options you 
want; each printer displays 
different options.

Click OK to close the Properties 
dialog box.

Click OK to close the Print dialog 
box.

7
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The Print command is probably the most used of all Flash's print 
options. In addition to normal printing functions, such as Copies and 
Pages, the Print command gives you other menus that let you control 
specific printing functions, such as output ink and color management. 
Understand that the options available for the Print command will be 
partially determined by the default printer. For example, if your default 
printer uses more than one paper tray, you will see options for select-
ing a specific tray for the current print job. In spite of the differences, 
there are some universal options to all print jobs, and these are cov-
ered here.

Printing a Document 
in Macintosh

Print a Document in Macintosh

Open a document.

Click the File menu, and then click 
Print.

Click the Printer popup, and then 
select from the available printer 
descriptions.

IMPORTANT Changes made 
here override any changes made 
in the Page Setup dialog box.

Click the Presets popup, and then 
select from the available preset 
options.

Select the various Copies & Pages 
options: Number Of Copies, 
Collated, Print All or Range Of 
Pages.

Click the Print Options popup, 
click Layout, and then select the 
various options: Pages Per Sheet, 
Layout Direction, and if you want a 
Border.

Click the Print Options popup, 
click Color Matching, and then 
select the option you want to 
match color using ColorSync (on 
your computer) or the printer.

7
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Click the Print Options popup, 
click Paper Handling, and then 
select your options.

Click the Print Options popup, 
click Scheduler, and then select 
the option you want to specify 
when you want to print the 
document.

Click the Print Options popup, 
click Summary, and then view the 
summary of settings.

Click the following options to 
finalize your print:

◆ PDF. Displays a menu to save a 
Flash document as a PDF with 
the option you want. The 
options include Fax PDF, Mail 
PDF, and Compress PDF.

◆ Preview. Displays a preview of 
the printed document

◆ Supplies. Displays an Apple 
Store Web site for printer 
supplies.

◆ Cancel. Stops a print job.

◆ Print. Prints the current 
document.

If you need additional help along 
the way, click the Help button.

12
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Printing a Document 
in Windows

Print a Document in Windows

Open a document.

Click the File menu, and then 
click Print.

TIMESAVER Press A+P 
(Mac) or Ctrl+P (Win).

If necessary, click the Name list 
arrow, and then click the printer 
you want.

Type the number of copies you 
want to print.

Specify the pages to print:

◆ All. Prints the entire document.

◆ Pages. Prints the specified 
pages.

◆ Selection. Prints the selected 
item.

Click OK.6

5

4

3

2

1

Printing a paper copy is the most common way to preview and share 
your documents. You can use the Print dialog box to set how many 
copies to print, specify a range of pages to print, and print your docu-
ment. Understand that the options available for the Print command will 
be determined by the default printer, and operating system. Different 
printers will display different options; there are some options that are 
fairly universal, and these options are covered here.
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Creating Graphics

Introduction

Flash offers a full suite of tools for creating and editing 
graphics. When you draw in Flash, you create vector art. 
Vectors are mathematical descriptions of lines and points 
that, when connected, form shapes and objects. Vector-
defined art is not limited by resolution like bitmaps are, so 
they can be scaled to any size without a loss in quality or 
increase in file size. This is the basis of Flash; and the main 
reason Flash files are so small and why they can be deployed 
on so many platforms. Vector graphics are also fully editable 
after they are created so you can continue to adjust their 
properties. Included in Flash are many of the drawing tools 
and procedures familiar to the seasoned user of vector draw-
ing programs. It is also a good place for the beginner to 
learn. Sketch naturally with the Pencil and Brush tools or use 
vector-based objects, such as the Rectangle or Oval tools or 
the Polystar tool. Use the Pen tool to create lines and shapes 
with Bézier curves. Whatever is drawn can be edited and 
modified with a variety of tools and palettes. When you select 
an object or graphic on the Stage, the Property Inspector dis-
plays the attributes of that object that are modifiable, such as 
fill and stroke color, position, and scale. 

You can draw shapes in Flash using two drawing models: 
Merge Drawing and Object Drawing. The Merge Drawing
model, the default (like previous versions of Flash), automati-
cally merges shapes that you draw when you overlap them.
If you select a shape that has been merged with another, and 
move it, the shape below it is moved too. The Object Drawing
model allows you to draw shapes as separate objects that do 
not automatically merge together when you overlap them. 
You can now extend the Object Drawing mode by creating 
primitive rectangles and ovals in Primitive mode, which 
allows you to edit properties in the Property Inspector and 
specify the corner radius of rectangles and inner radius of 
ovals. This makes it easy to create pie wedges, round off cor-
ners, and other curved shapes.

3

3
What You’ll Do

Work with Object Drawing

Draw Lines and Shapes

Use the Selection Tools

Zoom In and Out

Move Around with the Hand Tool

Use Rulers, Grids, and Guides

Modify Grid and Guide Settings

Use Snap Align

Change Stroke and Fill Colors

Create Custom Colors

Add Colors Using the Kuler Panel

Edit Strokes with the Ink Bottle

Edit Fills with the Paint Bucket

Use the Spray Brush and Deco Tools

Edit Strokes and Fills with the 
Eyedropper

Create Gradients

Use the Fill Lock

Use Paint Brush Modes

Draw with the Pen Tool

Modify Shapes

Use the Free Transform Tool

Use Transform Options for Shapes

Change Drawing Settings

73
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Working With Object 
Drawing

Enable and Use Object Drawing

Select a drawing tool on the Tools 
panel that supports Object 
Drawing (Pencil, Line, Pen, Brush, 
Oval, Rectangle, and Polygon). 

Select the Object Drawing button 
on the Tools panel.

TIMESAVER Press the J key to 
toggle between Merge and Object 
Drawing.

With the Pointer tool, click to 
select an object, and then drag the 
bounding box to move it.

To switch back Merge Drawing, 
click the Object Drawing button 
again.

4

3

2

1

Previously in Flash, all shapes in the same layer on the Stage could 
change other overlapping shapes, known as Merge Drawing. In Flash, 
you can create shapes directly on the Stage that do not affect other 
overlapping shapes, known as Object Drawing. By default, Flash uses 
Merge Drawing. To draw shapes using Object Drawing, you use the 
Object Drawing button on the Tools panel. When you select a shape 
created using Object Drawing, Flash selects the shape with a rectangu-
lar bounding box, which you can use with the Pointer tool to move the 
shape on the Stage. You can use General preferences to set selection 
options for contact-sensitivity when selecting shapes created using 
Object Drawing.

1

2

Bounding box

Objects created 
with Object Drawing

3

See Also
See “Setting General Preferences” on 
page 60 for information on options for 
contact-sensitivity when selecting 
shapes created using Object Drawing.

Did You Know?
You can convert a Merge Drawing 
shape to an Object Drawing shape. 
Select the shape on the Stage, click 
the Modify menu, point to Combine 
Objects, and then click Union. 
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Drawing with the 
Line Tool

Use the Line Tool

Click the Line tool on the Tools 
panel.

The pointer becomes a crosshair 
that you can drag on the Stage.

TIMESAVER Press N to select 
the Line tool.

Click and drag on the Stage, and 
then release the mouse when the 
line is the length you need. 

TIMESAVER Hold down the 
Shift key, and then drag to draw a 
45, 90, or 180 degree line. 

To change line properties, click to 
select the stroke, and then specify 
the options (Color, Weight (0-200), 
Style, Width and Height, Cap, Join, 
or Miter) you want in the Property 
Inspector.

TROUBLE? To display the 
Property Inspector, click the 
Window menu, and then click 
Properties.

3

2

1

The Line tool draws perfectly straight lines in any direction you drag 
your mouse. In Flash, a line is called a stroke and there is a variety of 
thicknesses (0-200 pixels), styles, colors, and gradient fills that can be 
applied to it. You can also create your own line style for specific types 
of dashed, dotted or artistic lines. You can constrain the path a line 
draws to 45-degree angles or create closed shapes by intersecting the 
lines you draw. In Merge Drawing when a line overlaps another line on 
the same layer, it essentially cuts it into two pieces that can be edited 
as separate objects. You can also specify a line cap and join type. A 
join is the place where two strokes meet (Miter, Round, or Bevel). A 
cap is the end point of a stroke that does not join with another stroke. 
Select Stroke hinting to make stroke intersections easier to view. 

Cap and Join 
options

See Also
See “Changing Stroke and Fill Colors” 
on page 96 for information on using 
color.

Stroke width 
and height

Fill Color

Stroke Scale 
and Hinting

Stroke Weight 
and Style

Stroke Color

3

2 A preview of the line appears as you 
drag. A circle beneath the crosshair 
indicates the line's endpoint. 

Stroke join

1
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Drawing with the 
Pencil Tool

Use the Pencil Tool in 
Straighten Mode

Click the Pencil tool on the Tools 
panel.

The pointer becomes a pencil. The 
Pencil tool options appear at the 
bottom of the Tools panel. The 
default mode is Straighten.

TIMESAVER Press Y to select 
the Pencil tool.

Draw on the Stage with the Pencil, 
and then release the mouse. 

A rough preview of the line 
appears as you draw. In Straighten 
mode, Flash transforms the line 
into a series of straight-line 
segments and standard curves.

To change the straighten rate, 
select the object, click the Modify 
menu, point to Shape, click 
Advanced Straighten, enter a 
value, and then click OK.

3

2

1

Use the Pencil tool for freeform drawing. When you draw with the 
Pencil tool you are creating strokes. It works the same way as a real 
pencil with options for smoothing and straightening. Depending upon 
which mode you choose, Flash makes corrections to the drawn line. 
Smooth mode softens the curve of the line you draw while Straighten 
mode transforms the line into a series of straight-line segments and 
standard curves. If you are using the Pencil or Brush tools with Smooth 
mode, you can specify the degree of smoothness. Additionally, Flash 
performs shape recognition to the lines you draw so that if it detects 
something approximating a simple geometric shape such as a rectan-
gle, oval, or triangle, it converts your drawing into whichever shape it 
detects. To bypass these modifications, select Ink mode. This mode 
allows for the most freeform drawing with minimal correction by Flash.

Pencil mode is set to 
straighten by default.

Flash straightens 
the drawn line.

Flash applies shape recognition 
in Straighten mode. 

2

Did You Know?
Flash converts rough shapes into 
clean, geometric shapes. Set the toler-
ance level of shape recognition in the 
Drawing preferences. 

1
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Use the Pencil Tool in 
Smooth Mode

Click the Pencil tool on the Tools 
panel.   

The pointer becomes a pencil. The 
Pencil tool options appear at the 
bottom of the Tools panel. 

Click the Pencil mode list arrow in 
the Options area of the Tools 
panel, and then click Smooth.

In the Property Inspector, click the 
Smoothing list arrow, and then 
click a value from 1 to 100. 

The default value is set to 50. The 
greater the smoothing value, the 
smoother the resulting line. 

TROUBLE? To display the 
Property Inspector, click the 
Window menu, and then click 
Properties.

Draw on the Stage with the Pencil, 
and then release the mouse.

A rough preview of the line 
appears as you draw. In Smooth 
mode, Flash smoothes the line you 
draw into curved line segments.

To change the smooth rate and 
angles (above and below), select 
the object, click the Modify menu, 
point to Shape, click Advanced 
Smooth, enter a value, and then 
click OK.

5

4

3

2

1

4 Flash smoothes 
the drawn line.

Use Ink mode for more 
freeform drawing.

Did You Know?
You can disable straightening and 
smoothing. Click the Pencil mode list 
arrow in the Options area of the Tools 
panel, and then click Ink mode to yield 
a line closest to the line you've drawn 
with minimal corrections 
performed by Flash.

Smoothing Curves Another Way
You can also smooth curves by optimizing the shape. Optimizing a 
shape refines curved lines and fill outlines by reducing the number 
of curves used to define the shape. To optimize a shape, click it, click 
the Modify menu, point to Shape, click Optimize, specify a smoothing 
level, select additional options (select Use Multiple Passes to repeat 
the smoothing process until you can’t anymore, and select Show 
Totals Message to display an alert when smoothing is complete), and 
then click OK.

For Your Information

1

3

2

5

Select to display a live preview of 
your changes
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Drawing Shapes with 
the Rectangle and 
Oval Tools

Draw with the Oval Tool 

Click the Oval or Oval Primitive 
tool on the Tools panel. 

TIMESAVER Press O to select 
an Oval tool.

Select a Stroke and Fill Color from 
the Colors area of the Tools panel.

Click and drag on the Stage, and 
then release the mouse. 

TIMESAVER Press and hold 
Shift while you drag to create a 
circle.

In the Properties Inspector, 
change the values you want. 

Draw with the Rectangle Tool 

Click the Rectangle or Rectangle 
Primitive tool on the Tools panel. 

TIMESAVER Press R to select 
a Rectangle tool.

Select a Stroke and Fill color from 
the Colors area of the Tools panel. 

Click and drag on the Stage, and 
then release the mouse. 

TIMESAVER Press and hold 
Shift while you drag to create a 
square.

In the Properties Inspector, 
change the values you want. 

4

3

2

1

4

3

2

1

The Flash Tools panel includes several tools for quickly creating simple 
geometric vector shapes. They are easy to use; you just click and drag 
on the Stage to create the shapes. The Rectangle tool creates rectan-
gles with square or rounded corners. The Oval tool creates circular 
shapes such as ovals and circles. These shapes can be comprised of 
Strokes, which are lines that surround and define the shape, Fills, which 
are a color or texture inside the shape, or both. You can create two 
types of shapes: Drawing or Primitive. Drawing, or standard, shapes are 
self contained; the stroke and fill of a shape are not separate elements, 
while for Primitive shapes they are separate elements. 

3

1

2

3

1

2
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Draw a Rounded Rectangle

Click the Rectangle or Rectangle 
Primitive tool on the Tools panel. 

Enter a value for the corner radius 
in the Properties Inspector. 

To create an exact size rectangle 
shape, select the shape, enter the 
width and height values in the 
Properties Inspector. 

Click and drag on the Stage, and 
then release the mouse. 

4

3

2

1
5 points 20 points 35 points

Did You Know?
You can enter values ranging from 0 to 
100 points in the Rectangle Settings 
dialog box. A value of zero gives you a 
straight-sided-square. Higher numbers 
produce squares with more rounded 
sides.

You can hold down the Shift key while 
dragging to produce a perfect square 
with equal sides or a perfect circle. If 
you want to draw an oval or a rectan-
gle without a stroke or fill, you can set 
either of these options to No Fill in the 
Colors area of the Tools panel or in the 
Color panel.

You can draw shapes without a stroke 
or a fill. Set either of these properties 
to No Fill in the Colors section of the 
Tools panel or in the Color panel.

You can set specific sizes with a dia-
log box. Alt+click (Win) or Option+click 
(Mac) a rectangle or oval, set the val-
ues you want, and then click OK. 

See Also
See “Changing Stroke and Fill Colors” 
on page 96 for information on changing 
shapes.

Creating Primitive Rectangles and Ovals
In addition to creating standard rectangles and ovals, you can now 
create Primitive rectangles and ovals. A Primitive shape allows you 
to change its attributes in the Property Inspector. The Primitive 
shape tools allow you to specify the corner radius of rectangles, and 
the start and end angle and the inner radius of ovals using controls 
in the Property Inspector, which makes it easy to create pie wedges, 
rounded corners, and other curved shapes. When either of the 
Primitive shape tools is selected, the Property Inspector retains the 
values of the last primitive object that you edited.

For Your Information

24

1

3
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Using the Polystar 
Tool

Draw a Polygon or Star Shape

Click and hold the Rectangle tool 
on the Tools panel, and then point 
to PolyStar Tool.

The pointer becomes a crosshair 
that you can drag anywhere on the 
Stage.

Click Options in the Property 
Inspector. 

TIMESAVER Press A+F3 
(Mac) or Ctrl+3 (Win) to open the 
Property Inspector.

Click the Style list arrow, and then 
select Polygon or Star.

Enter a value for the number of 
sides. You can create an object 
with up to 32 sides.

For the Star style, you can specify 
an additional option for your point 
size. You can enter a value ranging 
from .10 to 1.0 points.

Click OK.

Click and drag on the Stage, and 
then release the mouse.

7

6

5

4

3

2

1

Working in much the same way as the Oval and Rectangle tools, the 
new Polystar tool allows you to easily create complex vector shapes. 
You can use this tool to create polygons and stars with up to 32 sides. 
Choose between creating a polygon or a star. Both styles have charac-
teristics that can be adjusted in the Property Inspector before you draw 
the shape. Both the polygon and star style can have up to 32 sides, with 
the star style having an additional star point size that can be set. 
Experiment with several options to get the kind of shape you want.

5

4

3

1

6See Also
See “Editing Strokes with the Ink 
Bottle” on page 102 for information on 
editing an object. 

7 Polystar shape

2
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When you create vector graphics in Flash, 
they are comprised of distinct elements that 
can be selected separately or as a whole with 
a variety of selection tools. The type of editing 
you need to perform determines which tool 
you use. For example, a simple rectangle 
drawn is comprised of four line segments that 
surround the contour of the shape and one fill 
in the center. Each of these five parts can be 
selected in tandem or individually with the 
Selection tool. Likewise, any stroke that inter-
sects another stroke or fill splits them into dis-
tinct elements that can be selected separately. 

In Normal selection mode, holding down 
the Shift key adds to the selection any addi-
tional elements you click on. You can change 
this option in the General tab of the 
Preferences window so that it isn't necessary 
to use the Shift key to perform this function. 
Double-click any stroke to select other strokes

connected to it or double-click a fill to select it 
and any strokes that touch or intersect it. To 
select an entire shape (strokes and fills) or 
just a portion of it, you can drag a selection 
rectangle with the Selection tool or draw a 
freeform selection area with the Lasso tool. 
These methods work best for very complex 
shapes with many intersecting strokes and 
fills, or if there is only a portion of the shape 
you need to edit.

The Sub-Selection and Pen tools allow you 
to select the entire shape (strokes and fills) 
simultaneously, making its anchor points and 
Bézier handles visible for editing. Use this 
method when you need to edit the contours 
of the shape with precision.

For information on making selections 
using the Object Drawing model, see 
“Working with Object Drawing”, on page 74.

Understanding Selections

Each element (4 
lines and a fill) can 
be selected 
separately.

Shift-select to 
add elements to

the selection.

Single line segment. When two line segments 
intersect, four new line

segments are created that 
can be selected separately.

Double-click a fill 
to select it and any 
connected strokes.

Double-click a 
stroke to select all

connected 
strokes.

Click and drag to 
select a portion of 
the shape.

Only a portion of 
the fill and strokes 
is selected.

Selection Examples
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Selecting Strokes 
with the Selection 
Tool

Select a Stroke with the 
Selection Tool 

Click the Selection tool on the 
Tools panel. 

The pointer becomes an arrow.

TIMESAVER Press V to select 
the Selection tool.

Position the arrow on the edge of 
the shape. 

Notice that Flash displays a small 
curved line icon when you position 
the arrow over a Curve point and a 
corner line icon when over a 
Corner point.

Click on any part of the stroke. 

Flash only selects a portion of it. 
This is because what appears to 
be one whole shape is actually a 
series of lines connected by points 
and each can be selected 
separately.  

3

2

1

There are several ways to select objects in Flash. You can select an 
object's stroke or fill or both. You can use the Selection tool to select 
parts of the object or drag over a portion of it to create a selection rec-
tangle. The Property Inspector displays the properties of what is 
selected including Stroke line weight and style, Fill color, pixel dimen-
sions, and X and Y coordinates. When a stroke or fill is selected, a dot-
ted pattern appears over it indicating it has been selected. This makes 
editing and modifying graphics simple and illustrates the versatility of 
the vector-based graphics model used in Flash.

2 Curve point detected

Corner point detected 

See Also
See “Working with Object Drawing” on 
page 74 for information on selecting 
overlapping objects on the same layer.

3

1
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Select Multiple Stroke 
Segments

Click the Selection tool on the 
Tools panel.

The pointer becomes an arrow. 

TIMESAVER Press V to select 
the Selection tool. You can 
temporarily switch to the Selection 
tool from any other tool by 
pressing A (Mac) or Ctrl (Win).

Click on any part of the stroke to 
select one segment.

Hold down the Shift key, and then 
click other strokes to add them to 
the selection.

Select Connected Stroke 
Segments

Click the Selection tool on the 
Tools panel. 

The pointer becomes an arrow.

Double-click any part of the 
segment or stroke to select all 
connected strokes.

2

1

3

2

1

32

1

Shift-select to add stroke segments 
to the selection.

2 All connected stroke segments selected.

Did You Know?
You can turn off the Shift-select 
feature in the General tab of the 
Preferences dialog box. When this 
feature is disabled, you can add to the 
selected segments by clicking them 
without the need to hold down the Shift 
key. In this mode, holding the Shift key 
and clicking a selected stroke segment 
deselects that segment.

1
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Selecting Strokes 
and Fills with the 
Selection Tool

Select Fills with the Selection
Tool 

Click the Selection tool on the 
Tools panel. 

The pointer becomes an arrow.

Position the arrow in the Fill area 
or the center of the shape and 
click.

The fill becomes highlighted with a 
dotted pattern to indicate it has 
been selected. Hold down the Shift 
key to add other strokes and fills to 
the selection.

Select with a Selection 
Rectangle

Click the Selection tool on the 
Tools panel. 

The pointer becomes an arrow.

Click on the Stage above and to 
the left of the shape you want to 
select and drag to create a 
Selection Rectangle, and then 
release the mouse when the 
bounding box fully encloses the 
shape.

2

1

2

1

The Selection tool provides the most simple and versatile procedures 
for selecting objects in Flash. The Selection tool selects anything you 
click on (provided it isn't on a locked layer). Double-clicking shapes 
with the Selection tool selects all fills and strokes that are connected. 
Shift-selecting allows you to add to the selection only what you need. 
Alternately, dragging a selection rectangle on the Stage with the 
Selection tool creates a bounding box that selects anything you drag it 
over. This bounding box method is the most reliable technique for 
selecting very complex objects with many intersecting strokes and fills.

Selected fill

Double-clicking 
the shape selects 
both the fill and 
the stroke.

Both fill and strokes are selected.

1

2

2

1
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Making Selections 
with the Lasso Tool

Select with the Lasso Tool

Click the Lasso tool on the Tools 
panel.

TIMESAVER Press L to select 
the Lasso tool.

Draw around the shapes you want 
to select. 

To complete the selection, return 
to the point where you started.

Select with the Lasso Tool in 
Polygon Mode 

Click the Lasso tool on the Tools 
panel.

Click the Polygon Mode button in 
the Options area of the Tools 
panel.

Click near the area you want to 
select. Move the pointer and click 
again. Keep clicking until the 
object or portion you want to 
select is surrounded.

Double-click to complete the 
selection.

4

3

2

1

3

2

1

Use the Lasso tool when you want to select shapes that are too close 
to shapes you don't want to select. This tool allows you to draw around 
the shape, selecting everything contained in the shape you draw. In the 
default mode, you can draw a freeform lasso around the object you 
want to select. You can also choose the Polygon mode for defining the 
selected area with a series of straight-line segments.

Selected shape

Selected shape2

1

Did You Know?
You can select single or multiple 
objects. Holding the Shift key adds line 
segments and fills them. Shift-clicking 
selected items deselects them. 

1

2

3

Flash draws a preview of the 
selection lasso as you draw.
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Zooming In and Out 
with the Magnifying 
Glass

Zoom In 

Click the Zoom tool on the Tools 
panel.   

Click the Enlarge button in the 
Options area of the Tools panel. 

The pointer becomes a magnifying 
glass with a plus (+) symbol in it.

Click on the area of the Stage you 
want to zoom into.

TIMESAVER Press Z to select 
the Zoom tool. To temporarily 
toggle between the Enlarge and 
Reduce Modifiers buttons in the 
Options area of the Tools panel, 
press Option (Mac) or Alt (Win).

Zoom Out 

Click the Zoom tool on the Tools 
panel.

Click the Reduce button in the 
Options area of the Tools panel. 

The pointer becomes a magnifying 
glass with a minus (-) symbol in it.

Click on the area of the Stage you 
want to zoom out from.

3

2

1

3

2

1

Because the Stage and Work Area in Flash share the same space with 
a variety of panels, palettes and windows, it is often necessary to 
change the magnification level. You can use the Magnifying Glass to 
zoom out and see the entire piece or zoom in to do more detailed work 
on a small portion. The tool is made up of two modifiers: a plus (+) sym-
bol in the circle indicates enlargement of the Stage and a minus (-) indi-
cates reduction. Flash allows magnification levels from 8 percent to 
2000 percent. 

3

3

1

2

2

1
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Zoom Into a Specific Area by 
Dragging on the Stage

Click the Zoom tool on the Tools 
panel.

Click the Reduce or Enlarge button 
in the Options area of the Tools 
panel.

Click on the area of the Stage you 
want to magnify and drag the 
pointer. 

3

2

1

3

Did You Know?
You can change the magnification 
level in several places. The Zoom 
Control field in the top right hand cor-
ner of the Stage allows you to enter a 
value or access a list arrow with vari-
ous magnification levels. You can also 
change the magnification submenu in 
the View menu or use the keyboard 
shortcuts A+ - (Mac) or Ctrl+ - (Win) 
to zoom out, and A+ + (Mac) or 
Ctrl+ + (Win) to zoom in. Quickly switch 
to 100 percent magnification by press-
ing A+1 (Mac) or Ctrl+1 (Win). 

2

1
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Moving Around with 
the Hand Tool

Move the Stage View

Click the Hand tool on the Tools 
panel.

The pointer becomes a small hand 
that moves the entire Stage 
revealing other parts of the Stage 
as you drag.

TIMESAVER Pressing the 
space bar temporarily changes the 
active tool to the Hand tool. 
Continue holding as you drag.

Click and drag the Stage to move 
the view. 

2

1

At certain magnifications, parts of the Stage may not be viewable. Use 
the Hand tool to quickly move to different parts of the Stage without 
having to change the magnification level. The Stage is the active area 
of your movie, the only area that will be visible in the exported Flash 
movie. The gray area around the Stage is the work area called the 
pasteboard, which you can use to store artwork and other objects 
without having them be visible in the published movie. The objects 
might not be visible on the Stage, but they contribute to the overall file 
size. It is a good idea to clean up your files before exporting the final 
movie. The Hand tool allows you to easily access objects contained on 
the pasteboard if you are doing detailed work at high magnification. 

2

Did You Know?
You can turn off the visibility of the 
Work Area (the gray space around the 
Stage) and quickly change the View 
scale to 100 percent. Toggle the Work 
Area option in the View menu or use 
the keyboard shortcut A+Shift+W 
(Mac) or Ctrl+Shift+W (Win). This is a 
great way to temporarily see what is 
viewable in the exported Flash SWF file 
when you are working with large 
images that extend past the Stage 
boundaries.

Using the Info Pane
The Info pane display information about objects on the Stage. Click 
the Window menu, and then click Info. The Info pane displays width
(W), height (H), object position (X, Y), mouse position (X, Y), and color 
info Red, Green, Blue, and Alpha (R, G, B, A). The W and H values 
display live info (New!) while you draw or resize an object. The X 
and Y values display live info (New!) while you move an object. The 
RGBA values display when you move the pointer over a symbol 
(New!).

For Your Information

1
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Displaying Rulers

Show and Hide Rulers 

Click the View menu, and then 
click Rulers.

A check mark next to the option 
means its visibility is enabled.

To hide rulers, click the View 
menu, and then click Rulers to 
remove the check mark and hide 
the rulers. 

TIMESAVER Press 
A+Option+Shift+R (Mac) or 
Ctrl+Alt+Shift+R (Win) to turn 
the ruler on and off.

2

1

Ruler bars are located on the top and left sides of the Stage and serve 
several purposes. They let you measure the width and height of Flash 
elements and they let you place guides on the screen to control place-
ment of objects on the Stage. In all, Rulers serve a very important role. 
When you display rulers, you can use guides to help you correctly align 
objects with other objects. By using guides, you have access to precise 
alignment systems. To use the guides, the ruler bars must first be visi-
ble. When you no longer need the rulers, you can hide the rulers to free 
up more workspace.

1

Vertical ruler

Horizontal ruler

Did You Know?
You can change the unit of measure 
displayed on the Rulers. Click the 
Modify menu, click Document, click the 
Ruler Units list arrow, select a unit of 
measure, and then click OK. Using the Pasteboard Work Area

You can use the work area (called the Pasteboard) around the Stage 
to store artwork and other objects, such as components, without 
having them be visible in the published movie. The objects might not 
be visible on the Stage, but they contribute to the overall file size. It 
is a good idea to clean up your files before exporting the final movie. 
You can clean up by removing any artwork outside the boundaries of 
the Stage or by putting them on a guide layer. 

For Your Information
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Using Grids and 
Guides

Show and Hide Grids 

Click the View menu, point to Grid, 
and then click Show Grid.

◆ You can also right-click (Win) 
or control-click (Mac) the 
Stage, point to Grid, and then 
click Show Grid.

A check mark next to the option 
means its visibility is enabled.

To hide the grid, click the View 
menu, point to Grid, and then click 
Show Grid to remove the check 
mark and hide the grid.

TIMESAVER Press 
A+apostrophe (') (Mac) or 
Ctrl+apostrophe (') (Win) to toggle 
Grid visibility on and off.

2

1

Flash comes with guides, grids, and rulers to help you lay out artwork 
and objects with precision. A grid is a series of crisscrossed lines that 
aid in aligning objects to each other on the Stage. Guides and grids are 
modifiable. You can change their visibility, position, color, and fre-
quency. These items are invisible by default, but they can be easily 
turned on and adjusted. Though you see them in the Flash development 
environment, they are invisible on export. Use guides to align art and 
objects to each other on vertical or horizontal paths, or turn on the grid 
for use in designing a layout that is proportional and balanced. 

1 Grid when visible

See Also
See “Modifying Grid and Guide 
Settings” on page 92 for information on 
changing settings.
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Create Guides

Click the View menu, and then 
click Rulers to display rulers. 

Click on the vertical ruler on the 
left side of the work area with the 
Arrow pointer and drag to the 
right, and then release the mouse 
where you want to place the 
vertical guide. 

A small directional triangle and 
line appears next to the pointer as 
you drag indicating that you are 
dragging the guide.

Click on the horizontal ruler at the 
top of the work area with the 
Arrow pointer and drag down, and 
then release the mouse where you 
want to place the horizontal guide.

Reposition the guides by selecting 
them with the pointer.

4

3

2

1 
1

Did You Know?
You can turn guide visibility on and 
off, lock guides, and enable or disable 
snapping to guides. Click the View 
menu, and then click Guides to access 
these options or use the following 
keyboard shortcuts: A+; (Mac) or 
Ctrl+; (Win) toggles between showing 
and hiding guides. Option+A+; (Mac) 
or Ctrl+Alt+; (Win) locks and unlocks 
guides. Shift+A+; (Mac) or Ctrl+ 
Shift+; (Win) turns Snapping on and off.

See Also
See “Displaying Rulers” on page 89 for 
information on showing and hiding 
rulers.

2

3
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Modifying Grid and 
Guide Settings

Modify Grid

Click the View menu, point to Grid, 
and then click Edit Grid.

TIMESAVER Press 
Option+A+G (Mac) or Ctrl+Alt+G 
(Win) to quickly access the Grid 
dialog box.

Click the Color list arrow, and then 
click a grid line color.

Select or clear the Show Grid 
check box to show or hide the 
grid.

Select or clear the Show Over 
Objects check box to show or hide 
the grid over objects.

Select or clear the Snap To Grid 
check box to enable or disable 
snapping.

Enter values for horizontal and 
vertical dimensions for the grid 
lines.

Click the Snap Accuracy list 
arrow, and then select a level of 
sensitivity for snapping to the grid. 
Select from Must Be Close, 
Normal, Can Be Distant, and 
Always Snap.

To make the current grid settings 
the default for new Flash files, 
click the Save Default button.

Click OK.9

8

7

6

5

4

3

2

1

The need for grids and guides varies depending upon the type of docu-
ment you are working on. They are useful for aligning text and graphics 
to interface elements and are an invaluable tool for creating a well 
composed and proportioned layout. Every project is different and has 
different requirements, so Flash allows the display, behavior, and char-
acteristics of guides and grids to be altered to fit your needs. They are 
only visible in the Flash development environment, and are not exported 
in the Flash movie.

7

2 35 4

9

8

6
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Modify Guides

Click the View menu, point to 
Guides, and then click Edit Guides.

TIMESAVER Press 
Option+Shift+A+G (Mac) or 
Ctrl+Alt+Shift+G (Win) to quickly 
access the Guides dialog box.

Click the Color list arrow, and then 
click a guide line color. 

Select or clear the Show Guides 
check box to show or hide guides.

Select or clear the Snap To Guides 
check box to enable or disable 
snapping.

Select or clear the Lock Guides 
check box to enable or disable 
movement of guides.

Click the Snap Accuracy list arrow, 
and then select a level of 
sensitivity for snapping to the 
guides. Select from Must Be 
Close, Normal, Can Be Distant.

To remove all guides from the 
active scene, click Clear All.

To make the current guides the 
default guides for new Flash files, 
click Save Default.

Click OK.

TIMESAVER Press A+; (Mac) 
or Ctrl+; (Win) to toggle between 
showing and hiding guides; press 
Option+A+; (Mac) or Ctrl+Alt+; 
(Win) to lock and unlock guides; or 
press Shift+A+; (Mac) or 
Ctrl+Shift+; (Win) to turn Snapping 
on and off.

9

8

7

6

5

4

3

2

1

6

2 4 5

9

7

8

3
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Using Snap Align

Enable Snap Align

Click the View menu, point to 
Snapping, and then click 
Snap Align.

A check mark appears next to the 
menu item when Snap Align is 
enabled.

Drag an object on the Stage.

Depending on the behaviors set in 
the Snap Align Settings dialog box, 
gray dashed lines appear when 
the edges or center vertices of 
objects move to within a certain 
pixel distance.

2

1

Snap Align is a new feature that enables dynamic alignment of art and 
objects on the Stage. Simply drag an object on the Stage and dashed 
lines appear that aid you in aligning to the edge or center vertices of 
other objects on the Stage. In the Edit Snapping dialog box you can 
enable and disable snap options, set the distance objects are to be 
from the movie borders and from each other before they snap, and 
save the settings as default. Additionally, you can choose to snap 
objects to edges or vertical and horizontal centers. Using the Snap 
Align feature enables you to lay out artwork more precisely and 
dynamically.

1

Edge Align Edge Align

Center Align 
Horizontal

Center Align 
Vertical

Snap Align to other 
items: Grid, Guides, 
Pixels, and Objects.

Did You Know?
You can change snapping tolerances.
Click the Flash (Mac) or Edit (Win) 
menu, and then click Preferences. 
Click the Drawing category, use the 
Connect Line list arrow to select an 
option, and then click OK. 
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Configure Snap Align and 
Save Defaults

Click the View menu, point to 
Snapping, and then click Edit 
Snapping.

Select the snap check box options 
you want to turn on.

Click Advanced.

Select from the following options:

◆ Snap align settings. Enter a 
value for the distance an object 
needs to be before it will snap 
to the boundaries of the stage 
movie (in pixels).

◆ Object spacing. Enter a value 
for horizontal and vertical edge 
tolerance (in pixels).

◆ Center alignment. Select the 
check boxes to center 
alignment on horizontal or 
vertical vertices or both.

To make the snap align setting the 
default for future use, click Save 
Default.

Click OK.6

5

4

3

2

1

4

5

6

Snapping to an Object
You can use the Snap to Object command in the View menu or use 
the Snap option for the Selection tool on the Tools panel. If the Snap 
option is enabled, a small black ring appears under the pointer when 
you drag an object. The small ring changes to a larger ring when the 
object is within snapping distance of another object.

For Your Information

2

3
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Changing Stroke and 
Fill Colors

Change the Stroke Color

Click the Selection tool on the 
Tools panel. 

Select the stroke of the shape by 
double-clicking it. 

Click the Stroke color box on the 
Tools panel or Property Inspector. 

Select a new color from the 
palette.

4

3

2

1

Artwork created in Flash can have strokes and fills. Strokes and fills 
behave differently and are edited in different ways. A stroke is an out-
line. It describes the edges of a shape or it can be a simple line. You 
can create strokes with the Line tool or the Pencil tool. A fill is a solid 
shape, often contained or surrounded by a stroke. It is the surface area 
of a shape and can be a color, gradient, texture, or bitmap. Fills can be 
created with the Paintbrush tool and the Paint Bucket tool. The Oval, 
Rectangle, and Pen tool can create shapes with either a stroke or a fill, 
or both. You can edit the characteristics of strokes and fills, such as 
color, in several ways. If the shape is selected on the Stage, a color 
change to a stroke or fill can be made in any of the color palettes. 
Because Flash uses vectors to describe shapes, you can change their 
properties as much as you want without any loss in quality. It is impor-
tant to grasp the concept behind them because they are the basis for 
drawing in Flash.

2

4 Click to 
access the 
Color Picker.

Active color

Did You Know?
You can change the stroke color in 
three other places. Stroke color boxes 
are also located in the Property 
Inspector, the Color panel, and the 
Swatches panel. In all cases, select 
the stroke you want to change and 
choose a new color from any of the 
palettes.

You can change the line width and 
style of a stroke or set the stroke color 
to None in the Property Inspector. Click 
the stroke you want to change to 
select it, and then select any of the 
options in the Property Inspector. 
Setting the stroke color to None 
removes the stroke from the shape.

No stroke color
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3

4Gradients

Color 
Picker

Change the Fill Color

Click the Selection tool on the 
Tools panel.

The pointer becomes an arrow.  

Click the fill of the shape to 
select it.

This is the area inside the stroke.

Click the Fill color box on the Tools 
panel or Property Inspector.

Select a new color from the 
palette.

4

3

2

1

Did You Know?
You can change the fill color in three 
other places. Fill color boxes are also 
located in the Property Inspector, the 
Color panel, and the Swatches panel. 
Just select the fill and choose a new 
color from one of the palettes by click-
ing on a new color box.

See Also
See “Editing Fills with the Paint 
Bucket” on page 103 for information on 
changing the fill color.

1

2

No fill 
color
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Creating Custom Colors

Create a Custom Color by 
Specifying a Value

Open the Color panel.

◆ To open the Color panel, click 
the Window menu, and then 
click Color.

TIMESAVER Press Alt+Shift 
+F9 (Win) or Option+Shift+F9 (Mac).

Click an RGB or HSB option, and 
then adjust the color RGB value 
between 0 and 255 or HSB 
percentage between 0 and 100.

Enter an alpha value between 0 and 
100.

Click the Options button in the 
panel, and then click Add Swatch.

4

3

2

1

Each Flash document has its own color palette. The color palette dis-
plays as swatches when you access a color box or panel. The default 
color palette is the Web-safe palette of 216 colors. Flash allows you to 
edit and create new colors for strokes and fills in several ways in the 
Color panel. You can alter a color's RGB values (assigning it different 
levels of Red, Green or Blue), HSB values (New!) (assigning it different 
Hue, Saturation, Brightness), and Alpha (transparency). You can 
accomplish this by using sliders, dragging on a color-space, or entering 
a numeric value that corresponds to a specific color. In each case, you 
can save your color into the palette for easy access.

1

3

Color window

Did You Know?
You can alter the RGB or HSB values 
with the sliders located in the numeric 
entry boxes. Point to an entry box, and 
then drag the slider. Additionally, you 
can drag the cursor over the Color 
space bar at the bottom of the Color 
panel to change the color interactively.

You can also specify a color using a 
hexadecimal number in the Color 
panel. A hexadecimal number is an 
internal computer numbering scheme 
that is used to identify colors in a color 
palette.

2

Options button

4
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Create a Custom Color with 
the Color Picker

Click a Stroke or Fill color box on 
the Tools panel or the Property 
Inspector.  

Click the Color Wheel button to 
the far right of the palette.

Click a color from one of the 
available pickers (Mac) or from the 
Color window (Win).

Click OK.4

3

2

1

1

2

3

4

Did You Know?
You can import and export solid and 
gradient color palettes between Flash 
files and other applications. You can 
share color palettes between applica-
tions, such as Adobe Fireworks and 
Adobe Photoshop. Click the Window 
menu, and then click Color Swatches. 
Click the Options button on the panel, 
and then click Add Colors or Replace 
Colors to import colors from a color 
palette, or click Save Colors to export 
as a color palette.

Working with Color Palettes
Each Flash file stores its own color palette, Web safe 216 by default. 
If you change colors in the default color palette, you can save the 
new palette as the default or change back to the Web safe 216 
default. To view the color palette, click the Window menu, and then 
click Color Swatches. To load or save the default palette, click the 
Options button in the Color Swatches panel, and then click Load 
Default Colors or Save As Default. To reload the Web-safe color 
palette, click the Options button, and then click Web 216.

For Your Information

No fill color
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Adding Colors Using 
the Kuler Panel

Browse Themes and Add to the 
Swatches Panel

Click the Window menu, point to 
Extensions, and then click Kuler.

Click the Browse tab.

To search for a theme, click in the 
Search box, enter the name of the 
theme, a tag, or a creator, and 
then press Enter (Win) or Return 
(Mac).

IMPORTANT In a search, use 
only alphanumerical characters 
(Aa-Zz, 0-9).

To narrow down the browse list, 
click the popups, and then select 
the filter options you want. Some 
include Highest Rated, Most 
Popular, Newest. 

◆ To save a search, click the first 
list arrow, click Custom, enter 
your search criteria, and then 
click Save.

To browse for a theme, click the 
View previous set of themes or 
View next set of themes button.

Select a theme in the panel.  

To add the theme to the Swatches 
panel, click the Add Selected 
Theme To Swatches button.

7

6

5

4

3

2

1

The Kuler panel is an extension to Flash that allows you to use groups 
of color, or themes in your projects. You can use the panel to browse 
thousands of color themes, create your own using the complementary 
harmony rules, and share them with others in the Kuler community. 
After you find or create the theme you want, you can add it to the 
Swatches panel for use in your project. You can access the Kuler panel 
by using the Extensions submenu on the Window menu. The Kuler 
panel is also available in the CS5 version of Photoshop, InDesign, 
Illustrator, and Fireworks.

5

2

6

7

4

3
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Create or Edit a Theme

Click the Window menu, point to 
Extensions, and then click Kuler.

To create or edit a theme, do 
either of the following: 

◆ Create a theme. Click the 
Create tab.

◆ Edit a theme. Click the Browse 
tab, select the theme you want 
to edit, and then click Edit 
Theme in Create Panel.

Click the Select Rule list arrow, 
and then select a harmony rule or 
Custom.

The harmony rule uses the base 
color as the basis for generating 
the colors in the color group, so 
you can create a theme with 
complementary colors. 

Select a color box, and then use 
the sliders and the color wheel to 
display the color you want. 

Use the buttons below the color 
boxes to add/remove the theme 
color, add the current stroke/fill 
color as the base color, or adjust 
the other colors. 

◆ Double-click a color box to set 
the active color in Flash.

Upon completion, do any of the 
following:

◆ Save theme. Click Save Theme, 
name the theme, and then click 
Save to create a new one.

◆ Add to Swatches Panel. Click 
the Add This Theme to 
Swatches button.

◆ Upload to Kuler. Click the 
Upload Theme to Kuler button.

6

5

4

3

2

1

6

2

3

4

5

Colors added 
from Kuler panel

 From the Library of Wow! eBook



ptg

102 Chapter 3

Editing Strokes with 
the Ink Bottle

Use the Ink Bottle

Select a stroke on the Stage, and 
then change Stroke attributes in 
the Property Inspector. 

Click the Ink Bottle tool on the 
Tools panel. 

The pointer becomes a small ink 
bottle.

TIMESAVER Press S to select 
the Ink Bottle tool.

Click on the stroke of the shape to 
update it with the new attributes.

The stroke updates to the new 
color.

3

2

1

There are a number of ways to change the stroke of an object. You can 
select the stroke and change its characteristics in the Property 
Inspector, the Swatch palettes, and the Color panel. If you need to 
apply the stroke properties of one object to that of another, use the Ink 
Bottle tool. The Ink Bottle tool holds the properties you've set for 
strokes in any of the palettes. You can click any object on the Stage to 
change the properties of its stroke (color, line weight and style) or add 
a stroke to an object that doesn't have one.

1 Stroke Color

Stroke 
Weight

Stroke Style

Built-in Stroke 
styles

3

Shape with 
updated stroke

2

Did You Know?
You can click anywhere on the shape 
with the Ink Bottle to change the 
stroke. If the object on the Stage is 
selected (stroke and fill), click down 
with the Ink Bottle tool to update its 
stroke.
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Editing Fills with the 
Paint Bucket

Use the Paint Bucket

Change the Fill color box in either 
the Property Inspector, the Colors 
area of the Tools panel, or the 
Color panel.

Click the Paint Bucket tool on the 
Tools panel. 

The pointer becomes a small paint 
bucket.

TIMESAVER Press K to select 
the Paint Bucket tool.

Click in the fill of a shape on the 
Stage.

The fill updates to the new color.

3

2

1

You can change the fill of an object with the Paint Bucket tool. The 
Paint Bucket stores the fill color you've set on the Tools panel or in the 
Property Inspector. You can change the fill color of any existing shape 
on the Stage by touching down on the shape with this tool. You can 
also add a fill to any shape that has a closed stroke. After you select 
the Paint Bucket tool, you can select Paint Bucket sensitivity options 
located at the bottom of the Tools panel.

2

3 Shape with updated fill

Paint Bucket 
sensitivity

Paint Bucket Options

1

Did You Know?
You can set the sensitivity of the Paint 
Bucket tool in the Options areas of the 
Toolbox. These settings allow the Paint 
Bucket tool to close gaps in a shape 
(such as a break in the stroke line) and 
adjust how large or small a gap needs 
to be before Flash will close it.
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Ink Bottle appears 
when you click on a 
stroke.

Editing Strokes and 
Fills with the 
Eyedropper

Use the Eyedropper Tool to Edit 
Strokes and Fills

Click the Eyedropper tool on the 
Tools panel. 

The pointer becomes an 
eyedropper.

TIMESAVER Press I to select 
the Eyedropper tool.

Position the eyedropper over the 
stroke or fill of a shape on the 
Stage.

◆ Strokes. When you are 
positioned over a stroke, a tiny 
pencil appears next to the tool. 
When you click on the stroke 
the Eyedropper becomes an Ink 
Bottle.

◆ Fills. When you are positioned 
over a fill, a tiny paint brush 
appears next to the tool. When 
you click on the fill the 
Eyedropper becomes a Paint 
Bucket.

Click on another shape's stroke or 
fill to transfer the selected 
attributes.

The stroke or fill updates to the 
new color.

3

2

1

The Eyedropper tool allows you to select the attributes of a shape such 
as fill and stroke color, and line weight and style, and then transfer 
them to other shapes. This tool detects whether you are selecting a 
stroke or a fill, and then changes into the Ink Bottle (when selecting 
strokes) or the Paint Bucket (when selecting fills). Instead of taking 
several steps to copy attributes from one shape to another, the 
Eyedropper provides a quick means for storing and transferring attrib-
utes between editable shapes.

Paint Bucket appears 
when you click on a fill.

1

Tiny Pencil appears 
indicating 
eyedropper is 
positioned over a 
stroke.

Tiny Paint brush appears 
indicating eyedropper is 
positioned over a fill.
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Creating Gradients

Create a Multi-Color Gradient

With the Selection tool, select the 
fill or stroke of a shape on the 
Stage.

In the Color panel, click the Fill 
Style Type list arrow, and then 
click Linear Gradient or Radial 
Gradient.

To select the gradient display style 
(New!), click a Flow button: 
Extend Color, Reflect Color, or 
Repeat Color.

Position the pointer on the Color 
Picker box to display a circle 
pointer (New!).

Click in the Gradient bar to create 
a color proxy indicated by a little 
box with a triangle on top.

TIMESAVER To remove a 
proxy color indicator, drag it down.

Click one of the color proxy 
indicators to select it.

Click a new color from the Color 
Picker box above.

Drag the color proxy indicator 
along the Gradient bar to adjust 
the color placement.

Repeat steps 4-8 to add up to 15 
more gradient colors.

9

8

7

6

5

4

3

2

1

Flash can create a number of paint effects in addition to solid colors. 
Gradients are made up of two or more colors that gradually fade into 
each other. They can be used to give depth to an object or create real-
istic shadows. Two gradient modes are available: linear and radial. 
Linear gradients are made up of parallel bands of color. Radial gradi-
ents radiate from a center focal point. Both can be edited for color, 
alpha, and position within a fill or stroke. You can add up to 16 colors to 
a gradient, precisely control the location of the gradient focal point, 
and apply other parameters. A gradient behaves like any other fill or 
stroke. It can be saved to the palette as a swatch using the Color panel 
Options button, and added to other shapes with the Paint Bucket tool.

Example: 
3-Color 
Linear 
Gradient

1

5

2

6

4

3

7
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Using the Fill Lock

Lock Gradients

Create two simple shapes using 
the Rectangle or Oval tool.

Select the first shape on the Stage 
with the Selection tool.

Click the Paint Bucket tool on the 
Tools panel.

TIMESAVER Press K to select 
the Paint Bucket tool.

Click the Lock Fill button in the 
Options area of the Tools panel. 

Select a Gradient from the Colors 
area of the Tools panel or use the 
Color panel or Property Inspector.

Click the Eyedropper tool on the 
Tools panel, and then click on the 
gradient fill in the first shape.

Click down on the second shape to 
add the gradient fill.

7

6

5

4

3

2

1

As you increase the complexity and number of shapes in your movie, it 
can become tricky to edit each object separately. When using gradient 
fills on several objects you can choose to span a gradient across sev-
eral of these objects or give each object its own discreet gradient. The 
Lock Fill feature allows you to control how a fill is applied, essentially 
locking its position so that depending on where the shapes are posi-
tioned relative to the gradient, the one gradient spans all of the shapes. 
If you apply the same gradient to multiple shapes with the Fill Lock off, 
the gradient is applied to each shape independently. 

6

4

3

5

2 7

1

Shape 1 and 2 
with Fill Lock

Shape 1 and 2 
without Fill Lock

Did You Know?
You can quickly add a gradient that 
spans all of your shapes. Select all of 
the objects you want to fill, and then 
choose a gradient. Click the Paint 
Bucket tool and make sure Fill Lock is 
not selected. With your shapes still 
selected, click them with the Paint 
Bucket.
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Using Paint Brush 
Modes

Use Paint Brush Modes

Click the Brush tool on the Tools 
panel.

Click the Brush Mode list arrow in 
the Options area on the Tools 
panel, and then select from the 
following:

◆ Paint Normal. The brush paints 
over everything including 
strokes and other fills.

◆ Paint Fills. Painting only affects 
existing fills and empty areas of 
the Stage. Strokes are ignored.

◆ Paint Behind. The Paint Brush 
only affects empty areas of the 
Stage keeping existing lines 
and fills intact.

◆ Paint Selection. Painting only 
affects the selected areas you 
define with any of the selection 
tools.

◆ Paint Inside. The Paint Brush 
only affects the fill of the shape 
you started in, ignoring other 
shapes and empty areas on the 
Stage.

2

1

In addition to size, shape, and color settings for the Paint Brush tool, 
you can control how the brush behaves when painting on existing 
shapes and objects on the Stage. Paint Brush modes can restrict the 
area affected by the tool to fills or selections, empty areas of the Stage 
or specific shapes. When the Paint Brush tool is selected, a list arrow 
menu appears on the Tools panel. Select from the following modes: 
Paint Normal, Paint Fills, Paint Behind, Paint Selection, and Paint 
Inside. Each performs a specific operation providing you with varying 
levels of control as you paint. Flash previews your paint path as you 
paint, but it only affects the areas you've specified in the Paint modes. 
When you release the mouse, these previews disappear. 

Paint Normal

Paint Fills Paint Behind

Paint InsidePaint Selection

Brush mode 
options

1

2
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Using the Spray 
Brush Tool

Use the Spray Brush Tool

Click the Spray Brush tool on the 
Tools panel. 

Select a fill color for the default 
spray of dots and other options in 
the Property Inspector.

◆ Color Selector. Select a fill 
color for the default spray 
particle.

◆ Edit. Select a custom symbol 
from the library. You can use 
any movie clip or graphic 
symbol in the library as the 
spray particle.

◆ Scale. Scale the width and 
height of a symbol used as a 
spray particle.

◆ Random Scaling. Randomly 
spray particles on the Stage 
with different sizes.

◆ Rotate Symbol. Rotates the 
symbol spray particle around a 
center point.

◆ Random Rotation. Randomly 
rotate spray particles on the 
Stage.

◆ Width and Height. Specifies the 
brush width and height.

◆ Brush Angle. Specifies the 
spray angle of the particles.

Click or drag on the Stage where 
you want the pattern to appear.

3

2

1

The Spray Brush tool allows you to spray particles onto the Stage using 
the current fill color. If you want to create a more complex pattern, you 
can also use a movie clip or graphic symbol from the library as a parti-
cle. You can adjust the spray pattern by selecting Symbol and Brush 
options in the Property Inspector. The Symbol options include Scale, 
Random scaling, Rotate symbol, and Random rotation, while the Brush 
options include Width, Height, and Brush angle.

1

23
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Using the Deco Tool

Use the Deco Tool

Click the Deco tool on the Tools 
panel.

In the Property Inspector, click the 
Drawing Effect list arrow, and then 
select a drawing effect.

For the Vine Fill, Grid Fill, or 
Particle System effect, select a fill 
color for the default shape, or 
select a symbol.

◆ Color Selector. Select a fill 
color for the default pattern.

◆ Edit. Select a custom symbol 
from the library. You can use 
any movie clip or graphic 
symbol in the library as the 
pattern.

Specify the advanced options you 
want for the different effects; 
options vary depending on the 
selected effect.

Click the Stage or within the shape 
or symbol (Vine Fill, Grid Fill, and 
Particle System) where you want 
the pattern to appear.

5

4

3

2

1

The Deco tool allows you to apply a kaleidoscopic drawing effect to the 
Stage or a selected object on the Stage. You can apply several effects 
(New!): Vine Fill, Grid Fill, Symmetry Brush, 3D Brush, Building Brush, 
Decorated, Fire Animation, Flame Brush, Flower Brush, Lightning Brush, 
or Tree Brush. The Vine effect fills the Stage, symbol, object, or closed 
area with a vine pattern. You can also use your own artwork (symbols) 
for the leaves and flowers.The Grid effect fills the Stage, symbol, 
object, or closed area with a symbol from the library. You can create 
grid patterns, such as a tiled background or checkerboard. The 
Symmetry effect arranges symbols symmetrically around a central 
point, which you can control with a set of handles. You can create cir-
cular elements, such as a planet. The default symbol for the Symmetry 
effect is a 25 x 25 pixel black rectangle with no stroke. You can use 
other brushes (New!) to draw buildings, flames, lightning, trees, and 
other effects to add fire and smoke animations (New!) or a particle 
system (New!).

4

5 3

1

2
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Drawing with the 
Pen Tool

Use the Pen Tool to Create an 
Open Path

Click the Pen tool on the Tools 
panel.

TIMESAVER Press P to quickly 
select the Pen tool.

Click on the Stage.

An anchor point is created.

Move your pointer to another 
position, and then click again.

Flash connects the two anchor 
points.

Double-click to end the path.

TIMESAVER Ctrl+click (Win) or 
Command+click a blank area to 
leave the path open.

4

3

2

1

The Pen tool is the basis for vector drawing. The Pen tool now behaves 
similarly to the Illustrator Pen tool to provide consistency across Adobe 
software. Flash provides a number of ways to draw and edit objects 
that are unique to Flash, but the Pen tool utilizes procedures that will be 
familiar to those who have used other vector drawing programs. The 
Pen tool utilizes anchor points and Bézier handles to create lines and 
shapes and behaves in a way that is familiar to those who have used 
other programs such as Adobe Illustrator and Adobe FreeHand. You 
can use the Pen tool arrow to select a different pen to add, delete, or 
convert anchor points. You can edit the anchor points and vectors to 
create the drawings you want.

2 3

Open path drawn

1

Pen tools

Did You Know?
You can end an open path using a key-
board shortcut. Press A+click (Mac) 
or Ctrl+click (Win).

See Also
See “Modifying Shapes with the Sub-
Selection Tool” on page 116 for infor-
mation on using tools.
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Use the Pen Tool to Create a 
Closed Path

Click the Pen tool on the Tools 
panel.

TIMESAVER Press P to quickly 
select the Pen tool.

Click on the Stage.

An anchor point is created.

Move your pointer to another 
position, and then click again.

Flash connects the two anchor 
points.

Move the pointer to a third 
position, and then click again.

Flash connects the second and 
third anchor points.

Move the pointer back to the first 
anchor point. 

A small circle appears next to the 
pen pointer indicating you can 
close the path of the shape.

Click to close the shape.6

5

4

3

2

1

2 3

1

4

5

Closed path drawn

Did You Know?
You can delete an anchor point with 
the Pen tool. Click the Pen tool arrow, 
click Delete Anchor Point tool, and 
then click the point you want to delete. 

You can add an anchor point with the 
Pen tool. Click the Pen tool arrow, click 
Add Anchor Point tool, and then click 
where you want to add a point. 

You can create horizontal, vertical, 
and 45 degree lines while you draw. 
Hold the Shift key while you draw to 
constrain a line to horizontal, vertical, 
and 45 degree angles.

Pointer Description

Initial Anchor Point First pointer to create the beginning of 
a new path.

Sequential Anchor Creates an anchor point with a line
Point connecting the previous anchor point.

Add Anchor Point Adds an anchor point to existing path.

Delete Anchor Point Deletes an anchor point within a path.

Continue Path Extends a new path from an existing 
anchor point.

Close Path Closes the path of a drawing on the 
starting anchor point.

Join Paths Closes the path except not over the 
starting anchor point.

Retract Bézier Handle Displays Bézier handles when you point 
to an anchor. Click to retract the handles 
and revert to straight segments.

Convert Anchor Point Converts a corner point without 
direction lines to a corner point with 
independent direction lines. Use Shift+C 
modifier keys to toggle the pen.

Understanding Pen Pointers
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Drawing Curves with 
the Pen Tool

Create Curved Line Segments

Click the Pen tool on the Tools 
panel.

Click on the Stage without 
releasing the mouse, drag up, and 
then release the mouse.

Position the pointer to the right of 
the original point, drag in the 
opposite direction of the curve, 
and then release the mouse when 
the curve is where you want it.

Continue adding points as needed. 
To end the path, double-click or 
point to the last anchor point 
drawn and click on it.

4

3

2

1

The Pen tool can be used to draw precise and complex curves by sim-
ply clicking and dragging it on the Stage. These curves can be modified 
with precision by adjusting the Bézier handles that extend from the 
anchor points, or you can move the anchor points themselves. In this 
way, you can create any number of shape variations. For best results, 
make the grid visible so aligning anchor points isn't such a mystery.

1

2

3

Curved line segment drawn

Did You Know?
You can select to Show Precise 
Cursors instead of the tool icons in the 
General tab of the Preferences dialog 
box. When this option is selected, 
drawing tools, such as the Pen tool, 
appear as crosshairs for better preci-
sion and alignment to grids and guides.

You can convert a curve point to a cor-
ner point. Click the Pen tool arrow, 
click Convert Anchor Point tool, and 
then click the curve point you want to 
covert to a corner point.
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Create S-Curves

Click the Pen tool on the Tools 
panel.

Click on the Stage without 
releasing the mouse, drag down, 
and then release the mouse.

Position the pointer to the right of 
the original point, drag in the same 
direction as the first drag, and 
then release the mouse when the 
curve is where you want it. 

Continue adding points as needed. 
To end the path, double-click or 
return to the last anchor point 
drawn and click on it.

4

3
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1

2

3

S-Curve drawn
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Modifying Shapes 
with the Selection 
Tool

Use the Selection Tool to Modify 
a Shape

Click the Oval tool on the Tools 
panel and then create a simple 
oval shape.

Click the Selection tool on the 
Tools panel. 

The pointer becomes an arrow.

Make sure the shape you want to 
modify is not selected.

Position the pointer on the edge of 
the shape, and then drag to modify 
the shape.

You can pull the curve to any 
position.

4

3

2

1

In Flash, unlike other vector drawing programs, you can edit shapes 
and lines in a unique, freeform way by simply dragging with the Arrow 
Selection tool. You can quickly adjust the curve or corner of a shape or 
line without having to select anchor points or use any other tools. This 
way of editing shapes is also useful for creating shape tweens where 
amorphous, organic movement is desired. This is what sets Flash apart 
from other animation tools and gives it its distinctive style. Additionally, 
you can convert curved line segments into corner points with this sim-
ple drag technique.

2

1

4

Modified shape
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Convert Line Segments with the 
Selection Tool

Create a simple oval shape using 
the Oval tool.

Click the Selection tool on the 
Tools panel. 

The pointer becomes an arrow.

Make sure the shape you want to 
modify is not selected.

Position the pointer on the edge of 
the shape.

Press Option+drag (Mac) or 
Alt+drag (Win) to create a corner 
point.

5

4

3

2

1

2

1

4

Modified shape

More corners added
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Modifying Shapes 
with the Sub-
Selection Tool

Use the Sub-Selection Tool to 
Modify a Shape

Create a simple oval shape using 
the Oval tool.

Click the Sub-Selection tool on the 
Tools panel. 

The pointer becomes an empty (or 
white) arrow.

Click on the edge of the shape to 
reveal the anchor points, and then 
click on an anchor point to 
select it or drag a selection 
rectangle to select multiple anchor 
points.

The anchor points are the little 
white squares around the edge of 
the shape. When selected, Bézier 
handles appear on either side of 
the anchor point.

Grab one of the handles or the 
anchor points themselves and 
drag it, and then release the 
mouse.

4

3

2

1

Vector shapes are made up of anchor points connected by line seg-
ments. There are two types of anchor points: corner points and curve 
points. Corner points connect two line segments in a sharp angle such 
as the corner of a square. Curve points define a curve or positions 
along a straight line and can be modified with Bézier handles. These 
handles extend out from the curve point and allow for very precise 
modification of the shape of the curve. The Sub-Selection tool works 
hand-in-hand with the Pen tool to create and modify shapes and lines 
in this way.

2

3

1

4
Did You Know?

You can also use the arrow keys on 
the keyboard to move selected anchor 
points. Select one or more anchor 
points with the Sub-Selection tool, and 
then press the arrow keys to move the 
anchor point and its connected lines in 
the direction of the key you press.
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Convert Corner Points to 
Curve Points 

Create a simple rectangle shape 
using the Rectangle tool.

Click the Sub-Selection tool on the 
Tools panel. 

The pointer becomes an empty (or 
white) arrow.

Click on the edge of the shape to 
select it and then click on one of 
the corner points to select it.

Press Option+drag (Mac) or 
Alt+drag (Win) the point to convert 
it to a curve point and create 
Bézier handles.

Convert Curve Points to 
Corner Points 

Create a simple oval shape using 
the Oval tool.

Click the Pen tool on the Tools 
panel.

The pointer becomes a small pen.

Click on the edge of the shape to 
reveal the anchor points.

Position the pointer over one of 
the curve points. 

A small corner icon appears.

Click on the point to convert it to a 
corner point.

5

4

3

2

1

4

3

2

1
1

4

3

1

2

4

5 All anchor points 
converted to 
corner points.

2
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Using the Free 
Transform Tool

Change the Scale of an Object

Select the object by clicking on it 
or by dragging a selection 
marquee around it with the 
Selection tool.

Click the Free Transform tool on 
the Tools panel. 

TIMESAVER Press Q to select 
the Free Transform tool.

Click the Scale Modifier button in 
the Options area of the Tools 
panel.

Drag any of the small handles on 
the bounding box to change the 
size of the shape. The corner 
handles resize proportionally while 
the handles along the sides resize 
either horizontally or vertically.

To change the transformation 
point, drag the circle handle. 

5

4

3

2

1

There are a number of ways to change the scale or size of graphics in 
Flash. The Free Transform tool on Tools panel allows you to interac-
tively scale and rotate any selected object or shape on the Stage. 
Nearly every object in Flash can be transformed with these two func-
tions of the Free Transform tool including groups, symbols, text, 
bitmaps, and editable shapes. The Free Transform tool allows you to 
select an object on the Stage and then interactively change its size or 
rotate it freely. Both options are available at once depending on where 
you place your mouse on the bounding box that appears.

3

2

4

5

Working with the Transformation Point

When you transform an object, a transformation point appears at the 
center of the object. The point is initially placed in the center of the 
object, but you can move it at any time. To move the transformation 
point during a transformation, drag the point. To set it back to the 
center, double-click the point. To switch the point of origin for a scale 
or skew, Alt+drag (Win) or Option+drag (Mac) the point. To monitor 
the location of the transformation point (X and Y positions), click the 
center square in the grid in the Info panel (available on the Windows 
menu).

For Your Information
Did You Know?

You can restore a transformed object.
Select the transformed object, click the 
Modify menu, point to Transform, and 
then click Remove Transform. 

You can reset a transformed object. If 
you want to redo a transformation, 
select the object, and then click the 
Reset button in the Transform panel 
(available on the Window menu). 

 From the Library of Wow! eBook



ptg

Chapter 3 Creating Graphics 119

Rotate and Skew an Object

Select the object by clicking on it 
or by dragging a selection 
marquee around it.

Click the Free Transform tool on 
the Tools panel.  

TIMESAVER Press Q to select 
the Free Transform tool.

Click the Rotate/Skew Modifier 
button in the Options area of the 
Tools panel.

Drag any of the corner handles on 
the bounding box to rotate the 
shape. Drag the handles along the 
side to skew the object.

To change the transformation 
point, drag the circle handle. 

5

4

3

2

1
4

3

2

5

4 Skew

Rotate

Did You Know?
You can hold down the Shift key to 
constrain the rotation scale propor-
tionally. When rotating, it constrains 
the rotation to 45-degree turns. 

Working with Scale and Rotate
In the Default mode, both Scale and Rotate are enabled. Move the 
pointer to any of the four corner handles in the bounding box to 
enable the Rotate function. Scale and Rotate work relative to a cen-
ter transformation point on the shape, which becomes visible when 
the shape is selected with the Free Transform tool. Move this point if 
you want to scale or rotate a shape from a different part of the 
shape. This is especially important when tweening and animating. 
You can change the scale and rotate objects by entering values in 
the Transform panel or in the Property Inspector. You can also 
access all of the Transform modes and some additional effects, such 
as Flip Horizontal and Vertical from the Transform submenu in the 
Modify menu.

For Your Information
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Using Transform 
Options for Shapes

Distort a Shape

Select the object.

Click the Free Transform tool on 
the Tools panel.  

TIMESAVER Press Q to select 
the Free Transform tool.

Click the Distort Modifier button in 
the Options area of the Tools 
panel.

Drag any of the corner handles on 
the bounding box to distort the 
shape.

Drag any of the side handles on 
the bounding box to skew or 
stretch the shape.

Change the Envelope of a Shape

Select the object.

Click the Free Transform tool on 
the Tools panel.  

TIMESAVER Press Q to select 
the Free Transform tool.

Click the Envelope Modifier button 
in the Options area of the Tools 
panel.

Drag any of the handles on the 
bounding box to pull the shape in 
any direction or use the Bézier 
handles to fine tune the curves.

4

3

2

1

5

4

3

2

1

In addition to the scale and rotation changes that can be applied to 
groups, symbols, bitmaps, text and editable shapes, there are two addi-
tional transforms available only to editable shapes. Distort and 
Envelope are two modes available in the Free Transform tool options 
that enable you to transform the vectors of editable shapes to varying 
degrees. Distort transformations work on adjoining edges, tapering 
them down to vanishing points, similar to perspective. Envelope trans-
formations allow you to warp the edges of a shape by splitting it up into 
smaller portions each controlled by their own vectors and anchor 
points.

3

4
2

5

4

3

2
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Transforming 
Gradient Fills

Adjust a Gradient Fill

Click the Gradient Transform tool 
on the Tools panel. 

Click the gradient fill to select it.

A bounding box appears around it. 

Position the pointer over an editing 
handle on the bounding box to 
identify its function.

◆ Center point. Four-way arrow.

◆ Focal point. Inverted triangle.

◆ Size. Circle with an arrow.

◆ Rotation. Four arrows in the 
shape of a circle.

◆ Width. Double-ended arrow.

Click and drag an editing handle to 
adjust the gradient fill.

4

3

2

1

After you create a gradient fill, you can transform it by adjusting the 
size, rotation, width, or center of the fill with the Gradient Transform 
tool (formerly called the Fill Transform tool). For a radial gradient, you 
can now adjust the focal point (center) of a gradient fill applied to an 
object. You can also use the Gradient Transform tool to modify a bitmap 
fill.

2 4

Use Color panel to change 
color gradient settings

Radial gradient

Linear gradient

See Also
See “Modifying a Bitmap Fill” on page 
212 for information on using the 
Gradient Transform tool with bitmaps.

1
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Moving and Rotating 
Objects in 3D Space

Move Objects in 3D Space

Click the 3D Translation tool on the 
Tools panel.  

TIMESAVER Press G to select 
the 3D Translation tool.

Click the Global Transform button 
on the Tools panel to select it for 
global mode or deselect it for local 
mode. The default is global.

TIMESAVER Press D to toggle 
between global and local mode.

Select one or more movie clip 
objects.

◆ When you select multiple movie 
clips, and move one of them, 
the others move in the same 
way. Shift double-click one of 
the selected objects to move 
the axis controls to that object.

Drag the arrow tips (x- and y-axis) 
in the direction of the arrow or the 
black dot (z-axis) up or down.

◆ You can also move the object 
manually by using the Property 
Inspector.

4

3

2

1

In Flash, you can add 3D perspective effects to a movie clip by moving 
and rotating it in 3D space on the Stage. When you move or rotate a 
movie clip  by the z axis, it becomes a 3D movie clip. Moving an object 
in 3D space is called translation, and rotating an object in 3D space is 
called transformation. Flash provides two different 3D space: global 
and local. Global 3D space is the Stage space, while local 3D space is 
the movie clip space. The default mode is global. You can move a movie 
clip in 3D space with the 3D Translation tool. When you do, three axes 
appear in the 3D object: the x axis is read, the y axis is green, and the z 
axis is blue. In addition, you can rotate a movie clip in 3D space with 
the 3D Transformation tool. When you do, you can rotate around an 
individual axis or use the orange free rotate control to rotate around 
the x and y axes at the same time. If you want to change the effect of 
the rotation, move the center point. When you select a 3D object, it 
appears with a 3D axis overlay.

1

2

3 4
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Rotate Objects in 3D Space

Click the 3D Rotation tool on the 
Tools panel.  

TIMESAVER Press W to select 
the 3D Rotation tool.

Click the Global Transform button 
on the Tools panel to select it for 
global mode or deselect it for local 
mode. The default is global.

Select one or more movie clip 
objects.

◆ When you select multiple movie 
clips, and move one of them, 
the others move in the same 
way. Shift double-click one of 
the selected objects to move 
the axis controls to that object.

Drag one of the four axis controls 
to rotate around that axis, or the 
free rotate control to rotate x and y 
axis at the same time.

To move the rotation control 
center point relative to the movie 
clip, drag the center point.

◆ Double-click the center point to 
move it back to the center of 
the movie clip.

5

4

3

2

1

Did You Know?
You can turn the overlay on and off.
Click the Edit (Win) or Flash (Mac), 
click Preferences, click General, select 
or clear the Show axes for 3d movie 
clips check box, and then click OK.

1

2

3

5

4
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The Perspective Angle affects the size and view of 3D movie clips on 
the Stage. It’s like zooming in and out with a camera lens, which 
changes the angle of view through the lens. When you increase the 
angle, 3D objects appear closer to the viewer. When you decrease the 
angle, 3D objects appear further away. The default angle is 55 degrees 
of view, which is like a normal camera lens. You can adjust the value 
from 1 degree to 180 degrees. You can control only one viewpoint, or 
camera. Each Flash file has only one Perspective Angle.

Changing the 
Perspective Angle 
in 3D Space

Change Perspective Angle in 
3D Space

Select the 3D movie clip instance 
on the Stage that you want to 
change.

Click the Window menu, and then 
click Properties to open the 
Property Inspector.

Enter a new value in the 
Perspective Angle box or drag the 
hot text to change the value in the 
Property Inspector.

3

2

1

Did You Know?
You can automatically change the 
appearance 3D objects when you 
change the size of the Stage. Click the 
Modify menu, click Document, select 
or clear the Adjust 3D Perspective 
Angle to preserve current stage pro-
jection check box, and then click OK.

2

3

1
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Vanishing Point gives you the ability to move 3D movie clips and still 
maintain the same visual perspective of the original. Vanishing Point 
controls the orientation of the z-axis of 3D movie clips on the Stage. As 
you move the z-axis, 3D movie clips recede towards the Vanishing 
Point, which you can adjust to create the appearance you want. Each 
Flash file has only one Vanishing Point. If you move the Vanishing Point 
back to the default position in center of the Stage, you can use the 
Reset button in the Property Inspector.  

Adjusting the 
Vanishing Point 
in 3D Space

Adjust the Vanishing Point in 
3D Space

Select the 3D movie clip instance 
on the Stage that you want to 
change.

Click the Window menu, and then 
click Properties to open the 
Property Inspector.

Enter an x- and y-axis value in the 
Vanishing Point boxes or drag the 
hot text to change the value in the 
Property Inspector.

As you drag the hot text, guides 
indicating the location of the 
Vanishing Point appears on the 
Stage.

To move the Vanishing Point back 
to the center of the Stage, click 
the Reset button in the Property 
Inspector.

4

3

2

1

2

3

4

1
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Cutting and Pasting 
Graphics Between 
Layers

Paste Objects Between Layers

Create or open a document with 
several layers. 

Select one or more objects on the 
Stage.

Flash selects the object’s layer in 
the Timeline.

Click the Edit menu, and then click 
Cut or Copy.

Select a destination layer in the
Timeline.

Click the Edit menu, and then click 
Paste In Center.

Flash pastes the objects on the 
Stage in the middle of the active 
layer.

5

4

3

2

1

Unless you lock or hide layers, or lock objects, the graphics on all lay-
ers are available for editing. You can select objects on one or more lay-
ers, cut or copy them, and then paste them all into a single layer. Flash 
can have only one layer active at a time. When you create and paste 
graphics, Flash places them on the active layer of a document. You can 
paste objects in two different ways: Paste In Center and Paste In Place. 
Paste In Center puts objects in the center of the open Flash window, 
which might not be the Stage. If you want to paste to the center of the 
Stage, you need to center the Stage in the open window. Paste In 
Place puts objects at the same location it had been when you cut or 
copied it.

2

1

4

Shape pasted on 
layer 2 in the center.

Did You Know?
You can use the area around the Stage 
to store graphics and other objects. 
Flash allows you to use the area 
around the Stage, called the 
Pasteboard, to store items for use later 
without having them appear on the 
Stage when you play the movie (SWF) 
file.
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Use the Paste In Place 
Command Between Layers

Create or open a document with 
several layers. 

Select one or more objects on the 
Stage.

Flash selects the object’s layer in 
the Timeline.

Click the Edit menu, and then click 
Cut or Copy.

Select a destination layer in the
Timeline.

Click the Edit menu, and then click 
Paste In Place.

Flash pastes the objects into their 
original locations on the Stage.

5

4

3

2

1

4

Shape pasted on 
layer 2 in place.

1

2
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Working with 
Graphics on Different 
Layers

Edit Object on Inactive Layers

Create or open a document with 
several layers. 

Click the Selection tool on the 
Tools panel.  

Select an object on the Stage.  

Flash selects the object’s layer in 
the Timeline.

Click a blank area of the Stage.

Flash deselects the object but 
keeps the active layer.

Make changes to another object in 
another layer (inactive layer) 
without actually selecting the 
object. You can do any of the 
following:

◆ Drag an object’s outline to 
reshape it.

◆ Select a tool on the Tools panel, 
such as the Paint Bucket tool, 
and use it to modify the object.

Flash modifies the object in the 
inactive layer. The active layer 
didn’t change. Flash changes 
active layers only if you select an 
object.

5

4

3

2

1

When you select an object on the Stage, Flash selects the object’s 
layer in the Timeline. The reverse is also true. When you select a layer 
in the Timeline, Flash selects all the objects for that layer on the Stage. 
As you work with objects on different layers, it helps to know how 
selections work. Unless you lock or hide layers, or lock objects, the 
objects on all layers, either active or inactive, are available for editing. 
You can activate a layer and edit objects on inactive layers.

2

Layer 1 active

3

4

Layer 1 still active

5

1
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Distributing Graphics 
to Layers

Place Selected Objects on 
Separate Layers

Create or open a document with 
several objects on a single layer. 

Select all the objects on a single 
layer you want to distribute to 
separate layers.

TIMESAVER Click the Edit 
menu, and then click Select All or 
press A+A (Mac) or Ctrl+A (Win).

Click the Modify menu, point to 
Timeline, and then click Distribute 
To Layers.

TIMESAVER Press A+Shift+D 
(Mac) or Ctrl+Shift+D (Win) to 
distribute to layers.

Flash creates a layer for each 
object. New layers appear at the 
bottom of the Timeline in the order 
in which you originally placed 
them on the Stage. Each object is 
placed in the same location on the 
Stage (like the Paste In Place 
command).

3

2

1

If you have several objects on a single layer, and need to move them 
onto separate layers, you can use Cut and Paste in place for each 
object or you can save time by using the Distribute to Layers command. 
The Distribute to Layers commands puts each object (shapes, groups, 
and symbols) in a selection on a separate layer; any unselected objects 
remain on their original layer. This command comes in handy when you 
want to create a motion tweening animation, which requires objects to 
be on individual layers. 

2

Shape on layer 5

Text on layer 3

Shape on layer 4

Text on layer 2

See Also
See Chapter 8, “Animating with Motion 
Tweening” on page 237 for information 
on using motion tweening.

1
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The Drawing category on the Preferences dialog box contains a num-
ber of drawing settings that control the sensitivity and behavior of 
Flash's drawing tools. Make changes to the tolerance levels for 
smoothing or straightening, set the sensitivity for line and shape recog-
nition, or fine-tune snapping. You can exercise greater control over 
your drawing or allow Flash to perform corrections and adjustments as 
you draw. You can customize the way you use Pen tools, draw connect-
ing lines and smooth curves, and recognize lines and shapes. 

Changing Drawing 
Settings

Change the Drawing Settings

Click the Flash (Mac) or Edit (Win) 
menu, and then click Preferences.

Click the Drawing category.

Specify the drawing option you 
want:

◆ Pen Tool options. Select check 
boxes to show pen preview, 
solid points, and precise 
cursors.

◆ Connect Lines. Determines how 
close the ends of any two lines 
need to be before Flash 
connects them. It controls when 
a line is converted into a 
perfectly straight line. 

◆ Smooth Curves. Determines the 
amount of smoothing applied to 
a drawn line. The lower the 
smoothing applied, the closer 
the line appears to what you 
have drawn. 

◆ Recognize Lines. Defines how 
straight a line drawn with the 
Pencil tool must be before it’s 
converted into a perfectly 
straight line.

◆ Recognize Shapes. Sets how 
precise simple geometric 
shapes must be drawn before 
they are detected as shapes.

◆ Click Accuracy. Determines how 
near to a shape the pointer must 
be before it’s recognized. 

◆ IK Bone Tool. Automatically sets 
the transformation point.

Click OK.4

3

2

1 2

3

4
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Working with Groups, 
Symbols, and Instances

Introduction

All vector objects are editable. As the complexity of your doc-
ument increases, you can protect artwork from being inad-
vertently changed by storing it in special modes called 
groups and symbols. Groups provide a quick way to seal a 
shape by storing it in a bounding box that can only be edited 
by entering a group editing mode. Groups are created on the 
Stage and are not stored anywhere else. For items that are 
more global to your movie, you can convert them into sym-
bols. The basis for interactivity and animation in Flash resides 
in its use of these reusable objects. 

You can create artwork and then save that artwork as a 
symbol that is stored in the Library of your Flash document. 
Symbols are an efficient way to build your movies because 
you can reuse these assets as instances on the Timeline, and 
Flash will only store it in your file once. Apply ActionScript to 
control a movie clip symbol instance and to add interactivity, 
place art inside of button symbols to create hit states, or 
apply a variety of transparency and color effects to instances 
on the Stage. The Library stores all of the reusable art and 
objects in your movie including symbols, sounds, video clips, 
bitmaps, and components. It can be organized and sorted for 
easy access to your movie's assets. A Library can also be 
shared with other Flash documents. 4

4
What You’ll Do

Create Groups

Arrange Multiple Groups

Use the Library

Create Symbols

Edit in Symbol Mode

Create Instances

Change Symbol and Instance Behaviors

Swap Symbol Instances

Use Graphic and Button Symbols

Enable and Disable Buttons

Create Invisible Buttons

Use Movie Clip Symbols

Break Symbols Apart

Modify Instance Properties

Modify Instance Color Styles and 
Blends

Use Advanced Color Options

Use 9-Slice Scaling on a Movie Clip 
Symbol

Set Highlight Color Preferences

131
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When you group artwork on the Stage, you prevent it from interacting 
with other artwork on the same layer. Grouping essentially stores the 
artwork in a bounding box that can only be edited by entering a special 
group editing mode, which you can easily do by double-clicking the 
group. For example, if you draw a shape over another shape on the 
same layer, the strokes and fills of the second shape will cut through or 
replace the strokes and fills of the shape directly beneath it. Grouping 
your artwork prevents this from happening. You can also use grouping 
to combine several shapes into one group so you can manipulate them 
simultaneously. You can ungroup artwork or objects that have been 
grouped by using the ungroup option or by breaking them apart. Doing 
so removes the bounding box and the artwork can be freely edited.

Creating Groups

Group Artwork on the 
Same Layer

Select the artwork on the Stage 
that you want to group with any of 
Flash's selection tools or methods.

Click the Modify menu, and then 
click Group.

TIMESAVER Press A+G 
(Mac) or Ctrl+G (Win) to quickly 
group selected objects or artwork.

Ungroup Artwork

Select the artwork on the Stage 
that you want to ungroup.

Click the Modify menu, and then 
click Ungroup.

TIMESAVER Press Shift+ A+G 
(Mac) or Shift+Ctrl+G (Win) to 
quickly ungroup selected objects 
or artwork.

2

1

2

1

1

Selected ungrouped artwork

Selected 
grouped 
artwork in 
bounding 
box

2

1

Selected grouped artwork

Artwork 
ungrouped 
or broken 
apart

2
See Also

See “Breaking Symbols Apart” on 
page 155 for information on taking 
apart elements.
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When objects are grouped they appear on top of shapes that aren't 
grouped on the same layer. Each subsequent group that is created will 
appear on top of the last. This is called the stacking order. Flash allows 
you to change this order with the Arrange command. You can send a 
group or symbol to the bottom of this stack or bring one at the bottom 
to the top. Additionally, you can change the order incrementally.

Arranging Multiple 
Groups

Change the Stacking Order

Select the group whose stacking 
order you want to change.

Click the Modify menu, point to 
Arrange, and then click:

◆ Bring To Front. The selected 
object is brought to the top of 
the stack.

TIMESAVER Press 
Option+Shift+Up (Mac) or 
Ctrl+Shift+Up (Win).

◆ Bring Forward. The selected 
object is brought up one level 
in the stacking order.

TIMESAVER Press A+Up 
(Mac) or Ctrl+Up (Win).

◆ Send Backward. The selected 
object is brought down one 
level in the stacking order.

TIMESAVER Press 
A+Down (Mac) or Ctrl+Down 
(Win).

◆ Send To Back. The selected 
object is brought to the bottom 
of the stack.

TIMESAVER Press 
Option+Shift+Down (Mac) or 
Ctrl+Shift+Down (Win).

2

1

1

2 Bring To Front

 From the Library of Wow! eBook



ptg

134 Chapter 4

The Library panel is where all of the reusable assets in your Flash 
movie are stored. An asset is any artwork or object you have made into 
symbols, such as fonts, graphic symbols, movie clips, and buttons. 
Flash also stores bitmaps, sounds, video clips, and components in the 
Library. You can also open libraries from other Flash files to quickly 
transfer assets from one project to another. In Flash, you can use a sin-
gle Library panel to view the library items of multiple Flash files at the 
same time. 

Opening the Library
Panel

Open the Library

Click the Window menu, and then 
click Library.

TIMESAVER Press A+L 
(Mac) or Ctrl+L (Win) to open the 
Library panel.

Click the Document list arrow, and 
then select a library from a 
currently opened document.

If you want one library selected 
regardless of what document is 
active, simply select the library 
from the Document list arrow 
menu, and click the Pin button.

3

2

1

1

New Library 
Panel

Options menu2 3
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Open Other Libraries

Click the File menu, point to 
Import, and then click Open 
External Library.

TIMESAVER Press A+Shift+O 
(Mac) or Ctrl+Shift+O (Win) to 
open the Open As Library dialog 
box.

Navigate to the drive or folder 
where the Flash movie containing 
the Library is located.

Select the library file.

Click Open.

The Library appears docked 
underneath the Library of the 
active project.

4

3

2

1

3

Imported Library

4

Did You Know?
You can use sample common libraries 
included with Flash and create your 
own. To use a common library, click 
the Window menu, point to Common 
Libraries, select the library type you 
want from the submenu, and then drag 
items from the library to your docu-
ment. To create a common library, cre-
ate a Flash file (.fla) with a library 
containing the symbols you want, and 
then save the file to the Libraries folder 
located in the Flash application folder 
on your hard disk.

2

 From the Library of Wow! eBook



ptg

136 Chapter 4

You can organize your Library assets into folders, sort the items, dupli-
cate symbols or change their behavior. You can sort items by name, 
type, date, use count, or ActionScript linkage identifier. If you have a 
long list of items in your Library, you can search for the ones you want. 
The improved Library panel also allows you to set properties on most 
multiple Library items at once.

Working with the 
Library Panel

Organize Items in the Library
Panel

Click the Window menu, and then 
click Library.

Use any of the following options to 
organize items in the Library panel:

◆ Search. Click in the Search box, 
start to type the name of the 
item you want to find. As you 
type, the list of Library items 
narrows to display the items 
that match what you typed.

Click X in the Search box to 
display all the items in the 
Library panel.

◆ Sort. Click the name header to 
sort the Library items from A-Z 
or Z-A.

◆ New Folder. Click the New 
Folder button, type a name, and 
then press Enter (Win) or 
Return (Mac).

◆ Use Folders. Select a Library 
item from the list and drag it to 
the folder where you want to 
store it. Click the triangle to 
expand/collapse the folder.

◆ Delete Item. Select the items 
you want to delete, and then 
click the Delete button.

◆ Rename Item. Double-click the 
item you want to rename, type 
a new name, and then press 
Enter (Win) or Return (Mac).

2

1

Preview 
controller

Delete button 
New Folder button

Create New Symbol button

New Library 
Panel

Options menu

Click the column 
header to sort 
items.

Search box
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Access Library Options

Click the Options menu on the 
Library panel.

A menu of options for adding, 
deleting, organizing, and 
configuring Library items appears, 
such as:

◆ New Font. Create a font symbol 
to embed a font in a movie.

◆ New Symbol. Create a symbol.

◆ Duplicate. Make a copy of the 
selected items.

◆ Edit or Edit With. Edit items in a 
library. Select the item first.

◆ Linkage. Define properties to 
share library assets for runtime 
or author development time.

Change Library Item Properties

Click the Window menu, and then 
click Library.

Select the Library items you want 
to change.

To select multiple items, hold down 
Ctrl (Win) or A (Win), and the 
click the items you want to select.

Click the Properties button.

Make the changes you want for 
the Library items.

Click OK.5

4

3

2

1

1 1

Library 
options

3

2

4

5
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Using symbols is an efficient way to add artwork or elements to your 
Flash movie. When you create a symbol, it is stored in the Library 
where it can be reused as an instance in the Timeline. You can turn 
graphics or animations you've made into symbols or create a new one 
from scratch. There are three default symbol types you can choose 
from: graphic, movie clips, and buttons. How you use the symbol will 
determine which of these three types to use. Symbols have their own 
discrete Timelines. Think of a symbol as a package containing artwork 
that you can open and close. You enter a symbol editing mode to make 
changes and when you leave this mode the artwork is protected.

Creating Symbols

Create New Symbols

Click the Insert menu, and then 
click New Symbol.

TIMESAVER Press A+F8 
(Mac) or Ctrl+F8 (Win) to create a 
new symbol.

Type a name for the symbol.

Select a symbol type option.

Click OK.

Flash enters a special Symbol 
editing mode.

Create or insert a symbol item, and 
then click the Back button.

Convert Existing Artwork 
into Symbols

Select the artwork on the Stage 
you want to make into a symbol.

Click the Modify menu, and then 
click Convert To Symbol.

TIMESAVER Press F8 to 
convert the artwork into a symbol.

Type a name for the symbol.

Select a symbol type option.

Select a registration point.

Click OK.

Symbol appears in the Library.

6

5

4

3

2

1

5

4

3

2

1

Click to set 
ActionScript 
options

3

1

6

2

Symbol editing mode indicator
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Convert Animations 
into Symbols

In the Timeline, select every frame 
in the animation that you want to 
make into a symbol.

Click the Edit menu, point to 
Timeline, and then click Copy 
Frames.

TIMESAVER Press 
Option+A+C (Mac) or Ctrl+Alt+C 
(Win) to copy frames.

Click the Insert menu, and then 
click New Symbol.

Type a name for the symbol.

Select a movie clip or graphic 
symbol.

Click OK.

Flash enters a special symbol 
editing mode.

Select the first frame of the
Timeline.

Click the Edit menu, point to 
Timeline, and then click Paste 
Frames.

TIMESAVER Press 
Option+A+V (Mac) or Ctrl+Alt+V 
(Win) to paste frames.

8

7

6

5

4

3

2

1

1

7

New symbol’s Timeline

6

5

4

See Also
See “Editing in Symbol Mode” on page 
140 for information on editing symbols 
in symbol editing mode. 

Selecting a Registration Point

In the Convert to Symbol dialog box, there is a registration grid. The 
grid represents the symbol’s bounding box. It displays a small black 
square to indicate the registration point for the graphic. A registra-
tion point is the axis from which a symbol rotates or aligns to other 
objects. You can view the registration point for a symbol by selecting 
it, and then opening the Property Inspector or the Info panel.

For Your Information
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When you need to change or modify a symbol, you must enter a special 
symbol editing mode. Entering this mode allows you to view and edit 
the symbol's Timeline. Any changes you make are stored in the Library, 
and all other instances of the symbol are updated with these changes. 
You can choose to enter the symbol mode, entirely replacing the view 
of the main Timeline, or view the symbol in context to the main Timeline. 
Additionally, you can open the symbol mode in a new window.

Editing in Symbol 
Mode

Enter Symbol Editing Mode

Select the symbol you want to 
modify.

Click the Edit menu, and then click 
Edit Symbols.

Selecting Edit Symbols centers the 
symbol based on its registration 
point in the symbol editing work 
area. The Timeline is not visible.

TIMESAVER Double-click the 
symbol, or press A+E (Mac) or 
Ctrl+E (Win) to enter symbol 
editing mode.

Modify the symbol or its Timeline.3

2

1

3

Edit Symbols 
button

Symbol editing 
mode

Did You Know?
You can use the Edit Symbols button to 
access any symbol stored in the Library. 
When you click the Edit Symbols but-
ton in the Edit bar, a list of symbols 
stored in the Library appears from 
which you can select.

Entering and Viewing a Symbol’s Editing Mode
There are two additional modes for viewing a symbol's editing mode: 
Edit In Place and Edit In New Window. You can access these options 
from the Edit menu or from the context-sensitive menus by Control-
clicking (Mac) or right-clicking (Win) the instance on the Stage. 

Edit In Place. Preserves the view of the symbol's position in the main 
Timeline, dimming everything else in the main Timeline. This feature 
is useful when you need to see a symbol's placement relative to 
other elements in the main Timeline as you edit it. To quickly Edit in 
Place, double-click the instance on the Stage.

Edit In New Window. Opens the symbol's Timeline in a new window.

Additionally, you can select the symbol from the Edit Symbol list 
arrow on the right side of the Information bar above the Timeline.

For Your Information

2
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Exit Symbol Editing Mode

When you are finished making 
changes to a symbol, you can 
return to the main Timeline in 
several ways:

◆ Click the Back button or the 
Scene name on the Edit bar to 
return to the parent scene.

◆ Click the Edit Scene button on 
the Edit bar, and then click 
another Scene name.

◆ Click the Edit menu, and then 
click Edit Document to return to 
the main Timeline.

◆ Press A+E (Mac) or Ctrl+E 
(Win).

1
Back button and Scene name

Return to main Timeline  

Edit Scene button

Edit bar with options 
for leaving symbol 
editing mode. 
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An instance is a copy of a symbol. When you use a symbol in your 
Timeline you are using an instance of it. You can animate an instance of 
a symbol and apply a variety of effects to it without affecting the origi-
nal symbol in the Library. You can also use multiple instances of the 
same symbol. When you change the properties of an instance in the 
Timeline, you are only applying these changes to that copy, or instance, 
of the symbol. In this way, you keep the file size down because Flash 
only keeps track of the changes you've made while preserving the sym-
bol in the form you created. If you have several instances of a symbol 
in your movie and you want to edit the artwork, you can make changes 
to the master symbol. When you do this, all of the instances of that 
symbol will be updated with these changes.

Creating Instances

Place Instances on the Stage

Open or expand the Library panel.

TIMESAVER Press F11 or 
A+L (Mac) or Ctrl+L (Win) to 
quickly open and close the Library 
panel.

Select the symbol from the list of 
assets and drag it to the Stage to 
create an instance of that symbol.

TIMESAVER Drag the preview 
image of a symbol selected in the 
Library item list to create an 
instance of that symbol on the 
Stage.

2

1

2

Filled keyframe indicates instance is placed on the Stage.

1Instance of the symbol on the Stage
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Edit Master Symbols

Double-click any instance of a 
symbol you want to edit.

Make changes to the symbol 
artwork or animation. 

Click the Back button or Scene 
name on the Edit bar to return to 
the main Timeline.

All of the instances reflect these 
changes.

3

2

1

All other instances update with new changes.

3

2
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Symbols have three specific types that are set when you first create 
the symbol: graphic, movie clip, and button. You can change these 
types for a symbol's instance by selecting it and then selecting a new 
type option in the Property Inspector. Do this when you need the 
instance to display a behavior different than its parent symbol. 
Alternately, you can change the behavior of the parent symbol itself in 
the Library. All subsequent instances that you create from this symbol 
will exhibit the new behavior.

Changing Symbol and 
Instance Type

Change a Symbol's Behavior

Open or expand the Library panel.

Select the symbol from the list.

Click the Properties button at the 
bottom of the Library window to 
open the Symbol Properties dialog 
box.

Select a different symbol type 
option.

Click OK.

The symbol displays a new 
behavior. All subsequent instances 
will default to this behavior.

5

4

3

2

1

4

2

Symbol begins 
as a movie clip.

3

Symbol is converted 
into a graphic symbol.

1

5

See Also
See “Breaking Symbols Apart” on 
page 155 for information on taking 
apart elements.

Did You Know?
If you are already using instances of a 
symbol in your movie, they will not be 
affected by a change in behavior. Flash 
allows you to change the types of 
instances separately from your sym-
bol's default behavior. To update the 
instance to a new symbol, select it on 
the Stage, and then change the type in 
the Property Inspector.
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Change the Symbol Behavior of 
an Instance

If necessary, open the Property 
Inspector.

Select the instance on the Stage.

Click the Symbol list arrow in the 
Property Inspector, and then 
select another behavior: Movie 
Clip, Button, or Graphic.

3

2

1

3

Symbol options for 
instances

2

Did You Know?
You can use a method to change the 
symbol behavior of any instance. 
Select from any of the three options: 
graphic symbol, button, or movie clip. 
In this way, you can get graphic sym-
bols to behave as movie clips, movie 
clips to behave like buttons, etc.
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Symbols are used in the Timeline as instances. If you apply motion or 
color effects to an instance, you only affect that instance, not its parent 
symbol. If you would like to swap the parent symbol for another symbol, 
while retaining any effects and/or animation that have been applied to 
the instance, you can use the Swap Symbol feature. All of the effects 
are preserved but are instead applied to and referencing the new cho-
sen symbol. Alternately, if you are using several instances of a symbol 
and want to change the content (the master symbol itself) of one of 
these instances without affecting the other instances, you can dupli-
cate and swap that symbol in the Swap dialog box. Essentially you cre-
ate a new master symbol linked to your instance that is no longer 
related to the original master symbol and all its instances.

Swapping Symbol 
Instances

Swap Instances

If necessary, open the Property 
Inspector.

Select the instance on the Stage.

Click Swap in the Property 
Inspector to open the Swap 
Symbol dialog box.

TIMESAVER Control+click 
(Mac) or right-click (Win) the 
instance on the Stage, and then 
click Swap Symbol.

Click a symbol from the list.

Click OK.

The instance is now linked to a 
new symbol.

5

4

3

2

1

4

5

3
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Duplicate Symbols During Swap

Select the instance on the Stage.

Click Swap in the Property 
Inspector.

Click the Duplicate Symbol icon in 
the bottom left-hand corner of the 
dialog box.

Enter a new name.

Click OK.

The instance is now linked to a 
new symbol, copied from the 
original master symbol.

Click OK.6

5

4

3

2

1

New master symbol created

6

4

5

See Also
See “Breaking Symbols Apart” on 
page 155 for information on breaking 
symbols apart in symbol editing mode.

2

3
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Graphic symbols can be used for static images and for animations that 
are in sync with the main Timeline. There are three instance options 
available to them: Loop, Play Once, and Single Frame. Set the instance 
to Loop if you want the symbol's Timeline to play continuously. Play 
Once plays the Timeline of a graphic symbol once and then stops. 
Single frame sets the instance to display as a single frame contained in 
the graphic symbol's Timeline. Unlike movie clip symbols, an animation 
contained in a graphic symbol can be seen in the main Timeline without 
having to export the Flash movie. However, any ActionScript and 
sounds that have been included in a graphic symbol's Timeline will not 
work.

Using Graphic 
Symbols

Create a Graphic Symbol 

Click the Insert menu, and then 
click New Symbol.

TIMESAVER Press A+F8 
(Mac) or Ctrl+F8 (Win) to create a 
new symbol.

Type in a name for the symbol.

Click the Type list arrow, and then 
click Graphic.

Click OK.

Flash enters a symbol editing 
mode that contains an empty 
Timeline for that symbol.

4

3

2

1

3

2 4

Did You Know?
Graphic symbol animations are synced 
up to the main Timeline. For example, 
if the animation in the graphic symbol 
spans 10 frames, the instance in the 
main Timeline must also span 10 
frames if the entire animation is to be 
seen.
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Change the Options for Graphic 
Symbol Instances

Select a graphic symbol instance 
on the Stage.

Click the list arrow in the Property 
Inspector, and then select from the 
following graphic options:

◆ Loop. The Timeline in the 
graphic symbol will loop 
continuously.

◆ Play Once. The Timeline in the 
graphic symbol will play once 
and stop. If there is no 
animation in the symbol or if 
there is only artwork on one 
frame, it will be treated as a 
static graphic.

◆ Single Frame. Sets the instance 
to a single frame in the Timeline 
of the master symbol. When 
this is selected, the graphic 
symbol is treated as a static 
graphic.

2

1

2

Options for graphic 
symbol instances 

Converting a Graphic to a Symbol

In addition to creating a new symbol and adding a graphic, you can 
also convert an existing graphic to a symbol. Select the vector 
graphic on the Stage, click the Modify menu, and then click Convert 
To Symbol. In the Convert to Symbol dialog box, enter a name (that 
you’ll refer to in an ActionScript), and then click the Graphic option 
as the type. The registration grid within the symbol bounding box dis-
plays a small black square to indicate the registration point for the 
graphic.

For Your Information
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Use buttons to add interactivity to your movie. Button symbols have 
their own four-frame Timeline. The first three frames define the states 
of the button: up, over, and down. The first frame is the Up state, which 
is the appearance of the button when in its normal, non-active state. 
The second frame is the Over state, which is triggered when the user 
places their mouse over the button. The third frame is the Down state, 
which appears when the user presses the button with their mouse. The 
fourth frame—which is invisible outside of the symbol editing mode— 
defines the active area. This is the area that the user must place their 
mouse over to activate the other states of the button. You can assign 
actions, such as sound or animation, to instances of buttons that tell 
Flash what to do when the button is clicked.

Using Button Symbols

Create a Button

Click the Insert menu, and then 
click New Symbol.

TIMESAVER Press A+F8 
(Mac) or Ctrl+F8 (Win) to create a 
new symbol.

Type in a name for the symbol.

Click the Type list arrow, and then 
click Button.

Click OK.

Place artwork in the keyframe of 
the first frame. 

This represents the button's Up 
state, its normal, inactive state.

Click the Insert menu, point to 
Timeline, and then click Keyframe 
to add a keyframe in the second 
frame (the Over state).

TIMESAVER Press F6 to 
quickly add a keyframe and press 
F7 to add a blank keyframe. 

6

5

4

3
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4

5
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Change the artwork or add new 
artwork in this frame.

Click the Insert menu, point to 
Timeline, and then click Keyframe 
to add a keyframe in the third 
frame (the Down state).

Alter the artwork or add new 
artwork in this frame.

Click the Insert menu, point to 
Timeline, and then click Keyframe 
to add a keyframe in the fourth 
frame (the active area).

Add a simple graphic (a rectangle 
or oval, for example) to define the 
active area.

To assign a sound to a state of the 
button, select the state’s frame in 
the Timeline, open the Property 
Inspector, and then:

◆ Select a sound from the Sound 
list arrow menu.

◆ Select an event from the 
Synchronization list arrow 
menu.

Click the Control menu, point to 
Test Movie, and then click Test.

TIMESAVER Press A+Return 
(Mac) or Ctrl+Enter (Win) to test it.

13

12

11

10

9

8

7

7 9 11

See Also
See “Enabling and Disabling Buttons” 
on page 152 for information on turning 
buttons on and off.

Adding Animation to a Button

There are several ways to add animation to a button. First, you can 
place an instance of the button symbol on the Stage and assign 
actions to it, not to frames in the button’s Timeline. Another way is to 
create a button using a movie clip symbol or a button component. You 
can create more complex animation with the movie clip button. The 
downside is that file size increases. The button component provides 
more pre-built button types, such as PushButton and RadioButton, 
and customizable features. See Chapter 18, “Adding and Modifying 
Components” on page 427 for information on components and using 
button components.

For Your Information
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Flash allows you to test your buttons within the development environ-
ment without having to export the movie. You can test the behavior of 
simple buttons by toggling the Enable Simple Buttons feature on and 
off. When buttons are enabled, you can't select them or enter their 
symbol editing mode normally. Disable this feature if you need to enter 
the symbol mode. You can quickly see how the different states of your 
button behave without having to export the whole flash movie. Any 
ActionScript applied to the button will be ignored.

Enabling and 
Disabling Buttons

Enable and Disable Buttons

Place a button on the Stage.

Click the Control menu, and then 
click Enable Simple Buttons to 
enable the button.

TIMESAVER Press Ctrl+Alt+B 
(Win) or Option+A+B (Mac) to 
toggle the enabling and disabling 
of simple buttons.

Place the mouse over the button to 
test the Over state.

Press down on the button to test 
the Down state.

To disable the button, click the 
Control menu, and then click 
Disable Simple Buttons.

5

4

3

2

1

The Up state is the 
button’s normal, 
inactive state.

The Over state is 
active when the 
mouse pointer 
passes over it.

The Down state 
is active when 
the mouse 
pointer presses 
down on it.

3 4

2

See Also
See “Using Button Symbols” on page 
150-151 for information on creating a 
button.

Did You Know?
Regardless of whether buttons are 
enabled or disabled, they will be func-
tional when you export your movie. 
The Enable Simple Buttons command 
is only relevant to the Flash develop-
ment environment. 
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Buttons do not require graphics to be placed in the hit state frames (the 
first three frames). As long as the active area contains a shape, the 
button will be invisible but will be functional and ActionScript can be 
applied to it. The active area is the fourth frame in the button symbol 
Timeline. An instance of an invisible button appears as a transparent 
blue shape in the main Timeline, but it will not be visible in the exported 
movie.

Creating Invisible 
Buttons

Create an Invisible Button

Click the Insert menu, and then 
click New Symbol.

TIMESAVER Press A+F8 
(Mac) or Ctrl+F8 (Win) to create a 
new symbol.

Click the Type list arrow, and then 
click Button.

Click OK.

Click the Insert menu, point to 
Timeline, and then click Keyframe 
to add a keyframe in the fourth 
frame (the active area). 

TIMESAVER Press F6 to create 
a keyframe.

Add a simple graphic (a rectangle 
or oval, for example) to define the 
active area.

Make sure the first three frames 
remain empty.

Return to the main Timeline.

Drag the invisible button from the 
Library to the Stage.

Invisible buttons appear as 
transparent blue shapes but are 
invisible in the final export.

8
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The first three frames of the 
button remain empty.

8

An invisible button appears as a 
transparent blue square in the 
Flash development environment.
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Movie clip symbols operate independently on the main Timeline. When 
you want an animation to loop on a single frame in the Timeline, you 
can store this animation in the Timeline of a movie clip that will sit on 
this frame. Movie clip instances can have actions applied to them and 
can be controlled from anywhere in the Flash movie through 
ActionScript. They can contain animations, interactive controls, 
sounds, and even other movie clips. Unlike graphic symbols, you can 
only see the first frame of the movie clip in the main Timeline. Export 
your movie to see the movie clip play.

Using Movie Clip 
Symbols

Create and View Movie 
Clips Symbols

Click the Insert menu, and then 
click New Symbol.

Click the Type list arrow, and then 
click Movie Clip.

Click OK.

Add your content to the Movie Clip 
Timeline.

Return to the main Timeline by 
clicking the Back button or the 
Scene name on the Edit bar.

Drag the movie clip symbol to the 
Stage from the Library.

To change movie clip properties, 
select the clip on the Stage, and 
then change options in the 
Property Inspector.

◆ Symbol. Movie Clip, Graphic, or 
Button

◆ X and Y position

◆ Width and Height

◆ Color. Brightness, Tint, Alpha, 
and Advanced

Click the Control menu, point to 
Test Movie, and then click Test.

TIMESAVER Press A+Return 
(Mac) or Ctrl+Enter (Win) to test it.
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Sometimes you'll need to break a symbol instance so that it is no longer 
linked to the master symbol. You might do this if you want to add some-
thing to the symbol without affecting the other instances. In this way, 
the content inside the symbol will become a simple graphic that you 
can adjust without affecting the master symbol you made it from or any 
of its instances.

Breaking Symbols 
Apart

Break an Instance

Select an instance on the Stage 
you would like to break.

Click the Modify menu, and then 
click Break Apart.

TIMESAVER Press A+B 
(Mac) or Ctrl+B (Win) to quickly 
break apart a symbol.

2

1 
1

Symbol broken 
apart into an 
editable shape.

See Also
See “Swapping Symbol Instances” on 
page 146 for information on swapping 
symbol instances.
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You can alter the properties of an instance of a symbol without affect-
ing the master symbol. Any transform applied to an instance can be 
animated with motion tweening. Flash will gradually draw the frames in 
between one transform to another. This is how you create movement in 
Flash. Change the scale of an instance or rotate and skew it. You can 
perform these functions interactively with the Free Transform tool. You 
can also add values in the Transform panel, or access additional 
Transform options in the program's Modify menu. Distort and Envelope 
cannot be applied to instances and are disabled on the Tools panel 
options when the Free Transform tool is selected. 

Modifying Instance 
Properties

Modify the Scale or Rotation

Select the instance on the Stage.

Click the Free Transform tool on 
the Tools panel.

TIMESAVER Press Q to quickly 
select the Free Transform tool.

Click the Scale or Rotate and 
Skew button in the Options 
section of the Toolbar.

Drag the small handles around the 
bounding box to change the size of 
the instance or rotate it.

To use the Transform panel, click 
the Window menu, and then click 
Transform.

TIMESAVER Press Ctrl+T (Win) 
or A+T (Mac) to open the 
Transform panel.

5

4

3

2

1

3

4

2

The Transform panel allows you to 
enter values for various transforms.

Did You Know?
You can select multiple instances and 
change their properties simultane-
ously. Press Shift+select each instance 
you would like to alter in tandem. A 
bounding box will appear around all 
selected instances.

5
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Transforms objects 
freely

Constrain transforms

Rotate commands

Flip commands

Removes all applied 
Transform effects

Use Additional Transform 
Commands

Select the instance on the Stage.

Click the Modify menu, point to 
Transform, and then click one of 
the following:

◆ Free Transform. Transforms the 
object freely. 

◆ Scale. Constrains the transform 
to scale.

◆ Rotate And Skew. Constrains 
the transform to rotate and 
skew.

◆ Scale And Rotate. Constrains 
the transform to scale and 
rotation changes.

◆ Rotate 90° CW. Rotates the 
selected object 90° clockwise.

◆ Rotate 90° CCW. Rotates the 
selected object 90° counter-
clockwise.

◆ Flip Vertical. Flips the object 
along a vertical axis.

◆ Flip Horizontal. Flips the object 
along a horizontal axis.

◆ Remove Transform. Removes 
any transform effects applied to 
the selected instance.

2

1

Did You Know?
Changing the scale or rotation of an 
instance can also be done in the 
Transform panel. Simply select the 
instance, and then access the 
Transform panel. Click the Window 
menu, and then click Transform. The 
Modify menu includes additional trans-
form commands not available any-
where else. 

2

 From the Library of Wow! eBook



ptg

158 Chapter 4

You can change the tint, brightness, or transparency of an instance in 
the Color list arrow located in the Property Inspector. This feature 
appears whenever an instance is selected on the Stage. If you would 
like to add a color to the instance, you can do so by selecting the Tint 
color style. Choose a color and then choose the amount of color that 
will be applied. You can adjust the Brightness (that is, how much white 
or black will be added) of an instance by choosing the Brightness color 
style. An instance can also be made transparent by altering the Alpha 
color style. An Alpha of zero will make the instance invisible, though it 
can still be selected and animated. This is useful when you want an 
object to fade on or off the Stage. You can also create unique compos-
ite image effects by varying color and transparency and applying a 
blend to two or more overlapping movie clips instances. 

Modifying Instance 
Color Styles and 
Blends

Modify the Brightness

Select the instance on the Stage.

Click the Style list arrow in the 
Property Inspector, and then click 
Brightness.

Enter a value between -100 and 
100 (-100= no brightness, black; 
100= maximum brightness, white).

TIMESAVER You can use the 
slider to the right of the field to 
interactively change the level of 
Brightness applied.

Modify the Tint Color

Select the instance on the Stage.

Click the Color list arrow in the 
Property Inspector, and then click 
Tint.

Click a color from the color box list 
arrow or enter an RGB value in the 
fields.

Enter a value between 0 and 100 
(0= no color, 100= maximum 
saturation).

4

3

2

1

3

2

1

2

Brightness of 
75%

Brightness of 
-50%

3

4

Tint of 50% Tint of 100%

2
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Modify the Transparency

Select the instance on the Stage.

Click the Style list arrow in the 
Property Inspector, and then click 
Alpha.

Enter a value between 0 and 100 
(0= invisible, 100= fully visible).

TIMESAVER You can use the 
slider to the right of the field to 
interactively change the level of 
Alpha applied.

If you need to apply a color style 
with alpha you must use the 
Advanced option.

Modify the Blend

Select the movie instance on the 
Stage.

Click the Style list arrow and 
adjust the color and transparency.

Click the Blending list arrow, and 
then select a blend.

Position the movie clip with the 
blend over another symbol.

To achieve the effect you want, 
you will need to experiment with 
the color and transparency of the 
movie clip and blend mode.

4

3

2

1

3

2

1

2

Alpha of 25%

Alpha of 50%

Hard Light 
blend

Subtract 
blend

3

4

Difference 
blend

Blend result 
color

Did You Know?
A blending mode contains different 
elements. It contains a blend color, 
opacity (degree of transparency), base 
color (pixel colors under blend), and 
result color.

3

2
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An instance can have only one color style (Brightness, Tint, or Alpha) 
applied. To apply multiple color styles, you must use the Advanced fea-
ture in the Property Inspector's Color list arrow menu. This option 
allows you to change the percentage of Red, Green, or Blue (0% -100%) 
added or subtracted as well as the constant values of RGB (-255 to 
+255). Additionally, there is an Alpha scale that can be applied to each 
of these options. Apply a color, brightness, or alpha style to an instance 
and then access the Advanced options to make adjustments. The 
applied color style is preserved. Experiment with this features until you 
get the effects that you need.

Using Advanced 
Color Options

Modify the Color and 
Transparency Simultaneously

Select the instance on the Stage.

Click the Style list arrow in the 
Property Inspector, and then click 
Tint, Brightness or Alpha and 
apply an effect.

Click the Style list arrow again, 
and then click Advanced.

Add or subtract percentages or 
values of RGB and Alpha.

4

3

2

1

4

Tint of 100% 
Alpha of 25%

Tint of 100%

Reduce the color 
values or alpha by 
a percentage.

Increase or decrease 
the constant color or 
alpha values.

Did You Know?
You can go directly to the Advanced 
panel to add color effects without hav-
ing applied any Brightness, Tint, or 
Alpha. If you have already chosen one 
of these options and then enter the 
Advanced settings, your previous 
applied effect will be preserved and 
the sliders in the Advanced Settings 
window will reflect this change. For 
example, if you have added a tint of red 
to your instance, the sliders in the 
Advanced setting will show that red 
has been added.

3

2
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In previous versions, Flash scales movie clips equally in height and 
width. For many rectangular movie clips, this method of scaling doesn’t 
work very well at the corners. In Flash, a method called 9-slice scaling 
is used. A movie clip is visually divided into nine areas, or slices, with a 
grid overlay (dotted lines called slide guides). Each area of the grid is 
scaled separately, except the corners, which provides more accurate 
results. The slide guides are set at 25% of the symbol’s height and 
width by default. Before you can scale a movie clip, you need to enable 
9-slice scaling. To edit a movie clip, you need to use symbol-editing 
mode.

Using 9-Slice Scaling 
on a Movie Clip 
Symbol

Enable 9-Slice Scaling

Select the movie clip symbol you 
want in the Library panel.

Click the Options menu, and then 
click Properties.

Click Advanced.

Select the Enable guides for 9-
slice scaling check box.

Click OK.

Scale a Movie Clip Symbol

Double-click the movie clip symbol 
in the Library to enter symbol-
editing mode.

To see the scaling on the Stage, 
click the Control menu, and then 
click Enable Live Preview.

Drag the horizontal or vertical 
guides to scale the symbol.

The new position of the guides 
provides the new scaling.

3

2

1

5

4

3

2

1

4

23 Drag any guide

1

5
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Setting Highlight 
Color Preferences

Set Highlight Color Preferences

Click the Flash (Mac) or Edit (Win) 
menu, and then click Preferences.

Click the General category.

Select the Use Layer Color option 
to use the current layer’s outline 
color, or select the option, and 
then select the color you want for 
the following elements:

◆ Drawing Objects.

◆ Drawing Primitives. 

◆ Groups.

◆ Symbols.

◆ Other Elements. 

Click OK.4

3

2

1

Flash allows you to set general preferences to customize the highlight, 
or selection, color of elements in Flash to make them easier to see. In 
the General category of the Preferences dialog box, you can select dif-
ferent colors for different types of elements, including drawing objects, 
drawing primitives, groups, symbols, and all other elements. If you don’t 
want to set individual colors, you can use the layer color for all ele-
ments.

4

2

3
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Working with Text

Introduction

In Flash, you can create two types of text: TLF (Text Layout 
Framework) or Classic. TLF provides advanced text capabili-
ties (New!) for text in Flash targeted for Flash Player 10 and 
ActionScript 3.0 or later, while Classic provides the standard 
capabilities available in previous versions of Flash. 

There are three types of Classic text: static, dynamic, and 
input. Static is text that doesn’t change. Dynamic is text that 
updates, such as stock quotes, weather reports, or sports 
scores. Input is text entered by a user in forms or surveys. 
You can create editable text boxes for use as static display 
text or to implement dynamic text objects with the Text tool. 

In the program's text menu, as well as the Property 
Inspector, there are a number of attributes to choose from 
such as Font type, style, size, color, indentation, orientation, 
and direction. Also included are familiar letter form format-
ting procedures for kerning, tracking, and anti-aliasing. 
Because text boxes are editable, you can change any text 
attribute—as well as the content in the text box—after it is 
created.

Use the Break Apart command to break editable text 
boxes into shapes and edit them with any of the selection 
tools or pen modifiers. This is especially useful for creating 
new font forms, and it also allows you to implement shape 
tweening. Create dynamic text boxes that can be updated 
from a text file on a server or some other source using 
ActionScript. In Flash, you can now configure the Find and 
Replace feature to target text contained in specific elements 
in your Flash document and swap these out with new entries 
from the built-in Adobe dictionaries or from a personal dic-
tionary you create. Other features include the implementation 
of Cascading Style Sheets for consistent HTML text format-
ting and the built-in Spell Checker for enhanced productivity.

5

5
What You’ll Do

Create Classic Static or TLF Text

Link Text Together

Change Font Type, Style, Size, and Color

Modify Tracking and Kerning

Change Text Alignment

Create Text Columns

Change Text Direction and Orientation

Change Advanced Text Options

Use Break Apart to Modify Characters

Use Anti-Alias Text

Use Font Mapping

Set Device Fonts Versus 
Embedded Fonts

Create Classic Dynamic Text and 
Input Text

Check Spelling

Use Find and Replace

Use Cascading Style Sheets with 
HTML Text
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Classic static text refers to any classic text box that isn't dynamic or 
input text. The Text tool creates an editable text box wherever you 
touch down on the Stage. Flash will keep the text on a single line until 
you press Enter (Win) or Return (Mac). If you need a text box with a 
predefined width, you can create a text box before you start typing. The 
entered text will automatically wrap relative to the boundaries of the 
box and any formatting settings you've applied. To re-enter an existing 
text box to change the text, simply double-click any character in the 
Text box or click it with the Text tool to activate it and make it ready to 
edit.

Creating Classic 
Static Text

Create Classic Static Text

Click the Text tool on the Tools 
panel.

The pointer becomes a crosshair 
with a small "T" in the corner.

TIMESAVER Press T to quickly 
select the Text tool.

Click the Text Engine list arrow in 
the Property Inspector, and then 
click Classic Text.

Click the Text Type list arrow in the 
Property Inspector, and then click 
Static Text.

Click the Stage where you want to 
create a single line text box or 
drag to create a text box the size 
you want that automatically wraps.

Begin typing in the box that 
appears.

Click anywhere on the Stage 
outside the text box to deselect it.

To reselect a text box, click to 
select it.

A black bounding box with square 
handles appears around a text box 
when it’s selected.

To resize a text box, drag any of 
the black resize handles, the white 
small circle (single line) or white 
square (text block) to resize. 

The text in the box wraps to 
accommodate to the new size..

8

7

6

5

4

3

2

1

1

5

6

Small square 
indicates text 
box

Small circle indicates 
single line of text.

2

3
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TLF (Text Layout Framework ) text (New!) provides advanced text 
capabilities in Flash documents targeted for Flash Player 10 and 
ActionScript 3.0 or later. You can create columns, rotate text, indent 
text, change text direction and orientation, change text case, adjust the 
text baseline, and apply text blending and color effects in the Property 
Inspector. TLF text created in Flash is read-only by default, however, 
you can change it to selectable or editable. If you need a text box with 
a predefined width, you can create a text box before you start typing. 
The entered text will automatically wrap relative to the boundaries of 
the box and any formatting settings you've applied. To re-enter an exist-
ing text box to change the text, simply double-click any character in the 
text box or click it with the Text tool to make it ready to edit. 

Creating TLF Text

Create TLF Text

Click the Text tool on the Tools 
panel.

The pointer becomes a crosshair 
with a small "T" in the corner.

TIMESAVER Press T to quickly 
select the Text tool.

Click the Text Engine list arrow in 
the Property Inspector, and then 
click TLF Text.

Click the Stage where you want 
your text box to begin or drag until 
the box is the size you need.

Begin typing in the box that 
appears.

Click anywhere on the Stage 
outside the text box to deselect it.

To reselect a text box, click to 
select it.

A black bounding box with square 
handles appears around a text box 
when it’s selected.

To resize a text box, drag any of 
the black resize handles, the white 
small circle (single line) or white 
square (text block) to resize. 

The text in the box wraps to 
accommodate to the new size..
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Small square 
indicates text 
box
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If you type, paste, or import more text than a TLF text box can hold, an 
Overflow icon (a tiny red plus sign in a square) appears on the edge of 
the text box (New!). You can reshape the text box to display the text or 
create a thread (link) to another text box. You can thread overflow text 
from one text box to a new or existing text box (New!). You can think of 
the linked text boxes as one, however, each text box still retains it’s 
own properties. If you no longer want to thread two or more text boxes, 
you can unthread or disconnect them. When you unthread text boxes, 
the text in the text box remains in the first text box (it may still over-
flow). When you disconnect text frames, the text in the text frames 
remains where it is. 

166 Chapter 5

Linking Text Together

Link Text Boxes Together

Click the Text tool on the Tools 
panel.

The pointer becomes a crosshair 
with a small "T" in the corner.

TIMESAVER Press T to quickly 
select the Text tool.

Click the Text Engine list arrow in 
the Property Inspector, and then 
click TLF Text.

Click the Stage where you want 
your text box to begin and drag 
until the box is the size you need.

Begin typing in the box that 
appears or paste in text from the 
Clipboard until it fills the entire 
text box.

Click the Overflow icon on the 
selected text box.

The pointer changes to the Loaded 
Text cursor.

To create a new text box for the 
overflow text, click a blank area or 
drag to create a text box.

To use an existing text box, click in 
an existing text box.

Overflow text from the first text 
box threads to the second text 
box.

6
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3
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Unthread Text Boxes

Select the Selection tool or the
Text tool on the Tools panel.

Select a threaded text box with 
the Selection tool or click in the 
threaded text box with the Text 
tool.

Double-click the In Port or Out 
Port icon on the selected object.

Change the Thread Between 
Text Boxes

Select the Selection tool or the
Text tool on the Tools panel.

Select a threaded text box with 
the Selection tool or click in the 
threaded text box with the Text 
tool.

Click the In Port or Out Port icon 
on the selected object.

To create a new text frame for the 
overflow text, click a blank area or 
drag to create a text box.

To use an existing text box, click in 
an existing text box.

4

3

2

1

3

2

1

Did You Know?
You can delete a linked text box.
Select the text box with the Selection 
tool, and then press Delete. The text in 
the deleted text box is moved back to 
the remaining text box thread.

Out PortIn Port 2

3

3

2
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Flash includes a number of text properties to choose from. These 
include a font type, style, size, and color. You can set these attributes 
before you create a text box or alter them on existing text. To make 
changes to the entire text box, select it with the Selection tool without 
entering the box (or making it active). If you only want to change a por-
tion of the box, enter the text box and select only those characters or 
words you want to change. Attributes such as font type, style, size, and 
color as well as more advanced text properties can be easily accessed 
in the Property Inspector. When the Text tool or any text box is 
selected, the Property Inspector displays all of the available attributes.

Changing Font Type, 
Style, Size, and Color

Change the Font Type, Style, 
and Size

Select the text box you want to 
change with the Selection tool or 
select text within the text box with 
the Text tool.

Click the Family list arrow in the 
Property Inspector, and then 
select a font name.

The Family menu displays the font 
name and sample text for each 
font style to make it easier to 
decide what font you want to use.

Click the Style list arrow in the 
Property Inspector, and then 
select a font style: Regular, Italic, 
Bold, or Bold Italic.

Click the current point value in the 
Property Inspector, and then enter 
another point value in the Size 
entry box.

Click any of the following format 
buttons in the Property Inspector:

◆ Subscript or Superscript.

◆ Underline (TLF). (New!)

◆ Strikethrough (TLF). (New!)

5

4

3

2

1

The Property Inspector 
displays text attributes 
whenever any text box is 
selected on the Stage.

1

4

3

2
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Change the Font or Highlight 
Color

Select the text box you want to 
change with the Selection tool, or 
select text within the text box with 
the Text tool.

Click the Color box in the Property
Inspector, and then select a fill 
color or click the Color Wheel icon 
to create or select a custom color.

Click the Highlight box (TLF) 
(New!) in the Property Inspector, 
and then select a fill color or click 
the Color Wheel icon to create or 
select a custom color.

3

2

1

1

2

See Also
See “Setting Text Preferences” on 
page 62 for information on setting 
options for showing font previews on 
font menus.

Did You Know?
You can change the text color in any 
of the color palettes. Change the fill 
color of any selected text box by click-
ing on any of the color palettes. They 
are located in the Tools panel, the 
Color Mixer panel, and the Color 
Swatches panel.

You can change the font type, size, and 
style in the Text menu. Click the Text 
menu, point to Font, Size, or Style, and 
then select an option.

You can quickly select all text in a 
text box. If you are inside an active 
text box, press A+A (Mac) or Ctrl+A 
(Win) to select all of the text.

3
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Sometimes the space between text characters can appear awkward or 
where increasing the space is a creative solution. Flash provides meth-
ods for adjusting these spaces, called kerning and tracking. Tracking is 
the space between characters and words on a single line and adjusting 
tracking affects the entire line. Kerning deals with the space between 
any two characters and adjusting it will only affect that space. Many 
Fonts contain built-in information about problematic character pairs. 
Flash makes use of this information when you turn on Auto Kern in the 
Property Inspector.

Modifying Tracking 
and Kerning

Adjust Tracking 

Select the text in a text box you 
want to track or you can select the 
text box with the Selection tool.

Click the Text menu, point to Letter 
Spacing, and then click Increase 
or Decrease.

The Tracking increases or 
decreases in 0.5-point (Classic) or 
10 in 1000ths of an em (TLF) 
increments.

TIMESAVER You can adjust 
tracking in the Property Inspector 
with the Letter Spacing (Classic) 
or Tracking (TLF) (New!) entry box 
or slider.

2

1 1 Increased tracking

Decreased tracking

Letter Spacing Entry 

Did You Know?
You can quickly adjust kerning or 
tracking using the keyboard. Select 
the text or text box (to track) or place 
the cursor between two characters, 
and then press Option+A+right arrow 
(Mac) or Ctrl+Alt+right arrow (Win) to 
increase the space or Option+A+left 
arrow (Mac) or Ctrl+Alt+left arrow 
(Win) to decrease the space. Holding 
down the Shift key with this keyboard 
shortcut adjusts the space in larger 
increments.
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Adjust Kerning

Enter a text box on the Stage by 
double-clicking on it.

Place the cursor between the two 
characters you want to kern.

Click the Text menu, point to Letter 
Spacing, and then click Increase 
or Decrease.

Set Auto Kerning

Select the text box you want to 
change with the Selection tool.

Select the Auto Kern check box 
(Classic) in the Property Inspector 
or click the Kerning list arrow 
(TLF), and then click Auto (New!).

Auto kern is enabled for that text 
box.

2

1

3

2

1

2

The Kerning increases or 
decreases in 0.5-point increments.

Auto Kerning can correct problematic 
character combinations.

1

2 Classic text

2 TLF 
text
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Similar to other text editing tools or word processing programs, Flash 
includes features for formatting paragraphs with alignment, margins, 
and indentation (New!). These features can be accessed through the 
Text menu and in the Property Inspector whenever any text box is 
selected on the Stage. Each text box can have its own individual prop-
erties assigned to it. Alignment governs the position of the text in a text 
box, margins are the space between the left and right side of the text 
and the boundaries of the text box, and indentation sets the amount of 
character spaces before the first line of text in a paragraph begins.

Changing Text 
Alignment

Align Paragraph Text 

Select the text box you want to 
change with the Selection tool or 
select text within the text box with 
the Text tool.

In the Property Inspector in the 
Paragraph section, click one of the 
following:

◆ Align Left. Aligns text to the left 
margin.

◆ Align Center. Text is centered 
between the boundaries of the 
text box.

◆ Align Right. Aligns text to the 
right margin.

◆ Justify. Each line of text fills the 
width of the text box boundary. 
The last line aligned to the left.

◆ Justify Center (TLF). Justify 
with the last line aligned 
center (New!).

◆ Justify Right (TLF). Justify 
with the last line aligned 
right (New!).

◆ Justify All (TLF). Justify all 
the lines (New!).

◆ Text Justify (TLF). Distributes 
justification between letters or 
words (New!). Click the Text 
Justify list arrow, and then 
click Word spacing or Letter 
spacing.

2

1

Align Right

Align Left

JustifyAlign Center

2 Classic text

2 TLF 
text
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Set Paragraph Text Margins, 
Indents, and Line Spacing

Select the text box you want to 
change with the Selection tool.

In the Property Inspector in the 
Paragraph section, enter values 
for any of the following:

TROUBLE? Options differ 
depending on the orientation of 
the text box.

◆ Indent. Indents the first line of 
the paragraph. 

◆ Line Spacing (Classic) or 
Leading (TLF). Adjusts the 
space between lines of text.

◆ Left Margin (Classic) or Start 
Margin (TLF). Adjusts the 
amount of space between the 
left barrier of the text box and 
the left side of the paragraph.

◆ Right Margin (Classic) or End 
Margin (TLF). Adjusts the 
amount of space between the 
right barrier of the text box and 
the right side of the paragraph.

◆ Space Before Paragraph (TLF). 
Adjusts the amount of space 
before a paragraph (New!).

◆ Space After Paragraph (TLF). 
Adjusts the amount of space 
after a paragraph (New!).

◆ Behavior.  Specifies the line 
type: Single Line, Multiline, or 
Multiline No Wrap.

2

1

Indentation space affects 
the first line of text.

Line Spacing 
is the space 
between the 
lines.

Right marginLeft margin

Did You Know?
You can transform text just like other 
objects. You can scale, rotate, skew, 
and flip text boxes to create unique 
effects.

2 Classic 
text

2 TLF 
text
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If you want to create columns for a more newspaper style for your text, 
you can create columns in a TLF text box (New!). In the Property 
Inspector for text, you can use the Container and Flow section to spec-
ify the number of columns, the gutter size between the columns, the 
padding size between the text and the border edge, the maximum num-
ber of characters, and the alignment to display the text the way you 
want. In addition, you can select a border and background fill color. If 
you want to offset the first line of text, you can specify the distance you 
want.

Creating Text Columns

Create Text Columns

Select the TLF text box you want to 
change with the Selection tool or 
select text within the TLF text box 
with the Text tool.

Click the Columns box in the 
Property Inspector in the 
Container and Flow section, 
specify the number of columns you 
want.

In the Property Inspector in the 
Container and Flow section 
(New!), specify any of the 
following:

◆ Alignment. Click the Align Top, 
Align Center, Align Bottom, or 
Justify button.

◆ Max Chars. Specify the 
maximum number of characters 
allowed in the text box.

◆ Gutter. Specify a gutter width in 
pixels.

◆ Padding. Specify a Left, Right, 
Top, and Bottom padding width 
in pixels.

◆ Border and Background Color. 
Click the Border or Background 
color swatch, and then select a 
color.

◆ 1st Line Offset. Click the 1st 
Line Offset list arrow, and then 
select an option: pt (specify a 
height in points), Auto (default), 
Ascent, or Line Height.

3

2

1

1

3

2
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If you work with different languages that read from left to right across 
the screen, such as Arabic, instead of right to left, such as English, you 
can change the direction of text to display the language the way it’s 
supposed to appear (New!). In the Property Inspector for text, you can 
use the Direction option to display text from left to right or right to left. 
If the Direction option is not available, you need to select the Show 
Right-to-Left Options on the Options menu in the Property Inspector or 
in Text Preferences.

Changing Text
Direction

Change Text Direction

Select the TLF text box you want to 
change with the Selection tool or 
select text within the TLF text box 
with the Text tool.

To show language related options 
(New!), click the Options button, 
and then click Show Right-to-Left 
Options to select it with a check 
mark.

To change the direction (New!), 
click the Direction list arrow, and 
then click Left to Right or Right to 
Left.

3

2

1

Did You Know?
You can always show right-to-left 
options. Select the Show Right-To-Left 
Text Options check box in the Text 
Preferences dialog box.

You can make right to left text flow the 
default. Select the Right To Left Text 
Flow check box in the Text Preferences 
dialog box.

1

2

3
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If you work with different languages that read vertically down the 
screen, such as Japanese, you can change the orientation of text to 
display the language the way it’s supposed to appear (New!). In the 
Property Inspector for text, you can use the Orientation option to dis-
play text horizontally or vertically. If you need the text to rotate and fol-
low the orientation of the line, you can set it to rotate automatically. If 
you’re working with Asian text, you can use the Advanced Paragraph 
section in the Property Inspector to select options for Mojikumi, 
Kinsoku Shori Type, and Leading Model. 

Changing Text 
Orientation

Change Text Orientation

Select the TLF text box you want to 
change with the Selection tool or 
select text within the TLF text box 
with the Text tool.

To change the orientation, click 
the Orientation button in the 
Property Inspector, and then click 
Horizontal or Vertical.

To show language related options, 
click the Options button, and then 
click Show Asian Options to 
select it with a check mark.

To change Asian text options, 
specify any of the following in the 
Advanced Paragraph section:

◆ Mojikumi. Select Auto, Space, 
or East Asian.

◆ Kinsoku Shori Type. Select 
Auto, Prioritize Least 
Adjustment, Push In Kinsoku, 
or Push Out Only.

◆ Leading Model. Select Auto, 
Roman Up, Ideographic Top Up, 
Center Up, Top Down, Center 
Down, or Ascent Descent Up.

4

3

2

1

Did You Know?
You can always show right-to-left 
options. Select the Show Asian Text 
Options check box in the Text 
Preferences dialog box.

1

3

2

4
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Create a Vertical Text Block 

Select the Classic text box you 
want to change with the Selection 
tool or select text within the 
Classic text box with the Text tool.

Click the Change Orientation 
button in the Property Inspector, 
and then click Vertical, or Vertical, 
Left To Right.

When you're finished, click 
anywhere on the Stage outside the 
text box.

Rotate Characters in a Text Box

Select a character or word in a 
text box or select the text box with 
the Selection tool.

In the Property Inspector, click the 
Rotate Text button (Classic), 
enabled only for vertical text 
boxes, or click the Rotation 
list arrow (TLF) (New!), and then 
click Auto, 0°, or 270°.

2

1

3

2

1

2

Vertical, Left to Right Orientation

Did You Know?
You can also rotate a text box with the 
Free Transform tool. Click the Free 
Transform tool, point to the outside 
edge of a corner (pointer changes to 
an arced arrow) , and then drag. 

Text rotates 90 degrees

Did You Know?
You can make vertical text the default 
orientation. Select the Default Text 
Orientation check box in the Text 
Preferences dialog box. This can be 
useful when working in some Asian 
languages.

2

3

Vertical, Right to Left 
Orientation
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The Properties Inspector provides advanced options for TLF text 
(New!). In the Advanced Character section, you can change the text 
case (such as upper or lower case), specify a baseline for multi-lan-
guage text or baseline shift (such as superscript or subscript), apply 
line breaks, and select the user’s language and region. Similar to a fea-
ture in Adobe Photoshop, you can apply blending modes (New!) and 
color effects (New!) to a text box in front of another element, such as 
a graphic, to create a new look from the mix of color pixels.

Changing Advanced 
Text Options

Change Advanced Character 
Options

Select the TLF text box you want to 
change with the Selection tool or 
select text within the TLF text box 
with the Text tool.

In the Advanced Character section 
of the Property Inspector (New!), 
specify any of the following:

◆ Case. Changes the text to upper 
or lower case, or caps.

◆ Digit Case. Changes the text to 
settings specified by the font 
designer.

◆ Digit Width. Changes the text 
to proportional or tabular 
widths.

◆ Dominant Baseline. Changes 
the multiple language text to a 
common baseline.

◆ Alignment Baseline. Changes 
the baseline alignment for 
multiple language text.

◆ Ligatures. Changes the running 
together of letters, such as 
“Th.”

◆ Break. Specifies the use of line 
breaks.

◆ Baseline Shift. Specifies the 
shift in the baseline in points 
(pt) or percentage (%). You can 
also select Superscript or 
Subscript for standard shifts.

◆ Locale. Specifies the user’s 
language and region.

2

1

2

1
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Add Display and Color Effects

Select the TLF text box you want to 
change with the Selection tool.

In the Display and Color Effect 
sections of the Property Inspector 
(New!), specify any of the 
following:

◆ Display. Click the Blending list 
arrow, and then select a 
blending effect.

◆ Normal. Removes the 
current blending effect.

With that in mind, the modes 
that produce the most stunning 
results are Multiply, Screen, 
Hard Light, and Difference. 

◆ Color Effect. Click the Style list 
arrow, and then select a color 
effect.

◆ None. Removes the current 
color effect.

◆ Brightness. Specifies the 
lightness/darkness of the 
text.

◆ Tint. Specifies the blending 
of a color and white (which 
increases lightness) for the 
text.

◆ Advanced. Specifies the 
blending of a color and an 
alpha blend for the text.

◆ Alpha. Specifies the 
blending of two colors 
(allowing for transparency) 
for the text.

2

1

Loading an External Text File

If you have a body of text that may change over time, you can use the 
ActionScript command LoadVars to load a text file (.txt). To load the 
text file headlines.txt (which contains headlines=”sample text”) into 
the headlines dynamic text box (instance is headlines_text and var is 
news_lv) using the LoadVars object, you can use a similar script: 
var news_lv:LoadVars = new LoadVars(); 
news_lv.load(“c:/yourfolderlocation/headlines.txt”); 
news_lv.onLoad = function () {

headlines_txt.text = news_lv.headlines; 
}

For Your Information

1

2
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When a line of text is created in Flash, it appears in a bounding box that 
is editable. Sometimes you might need to adjust the characters sepa-
rately or you might want to modify the shape of the characters them-
selves to create new character styles. The Break Apart command 
allows you to do this. There are two levels of breaking that you can uti-
lize. The first break will separate the text box into singular, editable 
characters. This is useful if you want to reposition or align the letters of 
a word independently. The second break severs the text from its font 
reference: in essence it becomes a shape that you can edit with any of 
the drawing tools or pen modifiers. 

Using Break Apart to 
Modify Characters

Break a Text Box into 
Single Characters

Select the text box you want to 
change with the Selection tool.

Click the Modify menu, and then 
click Break Apart.

Each character appears in its own 
editable box.

TIMESAVER Press A+B 
(Mac) or Ctrl+B (Win) to use the 
Break Apart command.

2

1

2

1

The text box is broken into separate text boxes 
that can be moved and edited separately.

Broken text box 
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Break a Text Box into Shapes

Select the text box you want to 
change with the Selection tool.

Click the Modify menu, and then 
click Break Apart.

The characters become individual 
text boxes.

Click the Modify menu again, and 
then click Break Apart.

The characters become simple 
shapes that you can adjust with 
Flash's drawing tools.

TIMESAVER Press A+B 
(Mac) or Ctrl+B (Win) twice to 
break text into editable shapes.

3

2

1

2

Text boxes become 
editable shapes.

See Also
See “Using the Free Transform Tool” 
on page 118 for information on trans-
forming objects.

Transforming Text

You can use the Free Transform tool or the options on the Modify 
menu under Transform to transform text boxes in the same ways you 
transform other objects. You can scale, rotate, skew and flip text 
boxes, but the text might become hard to read. However, you can still 
edit it. Important: when you scale a text box as an object, the point 
size in the Property Inspector may not be accurate. To restore a 
transformed object, select the object, click the Modify menu, point to 
Transform, and then click Remove Transform.

For Your Information

1

Characters become 
individual text boxes.
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Anti-aliasing affects the pixels on the edge of a shape by allowing 
them to blend in with the background. It is a crucial feature when work-
ing with some text as it makes it appear smoother and more integrated. 
Flash includes FlashType, a new text rendering feature that improves 
anti-aliasing and readability for fonts. FlashType is enabled whenever 
Flash Player 7 or later is the selected player, and anti-aliasing is set to 
anti-aliasing for readability or custom. The drawback with anti-aliasing 
is that at smaller font sizes the text can appear blurry. To avoid this 
problem, use sans serif text, such as Helvetica or Arial, and don’t use 
bold and italic. You can use anti-aliasing with static, dynamic, and input 
text. You apply anti-aliasing to text boxes instead of characters.

Using Anti-Alias Text

Set a Text Box to Anti-Alias Text 

Select the text box you want to 
change with the Selection tool.

In the Character section of the 
Property Inspector (New!), click 
the Anti-Alias list arrow, and then 
select one of the following:

◆ Use Device Fonts. The SWF file 
uses fonts installed on the local 
computer to display fonts.

◆ Bitmap Text (No Anti-Alias) 
(Classic). No text smoothing.

◆ Anti-Alias for Animation 
(Classic) or Animation (TLF). 
Smooths out animation.

◆ Anti-Alias for Readability 
(Classic) or Readability (TLF). 
Smooths out text.

◆ Custom Anti-Alias (Classic). 
Modify font properties.

2

1

Anti-alias text 
at small sizes

Alias text produces crisp 
fonts at small sizes.

Alias text

Anti-aliasing blends the edge 
pixels with the background.

2Classic text

2 TLF 
text
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If you open a document with a missing font on a computer, a Missing 
Font alert appears, asking you to choose a substitute font. You can 
open and use the Font Mapping dialog box to map a substitute font to 
the missing font, view the mapped fonts in the document, and delete a 
font mapping. After you select a substitute font, text appears with the 
correct font (if available) or the substitute font (if missing). When you 
use a substitute font, the text box or attributes might need to be 
adjusted.

Using Font Mapping

Select Substitute Fonts

Open the document with the fonts 
you want to map.

◆ To view all the font mappings 
saved on your computer, close 
all documents.

Click the Flash (Mac) or Edit (Win) 
menu, and then click Font 
Mapping.

Click a font in the Missing Fonts 
column.

TIMESAVER Press Shift+click 
to select multiple missing fonts to 
map to the same substitute font.

Click the Substitute Font list arrow, 
and then click a font, or click 
System Default.

Click OK.5

4

3

2

1

54

3

Did You Know?
You can delete the font mapping. Close 
all documents, click the Flash (Mac) or 
Edit (Win) menu, click Font Mapping, 
select a font mapping, click Delete, and 
then click OK.

You can turn off the Missing Font alert.
Click the Flash (Mac) or Edit (Win) 
menu, click Font Mapping, select the 
Don’t Show Again For This Document, 
Always Use Substitute Fonts check 
box, and then click OK.
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When you include a font in your Flash document that is installed on 
your computer, you can include the font into the exported Flash movie. 
This is called an embedded font and it ensures that your fonts will look 
consistent when displayed on other computers. This adds to the file 
size, as each character from the selected font family has to be included 
in the final SWF. If file size is an issue, and the exact character match-
ing is not important, you can choose to use device fonts. The Font 
Embedding dialog allows you to add or remove the fonts (all or part) 
you want to embed in the Flash document (New!). You can view a list 
of all your embedded fonts in one place. When a font is set to device, 
Flash will not embed the font information in the exported file. Instead 
the Flash Player will substitute the closest resembling font by name on 
the computer playing the Flash movie. The drawback is that you won't 
be able to predict how the fonts will display on every computer. To 
combat this uncertainty, Flash includes three device fonts. Each is 
designed with characteristics of typical fonts usually found by default 
on most computers. You can also choose device fonts when using small 
font sizes because they are not anti-alias and display clearly.

Setting Device Fonts 
Versus Embedded 
Fonts

Embed Fonts

Select the text box with the fonts 
you want to embed with the 
Selection tool.

Click the Embed button in the 
Property Inspector.

Click the Options tab, and then 
specify a font name, family, style, 
and character ranges you want.

To add or delete an embedded 
font, do either of the following:

◆ Add New Font. Click Add New 
Font button, and then specify 
the font information in the 
Options tab.

◆ Delete Font. Select a font from 
the Font list, click the Delete 
Selected Font button, and then 
click OK.

Click the ActionScript tab, and 
then select options to export font 
information for ActionScript or to 
share font information for runtime 
sharing.

Click OK.6

5

4

3

2

1 
654

3

Embedded fonts
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Set a Text Box to Device Font

Select the text box you want to set 
to the device font with the 
Selection tool.

Click the Anti-Alias list arrow in 
the Property Inspector, and then 
click Use Device Fonts.

Choose a Built-In Flash 
Device Font

Select the text box you want to set 
to the device font with the 
Selection tool.

Click the Family list arrow in the
Property Inspector or click the 
Text menu, point to Font, and then 
select one of the following fonts:

◆ _sans. Matches up with a sans-
serif font, such as Helvetica or 
Arial.

◆ _serif. Matches up with a serif 
font, such as Times or 
Garamond.

◆ _typewriter. Matches up with a 
typewritten-looking font, such 
as Courier.

2

1

2

1

2

1

1

2

Did You Know?
You can test for missing fonts. If there 
is incomplete font information on your 
computer, fonts may appear in the Font 
list in Flash but will not embed in the 
final movie. To test whether a font is 
complete, click the View menu, point to 
Preview Mode, and then click Anti-
alias Text. If the text appears jagged, 
this means the font outlines are miss-
ing from the system.
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When you create Classic text boxes in Flash, they default to static 
boxes. A static box is for display only and is hard-coded in the .swf. 
One cannot be changed unless you return to the Flash development 
environment, edit it, and re-export the file. If you need your text to be 
updatable from an outside source, such as a text document on a server 
or if you need the user to input text for you to retrieve and process with 
ActionScript, you can set your text box to enable this functionality. 
Setting your text box to dynamic text turns it into an ActionScript object 
that can be given an instance name or turned into a variable that can 
be populated from some other source outside of the .swf. This is great 
when you need to update content on the fly and would rather not have 
to deal directly with Flash for each update. If you require the user to 
enter a string of text, such as in a form, you can set a text box to input 
text. This enables the user to enter information in the text box that can 
be retrieved and processed.

Creating Classic 
Dynamic Text and 
Input Text

Set a Classic Text Box to be 
Dynamic

Select the Classic text box you 
want to be a dynamic box with the 
Selection tool.

Click the Text Type list arrow in the 
Property Inspector, and then click 
Dynamic Text.

Select from the following 
properties:

◆ Instance Name. Gives the text 
box an instance name so it can 
be controlled with ActionScript.

◆ Embed Options. Allows you to 
choose which characters you 
want to embed in the text.

◆ Letter Spacing. Changes 
character position on a line. 

◆ Render Text As HTML.
Preserves Rich Text Formatting, 
allowing you to include 
hyperlinks and HTML tags.

◆ Show Border. Displays a 
border around the text box in 
the exported movie.

◆ Variable Name. Gives the text 
box a variable name for use 
with ActionScript.

3

2

1

Show Border, Render Text As HTML

Variable Name

2

Instance Name

1

Embed Options

3

Line Type

Letter Spacing

Dynamic text boxes display in 
a dashed bounding box.
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Set a Classic Text Box to be an 
Input Box 

Select the Classic text box you 
want to be an input box with the 
Selection tool.

Click the Text Type list arrow in the 
Property Inspector, and then click 
Input Text.

Select from the following 
properties:

◆ Instance Name. Gives the text 
box an instance name so it can 
be controlled with ActionScript.

◆ Embed Options. Allows you to 
choose which characters you 
want to embed in the text.

◆ Letter Spacing. Changes 
character position on a line. 

◆ Line Type. Choose from Single 
Line and Multi-Line with or 
without Wrap, and Password 
(available only for Input text).

◆ Selectability. Allows or denies 
the user the ability to select the 
text in the exported movie.

◆ Show Border. Displays a 
border around the text box in 
the exported movie.

◆ Variable Name. Gives the text 
box a variable name for use 
with ActionScript.

◆ Maximum Characters. Limit the 
amount of characters a user 
can enter into the box.

3

2

1

Show Border, Render Text As HTML

Embed Options

Line Type

2

Instance Name

Maximum Characters

Input text boxes display in a 
dashed bounding box.

3

1

Letter spacing

Did You Know?
You can create scrolling text. Shift-
double-click the handle of dynamic and 
input text to create text boxes that 
don’t expand when you enter text on 
the Stage.

Using Multiple Languages in a Document

When you're working with Classic text in a Flash document, don't for-
get the global community. Flash supports multi-language authoring. 
You could create a document that displays text in Spanish and 
English, using a variety of methods: The text can be written within an 
external file and called using the #include ActionScript within a 
dynamic or text input box, or the text can be inserted into the docu-
ment at runtime using an external XML (Extensible Markup Language) 
file. This allows you to insert different languages that automatically 
appear to the visitor. When you're working with multi-language Flash 
documents, click the Window menu, point to Other Panels, and then 
click Strings. The Strings panel lets you streamline the process of 
localizing content into multiple languages, because it collects and 
tracks all character strings throughout the development process in a 
central place. In the Strings panel, you can select a language and 
assign each text string, either a  dynamic or input text box, in the 
document with a unique ID. The Strings panel has been improved to 
include multi-line support in the String box and the language XML file.

For Your Information

Variable Name
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Flash includes a global spell-checker that is fully configurable. Search 
the entire Flash document or isolate specific elements to search in the 
Spelling Setup dialog box. You can choose from a variety of built-in dic-
tionaries as sources including a personal dictionary you can edit. 
Additionally, you can choose which text characteristics to ignore, such 
as words with numbers and internet addresses, as well as choose what 
type of alternative suggestions you want Flash to provide.

Checking Spelling

Set Up Spell Checking

Click the Text menu, and then click 
Spelling Setup.

Select from the following options: 

◆ Document Options. Specify 
which elements in the Flash 
document you want to spell 
check. You can also specify 
whether you want to live-edit 
the document during the Check 
Spelling process.

◆ Dictionaries. Select a built-in 
dictionary as a source. At least 
one dictionary must be 
selected to activate Check 
Spelling.

◆ Personal Dictionary. Specify an 
option to use a dictionary 
created and edited by you. 
Navigate to a text document on 
your hard drive or edit the 
default one included by clicking 
the Edit Personal Dictionary 
button. Each new entry in the 
personal dictionary must be on 
a separate line.

◆ Checking Options. Set word-
level behaviors. You can have 
Internet addresses ignored, find 
duplicate words, or specify the 
types of suggestions you want 
displayed in the Check Spelling 
window.  

Click OK.3

2

1

3

Set parameters 
for Spell Check

Set new location 
for Personal 
Dictionary

Built-in 
Dictionaries

Spell Check
Set locations toAllow or deny on-the-fly 

editing during Spell Check
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Use Spell Checking

Click the Text menu, and then click 
Check Spelling.

If Flash finds suspect words, the 
Check Spelling dialog box opens. 
Otherwise, Flash displays a 
message that the Spell Check is 
complete.

Word not found (*element*):

This identifies the suspect word 
and what type of element it was 
found in parenthesis.

Do one of the following:

◆ Add To Personal. Click to add 
the word to your personal 
dictionary.

◆ Ignore. Click the Ignore and 
Ignore All buttons to not flag 
this word again in this Check 
Spelling session.

◆ Change. Click Change or 
Change All. In the Change To 
and Suggestions boxes, Flash 
displays the closest altern-
atives to the suspect word.

◆ Delete. Click to delete the word 
from the box that contains it.

Continue until Flash produces a 
message that Check Spelling is 
complete or click Close to stop the 
Check Spelling process before it is 
completed.

4

3

2

1

Ignore all incidences 
of the word

Change all 
incidences of the 
word

Ignore the word

Delete the text box 
from the document

Change the word to one from the 
suggestion list or one you’ve typed in

Adds word to your 
personal Library

Identifies the location (the 
element) the misspelled 
word is located in

Suggestions 
generated from 
built-in and 
personal 
dictionaries

Displays 
Misspelled word 
and allows you to 
enter a new one to 
replace it

2

3

Access 
Spelling 
setup

Did You Know?
You must access the Spelling Setup 
once to activate Check Spelling. You 
need to activate Check Spelling to 
select a dictionary. Click the Text 
menu, and then click Spelling Setup.

4
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Use Find and Replace to locate specific elements in your Flash docu-
ment. You can specify where to look, what to look for, and what to 
replace it with. Choose to search the entire Flash document or the cur-
rently active scene. Each element you search for has its own config-
urable settings and options. Included is a log that shows the exact 
locations of the found element.

Using Find and 
Replace

Locate Items with Find 
and Replace 

Click the Edit menu, and then click 
Find And Replace.

TIMESAVER Press A+F 
(Mac) or Ctrl+F (Win) to quickly 
open the Find and Replace 
window.

Select where you want to search 
from the Search In list arrow 
menu.

Select which element from the For 
list arrow menu you want to 
search for in Flash:

◆ Text

◆ Font

◆ Color

◆ Symbol

◆ Sound

◆ Video

◆ Bitmap

Enter and/or select the parameters 
you want for your search.

To find the element with the 
characteristics you've entered, 
click Find Next or Find All.

To update the found element with 
the new characteristics, click 
Replace or Replace All.

6

5

4

3

2

1

5

6

2

4

3
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Using Cascading Style Sheets with HTML Text

Cascading Style Sheets (CSS) contain sets of 
formatting rules for HTML and XML text. CSS 
allow you to define certain text attributes and 
give them a style name. This style name, 
called a selector, can be applied to any imple-
mented text. Each time you need to imple-
ment the defined style, you can refer back to 
the CSS. This allows for more control over the 
text displayed on your Web page. Load styles 
from an external CSS or create them within 
Flash using the Style Sheet Object. The 
ActionScript class for CSS is described as: 
TextField.StyleSheet. This is a new functional-
ity and it is only available to SWFs in the 
Flash 7 Player or later.

Load an external CSS

In any text or HTML editor, place the follow-
ing code:

// External CSS File: styles.css 
headline {

font-family: Arial, Helvetica, sans-serif; 
font-size: 12 px;

} 
bodyText {

font-family: Arial, Helvetica, sans-serif; 
font-size: 10 px;

}

This code is typically found in a CSS. This 
example defines two styles, one for a sans-
serif headline at 12 pixels, the other a sans-
serif body text at 10 pixels. 

Select the first frame of your Flash movie. 
Place the following code in the Actions panel:

var css_styles = new TextField.StyleSheet(); 
css_styles.load("styles.css"); 
css_styles.onLoad = function(ok) {

if(ok) { 
// display style names 
trace(this.getStyleNames());

} else { 
trace("Error loading CSS file.");

} 
}

The CSS you created, “styles.css” is loaded 
into this object. A loader is created to ensure 
the CSS is loaded properly. Make sure the 
CSS and the swf are in the same directory.

Create a CSS in Flash

Select the first frame of your Flash movie. The 
following code creates a text style for head-
line text and body text. Place the following 
code in the Actions panel:

var styles = new TextField.StyleSheet(); 
styles.setStyle("headline", 

{fontFamily: 'Arial,Helvetica,sans-serif', 
fontSize: '12px'}

); 
styles.setStyle("bodyText", 

{fontFamily: 'Arial,Helvetica,sans-serif', 
fontSize: '10px'}

);

This CSS code can now be placed in the 
Actions panel in Flash. This example defines 
two styles, one for a sans-serif headline at 12 
pixels, the other a sans-serif body text at 10 
pixels.

 From the Library of Wow! eBook



ptg

This page intentionally left blank 

 From the Library of Wow! eBook



ptg

Importing Graphics

Introduction

In addition to the vector drawing tools that allow you to cre-
ate graphics and animation in Flash, you can also import art-
work in other formats to use in your Flash movie. Flash has 
full native support for Adobe Photoshop, Adobe Illustrator, 
Adobe FXG, BMP, JPEG, GIF, and PNG files, the standard 
bitmapped graphics. However, you can also import EPS and 
PDF by using Adobe Illustrator. This allows you to import a 
variety of different graphic formats into your Flash produc-
tion process. 

Flash drawing tools create and edit vector objects, not 
pixels, so preparation is necessary for bitmapped graphics in 
a paint application outside of Flash, such as Adobe 
Photoshop. Fortunately, Flash allows you to convert a 
bitmapped graphic into a vector with the Trace Bitmap func-
tion. You can also use a bitmap as a fill for vector objects. An 
important thing to remember is that any bitmap used in your 
project can add considerable size to your Flash movie. Flash 
includes several procedures for optimizing these bitmaps on 
export, through compression settings applied globally, or 
specifically to each image. 6

6
What You’ll Do

Understand Vector and Bitmap Graphics

Examine Import File Formats

Set Illustrator Import Preferences

Set Photoshop Import Preferences

Import Photoshop and Illustrator Files

Import Bitmaps

Import Fireworks PNG Files

Import Multiple Files

Copy Images from Other Programs

Edit Bitmaps in an Outside Editor

Set Bitmap Compression

Use Break Apart to Create Fill Patterns

Modify a Bitmap Fill

Edit a Bitmap with the Magic Wand

Use Trace Bitmap to Create
Vector Shapes

193
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Understanding Vector and Bitmap Graphics

Vector graphics are comprised of anchor 
points connected to each other by lines and 
curves, called vectors. These anchor points 
and vectors describe the contour and surface 
of the graphic with some included informa-
tion about color, alpha, and line width. 
Because they are general descriptions of the 
coordinates of a shape, they are resolution-
independent; that is they can be resized with-
out any loss to the quality of the graphic. 
Resolution represents the amount of informa-
tion contained within a linear inch repre-
sented by a grid. 

Bitmapped graphics are made up of small, 
colored squares, called pixels that form a 
grid. Each pixel is given a specific color and a 
grid of these pixels forms a mosaic, which is 
your image. Because of this, bitmaps are 
dependent on resolution (the number of pix-
els in the grid). Resizing up or down forces 
pixels to be created or removed to accommo-
date the new grid size, which can result in a 
loss of image quality. In Flash, bitmaps look 
much better on the Stage when severely 
enlarged or reduced. The smoothing process 
makes the appearance of these bitmaps in 
the Flash authoring tool and in Flash Player 
now consistent.

Both vector and bitmap graphics have 
their strengths and weaknesses. Vector 
shapes are simple and graphic in nature. They 
are a good choice for creating high-contrast, 
geometric art or art with limited color shifts. If 
you need to implement artwork with a richer 
surface texture, color depth, and shading, like 
those qualities found in a photograph, a 
bitmap better suits this purpose. The strength 
of Flash as a content creator is that you can 
combine the strengths of both vector art and 
bitmapped art.

Bitmap Image

Vector Image
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Examining Import File Formats

The following image files can be imported into Flash:

The following files can be imported into Flash only if QuickTime 4 or later is installed on 
your system:

File Type Extension Windows Macintosh

Adobe Illustrator .ai ✓ ✓

Adobe Photoshop .psd ✓ ✓

Adobe FXG (New!) .fxg ✓ ✓

AutoCAD DXF .dxf ✓ ✓

Bitmap .bmp ✓ ✓ (Using QuickTime)

Enhanced Windows Metafile .emf ✓

GIF and animated GIF .gif ✓ ✓

JPEG .jpg ✓ ✓

PNG .png ✓ ✓

Flash SWF Movie .swf ✓ ✓

Windows Metafile .wmf ✓ ✓

QuickTime Image .qtif ✓ ✓

TIFF .tiff ✓ ✓

Image File Formats
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Setting Illustrator 
Import Preferences

Set Illustrator File Import 
Preferences

Click the Flash (Mac) or Edit (Win) 
menu, and then click Preferences.

Click the AI File Importer category.

Select from the following options:

◆ General.

◆ Show Import Dialog Box.
Select to show AI File 
Importer dialog box.

◆ Excludes Objects Outside 
Art Board. Select to exclude 
object outside the artboard 
or crop area.

◆ Import Hidden Layers.
Select to import hidden 
layers.

◆ Import Text As.

◆ Editable Text. Imports 
Illustrator text as editable 
text in Flash.

◆ Vector Outlines. Converts 
text to vector paths; use to 
preserve appearance.

◆ Bitmaps. Converts text into 
a bitmap; not editable.

◆ Create Movie Clips. Imports 
text into a movie clip; use to 
maintain blends, AI effects, 
and transparency.

3

2

1

Flash allows you to set preferences to customize the way you import 
Adobe Illustrator (.ai) files. You can specify general options to specify 
whether to use the import dialog box, import objects outside the 
Illustrator artboard or import hidden layers. After you set the general 
options, you can set options for specific element types you want to 
import, such as text, paths, images, groups, and layers. The options you 
set are applied to all Illustrator files when you import them into Flash. 
However, you can change options in the Illustrator import dialog box.

2

3
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◆ Import Paths As.

◆ Editable Paths. Imports
Illustrator path as editable 
in Flash.

◆ Bitmaps. Converts the path 
into a bitmap; use to 
preserve appearance of 
path; not editable.

◆ Create Movie Clips.
Imports path into a movie 
clip symbol in Flash.

◆ Images.

◆ Flatten Bitmaps To
Maintain Appearance. 
Converts an image into a 
bitmap; not editable.

◆ Create Movie Clips.
Imports an image into a 
movie clip symbol in Flash.

◆ Groups.

◆ Import As Bitmaps.
Converts all objects in the 
group into a bitmap; not 
editable.

◆ Create Movie Clips.
Imports all objects into a 
movie clip symbol in Flash.

◆ Layers.

◆ Import As Bitmaps.
Converts the layer into a 
bitmap; not editable.

◆ Create Movie Clips.
Imports the layer into a 
movie clip symbol in Flash.

◆ Movie Clip Registration. Select 
the global registration point for 
movies and all other object 
types.

Click OK.4

4

3
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Setting Photoshop 
Import Preferences

Set Photoshop File Import 
Preferences

Click the Flash (Mac) or Edit (Win) 
menu, and then click Preferences.

Click the PSD File Importer 
category.

Select from the following options:

◆ Import Image Layers As.

◆ Bitmap Images With 
Editable Layer Styles. 
Create a movie clip with a 
bitmap clipped inside.

◆ Flatten Bitmap Images.
Convert an image into a 
bitmap; not editable.

◆ Create Movie Clips.
Imports an image into a 
movie clip symbol in Flash. 

◆ Import Text Layers As.

◆ Editable Text. Imports 
Photoshop text from the 
text layer as editable text 
in Flash. 

◆ Vector Outlines. Converts 
text to vector paths; the 
object is also converted to 
a movie clip.

◆ Flattened Bitmap Images.
Converts text into a bitmap; 
not editable.

3

2

1

Flash allows you to set preferences to customize the way you import 
Adobe Photoshop (.psd) files. You can set options for specific element 
layer types you want to import, such as images, text, paths, shapes, 
and groups. You can also set compression and quality publishing 
options for the imported Photoshop files. The options you set are 
applied to all Photoshop files when you import them into Flash. 
However, you can change options in the Photoshop import dialog box.

2

3
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◆ Create Movie Clips. Imports 
the text layer into a movie 
clip symbol.

◆ Import Shape Layers As.

◆ Editable Paths And Layer
Styles. Creates an editable 
vector shape with a bitmap 
clipped inside the vector 
shape.

◆ Flatten Bitmap Images.
Converts an image into a 
bitmap; not editable.

◆ Create Movie Clips. Imports 
an image into a movie clip 
symbol in Flash.

◆ Layer Groups. Select the Create
Move Clips check box to 
convert all groups into a movie 
clip in Flash.

◆ Merged Bitmaps. Select the
Create Movie Clips check box to 
convert the shape layers into a 
movie clip in Flash.

◆ Movie Clip Registration. Select 
the global registration point for 
movies and all other object 
types.

◆ Publish Settings.

◆ Compression. Select the
Lossy (JPEG) or Lossless 
(PNG/GIF) compression 
mode you want.

◆ Quality. For the Lossy 
compression, select the Use 
Publish Setting or Custom 
option; select the quality 1 
to 100; the higher the 
setting, the greater quality, 
yet the larger the file size.

Click OK.4

4

3
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Flash includes support for importing Adobe Photoshop (.psd) files and 
Adobe Illustrator files created in versions 6 through 10. When these 
files are imported, there are a number of options you can choose from. 
Before you import Photoshop and Illustrator files, you need to set 
import options in the Preferences dialog box. For Illustrator files, you 
can also specify whether you want to show an import dialog box where 
you can set import settings for specific parts of an Illustrator file. The 
options you set are applied to all Illustrator and Photoshop files when 
you import them into Flash. However, you can change options in the 
import dialog box. Some options in the Import dialog box are context-
sensitive; that is, they only appear if they are relevant to the imported 
file. The import options are similar between Illustrator and Photoshop; 
when they differ, the options are noted.

Importing Photoshop 
and Illustrator Files

Import a Photoshop or 
Illustrator File

Click the File menu, point to 
Import, and then click Import To 
Stage or Import To Library.

◆ Open and select the library 
where you want to import files.

Click the Show popup (Mac) or 
Files Of Type (Win), and then 
select Photoshop, Adobe 
Illustrator or All Image Formats.

Navigate to the drive or folder 
where the file is located.

Select the Photoshop or Illustrator 
file you want to import.

Click Import (Mac) or Open (Win).

Flash inserts the image file or 
displays an import dialog box for 
files, where you can specify 
options for the specific files. If the 
Import dialog box opens, continue.

5

4

3

2

1

5

3

2

4

Did You Know?
You can import an Illustrator EPS or 
PDF using Illustrator CS4 or later. Open 
the file in Adobe Illustrator CS4 or later, 
save it as a CS4-compatible AI file, and 
then import into Flash as an AI file.
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To generate a list of items from
Illustrator now compatible with 
Flash, click Incompatibility Report.

Select the check boxes with the 
elements you want to import, 
select each element and set the 
related options you want; you may 
need to ungroup elements.

Click the Convert Layers To list 
arrow, and then click.

◆ Flash Layers. Click this option 
to convert the layers in the 
imported file into corresponding 
layers in the Flash Timeline.

◆ Keyframes. Click this option to 
convert the layers in the 
imported file into consecutive 
keyframes.

◆ Single Flash Layer. Click this 
option to flatten the layers in 
the imported file onto a single 
layer in Flash. 

Select from the following options:

◆ Place At Original Position.
Select to maintain the same 
positions from Illustrator or 
Photoshop to Flash.

◆ Set Stage Size To Same Size
As. Select to set the Flash 
Stage to the same size as the 
Illustrator artboard or 
Photoshop canvas.

◆ Import As Unused Symbols (AI).
Select to import AI symbols not 
used as instances as unused 
symbols in Flash.

◆ Import As A Single Bitmap
Image (AI). Select to convert 
into a bitmap.

Specify the compression and 
quality settings you want (PSD).

Click OK.11

10

9

8

7

6

11

7

9

8

10
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You can import bitmaps of several file types directly into Flash to use in 
your Flash movie. It is important to remember that even though you can 
edit and resize bitmaps in Flash, the original bitmap will always be 
embedded in the exported Flash file. If file size is an issue, it is best to 
bring your bitmapped art in at the size you want to export it. For exam-
ple, if your image is going to be 160 pixels by 160 pixels in the final 
movie, it is best to import it at this size and not resize it up or down in 
Flash. You will end up with higher-quality images and smaller files if you 
do this. You can import files using the Import To Stage or Import To 
Library methods. The Import To Stage method stores the bitmap in the 
Library and places a copy on the Stage, while the Import To Library 
method stores the bitmap in the Library and doesn't place a copy on 
the Stage.

Importing Bitmaps

Import a Bitmap to the Stage

Click the File menu, point to 
Import, and then click Import 
To Stage.

Click the Show popup (Mac) or 
Files Of Types list arrow (Win), 
and then select the format of the 
file you want to import. 

Navigate to the drive or folder 
where the file is located. 

Select the file you want to import.

Click Import (Mac) or Open (Win).5

4

3

2

1

54

3

2Did You Know?
You may not be able to see the images 
you've imported to the Stage at certain 
magnification levels. Flash aligns the 
top left-hand corner of the image at the 
0,0 coordinate. If you are zoomed in, 
the image may have appeared outside 
the viewable area. Use the Hand tool 
to navigate around, zoom out, or press 
Shift+A+W (Mac) or Ctrl+Shift+W 
(Win) to toggle the Work Area off. This 
sets the zoom level to 100% and hides 
the Work Area.

Scaling Image Before Importing
Scaling bitmaps reduces the quality of the image, so it’s best to 
import an image into Flash at the size you want it to be. If you need 
to scale an image in Flash, it’s a good idea to import the image at a 
slightly larger size, so when you scale it down, loss of quality is mini-
mized.

For Your Information
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Import to the Library

Click the File menu, point to 
Import, and then click Import 
To Library.

Click the Show popup (Mac) or 
Files Of Types list arrow (Win), 
and then select the format of the 
file you want to import.

Navigate to the drive or folder 
where the file is located. 

Select the file you want to import.

Click Import To Library (Mac) or 
Open (Win).

5

4

3

2

1

Image is placed in the Library.

54

3

2

Did You Know?
You can quickly swap bitmaps. You 
can exchange an image on the Stage 
with another one from the Library. To 
swap one bitmap with another on the 
Stage, select the bitmap image on the 
Stage, open the Property Inspector, 
click Swap, select the image you want 
from the list of currently stored images 
in your document library, and then 
click OK.
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You can import Adobe Fireworks PNG files into Flash as editable 
objects or bitmap images. When you import a PNG file as a bitmap 
image, the file, including any vector data, is flattened, or rasterized, and 
converted to a bitmap. When you import a PNG file as an editable 
image, the file retains any vector data, bitmaps, text (with default anti-
alias settings), filters (called effects in Fireworks) and guides. In Flash, 
you can retain Fireworks filters, blend modes, and text, and continue to 
modify them using Flash. When you import Fireworks files into Flash, 
PNG file graphic properties remain intact. You can also select multiple 
PNG files to import in a batch. When you batch PNG files, you select 
import settings one time. When you import a PNG as a flattened image, 
you can also edit the image in Fireworks directly from Flash. Flash 
updates the image with your changes from Fireworks creating easy 
round-trip edits.

Importing Fireworks 
PNG Files

Import and Edit Fireworks 
PNG Files

Click the File menu, point to 
Import, and then click Import To 
Stage or Import To Library.

Click the Show popup (Mac) or 
Files Of Types list arrow (Win), 
and then click PNG File or All 
Formats.

Navigate to the Fireworks PNG 
files you want to import, and then 
select one or more.

Click Import or Import To Library 
(Mac) or Open (Win).

To flatten the PNG file into a 
bitmap, select the Import as a 
Single Flattened Bitmap check 
box.

IMPORTANT To use round-trip 
editing, you need to flatten the 
PNG file into a bitmap. You cannot 
edit bitmaps from Fireworks PNG 
files imported as editable objects.

Click the Import popup, and then 
click Page or other available 
options.

Click the Into popup, and then 
click Current Frame As Movie Clip, 
New Layer or other available 
options.

7

6

5

4

3

2

1

3

5

4

2
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For objects and text, select one of 
the following: 

◆ Import As Bitmaps To Maintain 
Appearance. Retains Fireworks 
fills, strokes, and effects in 
Flash.

◆ Keep All Paths Editable. 
Retains vector properties; 
however, some Fireworks fills, 
strokes, and effects are lost; 
places file and related files in a 
Fireworks Objects folder in the 
Library.

Click OK.

To edit a flattened PNG bitmap, 
right-click (Win) or control-click 
(Mac) the PNG/bitmap’s icon in the 
Library, and then click Edit with 
and select an image editing 
program or click Edit with 
Fireworks.

◆ In the Edit Image dialog box, 
specify whether the PNG file or 
the bitmap file is to be opened.

◆ In Fireworks, edit the image, 
click Done or click the File 
menu, and then click Update.

10

9

8

9

10

PNG file from Fireworks

6

7

8

Did You Know?
You can optimize PNG images in 
Fireworks for Flash. Images can 
increase the size of a movie so you 
want to optimize images to be as small 
as possible while still maintaining high 
quality. You can optimize bitmap and 
PNG images in Fireworks using round-
trip editing from Flash. In Fireworks, 
specify options on the Optimize panel 
to optimize and compress images.
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Flash allows you to import multiple files simultaneously to save time. 
This is useful if you have many files to import. You can select multiple, 
non-sequential files in the Import dialog box. Choose to import to the 
Library or to the Stage directly. When you import to the Stage, the file is 
stored in the Library and a copy is placed on the Stage so you can 
begin editing it immediately. If you attempt to import a series of files 
that are numbered sequentially, Flash detects this and produces a dia-
log box to handle this. When sequential images are imported, they will 
appear in separate frames by order of the number in their file name. 
This is extremely useful for image sequences where a series of images 
forms an animation.

Importing 
Multiple Files

Import Multiple Files or a 
Sequence of Files

Click the File menu, point to 
Import, and then click Import To 
Stage or Import To Library.

Click the Show popup (Mac) or 
Files Of Types list arrow (Win), 
and then select the format of the 
file you want to import.

Navigate to the drive or folder 
where the file is located. 

Select the first file you want to 
import.

To import multiple files, hold down 
the A (Mac) or Ctrl (Win) key and 
click additional files to select 
them.

Click Import (Mac) or Open (Win).

For a sequence of files, Flash 
detects that this image is part of a 
sequence and asks whether you 
want to import all of them at once.

Click Yes.

The numbered files are imported 
and placed on separate sequential 
keyframes on the selected layer in 
the Timeline.

7

6

5

4

3

2

1

5

Multiple files imported 
appear stacked on top 
of each other. Press 
down and drag with 
your mouse to reveal 
images underneath.

4

Each imported image appears on a 
separate frame sequentially.

6

3

2
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You can paste a bitmap image from other image editing programs, such 
as Adobe Photoshop or Adobe Fireworks. Simply use the standard 
copying procedure in the program of your choice to place the bitmap 
into the clipboard, which is where the operating system dynamically 
stores information you copy, and then paste it into Flash directly on the 
Stage. Copying images from other programs works well for bitmaps. 
However, results are unpredictable when pasting vector graphics from 
other programs. Often they become corrupted when they are copied to 
the clipboard, depending upon the origin program or the operating sys-
tem. It is best to use the Import command to import vector graphics into 
Flash.

Copying Images from 
Other Programs

Paste from the Clipboard

Copy the image to the clipboard in 
an image-editing program.

Launch or switch to Flash, and 
then open the Flash document in 
which you want to paste an image 
from the clipboard. 

Select an unlocked layer or 
keyframe.

Click the Edit menu, and then click 
Paste in Center or Paste in Place.

TIMESAVER Press A+V 
(Mac) or Ctrl+V (Win) to quickly 
paste in center from the clipboard; 
press A+Shift+V (Mac) or 
Ctrl+Shift V (Win) to quickly paste 
in place from the clipboard.

4

3

2

1

3

Image is pasted 
onto the Stage 
and placed in the 
Library.
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You can edit a bitmap in its native program, such as Photoshop CS5 or 
Fireworks 3, or some other image editing tool. Once it is re-saved or 
updated to the hard drive, Flash automatically updates the bitmap back 
when you return to Flash (New!). If an image is moved to another loca-
tion, you can manually update it. In addition, you can import another 
image to replace the bitmap in the Library. In either case, every copy of 
the bitmap used in the Flash movie (including bitmap fills) will update 
with these changes. This is a convenient way to make global changes 
to bitmap art included in your project. 

Editing Bitmaps in an 
Outside Editor

Update an Image Edited Outside 
of Flash

Import a bitmap into Flash.

Open the Library panel.

Right-click (Win) or Control-click 
(Mac) the bitmap’s icon, and then 
click Edit with Photoshop CS5 or 
Edit with Fireworks 3.

◆ For other imaging programs, 
click Edit With, select an 
image-editing program, and 
then click OK.

In the image-editing program, 
modify the bitmap, click the File 
menu, and then click Save or 
Update, and then return to Flash.

The bitmap is automatically 
updated in Flash.

To manually update an image or 
relink to a different location, right-
click (Win) or Control-click the 
icon in the Library panel, click the 
Properties, click Update, and then 
click OK.

5

4

3

2

1

5Larger preview of the bitmap

3

2
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Replace a Bitmap

Open the Library panel, and then 
select the bitmap from the item 
list.

Click the Properties icon in the 
bottom of the panel or double-click 
the bitmap file in the list.

Click Import.

Navigate to the replacement file 
on your hard drive.

Select the replacement file.

Click Import (Mac) or Open (Win).

Change the name and any other 
options you want.

Click OK.8

7

6

5

4

3

2

1

3

6

Image is replaced with new imported image. All copies 
used in the Flash movie update to this new image.

5

8

4

Did You Know?
Flash preserves the path when you 
import a bitmap. When you import a 
bitmap into Flash, the path to that 
image is preserved in the Bitmap 
Properties. If you have moved the 
image to another directory on your 
hard drive and you want to update the 
file in the Library with the new 
changes, navigate to it by using the 
Import button in the Bitmap Properties 
window.
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When you export a Flash movie, you can decide how much color infor-
mation to include in each exported bitmap. This is called compression. 
The more compression you apply, the less color information is included 
and the lower the size and quality of the image. Lossy compression 
reduces the file size by removing color information, while lossless com-
pression reduces the file size (not as much) without removing informa-
tion. You can choose to set a global compression for all bitmap files 
used in a Flash movie or you can set a separate compression for each 
image. As with all image compression, file size needs to be weighed 
against image quality. It is always best to experiment until you get the 
results you want.

Setting Bitmap 
Compression

Set Compression for a Bitmap 

Open the Library panel.

Select the bitmap from the Library 
item list in which you want to set 
compression.

Click the Properties icon in the 
bottom of the panel or double-click 
the bitmap file in the list.

Select the Allow Smoothing check 
box to anti-alias the edges of the 
image, making it appear smoother.

Click the Compression popup, and 
then select from the following 
options:

◆ Lossless (PNG/GIF).
Compresses the image without 
losing any information; remains 
in its highest quality.

◆ Photo (JPEG). You can choose 
to use the compression 
information contained by 
selecting the Use Document 
Default Quality check box. By 
deselecting this feature you 
can set the level of JPEG 
compression applied to the 
bitmap. The values are 1-100. 
The higher the number, the less 
compression applied, 
producing a higher quality 
image.

Click OK.6

5

4

3

2

1

2

3

6

54
Thumbnail 
preview

Click to test 
and preview 
the image in 
thumbnail.

1
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By default, when you import a bitmap into Flash and drag it to the 
Stage, you are limited in how you can edit it. Break Apart the image to 
remove the image from its bounding box and enable you to cut into the 
image, remove parts, select regions, and use it as a fill pattern. The 
bitmap is still linked to its parent in the Library. Any edit made to a 
bitmap only affects the copy on the Stage. For example, if you break an 
image and then edit it down to a tiny portion, in the exported movie the 
image appears exactly as you edited it. However, it will still have the 
same file size of the image you imported (less any compression you 
may have applied). It is always best to do your most severe editing in a 
bitmap or paint program outside of Flash.

Using Break Apart to 
Create Fill Patterns

Create a Bitmap Fill Pattern

Drag a copy of a bitmap to the 
Stage from the Library panel; make 
sure the bitmap is selected on the 
Stage.

Click the Modify menu, and then 
click Break Apart.

TIMESAVER Press A+B 
(Mac) and Ctrl+B (Win) to quickly 
break apart a bitmap on the Stage.

Click the Eyedropper tool on the 
Tools panel. 

Position the eyedropper over the 
image, and then click to select it.

The bitmap is a selected fill that 
you can use to fill vector shapes.

Click the Rectangle or Oval tool on 
the Tools panel.

Click and drag on the Stage to 
create a new shape with the 
bitmap fill.

6

5

4

3

2

1

3

4

6

5

Bitmap becomes the selected fill.

Did You Know?
You can select the bitmap fill in the 
Color Mixer panel. In the panel, click 
Bitmap from the Fill Style popup, and 
then select a thumbnail fill (bitmaps 
from the Library appear). 
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Flash defaults to tiling a bitmap fill. Tiling is simply when an image is 
repeated in a grid until it fills the entire object. If you have applied a 
bitmap fill to a vector object, you can continue to edit its characteris-
tics and placement. You can resize, skew, or rotate the fill or change its 
center point within the shape with the Gradient Transform tool. This tool 
allows you to dynamically make these changes when it is applied to 
any editable shape. As with most of the assets Flash stores in the 
Library, any change you make to the application of the fill does not 
affect the master object stored in the Library. In this way, bitmaps like 
video clips and sounds, behave similarly to symbols in that their master 
object is not affected. Although when you use a bitmap in your movie 
Flash refers to this as a copy, not an instance, because there are no 
built-in controls for bitmaps.

Modifying a Bitmap 
Fill

Change the Center Point

Create a shape on the Stage with 
a bitmap fill.

Click the Gradient Transform tool 
on the Tools panel. 

The pointer changes to an arrow 
with a small gradient box in the 
right-hand corner. 

TIMESAVER Press F to quickly 
select the Gradient Transform tool.

Click the shape to select it.

A bounding box appears on the 
tile.

Position the pointer over the white 
circle in the center of the 
bounding box.

The cursor becomes a Move icon.

Click and drag the center point to 
a new position.

The tile accommodates to the new 
position of the center point.

5

4

3

2

1

4

Bitmap fill in 
new location

1 Bounding box

5

2
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Modify the Orientation and Size 
of a Bitmap Fill

Create a shape on the Stage with 
a bitmap fill.

Click the Gradient Transform tool 
on the Tools panel. 

The pointer changes to an arrow 
with a small gradient box in the 
right-hand corner.

Position the pointer over the 
shape, and then select it.

A bounding box appears on the 
tile.

Do one of the following:

◆ Bottom-left-corner square.
Drag this to resize the fill 
proportionally.

◆ Left-center square. Drag this to 
resize width of fill.

◆ Bottom-center square. Drag 
this to resize height of fill.

◆ Top-right-corner circle. Drag 
this to rotate fill.

◆ Top-center circle. Drag this to 
skew fill horizontally.

◆ Right-center circle. Drag this to 
skew fill vertically.

4

3

2

1 2

3

Resize proportionally Resize width Resize height

Rotate Skew horizontally Skew vertically

Circle handleSquare handle

Samples of various fills
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When you use Break Apart on a bitmap, the bitmap becomes a fill and 
its content is editable. You can select specific regions of it with any of 
Flash's selection tools and procedures. If you want to remove parts of 
the bitmap or replace them with different fills you can select those 
parts with the Magic Wand tool. The Magic Wand tool selects regions 
of similar colors. Clicking on other parts adds those parts to the selec-
tion. The color threshold (or sensitivity) for this tool can be set in the 
Magic Wand options popup menu.

Editing a Bitmap with 
the Magic Wand

Use the Magic Wand

Select a bitmap on the Stage.

Click the Modify menu, and then 
click Break Apart.

TIMESAVER Press A+B 
(Mac) or Ctrl+B (Win) to quickly 
break apart a bitmap on the Stage.

Click on the Stage to deselect the 
broken bitmap.

Click the Lasso tool on the Tools 
panel.

Click the Magic Wand Mode 
button in the Options section of the 
Tools panel.

The pointer becomes a small 
magic wand.

Position the pointer over regions 
of the image you want to select.

The color region you clicked on is 
selected. Subsequent clicks on 
other regions are added to the 
selection.

6

5

4

3

2

1

4

5

6

Color regions selected 
and deleted from 
bitmap fill.

3
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Set the Magic Wand Options

Click the Lasso tool on the Tools 
panel.

Click the Magic Wand Properties 
button on the Tools panel.

Enter a color threshold between 0 
and 200. 

This number defines how close 
adjacent colors have to be to the 
selected color before they are 
added to the selection. A higher 
number selects a broader number 
of colors.

Click the Smoothing popup, and 
then select from the following 
options: Pixels, Rough, Normal, 
and Smooth.

This sets the smoothness of the 
edges of the selection. 

Click OK.5

4

3

2

1

2

3

5

4

1
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Flash provides a procedure to convert bitmaps into vector art. When 
Trace Bitmap is used, Flash interprets the pixel information in the 
bitmap and converts it into vector shapes. The results can be unpre-
dictable in quality and have unwieldy file sizes if the bitmaps are very 
complex. However, there are several parameters in the Trace Bitmap 
dialog box that can be modified to strike a balance between file size 
and quality.

Using Trace Bitmap to 
Create Vector Shapes

Trace a Bitmap

Drag a copy of a bitmap to the 
Stage from the Library panel; make 
sure the bitmap is selected on the 
Stage.

Click the Modify menu, point to 
Bitmap, and then click Trace 
Bitmap.

TROUBLE? The Trace Bitmap 
command is disabled if you select 
a broken bitmap (a bitmap fill).

Specify values and options to 
determine how close the vector 
shape resembles the bitmap:

◆ Color Threshold. If the 
difference in the RGB color 
value for two pixels is less than 
the color threshold, the pixel 
colors are considered the 
same. Enter a value between 1 
and 500. The higher the value, 
the lower the number of colors. 

◆ Minimum Area. Determines 
how many neighboring pixels to 
include in the threshold 
calculation. Enter a pixel value 
between 1 and 1000.

◆ Curve Fit. Determines how 
smoothly Flash creates vector 
outlines.

◆ Corner Threshold. Controls 
whether to preserve sharp 
edges or create more smooth 
contours.

Click OK.4

3

2

1
4

3

Vectorized bitmap

Creating Vectors Closest to the Original Bitmap
Adobe recommends using the following settings in the Trace Bitmap 
feature to produce a vector version that is closest to the original 
bitmap: Color Threshold = 10, Minimum Area = 1 pixel, Curve Fit = 
Pixels, and Corner Threshold = Many Corners. However, depending 
on the complexity of the bitmap, this can produce very large and 
unwieldy file sizes and, in some cases, take a long time for Flash to 
complete the operation.

For Your Information
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Creating Frame-by-Frame 
Animation

Introduction

Flash provides several methods for creating animation. In 
addition to shape and motion tweening, you can create 
frame-by-frame animations. The frame-by-frame method is 
derived from the traditional animation process whereby the 
content is redrawn on each frame with slight differences from 
the last frame. When these frames are played in sequence, 
there is an illusion of movement. In Flash, you utilize 
keyframes in the Timeline to accomplish this. A keyframe
defines a change to the artwork placed on the Stage. There 
are a number of ways to create and edit keyframes, as they 
are editable objects. Keyframes can be moved, copied, and 
pasted to and from any Timeline in your Flash movie or 
between different Flash documents. Frame-by-frame anima-
tions can be previewed in the Flash development environ-
ment so you can quickly see the results and check your work 
as you animate. They can also be viewed in the Flash Player 
using the Test Movie options. 

Additionally, there is an Onion Skin mode that allows you 
to see the active frame in context to the frames around it, 
making it easier to fine-tune keyframe changes. The versatility 
of the Timeline and the strength of the Flash Player allow you 
to implement animation in your movie and give it life. 7

7
What You’ll Do

Understand Frame-by-Frame Animation

Create Keyframes

Convert Frames to Keyframes

Use Frame-Based Versus Span-
Based Selection

Clear Keyframes Versus Removing 
Frames

Edit Keyframes

Create a Simple Frame-by-Frame 
Animation

Play an Animation

Use Onion Skinning

Modify Onion Skin Markers

Edit Multiple Frames

217
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Animation is the illusion of movement. It is 
comprised of a series of pictures, each slightly 
different from the last, that when played 
sequentially imply movement. Motion pic-
tures work the same way. What you see when 
you view a film is a long strip of images 
played at specific intervals. In this way, the 
content in the pictures moves and seems to 
imitate real life.

Traditional cell animators draw a picture 
onto a frame of celluloid and then draw the 
same thing onto the next frame but with 
slight changes made to the drawing. Static 
parts of the scene (such as a background) are 
copied and only the objects that change are 
redrawn. In this way the process is more effi-
cient.

The principles for animating in Flash have 
derived from this process. In Flash, you create

frame-by-frame animations in the Timeline 
through the use of keyframes. Each keyframe 
defines a change on the Stage, and when 
played in succession, the content can seem to 
evolve, or move. When you export your 
movie, Flash will play these frames in succes-
sion at specific intervals depending on the 
frame rate you set. A good introduction to this 
concept, as well as the basics of animation, is 
the dissection a character walk cycle. When 
human beings walk, they are essentially 
repeating the same motion over and over 
again. In an animated walk cycle, the same 
thing occurs, though instead of drawing the 
cycle over and over again, the motion is 
spaced out so that the last frame (the last 
image drawn) meets up with the first frame. If 
this animation is looped, the character will 
seem to walk perpetually. 

Understanding Frame-by-Frame Animation

Static elements such as 
the sidewalk span across 
multiple frames.

Keyframes define 
changes. Each frame 
displays a different 
part of the walk cycle.
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Frame 4                                                            Frame 5                                                             Frame 6

Frame 7                                                        Frame 8

Frame 1                                                           Frame 2                                                             Frame 3

Frame-by-Frame Animation
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When art is placed on the Stage, it appears in a keyframe in the 
Timeline. A keyframe is represented as a black-bounded box with a 
small circle in it. By default, each layer in the Timeline has a keyframe 
on its first frame. An empty keyframe displays an empty or hollow cir-
cle, but when you place artwork or objects on the Stage, the bounding 
box becomes shaded and the small circle becomes a filled black dot. A 
keyframe can span multiple frames when there are no changes to the 
art. To make a change you create another keyframe. In this way, you 
can create animations or content that seems to move or change over 
time.

Creating Keyframes

Create a Keyframe

Place art or an object on the 
Stage.

Click on a frame later in the 
Timeline.

Click the Insert menu, point to 
Timeline, and then click Keyframe.

A new keyframe appears.

TIMESAVER Press F6 to add a 
keyframe or Control+click (Mac) or 
right-click (Win) the selected 
frame, and then click Add 
Keyframe.

3

2

1

Empty keyframe appears 
as a hollow circle.

When content is placed 
on the Stage, the hollow 
dot becomes a filled 
black dot.

2

New keyframe appears

Framespan

Did You Know?
You can remove content from a 
keyframe. Select a filled keyframe in 
the Timeline or the art on the Stage 
contained in that keyframe, and then 
press the Delete (Mac) or Backspace 
(Win) key.
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Create a Blank Keyframe

Click on a frame in the Timeline 
where you want to add a blank 
keyframe.

IMPORTANT You can only add 
a blank keyframe to a frame 
without an existing keyframe 
(sometimes called an inactive 
frame or keyspan).

Click the Insert menu, point to 
Timeline, and then click Blank 
Keyframe.

TIMESAVER Press F7 to add a 
keyframe or Control+click (Mac) or 
right-click (Win) the selected 
frame, and then click Add Blank 
Keyframe.

Increase the Keyframe Span

Click anywhere in a keyframe 
span.

◆ To insert multiple keyframes, 
select the number of frames 
you want.

Click the Insert menu, point to 
Timeline, and then click Frame.

Repeat until you've increased the 
framespan to the length you need.

TIMESAVER Press F5 to add a 
frame or Control+click (Mac) or 
right-click (Win) the selected 
frame, and then click Insert Frame.

2

1

2

1 
1

1

Blank keyframe appears

A framespan increased by 10 frames

Inserts one frame

Did You Know?
You can decrease the keyframe span.
Press Shift+F5 for each frame you want 
to remove.
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Any frame can be converted into a keyframe. As a time-saver, you can 
select a range of frames and convert them all into keyframes simulta-
neously. This is useful when you have many frames to convert. It is also 
a good technique for fine-tuning shape and motion tweens. After the 
tween has been applied, you can convert the frames in the tweened 
span into keyframes and edit them independently. 

Converting Frames to 
Keyframes

Convert Multiple Frames 
Into Keyframes

Click on a frame, and then drag to 
select a frame span.

Click the Modify menu, point to 
Timeline, and then click Convert 
To Keyframes.

TIMESAVER Press Ctrl+click 
(Mac) or right-click (Win) the 
selected frames, and then click 
Convert To Keyframes or Press F6 
after selecting all of the frames 
you want to convert.

2

1

1

Selected frames are 
converted into keyframes.

Did You Know?
You don't have to select a frame to add 
keyframes. If you place the playhead 
over a frame and add a keyframe or a 
blank keyframe, it appears without you 
having to select the actual frame. 
However, if you are working with multi-
ple layers, Flash adds a keyframe to all 
layers at that frame if no frame is 
selected.

 From the Library of Wow! eBook



ptg

Chapter 7 Creating Frame-by-Frame Animation 223

Depending upon how you like to work, you can choose between two 
selection modes in Flash. The default mode is frame-based selection. In 
this mode, frames are treated as individual elements. When span-
based selection is chosen, Flash treats frames as part of a frame span, 
which means all of the frames adjacent to a keyframe are selected as a 
unit. You can accomplish the same tasks in either mode and you can 
switch between the two depending upon the task at hand.

Using Frame-Based 
Versus Span-Based 
Selection

Set the Frame Selection Style

Click the Flash (Mac) or Edit (Win) 
menu, and then click Preferences.

If necessary, click the General 
category.

Select the Span Based Selection 
check box to enable span-based 
selection or clear it to enable 
frame-based selection.

Click OK.4

3

2

1

3

Frame-based selection: 
Clicking once on a frame selects that frame

Span-based selection: 
Clicking once on a frame selects the entire span

2

4

Did You Know?
You can select a single frame in span-
based mode. Press A+click (Mac) or 
Ctrl+click (Win) the frame. Likewise, to 
select a span of frames in frame-based 
mode, click the first or last frame in the 
span, and then drag until you've 
selected the entire span.
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Depending on what you are trying to accomplish, you can choose to 
remove a frame's status as a keyframe or remove the frame entirely. 
Clearing a keyframe preserves the length of the framespan and the 
overall duration of the animation on the layer. It simply turns the 
keyframe back into a regular frame and removes any changes the 
keyframe contained. Conversely, removing frames deletes the entire 
frame and shortens the framespan as well as the length of your anima-
tion in the Timeline.

Clearing Keyframes 
Versus Removing 
Frames

Clear Keyframes

Click on the frame to select it or 
click and drag to select a range of 
frames.

Click the Modify menu, point to 
Timeline, and then click Clear 
Keyframe.

Flash converts the keyframe back 
into a regular frame.

TIMESAVER Press Shift+F6 to 
clear keyframes.

2

1 
1

The duration is maintained

The keyframe is cleared
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Remove Frames

Click on the frame to select it or 
click and drag to select a range of 
frames.

Click the Edit menu, point to 
Timeline, and then click Remove 
Frames.

Flash removes the selected 
frame(s) and shortens the length 
of the animation.

TIMESAVER Press Shift+F5 to 
remove frames.

2

1 
1

The duration is shortened
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Keyframes are editable elements. You can add or remove content from 
a keyframe, move keyframes around by simply dragging, or copy and 
paste keyframes in the same Timeline, across scenes and even other 
Flash documents. Because keyframes are so versatile, you can con-
tinue to fine-tune your animations after they are created. When the 
playhead is placed on a frame, the content of that frame is displayed on 
your Stage. Selecting the keyframe in the Timeline selects all of the 
content on that keyframe on the Stage. Likewise, selecting any of your 
content on the Stage will select its corresponding keyframe. In this 
way, you can interactively edit the content in a keyframe or the 
keyframe's position in the Timeline and know what you are affecting.

Editing Keyframes

Copy and Paste Keyframes 

Click on the keyframe to select it 
or click and drag to select a 
keyframe and a range of frames.

Click the Edit menu, point to 
Timeline, and then click Copy 
Frames.

TIMESAVER Press 
Option+A+C (Mac) or Ctrl+Alt+C 
(Win) to copy frames.

Click on the frame where you want 
to paste the frames.

Click the Edit menu, point to 
Timeline, and then click Paste 
Frames.

TIMESAVER Press 
Option+A+V (Mac) or Ctrl+Alt+V 
(Win) to paste frames.

4

3

2

1 1

Frames are pasted starting 
on selected frame.

3
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Drag and Drop Keyframes 

Click on the keyframe to select it 
or click and drag to select a 
keyframe and a range of frames.

Click again on the selected 
frame(s), and then drag to a new 
area of the Timeline. 

2

1 
1

Frames copied to the new location.

Move frames as you drag.

The plus sign (+) 
modifier indicates a 
copy has been engaged.

Frames are moved to the 
new location.

Press the Option key (Mac) or the Alt key (Win) 
to copy frames as you drag them.

Did You Know?
It’s important to understand the differ-
ence between the normal copy and 
Paste commands and the copy frames 
and Paste Frames commands. When 
you copy and paste frames you are 
copying the keyframes and in-between 
frames and the content contained in 
them. Pasting them preserves the 
structure and layout. If you select a 
keyframe and use the normal copy and 
paste commands A+C and A+V 
(Mac) or Ctrl+C and Ctrl+V (Win), you 
are only copying the content contained 
in that keyframe.

You can use drag and drop to copy 
frames. Press and hold down the 
Option (Mac) or Alt (Win) key as you 
drag frames, Flash copies them to a 
new location. 
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Flash incorporates the traditional animation technique with its use of 
keyframe-based animation. Artwork is placed in a keyframe in the 
Timeline and subsequent keyframes are created to record changes to 
the artwork. When played consecutively, these minute changes mimic 
movement as each keyframe describes an altered position or transform 
effect. Static art that does not change is stored on separate layers and 
can span the entire animation. In this way, you don't have to redraw the 
entire frame and you can quickly create complex animations.

Creating a Simple 
Frame-by-Frame 
Animation

Create a Frame-by-Frame 
Animation

Create a new Flash document or 
open an empty Timeline.

Click the first frame to select it. 

Click the Oval tool on the Tools 
panel.

Click on the Stage, and then drag 
to draw a circle.

Click the second frame to select it. 

Click the Insert menu, point to 
Timeline, and then click Keyframe.

TIMESAVER Press F6 to insert 
a keyframe.

Select the second keyframe or 
double-click the circle on the 
Stage and drag it slightly to the 
right.

7

6

5

4

3

2

1

3 
4

2

5

7
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Click on the third frame to select it.

Repeat step 6. 

Select the third keyframe or 
double-click the circle on the 
Stage and drag it slightly further to 
the right. 

Continue to add keyframes and 
move the circle until it reaches the 
right edge of the Stage.

IMPORTANT The more 
keyframes you add the smoother 
the animation is.

Click the Playhead and move it 
across the frames to preview the 
movement of the circle.

12

11

10

9

8

10

8

The circle 
is moved 
frame-by-
frame until 
it reaches 
the other 
side of the 
Stage.
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In addition to moving the playhead in the Timeline to view your anima-
tion, commonly called scrubbing, Flash provides a controller to navi-
gate the Timeline. The Controller resembles the transport controls on a 
VCR and can be used in the same way. Additionally, you can export 
your Flash document into a Flash movie (a .swf file). You do this to see 
your Flash movie in its final state, as there are some elements that are 
not viewable in the Flash Development environment, such as anima-
tions contained in movie clip symbols and ActionScript functionality. To 
preview basic animations from their own Timeline, you can use the 
Controller to preview them.

Playing an Animation

Use the Controller to Play 
an Animation 

Click the Window menu, point to 
Toolbars, and then click 
Controller.

To stop the animation, click Stop.

To rewind to the first frame of the 
animation, click Rewind To 
Beginning.

To step back one frame, click Step 
Back.

TIMESAVER Press the <  key 
to step back a frame.

To play or stop the animation, click 
Play.

TIMESAVER Press Return 
(Mac) or Enter (Win) to play if 
stopped or to stop if playing.

To step forward one frame, click 
Step Forward.

TIMESAVER Press the >  key 
to step forward a frame.

To fast-forward to the end of the 
animation, click Go To End.

7

6

5

4

3

2

1

3 5

2 4 6

1

7
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Test Animation in the 
Flash Player

Click the Control menu, point to 
Test Movie, and then click Test.

The Test command tests the movie 
based on the current test option. 
Flash uses the document type the 
default until you change it.

For the in Flash Professional test 
option, Flash exports the entire 
Timeline and any other scenes 
you've created into a SWF file that 
plays in the Flash Player.

TIMESAVER Press A+Return 
(Mac) or Ctrl+Enter (Win) to test a 
movie.

1

Animated man

Test Movie (in Flash Professional) exports 
the Flash movie with the SWF extension, 
which plays in the Flash Player. 

1

Current test option
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Normally, the playhead shows one frame at a time—the frame it’s 
placed on. As you play the Timeline, the Stage displays the content of 
one frame at a time, forming your animation. Onion Skinning mode 
allows you to view multiple frames simultaneously. This is useful for 
fine-tuning your animation, because you can see the content on the 
frames immediately preceding and following the active frame. 

Using Onion Skinning

Activate Onion Skinning

Open a Timeline with a multiple 
frame animation. 

Click the Onion Skin Mode button 
in the Status bar.  

Onion skin markers appear in the 
area above the frame numbers 
and the area of the range of 
frames selected dims. The frames 
that precede the active frame and 
the frames that follow appear in 
varying degrees of shading on the 
Stage, becoming lighter the further 
they are from the active frame. 

2

1

1

2

Onion Skinning allows 
you to see the content 
on all the frames.

Onion Skin Markers
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Use Onion Skin Outlines

Open a Timeline with a multiple 
frame animation. 

Click the Onion Skin Outlines 
button in the Status bar. 

The frames that precede the 
active frame and the frames that 
follow appear as outlines on the 
Stage.

2

1

1

Did You Know?
You can only edit the active frame.
This is the frame the playhead is on. 
The art that appears when Onion Skin 
(regular and outline) is enabled is for 
preview only.   

Onion Skin 
Outlines 
mode

2
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You can adjust the number of frames previewed in the onion skin by 
manually dragging the onion skin markers. These markers have drag-
gable handles that set the beginning and end of the onion skin. The 
handles appear as brackets with small dots. Alternately, you can 
set the range of the markers from the Modify Onion Markers popup 
menu.

Modifying Onion Skin 
Markers

Set Onion Skin Markers 
Manually

Click the Onion Skin Mode button 
in the Status bar, if necessary  

Click on the small dot on either 
end of the onion skin markers and 
then drag to include or exclude 
any consecutive frames in the 
onion skin.

2

1

Did You Know?
You can only edit the active frame in 
the onion skin. To edit other frames 
and maintain the selected frames, 
select Anchor Onion in the Modify 
Markers popup menu. 

2

1

More frames are 
contained in the Onion 
Skin Markers, so more of 
the animation is seen 
simultaneously.
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Set Onion Skin Markers in 
Modify Onion Markers Window

Click the Modify Onion Markers 
button.

The Modify Onion Markers popup 
appears.

Select from the following options:

◆ Always Show Markers. Keeps 
Onion Skin Markers visible in 
and out of Onion Skin mode.

◆ Anchor Onion. Maintains the 
selected frames even if you 
move the playhead. 

◆ Onion 2. Shows two frames 
before and after the current 
frame.

◆ Onion 5. Shows five frames 
before and after the current 
frame.

◆ Onion All. Includes the entire 
duration of the Timeline in the 
markers.

2

1

2

Command Description

Always Show Markers Keeps Onion Skin Markers visible in and 
out of Onion Skin mode.

Anchor Onion Prevents the Markers from moving as you 
move your playhead.

Onion 2 Selects two frames before and after the 
active frame.

Onion 5 Selects five frames before and after the 
active frame.

Onion All Selects all the frames in the Timeline.

Onion Skin Markers

1
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If you need to make changes to an entire animation or to a series of 
frames at once, you can select them in Edit Multiple Frames mode. 
When this feature is enabled, brackets appear similar to those in Onion 
Skinning mode. Drag them to select the range of frames you want to 
edit. This works well if you need to make global changes to your anima-
tion such as resizing it or changing its location. You can select an entire 
framespan or layer instead of moving or resizing the content on each 
individual frame separately.

Editing Multiple
Frames

Select Multiple Frames

Open a Timeline with a multiple 
frame animation. 

Click the Edit Multiple Frames 
button in the Status bar. 

Click and drag the markers until 
they include all the frames you 
want to select.

All of the content in the selected 
frames appears on the Stage.

Click the Selection tool on the 
Tools panel.

TIMESAVER Press V to select 
the Selection tool.

Drag a selection box around the 
content on the Stage.

You can make changes to location, 
scale, effects, etc. All the selected 
frames will be affected.

TIMESAVER Press A+A 
(Mac) or Ctrl+A (Win) to select all 
the content on all unlocked layers.
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Did You Know?
When Edit Multiple Frames is acti-
vated, it selects all of the frames on all 
layers contained in the markers. You 
must lock any layers you don't want 
included in the selection. 

2
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Understand Motion Tweening

Apply Motion Tween Presets

Create a Motion Tween

Adjust Motion Tween Properties

Edit Motion Tween Properties with 
the Motion Editor

Add Color Effects and Filters

Work with Property Keyframes

Edit the Path of a Motion Tween

Copy Motion as ActionScript
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Introduction

In Flash, it’s not necessary to draw every frame of an anima-
tion. You can set the position and attributes of your art in the 
beginning and ending frames, and Flash will create all of the 
frames in between. This is called tweening. A motion tween 
connects two keyframes, each with different effects or charac-
teristics applied to them and then gradually "morphs" one 
into the other. Tweening allows you to quickly animate 
objects, apply fades, and gradually alter color, alpha, scale, 
and any other effect that can be applied to a symbol, group, 
or text object. 

The span between the starting frame and ending frame of 
a motion tween is called the tween span. The tween span 
consists of a group of frames in a single layer with a blue 
background in the Timeline in which an object changes over 
time. Only one object, known as the target object, on the 
Stage can be animated in each tween span.

Once an animation is tweened, you can continue to edit it 
by adding or removing frames to make it move slower or 
faster, adjust effects, or control the inertia with ease-in and 
ease-out properties, adding further complexity. Motion 
tweening produces smaller files than frame-by-frame anima-
tion because Flash describes the motion mathematically, 
incrementally transforming the object in between the two 
keyframes. 
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Motion tweening allows you to apply smooth 
motion and transform effects, such as scale, 
position, rotation, and skew, to symbol 
instances (movie clip, graphic, and button) 
and text fields. Additionally, you can utilize 
Flash's advanced color effects to apply 
changes to color, alpha, and brightness. 

Because these effects are applied to 
instances, they only affect the instance placed 
on the Stage. Its parent (original) symbol in 
the Library is not affected. Motion tweening 
produces the smallest file sizes of any of 
Flash's animation methods.

Flash use two different types of motion 
tweens: classic tween and motion tween. A 
classic tween uses several instances in 
keyframes of an object along with property 
keyframes to create a tween, while a motion 
tween uses one object instance over the entire 
span along with property keyframes to create 
a tween. A property keyframe is a frame 
within the motion tween where you define a 
value for a property. A motion tween is known 
as object based animation. Motion tweens are 
easy to create and provide precise control, 
while classic tweens are more complex to cre-
ate and provide more advanced control. All 
motion tweens from Flash CS3 are classic 
tweens.

Tween Differences

There are several differences between classic 
and motion tweens. 

Classic Tweens
◆ Use Keyframes and property keyframes 

to create tweens.

◆ Allow frame scripts.

Understanding Motion Tweening

◆ Allow only symbols (movie clip, graphic, 
and button) as a tweenable type. It 
converts all others (editable shapes, 
groups, and text objects) to a graphic 
symbol.

◆ Consist of groups of individually 
selectable frames in the Timeline.

◆ Apply eases to groups of frames 
between keyframes within the tween.

◆ Allow animation between two different 
color effects, such as tint and alpha 
transparency.

◆ Don’t allow animation of 3D objects.

◆ Allow symbol swaps and setting the 
frame number of a graphic symbol to 
display in a property keyframe. 

Motion Tweens
◆ Use one object instance and property 

keyframes instead of keyframes to create 
tweens.

◆ Don’t allow frame scripts.

◆ Allow text as a tweenable type. It doesn’t 
convert it to a symbol.

◆ Treat tween spans as a single object that 
you can stretch and resize in the 
Timeline.

◆ Apply eases across the entire length of a 
motion tween span. 

◆ Apply only one color effect per tween. 

◆ Allow animation of 3D objects. 

◆ Don’t allow symbol swaps and setting 
the frame number of a graphic symbol to 
display in a property keyframe. 

◆ Convert all non-allowed object types 
(editable shapes and groups) to a movie 
clip symbol.
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Motion tweening when viewed in 
Onion Skin/Multiple Frames mode

Motion tweening when viewed in 
Onion Skin/Multiple Frames mode

Motion Tweening of Scale and Alpha Changes

Motion Tweening of Scale, Alpha, and Rotation Changes
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Motion Presets are ready-made motion tweens that you can apply to 
an object on the Stage. After you preview a motion tween in the 
Motion Presets panel, you can quickly apply it to a selected object. You 
can apply only one motion preset per object on the Stage. If you apply 
another preset to an object, it replaces the previous one. You can only 
apply a 3D motion preset to a movie clip instance, which is the only 
object type for 3D effects. Each motion preset contains a specific 
number of frames, which you can adjust later. In the Motion Presets 
panel, you can also create and save your own custom motion presets 
as well as import and export them (stored as XML files) to share with 
others.

Applying Motion 
Tween Presets

Apply a Motion Tween Preset

Select a tweenable object (symbol 
instance or text field) on the Stage.

Click the Window menu, and then 
click Motion Presets to open the 
panel.

Select a preset in the Motion 
Presets panel.

A preview of the preset plays in 
the Preview pane at the top of the 
Motion Presets panel.

◆ To stop the preview, click 
outside the Motion Presets 
panel.

Click Apply.

◆ If you apply a motion tween to 
a non-tweenable object, a 
dialog box appears, asking you 
to convert it to a symbol.

The motion is set to start at the 
current position of the object on 
the Stage.

◆ To apply the preset so that the 
motion ends at the current 
position of the object on the 
Stage, hold down Shift, and 
then click Apply.
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2 Preview pane
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Save a Tween as a Custom 
Motion Preset

Select the tween span, object on 
the Stage, or the motion path on 
the Stage with the custom tween 
that you want to save as a preset.

Click the Window menu, and then 
click Motion Presets to open the 
panel.

Click the Save Selection As Preset 
button.

Type a name for the preset.

Click OK.

The new preset appears in the
Motion Presets panel under 
Custom Presets. The preset is 
saved as an XML file in the Motion 
Presets folder, which you can 
locate by performing a search 
using Instant Search (Win) or 
Spotlight (Mac).

◆ To create a preview for the new 
preset, publish a SWF of the 
motion tween with the same 
name in the Motion Presets 
folder.

5

4

3
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Did You Know?
You can import and export a motion 
preset. To import a motion preset, click 
the Options button on the Motion 
Presets panel, click Import, select the 
XML file, and then click Open. To 
export a motion preset, select the pre-
set in the Motion Presets panel, click 
the Options button, click Export, spec-
ify a name and location, and then click 
Save.

You can delete a motion preset. Select 
the motion preset in the Motion 
Presets panel that you want to delete, 
and then click the Remove Item button.
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You can tween position, scale, rotation and other transform effects 
applied to symbols instances and text fields. A motion tween uses one 
instance over the entire span along with property keyframes, which you 
define with property values to modify the tween. You can change prop-
erty keyframes on Stage, in the Property Inspector, or in the Motion 
Editor. You should have only one object when you apply the tween or 
the results will be unpredictable. Tweened frames must reside on the 
same layer in the Timeline. After you add a tween to a layer, Flash 
changes it to a tween layer, which you can no longer draw on. A tween 
layer can contain tween spans, static frames, and actions.

Creating a Motion 
Tween

Create a Motion Tween

Select one or more objects to 
tween on the Stage.

◆ To create multiple tweens at 
once, place objects on multiple 
layers, and then select them all.

Click the Insert menu, and then 
click Motion Tween.

◆ If you apply a motion tween to 
a non-tweenable object, a 
dialog box appears, asking you 
to convert it to a symbol.

Flash converts the layer 
containing the tweened object 
to a tween layer and creates a 
tween span in the layer.

To change the length of the tween 
span, drag either end of the tween 
span in the Timeline.

To add motion to the tween, click a 
frame within the tween span, and 
then drag the object on the Stage. 

To tween 3D rotation or position, 
use the 3D Rotation tool or 3D 
Translation tool.

To remove a motion tween, select 
the tweened object, click the 
Insert menu, and then click 
Remove Tween.

To add another tween to an 
existing layer, drag a tween span 
from a different layer.

7
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Motion tween appears 
with a blue background.

A black dot indicates a target 
object in the first frame.

Black diamonds indicate property 
keyframes and the last frame.
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Motion tweens can be fine-tuned in the Property Inspector or the 
Motion Editor. When a tweened object is selected, a number of options 
are enabled that you use to add complexity to your motion path. You 
can set motion tween properties to deal with position and size, set rota-
tion direction and frequency, apply color and display blending effects, 
or control the easing in or out of the motion. The options you set in the 
Property Inspector are applied to the entire tween span.

Adjusting Motion 
Tween Properties

Set Motion Tween Properties in 
the Property Inspector

Click the Window menu, and then 
click Properties to open the 
Property Inspector.

Select an object on the Stage with 
a tween applied.

Choose from the available settings; 
options vary depending on the 
selected tweened object:

◆ Ease. Sets the motion speed in 
and out.

◆ Position and Size. Sets the X 
and Y position, and the 
selection width and height.

◆ 3D Position and View. Sets the 
3D X, Y, and Z position, 3D 
perspective selection width and 
height, perspective angle, and 
vanishing point.

◆ Rotation. Sets the direction and 
frequency your object rotates. 
Select the Orient To Path check 
box to keep your object parallel 
to the guide relative to its 
center point.

◆ Path. Sets the X and Y position, 
and the selection width and 
height.

◆ Color Effect. Sets the color 
style effect: Brightness, Tint, 
Alpha, or Advanced.

◆ Display. Sets the display 
blending effect, which includes 
Darken, Overlay, and Invert.

3
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The Motion Editor panel allows you to view and edit all tween 
properties and related keyframe properties. You can change the basic 
motion of the tween by changing the x-, y-, and z-axes, transform the 
skew and scale, apply color and filter effects, or add motion speed 
easing in or out. You can open the Motion Editor panel by using the 
Window menu. It appears next to the Timeline. When you select a 
tween space, a tweened object, or motion path, the Motion Editor panel 
displays tween property values in categories and a grid with a graph 
for each property. 

Editing Motion Tween 
Properties with the 
Motion Editor

Change the Motion Editor
Display

Select an object on the Stage with 
a tween applied.

Click the Window menu, and then 
click Motion Editor to open the 
panel.

To change the display of the 
Motion Editor, do any of the 
following:

◆ Display Properties. Click the 
triangle next to a property 
category.

◆ Expand/Collapse Property 
View. Click the property name 
to toggle it.

◆ Viewable Frames. Sets the 
number of frame of a tween 
shown in the Motion Editor.

◆ Graph Size. Sets the size of the 
graph.

◆ Expanded Graph Size. Sets the 
expanded property view size of 
the graph.

◆ Add Eases Options. Adds an 
ease option to menus in the 
Motion Editor. Click the Add 
button on the Eases category, 
and then select an ease option.

3
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1

3

2

Add Eases options

Display properties

Viewable Frames

Expanded Graph size

Graphic size
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Set Motion Tween Properties in 
the Motion Editor

Select an object on the Stage with 
a tween applied.

Click the Window menu, and then 
click Motion Editor to open the 
panel.

Click the triangle to expand a 
category, and then specify any of 
the following: 

◆ Basic Motion. Specify values 
for the x-, y-, and z-axes, and 
other related options.

◆ Transformation. Specify skew 
and scale values, and other 
related options.

◆ Color Effect. Click the Add or 
Remove button on the Color 
Effect category, and then select 
an option. Specify the color 
effect options you want.

◆ Filters. Click the Add or 
Remove button on the Filters 
category, and then select an 
option. Specify the filter 
options you want.

Select or clear the Ease check box 
to enable or disable it for a 
property or category, and then set 
an ease value. Positive values 
increase the ease at the end of the 
curve, while negative values 
increase the ease at the beginning 
of the curve. 

To reset values for an option, click 
the Reset Values button.

5

4

3
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2 4

Add and 
Remove 
buttons

3
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Wondering where Timeline Effects have gone in Flash. They are now a 
part of the Motion Editor. You can add many Timeline Effects by using 
filters in the Motion Editor. You can add filter effects, such as Drop 
Shadow, Blur, Glow, Bevel, Gradient Glow, Gradient Bevel, and Adjust 
Color, to a motion tween. You can also add color effects, such as 
Alpha, Brightness, Tint and Advanced Color, to a motion tween. You can 
apply more than one effect or filter to an object to create a different 
effect. If an applied color effect or filter doesn’t work for you, you can 
remove it. 

Adding Color Effects 
and Filters

Add Color Effects and Filters to a 
Motion Tween

Select an object on the Stage with 
a tween applied.

Click the Window menu, and then 
click Motion Editor to open the 
panel.

Click the triangle to expand the 
Color Effect or Filters category.

Use any of the following:

◆ Color Effect. Click the Add 
button on the Color Effect 
category, and then select an 
option.

The options include Alpha, 
Brightness, Tint, and Advanced 
Color.

◆ Filters. Click the Add button on 
the Filters category, and then 
select an option.

The options include Drop 
Shadow, Blue, Glow, Bevel, 
Gradient Glow, Gradient Bevel, 
and Adjust Color.

Specify the options you want for 
the category; options vary 
depending on the color effect or 
filter that you choose.
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Drop Shadow 
filter

Bevel filter Gradient Grow 
and Blur filters
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Work with Color Effects and 
Filters

Select an object on the Stage with 
a tween applied.

Click the Window menu, and then 
click Motion Editor to open the 
panel.

Click the triangle to expand the 
Color Effect or Filters category.

Specify the options you want for 
the category; options vary 
depending on the color effect or 
filter that you choose.

To remove a color effect or filter, 
click the Remove button on the 
Color Effect or Filter category, and 
then select the effect or filter that 
you want to remove. 

To reset values back to the default, 
click the Reset Values button for 
the effect or filter. 
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When you select a tween space, a tweened object, or motion path, the 
Motion Editor panel displays tween property values in categories and a 
grid with a graph for each property. Each keyframe property for a spe-
cific property appears as a control point on the graph. You can add or 
remove a property keyframe at any time. Control points can be either 
smooth or corner points. When a point is smooth, Bezier handles 
appear, which you can adjust. Some properties in the Motion Editor are 
associated with each other, such as Scale X and Scale Y. You can use 
the Link icon to constrain values to match to each other.

Working with 
Property Keyframes

Work with Property Keyframes

Select an object on the Stage with 
a tween applied.

Click the Window menu, and then 
click Motion Editor to open the 
panel.

Click the triangle to expand a 
category.

To work with property keyframes, 
do any of the following: 

◆ View. Click the Go To Previous 
Keyframe or Go To Next 
Keyframe arrows.

◆ Add. Place the playhead where 
you want to property keyframe, 
and then click the Add or 
Remove Keyframe button.

◆ Remove. Right-click (Win) or 
Control-click (Mac) the control 
point in the graph, and then 
click the Remove Keyframe.

◆ Smooth or Corner. Alt-click 
(Win) or Command-click (Mac) 
the control point to toggle 
between smooth and corner.

◆ Link. Click the Link icon to 
constrain values to match for 
associated pairs. Click the icon 
again to unlink a pair.

4
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Control points

Go To Preview/next keyframe

2

Add or Remove keyframe
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If you want to change the x-, y-, or z-axes, it’s easier to make bigger 
adjustments in the motion path of a tween on the Stage and minor ones 
in the Motion Editor. You can move the entire motion path to another 
location on the Stage or edit individual points on the path. If segments 
within the path become to fast or slow, you can use the roving property 
for the x-, y-, and z- axes to make the speed consistent throughout the 
tween.

Editing the Path of a 
Motion Tween

Edit the Path of a Motion Tween

Select an object on the Stage with 
a tween applied.

To make changes directly on the 
Stage, do any of the following:

◆ Object Position. Place the 
playhead in the frame you want 
to move, click the Selection 
tool, and then drag the target 
object to a new location.

◆ Motion Path Position. Click the 
Selection tool, click the motion 
path, and then drag the path.

◆ Motion Path Size. Click the 
Free Transform tool, click the 
motion path, and then drag a 
resize handle.

◆ Motion Path Shape. Click the 
Selection tool, click away from 
the motion path, and then drag 
any line segment on the path.

Click the Subselection tool, 
click the path, and then drag a 
control point to move it, or click 
a control point, and then drag 
the Bezier handles of the 
control point to reshape it.

◆ Delete Motion Path. Click the 
Selection tool, double-click the 
motion path, and then press 
Delete.

◆ Roving. Right-click (Win) or 
Control-click (Mac) the tween 
span or an individual control 
point in a Motion Editor graph, 
and then click Roving to toggle 
on and off.

2
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1Path

2

Subselection tool

Selection tool

Free Transform tool
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If you have a complex animation in the timeline that you want to con-
vert into ActionScript 3.0 code, you can use the Copy Motion as 
ActionScript 3.0 command to get the job done. When you use the com-
mand, Flash copies the properties that define the motion tween on the 
timeline and writes the ActionScript 3.0 code for you to apply to a sym-
bol. You can apply the code as timeline code or in class files for the 
Flash document file.

Copying Motion as 
ActionScript

Copy Motion as ActionScript 3.0

Create the animation using a 
symbol on the timeline in a layer 
that you want to copy as 
ActionScript 3.0 code.

Create a new layer.

Create a new symbol or drag 
another instance of your existing 
symbol on the Stage.

Select the entire animation that 
you want to copy on the animation 
layer of the timeline. Click the first 
frame, press Shift, and then click 
the last frame.

Right-click (Win) or Control-click 
(Mac) the animation, and then 
click Copy Motion as ActionScript
3.0.

Type an instance name to use in 
the ActionScript code. Enter the 
instance name of the instance that 
you want to apply the ActionScript 
code to. 

Select your second instance that 
you added to layer 2 (from Step 2), 
and type the instance name you 
entered into the Properties panel.

Create a new layer (for the 
ActionScript), and select the first 
frame of that layer.

Open the Actions panel and paste 
the code into the Script pane.

Before you test the animation, 
make sure layer 2 has the same 
number of frames as the animation 
layer.
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9 Pasted ActionScript 3.0 code
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Introduction

In the previous Chapter you learned about motion tweening. 
In this Chapter, you’ll learn about classic tweening. Tweening 
is an animation technique that creates the necessary in-
between frames based on a starting and ending frame. A 
motion tween uses one object instance over the entire span 
along with property keyframes to create a tween, while a clas-
sic tween uses several instances in keyframes of an object 
along with property keyframes to create a tween. Classic 
tweens are more complex to create than motion tweens. 
However, if you’re looking for a custom result, classic tweens 
provide more advanced control.

When you create an animation with classic tweening, 
there are some things you should know about. A classic 
tween:

◆ Uses Keyframes and property keyframes to create 
tweens.

◆ Allows frame scripts.

◆ Allows only symbols (movie clip, graphic, and button) as 
a tweenable type. It converts all others (editable shapes, 
groups, and text objects) to a graphic symbol.

◆ Consists of groups of individually selectable frames in 
the Timeline.

◆ Applies eases to groups of frames between keyframes 
within the tween.

◆ Allows animation between two different color effects, 
such as tint and alpha transparency.

◆ Doesn’t allow animation of 3D objects.

◆ Allows symbol swaps and setting the frame number of a 
graphic symbol to display in a property keyframe. 
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Classic tweening can only be applied to instances of symbols. When applying classic tweening 
to groups or text objects, Flash automatically converts them into symbols and stores them in 
the Library. When this happens, they appear in the Library named as Tween 1, Tween 2, etc. It is 
a good idea to convert them into symbols as the tweening is applied. When managing large 
projects with many assets it can become confusing to have assets named in this generic way. 
Of course you can always rename them by selecting the field in the Library and typing in a new 
name.

If your classic tweened animation doesn't behave as expected, there are a few things you 
can check. If the object disappears when you play the animation and only re-appears on the 
end keyframe, you may have more than one object on the keyframe. Make sure that only one 
object, or instance, is on each keyframe in the tweened span. Also, make sure that both 
instances are of the same object. Flash cannot motion tween two different objects. To "morph" 
different shapes into each other you must use shape tweening. 

Working with Classic Tweening 

When classic tweening is applied to 
groups or text objects, Flash automatically 
converts them into symbols and names 
them incrementally in this generic fashion.

A dotted line in a tween span indicates that there is a 
problem with the tween. Makes sure there is only one 
instance (the same instance) on each keyframe. 
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There is a difference between frame properties and instance properties. This is a source of ini-
tial confusion when dealing with animation tweens (both motion and shape). Because the 
Property Inspector is context-sensitive, it displays properties for many different objects in Flash, 
depending on which of these objects is selected. 

Classic motion (and shape) tweens are applied to keyframes in the Timeline. Color and 
Transform effects are applied to instances on the Stage. To view the classic tween properties for 
a specific frame or keyframe, you must select that frame. It is here that you activate tweening 
and tell Flash what you are going to tween (such as scale or rotation). This needs to be differen-
tiated from the effects you apply to the instances in the tweened keyframes. These are accessed 
in the Property Inspector and the Transform panel whenever any instance is selected on the 
Stage. For example, if you check scale as an option in the tween properties for a keyframe, a 
change in size only results if the size of one of the instances is changed. Conversely, if you want 
to tween a change in alpha, you can't do this by selecting either of the keyframes in a tween; 
you must select the instance on the Stage and apply the alpha change when the instance prop-
erties appear in the Property Inspector.

Understanding Frame and Instance Properties

Frame Properties appear when a frame is 
selected in the Timeline.

Instance Properties appear when the 
instance is selected on the Stage. 
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You can tween position, scale, rotation and other transform effects 
applied to symbols, groups, and text. Additionally, you can apply classic 
tweening to color and alpha changes. A classic tween connects two 
keyframes. You should have only one object in the keyframe when you 
apply the tween or the results will be unpredictable. Tweened frames 
must reside on the same layer in the Timeline.

Creating a Classic 
Tween

Create a Simple Classic Tween

Create a new Flash document, and 
then click on the first frame of the 
Timeline.

Do one of the following:

◆ Draw a shape on the Stage 
with any of Flash's drawing 
tools and convert into a symbol.

◆ Drag an instance of a symbol 
from the Library.

Select the first frame.

Click the Insert menu, and then 
click Classic Tween.

Click frame 10 in the Timeline.

Click the Insert menu, point to 
Timeline, and then click Frame.

Flash displays a dashed line in the 
framespan to indicate an 
incomplete or broken motion 
tween. It also tints the framespan 
a pale, bluish-purple to indicate 
that a motion tween has been 
applied.

TIMESAVER Press F5 to add 
frames, or right-click the frame, 
and then click Insert Frame.

6

5

4

3

2

1

2

4

Dotted line indicates a 
broken or incomplete tween.

A black dot at the beginning keyframe with a black 
arrow and blue background indicates a classic tween.3

6

5
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Click and drag the object on the 
Stage at frame 10 to a new 
location.

Flash creates a second keyframe 
that is connected to the first with 
an arrow. This indicates the 
motion tween is complete. 

Click the Control menu, point to 
Test Movie, and then click Test.

Flash gradually moves the object.

8

7

End keyframe is created when 
object is moved to a new position.

Motion tween viewed 
in Onion Skin mode.

Did You Know?
You can add keyframes and then alter 
the position of the object on the Stage. 
Tweening can be applied to any two 
existing keyframes on the same layer. 
Select the first keyframe, click the 
Tweening list arrow in the Property 
Inspector, and then click Motion.

You can move keyframes around in the 
Timeline. Simply click to select it, and 
then click it again and drag it to a new 
location.
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Classic tweens can be fine-tuned in the Property Inspector. When a 
tweened frame is selected, a number of options are enabled that you 
use to add complexity to your motion path. It is also where you remove 
an applied classic tween. Set the tween to deal with scale, set rotation 
direction and frequency, or apply inertia by easing in or out of the 
motion. Additionally, you can set orientation and snapping when using a 
motion guide. In Flash, you can customize easing in or out of a motion 
using the Edit button in the Property Inspector.

Adjusting Classic 
Tween Properties

Set Classic Tween Properties

Click the Window menu, and then 
click Properties to open the 
Property Inspector.

Select a keyframe with motion 
tween applied.

Choose from the following 
settings:

◆ Scale. Check this when you are 
tweening scale changes.

◆ Rotate. Sets the direction and 
frequency your object rotates.

◆ Orient To Path. Use this when 
you have applied a motion 
guide layer. This keeps your 
object parallel to the guide 
relative to its center point.

◆ Sync. This synchronizes the 
animation contained in the 
symbol with the Timeline that 
contains it. Use this when your 
symbol's Timeline is not an 
even number of frames.

◆ Snap. Check to snap the 
object's registration point to a 
motion guide.

◆ Edit. This button allows you to 
create custom ease in and 
ease out transitions.

To remove a classic tween, click 
the Insert menu, and then click 
Remove Tween.

4

3

2

1

Snap, Sync, Orient to path, and Scale

Rotate

Edit

3
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Set Ease Properties in a 
Classic Tween

Click the Window menu, and then 
click Properties to open the 
Property Inspector.

Select a keyframe with motion 
tween applied.

Click the Ease field, and then 
select the setting to set the speed 
at which your object eases in or 
out of its motion. 

A positive value eases in, a 
negative value eases out. A zero 
value evenly distributes motion 
across each frame.

3

2

1

No Easing

Ease Out

Ease In

Motion is evenly distributed 
across frames.

Most of the motion is applied to the beginning frames 
so the object appears to slow down as it stops.

Most of the motion is applied 
to the end frames so the object 
appears to slowly accelerate.

3
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After you fine-tune a motion tween, you can copy and paste the frames, 
tween, and symbol information to another object. When you paste a 
motion tween, you can also specify the motion tween properties you 
want to apply, such as X and Y position, horizontal and vertical scale, 
color, filters, and blend. You can also override target scale, rotation, 
and skew properties. If you want to use a motion tween as ActionScript
3.0 in the Actions panel or other code-specific location, you can use 
the Copy As ActionScript command.

Copying and Pasting 
a Tween

Copy and Paste a Motion Tween

Select the frames in the Timeline 
with the motion tween you want to 
copy. The frames you select need 
to be on the same layer. However, 
the selection can span a tween, 
empty frames, or two or more 
tweens.

Click the Edit menu, point to 
Timeline, and then click Copy 
Motion.

Select the symbol instance to 
receive the copied motion tween.

Click the Edit menu, point to 
Timeline, and then click Paste 
Motion.

The frames, tween, and symbol 
information are inserted to match 
the original copied tween.

4

3

2

1 
2

1

3

Motion pasted to instance
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Paste Motion Tween Properties

Select the frames in the Timeline 
with the motion tween you want to 
copy.

Click the Edit menu, point to 
Timeline, and then click Copy 
Motion.

Select the symbol instance to 
receive the copied motion tween.

Click the Edit menu, point to 
Timeline, and then click Paste 
Motion Special.

Choose from the following 
settings:

◆ X or Y Position. Pastes how 
much to move in the X 
(horizontal) and Y (vertical) 
direction.

◆ Horizontal or Vertical Scale. 
Pastes the ratio between the 
current and the natural size in 
the horizontal (X) or vertical (Y) 
direction.

◆ Rotation And Skew. Pastes the 
rotation of the object.

◆ Color. Pastes the color values 
of the object.

◆ Filters. Pastes the filter 
properties of the object.

◆ Blend Mode. Pastes the blend 
properties of the object.

◆ Override Target Scale or 
Rotation and Skew Properties. 
Select to override the existing 
scale, or rotation and skew 
properties of the object. Clear 
to paste the properties relative 
to the target object.

Click OK.6

5

4

3

2

1

6

5

Copying Motion As ActionScript 3.0

In addition to copying motion tweens in the Timeline, you can also copy 
motion tweens to the Actions panel or use them as ActionScripts. To 
accomplish this task, you use the Copy Motion As ActionScript com-
mand. This command copies the properties that define a motion tween 
in the Timeline as ActionScript 3.0. These properties include Position, 
Scale, Skew, Rotation, Transformation Point, Color, Blend Mode, 
Orientation To Path, Cache As Bitmap Setting, Frame Labels, Motion 
Guides, Custom Easing, and Filters. After you copy the properties, you 
can apply them to another symbol in the Actions panel or in the source 
files for the Flash document that uses ActionScript 3.0. To copy a 
motion tween as ActionScript 3.0, select the frames in the Timeline with 
the motion tween you want to copy, click the Edit menu, point to 
Timeline, click Copy Motion As ActionScript 3.0, type the name of the 
instance to attach the motion tween to, and then click OK. Flash gener-
ates ActionScript for the specific instance name. The code appears on 
the Clipboard for use in the Actions Panel or other place. 

For Your Information
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Tweens in Flash are editable after they have been created. You can 
continue to change their properties and position in the Timeline, and 
Flash redraws the tweened frames. To change the length of a motion or 
shape tween (that is, the time it takes to complete the tween), you can 
add or remove frames in the framespan. Essentially you are adjusting 
the amount of frames Flash uses in its calculation of the tween. Adding 
frames means it takes longer for the transformation to happen, while 
deleting frames shortens the time. 

Changing the Length 
of a Tween

Add Frames to a Tween

Click anywhere except the last 
keyframe on a motion or shape 
tweened framespan to place the 
playhead.

◆ To add multiple frames, select 
multiple frames in the Timeline.

Click the Insert menu, point to 
Timeline, and then click Frame.

TIMESAVER Press F5 to add 
frames.

2

1 
1

Frame is added to tween span.

Duration of other tweens 
is maintained.
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Remove Frames from a Tween

Click anywhere on a motion or 
shape tweened framespan to 
place the playhead.

◆ To remove multiple frames, 
select multiple frames in the 
Timeline.

Click the Edit menu, point to 
Timeline, and then click Remove 
Frames.

TIMESAVER Press Shift+F5 to 
subtract frames.

2

1 1

Tween span is reduced by one frame.

Did You Know?
If no layer is selected, the entire 
Timeline increases or decreases when 
you add or remove frames. To con-
strain this action to one target layer, 
lock all other layers you don't want to 
affect, or simply select the frame in the 
tween you want to adjust. 

Tweens with more frames will be 
smoother. The more frames you add to 
a tween, the smoother the animation 
plays, because Flash has more frames 
to split the motion between. However, 
if you add too many frames the anima-
tion may move so slowly that the illu-
sion of movement could be hampered. 
It is best to experiment with the length 
of a motion or shape tween and the 
frame rate of your Flash movie until 
you get the results you are looking for.
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The frame rate describes the amount of frames the Flash Player will 
play each second. The higher you set the frame rate, the smoother your 
animations will play. Traditional animations play at a rate of 24 frames 
per second, the same rate at which film plays, while NTSC video plays 
at 29.97 frames per second. It is important to keep your audience in 
mind and what the destination of the Flash movie will be. For delivery 
via the Web, you should consider the processor speeds of the destina-
tion computers. If you set the frame rate too high, the computer may 
not be powerful enough to play all of the frames. When this happens, 
Flash will drop frames in order to stay in sync. Try to avoid this scenario 
because it can make your animations play choppily. Consider where 
your Flash movie is going to be played and choose accordingly. Avoid 
frame rates over 30 fps, and, for slower computers, you can go as low 
as 12 fps, which is the default frame rate in Flash.

Changing the Frame 
Rate

Change Frame Rate 

Click a blank area on the Stage.

Click in the Frame Rate field in the 
Property Inspector or at the 
bottom of the Timeline, and then 
type in a frame rate. 

2

1

Document settings appear in the Property Inspector 
when nothing is selected on the Stage or the Timeline.

The frame rate is also 
available to change at the 
bottom of the Timeline. 

2

Did You Know?
You can also change the frame rate in 
the Document options window. 
Access this window by clicking the 
Document button in the Property 
Inspector or in the Modify menu.

The frame rate is ignored for FLV Flash 
video. You need to set its frame rate in 
the encoder or editing application. 
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With a classic tween, use the Reverse Frames command to reverse the 
frames in the Timeline. You can access this action in the Modify menu 
and it will be applied to all selected frames. This works for animations 
created frame-by-frame or with motion or shape tweening applied. 
Flash changes the order of the frames so your animation plays back-
wards.

Reversing Frames

Reverse Frames 

Click and drag on the range of the 
frame span or tween you want to 
reverse.

Click the Modify menu, point to 
Timeline, and then click Reverse 
Frames.

TROUBLE? If the tween is not 
preserved when you use the 
reverse frames command, you 
might not have applied motion or 
shape tweening to the end 
keyframe in the tween. Flash only 
requires you to apply tweening to 
the starting keyframe in a tween. It 
is implied that it tweens into the 
next (or end) keyframe. To fix this, 
do one of the following: (1) Before 
you reverse frames, select the end 
keyframe and apply Motion (for 
motion tweening) or Shape (for 
shape tweening) to it from the 
Property Inspector. (2) After you 
reverse frames, select the 
beginning keyframe (which use to 
be the end keyframe) and apply 
Motion (for motion tweening) or 
Shape (for shape tweening) to it 
from the Property Inspector. 

2

1

Frames before reversing

Click and drag to select a range of frames

Frames after reversing

Did You Know?
You can select an entire layer and 
reverse all the frames on that layer. To 
select an entire layer, click the layer 
name to select it, and then reverse 
frames.
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With a classic tween, you can add keyframes to a motion tween by 
simply dragging the object on the Stage on the frame on which you 
want the change (or keyframe) to be created or by using the Add 
Keyframe function in the Insert menu. For example, if you want the 
object to move to another coordinate before it reaches the end posi-
tion, you can set another keyframe between them. In this way, you can 
animate shapes in several directions in the same motion tween. 
Alternately, you can clear a keyframe from the tween by selecting it 
and using the Clear Keyframe function in the Modify menu. In either 
case, the length of the tween is preserved; the frame’s status as a 
keyframe is removed and Flash redraws the animation, connecting the 
keyframes located before and after.

Adding and Removing 
Keyframes from a 
Classic Tween

Add a Keyframe to a 
Classic Tween 

Click on a frame in a tweened 
framespan you want to add a 
keyframe to.

Click the Insert menu, point to 
Timeline, and then click Keyframe.

TIMESAVER Press F6 to insert 
a keyframe.

2

1

1

Keyframe is added

Did You Know?
You can click and drag the object on 
the Stage and move it to another coor-
dinate. Flash automatically creates a 
keyframe on the active frame if the 
playhead is in a motion tweened 
framespan.
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Remove a Keyframe from a 
Classic Tween 

Click on the keyframe you want to 
remove in the motion tween.

Click the Modify menu, point to 
Timeline, and then click Clear 
Keyframe.

The keyframe is cleared but the 
duration of the tween is preserved. 
The first and last keyframe are 
automatically reconnected and 
Flash redraws the tween.

TIMESAVER Press Shift+F6 to 
remove the keyframe.

2

1

1

Keyframe is removed

Duration is maintained
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With a classic tween, any change made to an object on either 
keyframe can be tweened. Included are any changes made to the scale 
or rotation of objects on either keyframes in a tweened span. Simply 
alter the size or rotation of the instance on either frame, and Flash 
gradually tweens these properties. To change scale, you must select 
the scale option in the Property Inspector, while rotation has several 
options to choose from, including clockwise and counter-clockwise 
rotation, and frequency of rotation.

Scaling and Rotating 
a Classic Tween

Change Scale During a 
Classic Tween 

Open a document with a tweened 
animation or create a new one.

Select the first keyframe in the 
tween to open the Motion settings 
in the Property Inspector.

Select the Scale check box in the 
Property Inspector.

Change the size of the object on 
either keyframe with any of Flash's 
transform methods including the 
Free Transform tool, the Transform 
panel or the transform options in 
the Modify menu.

To preview the animation, drag the 
playhead in the Timeline, or click 
the Control menu, point to Test 
Movie, and then click Test.

Flash gradually increases or 
decreases the size of the object.

TIMESAVER Press A+Return 
(Mac) or Ctrl+Enter (Win) to test it.

5

4

3

2

1

4

First keyframe Last keyframe

3

Scale and position changes tweened

2 1
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Change Rotation During 
Classic Tween

Open a document with a tweened 
animation or create a new one.

Change the rotation of the object 
on either keyframe with any of 
Flash's transform methods 
including the Free Transform tool, 
the Transform panel or the 
transform options in the Modify 
menu.

In the Property Inspector, click the 
Rotation Options list arrow, and 
then select a rotation property:

◆ None. This is the default 
setting. No rotation is applied.

◆ Auto. Rotates the object in the 
direction requiring the least 
motion.

◆ CW. Rotates the object 
clockwise. Enter the number of 
times you want the object to 
rotate.

◆ CCW. Rotates the object 
counter-clockwise. Enter the 
number of times you want the 
object to rotate.

To preview the animation, drag the 
playhead in the Timeline, or click 
the Control menu, point to Test 
Movie, and then click Test.

Flash gradually rotates the object 
in the direction indicated.

4

3

2

1

First keyframe Last keyframe

2

Rotation and position 
changes tweened

1

3
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With a classic tween, any color effect that can be applied to an 
instance can be transformed in a motion tween. You can tween any 
color properties applied to either the starting or ending keyframe. For 
example, if the starting keyframe in a motion tween is tinted red and the 
ending keyframe is tinted yellow, Flash will gradually change the tint of 
the object from red, through shades of orange to the final tint of yellow. 
Use these properties to create any number of color effects in your ani-
mations. Additionally, you can tween the alpha of an object to make it 
appear to fade on and off the Stage.

Adding Color Effects 
to a Classic Tween

Add Color Effects to a 
Classic Tween 

Open a Timeline with a tweened 
animation or create a new one.

Select the object on the Stage on 
either keyframe in the tween.

Click the Color Styles list arrow in 
the Property Inspector, and then 
select an effect: Brightness, Tint, 
Alpha, or Advanced.

Drag the slider to set the 
percentage of the Color Styles 
applied or enter a value in the 
entry field.

TROUBLE? If the Color styles 
don't appear in the Property 
Inspector, you may have selected 
the keyframe in the Timeline and 
not the object on the Stage.

To preview the animation, drag the 
playhead in the Timeline, or click 
the Control menu, point to Test 
Movie, and then click Test.

Flash applies the tint gradually 
between the two keyframes.

5

4

3

2

1

2 5

First keyframe 
Alpha of 100%

Last keyframe 
Alpha of 0%

3

Alpha and position tweened

See Also
See "Creating a Motion Tween" on 
page 242 for information on creating a 
motion tween.

4

1
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If you want to implement motion that is smoother, or that follows a 
curve or some specific path, you can create a motion guide. A motion 
guide has its own layer just above the layer containing the object. Flash 
allows you to draw a line that you want your object to follow with any 
of the built-in drawing tools. Because this layer is a guide, it will be 
invisible in the exported Flash movie.

Creating a Classic 
Motion Guide Layer

Create a Classic Motion Guide 

Select the layer containing the 
classic motion tween. 

Right-click (Win) or Control-click 
the layer containing the classic 
tween, and then click Add Classic 
Motion Guide.

Flash creates a new layer above 
the selected layer and indents the 
affected layer.

TIMESAVER Press 
Control+click (Mac) or right-click 
(Win) the layer you want to add a 
motion guide to, and then click 
Add Motion Guide.

Click on the motion guide layer to 
select it.

Draw a line on the Stage with any 
of Flash's drawing tools to define 
the path your object will follow.

4

3

2

1

12

4

Any line can be 
used as a motion 
guide.

3
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Turn snapping on to easily animate along a classic motion guide. The 
center point of the object must be on the classic motion guide path for 
it to work, and snapping ensures that this happens. Once the classic 
motion guide is created, all you have to do is drag the object in the first 
and last frames of the tween to the classic motion path you drew and 
Flash will draw the in-between frames along this path.

Animating Along a 
Classic Motion Guide

Animate Along a Classic 
Motion Path 

Create a classic motion guide.  

Click on the first keyframe of the 
motion tween, and then click and 
drag the object on the Stage onto 
the start of the motion path.

The object snaps to the motion 
path.

TROUBLE? If the object 
doesn't snap to the motion path, 
verify that the Snap setting is 
turned on in the Property 
Inspector for this frame. The 
objects on both the beginning and 
ending keyframe must be snapped 
to the motion guide line for the 
motion to follow the guide line.

Click on the last keyframe of the 
motion tween, and then click and 
drag the object on the Stage onto 
the end of the motion path.

The object follows the line you 
drew located in the motion guide 
layer.

3

2

1

3

See Also
See "Creating a Classic Motion Guide 
Layer" on page 269 for information on 
creating a motion guide.

1

2
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When objects are tweened along a classic motion path, they remain in 
their native orientation regardless of the path. For certain objects, such 
as a circle, this is ok. For more complex objects, you must rotate the 
object so that it follows the path in a more naturalistic way. A good 
example of this sort of orientation in motion is in the path a car takes 
while driving down a road-the car must rotate gradually as the road 
curves to remain parallel with the road, and so, avoid disaster. Flash 
can do this work for you when you set the Orient To Path option in the 
motion tween settings.

Orienting Objects to a 
Classic Motion Path

Animate Along a Classic 
Motion Path 

Animate an object along a classic 
motion guide.   

Click on the first keyframe of the 
motion tween to select it.

Select the Orient To Path check 
box in the Property Inspector.

The object will automatically 
rotate to remain parallel with the 
motion guide.

3

2

1

Tweening along a motion guide without 
orientation can seem unnatural.

Orient to Path makes sure the baseline 
is always parallel.

See Also
See "Animating Along a Classic Motion 
Guide" on page 270 for information on 
creating animation using a motion 
guide.

2

3
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With a classic tween, you can customize easing in or out of a motion 
tween using the Edit button in the Property Inspector. The ease in and 
out of a motion tween is the rate at which the change of location is 
applied to an object. You can make an object move back and forth on 
the Stage within a single tween or create more complex tweens. Flash 
displays a graph representing the degree of motion in frames over time. 
The percentage of change is the vertical axis and the number of frames 
is the horizontal axis. The rate of change of the object is indicated by 
the slope of the graph’s curve.

Easing In and Out of 
a Classic Tween

Set Ease In and Out Motion
Tween Properties

Click the Window menu, and then 
click Properties to open the 
Property Inspector.

Select a keyframe with motion 
tween applied.

Click the Edit button in the 
Property Inspector. 

Select or clear the Use One 
Setting For All Properties check 
box. Select it (default) to 
customize one curve, clear it to 
customize a curve for each curve 
property (Position, Rotation, Scale, 
Color, and Filters). 

If cleared, use the Property list 
arrow to select a curve.

Click a point on the ease line to 
add a control point, and then drag 
the control point to change ease in 
and out. You can add and change 
multiple points.

Drag a tangent point (hollow 
circles on the sides of a control 
point) to further change ease in 
and out. 

Click the Play or Stop buttons to 
try the customized ease settings.

To reset setting to the default, click 
Reset.

Click OK.9

8

7

6

5

4

3

2

1

94

857 6

Last keyframe at 100%

First keyframe at 0%; 
square handles (control points) 
represent frame indicators.

Click a control point 
(square handle) to 
display its keyframe 
and % of change.

3
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Animating with Shape 
Tweening

Introduction

Shape tweening works similarly to motion tweening. It fol-
lows the same structure of keyframing in the Timeline. You 
can animate many of the same changes such as alpha, color, 
scale, and position, though its main purpose is to transform 
the shape of an object into another shape. Whereas motion 
tweening is applied to groups and symbols, shape tweening 
must be applied to an editable shape. You can determine 
whether an object is editable by selecting it with the 
Selection tool—if it doesn't have a bounding box when 
selected, shape tweening can be applied. The reason for this 
is that when you convert a shape into a symbol, you are 
essentially protecting it from editing by storing it in its own 
Timeline. To apply shape tweening to a symbol, you must 
enter symbol editing mode and apply it to the shape con-
tained inside the symbol. Shapes are created with any of 
Flash's drawing tools, such as the Oval or Rectangle tools. By 
making changes to the shape with any of Flash's editing 
tools, you can change the contours of the shape (for exam-
ple, turn a circle into a square) and then use shape tweening 
to make this change happen gradually over time. Because the 
results of a shape tween can be unpredictable, you can set 
shape hints to let Flash know how to proceed with the tween. 
This is useful when you are working with complex shapes 
such as letterforms. In all cases you should only tween one 
shape at a time in a tweened span for best results.

In addition to shape tweening, you can also animate 
shapes using Inverse Kinematics (IK), which allows you to 
stretch and bend shape objects and link groups of symbol 
instances to make them move together in naturalistic ways 
using an internal structure of bones to create character ani-
mation. 10

10
What You’ll Do

Use Shape Tweening

Create a Shape Tween

Add and Remove Keyframes from a 
Shape Tween

Change Shape Positions with 
Shape Tweening

Change Shape Position and 
Form Simultaneously

Adjust Shape Tween Properties

Change Shape Tweening Color and 
Alpha Options

Use Shape Hints

Create Animation Using ActionScript

Use Inverse Kinematics

Add Bones to an Armature

Edit Armatures and Bones

Bind Bones

273
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You can use shape tweening when you need 
to alter the form of any editable shape gradu-
ally. Place artwork in a keyframe and then use 
any of Flash's drawing and editing tools to 
adjust the contours of a shape on another

keyframe. When you apply shape tweening, 
Flash draws the frames in-between the two 
keyframes so that the object appears to 
"morph" between the two states. To provide 
even more control, you can use shape hints.

Using Shape Tweening

Shapes created with 
the Polystar tool

Break apart letterforms 
for shape tweening

Using the Polystar Tool

Using Shape Hints
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For best results, tween shapes separately on different layers.

Creating Complex Animations
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In most cases, you can easily shape tween any two simple shapes. 
Geometric forms such as lines, rectangles and circles yield the best 
results. Because Flash draws the tweened frames mathematically, the 
simpler the shape, the more likely it will tween without any problems or 
without having to apply corrections such as shape hints. 
Experimentation is the key. As long as both keyframes contain an 
editable shape, Flash will attempt to morph one object into another. Use 
any of Flash's drawing tools or import a vector shape from another vec-
tor drawing program. If you want to apply a shape tween to grouped 
artwork or a symbol, you can break apart the group or enter symbol 
editing mode and apply the shape tween to any editable shape in the 
symbol's Timeline. You can quickly view your animation by exporting it 
with the Test command (in Flash Professional). By default, Flash loops 
animations in the Flash Player.

Creating a Shape 
Tween

Create a Shape Tween

Create a new Flash document.

With any of Flash's drawing tools, 
draw a shape on the Stage at 
frame 1.

Select the first frame.

Click the Insert menu, and then 
click Shape Tween.

4

3

2

1

3

Square drawn 
on Frame 1

2

 From the Library of Wow! eBook



ptg

Chapter 10 Animating with Shape Tweening 277

Select frame 10.

Click the Insert menu, point to 
Timeline, and then click Blank 
Keyframe.

Flash tints a shape-tweened span 
a pale green.

TIMESAVER Press F7 to add a 
blank keyframe.

With any of Flash's drawing tools, 
draw a different shape on the 
Stage at frame 10.

Click the Control menu, point to 
Test Movie, and then click Test.

The shape on frame 1 slowly 
transforms into the shape on 
frame 10.

TIMESAVER Press A+Return 
(Mac) or Ctrl+Enter (Win) to test it.

8

7

6

5

Beginning Shape 
on Frame 1

Ending 
Shape on 
Frame 10

Tweened frames

Tweened frames

5

Circle drawn 
on Frame 10

Shape tween span is tinted 
a pale green
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The procedure for adding or removing keyframes in a shape tween is 
similar to that of motion tweens except for one crucial difference. In a 
motion-tweened framespan you can drag the object on the Stage and a 
new keyframe is automatically created. In shape-tweened spans, the 
object is only selectable on a keyframe. To add additional locations or 
shape changes along a shape-tweened span, you must add the 
keyframe first and then edit the shape. You can do this by using the Add 
Keyframe function in the Insert menu. Once the keyframe is added, the 
shape at that point in the framespan becomes editable.

Adding and Removing 
Keyframes from a 
Shape Tween

Add a Keyframe to a 
Shape Tween 

Place the playhead between any 
two shape tweened keyframes.

Click the Insert menu, point to 
Timeline, and then click Keyframe.

TIMESAVER Press F6 to insert 
a keyframe.

2

1

1

Keyframe is added
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Remove a Keyframe from a
Shape Tween 

Click on the keyframe you want to 
remove in the shape tween.

Click the Modify menu, point to 
Timeline, and then click Clear 
Keyframe.

The keyframe is cleared but the 
duration of the tween is preserved. 
The first and last keyframes are 
automatically reconnected, and 
Flash redraws the tween.

TIMESAVER Press Shift+F6 to 
remove the keyframe.

2

1

1

Keyframe is removed 

Duration is maintained
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To create a shape tween you need to draw or place an editable shape 
in a keyframe. Use any of Flash's drawing tools or import a vector 
shape from another vector drawing program. If you want to apply a 
shape tween to grouped artwork or a symbol, you can break apart the 
group or enter symbol editing mode and apply the shape tween to any 
editable shape in the symbol's Timeline. You can quickly view your ani-
mation by exporting it with the Test command (in Flash Professional). 
By default, Flash loops animations in the Flash Player.

Changing Shape 
Positions with Shape 
Tweening 

Animate a Ball with 
Shape Tweening

Create a new Flash document.

Select the Oval tool on the Tools 
panel.

Set the Stroke Color to None.

On the first frame, draw a circle on 
the left side of the Stage.

Select the first frame.

Click the Insert menu, and then 
click Shape Tween.

Click frame 20 in the Timeline.

Click the Insert menu, point to 
Timeline, and then click Keyframe.

Flash tints a shape-tweened span 
a pale green.

TIMESAVER Press F6 to add a 
keyframe.

8

7

6

5

4

3

2

1

3

5 7

4

Circle position 
on Frame 1

2
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Select the Selection tool on the
Tools panel.

Select the circle on frame 20 and 
drag it to the right side of the 
Stage.

Click frame 40 in the Timeline, and 
then add another keyframe.

Select the circle shape on frame 
40 and drag it back to the left side 
of the Stage.

Click the Control menu, point to 
Test Movie, and then click Test.

The ball animates back and forth 
across the screen.

13

12

11

10

9
9

10

13

Circle position on Frame 20

Circle position on Frame 40

11
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Many of the same motion effects can be applied using either motion or 
shape tweening. What differentiates shape tweening from motion 
tweening is that shape tweening is applied to editable shapes. You can 
change the form of the shape on either keyframe and these changes 
will be applied gradually by Flash across the tween, slowly morphing 
one into the other. Additionally, you can combine movement with this 
tweening process, so your shape can change its shape as it changes 
its location. 

Changing Shape 
Position and Form 
Simultaneously

Combine Shape Tweening and 
Movement in a Ball Animation

Create a shape tween of a moving 
ball that begins on the left side of 
the Stage, hits the right side of the 
Stage, and then returns to the left.

Click to place the playhead 
between the first and second 
keyframes in the shape tween.

Click the Insert menu, point to 
Timeline, and then click Keyframe.

Select the Selection tool on the
Tools panel.

Place the pointer on the left edge 
of the shape and pull it to create a 
tail off the circle.

The shape must be deselected on 
the Stage to pull the edges of the 
shape.

5

4

3

2

1

4

5

Small curve icon indicates 
editable curve. 

New keyframe 
placed at Frame 10.

Shapes must be deselected 
to pull the edges.

2

1
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Click to place the playhead 
between the second and third 
keyframes in the shape tween.

Click the Insert menu, point to 
Timeline, and then click Keyframe.

With the Selection tool still 
selected, place the pointer on the 
right edge of the shape and pull it 
to create a tail off the circle.

Click the Control menu, point to 
Test Movie, and then click Test.

The ball stretches as it animates 
back and forth across the screen.

9

8

7

6

6

New keyframe placed at Frame 30.

8

See Also
See "Changing Shape Positions with 
Shape Tweening" on page 280 for infor-
mation on animating a moving ball.
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When shape tweens are applied to keyframes, the Property Inspector 
enables several options for controlling how Flash draws the tweened 
frames. Settings such as easing in and easing out enable you to control 
how the shape changes are distributed across the frames in the tween. 
Frame Blending allows you to set preferences to let Flash know which 
qualities to maintain during the tween.

Adjusting Shape 
Tween Properties

Set Shape-Tween Properties

Click the Window menu, and then 
click Properties to open the 
Property Inspector.

Select a keyframe with shape 
tween applied. 

Choose from the following 
settings:

◆ Ease. This sets the speed at 
which your object eases in or 
out of its motion. A positive 
value eases in, a negative value 
eases out.

◆ Blend. The Distributive option 
smoothes out the tweened 
shapes, while the Angular 
option preserves corners and 
straight lines in the shape 
tweens.

3

2

1 1

3
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Because shape tweening can only be applied to editable shapes, you 
can't use the same color style effects that are available to instances. 
Instead, you must make these changes directly to the shape using the 
color palettes, the Color panel, or the Swatches panel. When shape 
tweening is applied, differences in color and alpha are tweened along 
with any shape changes. This applies to strokes as well as fills.

Changing Shape 
Tweening Color and 
Alpha Options

Change Shape-Tween Color 

Select the beginning or ending 
keyframe in a shape tween or 
select the shape on the Stage.

Click the Window menu, and then 
click Color, if necessary. 

TIMESAVER Press Shift+F9 to 
open the Color panel.

Make changes to the shape's 
stroke and fill colors by entering 
values in the RGB, HSB, and Alpha 
fields, or by using the list arrows to 
the right of these fields.

Click the Control menu, point to 
Test Movie, and then click Test.

The shape color changes as the 
shape tweens.

4

3

2

1

Stroke Color

Fill Color

Did You Know?
You can use any palette available to 
change the color of a shape in a 
tween. In addition to the Color Mixer, 
there are palettes located on the Tools 
panel, Property Inspector, and 
Swatches panel.

1

See Also
See “Modifying Instance Color Styles 
and Blends” on page 158-159 for more 
information on working with color and 
alpha options. 

Color Picker

3
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Sometimes it isn't possible to predict how some, more complicated, 
shapes will tween. To exercise greater control over the tweening 
process, you can set shape hints to guide how Flash draws the in-
between frames. You simply specify a beginning shape hint and then a 
corresponding end shape hint. In this way, Flash will know which parts 
of the shape in the first keyframe will transform into which parts in the 
end keyframe. Even with shape hints enabled, the results can be unpre-
dictable, but you will have a greater control over the process.

Using Shape Hints

Set Shape Hints 

Create a shape tween of a simple 
shape into a complex shape.

Click to place the playhead on the 
first frame of the shape tween. 

Click the Modify menu, point to 
Shape, and then click Add Shape 
Hint.

A small red, circle with a small 
letter on it appears in the center of 
the shape. The first letter is "a". 
Shape hints appear in alphabetical 
order "a, b, c…". You can use up to 
26 hints in one tween.

TIMESAVER Press Shift+A+H 
(Mac) or Ctrl+Shift+H (Win) to 
insert a shape hint. 

Drag the shape hint to an area of 
the shape you want to control. 

Click to place the playhead on the 
last frame of the shape tween.

The corresponding shape hint 
appears as a small green circle 
with a corresponding letter that 
matches the beginning hint. 

5

4

3

2

1
Beginning 
shape hint “a” 

End shape 
hint “a” 

4

2

Place start shape hints 
on problem areas.

Place end shape hints on 
corresponding areas.

Did You Know?
You can show all shape hints. Click 
the View menu, and then click Show 
Shape Hints.

5
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Drag the corresponding end shape 
hints to the part of the shape that 
corresponds to the placement of 
the beginning shape hint.

"a" should correspond with "a", "b" 
should correspond with "b", etc.

Move the playhead back to the 
first frame. 

Repeat steps 3, 4, 5, 6, and 7 until 
you have set and placed shape 
hints on all areas of the shape you 
want to control.

Click the Control menu, point to 
Test Movie, and then click Test.

The shape hints help make 
complex shape tweens more 
predictable.

9

8

7

6 Animation without Shape Hints

Animation with Shape Hints

Did You Know?
You can remove shape hints. Drag 
shape hints off the Stage or click the 
Modify menu, point to Shape, and then 
click Remove All Hints.

You should place your shape hints 
consecutively in a clockwise or 
counter-clockwise direction. Placing 
shape hints out of order can confuse 
Flash and often produces unwanted 
results.
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In addition to creating animation using the Timeline and Property Inspector, you can also use 
ActionScript to animate movie clips, buttons, text, and components. You can animate any 
instance name with ActionScript. For an ActionScript 3.0 example, see Project 4, “Modifying an 
Object with ActionScript in the Workshops, available at www.perspection.com. For ActionScript
2.0, you can animate an object over time and change any ActionScript property, such as scale, 
rotation, color, and transparency. ActionScript provides two events that work well for anima-
tion: onEnterFrame and setInterval. The onEnterFrame event is a continuously executing event 
based on the frame rate of your movie until you stop (delete) it. The setInterval event is a contin-
uously executing event for only a certain period of time. The one disadvantage of these actions 
is the large use of memory and CPU, so you need to clear it.

◆ onEnterFrame event.The following example is a frame script that animates a movie clip 
to the right until it reaches the position it should be in:

myMovieClip.onEnterFrame=function()

{

if(this._x<300)

{

this._x+=10;

}

else

{

delete this. onEnterFrame;

◆ setInterval event. This event requires two parameters: funtionName and an interval 
(amount of time in milliseconds between executions). If your interval is smaller than 
your frame rate, the screen cannot refresh. If your interval is greater than your frame 
rate, it executes as close as possible. The following example moves a TextArea 
component to the right every 10 milliseconds until it has reached its final location:

myInternval=setInterval(textAreaMove, 10);

function textAreamove()  {

if (textAreaInstance._x<300)  {

textAreaInstance._x += 10;

} else

clearInterval(myInterval);

}

}

Creating Animation Using ActionScript
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Inverse Kinematic (IK) allows you to stretch 
and bend shape objects and link groups of 
symbol instances to make them move 
together in naturalistic ways using an internal 
structure of bones to create character anima-
tion.

You can add bones to the interior of a 
shape or to separate symbol instances. When 
you move one bone, the other connected 
bones move in relation to the one that initially 
moved. A chain of bones is called an arma-
ture, which is either linear or branched in 
structure.

There are two types of Inverse Kinematic 
animation: those with symbols and those with 
shapes. For the symbol type, you link them 
together as a chain. For the shape type, you 
add bones inside the shape. 

When you add bones to a shape or sym-
bol instance, Flash creates a new layer called 
a pose layer. For a shape, Flash also converts 
the selected shapes and bones into an IK 
shape object. Each pose layer can contain 
only one armature. The first bone in an arma-
ture is the root bone. It appears with a circle 
around the head of the bone. Each bone has 
a head, the round end, and a tail, known as 
the pointed end. 

After you add bones to an armature, you 
can change the position and length of a bone, 
delete bones, and edit objects containing 
bones.

When you’re ready to animate an arma-
ture, all you need to do is add frames to the 
pose layer and reposition the armature on the 
Stage to create a keyframe. Keyframes in 
pose layers are called poses. To insert a frame 
in a pose layer, right-click (Win) or Option-
click (Mac) a frame in a pose layer to the right

of any existing frames, and then click Insert 
Frame. To add a pose to a frame, right-click 
(Win) or Option-click (Mac) the frame in the 
pose layer, and then click Insert Pose. After 
you insert a pose, you can use the Selection 
tool to change the configuration of the arma-
ture. If you want to change the length of the 
animation, drag the last frame of the pose 
layer to the right or left in the Timeline to add 
or remove frames. 

You can adjust the speed of an armature 
animation in frame around each pose by 
applying an easing motion. To add easing to 
frames in a pose layer, click a frame in a pose 
layer, open the Property Inspector, click the 
Ease popup, select an ease option, and then 
enter an ease strength value (0-100, where 0 
is no easing and 100 is the most easing).

Using Inverse Kinematics

Inverse Kinematics
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With Inverse Kinematic (IK), you can use bones to create two types of 
IK animations: those with symbols and those with shapes. For the sym-
bol type, you link them together as a chain. For the shape type, you add 
bones inside the shape. When you add bones to a shape or symbol 
instance, Flash creates a new pose layer. For a shape, Flash also con-
verts the selected shapes and bones into an IK shape object. The first 
bone in an armature is the root bone. It appears with a circle around 
the head of the bone. Each bone has a head, the round end, and a tail, 
known as the pointed end. 

Adding Bones to an 
Armature

Add Bones to a Shape

Create one or more filled shapes 
and arrange them the 
configuration you want.

Select the entire shape on the 
Stage.

Click the Bone tool on the Tools 
panel.

Click inside the shape, and then 
drag to another location within the 
shape.

While you drag, a bone appears. 
When you connect the points, a 
solid bone appears between them. 
Flash converts the selected shape 
into an IK shape object and moves 
it to a new pose layer in the 
Timeline.

To add another bone, drag from 
the tail of the first bone to another 
location in the shape.

As you add bone instances, Flash 
moves each one to a new pose 
layer in the Timeline.

To create a branched armature, 
click the head of an existing bone, 
and then drag to create a new 
branch of the first bone.

6

5

4

3

2

1 45

1

2

Armature layer

3
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Add Bones to a Symbol

Arrange the instances in the 
configuration you want.

Click the Bone tool on the Tools 
panel.

Click the symbol instance that you 
want as the root or head of the 
armature.

Drag the symbol instance to 
another symbol instance to 
connect it.

While you drag, a bone appears. 
When you connect the symbols, a 
solid bone appears between the 
symbols. As you add bone 
instances, Flash moves each 
instance to a new pose layer in the 
Timeline.

To add another bone, drag from 
the tail of the first bone to the next 
symbol instance you want to add 
to the armature.

To create a branched armature, 
click the head of an existing bone, 
and then drag to create a new 
branch of the first bone.

You can add as many branches as 
you want.

6

5

4

3

2

1

Did You Know?
You can move an armature. Select the 
IK shape object with the Selection tool, 
and then drag any of the bones to 
move it.

3 54

2

Symbols
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After you add bones to an armature, you can change the position and 
length of a bone, delete bones, and edit objects containing bones. An 
armature can only be edited in pose layers that contain an initial pose 
in the first frame in which the armature appears in the Timeline. To edit 
the armature, you need to delete any additional poses after the first 
frame of the armature. You can bone properties, such as motion speed, 
joint rotation and motion, and springiness (life-like movement) (New!), 
in the Property Inspector. 

Editing Armatures 
and Bones

Edit Armatures, Bones, and 
Related Objects

Select the bones and associated 
objects you want:

◆ Bone. Click the Selection tool, 
and then click a bone. You can 
Shift-click to select multiple 
bones.

◆ Armature. Double-click a bone.

◆ IK Shape. Click the shape.

◆ Symbol Instance. Click the 
instance.

To move bones, do any of the 
following:

◆ Bone. Drag a bone.

◆ IK Shape. Select the shape, and 
then change its X and Y 
position in the Property 
Inspector.

◆ Bone End in IK Shape. Click the 
Subselection tool, and then 
drag the end of the bone.

◆ Bone Joint, Head, or Tail. Use 
the Transform panel to move 
the transformation point of the 
symbol instance.

◆ Rotate a Bone. Shift-drag a 
bone to rotate it with its child 
bones without moving the 
parent bone.

To delete bones, do either of the 
following:

◆ Bone. Select the bones you 
want to delete, and then press 
Delete.

3

2

1

Selection tool

Armature layer

1

Transform panel

Symbols
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◆ IK Shape or Symbol Instance. 
Select the shape or symbol, 
click the Modify menu, and 
then click Break Apart.

To edit an IK shape, do any of the 
following:

◆ Move the Position of a Bone. 
Drag a bone endpoint to move 
the position of a bone without 
changing the IK shape.

◆ Display Control Points of the 
Boundary. Click the stroke of 
the IK shape.

◆ Move Control Point. Drag the 
control point.

◆ Add Control Point. Click a part 
of the stroke without any 
control points. You can also use 
the Add Anchor Point tool on 
the Tools panel.

◆ Delete Control Points. Click a 
control point to select it, and 
then press Delete. You can also 
use the Delete Anchor Point 
tool on the Tools panel.

To set motion constraints, open the 
Property Inspector, and then 
specify the options you want (see 
table for details) to move or 
constrain joints, disable bone 
rotation around joints, constrain 
the rotation of a bone, make a 
bone stationary, limit the motion 
speed of a bone, or adjust the 
springiness (New!) to bones.

◆ Enable or Disable Spring 
Options. Select the pose layer 
in the Timeline, and then select 
or deselect the Enable check 
box in the Spring section of the 
Property Inspector.

5

4

4

3

IK shape

5

Properties Options

Location Displays the X and Y position, length, and angle. 
Specify a speed percentage.

Joint: Rotation Select the Enable check box to allow joint rotation. 
Select the Constrain check box to constrain the Min 
and Max angles of rotation.

Joint: X or Y Select the Enable check box to allow the bone to 
Translation move along the X or Y axis. A two-headed arrow 

appears to indicate that X or Y axis motion is 
enabled. Select the Constrain check box to limit the 
amount of motion along the X or Y axis.

Spring Specify the Strength (stiffness) (New!) of the bone 
spring. The higher the Strength, the stiffer the 
spring. Specify the Damping (rate of decay) (New!) 
of the spring effect. The higher the Damping, the 
faster the spring diminishes and the animation ends. 
A 0 value equals full strength.

Bone Properties
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When the stroke of an IK shape doesn’t distort in the way you want, 
you can use the Bind tool to edit the connections between individual 
bones and shape control points to create the appearance you desire. 
By default, the control points of an IK shape are connected to the bone 
that is nearest them. The Bind tool allows you to change it. You can 
bind multiple control points to a bone and multiple bones to a control 
point.

Binding Bones 

Bind Bones to Shape Points

◆ Highlight Control Points 
Connected to a Bone. Click the 
Bind tool, and then click a bone.

The connected points are 
highlighted in yellow while the 
selected bone is highlighted in red.

◆ Add Control Points. Select a 
bone, and then Shift-click an 
unhighlighted control point.

◆ Remove Control Points. Ctrl-click 
(Win) or Option-click (Mac) a 
control point that is highlighted in 
yellow.

◆ Highlight Bones Connected to a 
Control Point. Click the Bind tool, 
and then click the control point.

The connected bones are 
highlighted in yellow while the 
selected control point is 
highlighted in red.

◆ Add Other Bones to a Control 
Point. Select a control point, and 
then Shift-click a bone.

◆ Remove a Bone from a Control 
Point. Select a control point, and 
then Ctrl-click (Win) or Option-
click (Mac) a bone that is 
highlighted in yellow.

Bind 
tool

Control points

Binded bones to shape points
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Creating Masks

Introduction

You can create mask layers to show and hide parts of your 
artwork on the Stage. A mask works like a window blocking 
out everything but a certain area that you define. Any shape, 
symbol or text object can be used as a mask. The shape you 
place in a mask layer defines the area that will be visible in 
the linked layers below it. You can animate a mask to reveal 
the content on a layer in stages or animate the art in the 
layer beneath the mask. It is useful for spotlighting and con-
trolling the shape of the viewable area. Masks are great tools 
for keeping the boundaries of the art on your Stage neat and 
controlled. They are also useful for cropping and experiment-
ing with different borders and layouts, because you don't 
have to edit your art, you simply edit the mask. When creat-
ing a mask layer, it is important not to mix elements. For 
example, don't use an editable shape and a group on the 
same mask layer group everything together or break the 
groups into editable shapes. For the most consistent results, 
use ungrouped, editable shapes in the mask layer. 11

11
What You’ll Do

Understand Masks

Create a Mask Layer

Draw a Mask

Activate a Mask

Edit a Mask

Remove a Mask

Add Layers to a Mask

Animate a Mask Layer

295
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You use a mask in Flash to control what is 
viewable on a layer. Whatever you paint or 
draw onto a mask layer defines the viewable 
area on any layer it is linked to. Essentially, 
the shape you place on the mask layer acts 
like a window to the layers linked beneath it. 

To link a layer, you simply drag it into the 
linked set. When a layer is linked to a mask it 
displays a tinted icon and is indented under-
neath the mask layer. Masks are useful for 
cropping artwork on the Stage, and animated 
masks can create interesting visual effects.

Understanding Masks

Linked layer

Draw any shape or shapes on 
a mask layer to limit the visible 
area of any layer linked to it.

Mask layer
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The mask layer and all linked layers 
must be locked to activate the mask.

Shapes drawn on the 
mask layer define the 
visible area. 
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Any layer can be converted into a mask layer. A mask layer only affects 
the linked layers beneath it, and there is no limit to the number of layers 
that can be included. Once a mask layer is created, you can drag other 
layers beneath it to link them. It is important to keep in mind that too 
much masking can affect performance in the Flash Player, especially 
when objects in the masked layers or the mask itself are animated. 

Creating a Mask 
Layer

Create a Mask Layer

Create a new Layer in the Timeline 
or select an existing one.

The layer you select will be the 
one converted into a mask. If you 
want to mask the selected layer, 
create a new layer above this 
layer and select it.

Click the Modify menu, point to 
Timeline, and then click Layer 
Properties.

Click the Mask option from the 
Layer Type list.

Click OK.

A blue masking icon appears on 
the layer.

4

3

2

1

3

1

Layer 2 becomes a mask layer indicated by masking icon.

4
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Click the layer name of the layer 
directly beneath the mask layer, 
and then drag the layer slightly up 
to link it to the mask.

TIMESAVER Press 
Control+click (Mac) or right-click 
(Win) the Layer Name area of the 
layer you want to convert into a 
mask, and then click Mask. When 
you use this method, Flash 
converts the layer into a mask and 
then automatically links it to the 
layer directly beneath it.

5

Drag layer 1 slightly up until the gray bar 
appears. This links it to the mask layer.

Layer is linked to the mask layer. It appears in the Timeline 
indented under the mask layer with a tinted icon.

Mask layer
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You can use any filled shape as a mask. Flash ignores gradients, lines, 
and the content in bitmaps—in all cases it just deals with the whole 
shape. Use any of Flash's drawing tools to create a shape that will 
define the viewable area of the linked layers below. Keep in mind that 
mixing elements at different levels (editable shapes and symbols, for 
example) can produce unexpected results. Try to use only one type of 
element in any one mask: editable shapes, symbols, or groups. 

Drawing a Mask

Create a Mask Layer

Click to select the mask layer.

If the mask layer is locked, click on 
the lock icon in the Lock Layer 
column to unlock it.

Draw a shape with any of Flash's 
drawing tools or drag a symbol 
from the Library.

The area of the shape drawn, or 
symbol used, is the area that will 
be the visible area of the linked 
layer(s) beneath the layer mask.

3

2

1

Any shape or shapes drawn on the 
mask layer defines what is visible 
in the linked layers beneath.

1 2

Circle shape
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To activate a mask, you simply lock it and any of the linked layers 
beneath it. Linked layers are indented in the Layer Name region and 
have tinted blue icons. You can lock and unlock a mask and its layers to 
edit them and see the effects of the mask in the Flash development 
environment. You can also use the Test command (in Flash 
Professional) to view the masking effects in the Flash Player.

Activating a Mask

Activate a Mask 

Open a document with a masked 
layer.

Click the black dot in the lock 
column of the mask layer to lock it.

The dot changes to a lock icon.

Click this dot on each linked layer 
to lock all of them and see the 
masking effect.

TIMESAVER You can click the 
Lock icon at the top of the lock 
layers column to lock all the layers 
in your Timeline simultaneously.

3

2

1 
2

Shapes 
drawn on 
the mask 
layer define 
the visible 
area.
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Masks are editable. Which type of element you are using in the mask 
layer defines the procedure for editing: editable shapes can be modi-
fied with Flash's drawing tools, while groups and symbols must be 
edited in their own editing modes. Regardless, Flash only concerns 
itself with the fill area. Changes to color, alpha, and other such attrib-
utes are ignored. To edit a mask, you must first unlock it. To view your 
changes, simply re-lock the mask layer and all of its linked layers. 

Editing a Mask

Edit a Mask

If the mask layer is locked, click on 
the lock icon in the Lock Layer 
column to unlock the layer and 
enable it for editing.

Edit the shape of the mask or, if 
using a group or symbol, enter the 
group or symbol's editing mode.

Re-lock the mask layer and any 
linked layers to view changes.

3

2

1

1

Add or delete 
shapes, or draw 
new ones with 
any of Flash’s 
drawing tools.

3
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To remove a mask layer entirely, select it and then click the 
Delete Layer icon. You can also convert a mask layer back to a normal 
layer in the Layer Properties dialog box. Additionally, you can remove 
linked layers from a mask layer set by dragging them out of the 
indented set. 

Removing a Mask

Remove a Mask   

Click on the mask layer to select it.

Click the Modify menu, point to 
Timeline, and then click Layer 
Properties.

Click the Normal option from the 
Layer Type list.

Click OK.

The mask layer is converted into a 
normal layer.

TIMESAVER Press 
Control+click (Mac) or right-click 
(Win) the Layer Name area of the 
mask layer you want to convert 
back into a normal layer, and then 
click Mask to deselect it. 

4

3

2

1

3

4

Mask layer becomes a Normal layer.

1
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Add layers to an existing mask by dragging them to any region within 
the masked layer hierarchy. Simply drag it between layers already 
linked, drag it under the mask layer, or drag it slightly up toward the 
bottom of a masked layer set. There is no limit to the number of layers 
that can be contained in a mask. Additionally, you can remove linked 
layers by dragging them out and above the mask layer set. 

Adding Layers to a 
Mask

Link Additional Layers to 
a Mask

To add additional layers to a mask, 
do one of the following:

◆ Click and drag the layer below 
the mask.

◆ Click and drag the layer until it 
touches the bottom of a layer 
already linked to the mask.

1

To add a layer to the top of or between the linked layers of 
the mask set, click and drag the layer into the indented set.

To add a layer to the bottom of the mask set, 
click and drag slightly below the set to link it.

Layers linked to the mask.

Any layer 
can be 
added to 
an existing 
mask layer 
set.

Did You Know?
You can change the order of the linked 
layers. Masked layers behave the 
same as other layers. Click and drag 
the layers to reorder them in the 
indented set.

 From the Library of Wow! eBook



ptg

Chapter 11 Creating Masks 305

Remove a Linked Layer from 
a Mask 

Click on the linked layer, and then 
drag it above the masked layer.

The layer will no longer be linked 
to the mask and the indentation 
disappears.

1

Select the layer you want to remove. Drag it 
above the mask layer until a gray bar appears.

1

Select the layer you want to remove.

Layer is no longer linked to the mask.
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To create special effects such as a spotlighting effect or a gradual 
reveal of artwork on the Stage, you can animate a mask. Use any form 
of animation such as frame-by-frame animation or a shape or motion 
tween. The path of the shape or object on the mask layer will reveal the 
art below as it passes over it. Transforms to scale and position work 
well as well as shape tweens to editable objects. Other effects such as 
color and alpha will be ignored.

Animating a Mask 
Layer

Animate a Mask   

Place artwork in a linked layer.

Click on the first frame of the 
layer's mask layer in the Timeline.

Do one of the following:

◆ Draw a shape on the Stage 
with any of Flash's drawing 
tools.

◆ Drag an instance of a symbol 
from the Library.

Select the first frame with the 
shape or symbol.

Click the Insert menu, and then 
click Classic Tween (when using 
symbols) or Shape Tween (when 
using editable shapes).

Click frame 12 in the Timeline.

Click the Insert menu, point to 
Timeline, and then click Keyframe.

TIMESAVER Press F6 to add a 
keyframe.

Transform the object with any of 
Flash's editing procedures: scale, 
skew, position, or in the case of 
shape tweening, edit the shape of 
the object.

Lock the mask layer and linked 
layer to see the effect.

9

8

7

6

5

4

3

2

1

6

Frame      1           3               5                   7                      9                           10

Tweened scale changes on the mask layer 
reveal the photograph located on the 
linked layer beneath the mask in stages.

8

9

 From the Library of Wow! eBook



ptg

12

12
What You’ll Do
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Working with Sounds

Introduction

Incorporating audio can really bring life to a Flash movie; 
however, the effect is very subtle. For example, most people 
would not be able to tell you the background music playing 
behind their favorite movie, but try leaving the sound out and 
they'll immediately notice. This makes audio a powerful influ-
ence on the viewers of your Flash movies. Adobe under-
stands the power of audio and gives you the ability to import 
audio in a variety of formats, including ASND, MP3, WAV, AIF, 
and AU. If you want more control over your audio, you can 
edit sounds in Adobe Soundbooth directly from Flash. You 
can use on-clip controls to make fast edits and intuitive, task-
based tools to clean up recordings, polish voice-overs, cus-
tomize music, modify sound effects, apply high-quality filters, 
and much more.

There are two types of sounds: event sounds and stream
sounds. An event sound needs to download completely 
before it starts to play, while a stream sound starts to play as 
soon as enough data downloads for the first few frames. 
Event sounds continue to play until they are done or you 
explicitly stop them. Steam sounds are synchronized to the 
Timeline for playing on a Web site. 

Flash audio can be controlled using Flash's version of 
JavaScript, called ActionScript, and it even gives you the abil-
ity to load streaming MP3 files. Add to that the ability to 
choose between mono and stereo, and you can further 
reduce the size of your audio files (mono audio files are half 
the size of stereo). The one drawback to using audio is that it 
produces a much larger file (even compressed audio files are 
relatively large), but even this can be reduced to a minimum 
by using shared audio libraries. Since audio files create large 
Flash movies, use sounds when they are necessary to the 
design of the Flash movie, and remember that sometimes 
silence is golden.

What You’ll Do

Import Audio

Use Audio on the Timeline

Load a Sound from a Shared Library

Use Audio with ActionScript

Load a Streaming MP3 File

Sync Sounds to the Timeline

Add Effects and Looping Sounds

Publish Documents Containing Audio

Edit Sounds

Edit Sounds Using Soundbooth
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When working with Flash, understand that Flash will let you import 
audio in a variety of formats. However, Flash has no way to record or 
create sounds; you can do it with Adobe Soundbooth. Therefore, audio 
must come from external sources. You can use the sample Sounds 
library that comes with Flash or conduct audio searches on the Internet 
using your favorite search engine to find a lot of audio files. One other 
consideration is creating your own audio, using your computer, an 
attached microphone, and a bit of imagination. Flash supports the fol-
lowing sound formats: ASND (from Adobe Soundbooth), WAV, AIFF, 
MP3, Sound Designer II (Mac), Sound Only QuickTime Movies, AU, and 
System 7 Sounds (Mac). When you import an audio file to Flash's 
Stage, you will first need to have a specific layer and keyframe 
selected. When you work on a Flash project, it might be beneficial to 
bring audio files directly into Flash's Library. That way you have easy 
access to them when needed. Any unused audio files are purged when 
you publish the Flash movie.

Importing Audio

Import Audio Files to the Stage

Select a keyframe in the Timeline 
in which you want the audio file 
placed.

IMPORTANT You should 
always place audio files in a 
separate layer. This gives you easy 
access and control over the audio 
file once it's been placed on the 
Stage.

Click the File menu, point to 
Import, and then click Import To 
Stage.

Navigate to the drive or folder 
location with the files you want.

Select one or more audio files to 
import.

To select more than one file, click 
an audio file, then hold down the 
Shift key and click another file to 
select contiguous audio files, or 
hold down the A (Mac) or the 
Ctrl key (Win), and then click to 
select non-contiguous audio files.

Click Import (Mac) or Open (Win).5

4

3

2

1

5

Using QuickTime for Sound

In addition, many formats that are not easy to import can be con-
verted using the QuickTime plug-in. Point your browser to 
www.quicktime.com and download this free plug-in. You can also 
purchase QuickTime Pro to perform a wider range of conversions. In 
addition, you can perform limited conversions for free at 
www.itunes.com.

For Your Information

3

4
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Import Audio Files to 
the Library

Open and select the library where 
you want to import your audio 
files.

Click the File menu, point to 
Import, and then click Import To 
Library.

Navigate to the drive or folder 
location with the files you want.

Select the audio file or files you 
want moved into the Library.

Click Import To Library (Mac) or 
Open (Win).

5

4

3

2

1

Sound wave

Current audio in library

Did You Know?
You can sync sound to a Timeline ani-
mation. Select the sound on the Stage, 
and then change the Sync option on 
the Properties panel to Stream. Flash 
will force the animation to sync to the 
timing of the audio file even if it has to 
drop video frames to keep up.

See Also
See “Using Audio on the Timeline” on 
page 310-312 for information on import-
ing audio using an external library.

Audio files
Audio files are embedded directly into the Flash movie. When you 
publish the Flash movie, by default, all audio files are embedded with 
the movie. Therefore, the Flash SWF file becomes a self-contained 
movie file without the need to access the original audio files.

For Your Information

1

Sample Sounds library

 From the Library of Wow! eBook



ptg

310 Chapter 12

Once you've imported audio files into the active document's Library, it's 
a simple matter to transfer the file to the Timeline. Flash's Timeline is 
actually a frame-by-frame representation of the Stage. For example, if 
you select frame 23 on the Timeline, the Stage displays the contents of 
the 23rd frame on the Stage. Audio, however, does not have a visible 
Stage object, so when you add an audio file to the Timeline, the effects 
are only apparent on the Timeline, not the Stage. Flash's Library holds 
all of the audio files that you've imported into the active Flash docu-
ment. No matter how many times you use that audio file in the source 
document, Flash only needs to save it one time in the published Flash 
movie. In addition to the main Library, you can also use audio from the 
Sounds library that comes built-in to Flash. One of Flash's powerful fea-
tures is the ability to use audio files from other Flash libraries. External 
Flash libraries are simply Flash source documents, which have an 
active Library. This gives you the ability to create libraries of audio files 
and use them over and over again.

Using Audio on 
the Timeline

Add Audio Using the Library or 
Sound Library

Open the library that you want to 
use:

◆ Library. Click the Window 
menu, and then click Library.

TIMESAVER Press A+L 
(Mac) or Ctrl+L (Win) to open the 
Library panel.

◆ Sound Library. Click the 
Window menu, point to 
Common Libraries, and then 
click Sounds.

Select a layer and keyframe in the 
Timeline in which you want the 
audio file placed.

Drag the audio file from the Library 
directly onto the Stage.

Flash places the audio file in the 
selected keyframe.

3

2

1

3

Audio file placed on the keyframe.

Library

Sound 
library
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Add Audio Using an 
External Library

Click the File menu, point to 
Import, and then click Open 
External Library.

Navigate to the drive or folder 
location with the files you want.

Select a Flash document that 
contains an active Library.

Click Open.

Drag items from the external 
Library directly to the Stage.

Drag items from the external 
Library to the active document's 
Library.

IMPORTANT When you drag 
an object from an external Library 
onto the Stage of the active Flash 
document, it is automatically 
added to the active document's 
Library.

6

5

4

3

2

1

2

5

4

Did You Know?
You can use a single Library panel for 
all open documents. When you open 
multiple documents, Flash now consoli-
dates all the libraries into a single 
Library panel. Click the list arrow but-
ton (located at the top of the Library 
panel) to select from any available 
library. 

See Also
See “Working with the Library Panel” 
on page 136 for information on using 
the single library panel and other 
options.

3

 From the Library of Wow! eBook



ptg

312 Chapter 12

By default, Flash embeds audio files directly into the published (.swf) 
file. You have the option of loading audio files from a common Library. 
This gives you the advantage of using the same sounds in several Flash 
movies at the same time. For example, you create a Web site using 
fifteen separate Flash movie files, and each one uses the same back-
ground music. Rather than embed the same sound fifteen times, you 
can simply load the sound, when needed, from a common Library. 
Shared libraries are simple Flash documents that are set up to share 
their files between several Flash movies. The process is easy, and the 
rewards are great, and you don't increase the file size of Flash movies 
using shared Library elements. Once you've created and defined a 
Flash document as a shared Library, you can use the items in other 
Flash movies without increasing the size of the Flash published .swf file.

Loading a Sound from 
a Shared Library

Create a Shared Audio Library

Create a new Flash document.

Add the audio files to the 
document's Library. They do not 
have to be placed on the Stage.

Click the File menu, and then click 
Save. Use a distinctive name for 
the source document.

Select an audio file in the Library.

Click the Library Options button, 
and then click Properties.

Select the Export For Runtime 
Sharing check box.

◆ If the check box is not 
available, clear the Import for 
runtime sharing check box. 

Enter a distinctive name for the 
Identifier field or use the default.

Enter the name of the published 
document into the URL field.

Click OK.

Repeat steps 4 through 9 until all 
the audio files are correctly linked.

Click the File menu, and then click 
Publish to create the Flash .swf 
file.

Close the original source file.11

10

9

8

7

6

5

4

3

2

1

4

5

6 8

7

9
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Work with Shared Audio 
Libraries

Click the File menu, point to 
Import, and then click Open 
External Library.

Select the shared Library, and then 
click Open.

The items in the external Library 
will be grayed out, indicated they 
are sharable items.

Drag the audio files from the 
external Library to the Library of 
the active document.

To display or change link 
properties for an audio, double-
click the audio icon in the Library, 
click Advanced (if necessary), 
view or change link options, and 
then click OK.

When you publish the Flash .swf 
file, the audio files will be drawn 
from the common Library, without 
increasing the size of the Flash 
movie.

4

3

2

1

External 
Library 
(Shared)

3

Linkage settings 
for audio

Active 
Library

4

Did You Know?
A Flash Library can be shared with 
other designers. Since a Library is sim-
ply a Flash movie with Library ele-
ments, you can create common 
libraries of often-used elements, and 
then give them to other designers. 
When you're working with two or more 
designers, this is a great way to 
maintain consistency on a complex 
project.
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Sound is a great motivator. For example, a particular piece of music 
can make you happy, or it can make you sad. In addition, sounds can 
pull out childhood memories and stir emotions. Sound is a powerful 
tool, however, different people react differently to sounds, therefore it's 
important that you think carefully about the sounds you add to your 
movies. It's equally important to understand how you can control your 
movies using using ActionScript 3.0 code or ActionScript Behaviors in 
ActionScript 2.0.

Using Audio with 
ActionScript

Load a Sound from the Library 
with ActionScript 3.0

Create or open a Flash document 
(ActionScript 3.0).

Click the Window menu, click 
Library to open the Library panel, 
and then select an audio file from 
the available Library items.

Right-click (Win) or Command-
click (Mac) the audio sound, and 
then click Properties. Click 
Advanced, if necessary.

Enter a distinctive name for the 
Identifier field or use the default.

Select the Export For ActionScript 
check box.

Leave the other fields at their 
default values, and then click OK.

Click Frame 1 in a layer.

Click the Window menu, and then 
click Actions.

Type the ActionScript code shown 
in the illustration:

Click the Control menu, point to 
Test Movie, and then click Test.

10

9

8

7

6

5

4

3

2

1

2 64

9

8

3

5
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Load a Sound from the Library 
with an ActionScript Behavior

Create or open a Flash document 
(ActionScript 2.0).

Click the Window menu, click 
Library to open the Library panel, 
and then select an audio file from 
the available Library items.

Click the Library Options button, 
and then click Properties.  Click 
Advanced, if necessary.

Select the Export For ActionScript 
check box.

Enter a distinctive name for the 
Identifier field or use the default.

Leave the other fields at their 
default values, and then click OK.

Click the Window menu, and then 
click Behaviors to open the 
Behaviors panel.

Select a button object on the 
Stage or Timeline keyframe.

Click the plus (+) sign, located in 
the upper-left portion of the 
Behaviors panel, point to Sound, 
and then click Load Sound From 
Library.

Enter the name of the audio file in 
the Linkage ID field. 

Enter a unique name in the 
instance field. 

Select the Play This Sound When 
Loaded check box. 

Click OK.

Select an Event to trigger the 
sound. If the audio file was added 
to a Timeline frame, the event field 
will be disabled.

Click the Control menu, point to 
Test Movie, and then click Test.
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You can load an MP3 music audio file using a built-in Flash behavior. 
The advantage to this process is that the file is loaded when needed, 
and it never increases the size of the original Flash movie. Flash per-
forms a calculation on audio files as they are loading. When it has 
enough of an audio file, it begins playing, while it continues to down-
load the remaining information in the background. For large audio files, 
this cuts down on long wait times and keeps the visitor from becoming 
bored. Streaming MP3 files are not part of a pre-existing Flash movie, 
they're just available from a common location.

Loading a Streaming
MP3 File

Load a Streaming MP3 File with 
ActionScript 3.0

Create or open a Flash document 
(ActionScript 3.0), and then select 
a button object on the Stage.

Open the Properties panel.

Enter a distinctive name for the 
object in the Instance field, such 
as myButton.

Click Frame 1 in the actions layer.

Click the Window menu, and then 
click Actions.

Enter the script as shown in the 
illustration:

Click the Control menu, point to 
Test Movie, and then click Test.

7

6

5

4

3

2

1

1

4

6

5
See Also

See Project 2, “Loading and Formatting 
Text” in the Workshops, available at 
www.perspection.com, for Action-
Script 3.0 code to load external text.
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Load a Streaming MP3 File with 
an ActionScript Behavior

Create or open a Flash document 
(ActionScript 2.0), and then select 
a button object on the Stage or 
Timeline keyframe.

Click the plus (+) sign, located in 
the upper-left portion of the 
Behaviors panel, point to Sound, 
and then click Load Streaming 
MP3 File.

Enter the URL to the source MP3 
file.

Enter a unique name in the 
identifier field.

Click OK.

If you selected a button object, 
select an Event to trigger the 
sound.

Click the Control menu, point to 
Test Movie, and then click Test.

7

6

5

4

3

2

1

2

3

1
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Did You Know?
You can stop all sounds using an 
ActionScript Behavior. Create or open 
a Flash document (ActionScript 2.0) 
that contains playing audio files, place 
a button object on the Stage, and then 
select it. Click the plus (+) sign in the 
Behaviors panel, point to Sound, and 
then click Stop All Sounds. Click OK. 
Select an Event to stop the sound.
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When you sync a sound to the Timeline, you're essentially instructing 
Flash how to play the sound. Syncing sounds is a fundamental operation 
because choosing the wrong sync operation can drastically change 
how the sound plays out during the execution of the Flash movie. Flash 
gives you the ability to choose a separate sync operation for each indi-
vidual sound file. When you place the sound on the Timeline, the 
Properties panel displays the audio properties for the selected sound 
and lets you define individual properties for every sound in your Flash 
document. For example, you have a background music sound that's 
located in several scenes, and you want to make sure it doesn't play on 
top of itself (Sync: Stop). Or, you have a narration that you want per-
fectly synced to an animation on the Timeline (Sync: Stream). 

Syncing Sounds to 
the Timeline

Sync Sounds to the Timeline

Select the keyframe on the 
Timeline containing the sound you 
want to sync.

Click the Window menu, and then 
click Properties to open the 
Property Inspector.

Click the Sync list arrow, and then 
select from the following options:

◆ Event. When you select Event 
(default) the sound plays when 
the record head reaches the 
keyframe containing the sound, 
and continues to play until the 
end of the sound. If the record 
head reaches another keyframe 
that contains the same sound, it 
will begin playing on top of the 
original sound.

◆ Start. Doesn’t allow the sound 
to play on top of itself.

◆ Stop. Stops a sound if it is 
already playing, without 
affecting any other sounds.

◆ Stream. The Stream Sync 
creates sounds synchronized to 
the Timeline. This is useful for 
matching sounds to a particular 
visual event in the movie. If the 
video can not keep up with the 
audio, Flash will automatically 
drop video frames to keep the 
audio synchronized.

3
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1
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Once a sound is imported into Flash and placed on the Timeline, you 
can add sound effects and determine the number of loops. When you 
loop a sound, you're instructing the Flash movie to repeat the sound a 
given number or times, or to loop the sound forever. Some sounds loop 
better than others. For example, you create some background music, 
and you want it to continue to play for as long as the visitor is on that 
particular page, but you don't want the sound to have a definable 
beginning or end. In addition to loops, you can also add effects to a 
sound, including fades in and out, and fade to the left or right channel. 
The effects applied will only modify the selected audio file. Each copy 
of an audio file dragged into a Flash movie is controlled independently.

Adding Effects and 
Looping Sounds

Add Effects and Loop Sounds

Select the keyframe on the 
Timeline containing the sound you 
want to change.

Click the Window menu, and then 
click Properties to open the 
Property Inspector.

To add effects to the sound, click 
the Effect list arrow, and then 
select an option: 

◆ Left Channel/Right Channel. 
Plays sound in the left or right 
channel.

◆ Fade Left To Right/Fade Right 
To Left. Changes sounds from 
one channel to the other.

◆ Fade In. Increases volume.

◆ Fade Out. Decreases volume.

◆ Custom. Creates custom in and 
out sound points using the Edit 
Envelope.

To loop a sound, click the list 
arrow, and then select an option: 

◆ Loop. Click Loop to force the 
sound into an infinite loop.

◆ Repeat. Click Repeat, and then 
enter the number of times you 
want the sound to loop (up to 
65,535).
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Sooner or later, you're going to want to export your Flash movie that 
contains audio as an SWF file. The process of publishing is relatively 
painless; however, there are a few considerations as to the compres-
sion of the files, which will be important to the size and playability of 
the Flash movie. Publishing requires knowledge of where the document 
will be used. For example, if the document is to be streamed over the 
Internet, and your visitors have relatively low bandwidth, you would 
want to choose compression settings that would significantly reduce 
the size of the audio files. It's possible that the Flash document is 
intended for playing off a CD/DVD; in that case, you could increase the 
compression settings. When you're designing a Flash document, it's 
imperative that you understand the end game and design the document 
toward that goal. Always remember that you can design a Flash docu-
ment, but it's your visitors that ultimately will see, and use it.

Publishing Documents 
Containing Audio

Publish Sound Documents

Click the File menu, and then click 
Publish Settings.

Click the Formats tab, and then 
select the Flash (.swf) check box.

Click the Flash tab.

Click the Set buttons for Audio 
Stream or Audio Event.

Select other sound options as 
desired:

◆ Select the Override Sound 
Settings check box to override 
any sound settings applied to 
the individual sound files within 
the active Flash document.

◆ Select the Export Device 
Sounds check box to export 
sounds suitable for devices, 
such as mobile devices, instead 
of the library sound.

Click the Compression list arrow, 
and then select from the following 
options:

◆ Disable. Turns off all sound 
compression options and 
instructs Flash not to export 
sounds.

◆ ADPCM. Performs minor 
compression to the audio files.
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◆ MP3. Creates audio files, 
especially music files, with 
excellent quality in a small file 
size.

◆ Raw. Leaves the sounds intact 
without any compression 
schemes applied.

◆ Speech. Creates optimized files 
for the human voice.

Select the Convert Stereo To Mono 
check box for the ADPCM and 
RAW compression formats.

Based on your Compression 
selections from step 5, select the 
following options:

◆ Sample Rate. Available for 
ADPCM, Raw, and Speech 
compression. The higher the 
sample rate the better the 
quality, but the bigger the file.

◆ ADPCM bits. Higher bit values 
translate into better quality 
audio, but larger file sizes.

◆ Quality. Available for MP3 
compression. The Best option 
gives the finest quality, but 
produces a larger file.

◆ Bit Rate. Available for MP3 
compression. The higher the 
value, the better the quality and 
the bigger the file.

Click OK.

Select the Override Sound 
Settings check box to take priority 
over the individual settings applied 
to the audio files.

Select the Export Device Sounds 
check box to export device sounds 
with the published Flash movie.

Click OK.12
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Changing Audio File Quality
You cannot publish a Flash movie with audio files that are better 
quality than the originals. For example, if the MP3 audio files you're 
using have a Bit rate of 16kbps, increasing that to 48kbps does not 
create a better quality audio file. In fact, that’s true of most Flash 
objects, not just audio. To increase the quality of an audio file would 
require the use of an audio application. You can find sound programs 
at www.downloads.com.

For Your Information
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Flash is not a major sound editing application. For example, you can't 
trim or cut audio files, nor can you enhance audio or reduce hum and 
background noises. Flash expects all that to be done before you import 
the file. However, you do have some control over when the sound 
begins and ends (time in, and time out), and you do have control over 
the volume (fade in and fade out). Making sure that your audio file is 
clean and smooth flowing will help with the quality of your audio file.

Editing Sounds 

Work with Edit Envelope

Select a keyframe on the Timeline 
that contains an audio file.

Click the Window menu, and then 
click Properties to open the 
Property Inspector.

Click the Edit button.

Click the Effect list arrow, and then 
select a channel, fade, or custom 
effect.

Drag the Time In marker to the 
right to change where the audio 
file begins.

Drag the Time Out marker to the 
left to change where the audio file 
ends (the Time Out marker appears 
at the end of the audio file).

Click the Envelope lines to adjust 
the volume on the right or left 
channels.

Use the Zoom buttons to increase 
or decrease the size of the audio 
file in the edit window.

Click the Play or Stop buttons to 
test the changes to the audio file.

Click the Time Marker buttons to 
change the marker code from 
frames to seconds.

Click OK to save your changes.

IMPORTANT Adjusting an 
audio file using Edit Envelope only 
impacts the select instance of the 
audio file. The original audio file 
(in the Library) is unaffected by 
these changes.
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Adobe Soundbooth is a program that allows you to record and modify 
sound files. If you have Soundbooth installed on your computer, you can 
edit imported sounds in Soundbooth directly from within Flash. When 
you’re done editing the sound file in Soundbooth, you can save the file 
and your changes automatically appear in Flash. If you change the 
name or format of a sound after editing it, you’ll need to re-import the 
modified file back into Flash. You can edit all different sound file formats 
in Soundbooth. If you want to non-destructively edit sounds, then use 
the default sound file format (ASND) in Soundbooth for the best results. 

Editing Sounds Using 
Soundbooth

Edit a Sound Using Adobe 
Soundbooth

Click the Window menu, and then 
click Library to open the Library 
panel.

Right-click (Win) or Control-click 
(Mac) the sound file you want to 
edit, and then click Edit with 
Soundbooth.

The sound file opens in Adobe 
Soundbooth.

Edit the sound file using Sound-
booth tools and commands.

◆ Use Help in Soundbooth to edit 
the sound file the way you 
want.

When you’re done, save the sound 
file in Soundbooth. Click the File 
menu, and then click Save.

◆ To save the changes in a non-
destructive format, save the file 
using the ASND file format, the 
default in Soundbooth.

◆ If you change the name or 
format of a sound after editing 
it, you’ll need to re-import the 
modified file back into Flash.

Quit (Mac) or exit (Win)
Soundbooth to return to Flash and 
view the edited version of the 
sound file in the Library panel. 
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Working with Video

Introduction

The Flash Video Import Wizard lets you import a video clip as 
a file that is streamed from a Flash server, progressively 
downloaded from a Web server, embedded (stored in movie) 
or linked (stored out of movie). It guides you through the 
steps for the specific deployment method. During the import 
process, you have the ability to compress the video using 
user-defined profiles, or preset values, set cue points, and 
trim excess video. It's important to understand that although 
Flash can import a video file, it can't make the quality of the 
video any better than the original. If you receive your video 
from outside sources, there is little you can do; however, if 
you're the one shooting the footage, pay close attention to 
lighting, camera angles, and distractions within the video. 
The more time and attention you spend taking the video, the 
better the video will be when imported into Flash. If you do 
need to tweak a video file, video-editing applications such as 
Adobe's Premiere (Mac/Win), and Apple's Final Cut Pro (Mac) 
are excellent choice for the budding movie director.

If you have a video-editing application and Flash, you can 
create a movie against a blue screen and then mask the area 
out using alpha channel masks. They do this in the movies all 
the time. The process involves opening the image within a 
video-editing application, and creating the transparency 
using a specific color (referred to as blue or green screening), 
using luminosity levels, or actually creating a mask in an 
image-editing application such as, Adobe Photoshop, and 
then importing the mask. When you open the movie in Flash, 
any other background you place behind the movie will 
replace the original green screen. 13

13
What You’ll Do

Use the Video Import Wizard

Work with Video on the Stage

Work with Video on the Timeline

Use Movie Clips with Video Files

Add Cue Points to a Video

Use Video with ActionScript

Control Video Through Movie Clips

Use the FLV Playback Component

Work with the Video Encoder

Work with Alpha Channel Masks

Export as a QuickTime Video

Export as a FLV File 

325
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Importing video into Flash is not much more difficult than importing a 
graphic or audio file. The Video Import Wizard is Flash's way of helping 
you through the process of importing video files into Flash. When you 
import video, the Wizard lets you import a video clip as a file that is 
streamed from a Flash server, progressively downloaded from a Web 
server, embedded (stored in movie) or linked (stored out of the movie). 
It guides you through the steps for the specific deployment method. 
During the import process for some methods, you have the ability to 
compress the video using user-defined encoding profiles, set cue 
points, and trim excess video. You can choose to accept the Wizard's 
recommendations or make changes. You can also attach movie play-
back controls with different looks, known as skins (New!). The Wizard 
seamlessly uses the Skinning component to attach movie controls.

Using the Video 
Import Wizard

Use the Video Import Wizard

Click the File menu, point to 
Import, and then click Import 
Video.

◆ For the FLV format, use Import 
To Library since the file is 
native to Flash and doesn’t 
need to be encoded.

Flash saves the video in the active 
document's Library. 

Select a video file location option:

◆ Click the On Your Computer 
option, click Browse to 
manually locate the video file.

Choose a video method from 
the following options:

◆ Load external video with 
playback component.

◆ Embed FLV in SWF and play 
in timeline.

◆ Import as mobile device 
video bundled in SWF.

◆ Click the Already deployed to a 
web server, Flash Video 
Steaming Service, or Flash 
Media Server option, and then 
enter in the file's URL.

Click Next.3

2
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2

3

Skinning options
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Options vary depending on the 
deployment method; select the 
ones you want.

◆ Skinning. Specify the 
appearance and position of the 
play controls (New!); 
additional skins added.

◆ Embedding. Specify a symbol 
type, and other embedding 
options.

Click Next.

Click Finish.

Flash will automatically create an 
FLV component, and drop it into 
the active layer on the Timeline. 
Flash places the external video on 
the Stage with the first frame of 
the video (New!) and playback 
controls at the bottom. 

Click the Control menu, point to 
Test Movie, and then click Test.

7
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5

6

Extension Description

.flv, f4v Adobe Flash Video

.mp4, .m4v, .avc Moving Picture Experts Group

.mov, .qt QuickTime

.3gp, .3gpp, .3gp2, 3GPP/3GPP2 for Mobile Devices

.3gpp2, .3g2

Supported Import Video Formats

See Also
See “Working with the Video Encoder” 
on page 340 for information on Flash 
video encoding settings.
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When you import video into a source document, Flash places the exter-
nal video on the Stage with the first frame of the video (New!) and 
playback controls at the bottom. You can use the playback controls on 
the Stage to play and work with the video (New!). In addition, you can 
make changes to video settings in the Properties panel as you work 
with the video on the Stage. In the Properties panel, you can change 
the position and size, alignment, skin, volume, autoplay, and cuepoints. 
You can no longer change video properties in the Component Inspector 
panel on the Parameters tab (New!).

Working with Video 
on the Stage

Move a Video File Directly 
to the Stage

Open a Flash document (.fla) that 
contains one or more video files.

Select the video.

Use the playback controls to work 
with the video.

Click the Window menu, and then 
click Properties to open the 
Properties panel.

Use the Properties panel to 
change the options you want.

◆ align. Specify FLV file alignment 
in the player.

◆ autoPlay. Select or deselect to 
automatically play the FLV file.

◆ cuePoints. Specify a string with 
the cue points for the video.

◆ isLive. Select or deselect 
whether the FLV is streaming 
live.

◆ preview. Creates a preview for 
authoring purposes.
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◆ scaleMode. Select an option to 
maintainAspectRatio, noScale, 
or exactFit.

◆ skin. Select a skin for the FLV 
video player.

◆ skinAutoHide. Select or 
deselect to automatically hide 
or show the skin.

◆ skinBackgroundAlpha. Specify 
a background alpha channel for 
the skin.

◆ skinBackgroundColor. Specify 
a background color for the skin.

◆ source. Specify the path to the 
video source file.

◆ volume. Specify a volume 
setting for the video.

Click the Control menu, point to 
Test Movie, and then click Test.

6

5

Skin for the FLV player
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When you import video into a source document, Flash stores a copy of 
the video in the active document's Library. Even if you import the video 
directly to the Stage, Flash will still place a copy in the Library. It's 
always best to import video files first into the Library; that way you have 
control of the video and how it's brought onto the Stage. Moving a 
video file directly to the Stage is the easiest way to incorporate video 
into a Flash movie. In fact, once the video file has been imported into 
Flash, it's a simple drag and drop operation. However, video files should 
always be held within a separate layer. That gives you control over the 
display of the video and lets you place other Flash elements in other 
layers.

Working with Video 
on the Timeline

Move a Video File to the Stage 
from the Timeline

Open a Flash FLA document that 
contains one or more video files in 
the Library or use the Video Import 
Wizard.

IMPORTANT To work directly 
with video files on the Timeline, 
you will have to Import them using 
the Embed video in SWF and play 
in Timeline (see Using the Video 
Import Wizard).

Click the Window menu, and then 
click Library to open the Library 
panel.

Click the Insert Layer button, name 
the new layer video_1, and then 
select the new layer.

Drag the video file from the Library 
onto the Stage.

Click Yes, if prompted to a dialog 
box indicating how many frames 
the video file will occupy on the 
Stage.

Click the Control menu, point to 
Test Movie, and then click Test.
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Video file in the Library
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While placing a video file directly onto the Stage may be an easy way 
to bring a video file into a Flash movie, the best way to control video is 
to first place it into a movie clip, and then drag the movie clip onto the 
Stage. That gives you control of the clip with two Timelines: the 
Timeline on the Stage, and the Timeline of the movie clip.

Using Movie Clips 
with Video Files

Use Movie Clips with 
Video Files

Click the Window menu, and then 
click Library to open the Library 
panel.

Click the Insert menu, and then 
click New Symbol.

Name the new symbol.

Click Type list arrow, and then 
click Movie Clip.

Click OK.

Drag a video file from the Library 
into the movie clip Library.

Click Yes when Flash instructs you 
as to how many frames the video 
file will occupy in the movie clip.

Return to the current scene by 
clicking the Scene button, located 
in the upper-left corner of the 
Flash window.

Click the Insert Layer button, and 
name the new layer video_1.

Select the new layer.

Drag the movie clip from the 
Library onto the Stage.

The movie clip occupies a single 
frame.

Click the Control menu, point to 
Test Movie, and then click Test.
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A cue point is a marked moment in time within a video clip. Cue points 
enable you to access different segments of a video clip. With Flash 
video, you can create and manage ActionScript cue points in the 
Properties panel (New!). You can add or delete a cue point, rename a 
cue point, adjust the time, and add or delete ActionScript parameters. If 
you want to reuse existing ActionScript cue points, you can also import 
and export them in the XML file format using the Import ActionScript 
Cue Point or Export ActionScript Cue Point buttons.

Adding Cue Points to 
a Video

Work with Cue Points in a Video

Open a Flash FLA document that 
contains one or more video files in 
the Library or use the Video Import 
Wizard.

Select the video.

Click the Window menu, and then 
click Properties to open the 
Properties panel.

Click the Cue Points arrow to 
expand the panel.

To work with ActionScript cue 
points, do any of the following:

◆ Find a Cue Point. Enter a 
keyword in the Search box, and 
then press Enter (Win) or 
Return (Mac). 

◆ To clear the search, click 
the Close button in the 
Search box.

◆ Add a Cue Point. Use the 
playback controls to position 
the video where you want to 
create a cue point, and then 
click the Add ActionScript Cue 
Point button.

◆ Delete a Cue Point. Select the 
cue point, and then click the 
Delete ActionScript Cue Point 
button.

◆ Rename a Cue Point. Click the 
cue point name to select it, 
rename it, and then press Enter 
(Win) or Return (Mac).
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Playback 
controls
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To add or delete ActionScript 
parameters, do any of the 
following:

◆ Add Parameter. Click the Add 
Cue Point Parameter button. 
Click the parameter name or 
value to change them. 

◆ Delete parameter. Select the 
the parameter, and then click 
the Delete Cue Point Parameter 
button.

To export or import ActionScript 
cue points, do any of the following:

◆ Export Cue Points. Click the 
Export Cue Points button, 
specify a filename and location, 
and then click Save.

The exported file also includes 
any navigation and event cue 
points which are embedded in 
the video

◆ Import Cue Points. Click the 
Import Cue Points button, 
select the cue points XML file, 
and then click Open.
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5
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7 Import

Cue point controls

See Also
See “Working with the Video Encoder” 
on page 340 for more information on 
working with encoded cue points.

Did You Know?
ActionScript cue points are different 
than encoded cue points. Encoded cue 
points are ones you add when encod-
ing video with Adobe Media Encoder. 
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Playing a video file inside a Flash movie is one thing, controlling the 
movie, or better yet, letting your visitors control the movie is something 
quite different. Control of a movie requires knowledge of Flash's 
ActionScript language. ActionScript is a control language that instructs 
Flash what to do, and when to do it. For example, you could create an 
ActionScript that instructs Flash to play or stop a movie, or you could 
add buttons to move the video backward or forward, one frame at a 
time. One way to display video in a Flash Movie is to drag it directly 
from the Library to the Timeline. Once the video is on the Timeline, 
ActionScripts can be created to start and stop the video. Since you're 
using the active document's Timeline to control the video, any other 
layers containing animation sequences on the Timeline will stop and 
start along with the video.

Using Video with 
ActionScript

Control Video from the Timeline

Create or open a Flash document, 
create a new layer to hold the 
video file, and then select the 
layer.

Drag the video file from the Library 
to the Stage.

Create a new layer to hold the 
navigation buttons, and then select 
the layer.

Drag the Play, Stop, and Rewind 
buttons into the Navigation layer 
from the Library, and then place 
them underneath the video.

Click the Window menu, and then 
click Actions to open the Actions 
panel.

To display scripting language 
commands for the scripting 
language you want to use, click 
the Language button, and then 
select the language you want.
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Did You Know?
You can check the syntax of any script 
with the click of a button. Click the 
Check Syntax button, located at the top 
of the Actions panel, and Flash will 
check the syntax of the script. 
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Do either of the following 
depending on the ActionScript 
version:

◆ ActionScript 2.0. Select the 
Play, Stop, and Rewind buttons 
individually, and then enter the 
ActionScript 2.0 script as 
shown in the illustration. 

◆ ActionScript 3.0. Click Frame 1 
in a layer, and then enter the 
ActionScript 3.0 script as 
shown in the illustration.

IMPORTANT ActionScript is a 
relatively easy language to learn, 
but it is also a very unforgiving 
language. For example, the 
gotoAndStop script must be 
written exactly as shown, 
including the capital "A" and "S". 
While ActionScripting, remember 
to keep an eye on syntax.

Click the Control menu, point to 
Test Movie, and then click Test.

IMPORTANT Although working 
with embedded video is a common 
practice, large video files can 
cause audio sync problems when 
the file is published and played. 
It's always wise to thoroughly test 
your published documents.

8

7

7

Did You Know?
Flash contains several sets of pre-
designed buttons. Click the Window 
menu, point to Common Libraries, and 
then click Buttons. Flash's button 
Library contains folders with dozens of 
buttons, including arcade buttons and 
buttons for controlling a Flash movie.

AS 2.0

AS 2.0 - Stop

AS 2.0 - Rewind
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While it's an easy matter to drag a video file onto the Stage and then 
use start and stop ActionScripts to control the playing of the video, it's 
better to create a movie clip, and then load the video file into the clip. 
It's a bit more work, but the additional rewards are great. For example, 
you can instruct a movie clip to stop playing without affecting anything 
else on the Stage. As a matter of fact, you can have as many movie 
clips on the Stage as you want, and each one can be controlled individ-
ually. It's exactly that kind of control that leads to awesome Flash 
movies. To control a video using a movie clip you will need to have a 
flash document that contains one or more video files, in the Library.

Controlling Video 
Through Movie Clips

Control Video Through 
Movie Clips

Create or open a Flash document, 
click the Insert button, and then 
click New Symbol.

Name the symbol, and then click 
the Movie Clip option.

Click OK.

Drag a video file from your Library 
into the movie clip symbol.

Click the Scene button to return to 
the Stage of the active scene. 

Create a new layer to hold the 
video, and then select the layer. 

Drag the movie clip to the Stage, 
and then select the clip. 

Enter a unique Instance name in 
the Property Inspector.

IMPORTANT The Instance 
name you enter will be used in the 
ActionScript to identify the movie 
clip to the button object "with 
(instance name)".

Create a new layer to hold the 
navigation buttons, and then select 
the layer.
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Drag Play, Stop, and Rewind 
buttons into the Navigation layer 
from the library, and then place 
them underneath the video.

Click the Window menu, and then 
click Actions.

To display scripting language 
commands for the scripting 
language you want to use, click 
the Language button, and then 
select the language you want.

Do either of the following 
depending on the ActionScript 
version:

◆ ActionScript 2.0. Select the 
Play, Stop, and Rewind buttons 
individually, and then enter the 
ActionScript 2.0 script as 
shown in the illustration. 

◆ ActionScript 3.0. Click Frame 1 
in a layer, and then enter the 
ActionScript 3.0 script as 
shown in the illustration.

IMPORTANT ActionScript is a 
relatively easy language to learn, 
but it is also a very unforgiving 
language. For example, the 
gotoAndStop script must be 
written exactly as shown, 
including the capital "A" and "S". 
While ActionScripting, remember 
to keep an eye on syntax.

Click the Control menu, point to 
Test Movie, and then click Test.
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AS 2.0

AS 2.0 - Stop

AS 2.0 - Rewind
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Instead of importing video into Flash, you can also use the FLVPlayback 
components to dynamically play external FLV files in Flash Player. The 
FLVPlayback component is the display area (made up of a customizable 
skin with playback controls) in which you view video. Simply export 
your movie as an FLV file from Flash or a video editing programs using 
the FLV Export plug-in, and then use the FLVPlayback component in 
Flash to play it back. If you want to include closed captioning (W3C 
standard XML format Timed Text), you can use the FLVPlayback 
Captioning component

Using the FLV 
Playback Component

Work with the FLV Playback 
Component

Create or open a Flash document.

Click the Window menu, and then 
click Components to open the 
Components panel.

Click the Video arrow to expand 
the list.

Drag the FLVPlayback component 
onto the Stage, and then select the 
component.

Click the Window menu, and then 
click Properties to open the 
Properties panel.

Click the Edit Source button.

Click the Browse folder icon, 
navigate to and select the FLV 
video file that you want to use, and 
then click Open.

Select the Match source 
dimensions check box to use the 
same video size as the file.

Click OK.9
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FLVPlayback component
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9

7

Use the Properties panel to 
change the options you want.

◆ align. Specify FLV file alignment 
in the player.

◆ autoPlay. Select or deselect to 
automatically play the FLV file.

◆ cuePoints. Specify a string with 
the cue points for the video.

◆ isLive. Select or deselect 
whether the FLV is streaming 
live.

◆ preview. Creates a preview for 
authoring purposes.

◆ scaleMode. Select an option to 
maintainAspectRatio, noScale, 
or exactFit.

◆ skin. Select a skin for the FLV 
video player.

◆ skinAutoHide. Select or 
deselect to automatically hide 
or show the skin.

◆ skinBackgroundAlpha. Specify 
a background alpha channel for 
the skin.

◆ skinBackgroundColor. Specify 
a background color for the skin.

◆ volume. Specify a volume 
setting for the video.

Click the Control menu, point to 
Test Movie, and then click Test.
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To improve workflow for those of us who love to work with video, 
Adobe Media Encoder includes a stand-alone video encoder that you 
can install on a computer dedicated to video encoding. The Adobe 
Media Encoder lets you batch process video encoding, allowing you to 
encode several video clips, using different codecs at the same time. 
The Adobe Media Encoder also lets you edit video clips, add cue points 
(to trigger other actions), and crop (change viewable area of video) and 
trim (edit beginning and end points) the video.

Working with the 
Video Encoder

Work with the Video Encoder

Open the Adobe Media Encoder 
CS5.

◆ Use the Start menu (Win) or 
Applications folder (Mac). 

◆ If you’re importing a video, click 
File, point to Import, click 
Import Video, and then click 
Launch Adobe Media Encoder.

Click Add to add video files to the 
batch list.

◆ Click the File menu, and then 
click Add Adobe Premiere Pro 
Sequence or Add Adobe After 
Effects Composition to add 
these file types.

Select the video that you want to 
change settings.

Click Duplicate to make a copy of 
the selected video file, which 
saves the same video file using 
different compression settings.

Click Remove to remove the 
selected video file from the batch 
list.

Click the Format menu, and then 
select a format with which to 
encode the video or audio clip. 

The selected format displays a list 
of available presets designed for 
the delivery format.

Click the Preset menu, and then 
select an encoding preset for your 
intended application. 
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Click the Output filename, specify a 
location and file name for the 
encoded file or use the default 
filename from the source clip.

Click Settings.

The Export Settings dialog box 
appears, displaying tabs for Source 
and Output.

Click the Source tab.

Select the Export Video check box, 
click the Video tab, and then 
specify a frame rate, and other 
video options.

Select the Export Audio check box, 
click the Audio tab, and then select 
a kbps data rate, quality setting, 
and other options.

Click the Crop button, enter edge 
values to crop the video, and then 
drag the in and out point markers 
below the scrubber bar to set the 
video trim points.

Click the Output tab to preview the 
cropped image. Use the Crop 
Setting list arrow to select an 
option.

Use the cursor to move the 
playback head to the frame 
location you want to embed, click 
Add Cue Point, and then specify 
the type of cue point you want.

Click OK.

Click Start Queue to begin batch 
processing all the files in the 
batch list. Click Stop Queue to halt 
the process. 

The status column provides 
information for each video during 
the encoding process.
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One of the cool features in Flash is its ability to work alpha channel 
masks. Alpha masks are typically created within video-editing applica-
tions, such as Apple's Final Cut Pro or Adobe's Premiere. The process 
involves opening the image within the video-editing application and 
creating the transparency using a specific color (referred to as blue or 
green screening), using luminosity levels, or actually creating a mask in 
an image-editing application such as Adobe Photoshop, and then 
importing the mask. For example, you could film yourself against a 
green screen, and then mask those areas out. When you open the 
movie in Flash, any other background you place behind the movie will 
replace the original green screen. They do this in the movies all the 
time.

Working with Alpha 
Channel Masks

Work with Alpha Channel 
Masks

Open your video-editing 
application, and create a specific 
alpha channel mask.

The mask represents the areas of 
the movie for which you want to 
maintain transparency.

Use your video-editing Export 
command and then select the 
Flash FLV format.

Click Options or select options for 
exporting a Flash FLV file.

◆ If Options is not available, open 
the Adobe Media Encoder 
(from the desktop), add the FLV 
file to the queue select a FLV 
preset format, and then open 
the Export Settings dialog box. 
Click the Edit menu, and then 
click Export Settings.

The Export Settings dialog box 
appears, displaying tabs for 
Source and Output.
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Click the Source tab.

Select the Export Video check box.

Click the Video tab.

Select the Encode Alpha Channel 
check box.

Click OK.

Click Save to save the file.

Open Flash Professional.

Click the File menu, point to 
Import, and then click Import 
Video.

Use the steps outlined in “Using 
the Video Import Wizard” on page 
326.

Move to the Timeline and create a 
new layer directly underneath the 
video layer, and name it backdrop.

Place an image in the backdrop 
layer.

Click the Control menu, point to 
Test Movie, and then click Test.

When you view the movie, the 
areas designated as transparent 
by the alpha channel mask will 
display the contents of the 
backdrop layer, directly through 
the running video.
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See Also
See “Using the Video Import Wizard” 
on page 326 for more information on 
using the Video wizard.
See “Working with the Video Encoder” 
on page 340 for information on Flash 
video encoding settings.
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Flash makes it easy to export a Flash document to a QuickTime video 
using the QuickTime Export Settings dialog box. By default, Flash cre-
ates a QuickTime video of the complete source document with the 
same dimensions. However, you can change the export options. In the 
QuickTime Export Settings dialog box, you can set movie dimensions, 
ignore stage color, specify when to stop exporting and where to store 
temporary data, and set advanced QuickTime settings. The advanced 
QuickTime settings are set for optimal playback. If you have experience 
using QuickTime, you can set the advanced settings to customize the 
results you want.

Exporting as a 
QuickTime Video

Export Flash as a QuickTime 
Video

Click the File menu, point to 
Export, and then click Export 
Movie.

Click the Format popup (Mac) or 
Save As Type list arrow (Win), and 
then click QuickTime (*.mov).

Type the new file name. 

Navigate to the drive or folder 
location where you want to save 
the document. 

Click Save.

The QuickTime Export Settings 
dialog box opens.

If available, specify the width and 
height in pixels you want for the 
QuickTime video.

◆ To maintain the same ratio of 
width and height, select the 
Maintain Aspect Ratio check 
box.

To create an alpha channel using 
the Stage color, select the Ignore 
Stage Color (Generate Alpha 
Channel) check box. 

The alpha channel is encoded as a 
transparent track, letting you 
overlay the exported QuickTime 
movie on top of other content to 
alter the background color or 
scene.
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Extension Description

.swf Shockwave movie

.avi Audio Video Interleaved

.mov QuickTime

.gif Animated GIF 

.wav Audio WAV

.jpg, .jpeg, .gif, .png Sequence of images for JPEG, GIF, or PNG

Supported Export Video Formats
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Click the When Last Frame Is 
Reached or After Time Elapsed 
option and then specify the time 
you want in the format 
(hh:mm:ss.msec), where hh is 
hours, mm is minutes, ss is 
seconds, and msec is milli-
seconds.

Click the In Memory or On Disk 
option to specify where you want 
to store temporary data. 

Click QuickTime Settings.

Select the Video check box, and 
then click the buttons where you 
want to make video option 
changes.

◆ Settings. Select video 
compression type, quality, 
frame rate, and data rate.

◆ Filter. Select a video filter, such 
as blur, emboss, sharpen, and 
special effects.

◆ Size. Select a standardized 
size, such as NTSC, PAL, etc.

Select the Sound check box, and 
then click the buttons where you 
want to make audio option 
changes.

◆ Settings. Select sound 
compression, sample rate, 
sample bit size, and usage 
(mono or stereo).

To optimize for Internet streaming, 
select the Prepare For Internet 
Streaming check box, and then 
select the option you want.

Click OK.

Click Export.

Upon completion, click OK.16
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The FLV (Flash Video) file format allows you to import or export a static 
video stream including encoded audio. For example, you could use the 
FLV format to save video for use with communications applications, 
such as video conferencing. When an FLV clip is exported with stream-
ing audio, the audio is compressed using the Streaming Audio settings 
in the Publish Settings dialog box, and the file is compressed. FLV files 
can be used with Flash's new media components to create streaming 
video files directly in a Flash movie. In order to use the FLV format, you 
must first set up the video files for exporting. Any Flash document that 
contains video clips will work. When FLV video files are played back, 
they're handled as a progressive download—Progressive downloads 
begin playing as soon as a certain percent of the complete file has 
been transferred. The playback is not as quick as that provided by 
streaming video, but it's not as slow as complete file download formats 
such as the MPEG video. 

Exporting as a FLV 
File

Export Video Clips into the FLV
File Format

Select a video clip in the Library 
panel.

Click the Libraries Options button, 
and then click Properties.

Click Export.

Enter a name for the exported file.

Select a location where it will be 
saved.

Click Save.

Click OK.7
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Did You Know?
You can use the Property Inspector to 
modify a Flash FLV video clip. Drag the 
FLV video file onto the Stage, select the 
video clip, and then open the Property 
Inspector. The Property Inspector lets 
you give the clip an instance name; 
change the width, height, and registra-
tion point of the clip; and even swap a 
video clip with another video clip.
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Using Basic ActionScripts

Introduction

Flash's programming language is called ActionScript. 
ActionScript lets you create detailed instructions on how the 
Flash movie will perform. Flash CS5 allows you to build 
applications using two different versions of ActionScript, 
either ActionScript 1.0 & 2.0 or ActionScript 3.0.

In this chapter, you’ll learn the basics of ActionScript 
along with scripting as it relates to ActionScript 2.0. In the 
next chapter, you’ll learn about scripting as it relates to 
ActionScript 3.0. ActionScripts can use an event to trigger the 
specific action. Say you create a button, and you want the 
ActionScript to trigger an instruction that will stop the movie, 
but only when the user clicks the button object. The defined 
event is the user clicking his mouse, and the action would be 
to stop playing the movie. ActionScript is a relatively easy 
language to learn, but a very precise language to code, so 
pay close attention to the syntax.

The good news is that once you master the language and 
the syntax, the full power of Flash is available to you. You can 
create ActionScripts that are triggered (the event) by specific 
data, or information typed in by a visitor. You can even create 
ActionScripts that are sensitive to variables such as date and 
time. Flash helps you by giving you functions (English-like 
script) and as your ActionScript skills grow, you can even cre-
ate and call your own functions. Each new version of Flash 
moves the ActionScripting language closer and closer to 
JavaScript. The power of Flash is fully realized when you 
write ActionScripts and incorporate them in your Flash docu-
ments.

What You’ll Do

View the Actions Panel

Set ActionScript Preferences

Understand Properties and Methods

Apply Properties and Methods to 
an Object

Use Dot Syntax

Understand Data Types

Use Functions

Use Conditional Statements

Attach a Mouse Event to a Button

Work with Frame Events

Work with Clip Events 

Attach a Clip Event to a Movie Clip

Work with Loops 

Use For Loops

Work with ActionScript Behaviors
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The Actions panel is gives the Flash designer 
control of a Flash document by allowing 
him/her to create and edit actions for an 
object or frame. To use the Actions panel, 
select an object on the stage, or select a 
frame on the Timeline, click the Window 
menu, and then click Actions. Scripts can be 
typed directly into the Actions panel using the 
Script pane, or augmented by using a list of 
installed Actions in the Toolbox.

◆ Toolbox. Supplies a list of all installed 
actions, either ActionScript 1.0 & 2.0 or 
ActionScript 3.0

◆ Script pane. Enter the Actions into the 
Script pane.

◆ Script Navigator pane. Gives reference 
to all the Scripts in the active movie.

◆ Current Script tag. Indicates which 
script is being edited.

◆ Pin Script. Adds a tab for a selected 
script.

◆ Options menu. Contains options that 
control and format the Actions panel.

◆ Add Statement. Lets you add script 
elements to the current action.

◆ Find, and Find and Replace. Searches 
the active script.

◆ Insert Target Path. Inserts a specific 
target clip into the action.

◆ Check Syntax. Checks the current 
action for syntax errors.

◆ Auto Format. Cleans up the script by 
auto indenting.

◆ Auto Close Bracket. When you type 
an open bracket {, Flash automatically 
adds the corresponding close 
bracket }. (New!)

◆ Show Code Hint. Gives you hints to 
the syntax of the action as you type.

◆ Debug Options. Add or remove 
breakpoints into the action to pause 
on the specified line of code.

◆ Collapse and Expand. Collapse 
between braces, collapse selection, 
or expand all.

◆ Comments. Apply a block or line 
comment.

◆ Code Snippet. Code Snippets 
provides ActionScript 3.0 code 
segments to use in scripts. (New!)

◆ Script Assist for 3.0. Script assist 
provides a visual interface for editing 
scripts (syntax completion and 
parameter descriptions).

◆ Help. Provides online help.

Viewing the Actions Panel

Script Tag

Script Navigator pane

Toolbox 

Script pane

Help

Script Assist

Options menu 

Pin Script

Actions Panel toolbar buttons Code Snippets
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Since ActionScripting is so important, Flash gives you the ability to con-
trol the Actions panel through preferences. ActionScript preferences 
give you the ability to control the font and size of the text typed into the 
Actions panel, as well as using syntax coloring to help you visualize the 
code. You can also set AutoFormat preferences to specify the auto-
matic formatting you want for your ActionScript code.

Setting ActionScript 
Preferences

Set ActionScript Preferences

Click the Flash (Mac) or Edit (Win) 
menu, and then click Preferences.

Click the ActionScript category.

Select from the following options:

◆ Automatic Close Brace. Select 
to automatically insert a close 
bracket. (New!)

◆ Automatic Indentation.
Instructs Flash to perform 
syntax indentation.

◆ Tab Size. Enter a value for the 
number of spaces used. 

◆ Code Hints. Gives you on-
screen hints as you type.

◆ Delay. Delay before showing a 
code hint. (0 to 4 seconds) 

◆ Font. Select a font and size for 
the ActionScript text.

◆ Open/Import and Save/Export. 
Select UTF-8 or Default 
encoding for open and import 
operations (UTF-8 is best).

◆ Reload Modified Files. Click to 
be prompted when Flash needs 
to reload a modified file.

◆ Class Editor. Select an editor or 
Ask to be prompted. (New!)

◆ Syntax Coloring. Choose the 
syntax-coloring scheme.

◆ Language. Click ActionScript 2.0 
or ActionScript 3.0 to modify the 
ActionScript sub-settings.

Click the Auto Format category.

Select format check boxes and 
view the effect in preview.

Click OK.6
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To reset preference setting to the 
default, click Reset To Defaults.

Preview 
area
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Objects in Flash are defined using two primary identifiers: properties and methods. The proper-
ties of an object define its characteristics. In the real world, a house would be an object, and its 
properties would be things like its color, style, and number of windows and doors. In Flash, it 
would be written something like this:

house.color = "green"; 
house.style = "ranch"; 
house.windows = "12"; 
house.doors = "2";

In this example, the word house is a unique instance name for the house object, and the words 
color, style, windows, and doors represent the properties assigned to this instance. Think of an 
instance as a copy of a Library item. When you create a movie clip, the object is created in 
Flash's Library. When you return to the Stage, you can then drag the movie clip from the 
Library to the Stage (technically, you're moving a Library symbol, created using the movie clip 
behavior). Once the movie clip is moved to the Stage, it is defined as an instance of the original 
Library item. When you select an instance on the Stage, Flash's Properties panel lets you give it 
a unique name. In the previous example, "house" is the unique name.

Giving a Library symbol a unique name gives you a lot of control. For example, you could 
move two instances of the same movie clip onto the Stage, give each of them its own unique 
name (house1, house2) in the Properties panel, and then define different properties for each 
one. Something like this:

house1.color = "green"; house2.color = "blue"; 
house1.style = "ranch"; house2.style = "tudor"; 
house1.windows = "12"; house2.windows = "8"; 
house1.doors = "2"; house2.doors = "4";

In Flash, most objects have properties. For example, the MovieClip object has property val-
ues such as transparency, horizontal and vertical position, and visibility. You might define prop-
erties loosely as the physical appearance of a movie clip, as it appears on the Flash Stage. A 
method instructs the object to perform some task. A method is a function that is part of a class 
definition. For example, if a DVD player is an object, then the methods would be something 
like: play, record, and stop. Flash methods are written like this:

play(); 
record(); 
stop();

Some methods require parameters within the parenthesis. The following method instructs the 
play head to move to frame 6 on the Timeline and stop:  gotoAndStop(6);

Attaching the method to a specific object requires identifying the object in the ActionScript 
code: myDVD.gotoAndStop(6);

ActionScript is a language, and just like learning any foreign language, all the words and syn-
tax might seem strange at first; however, the longer you work with the language, the simpler it 
becomes.

Understanding Properties and Methods
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Once you've gotten the hang of writing ActionScripts, the next step is 
to apply properties and methods to objects in a Flash document. You 
can have an object and let your visitor control its color. Changing the 
color is an example of changing an object’s properties. To make an 
object change color, you will need a Flash document that contains a 
MovieClip and button symbols. An easy script translation would be: 
Flash, when my visitor clicks (release) on the button, I want you to 
assign a new color to an object that I gave a unique instance name 
(change it), and I'm defining that property as objectColor, and change 
the color (setRGB) to red (0x990000). When you attach ActionScripts to 
buttons, you're not limited to just a single use. For example, you could 
drag three instances of the same button symbol on the Stage and 
repeat the previous code with one exception: change the SetRGB value 
of one to (0x990000) for red, another to (0x009900) for green, and the 
third one to (0x000099) for blue.

Applying Properties 
and Methods to an 
Object

Apply Properties and Methods

Drag the movie clip onto the 
Stage.

Enter a unique instance name in 
the Properties  panel.

Drag the button symbol onto the 
Stage, and then select the symbol.

Click the Window menu, and then 
click Actions to open the Actions 
panel.

Enter the script (ActionScript 2.0) 
as shown in the illustration.

◆ ActionScript 3.0 example files 
are available on the Web at 
www.perspection.com.

Click the Control menu, point to 
Test Movie, and then click Test.

Click the button to change the 
color of the object to red.
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See Also
See “Creating Invisible Buttons” on 
page 153 for information on creating 
invisible buttons.
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ActionScript, just like any human language, 
has rules you should follow. However, in 
ActionScripts, you have to follow the rules or 
it won't work. One of the more important 
rules to follow is the use of dot syntax. The 
use of dots (.) in a script serves several pur-
poses. First, is to specify the target path to a 
particular Timeline. For example, _root.amer-
ica.kansas.wichita defines a movie clip on the 
main (_root) Timeline with the name america, 
containing a movie clip named kansas, which 
in turn contains a movie clip named wichita. 
Dot syntax is used to create a road map for 
Flash to follow. Dot syntax is a separator 
between two or more parts of a Flash script. 

Another use of dot syntax is to change the 
properties and methods for a specific object. 
Since ActionScript, by definition is an object-
oriented language, Flash performs its respon-
sibilities by instructing an object to do 
something (method), or by changing a prop-
erty. For example, star._rotation = 90; instructs 
Flash to rotate the MovieClip instance named 
star, 90 degrees (property). To instruct the star 
MovieClip instance to play (method), you 
would enter the following code: star.play();

Using Dot Syntax

Movie Clip with Instance Name: MovieA

ActionScript 2.0
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When you use ActionScripts, you have the 
ability to work with data. Data can be informa-
tion entered in by a visitor in an input data 
field, or it can be computer information such 
as the current position of the mouse, or the 
date and time. When you work with data, you 
have 4 possible data types:

◆ String. Allows for the entering of text 
values.

◆ Number. Allows for the entering of 
numeric values.

◆ Boolean. A Boolean state has two 
values; typically true or false.

◆ Object. Serves as a storage device for 
any data type, including other objects.

Use Data Types to Control Information
Since data types control the type of informa-
tion that can be entered into a data field, you 
can use them to validate the data someone is 
entering. For example, you want to create a 
calculator to convert between degrees 
Fahrenheit and Celsius. To do this, you will 
need an input field for someone to enter the

current temperature in Fahrenheit, a button 
that would perform the calculation, and then a 
dynamic text field for the result, and one for 
an error message.

Select the Input Field, and then give it a 
unique variable name in the Properties 
panel.

Select the Error Dynamic Text Field and 
give it a unique variable name in the 
Properties panel.

Select the Results Dynamic Text Field, 
and give it a unique variable name in the 
Properties panel.

Select the button instance, and then 
enter a script into the Actions panel (see 
the example file for script details).

When the movie is played, the visitor will 
enter a value into the data field, and it will be 
evaluated as to whether it's purely numeric. If 
it isn't, an error message will display in the 
dynamic error field. If the field contains num-
bers, then the calculation will perform the 
conversion and display the results displayed 
in the output field.
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Understanding Data Types

Error Message using text Error Message using a 
blank field 

Correct data...no error 
message
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A function is a block of ActionScript code that 
can be reused anywhere in a SWF file. If you 
pass values as parameters to a function, the 
function will operate on those values. A func-
tion can also return values. Flash contains 
built-in functions that let you access certain 
information and perform certain tasks, such 
as getting the version number of Flash Player 
hosting the SWF file (getVersion()). Functions 
that belong to an object are called methods. 
Functions that don't belong to an object are 
called top-level functions and are found in the 
Functions category of the Actions panel.

Each function has its own characteristics, 
and some functions require you to pass cer-
tain values. If you pass more parameters than 
the function requires, the extra values are 
ignored. If you don't pass a required parame-
ter, the empty parameters are assigned the 
undefined data type, which can cause errors 
when you export a script. To call a function, it 
must be in a frame that the playhead has 
reached.

To call a function, simply use the function 
name and pass any required parameters. The 
following code describes a common syntax 
for creating functions:

function firstFunction (x, y, z) {

// place all actions here;

}

Using Functions

Calling a Function
Functions begin with the word function, fol-
lowed by the name of the function (user-
defined). The area enclosed by parenthesis is 
used for passing parameters to the function 
actions. If the parameters are left blank, 
you're essentially creating a generic function 
that will function the same way every time it's 
called. If the function contains parameters, it 
will perform in a unique way each time it's 
called. When you call a function, you're 
instructing Flash to execute all of the actions 
within that function. Therefore, if firstFunction 
contained 20 actions, all of them would be 
executed by using a single line of script. To 
call a function, simply add this line to the 
action:

myFunction ();

Passing Parameters to a Function
If the function has been defined to accept 
parameter information, you can use the fol-
lowing line of script:

myFunction (parameter 1, parameter2);

Once a Function is defined, it can be called 
anytime it's needed. Therefore, it's a good 
practice to define all of your functions in 
frame 1 of the active Flash document. That 
way they can be called anytime after that. 
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Conditional statements in ActionScript are a 
critical part of interactivity. They let you pro-
gram a script based on any number of condi-
tions. For example, in the morning, you say 
good day, or good morning to someone you 
meet. In doing so, you made a conditional 
choice.

ActionScript does the same thing. You can 
create an ActionScript that checks the time of 
day. If it's before noon, Flash responds with a 
Good Morning message. If it's from noon to 5, 
Flash says Good Afternoon, or from 5 till mid-
night, Flash says Good Evening. This type of 
condition is known as an if/else condition. If 
this happens, do this… else do that. Since a 
variable can be almost anything you can 
measure on a computer, and a conditional 
statement is made up of two or more vari-
ables, ActionScript can be taken to a point 
where it almost thinks for itself. The previous 
example could be expressed in flow charting 
the following way:

Typically, when you're creating a condi-
tional statement, you're comparing one ele-
ment against another using operators. The 
following operators are available to create 
conditional statements:

◆ == Checks for equality between two 
values (is time of day equal to 5).

◆ != Checks for inequality between two 
values.

◆ < Checks for less than (is value A less 
than value B).

◆ > Checks for greater than (is value A 
greater than value B).

◆ <= Checks for less than or equal to 
between two values.

◆ >= Checks for greater than or equal to 
between two values.

◆ && Checks for a logical AND (if day == 
"Friday" && time > 5).

◆ || Checks for a logical OR (if day == 
"Saturday" || day == "Sunday").

Using these operators to check between 
two or more values, you can create complex 
ActionScripts that react differently based on 
the available data. To create a dynamic field 
that checks the time, and responds with the 
appropriate answer, you would enter the fol-
lowing code:

if (time > "0000 &&  time < 1200) {

response = "Good Morning";

} else if (time >1200 && time < 1700) {

response = "Good Afternoon";

}else if (time > 1700 && time < 2400);

response = "Good Evening"

}

Using Conditional Statements
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Attaching a mouse event to a button is probably the easiest of all the 
event handlers. For example, you have a movie clip of a dog that con-
tains a barking audio file. When the movie clip plays, the dog barks. The 
trick is to have the dog bark when the visitor rolls their mouse over the 
dog’s face. To do this, you will need to create an invisible button and 
then attach the mouse event to the invisible button.

Attaching a Mouse 
Event to a Button

Attach an Event to a Button

Click the Insert menu, and then 
click New Symbol.

Select the Button type, and then 
name the symbol. 

Click OK.

Create a blank keyframe in the Hit 
state of the button, and then 
create a shape. 

Leave the Up, Over, and Down 
states blank. 

Exit the Symbol editing mode, and 
then return to the Stage.

Drag a movie clip onto the Stage.

Create a new layer, and then name 
the layer.

Drag the invisible button onto the 
Stage, and then place it over the 
area of the image you want to use 
as a button.

Enter the script (ActionScript 2.0) 
as shown in the illustration.

◆ ActionScript 3.0 example files 
are available on the Web at 
www.perspection.com.

When the visitor rolls into or out of 
the invisible button, the rollOver or 
rollOut event handlers will trigger 
the playing or stopping of the dog 
movie clip. 

Click the Control menu, point to 
Test Movie, and then click Test.
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Frame event handlers are easy to understand. When an action is 
attached to a frame, the action is triggered when the play head hits the 
frame. For example, you want to create a frame event that swaps 
images on the Stage, and you want the images to swap every 40 
frames. You can attach an ActionScript that swaps the image, and 
place the action every 40 frames. When the play head hits the frame, 
the action executes. When you attach an ActionScript to a frame, you’ll 
need a blank keyframe on the Timeline, and it is strongly recommended 
that you always place ActionScripts in a separate layer from access 
and control. In addition, if you're planning to swap images in a Flash 
movie, it's always best to use a blank movie clip (called a placeholder) 
to hold the images.

Working with 
Frame Events

Attach an ActionScript 
to a Frame

Drag a blank movie clip onto the 
Stage, and then select the clip.

Give the movie clip a unique 
instance name in the Properties 
panel.

Create a new layer, and then name 
the layer.

Create blank keyframes at frame 
numbers 1, 21, 41, and 61. 

Select a frame, click the Insert 
menu, point to Timeline, and then 
click Blank Keyframe.

Select frame 1, and then enter the 
script (ActionScript 2.0) as shown 
in the illustration.

◆ ActionScript 3.0 example files 
are available on the Web at 
www.perspection.com.

Select frames 21, 41, and 61, and 
then repeat the script, except 
change the name of the image you 
want to load (image_b.jpg, 
image_c.jpg, image_d.jpg).

Click the Control menu, point to 
Test Movie, and then click Test.
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on(press) { 
trace("The button has been pressed.");

}

You can specify two or more events for 
each on() handler, separated by commas. The 
ActionScript in a handler executes when one 
of the events specified by the handler occurs. 
For example, the following on() handler 
attached to a button will execute whenever 
the mouse rolls over or out of the button.

on(rollOver, rollOut) { 
trace("mouse rolled in or out");

}

If you want different scripts to run when 
different events occur, you have the option to 
attach more than one handler to an object. 
You can attach onClipEvent() handlers to the 
same movie clip instance. The first would exe-
cute when the movie clip first loads (or 
appears on the Stage); the second executes 
when the movie clip is unloaded from the 
Stage.

onClipEvent(load) { 
trace("loaded");

} 
onClipEvent (unload) {

trace("unloaded");

If you’re working with ActionScript 2.0 (not 
supported in ActionScript 3.0), you can attach 
clip events to movie clips, which triggers an 
action specified in the onClipEvent handler. 
Event handlers, also known as event listen-
ers, control when events in Flash occur. When 
you create a script, some event will be 
invoked to trigger that particular action. You 
might want a specific movie clip to stop play-
ing when another movie clip loads on the 
Stage, or when the user clicks or moves their 
mouse.

The Clip Event is one of a series of event 
handlers that Flash uses to create actions 
within a Flash movie. You can attach event 
handlers directly to a button or movie clip 
instance by using the onClipEvent() or the 
on() handlers. The onClipEvent() handles 
movie clip events, and on() handles button 
events. To use an on() or onClipEvent() han-
dler, attach it directly to an instance of a but-
ton or movie clip on the Stage, and then 
specify the event you want to handle for that 
instance. For example, the following on() 
event handler executes whenever the user 
clicks the button the handler is attached to.

Working with Clip Events 

Assigning a Clip Event using 
the Behaviors panel.

Assigning a Clip Event directly in 
the Actions panel.
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For ActionScript 2.0, you can only attach an onClipEvent() to a movie 
clip instance that has been placed on the Stage. You can't attach an 
onClipEvent() to a movie clip instance that is created at runtime; for 
example, using the attachMovie() method. However, you can still attach 
multiple event handlers. Using different event handlers within the same 
Flash document do not conflict with each other. You could have a but-
ton with an on(press) handler that tells the SWF file to play, and the 
same button can have an onPress method, for which you define a func-
tion that tells an object on the Stage to rotate. When the button is 
clicked, the SWF file plays, and the object will rotate. Being able to 
consolidate different event handlers with a single instance gives you 
greater control, as well as less Stage clutter.

Attaching a Clip Event 
to a Movie Clip

Attach an onClipEvent 
to a Movie Clip

Create or open a Flash document 
(ActionScript 2.0), place a movie 
clip on the Stage, and then select 
the movie clip.

Give the movie clip a unique 
instance name in the Properties 
panel.

Move down the Timeline and add a 
keyframe at frame 80. 

Click the Insert menu, point to 
Timeline, and then click Keyframe.

Add a second movie clip to the 
Stage, and then select the second 
movie clip.

Enter the script as shown in the 
illustration.

Click the Control menu, point to 
Test Movie, and then click Test.

When the playhead hits frame 80 it 
loads the second movie clip. The 
loading of the movie will trigger 
the onClipEvent handler, and stop 
the playing of the movie clip with 
the unique instance name of 
movie2.
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Working with Loops

Loops allow Flash to perform an action 
repeatedly. You can use a loop to create a 
dynamic drop-down menu, validate data, 
search for text, duplicate movie clips, and 
even detect collisions in games that have pro-
jectiles and objects. Conditional statements
let you execute an action based on a specific 
condition. You can have a specific action con-
tinue to loop until a certain condition is met. 
For example, continue to search for a specific 
text string until it is found or the end of the 
text document is reached. Loops come in two 
forms—While loops and For loops. While 
loops wait for a specific condition to start or 
stop the loop. That may sound similar to the 
For loop, with one exception: The For loop is 
self-contained, and the While loop works with 
an external condition, or one outside the 
scope of the loop.

◆ While Loops. While loops continue to 
execute while a certain condition exists 
(keep looping or searching) until a 
specific value is reached.

i = 4; 
while (var i > 0) {

my_mc.duplicateMovieClip("newMC" + i, i ); 
i--;

}

◆ For Loops. For loops are self-
contained counters. For example, loop 
(repeat the action) ten times and
then stop.

x = x; 
for (x=0; x<=10, ++x)  {

myClip.duplicateMovieClip ("myClip" + x, x); 
myClip._rotation =45 + x * 10;

}

When you create a Looping action, you 
can further control the loop by using the fol-
lowing loop exceptions:

◆ Continue. The continue exception lets 
you stop the current loop from 
performing its actions and jump 
directly to the next cycle of the loop.

◆ Break. The break exception is used to 
exit a loop, even if the original 
condition that is driving the loop is 
still true.

For example, if you create a While loop using 
the following script:

total = 0; 
i = 0: 
while (++i <=20) {

if (i == 10) { 
continue;

} 
total +=i;

}

The results would be a script that executes 
and adds 1 to total; unless the value of i 
equaled 10. This would create a sequence of 
numbers 1 2 3 4 5 6 7 8 9 11 12 13 14 15 16 17 
18 19 20. If you had used the break exception 
in place of continue, the values would read: 
1 2 3 4 5 6 7 8 9. Therefore, it loops whether 
For or While are controlled by internal or 
external conditions, and using a break or con-
tinue exception gives you further control over 
the loop.
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The For loop works with an increasing or decreasing numeric value. For 
example, you could use a For loop to create several copies of a movie 
clip on the Stage. Letting the For loop control movie clips to the Stage 
is far more efficient than having to move them one at a time. In addi-
tion, the visitor can control when the items appear on the Stage using a 
button.

Using For Loops

Use For Loops

Drag a movie clip from the Library 
to the Stage, and then select the 
movie clip.

Enter a unique instance name for 
the movie clip in the Properties 
panel.

Place a button on the Stage, and 
then select the button.

Enter the script (ActionScript 2.0) 
as shown in the illustration.

◆ ActionScript 3.0 example files 
are available on the Web at 
www.perspection.com.

When you play the movie, clicking 
on the button causes the action to 
loop 10 times. Each time it loops, it 
duplicates the original movie clip 
and rotate it by 45 degrees plus 
the current value of x times 10.

4

3
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1

4

Did You Know?
You can use a For Loop to pause a 
Flash movie. Select a value, instruct 
the loop to increment by 1, and then 
loop until the value is reached. Use a 
loop timer for such items as a Flash 
slide show, where you want the slides 
to display on the stage for a given 
number of seconds before moving to 
the next slide. 

1 3 2
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Behaviors are time-savers because they give 
you sections of ActionScript 2.0 code (not 
supported in ActionScript 3.0; see Code 
Snippets in the next Chapter) for common 
Flash tasks. Behaviors are a great way to 
introduce yourself to the wonderful world of 
ActionScripting without having to write all the 
code. For example, if you want to add a Play 
ActionScript to a button, you can do it using 
the Add button in the Behaviors panel, or you 
can write out the code on your own; see the 
example code below. Using Behaviors, as 
opposed to writing the code by hand, is not 
better, it’s simply faster. The more time you 
save doing common Action-Scripting tasks 
using Behaviors, the more time you will have 
for the creative process.

Using the Behaviors Panel
You use the Behaviors panel to apply the 
behavior to a triggering object, such as a but-
ton. You specify the event that triggers the 
behavior, such as releasing the mouse. Next 
select a target object, such as the movie clip 
instance, and then select settings for behavior 
parameters, such as a frame number or label, 
or a relative or absolute path. Flash comes 
with built-in behaviors, such as Load Graphic, 
Duplicate Movieclip, and GotoAndPlay At 
Frame Or Label. To add and configure a

behavior, select a trigger object, and then step 
through the following general instructions 
(steps may vary depending on the behavior):

Click the Window menu, and then click 
Behaviors.

Click the Add (+) button, and then select a 
behavior from the menu.

If necessary, select settings for the 
behavior parameters, and then click OK.

Under Event, click On Release (the default 
event), and then select a mouse event 
from the menu. 

4

3

2

1

Example Play ActionScript 2.0 code

on (release) {

if(this.video_1._parent._currentframe == this.video_1.parent._totalframes){

this.video_1parent.gotoAndPlay(1);

} else {

this.video_1._parent.play();

}

}

Working with ActionScript Behaviors

Add button Click to select a mouse event.

Behavior parameters
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Working with 
ActionScript 3.0

Introduction

Do you like Flash games and cool features on YouTube, like 
jumping from standard view to HD? There are two faces to 
Flash: the one you see and then the complex scripting 
engine, called ActionScript, you don’t. Without ActionScript 
Flash would not be interactive. ActionScript is the scripting 
language built within Flash that allows you to build interac-
tive solutions. Any Flash movie where you need to click, drag 
or pause requires the use of ActionScript to instruct Flash 
what to do. ActionScript is the core to all interactivity and 
logic built into Flash. 

The release of Flash CS3 introduced ActionScript 3.0, a 
significant overhaul of the scripting language. Older versions 
of ActionScript ran slowly with large and complex scripts. 
ActionScript 3.0 changed this. ActionScript 3.0 is up to 10x 
faster than ActionScript 2.0 and brings a whole lot more func-
tionality to the party. ActionScript 3.0 adopted a true object-
oriented approach to development, a technique that allows 
Flash applications to compete with solutions developed with 
Microsoft’s .NET or Oracle’s Java. ActionScript 3.0 dramati-
cally extends what can be accomplished by increasing the 
speed of Flash through the Flash Player 9 and 10. With 
ActionScript 3.0 and Flash Player 10.1, you can deliver Flash 
solutions to more desktops, devices and systems than ever 
before. ActionScript 3.0 is now the default scripting language 
in Flash CS5.

In this chapter, you’ll learn why ActionScript 3.0 is a pro-
gramming language you will want to start using, what has 
changed from earlier versions of ActionScript, what is the 
same and how you can make your applications rock by using 
ActionScript 3.0. The only challenge you have is to decide 
what to develop first. 15

15
What You’ll Do

Use Object-Oriented Programming 

Enable Flash to Execute Solutions
Faster with AVM 2.0

Use ActionScript 3.0

Change ActionScript 3.0 Settings

Insert Code with Code Hints

Insert and Create Code Snippets

Develop Solutions Built with the DOM3 
Model

Work with Classes

Work with Objects and Classes

Use NameSpaces in your Projects

Control Data

Manipulate XML with E4X

Use Regular Expressions

Control Text

Draw with the Shape Class

Extend Flash with Open Source 
Libraries
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Objects are the key to understanding object-
oriented programming. In object-oriented 
programming (OOP), an object is just as real 
as an object in this world. For example, your 
dog, or even your computer are objects that 
exist in the real world. Real-world objects 
share two characteristics with objects in the 
computer world: They have a specific state 
and behavior. For example, dogs have a state 
such as their name, color, breed, and if 
they're hungry. Dog behaviors would be: 
barking, fetching, and wagging their tails. All 
objects in the real and computer worlds have 
a behavior and a state.

Computer objects are modeled after real-
world objects in that they also have a specific 
state and behavior. A class is a representation 
of an object that stores information about its 
data type, state, and behaviors. A class can 
include three types of characteristics: proper-
ties, methods, and events.  A property repre-
sents different data associated with an object. 
A method is an action that can be performed 
by an object. An event is a system, applica-
tion, or user action, such as a mouse click, 
that triggers an action related to an object.

After you create a class, you can also cre-
ate new classes based on the existing one, 
known as subclassing or extending a class. 
The subclass inherits all the properties and 
methods of the parent class, known as the 
superclass. For example, you could create a 
superclass called Parents, and a subclass 
called Children. Inheritance allows one class 
definition (subclass) to include all the func-
tionality of a different class definition (super-
class). You can also additional methods and 
properties to the subclass as well as override 
methods inherited from a superclass, which is

called polymorphism. Inheritance and sub-
classing are very useful for large projects 
where you can share similar functionality and 
reduce the amount of code. 

An object maintains its state using one or 
more variables. A variable is an item of data 
named by an identifier, and an object per-
forms its behavior with methods. Everything 
an object understands (its state) and what it 
can do (its behavior) is expressed by the vari-
ables and the methods within that object. 

An object that represents a speeding car 
would have variables that instruct the object 
as to speed, direction, and color. These vari-
ables are known as instance variables 
because they contain the state for a particular 
object, and in object-oriented terminology, a 
particular object is called an instance. In addi-
tion to its variables, the car would have meth-
ods assigned to change speed and turn on the 
lights. These methods are formally known as 
instance methods because they inspect or 
change the state of a particular instance.

Variables Methods

Using Object-Oriented Programming
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Flash Player, the plug-in you install in your Web browser to play back Flash SWF files, is the 
key to success in building fast applications. To compile and then run any ActionScript in your 
Flash movies the Flash Player uses a tool called the ActionScript Virtual Machine, or AVM. 
For ActionScript 1.0 and 2.0, the Flash Player uses AVM 1.0. Flash Player 9 introduced a new 
AVM, called AVM 2.0, that is dedicated to running just ActionScript 3.0 SWF files. To put it 
simply: AVM 2.0 rocks. It makes your code zip along.

AVM 2.0 is critical to Adobe’s future success with Flash. With AVM 2.0, you can build 
applications that have the speed and complexity of traditional desktop applications. 
Examples of this include Adobe’s WorkFlow Lab, a tool that allows you to develop complex 
Workflow solutions and competes directly with Microsoft’s desktop tool Visio; Adobe Story, a 
tool that allows you to script rich media and video productions; and Kuler, a sophisticated 
color management tool. Using these tools has the same feel and responsiveness as tradi-
tional desk top application. But they are not. They are all running in Flash.

Developing ActionScript 3.0 solutions that are targeted at the AVM 2.0 rendering engine 
ensures you’ll have highly optimized Flash solutions. While ActionScript 3.0 is not required 
for content that runs in Adobe Flash Player 9 or later, it allows performance improvements 
that are available only with the AVM 2.0. ActionScript 3.0 code can execute up to ten times 
faster than legacy ActionScript code.

Flash Player 9 supports AVM 1.0 for backward compatibility with existing and legacy con-
tent. Flash Player 7 and 8 only support AVM 1.0 and not AVM 2.0. However, there are a few 
things you need to know about compatibility. A SWF file cannot combine ActionScript 1.0 or
2.0 with ActionScript 3.0 code, and ActionScript code can load an SWF file with ActionScript
1.0 or 2.0, but it cannot access the file’s variables and functions (except you can use the 
loadMovieNum() command and pass a level parameter). If you have ActionScript 1.0 or 2.0 
code and want to use version 3.0 code, you need to migrate all the old code to version 3.0. 
If you want to use behaviors, you need to use ActionScript 2.0; behaviors are not available 
for ActionScript 3.0.

Virtual Machines and JavaScript
Web Browsers use virtual machines to run JavaScript. JavaScript is a kissing cousin to 
ActionScript. Both technologies are structured on the international ECMA-262 scripting for-
mat, or ECMAScript as it is often referred too. Web browsers such as Google’s Chrome, 
Apple’s Safari, Mozilla’s Firefox and Microsoft’s Internet Explorer all use Scripting JVM’s 
(JavaScript Virtual Machines) to render content. Many of these companies have even given 
their JVM engine’s cool code names, such as V8 for Chrome, SquirrelFish for Safari and 
TraceMonkey for FireFox. Unfortunately, Microsoft win’s the prize for least inspired name by 
calling their JVM just JS, for JavaScript. Of course, Adobe’s AVM 2.0 is a close second. Any 
chance of getting a cool code name for AVM 3.0, Adobe?

Enabling Flash to Execute Solutions Faster with AVM 2.0
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ActionScript 3.0 has undergone significant 
changes. This does not mean that if you have 
worked with Flash ActionScript 1.0 or 2.0 that 
you will be completely lost, but it will require 
that you learn new ways to use your code.

Understanding ActionScript 3.0
ActionScript 3.0 is a robust programming 
model (completely up-to-date with the latest 
release of the ECMAScript standard) familiar 
to developers with a basic knowledge of 
object-oriented programming. If you have 
developed for other programming languages, 
such as Java, C++ or C#, then you have heard 
of this term. Object-oriented programming 
allows you break your code into objects that 
can be easily re-used. With object-oriented 
programming, it’s easier to manage an appli-
cation that has a collection of smaller files 
than one large file. 

There are number of changes that will take 
a while to get used. The main changes are:

◆ ActionScript is located in Class files or in 
the Timeline.

◆ Code design is truly object oriented.

◆ You cannot add ActionScript directly to 
movie clips or buttons instances.

◆ Triggering events has changed.

◆ Loading data has changed.

◆ XML is managed differently.

Some other enhancements include more 
run-time exceptions for common error condi-
tions, added use of run-time type information, 
improved use of properties and classes with 
sealed classes, added use of method closures 
for event handling, added use of industry 
standard ECMAScript for XML, more support 
for regular expressions, and added primitive 
types (int and uint).

There are a score of smaller changes. As 
you dive directly into ActionScript 3.0 you will 
find a learning curve as you move from 
ActionScript 2.0. Is it all worthwhile to go 
through the pain? Absolutely. ActionScript 3.0 
is simply so much faster and more powerful 
that it is worth the undertaking. 

Working with ActionScript 3.0
There are two ways in which you can work 
with ActionScript. The first method is to add 
ActionScript to the Timeline. This will be famil-
iar to earlier Flash developers. A good prac-
tice to get into is to have a layer in that 
Timeline that is dedicated to just working with 
ActionScript. Adobe recommends that you 
label the ActionScript label “Actions.” Locking 
the “Actions” layer will prevent you from acci-
dentally adding movie clips into it.

The second method is to insert 
ActionScript into Flash files with a Class file. 
Class files have a long history in the develop-
ment world. With a Class file you can now 
specify both Public and Private Classes. Using 
the Private keyword restricts the use of the 
attribute defined in just that class and not 
shared with other classes. This is useful as 
you develop instruction that needs to be exe-
cuted privately in a closed environment.

Other major changes include:

◆ Developing Solutions Built with the 
DOM3 event model.

◆ Using Namespaces in your projects.

◆ Controlling Data.

◆ Controlling Text.

◆ Drawing with the Shape Class.

◆ Ability to easily work with external 
ActionScript Libraries.

Using ActionScript 3.0
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ActionScript 2.0 and 3.0 Similarities
With all of the changes between ActionScript
3.0 and 2.0 it’s important to remember that 
there is a lot of functionality that is the same 
between them. For instance you still use the 
following in the same way:

◆ Variables

◆ Math object

◆ If/Else Statements

◆ Switch Statements

◆ String

◆ Date to control the use of date and time

◆ Array to build a structured collection of 
data

◆ Boolean to specify a true or false

The following works in ActionScript 2.0 
and ActionScript 3.0:

var str:String = new String("Hello, ");

var str2:String = new String("World");

trace (str + str2);

You can see that the overall syntax struc-
ture is the same between both versions of 
ActionScript. You still end your code with 
curly brackets, your variable names are still 
case sensitive, your variable names cannot 
start with a number and you still use number 
class objects the same way. 

For specific details about using an 
ActionScript language, click the Help menu, 
click Flash Help, and then look in the 
Programming ActionScript 2.0 or 3.0 or the 
ActionScript 2.0 or 3.0 Language and 
Components Reference online chapter.

Extending ActionScript with Open 
Source Libraries
The core to ActionScript 3.0 is that it can be 
easily extended. To this end, you can use 
dozens of great Open Source Libraries that 
can be used to extend the functionality of 
Flash. Great examples are:

◆ Box2D Physics Engine
(http://box2dflash.sourceforge.net/).

◆ CoreLib
(http://code.google.com/p/as3corelib/) a 
collection of basic utilities such as MD5 
hashing, JSON serialization and 
advanced data parsing.

◆ Syndication Library
(http://code.google.com/p/as3syndication 
lib/) a library that allows you to parse all 
ATOM and RSS feeds easily.

◆ AlivePDF 
(http://www.fpdf.org/) a library that 
allows you to convert your Flash screen 
content to PDF.

These are some of the best Libraries you 
can use. Each comes with its own level of 
documentation.

Extending ActionScript with C/C++
ActionScript can be extended using C/C++. 
The Open Source project Brajeshwar.com 
(http://brajeshwar.com/2008/cc-to-action-
script-compiler/) is a project that allows you 
to take C++ programs and compile them to 
run in Flash. As an Example, they were able 
to take the C++ version of Quake, convert it 
and run it in Flash. That is darn impressive 
and could not be done with ActionScript 2.0. 
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To take advantage of the new powerful AVM 2.0 and ActionScript 3.0 
you must be publishing your Flash movies to target Flash Player 9 or 
later. Adobe has done a great job of ensuring that the latest release of 
the Flash Player is installed on your computer. For instance, with the 
release of Flash Player 9, Adobe installed a feature that automatically 
updates your Player on your PC, Mac users receive updates through the 
Mac OS update tool and—as part of Flash Player 10.1—will now receive 
automatic updates as soon as new releases are available. Flash Player
10.1 will help your Flash movies to play back more efficiently on Mac 
based computers, especially for mobile devices, such as an Android, 
Palm Pre or BlackBerry phones. Flash Player 10.1 dramatically optimized 
code for the Cocoa Framework, it uses Apple’s Core Animation to render 
animation). Mobile users simply have not been able to view Flash. Now 
they can. To change which Flash Player you are targeting you need to 
open the Publish Settings and modify the Flash Player settings.

Changing ActionScript
3.0 Settings

Change Publishing Setting for 
ActionScript 3.0

Click File, and then click Publish 
Settings.

The default settings on the 
Formats tab include Flash and 
HTML.

Click the Flash tab.

Click the Player list arrow, and 
then click Flash Player 9 or Flash 
Player 10.

Click the Script list arrow, and 
then click ActionScript 3.0.

Click the HTML tab.

To publish settings for a specific 
subversion (an update to a main 
release) of the selected Flash 
Player, select the Detect Flash 
Version check box, and then enter 
the Flash Player subversion you 
want. For example, 10.1.52. This 
uses SWObject2 for version 
detection and embedding SWF 
into Web pages. (New!)

Click OK.

You are ready to start developing a 
ActionScript 3.0 Flash movie that 
uses AVM 2.0.

7
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6

Change ActionScript 3.0 Settings

Click File, and then click 
ActionScript Settings.

To create a document class, enter 
the filename of the ActionScript 
file without the .as extension.

Specify the frame where the class 
definition resides. 

Specify any of the following 
options:

◆ Strict Mode. Select to to report 
compiler warnings as errors.

◆ Warnings Mode. Select to 
report warnings for issues 
when updating ActionScript 2.0 
to ActionScript 3.0.

◆ Automatically declare state 
instances. Select to 
automatically declare instances 
on the Stage.

◆ Dialect. Select ECMAScript or 
ActionScript 3.0 
(Recommended).

Click any of the following tabs:

◆ Source path. Specify the 
location of the external 
ActionScript files that contain 
the class definition. 

◆ Library path. Specify the 
location of pre-compiled 
ActionScript code, which 
resides in the SWC files.

◆ Config constants. Specify any 
configuration constants for use 
with conditional compilation.

Click OK.6
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See Also
See “Creating a New Document” on 
page 12 for more information on creat-
ing an ActionScript 3.0 FLA document.
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Code hints makes it easy to insert and edit code accurately. With Code 
hints, you don’t have to remember all of the objects, methods, and prop-
erties used in ActionScript. As you enter to type code, you can display 
the Code Hints popup menu to help you enter it correctly (New!). Code 
hints can appear after the dot (.) following a statement or command, 
where a property or method needs to appear next, or between paren-
theses [()] in a method name. The Code Hints popup menu displays 
appropriate code options based on the currently entered code. When 
you enter code that refers to a custom ActionScript 3.0 class, you can 
also display the Code Hints popup menu to help you access the appro-
priate code options (New!). When you use a custom class in a script, 
Flash automatically imports the related code for its use. Code hinting 
also works for nested class references, and all classes included in a 
SWC file.

Inserting Code with 
Code Hints

Use Code Hints

Create or open a Flash document. 

Open the Actions panel or Script 
window. 

Place the insertion point where 
you want to add code.

Start to type the code you want, 
and then press Control+Spacebar 
(Win) or A+Spacebar (Mac) or 
click the Show Code Hint button 
on the toolbar to manually display 
the code hints popup menu.

Scroll through the list by using the 
scroll bar or pressing the Up 
Arrow and Down Arrow keys.

To insert a code hint, double-click 
an item, or select it and then press 
Enter (Win) or Return (Mac).

◆ Press Esc to dismiss the list of 
code hints. 

6
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See Also
See “Setting ActionScript 
Preferences” on page 349 for 
information on enabling code hinting.
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Use Code Hints for Custom 
Classes

Create or open a Flash or class 
document (ActionScript 3.0).

◆ Store the custom classes in the 
same folder as the document.

Open the Actions panel or Script 
window. 

Place the insertion point where 
you want to add code.

Start to type the code you want, 
and then press Control+Spacebar 
(Win) or A+Spacebar (Mac) or 
click the Show Code Hint button 
on the toolbar to manually display 
the code hints popup menu.

Scroll through the list by using the 
scroll bar or pressing the Up 
Arrow and Down Arrow keys.

To insert a code hint, double-click 
an item, or select it and then press 
Enter (Win) or Return (Mac).

◆ Press Esc to dismiss the list of 
code hints. 

6
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Did You Know?
You can reload code hints without 
restarting Flash. Open the Actions 
panel, click the Options menu, and then 
click Reload Code Hints.

You can save time with Auto close-
bracket insertion. When you type an 
open bracket { in the Actions panel or 
Script window, Flash automatically 
adds the corresponding close 
bracket }. (New!)

Properties Options

Type this Code hints for that same class

Type new+<space> Displays a list of available classes and 
packages

Type import+<space> Displays a list of all the built-in packages 
and custom packages

Code Hinting for Custom Classes

2 4 3
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As you build Flash documents for ActionScript 3.0, it's almost a certainty 
that you will use elements over and over again. Flash created a solution 
that makes it easier to reuse elements called Code Snippets (New!). 
Snippets offer a simple and convenient method of creating reusable 
code, which especially helpful for those transitioning from ActionScript
2.0 to ActionScript 3.0. They are composed of bits of code and/or content 
along with comments for usage that you can save, edit, use, and reuse 
as often as you want. You can use a pre-defined code snippet supplied 
by Flash or create your own in the Code Snippets panel (New!).

Inserting and Creating 
Code Snippets

Insert a Code Snippet

Select the object or Timeline frame 
in the Flash document where you 
want to insert/apply the code 
snippet.

Open the Code Snippets panel.

Click the arrow icon next to the 
folder (Actions, Timeline 
Navigation, Animation, Load and 
Unload, Audio and Video and Event 
Handlers) to display the snippet 
you want to insert.

Select the snippet you want to 
insert.

Click the Add to current frame 
button in the Code Snippets panel.

TIMESAVER You can also drag 
a snippet from the Code Snippets 
panel directly onto an element, or 
double-click the code snippet in 
the Code Snippets panel. In the 
Actions panel, you can click the 
Code Snippets button.

Click Yes to convert your selection 
to a movie clip, if necessary.

A new ActionScript is added to a 
new layer, labeled Actions, in the 
Timeline.
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Click to Play/Stop 
Sound snippet code

New layer with ActionScript
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Create a Code Snippet

Open the Code Snippets panel.

Click the Options button in the 
Code Snippets panel, and then 
click Create New Code Snippet.

Type a title and tooltip.

Type the code you want to use in 
the Code box or click Auto-fill to 
insert the code selected in the 
Actions panel.

Select or clear the Automatically 
replace instance_name_here 
when applying code snippet 
check box.

Click OK.6
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Did You Know?
You can edit an existing code snippet.
In the Code Snippets panel, select the 
snippet you want to edit, click the 
Options button, click Edit Code 
Snippets XML, make the changes you 
want, click the File menu, click Save, 
and then click the Close button in the 
Code Snippets tab. 

You can copy a code snippet to the 
clipboard. In the Code Snippets panel, 
select the snippet you want to copy, 
click the Copy to Clipboard button, and 
then click OK, if necessary. Now, you 
can paste it into the Actions panel or 
ActionScript file. Importing and Exporting Code Snippets

If you want to share code snippets with others, you can import or 
export one or more from the Code Snippets panel. To import a code 
snippet, click the Options button in the Code Snippets panel, click 
Import Code Snippets XML, select the XML file, and then click Open. 
To export a code snippet, select the snippet you want to export in the 
Code Snippets panel, click the Options button, click Export Code 
Snippets XML, type a name, specify a location, and then click Save.

For Your Information

1 2
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ActionScript 3.0 now supports the 
ECMAScript, DOM3, event model syntax. In 
laymen’s terms, this means that you now use 
the Listener object to detect when you inter-
act with your Flash movie using either a key-
board, mouse, or the new gesture interfaces 
used in touching the screen directly.

This is a big move from ActionScript 2.0. As 
an example, the following script is 
ActionScript 2.0 that instructs a Movie Clip to 
jump to frame 25 of a movie:

ActionScript 3.0 uses Listeners to trigger 
when an event occurs. Listeners are more 
complex to work with, but, give you more 
flexibility. There are essentially two parts to a 
Listener. The first is a function that describes 
what is going to happen when you trigger an 
event. The second is the Listener that waits for 
a specified event to happen, such as mouse 
clicking on a button.

The following steps adds an ActionScript 3.0 
event that mimics the same event as the 
ActionScript 2.0 example above.

Use ActionScript 3.0
Click the File menu, click New, click 
ActionScript 3.0, and then click OK.

Create a new Movie clip on the Stage 
with the name myMovie.

2

1

Create a new layer in the Timeline with 
the name Actions, and then select the 
layer.

Open the Actions panel, create the 
function, and then add the listener that 
triggers the function.

The function is called gotoFunction and 
the parenthesis dictates that it is looking 
for a mouse driven event. There is only 
one instruction in the function, the 
gotoAndStop function that moves the 
Timeline to frame 25. 

The first part of the Listener, myMovie, 
instructs ActionScript to target the movie 
clip object on the Stage. The second part 
of the Listener, addEventListener, 
instructs Flash that you are using the 
Listener object.The parenthesis has two 
parts that explain that the event is a 
mouse event and to use the function 
gotoFunction.

The ActionScript 3.0 event model gives you 
flexibility to write more complex scripts and 
to extend the functionality of the event model 
beyond traditional mouse and keyboard inter-
faces. To do this you use the core object class 
controlling events on the screen called the 
EventsDispatcher class. Through this you can 
not only leverage standard events such as 
mouse clicks and the keyboard, but you can 
extend the class with your event types. 

4

3

Developing Solutions Built with the DOM3 Event Model 
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A common design pattern in Object Oriented 
programs separates design, programming 
and data elements. Flash CS5 adds this func-
tionality with the inclusion of Classes. A Class 
is a packaged document that you can use to 
explain how UI components, business logic 
and data elements are to interact. 

A Class is a separate ActionScript file that 
is associated with the main Flash file and 
movie clips. You can use Flash CS5 as the 
Class file editor or your favorite text editor 
such as Eclipse, Notepad or Textedit. A Class 
file is only a text file. It is very easy to create 
entire Flash movies using just Class files and 
not even add any content into a traditional 
timeline.

Create a Simple Class File
Click the File menu, click New, click 
ActionScript 3.0, and then click OK.

Click the File menu, and then click Save
to save the file with the name 
helloWorld.fla.

Open the Properties panel.

Click the Edit Class Definition button 
(pencil icon) in the Property inspector, 
enter a new class with the name 
helloClass, and then click OK.

A new ActionScript file named 
helloClass.as opens with the following 
ActionScript 3.0 script. 

4

3

2

1

Remove the line that says //constructor 
code and replace it with:

trace (“Hello, World”);

Click the File menu, and then click Save
to save the Class file.

In the Flash document, click the Control
menu, point to Test Movie, and then click 
Test to view the results. 

The words “Hello, World” posted to the 
Output panel.

Classes provide you a way in which you 
can create public and private class elements. 
The difference between the two is related to 
how you use the data. For instance, a public 
property can be shared throughout your 
whole Flash movie. A private property can 
only be used within the class it is defined in.

Add Classes to Movie Clips
You can also add separate class references 
directly to Movie Clips in your Library. 

Open the Library panel.

Right-click (Win) or Control-click (Mac) a 
Movie Clip, and then click Properties.

In the Properties dialog box, click 
Advanced if necessary, and then select 
the Export For ActionScript check box.

Click OK.

A class is automatically created for the sym-
bol using the name of the Movie Clip. You 
can now modify the Class file for the Movie 
Clip in your favorite text editor. 

4
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Working with Classes 
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With ActionScript 3.0, you specify a class definition, either document or 
object level, to work with objects using ActionScript code. To create 
your own class, you need to follow a certain syntax. First, you enter a 
package statement to indicate where your class will be found. Then, 
you enter a class statement to define the name of the class. At this 
point, you define each property in the class by using variables, and 
each method by using functions. When you define a class element, 
such as a property or method, you can also specify an attribute. A pri-
vate attribute can be called only by code within the class, while a pub-
lic attribute can be called by any code in the program. After you define 
a class, you can define a subclass that inherits all the properties and 
methods of the parent class, or superclass. In the subclass, you can 
add methods and properties and override others from the superclass, 
known as polymorphism. If you want to trigger actions based on 
events, you can use the EventDispatcher class to keep track of event 
listeners and notify them of events.

Working with Objects 
and Classes

Work with Objects and Classes 
in ActionScript

Create or open a Flash document 
(ActionScript 3.0).

Open the Properties panel.

Click the Stage.

In the Class field, type the name of 
the ActionScript file to create a 
document class definition.

IMPORTANT Be sure not to 
include the .as extension.

Open the Library panel.

Right-click (Win) or A-click 
(Mac) the object you want to 
control in ActionScript, and then 
click Properties.

Click Advanced, if available. 
(Button name changes to Basic.)

Enter a name for the object.

Select the Export for ActionScript 
check box.

The Class appears with the same 
name as the object, and the Base 
class appears with object type.

9
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Class definitions
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Click OK.

If prompted, click OK to define the 
new class.

Click the File menu, and then click 
Save.

Click the File menu, and then click 
New.

Click ActionScript File.

Click OK.

Click the File menu, and then click 
Save As.

Navigate to the folder with the 
Flash document, and then name 
the file (same as the one in 
Step 4).

Click Save.

In the Actions panel, enter the 
script as shown in the illustration.

IMPORTANT ActionScript 3.0 is 
case-sensitive, so upper- and 
lower-case make a difference.

Click the File menu, click Save, 
and then close the ActionScript 
file.

Click the Control menu, point to 
Test Movie, and then click Test.

21
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Common Syntax in ActionScript 3.0

Command Description

Dot syntax Access the properties and methods of an object. 
myDotEx.method ();

Slash syntax Not supported in ActionScript 3.0.

Literals A value that appears directly in your code. 
“text”, true, false, 10

Semicolon (;) Terminates (ends) a statement. var a:int = 2;

Parentheses Indicates order of operation, evaluates a series of 
expressions, or pass parameters.

Comments Documents code. Single-line comments begin with //, 
while multi-line comment begin with /* and ends with */.

Keywords Reserved words you cannot use as identifiers. as, class, 
const, if, var, true, in

Constants A fixed value. const MINIMUM:int = 0; ActionScript 
defines constants with all CAPS with words separated 
by an underscore. const MOUSE_DOWN:String 
= “mouseDown”;

1

Public attribute

Function

ActionScript file

Change property

Variable

Package 
statement

Class 
statement

Did You Know?
You can define accessor methods. For 
advanced ActionScripting, you can 
also define accessors methods, which 
are a cross between a method and 
property (defined like a method, yet 
creates an instance like a property). 
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Namespaces are ways in which you can 
define the visibility of properties you are cre-
ating. This is commonly used in XML when 
you are importing documents using a URI 
indicator. 

You can also use the NameSpace as a way 
to overload your objects. The principle in 
overloading is to create several methods that 
have the same name but differ in the types of 
input and output they generate.

The following example is built using a 
Class called NamespaceExample. The role of 
this class is to pull in an XML document and 
step through the formatting of the code. 
Using Namespaces you can instruct Flash 
where to find a definition of the document 
type you are using, in this case an RSS for-
matted document type.

Click the File menu, click New, click 
ActionScript 3.0, and then click OK.

Open the Properties panel.

Click the Edit Class Definition button 
(small pencil icon) in the Properties 
inspector, enter a new class with the 
name NamespacesExample, and then 
click OK.

A new ActionScript file named 
NamespacesExample.as opens.

Create a simple RSS formatted XML 
document. You can use the following 
formatted RSS document:

<rdf:RDF

xmlns:rdf="http://www.w3.org/1999/02/22-
rdf-syntax-ns#"

xmlns="http://purl.org/rss/1.0/"

xmlns:dc="http://purl.org/dc/elements/1.1/" 
>

4
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<channelrdf:about="http://www.xml.com/cs/ 
xml/query/q/19">

<title>This is an RSS feed</title>

<link>http://www.bbc.co.uk/</link>

<description>This is a test RSS 
document.</description>

<language>en-us</language>

<items>

<rdf:Seq>

<rdf:li 
rdf:resource="http://www.bbc.co.uk/"/>

</rdf:Seq>

</items>

</channel>

<item rdf:about="http://news.bbc.co.uk/">

<title>BBC News Center</title>

<link>http://news.bbc.co.uk</link>

<description>Welcome to the BBC News 
Center</description>

<dc:creator>BBC</dc:creator>

<dc:date>2010-02-12</dc:date>    

</item>

<item 
rdf:about="http://www.bbc.co.uk/radio">

<title>BBC Radio Center</title>

<link>http://www.bbc.co.uk/radio</link>

<description>Welcome to the BBC Radio 
Center</description>

<dc:creator>BBC</dc:creator>

<dc:date>2010-02-12</dc:date>       

</item> </rdf:RDF>

Using Namespaces in your Projects
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Open the NamespacesExample Class, 
and then define the package with a 
public class named NamespacesExample 
that will extend the functionality of the 
Sprite object.

package 

{

import flash.display.Sprite;

public class NamespaceExample extends 
Sprite

Insert the Namespace reference that 
describes how to use RSS XML.

{

private var rss:Namespace = new 
Namespace("http://purl.org/rss/1.0/");

private var rdf:Namespace = new 
Namespace("http://www.w3.org/1999/02/22-
rdf-syntax-ns#");

private var dc:Namespace = new 
Namespace("http://purl.org/dc/elements/1.1/ 
");

public function NamespaceExample()

RSS has several standard XML types. 
You are going to extract the following: 
title, creator, date, link and description. 
Each of these items will be formatted in 
accordance to the namespace called 
RSS. You will see in the third line of the 
ActionScript that you reference the RSS 
namespace.

private function parseRSS(rssXML:XML):Array

{

default xml namespace = rss;

var items:XMLList = rssXML.item;

var arr:Array = new Array();

var len:uint = items.length();

7

6

5 for (var i:uint; i < len; i++)

{

arr.push({title:items[i].title, 
creator:items[i].dc::creator, 
date:items[i].dc::date, link:items[i].link, 
description:items[i].description});

}

return arr;

}

Add a Public function that will use the 
RSS namespace and send the content to 
the Output panel:

public function NamespaceExample()

{

var myXML:XML = getRSS();

var rssItems:Array = 
parseRSS(myXML);

var len:uint = rssItems.length;

for (var i:uint; i < len; i++)

{

trace(rssItems[i].title); 
trace(rssItems[i].creator);

trace(rssItems[i].date);

trace(rssItems[i].link);

trace(rssItems[i].description);

}

}

Click the Control menu, point to Test
Movie, and then click Test to see the RSS 
feed results sent to your Output panel. 

Namespaces are an effective way to man-
age your control over XML data. As with all 
core classes in Flash, you can extend the 
Namespace to use it in conjunction with other 
objects and data types.

9
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There are several key ways to control data in 
ActionScript 3.0. They include Arrays, Shared 
Objects and XML. An Array is the first method 
you are likely to use in your ActionScript 
code. The role of an Array is to create a list of 
data types in your code. For example, you 
may want to list the colors red, green, blue 
and orange. To do this you need to define a 
new variable with the data type of Array:

var colorArray:Array = new Array("red", "green", 
"blue", "orange");

You can see in this script that a set of four 
items have been inserted into the Array. You 
can access the data in the Array with the fol-
lowing trace statement:

trace (colorArray);

The “push” property will allow you to add a 
new item into your array:

colorArray.push("purple");

To remove the last item of an Array you can 
use the Pop property.

colorArray.pop();

What you will find is that Arrays are great 
for manage simple lists. Additional properties 
allow you to remove specific values, to count 
the number of values you have and to sort 
your lists. For more complex data you will 
want to leverage the Local Data Storage or 
XML.

When you are counting the number of 
values in an Array you have to remember 
that Arrays always start with 0. For instance, 
if you have five items in an array and tell the 
array to pull item 1, it will pull the second 
item. This is because the first item has the 
registered value of 0.

If you are developing an AIR solution you 
can take advantage of the SQL database built 
right into AIR. The SQL database comes with 
support for the creation of tables, stored pro-
cedures and SQL statements.

Using Flash Cookies
The Flash Player can also store data locally in 
very much the same way that a cookie can be 
stored in a Web browser. Flash does not call 
this cookies but Shared Objects. An example 
of Share Object ActionScript 3.0 is:

var mySO:SharedObject = 
SharedObject.getLocal("myFlashCookie"); 

mySO.data.now = new Date().time; 

trace(mySO.data.now);

The Share Object is declared and given a 
name where it will be stored on the local 
computer. You can now effectively target data 
to this space that can be accessed if this com-
puter comes back to this page at a later date.  

Controlling Data
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Manipulating XML with E4X

Flash has supported XML in one fashion or 
another since Flash 5. Have you worked with 
XML in ActionScript 2.0? It’s not pretty. To our 
relief, ActionScript 3.0 now supports the 
ECMA XML standard called E4X. You can now 
more easily step through your XML docu-
ments. You can also change the value of items 
into an XML document. What this means is 
that you can load an XML document and then 
modify the content. For instance, you can 
change Yellow to Blue.

Import an XML Document as a Data Type
Before you can import an XML 
document, you need to create one. You 
can use the following code and save it as 
an XML document with the name 
colors.xml.

<?xml version="1.0"  encoding="UTF-8"?>

<pallette>

<color>Orange</color>

<color>Red</color>

<color>Yellow</color>

</pallette>

Click the File menu, click New, click 
ActionScript 3.0, and then click OK.

Click the File menu, and then click Save
to save the FLA file to the same folder as 
the XML document.

The first step is to create a new object to 
manage the XML:

var myXml:XML;

The next step is to create a new 
URLLoader file that will load the XML 
file:

var xmlLoader = new URLLoader();
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xmlLoader.addEventListener 
(Event.COMPLETE,onXMLLoaded);

xmlLoader.load 
(new  URLRequest("colors.xml"));

At this point you have loaded the XML 
successfully into Flash. You can test this 
by adding the following function to trace 
the contents of the XML document into 
your OutPut window.

function onXMLLoaded(e:Event):void{

myXml =  new XML(e.target.data);

trace(myXml);

}

You can now easily pull out a specific 
value. For instance, add the following to 
the onXMLLoaded function to extract the 
third value in the XML file:

trace(myXml..color[2]);

The double dots after the variable myXML 
allows you to step to the second value of your 
XML document. All of this is so much easier 
to accomplish with E4X than with 
ActionScript 2.0.

7
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Patterns are everywhere as you develop your 
code. This is clearly seen with the use of 
Regular Expressions, a method for describing 
the pattern of data you are looking to use. 
Using Regular Expressions you can now eas-
ily format form fields to correctly capture 
date, ZIP or Credit Card numbers.

To validate data meets a simple pattern you 
need to create a string variable:

var myColor = "Orange";

Now create a new regular expression that is 
looking for a simple pattern. In this instance, 
the pattern is that the myColor string value 
must start with an “O”.

var colorRegExp:RegExp = /O/;

You can write a trace script to test your 
movie:

trace( colorRegExp.test( myColor ) );

The value in the Output panel is True.

Let’s extend what you can do with Regular 
Expressions by adding a pattern that looks for 
an email address. Start by adding a new 
email string with a valid email address:

var email:String = "mdavid@matthewdavid.ws";

Next, create a new Regular Expression that is 
looking for a pattern structure in your email:

var emailRegExp:RegExp = /^([a-zA-Z0-9_-]+)@([a-
zA-Z0-9.-]+)\.([a-zA-Z]{2,4})$/i;

The pattern is looking for a combination of 
alpha-numerical-special character formats 
separated by an “@” sign and suffix “.” Add 
the following trace statement to see whether 
or not the pattern works:

trace( "Is this email valid? " + emailRegExp.test( 
email ) )

Test the movie to view the following response 
in the Output panel:

Is this email valid? True

Change the email address to just “Matthew 
David” a pattern that does not match the 
Regular Expression. When you test the movie 
you will see that the Regular Expression 
returns a false response. 

You can also get great information on how to 
structure regular expressions at: 
http://www.regular-expressions.info.

Using Regular Expressions
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Controlling Text

In many ways you do not need to work on the 
Stage at all when using ActionScript 3.0. All 
visual objects can be programmatically cre-
ated. The easiest way to see this is in using 
the Text object to create dynamic text fields on 
the Stage.

Create a Dynamic Text Field
Click the File menu, click New, click 
ActionScript 3.0, and then click OK.

Open the Properties panel.

Click the Edit Class Definition button 
(small pencil icon) in the Properties 
inspector, enter a new class with the 
name text, and then click OK.

A new ActionScript file named text.as 
opens.

Add the libraries to be imported into 
your file:

import flash.display.Sprite;

import flash.text.TextField;

import flash.text.TextFieldAutoSize;

import flash.text.TextFormat;

Insert a private variable that will be used 
to define the dynamic text:

private var myTextField:TextField;

The following creates a basic string you 
can insert into your texftfield:

private var someText:String = "Hello world.";

A private function is used to define the 
physical position of the textfield on the 
screen.

Declare the text field as a new object, 
and then use the X and Y properties to 
place the text on the screen:

7
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private function configuretext():void

{

myTextField = new TextField();

myTextField.y = 200;

myTextField.x = 100;

A textFormat object is used to format the 
visual properties of the text. For instance, 
the following textFormat object sets the 
font to “_sans”, the color black and font 
size 15:

var format:TextFormat = new TextFormat();

format.font = "_sans";

format.color = 0x000000;

format.size = 15;

myTextField.defaultTextFormat = format;

addChild(myTextField);

The final two public functions tie the text 
string to the new formatted text field:

public function text()

{

configuretext();

setValueOfTextField(someText); 
}

public function setValueOfTextField 
(str:String):void

{

myTextField.text = str;

}

Click the Control menu, point to Test
Movie, and then click Test to display a 
text string added to your screen.

Creating a dynamic text field on the Stage 
with ActionScript allows you more control 
over the text on the Stage than using tradi-
tional methods.

10

9
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As with the text object, you can create images 
dynamically in ActionScript 3.0. There are sev-
eral different types of image you can create 
that include traditional Movie Clips and 
Graphics. You can now also create a new type 
of image called a Sprite. Essentially, a Sprite 
is the same as a Movie Clip with the excep-
tion that it does not contain timeline function-
ality. Sprite’s can be created by invoking the 
new Sprite Object Class and then adding 
properties to the object. 

Add a Square Shaped Sprite to the Stage
Add the following ActionScript to create 
a new Sprite with the name 
myFirstSprite.

var myFirstSprite:Sprite = new Sprite();

addChild(myFirstSprite);

1

The following ActionScript formats the 
size, fill/outline color, and position of the 
Sprite:

myFirstSprite.graphics.lineStyle(3,0xFF6600);

myFirstSprite.graphics.beginFill(0xFF0000);

myFirstSprite.graphics.drawRect(0,0,100,100);

myFirstSprite.graphics.endFill();

Click the Control menu, point to Test
Movie, and then click Test to view the 
rectangle on the screen.

The following ActionScript applies a fade 
in transition effect to your new Sprite.

myFirstSprite.addEventListener 
(Event.ENTER_FRAME, fadeInSprite);

myFirstSprite.alpha = 0;

function fadeInSprite(event:Event)

{

myFirstSprite.alpha += 0.01;

if(myFirstSprite.alpha >= 1)

{ 
myFirstSprite.removeEventListener 
(Event.ENTER_FRAME, fadeInSprite);

}

}

You can do a lot with ActionScript constructed 
images. Working with the all the different 
objects available to you in ActionScript 3.0 
you have almost no limits to what you can 
create using Flash.

4

3

2

Drawing with the Shape Class
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Developing iPhone Apps

Introduction

Apple has this device called an iPhone. Have your heard of 
it? Of course you have. There is even a good chance you have 
an iPhone. While the iPhone itself is an amazing piece of 
technology, it is the software that makes the iPhone really 
great.

The challenge in developing applications for the iPhone is 
that you need to know how to develop using Apple’s Cocoa 
Touch framework and the programming language Objective
C.  One of the most interesting and talked about features in 
Flash CS5 is Adobe’s inclusion of a tool that converts your 
Flash movies to files that will run on any iPhone OS device 
without needing to know Objective C. You just need to apply 
the Flash and ActionScript knowledge you already have. A 
new tool in Flash CS5, called the iPhone Packager, converts 
files into valid iPhone applications.

Before you can create an iPhone App there are several 
activities you need to complete so you can develop in Flash 
CS5. They are (1) Become a Certified Apple Developer, (2) 
Create a Development and Developer P12 certificate, and (3) 
Register your development iPhone with Apple. 

In this chapter, you’ll get an overview for how to start 
developing for the iPhone using Flash CS5 including deploy-
ing an App to the iTunes App Store. 16

16
What You’ll Do

Become an Apple Certified Developer

Register an iPhone and other Apple 
Testing Devices 

Create App’s ID

Create a Developer’s Provisioning 
Profiles

Create and Publish an iPhone App

Control the Accelerometer

Save Images to the Camera Roll

Understand the Limitations of Flash

Identify Devices to Deploy an Ad 
Hoc App

Create an Ad Hoc Distribution Profile

Package an Ad Hoc App

Use iTunes Connect to Publish an App

Use Screen Orientation in an App

Use Geolocation in an App

Use Multitouch in an App

385
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Becoming an Apple
Certified Developer

Become an Apple Certified 
Developer

Open your Web browser on the 
Mac, and then go to the iPhone 
Dev Center site: 

◆ http://developer.apple.com 
/iphone

IMPORTANT Use a Mac for 
these steps. later work can be 
done on a Windows computer.

Click the Register link on the Web 
page.

Follow the registration process; 
either use an existing iTunes 
Account or create a new account 
to register with the site.

◆ Upon completion, you’ll receive 
an email confirmation.

Go to http://developer.apple.com 
/iphone/manage/certificates to 
download and install your Apple 
iPhone Development Certificate.

Open the Keychain to view your 
Apple iPhone Development 
Certificates: a Developer and a 
Distribution Certificate.

5
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2
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The iPhone OS has rapidly become the mobile operating systems 
against which all other mobile systems, such as Android, Windows 
Mobile 7, BlackBerry, WebOS and Symbian, are all compared to. There 
is a very good reason for this: the iPhone OS is rock solid. Each App 
you develop for the iPhone OS will run on an ever increasing number of 
products shipping from Apple. They include the iPhone 3G and 3GS, 
iPod Touch and the iPad. All of your Flash CS5 applications (New!) will 
run on these devices. To be able to develop applications for the iPhone 
you do need to become a registered Apple developer. The cost is only 
$99 a year and this gives you the ability to load applications up to the 
iTunes App Store. Yes, you heard me right; it only costs $99 a year to 
load as many apps as you can develop into the iTunes App Store. This 
is an amazing deal. Similar programs run by Nintendo to develop apps 
for their Wii Wares store start in the low thousands of dollars.

2

5
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Control-click on the Developer 
Certificate, and then click Export 
Certificate.

Navigate to the location where 
you want to save the certificate.

Click the File Format list arrow, 
and then click Personal 
Information Exchange (.p12).

Click Save.

Enter a strong password for your 
App, and then remember it as 
you’ll need it later. 

Repeat Steps 6-10 to export the 
Distribution Certificate in the 
Personal Information Exchange 
(.p12) format.

11

10

9

8

7

6

Did You Know?
You can use the P12 Certificates on 
Windows. You can copy the P12 
Developer and Distribution Certificates 
to a disc and use them on a Windows 
computer. Creating the P12 Personal 
Information Exchange Certificates can 
be done on a Windows computer, but it 
requires the use of third party software 
such as OpenSLL. It is not easy. You 
are much better off starting with a Mac 
(find a friend, if you need to) and then 
moving to a Windows computer for 
your future Flash CS5 iPhone develop-
ment needs. 

Developing Apps on Macs and Windows

Amazingly, Adobe is the only company that allows you to develop 
iPhone Apps on Windows. All you need to accomplish this is to use a 
P12 Developer and Publishing certificate. The easiest way to get a 
P12 certificate is from a Mac computer. Just ask a friend if you can 
create an account on their Mac and then register yourself with 
Apple’s Development program and create your own P12. After that 
you can copy the P12 certificate onto your Windows machine and 
develop the iPhone Apps.

For Your Information

6
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The hardest part of developing apps for the iPhone is not the code you 
develop, but ensuring you have all of your i’s and t’s dotted and crossed 
per Apple’s rigorous registration process. One small step in the wrong 
direction and your App will not compile or install correctly. It is worth 
taking your time to go through the setup process (New!). After you 
have your P12 Certificates you will need to register your test iPhone 
with Apple. You can register up to 100 devices per year. The developer 
account ID, registered device and P12 certificates are needed for all 
apps your want to sell in the iTunes App Store. You can register 
iPhone’s, iPod Touches and iPads. 

Registering an iPhone 
and Other Apple 
Testing Devices

Find your iPhone’s Unique 
Identifier

Connect your test iPhone/iPod 
Touch to your computer.

Open iTunes, and then select your 
device from the list to view the 
Summary tab information.

Click the Serial Number next to 
your device. 

The number changes to an 
Identifier (UDID) number, which 
is. about 40 alpha-numeric 
characters long.

Copy the UDID number.

Open your Web browser, and then 
go to the Devices page on the 
iPhone Developer site:

◆ http://developer.apple.com 
/iphone/manage/devices 
/index.action

Click the Add Devices button.

Paste in the UDID number and 
then enter a name for your device. 

◆ Suggestion: you may want to 
choose something like “iPhone 
Development” or “iPod Touch 
Gen 3 Development.”

7
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The App ID is a unique identifier Apple uses to identify your App from 
the tens of thousands of Apps in the iTunes App Store. There are ten’s of 
thousands of applications in the iTunes App Store with more in constant 
development. Part of your registration process is to assign your App an 
ID, called the App ID. The App ID (New!) will be connected to your cer-
tificate and to the development and publication profiles you generate. 
You control the name of the App, but behind the scenes, Apple associ-
ates it an unique ID, called a Bundle Seed ID. Apple will know what your 
App is when it comes time for you to submit your App to iTunes. 

Creating App ID’s

Create an App ID

Open your Web browser, and then 
go to the App ID page on the 
iPhone Developer site: 

◆ http://developer.apple.com 
/iphone/manage/bundles 
/index.action

Click the New App ID button.

Enter a new App name you can 
find easily, such as 
WorldlyWordSearch; the name has 
to be all one word.

Enter a Bundle Seed ID. 

◆ The convention is to reverse 
your Web site address and add 
your Apps name at the end. 
For example, com.pearson. 
worldlywordsearch; the name 
has to be all one word.

Click OK.5

4
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A provision profile is a document which is associated with your App 
and developer certificate for either development or iTunes App distribu-
tion. There are three types of Provisioning Profiles (New!) you can use: 
Developer, Distribution to Ad Hoc and Distribution to iTunes App Store. 
You will cover how to use the Distribution Profiles later in the chapter. 
For now, let’s focus on creating Developer Profiles.

Creating a Developers 
Provisioning Profiles

Create a Developer Profile

Open your Web browser, and then 
go to the Provisioning Profiles 
page on the iPhone Developer site: 

◆ http://developer.apple.com 
/iphone/manage/provisioningpr 
ofiles/index.action

Click the Development tab.

Click the New Profile button.

Enter a meaningful Profile name. 

A convention that is gaining 
popularity is to use the prefix 
“Dev” followed by the App ID, 
such as DevWorldlyWordSearch.

Select the check box with your 
name in the Certificates list.

Click the App ID list arrow, and 
then select your App ID.

Select your test device from the 
devices listed.

Click the Submit button.

Your developer profile takes about 
30 seconds to generate. 
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Click Download (Mac) or Save 
(Win), and then save the 
Developer profile to your desktop. 

The file will have the extension 
“mobileprovision”

Connect your test iPhone to 
iTunes.

Drag the downloaded Developer 
Profile onto iTunes, and then sync 
your iPhone. 

This adds the Developer Profile to 
your testing device.

11

10

9

Developing Icons for your iPhone Apps

In preparation for your iPhone App there are four PNG images you 
need:

29.png – a file that is 29x29 pixels

57.png – a file that is 57x57 pixels

512.png – a file that is 512x512 pixels

Default.png – this place holder file that is used while your App 
is loading. It is important the file starts with a capital “D”.

You can create all of these files using Adobe Fireworks.

For Your Information

9
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With all of these tasks completed you are now ready to complete your 
first iPhone App. Sometimes it seems like a world full of red tape where 
you need to dot your i’s and cross your t’s, but you do get to the point 
where you can develop applications for your iPhone using Flash CS5 
(New!). You need to go through the steps of creating a Developer 
Certificate, registering your test iPhone, creating an App ID, and down-
loading a developers profile in order to develop for any iPhone develop-
ment tool; this is not just a unique Flash CS5 feature. Flash CS5, 
however, does allow you to very easily create the final iPhone App. 

Creating and 
Publishing an 
iPhone App

Create and Publish an 
iPhone App

In Flash, click the File menu, click 
New, click iPhone OS, and then 
click OK.

A new movie opens with the size 
320x480 pixels.

Create an iPhone App using Flash 
tools.

Open the Properties panel.

Click the iPhone Settings Edit 
button.

The iPhone Settings dialog box 
opens, displaying three tabs: 
General, Deployment and Icons. 

Click the General Tab.

Enter an Output file name, such as 
wordsearch.ipa.

Enter the App Name that you want 
to appear on the iPhone, such as 
Word Search. You are limited to 11 
characters.

Enter an version number for the 
App, such as 1.0.

Click the Aspect Ratio list arrow, 
and then select a display option: 
Portrait or Landscape view. 

Select or deselect any of the 
following options: 

◆ Full Screen. Select to force 
your App to take up all of the 
screen space on your phone; 
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deselect to show information at 
the top of your iPhone, 
including carrier signal, WiFi 
connection, time and battery 
life, will be visible in your App.

◆ Auto Orientation. Select to 
change the orientation of your 
App as the iPhone is rotated.

Click the Rendering list arrow, and 
then click an acceleration option, 
Auto, CPU, or GPU.

Click the Add button (+) in 
Included Files, and then select the 
Default.png file. The Default.png 
file displays when your App starts 
to run and disappears when your 
App has loaded.

Click the Deployment tab.

Click Browse, and then select your 
Developer P12 certificate file, and 
then enter your password.

Click Browse, and then select the 
developer Provisioning Profile you 
downloaded.

Enter the full name of the App ID 
you created in the iPhone 
Developer Center.

Select the Quick Publishing For 
Device Testing option.

Click the Icons tab.

Locate and add the 29.png, 57.png 
and 512.png file.

Click Publish.

Flash launches the iPhone 
Packager tool and generates (6-10 
minutes) an IPA iPhone App file in 
the same folder as your Flash files.

Locate the IPA file, and then drag 
the file onto iTunes and sync your 
device. When the sync completes 
you will be able to launch your 
App from your iPhone. 

21
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Playing Back Video

You can play back video in the iPhone, but there is a caveat. The only 
types of video that you can add to your iPhone Apps are Sorenson 
and ON2 VP6 video formats. If you want to use H.264 then you need to 
essentially post the video to a URL string so it pops up in Mobile 
Safari.

For Your Information
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With the release of the Flash Player 10.1 and 
Adobe Integrated Runtime, AIR 2.0, the Flash 
team added several new core API features 
(New!). Access to a devices Accelerometer is 
one of those. The role of the Accelerometer is 
to detect when you move your phone. The 
Accelerometer is a listener that is triggered 
when it is used. The following example adds 
an Accelerometer listener to your iPhone App.

Add an Accelerometer Listener
Create a new iPhone App and add the 
necessary development properties in the 
iPhone settings.

Add a dynamic text field to the Stage 
with the name myTextField in the 
Properties panel.

Create a new layer on the Timeline with 
the named Actions, and then select the 
Actions layer. 

Open the Actions panel.

Add code to import the libraries for the 
Accelerometer to work correctly:

import flash.events.AccelerometerEvent

import flash.sensors.Accelerometer; 

Add code to create a new Accelerometer 
object:

var acc1:Accelerometer = new Accelerometer()

Add a boolean object to test if the 
Accelerometer works or not:

var isSupported:Boolean = 
Accelerometer.isSupported;

checksupport();
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Controlling the Accelerometer

Add a function that contains the event 
listener, which waits for the 
Accelerometer to be triggered:

function checksupport():void {

if (isSupported) {

myTextField.text = "Accelerometer feature 
supported";

acc1.addEventListener 
(AccelerometerEvent.UPDATE, updateHandler);

} else {

myTextField.text = "howdy ";    }

}

Add a function that posts a message to 
the text field to tell what direction the 
device has moved to:

function 
updateHandler(evt:AccelerometerEvent):void {

myTextField.text = String("at: " + evt.timestamp 
+ "\n" + "acceleration X: " + evt.accelerationX 
+ "\n" + "acceleration Y: " + evt.accelerationY 
+ "\n" + "acceleration Z: " + 
evt.accelerationZ); 

Publish and package your file into an 
iPhone App and test it on your iPhone.

The Accelerometer gives you new ways 
for your customers to interface with your 
applications beyond touchscreen controls. The 
Accelerometer works great on the iPhone but 
the same code can be used for Adobe AIR 
apps running on Google’s Android OS, Palm’s 
WebOS and RIM’s BlackBerry phones. Yes, 
that’s right. Develop one App and have it 
deployed to multiple mobile devices.
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9

8

 From the Library of Wow! eBook



ptg

Chapter 16 Developing iPhone Apps 395

Adobe does give you access to some core 
iPhone specific tools. One of those is the abil-
ity to add a function that will save an image 
of the screen to the Camera Roll (New!). The 
following example saves a screen image to 
the Camera Roll in an iPhone App. 

Save a Screen Image to Camera Roll
Click the File menu, click New, click 
iPhone OS, and then click OK.

Create a new Movie Clip on the Stage 
with the name snapShot.

Add the following event Listener to:

snapShot.addEventListener(MouseEvent.CLICK, 
myScreenShot);

Add the following function that takes a 
screen shot of your iPhone:

function myScreenShot 
(event:MouseEvent):void

{

if (CameraRoll.supportsAddBitmapData)

{

4

3

2
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var cameraRoll:CameraRoll = new 
CameraRoll(); 
cameraRoll.addEventListener(ErrorEvent.ERROR 
, onCrError);

cameraRoll.addEventListener(Event.COMPLETE, 
onCrComplete);

var bitmapData:BitmapData = new 
BitmapData(stage.stageWidth,stage.stageHeigh
t);

bitmapData.draw(stage);

cameraRoll.addBitmapData(bitmapData);

}

else

{

trace("not supported.");

}

}

Publish and package your file into an 
iPhone App and test it on your iPhone.

5

Saving Images to the Camera Roll
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There are some limitations to using the 
iPhone Packager for Flash CS5 (New!). The 
first is that you cannot load external SWF 
movies. You can, however, load external JPG 
and PNG files and sound files such as MP3.

There are also performance problems 
between different versions of the iPhone. For 
instance, the iPhone 3GS is literally twice as 
fast as the iPhone 3G and original iPhone. 
There some simple tricks you can do to speed 
up things. The following code will prevent 
event Bubbles starting:

override public function 
dispatchEvent(evt:Event):Boolean {

if (hasEventListener(evt.type) || evt.bubbles) {

return super.dispatchEvent(evt);

}

return true;

}

A second optimization trick you can do is 
to restrict your use of vector based images 
inside of Flash. Use PNG formatted images 
where possible. The good news is that that the 
iPhone has great support for PNG files.

If you do need to use vector images you 
can fool the iPhone into thinking it’s a bitmap 
image by using the cahceAsBitmapMatrix. 

Create a new image. Add code import the 
Flash Geom Matrix:

import flash.geom.Matrix;

Create a new shape:

var my_shape :MyShape = new MyShape();

addChild(my_shape);

Add the cachasBitmap property to ensure 
that all objects that create are cached:

my_shape.cacheAsBitmap = true;

my_shape.cacheAsBitmapMatrix = new 
Matrix();
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Create images on the screen that the 
iPhone thinks are bitmaps.

A final significant limitation is the use of 
audio files. Audio files can have a short delay 
between an event happening and the sound 
playing. This is because the audio file is not in 
the iPhone’s cache for playback. You can avoid 
this by exporting your audio file to be trig-
gered in the first frame of your movie. 

What Flash Does Not Allow You To Do
Adobe has gone to great lengths to allow you 
to build applications for the iPhone using tra-
ditional Flash tools. BUT (and it is a big BUT) 
there are some things that Flash does not 
allow you to do using the iPhone Packager. 

The biggest challenge you will have is the 
inability to use ActionScript 1.0 and 2.0. All of 
your apps must be developed using 
ActionScript 3.0. There are tens of thousands 
of great ActionScript 1.0 and 2.0 apps that can 
not be published to the iPhone due to the 
ActionScript 3.0 limitation.

You also have to be careful using video. 
Only Flash Video will work. You can use a URL 
link to load a MPEG4 video, but this is really a 
cheat as you are running the video through 
the iPhone’s Mobile Safari Web browser. 

If you are familiar developing iPhone Apps 
using the iPhone SDK then you may expect 
core iPhone Cocoa Touch kits available to you 
in Flash. This includes the StoreKit (for “in 
App purchase”), GameKit, MapKit and other 
rich media tools. These useful kits are simply 
not available to the Flash developer.

The good news is that Adobe is well aware 
that the Flash CS5 iPhone Packager is not 
complete. Expect releases for the iPhone 
Packager to keep coming during the lifecycle 
of Flash CS5. 

4

Understanding the Limits of Flash
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Ad Hoc is a method for deploying your App to up to 100 iPhone, iPod 
Touch and iPad devices. The Ad Hoc method (New!) is a solution that 
allows you to deploy your apps to a small group of friends and co-work-
ers without the App appearing in the iTunes App Store. The method for 
creating the application is very similar to deploying an App for deploy-
ment to the iTunes App store. There are three steps you need to be able 
to successfully deploy an App using Ad Hoc: Identify each device you 
will be deploying your Ad Hoc App too; creating an Ad Hoc provisioning 
license; and packaging your Ad Hoc App.  

Identifying Devices 
to Deploy an Ad 
Hoc App

Collect and Add Deployment
Device IDs

Contact each person you will be 
deploying your App to and ask 
them to connect their iPhone, iPod 
Touch or iPad to their Mac or 
Windows computer.

Ask them to open iTunes, select 
their device, and then view the 
Summary tab information.

Ask them to click the Serial 
Number next to their device. 

The number changes to an 
Identifier (UDID) number.

Ask them to copy the UDID 
number, and then send it to you.

Open your Web browser, and then 
go to the Devices page on the 
iPhone Developer site: 

◆ http://developer.apple.com 
/iphone/manage/devices 
/index.action

For each trusted device, click the 
Add Devices button on the Web 
page, paste in the UDID number 
and then enter a device name. 

IMPORTANT You can only have 
100 identified devices per year. 
You cannot add and remove 
devices to keep your list at 100. 
When you have added the 100th 
device you have to wait a year 
before you can remove a device 
and add a new one.
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The first step is to identify the devices you will be deploying your Ad 
Hoc App to. The next step is to create the profile you will need to use 
when you are building your Application for Ad Hoc deployment. The Ad 
Hoc Distribution method (New!) removes the hassle of having to wait 
for your App to be approved by Apple (which can take days to weeks to 
complete). To be able to take advantage of the Ad Hoc deployment 
process you need to first create an Ad Hoc Distribution Profile. 
Creating the Ad Hoc Profile is very similar to the profile you will create 
when you submit your App to the iTunes Store. The one big difference 
is you need to have a list of all the unique iPhone's and iPod Touch 
devices you will be sending your final App too.

Creating an Ad Hoc
Distribution Profile

Create an Ad Hoc Distribution 
Profile

Open your Web browser, and then 
go to the Provisioning Profiles 
page on the iPhone Developer site:

◆ http://developer.apple.com 
/iphone/manage/provisioningpr 
ofiles/index.action

Click the Distribution tab.

Click the New Profile button.

Click the Ad Hoc option.

Enter a profile name for your App.

Click the App ID list arrow, and 
then select the App ID that 
matches the App you want to 
deploy using Ad Hoc.

Select the devices (from the list of 
ones you entered) you want to 
deploy using Ad Hoc.

Click the Submit button.

Your Ad Hoc profile takes about 30 
seconds to generate. 

Click Download (Mac) or Save 
(Win), and then save the Ad Hoc 
profile to your desktop.

At this point, you’re ready to 
create your Ad Hoc iPhone App.
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The final step you need to take is to package your Flash movie into an 
iPhone App using the Ad Hoc profile (New!). The final step in creating 
your Ad Hoc App is to package your Flash App for distribution. The Ad 
Hoc distribution process is very similar to the final App Store Packaging 
publication process. There are some differences. The main change is 
that you must use the Ad Hoc Profile you created in the previous sec-
tion. Without the Ad Hoc Profile your Ad Hoc deployment method will 
not work correctly.

Packaging an Ad 
Hoc App

Publish and Package an 
Ad Hoc App

In Flash, open the iPhone App you 
want to publish and package as an 
Ad Hoc App.

Open the Properties panel.

Click the iPhone Settings Edit 
button.

The iPhone Settings dialog box 
opens, displaying three tabs: 
General, Deployment and Icons. 

Click the Deployment tab.

Click Browse, and then select your 
Published P12 certificate file, and 
then enter your password.

Click Browse, and then select the 
Ad Hoc Distribution Profile you 
downloaded.

Click the Deployment – Ad Hoc 
option.

Click Publish.

Flash launches the iPhone 
Packager tool and generates (6-10 
minutes) an IPA iPhone App file in 
the same folder as your Flash files. 

Locate the IPA file and send it to 
anyone in the Ad Hoc Provisioning 
Profile list. Ask them to drag the 
file onto iTunes and sync their 
device. When the sync completes 
you will be able to launch your 
App from your iPhone.
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Apple’s iTunes Store is an amazing success story. 133,000 Apps and 3 
Billion downloads in 20 months is nothing to sneeze at. There are many 
stories of companies making millions from Apple. But, before you can 
get any money, you need to have your App ready for deployment. The 
method for packaging your Flash file into an iPhone App for distributing 
to the iTunes store is very similar to the Ad Hoc process with the 
exception that you only need to create a distributing profile and create 
your iPhone IPA file from Flash CS5 (New!) . 

Packaging an App for 
the iTunes App Store

Publish and Package an 
iPhone App 

Open your Web browser, and then 
go to the Provisioning Profiles 
page on the iPhone Developer site:

◆ http://developer.apple.com 
/iphone/manage/provisioningpr 
ofiles/index.action

Click the Distribution tab.

Click the New Profile button.

Click the App Store option.

Enter a profile name for your App.

Click the App ID list arrow, and 
then select the App ID that 
matches the App you want to 
deploy.

Click the Submit button.

Your profile takes about 30 
seconds to generate.

Click Download (Mac) or Save 
(Win), and then save the App Store 
profile to your desktop.

In Flash, open the iPhone App you 
want to publish and package as an 
App Store App.

Open the Properties Panel.

Click the iPhone Settings Edit 
button.

The iPhone Settings dialog box 
opens, displaying three tabs: 
General, Deployment and Icons. 
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Select the Deployment tab.

Click Browse, and then select your 
Published P12 certificate file, and 
then enter your password.

Click Browse, and then select the 
App Store Distribution Profile you 
downloaded.

Click the Deployment – Apple App 
Store option.

Click Publish.

Flash launches the iPhone 
Packager tool and generates (6-10 
minutes) an IPA iPhone App file in 
the same folder as your Flash files. 

Locate the IPA file and then 
change the extension of the file 
from IPA to ZIP.

Both file formats are container 
formats. That is, they contain all of 
the files needed for the App to run; 
iTunes Connect only accepts files 
in the ZIP format.

At this point, your App is ready for 
deployment to the iTunes App 
Store.
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Did You Know?
Ad Hoc is a great way to easily deploy 
apps to a small group of users. It is not 
a good solution for deploying apps to a 
large number of users. If you want to 
deploy your App to a large number of 
users then you will need to take advan-
tage of Apple’s powerful iTunes App 
Store.
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You are now very close to having an App available on the iTunes store. 
Can’t you feel the rush! You could be selling thousands of apps in a mat-
ter of a few days. The gap between you and riches is Apple’s iTunes 
Connect publishing tool. You are very close now. You will be using a new 
Web site to upload your final iPhone Apps. The site is called iTunes 
Connect (https://itunesconnect.apple.com/). In every sense, iTunes 
Connect is your business relationship with Apple. The site allows you to 
set up your contracts, tax records, banking information, review sales 
trends, download financial report and manage your In App Purchases. 
You will need to complete these sections in order to sell your App in 
iTunes. This section is going to focus on the important part of iTunes 
Connect: Managing your Applications (New!).

Using iTunes Connect 
to Publish an App

Use iTunes Connect to Publish 
your App

In Flash, create your iPhone App, 
publish and package it, and then 
change the extension from IPA 
to ZIP.

Convert the 512x512 PNG pixel 
image into a JPG image. Label the 
new file 512.jpg.

Take a screen shot of your App as 
it appears in your iPhone. When 
your App is playing on your 
iPhone, press the Home and Sleep 
buttons at the same time (screen 
flashes) to take a screen shot of 
your App.

The image is stored to your 
Camera Roll and is exactly the 
same size Apple needs.
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Did You Know?
You can download Apple’s Developer 
Guide. Open your Web browser, go to 
the Manage Your Application page on 
iTunes Connect, and then click the 
download link to save the PDF file. 
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Open your Web browser, and then 
go to the iTunes Connect page, 
and then use your Apple 
Developer ID and Password to 
log into the site: 

◆ https://itunesconnect. 
apple.com

Click Manage Your App from 
iTunes Connect. 

Add anew application or edit an 
existing one.

◆ Add New App. Click the Add 
New Application button  to 
start the process of creating 
a new iTunes App.

◆ Edit Existing App. Double-click 
the application icon. 

When you’re done editing your 
App settings, click Save 
Changes.

There are several screens you 
need to complete to upload your 
App to iTunes. 

If prompted, click the Yes or No 
option to specify whether your 
App contains encrypted data. 

◆ For a first App, click No to keep 
the process simple. In the 
future, you can experiment with 
different settings.

Click the Continue button when 
you have completed the page.

The next page allows you to add 
product overview information 
about your App. For the most part, 
the content you enter on this 
screen can be edited after your 
App has been submitted. 

Continue Next Page
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Continued from Previous Page

Enter or change information about 
your App. The information includes 
the following: 

◆ Name and description.
◆ Product primary and secondary 

categories.
◆ Copyright, version number, and

SKU number.
◆ Keywords. Use for search 

engines (up to 100 characters).
◆ URLs. Application/support URL 

and support email. 

Click the Continue button when 
you have completed the page.

The next page allows you to add a 
rating for your App. 

Click options to answer the 10 
questions to determine a rating.

Click the Continue button when 
you have completed the page.

The next page allows you to 
upload all of your App files. 

Click the Choose File button to 
upload your App files: 

◆ Upload the ZIP’d IPA file for the
Application.

◆ Upload the 512.jpg for the Large 
512x512 Icon.

◆ Upload a 480x320 jpg image for 
the Primary Screenshot.

◆ Add 1-4 480x320 jpg images for 
the Additional Screenshots. 

The upload will take about 20 
minutes. The upload is checking 
for some basic settings such as 
including the correct profile. 

A green check mark appears for 
each successfully loaded image. 
A red cross appears when 
something is wrong.
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Click the Continue button when 
you have completed the page.

The next page allows you to 
specify availability and pricing for 
your App. 

Specify an Availability Date and
Price Tier. 

◆ Availability Date. Specifies 
when your App goes on sale. 

◆ Price Tier. Select a price tier 
level; you do not get to select a 
specific price for your App. 

This removes the pain of selling 
with different currencies. A Tier
2 App will be $0.99 in the US, 59 
pence in England and AU$1.29 
in Australia. There are over 70 
different currencies that Apple 
manages for you. 

Click the Continue button when 
you have completed the page.

The next page allows you to 
specify localization for your App. 

Specify the localization settings 
you want for your App. 

Click the Continue button when 
you have completed the page.

At this point, review all of your 
content, and then click the 
Submit button.

◆ When you’re done editing your
App settings, click Save 
Changes.
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Did You Know?
Faster iTunes App Submission. Apple 
has done a lot to improve the review 
process for new apps. Today it only 
takes 5-7 days for an App to be 
approved and appear in iTunes.
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The iPhone has one characteristic that you will 
not see on a desktop or laptop computer: it 
can be easily rotated. Determining orientation 
can allow you to add interesting effects to 
your iPhone Apps (New!). For instance, the 
default Stocks tool on your iPhone will show 
you the numbers of a particular stock when 
you hold your phone in portrait; switch the 
phone to landscape and the content changes 
to a line chart illustrating how the stock is per-
forming. This trick is accomplished through 
the iPhone being able to detect the orientation 
of the device. The iPhone can detect 
Orientation in four distinct directions:

◆ Default – Portrait

◆ Rotation Left – Landscape

◆ Rotation Right – Landscape

◆ Upside Down – Portrait, upside down 

ActionScript contains a special class called 
the Orientation Class, which allows you to 
control content on the screen depending on 
the orientation of the device.

Use the Screen Orientation Class
Create a new iPhone App, apply the 
appropriate provisioning profiles, and 
then save the file with the name 
iPhoneOrientation.fla.

Add a dynamic text box to the Stage with 
the name myTxt, and then apply the 
_Sans font.

Open the Actions Panel.

Add a listener and function that changes 
the content of the text box based on the 
orientation of the device (see illustration).

Publish and package your file into an 
iPhone App and test it on your iPhone. 
Rotate your iPhone to see the text change 
on your iPhone.
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Using Screen Orientation in an App

In addition to using ActionScript to control 
the orientation of your phone, you can also 
have the whole movie auto-orientate as a 
default setting in your iPhone Settings screen. 
On the whole, however, you have much 
tighter control over your content is you use 
ActionScript to control the orientation of spe-
cific movies, sprites and objects over the 
auto-orientation Boolean setting.

Loading Files Into the iPhone

The Loader Class allows you to load external con-
tent into your Flash Player. For the most part, this 
still works when you package your Flash movie for 
the iPhone. For instance, you can still load MP3, 
Sorenson Flash video and PNG files. There is, 
however, one exception: you cannot load SWF files 
that contain ActionScript into your movies. This is 
a pain as a lot of Flash designers like to break up 
their movies into smaller, individual SWF files and 
then you use a shell SWF to package it all 
together. Hopefully that will change in future 
releases.

For Your Information
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Mobile devices are meant to move. With 
GeoLocation services, you can figure out your 
current location. So, when someone asks you 
“Where are you?” you can tell them. 

The following example shows how to add 
Adobe AIR 2.0 GeoLocation Class (New!) to 
your iPhone App. This sample is stripped 
down to a simple Class file, which can give 
you an idea of how you can use this in other 
Apps.

Add GeoLocation Services
Create a new iPhone App, apply the 
appropriate certificates and profiles, and 
then save your file with the name 
iPhoneGeolocation.fla.

Add a dynamic Classic Text box to the 
Stage with the name myTxt, and then 
apply the _Sans font. 

Create a new Class for the App with the 
name iPhoneGeolocation.

Save the ActionScript file with the name 
iPhoneGeolocation.as.

Add code to import the class files that 
allow you to use the Geolocation objects:

import flash.events.GeolocationEvent;

import flash.sensors.Geolocation

Create a new geolocation variable that 
you can use:

private var myGeo:Geolocation;

Create a simple If/Else statement that 
detects whether or not the geolocation 
services can be used.

The iPhone always gives the user of the 
iPhone a choice to whether or not you 
can use the Geolocation services. If you 
do not allow geolocation to be used a 
message will be posted to the text field
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informing the user that a location could 
not be detected. If you do, however, 
allow the user to use geolocation then a 
new listener event will be triggered and 
then re-run 10x/second.

Add a function triggered by the 
geolocation listener:

Publish and package your file into an 
iPhone App and test it on your iPhone.

How Does the iPhone Know Your 
Location?
There are three ways to detect your location. 
The most accurate method uses the Global 
Position Satellites (GPS) built into the iPhone 
3G and 3GS. The second method uses Cell 
Tower Triangulation where the location of the 
device is determined by using 3 or more Cell 
Tower’s. This method can be used by all 
iPhones and 3G enabled iPad’s. The third 
method uses a WiFi hotspot, which is similar 
to the Cell Tower Triangulation but is only 
accurate to within a few hundred feet. All 
iPhone OS devices (iPhone, iPod Touch and 
iPad) support WiFi hotspot geolocation 
services.

9
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Using Geolocation in an App
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By default, Flash assumes that you are using 
a mouse to touch the screen. This actually 
works OK for many iPhone Apps and allows 
you to take the same code you have devel-
oped for other Flash movies and move it into 
your iPhone projects. That’s OK, but what 
about those cool iPhone gestures (New!) you 
see people using to swipe content? Flash can 
do that, too.

For the iPhone, Flash supports the follow-
ing Multitouch gestures:

◆ TransformGestureEvent.GESTURE_PAN

◆ TransformGestureEvent.GESTURE_ROTATE

◆ TransformGestureEvent.GESTURE_SWIPE

◆ TransformGestureEvent.GESTURE_ZOOM

Each gesture is used as an interactive 
event in a Listener. This means that you can 
take your knowledge of Listeners and quickly 
apply it to iPhone Apps. The following exam-
ple shows you how to add a swipe gesture 
that will trigger a movie clip to fade onto the 
screen.

Use the Multitouch Class
Create a new iPhone App, apply the 
appropriate development profiles and 
certificates, and then save the file with 
the name iPhoneMultitouch.fla.

Draw a rectangle on the Stage, and then 
convert the rectangle into a Movie Clip 
with the name myMovie.

Open the Actions panel.

Add code to import the class libraries:

import flash.ui.Multitouch;

import flash.ui.MultitouchInputMode;

Set the default Alpha value for the Movie 
Clip to 0:

myMovie.alpha = 0;

Add a listener and function that enable 
the Movie Clip to fade onto the screen 
(see illustration).

Publish and package your file into an 
iPhone App and test it on your iPhone.
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Using Multitouch in an App
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Introduction

Flash provides several enhancements that make it easier for 
you to debug scripts using the ActionScript language. The 
features include new language elements, improved editing 
and debugging tools, and the introduction of a more object-
oriented programming language; however, not all debugging 
problems reside in an ActionScript. Debugging a Flash movie 
is similar to a mechanic attempting to fix the engine on a car. 
He can hear a knocking or pinging sound, but he's not sure 
what's causing it, so he brings out his debugging tools to 
help locate the problem. 

A Flash movie is not a car, however, there are similarities. 
If the movie is not doing what you want: Maybe it's running 
too slow, or your movie crashes after playing a specific 
scene; you can bring out Flash's debugging tools to help 
locate (and fix) the problem. When you design a Flash movie, 
the fonts, colors, video and audio (if any), along with the 
overall construction of the movie are very right-brain tech-
niques (your creative side at work). When you debug a Flash 
movie, you're using a very logical approach to the problem. 
Like the car mechanic, you're listening for that annoying 
pinging sound. Flash will not only help you locate the prob-
lem, its array of debugging tools will help you fix it and get 
you back speeding down the electronic highway.

Flash's debugging tools include the Debug workspace 
(ActionScript 3.0) or Actions panel (ActionScript 2.0) and the 
Movie Explorer, where you can set breakpoints, view vari-
ables, and see how they react during the play of the movie. 
Flash uses a different debugger for ActionScript 3.0 files than 
it does for ActionScript 2.0 files.The debugger functionality is 
similar, but the look and feel is different. The debugger for 
ActionScript 3.0 uses the Debug workspace while 
ActionScript 2.0 uses the traditional Actions panel. 17

17
What You’ll Do

Debug Concepts

Debug with the ActionScript Editor

Use the Movie Explorer

Debug for ActionScript 3.0

Resolve Compiler Errors

Debug for ActionScript 2.0

View Variables

Add Variables to the Watch List

View Properties

Set Breakpoints

Step Through Code

Debug Manually

409
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When you debug a movie, you're not just 
looking for the obvious problems; you're 
attempting to see if you can find anything that 
might happen. Depending on the complexity 
of the movie, hidden problems can be difficult 
to find. For example, if you're calling video 
files into a Flash movie, are all your paths to 
the files correct? It may function fine when 
you're testing on your computer, but will it 
still work when you move it to a CD or Web 
server? Test it and find out. Here are a few 
things to consider when going into the debug 
phase of a Flash Movie:

◆ Paths to file. If you're importing external 
SWF files, image files, video, or audio 
files into a Flash movie, the best 
approach is to create a folder to hold the 
entire Flash project, and then create sub-
folders within that folder to hold the 
movie assets. When you move the Flash 
project, move the entire folder. That way, 
all the path names stay correct, and you

always know where everything is, at all 
times.

◆ Short, descriptive file names. Computers 
allow for file names of unlimited length; 
however, that does not mean that you 
need to use large file names. Large file 
names are harder for you to type in, and 
there is a greater chance for errors. Use 
short, descriptive names. 

◆ Use smart naming conventions. Since 
file names display alphabetically, it's not 
a bad idea to come up with similar 
names for similar file types. For 
example, car_1.jpg, car_2.jpg, car_3.jpg. 
The name and extension describe (in 
general terms) the content of the file and 
file type and will display one after the 
other. Smart naming conventions won't 
make your Flash project any better, but 
they will help to organize some of the 
confusion that comes with a complicated 
Flash project.

Debugging Concepts

Project folder
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◆ Test and debug often. Debugging does 
not start at the end of a project, it begins 
as soon as you click the File menu, and 
then click New. Flash lets you test a 
movie whenever you choose. Just click 
the Control menu, point to Test Movie, 
and then click Test (to test the entire 
Flash movie), or click Test Scene (to test 
just the active scene). When you test a 
scene or movie, Flash creates a 
temporary SWF file and then runs the 
movie in a version of the Flash plug-in. 
Flash publishes the test movie using the 
settings in the Publishing dialog box. If 
there is a problem, you can use the 
Debugger to diagnose the problem, so 
you can fix it. Just click the Debug menu, 
point to Debug Movie, and then click 
Debug.

◆ Bandwidth. If a project is going out to the 
Internet, make sure that the size of the 
finished movie isn't so large that your

visitors have to wait a long time for it to 
download. It's possible you might want 
to include a pre-loader to entertain the 
audience while they're waiting. 

◆ Planning is the key. If you want your 
Flash movie to look good, work without 
error, and be completed in the least 
amount of time, then plan, plan, and then 
plan some more. Use the carpenter's 
adage: Measure Twice… Cut Once. 
University studies show that planning a 
project, before you start, cuts the project 
completion time by 20 percent. Planning 
involves thinking about what you want to 
accomplish (what's the message), 
research and gather all the files and 
things you'll need to complete the 
project, and think about where the 
project will be used (Internet, CD). In 
addition, a well-planned project will cut 
down your debugging time by over half.

Smart file naming 
conventions

 From the Library of Wow! eBook



ptg

412 Chapter 17

The ActionScript editor allows you to edit and debug scripts. When 
you're debugging a Flash movie, the traditional wisdom is to try to push 
it until it breaks, and then figure out why it broke. However, once you 
find out what's broken, it's very possible that you're going to have to 
work on the ActionScript's that drive the movie. That's where the 
Actions panel comes into play. The designers of Flash included editing 
and debugging features to make debugging easier. You can quickly set 
and remove breakpoints using the Debug Options button to check differ-
ent parts of your code to determine if it’s working correctly. You can also 
work in the Actions panel in Script Assist mode—supported by 
ActionScript 2.0 and ActionScript 3.0 (attached to a frame)—in which 
you filled in options and parameters to create code or access the Code 
Snippets panel (New!) to insert ActionScript 3.0 code. It is a great way 
for novice ActionScript coders to learn programming. To make working 
with code easier, you can use collapse and expand buttons to show and 
hide sections of code. In addition, you can use buttons to quickly add 
comments to a line or a block of code to document your work.

Debugging with the 
ActionScript Editor

Use the ActionScript Editor

Click the Window menu, and then 
click Actions to open the 
ActionScript Editor. 

Script Assist. Click the Script 
Assist button to view, write, and 
edit scripts using a visual interface 
that includes syntax completion 
and parameter descriptions. 

◆ To insert ActionScript 3.0 code, 
click Code Snippets to access 
the panel (New!).

Word wrapping. Click Word Wrap 
on the Options menu in the Actions 
panel to enable or disable word 
wrapping.

Viewing context-sensitive Help. 
When your pointer is positioned 
over an ActionScript element in 
the Actions toolbox or in the Script 
pane, you can click the Reference 
button in the context menu to 
display an element help page.

Importing scripts. Click Import 
Script on the Options menu in the 
Actions panel, the imported script 
is copied into the script at the 
insertion point.
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Breakpoints
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Single-click breakpoints. To add a 
debugging breakpoint before a line 
of code in the Debugger panel or 
the Script pane of the Actions 
panel, click in the left margin.

Pinning multiple scripts. You can 
pin multiple scripts within a FLA 
file along the bottom of the Script 
pane in the Actions panel.

Script navigator. The Script 
navigator is a visual structure of 
your Flash FLA file; you can 
navigate through the file to locate 
the ActionScript code.

Integrated Script window for 
editing external files. You can use 
the ActionScript editor in a Script 
window (separate from the 
Actions panel) to write and edit 
external script files.

Syntax coloring. Syntax coloring 
utilizes a user-defined set of colors 
to display the code entered into 
the Script pane. Click the Flash 
(Mac) or Edit (Win), and then click 
Preferences. Click the 
ActionScript category to modify 
the syntax coloring.

Instant Syntax Checking. Click the 
Check Syntax button to get an 
instant evaluation of the current 
script.

Code Hint. Click the Show Code 
Hint button to have Flash help you 
enter code.

Debug Options. Click the Debug 
Options button to set and remove 
breakpoints.

Collapse and Expand. Click the 
Collapse Between Braces, 
Collapse Selection, or Expand All 
buttons.

Comments. Click the Apply Block 
Comment, Apply Line Comment, 
and Remove Comment buttons.
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Selected code

14

Click to expand code

15

Collapsed code
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Flash's Movie Explorer gives you an easy way to view and organize the 
contents of an .fla document, and even select elements for modifica-
tion. It contains a display list of currently used elements, arranged in a 
tree hierarchical structure. The Movie Explorer gives you the ability to 
filter which categories of items in the document are displayed: text, 
graphics, buttons, movie clips, actions, and imported files. You can 
even display selected categories as individual scenes, concise symbol 
definitions, or both. When you select an item in the Movie Explorer 
panel, the item will be selected in the Flash document. If you double-
click on an ActionScript, Flash opens the script in the Actions panel. If 
you double-click on a Library item, Flash opens the item in the Library. 

Using the Movie 
Explorer

Use the Movie Explorer

Click the Window menu, and then 
click Movie Explorer to open the 
panel.

Click the Movie Explorer Options 
menu, and then select from the 
following options:

◆ Go To Location. Takes you to 
the selected layer, scene, or 
frame in the active document.

◆ Go To Symbol Definition. Takes 
you to the symbol definition for 
a symbol that is selected in the 
Elements area.

◆ Select Symbol Instances. Takes 
you to the scene containing 
instances of a symbol that is 
selected in the Definitions area.

◆ Find In Library. Select to 
highlight the selected symbol in 
the document's Library. 

◆ Rename. Select to enter a new 
name for a selected element.

◆ Edit In Place. Select to edit a 
selected symbol on the Stage.

◆ Edit In New Window. Select to 
edit a selected symbol in a new 
window.

◆ Show Movie Elements.
Displays document elements 
organized into scenes.

2

1 
1

2
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◆ Show Symbol Definitions.
Select to display all the 
elements associated with a 
symbol.

◆ Copy All Text To Clipboard.
Select to copy selected text to 
the Clipboard.

◆ Cut, Copy, Paste, And Clear.
Select to perform these 
functions on a selected 
element.

◆ Expand Branch. Select to 
expand the navigation tree at 
the selected element.

◆ Collapse Branch. Select to 
collapse the navigation tree at 
the selected element.

◆ Collapse Others. Select to 
collapse the branches in the 
navigation tree not containing 
the selected element.

◆ Print. Select to print the 
hierarchical display list 
currently displayed in the 
Movie Explorer.

The Show buttons give you the 
option to show or hide different 
elements of the movie. These 
options will only impact the Movie 
Explorer, not the Flash Stage.

◆ Show Text

◆ Show Buttons, Movie Clips, 
and Graphics

◆ Show ActionScripts

◆ Show Video, Sounds, and 
Bitmaps

◆ Show Frames and Layers

Click the Customize Which Items
To Show button to customize what 
items display in the Movie Explorer 
window.

4

3

43
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The designers of Flash included editing and debugging features to 
make debugging easier. You can quickly set and remove breakpoints to 
check different parts of your code to determine if it’s working correctly. 
Flash uses a different debugger for ActionScript 3.0 files (FLA or AS) 
than it does for ActionScript 2.0 files. The functionality is similar, but the 
look and feel is different. The debugger for ActionScript 3.0 uses the 
Debug workspace that displays the Debug Console, Variables, and 
Output panels along with the Actions panel or Script window. The 
Debug Console displays the call stack, scripts containing the functions 
in the call stack, and contains buttons to step through the code. The 
call stack shows the current list of nested function calls ready for exe-
cution. The Variables panel displays variables and their current values. 
When a problem is encountered, Flash displays the line of code in the 
Compiler Errors panel. Double-click the error to view it in the code.

Debugging for 
ActionScript 3.0

Use the Debugger for 
ActionScript 3.0

Create or open a Flash document 
(ActionScript 3.0).

◆ To debug an ActionScript 3.0 
file (AS), open the file in the 
Script window, select the 
associated Flash file from the 
Target menu. 

Click the Debug menu, point to 
Debug Movie, and then click 
Debug.

◆ You can access debugging 
commands on the Debug menu.

Add or remove breakpoints to 
interrupt the execution of the 
scripting code.

◆ Add. Click in the left margin 
next to the line of code.

◆ Remove. Click the breakpoint in 
the left margin. 

To step through the code line by 
line or step in and out of functions, 
use any of the following:

◆ Step into code line by line. 
Click the Step In button in the 
Debug Console panel.

◆ Step over a function call. Click 
the Step Over button in the 
Debug Console panel.

4

3

2

1

3

4

Output panel

Actions 
panel

2 1
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◆ Step out of a function call. 
Click the Step Out button in the 
Debug Console panel.

◆ Resume normal code 
execution. Click the Continue 
button in the Debug Console 
panel.

To view the individual scripts that 
contain each function, double-
click the script name in the call 
stack in the Debug Console panel.

To view variable values, click the 
Options button on the Variables 
panel, and then click one of the 
following:

◆ Show Constants. Displays the 
values constants.

◆ Show Statics. Displays 
variables for the class instead 
of instances of the class. 

◆ Show Inaccessible Member 
Variables. Displays variables 
that are inaccessible to other 
classes or namespaces. 

◆ Show Additional Hexadecimal 
Display. Displays hexadecimal 
values instead of decimal 
values.

◆ Show Qualified Names. 
Displays variable types with 
both the package name and the 
class name. 

To edit the values of variables in 
the Variables panel, double-click 
the value, enter a new value, and 
then press Enter (Win) or Return 
(Mac).

If an error occurs, double-click it 
in the Compiler Errors panel.

To exit debugging mode, click the 
End Debug Session button in the 
Debug Console panel. To change 
workspaces, click the Workspace 
menu, and then select one.

9
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When a problem is encountered, Flash displays the location and 
description of the warnings and errors in the Compiler Errors panel. In 
the Compiler Errors panel, you can show or hide warnings or errors 
(New!), scroll through each one (New!), and display/highlight them in 
the code (New!). You can also manage the types of compiler warning 
that appear in the Compiler Errors panel by setting options in the 
Publish Settings dialog box. Two options are available: Strict Mode and 
Warnings Mode. Strict Mode reports warnings as errors, while 
Warnings Mode reports extra warnings for discovering incompatibili-
ties when updating ActionScript 2.0 code to ActionScript 3.0.

418 Chapter 17

Resolving Compiler 
Errors

Resolve Compiler Errors

Create or open a Flash document 
(ActionScript 3.0).

Click the Control menu, point to 
Test Movie, and then click Test.

If an error occurs, the Compiler 
Errors panel opens displaying the 
errors found during the execution.

Open the Compiler Errors panel.

In the Compiler Errors panel, use 
the following options to resolve 
compiler errors:

◆ View Warnings or Errors in the 
Code. Select the warning or 
error, and then click the Go To 
Source button, or double-click 
the warning or error to display 
it in the Actions panel.

◆ Display Warnings or Errors. 
Click the Go To Previous or Go 
To Next button. The code line 
with the error highlights in the 
Actions panel.

◆ Clear Warnings and Errors. 
Click the Clear button.

◆ Show or Hide Warnings or 
Errors. Click the Warning(s) or 
Error(s) button at the bottom of 
the Compiler Errors panel.

4

3

2

1 
3

Show or hide errors 
or warnings

4

Source of error from the Compiler Errors panel

Errors due to a change from 
ActionScript 2.0 to ActionScript 3.0
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Control Compiler Warnings

Create or open a Flash document 
(ActionScript 3.0).

Click the File menu, and then click 
Publish Settings.

Click the Flash tab.

Click the Settings button for 
ActionScript 3.0

Select the Strict Mode check box 
to report warnings as errors. 

Select the Warnings Mode check 
box to report extra warnings for 
discovering incompatibilities when 
updating ActionScript 2.0 code to 
ActionScript 3.0 code.

Click OK.

Click OK.8
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Flash provides several tools for testing Flash files (ActionScript 2.0). The 
Debugger panel lets you find and locate errors hidden in an .swf file, 
while it's running in the Flash Player. You must view your SWF file in a 
special version of Flash Player called the Flash Debug Player (installed 
automatically when you install the Flash application). The Debugger 
panel shows a hierarchical display list of movie clips currently loaded in 
the Flash Player. You can then use the Debugger to display and modify 
variables and property values as the .swf file plays. You can insert 
breakpoints to stop the .swf file and step through the ActionScript code 
line-by-line. You can even use the Debugger panel to test files on a Web 
server in a remote location. The Debugger lets you set breakpoints in 
your ActionScript that stop the Flash Player, and then lets you step 
through the code as it runs. You can then go back to your scripts and 
edit them so that they produce the correct results. The Debugger will 
show you where the problems are, but it doesn't fix them. 

Debugging for 
ActionScript 2.0

Use the Debugger for 
ActionScript 2.0

Create or open a Flash document 
(ActionScript 2.0).

Click the Debug menu, point to 
Debug Movie, and then click 
Debug.

The Code View panel displays a 
message indicating the movie is 
paused.

Click the Continue button to start 
the movie.

Click the Stop Debugging button to 
turn off the Debugger panel.

Click inside the code, and then 
click the Toggle Breakpoint button 
to add or remove a breakpoint at 
the insertion point of the cursor. 

Breakpoints stop the movie from 
playing and allow you to step 
through the code line-by-line.

Click the Remove All Breakpoints 
button to remove all the 
breakpoints from the code.

Click the Step Over, Step In, and 
Step Out buttons to step through 
each line of an ActionScript.

8
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Testing Your Movie
When you use the Test command to test movies that implement key-
board shortcuts, click the Control menu, and then click Disable 
Keyboard Shortcuts. This prevents Flash from interpreting key-
strokes, and lets them pass through to the player. For example, you 
can have a Flash document that uses Ctrl+U to display a file or video. 
However, Flash uses Ctrl+U to display the Preferences panel. If you 
don't Disable Keyboard Shortcuts, pressing Ctrl+U in the Flash player 
will actually open Flash Preferences.

For Your Information
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When you work in the debugger, you have the option of viewing any 
variables used in the Flash movie. The Variables tab (ActionScript 2.0) 
or Variables panel (ActionScript 3.0) displays the names and values of 
any global and variables in the .swf file. If you change the value of a 
variable, you can see the change reflected in the .swf file while it runs. 
This gives you the ability to test new data variables and their impact on 
the Flash player document.

Viewing Variables

View Variables

Click the Debug menu, point to 
Debug Movie, and then click 
Debug.

Select the movie clip containing 
the variable from the display list.

Select an item in the display frame 
to view the variables’ names and 
values.

Click the Continue button to 
observe the variables as the Flash 
movie runs. 

Click the Variables tab 
(ActionScript 2.0) or open the 
Variables panel (ActionScript 3.0).

IMPORTANT The display list 
updates automatically as the .swf 
file plays. When a movie clip is 
removed from the .swf file at a 
specific frame, the movie clip, 
variable and variable name are 
removed from the display list in the 
Debugger panel. This lets you 
focus on the current variables. 
When you're viewing a complex 
Flash movie that contains a lot of 
variables, only having to view the 
current variables cuts down on the 
visual clutter and helps you to 
focus on the immediate problem.
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Variables panel 
(ActionScript 3.0)

 From the Library of Wow! eBook



ptg

422 Chapter 17

Adding Variables to 
the Watch List

Add Variables

In a Flash document (ActionScript
2.0), click the Debug menu, point to 
Debug Movie, and then click 
Debug.

Click the Variables or Locals tab, 
and then select a variable.

Click the Debugger Options button, 
and then click Watch.

Click the Watch tab.

Click the Debugger Options button, 
and then click Add Watch.

Enter the target path to the 
variable name and the value in the 
fields.

IMPORTANT To remove 
variables from the Watch list, 
select a variable on the Watch tab, 
click the Debugger Options button, 
and then click Remove Watch. 
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In any complex Flash movie, there will probably be a set of critical vari-
ables that you want to keep an eye on. You can monitor critical vari-
ables in a controllable way by marking them to appear in the Debugger 
panel Watch list (ActionScript 2.0). The Watch list displays the absolute 
path to the variable and its current value, and just like the Variables 
tab, you can enter a new variable value at any time during the debug-
ging process. If you add a local variable to the Watch list, its value 
appears only when Flash Player is stopped at a line of ActionScript 
where that variable is in scope. All other variables appear while the 
.swf file is playing. If the Debugger can't find the value of the variable, it 
will list the value as undefined.

6
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The Properties tab in the Debugger panel displays all property values of 
any movie clip on the Stage. Properties are modifiable script elements 
such as _alpha (controls transparency) or _rotation (controls the rota-
tion of an object). The Properties tab lists all the properties including 
their current values. You can then view and adjust the values as the 
Flash movie is running to judge their impact. This gives you a tremen-
dous amount of control over the debugging process.

Viewing Properties

View Properties

In a Flash document (ActionScript
2.0), click the Debug menu, point to 
Debug Movie, and then click 
Debug.

Select an available movie clip from 
the Display list.

Click the Properties tab to view all 
the properties, and their 
associated values.

Double-click on a value, and then 
enter a new value in any available 
property.

Click the Continue button to view 
how the Properties change as the 
Flash movie executes. 

IMPORTANT The Property 
value is picky about what you 
enter. For example, you can enter 
a value of 100 or text within quotes 
such as: "newvalue", but you 
cannot enter expressions such as: 
y + 12, or an array of values such 
as: 1, 2, 3. 
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Breakpoints are instructions to the Debugger to halt the running of a 
Flash movie. For example, you're watching how the .swf file plays using 
the debugger, however, it's moving so fast it's difficult to watch every-
thing. By inserting a breakpoint, you instruct the Debugger to halt the 
movie, and any variables and properties will display the values associ-
ated with that point in time. You can then change the values, and 
instruct the Debugger to continue playing the movie, using the modified 
values.

Setting Breakpoints

Set Breakpoints

Click the Debug menu, point to 
Debug Movie, and then click 
Debug.

Click in the left margin next to the 
line of code where you want the 
breakpoint (red dot) to appear.

◆ You can also click the Toggle 
Breakpoint button (ActionScript
2.0) to add/remove a 
breakpoint.

To remove a breakpoint, click the 
existing breakpoint (red dot) in the 
left margin.

Click the Continue button to begin 
playing the Flash .swf file.

The Debugger will stop the movie 
at each breakpoint.

4

3

2
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Breakpoint

Did You Know?
You can set or remove breakpoints in 
the Actions panel. In the Actions panel 
(ActionScript 2.0), click in the line you 
want, click the Debug Option button, 
and then select a command to set or 
remove breakpoints.

You cannot set a breakpoint on a com-
ment line. If you set a breakpoint in a 
comment (or empty line) in the Actions 
panel, the breakpoint will be ignored by 
the Debugger.

Toggle Breakpoint

2

3

Breakpoints

ActionScript 3.0
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When you open the Debugger, the Flash Player is automatically paused. 
This gives you the opportunity to set breakpoints in the script (see pre-
vious lesson: Setting Breakpoints). Once the breakpoints are set, you 
can click the Continue or Play button, and the Debugger will play the 
.swf file until it encounters a breakpoint. When a breakpoint is reached, 
the Debugger again pauses the movie. You now have the option to step 
in, out, or through the breakpoint script. 

Stepping Through 
Code

Step Through Code

Click the Debug menu, point to 
Debug Movie, and then click 
Debug.

Add breakpoints by clicking in the 
left margin next to the line of code 
where you want the breakpoint. To 
remove a breakpoint, click it. 

Click the Continue button.

Flash will stop at the first 
breakpoint.

Select from the step options:

◆ Continue. Click to leave the line 
at which the player is stopped 
and continue playing.

◆ Stop Debugging. Click to 
deactivate the Debugger, but 
continue to play the SWF file.

◆ Step In. Click to step into and 
execute a function (works only 
for user-defined functions). 

◆ Step Out. Click to move out of a 
function (works only if you are 
currently stopped in a user-
defined function).

◆ Step Over. Click to skip over a 
line of code.

IMPORTANT If you want to 
know where the Debugger 
stopped, keep an eye on the 
yellow arrow. A yellow arrow 
along the left side of the 
Debugger's code view indicates 
the line at which the Debugger 
stopped.

4

3

2

1 
3 2

The Yellow Arrow indicates 
where the Debugger stopped.

Stop Debugging 4Continue

Current breakpoints
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Debugging a Flash movie manually means exactly what it implies. You 
can open the movie and take it for a test drive. Debugging a movie 
manually gives you a chance to be the visitor, and experience your 
movie exactly as they would. When you manually test a Flash movie, 
you want to experience the wait time for downloading, you want to for-
get that you created this masterpiece, and you want to come at it just 
as if you were a first-time viewer. A Flash movie is composed of text, 
video, audio, images, animation, and ActionScript. Your visitors will 
never see the ActionScript code, and most do not care how it was writ-
ten; but they will care if it doesn't work properly. For example, your visi-
tor clicks a button to load a video file, and the video never loads, or it 
takes so long to load that they get bored and leave. Problems like these 
are what manual debugging can solve.

Debugging Manually

Debug Manually

Click the Control menu, point to 
Test Movie, and then click Test to 
test the entire Flash movie, or click 
Test Scene to test the active 
scene.

IMPORTANT Flash uses the 
settings described in the Publish 
Settings dialog box to test the 
movie. Use different settings such 
as Flash plug-in, to test the movie 
against earlier versions of the 
Flash plug-in.

Test the movie for any structural 
failures. Click all the buttons, and 
then do all the things you think a 
visitor would do.

Note any problems on paper 
(remember this is manual) in a list, 
called a debug, or edit list. The list 
can then be used to edit the 
document, using Flash's standard 
editing tools.

3

2

1

Click and test all the 
buttons and input fields. 

See Also
See Chapter 20, “Publishing a Movie” 
on page 477 for information on modify-
ing publishing settings.

Debugging Flash Player
When Adobe Flash is installed, the debug version of the Adobe Flash 
Player is installed for the application as well as any browser speci-
fied. While this debug version of the player can be very useful when 
authoring, there may be situations where the standard player is 
desired. If you would like to uninstall the debug player, point your 
browser to: http://www.adobe.com/support/flash/ts/documents 
/remove_player.htm, and then follow the on-screen instructions. You 
can then point your browser to: http://www.adobe.com/shockwave 
/download/download.cgi?P1_Prod_Version=ShockwaveFlash, and 
download the current version of the player.

For Your Information
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Adding and Modifying 
Components

Introduction

Components are building blocks that you can use to create 
interactive, dynamic Flash documents. Think of a component 
as a movie clip with modifiable parameters, which are set 
during the design of a Flash document, and ActionScript APIs 
(APIs allow you to customize the component at runtime). 
Since components are reusable, they give developers the 
ability to share code between projects. You can use compo-
nents created by Adobe, download components created by 
other developers or, with a bit of practice create your own 
components. Since components are rooted in ActionScript 
code, Flash comes with a set of components for ActionScript
2.0 and another one for ActionScript 3.0, and you cannot mix 
components in the same Flash document. 

Suppose you want to create a list of options from which a 
visitor would be able to click and choose. You can open the 
Actions panel, and then create the list by typing in about 
forty or more lines of script, or you can use Flash's built-in 
component to create the list. The difference is not in the qual-
ity of the list, but the amount of time it took to create it. 
Spending less time on creating dynamic, interactive Flash 
elements gives you more time to concentrate on design fea-
tures. To a Flash visitor, it's not about the code or how long it 
took you to create it, it's about the design, and it will always 
be about the design. 18

18
What You’ll Do

Understand Basic Components

Add a Text Input 

Add a Combo Text Box 

Add a Check Box 

Add a Radio Button 

Add a Text Area 

Add a Button 

Add a List 

Add a Label 

Add a Data Grid

Use a Local Data Provider

Add a Loader

Add a Numeric Stepper

Add a Progress Bar

Add a Scroll Pane

Create and Modify Bindings

Modify Schema

Modify Component Attributes 

Use Components to Build a Form

427
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Components are composed of two elements: 
a movie clip and parameters, allowing you to 
modify the components’ appearance and 
behavior. Components run the gamut from a 
radio button to a scroll pane. Components 
equalize the designer's playing field, enabling 
anyone to build complex applications, even if 
they do not have a complete understanding 
of the ActionScript language. As easy as it is 
to simply drag the component you need from 
the Components panel onto the Stage, it is 
just as easy to customize the look and feel of 
components to suit your design needs. 

Components let you easily and quickly 
build strong applications with a consistent 
appearance and behavior. Each component 
comes with predefined parameters, located in 
the Property Inspector (New!), which let you

Understanding Basic Components

control how the object looks and operates. 
Each component also includes a set of API 
(application programming interface) methods 
and properties that allows you to set parame-
ters and additional options at runtime. This is 
typically accomplished by adding the scripts 
to Frame 1 in the Flash Timeline. It is said 
that Flash components finally allow for the 
separation of coding and design. 

Using the Components Panel
Components are added to the Stage using the 
Components panel. To add a component to 
the Stage, you open the Components panel, 
expand the Components list, and then drag a 
component icon onto the Stage. Since com-
ponents are based on ActionScript code, 
Flash comes with a set of components for

Flash 
Components

Components 
panel

Available 
Settings

Loader component in the Property Inspector

 From the Library of Wow! eBook



ptg

Chapter 18 Adding and Modifying Components 429

Accessibility 
panel

ActionScript 2.0 and another one for 
ActionScript 3.0, and you cannot mix compo-
nents in a Flash document. You specify the 
components type by selecting an ActionScript 
version in the Publishing Settings dialog box.

There are three categories of components 
for ActionScript 2.0—user interface, media, 
and video—and three categories of compo-
nents for ActionScript 3.0—Flex, user interface 
and video. ActionScript 3.0 provides similar 
components as ActionScript 2.0. However, the 
parameters associated with a component may 
vary. User interface components allow you to 
interact with an application (RadioButton, 
Checkbox, and TextInput). Video components 
allow you to add video playback controls, 
such as FLVPlayback, FLVPlayback with cap-
tioning, Back, Forward, Mute, Pause, Play, 
Play/Pause, Seek Bar, Stop, and Volume Bar. 
Media components (ActionScript 2.0) allow 
you to play back and control streaming media 
(MediaController, MediaPlayback, and 
MediaDisplay).

After you add an instance of a component 
to a Flash document (drag a component to the 
Stage), you can give the component a unique 
instance name using the Property Inspector 
and then use the Component Inspector panel 
to set and view information for the instance. 

Using the Component Inspector
Once the component is on the Stage, it is con-
trolled through the Component Inspector 
panel. The Component Inspector panel has 
three tabs: Parameters, Bindings, and 
Schema. Each tab gives you modifiable ele-
ments to help control the look and functional-
ity of the component.The Parameters tab 
(now moved to the Property Inspector (New!)) 
lists the most commonly used properties; oth-
ers parameters can be added using the 
ActionScript panel. The Bindings tab gives you

a way to bind, or link two or more compo-
nents together. For example, you can bind an 
external database to a display component for 
on-screen viewing of the data. The Schema 
tab contains a list of a component's bindable 
properties, data types, internal structure, and 
other special attributes.

Using the Accessibility Panel
When you work with Flash components, you 
can create Flash content that is accessible to 
users with disabilities using Flash accessibly 
features. As you design accessible Flash 
applications, consider how your users will 
interact with the content. Visually impaired 
users might rely on additional technology, 
such as screen readers, while hearing-
impaired users might read text and captions 
in the document. To make a Flash Component 
accessible, click the Window menu, point to 
Other Panels, and then click Accessibility to 
open the Accessibility panel. For more infor-
mation on creating accessible compliant doc-
uments, open your browser and visit 
www.w3.org/WAI/, or for information on 
Flash, open your browser and visit 
www.adobe.com/, go to the Flash Exchange, 
and then type the word "accessibility" in the 
keyword field. 
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The power of a component is its ability to 
change. Components can be modified directly 
in the Component Inspector panel, or they 
can be modified dynamically, as the Flash 
movie runs. The Component Inspector panel 
has three areas to modify a component— 
Parameters, Bindings, and Schema. These 
three tabs allow you to attach components to 
data files, change or modify the text on a but-
ton, or create drop-down menus and lists.

Setting Parameters Options
After adding an instance of a component to a 
Flash document, you can name the instance 
at the top of the Property Inspector, and then 
specify the parameters for the instance using 
the options and fields under Component 
Parameters in the Property Inspector (New!).

Each component has parameters that you 
can set to change the instance’s appearance 
and behavior. A parameter is a property or 
method that appears in the Property 
Inspector. The most commonly used proper-
ties and methods appear as authoring param-
eters; others can be set using ActionScript. 
Authoring parameters represent common 
things such as the label attached to a Button 
component, or items displayed when using 
the List component. If you set a parameter 
using ActionScript, it will override any value 
set while authoring. 

Understand that each component will have 
its own unique parameters, and changing 
parameters in the Property Inspector only 
changes the selected instance. Parameters 
include the ability to change an instance's

Working with the Component Inspector

Component Parameters in the Property Inspector Bindings tab
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that the Bindings tab needs in order to handle 
your data correctly. For example, you can click 
the Schema tab, define the binding compo-
nent (DataGrid), and then use the Bindings 
tab to link the DataGrid component to the 
external XML file. 

The top portion of the Schema tab dis-
plays bindable properties associated with the 
selected component, while the bottom portion 
of the Schema tab displays detailed informa-
tion about the selected schema item (selected 
from the top portion of the Schema tab), and 
gives you the ability to view or edit them.

font, color, and size. You can add additional 
parameters by selecting the instance on the 
Stage and typing the script into the Actions 
panel. If you add the script to Frame 1 in the 
Timeline, you can create global changes to 
instance parameters.

Setting Binding Options
Data Binding is a concept where the property 
of one component can be bound to the 
property of another component: if the prop-
erty of the one component changes, so will 
the property of the other component or com-
ponents. The Bindings tab defines a link 
between two endpoints, a source (external 
data file, movie clip, graphic) and a destina-
tion component (DataGrid, Loader, Label). It 
listens for changes to the source endpoint 
and copies the changed data to the destina-
tion endpoint each time the source changes. 

Setting Schema Options
Schemas are important because they help 
create a communication link between other 
components, using the Bindings tab. A com-
ponent's schema simply represents the prop-
erties and fields that are available for data 
binding. Each property or field contains set-
tings that control validation, formatting, type 
conversion, and other features that affect how 
data binding and the data management com-
ponents handle the data of a field. 

The Schema tab lets you view the schema 
for the selected component. Schema is basi-
cally a list of the component's binding proper-
ties, their data types, their internal structure, 
and other special attributes, depending on the 
selected component. This is the information

Schema tab
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The TextInput component works with the ActionScript TextField object. 
Once a TextInput component is added to the Stage, you can use styles 
to customize the font, size, and color. A TextInput component can be 
formatted using HTML, or even as a password field that disguises the 
text. When a TextInput field has focus, visitors can use the arrow keys 
to move through information in the field, and they can use the tab key 
to move the focus to the next object, or Shift+Tab to move to the previ-
ous object. TextInput fields can be used to hold information. For exam-
ple, you could use a group of TextInput components as the basis for 
creating an interactive form for fields such as: name, address, city, 
state, and zip code.

Adding a Text Input 

Add a TextInput Component

Open the Components panel.

Click the User Interface arrow to 
expand the list.

Drag the TextInput component 
onto the Stage, and then select the 
component.

Open the Properties panel, and 
then click the Component 
Parameters arrow to expand it.

Select from the following Text 
Input parameters:

◆ editable. When you select the 
check box, the field can be 
edited. If you select false, the 
field can be selected but not 
edited.

◆ password (2.0) or display 
AsPassword (3.0). When you 
select the check box, text 
entered into the field appears 
as dots. If you select false, text 
typed into the field appears as 
typed.

◆ text. Click the Value field, and 
then enter the text that will 
appear in the field when the 
Flash document opens. 
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◆ maxChars. Click the Value field, 
and then enter a numerical 
value indicating the max 
characters allowed in the 
TextInput field.

◆ restrict. Click the Value field, 
and then enter any characters 
that cannot be entered into the 
TextInput field.

◆ enabled. When you select the 
check box, the field can be 
edited. If you select false, the 
field appears grayed out and is 
not selectable or editable.

◆ visible. When you select the 
check box, the field can be 
viewed. If you select false, the 
field is invisible.

◆ minHeight (2.0). Click the Value 
field, and then enter a minimum 
height for the TextInput box.

◆ minWidth (2.0). Click the Value 
field, and then enter a minimum 
width for the TextInput box.

Click the Control menu, point to
Test Movie, and then click Test.

IMPORTANT Although you can 
change the size of any component 
using the Free Transform tool, 
since the TextInput component is a 
single-line component, changing 
its height does not impact how 
many lines of text you can type.

6

TextInput 
component

5

4
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The ComboBox component creates a drop-down list of selectable 
options. They can be either static or editable. The static ComboBox 
component allows a user to make a single selection from a drop-down 
list. An editable ComboBox component lets users enter text into a text 
field located at the top of the list, as well as selecting an item from a 
drop-down list. A ComboBox component is composed of three subcom-
ponents: Button, TextInput, and List components. When a visitor selects 
an item, the label of the selection is automatically copied to the text 
field at the top of the combo box. The ComboBox component is an 
excellent way to offer several choices to a user, without the necessity 
of them having to type in a response. For example, a ComboBox could 
be used to list all of the states in the union in a drop-down box, giving 
the user the chance to select his home state. When the ComboBox dis-
plays in a Flash document, it appears as a single line; clicking the trian-
gle to the right of the line expands the box and displays all the available 
options.

Adding a Combo 
Text Box

Add a ComboBox Component

Open the Components panel.

Click the User Interface arrow to 
expand the list.

Drag the ComboBox component 
onto the Stage, and then select the 
component.

Open the Properties panel, and 
then click the Component 
Parameters arrow to expand it.

Select from the following 
ComboBox parameters:

◆ data (2.0) or dataProvider (3.0). 
Click the Edit button, and then 
enter an array in the Values 
dialog box. Click the plus (+) 
sign to add values and the 
minus sign (-) to remove a 
value. Data values are used to 
populate the drop-down list.

◆ editable. When you select the 
check box, the field can be 
edited. If you select false, the 
field can be selected but not 
edited.
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◆ labels (2.0). Click the Edit 
button, and then enter an array 
in the Values dialog box. Click 
the  plus (+) sign to add values, 
and the minus sign (-) to 
remove a value. Data values 
are used as the selectable 
items in the list. 

◆ rowCount. Click the Value field, 
and then enter a number to 
determine the maximum height 
of the drop-down list.

◆ enabled. When you select the 
check box, the items in the list 
can be selected. If you select 
false, the field appears grayed 
out and is not selectable.

◆ prompt (3.0). Click the Value 
field, and then enter a prompt 
message text.

◆ visible. When you select the 
check box, the field can be 
viewed. If you select false, the 
field is invisible.

◆ minHeight (2.0). Click the Value 
field, and then enter a minimum 
height for the ComboBox box.

◆ minWidth (2.0). Click the Value 
field, and then enter a minimum 
width for the ComboBox box.

IMPORTANT If there is not 
enough room for the ComboBox to 
open without hitting the bottom of 
the document, it will open up 
instead of down.

Click the Control menu, point to 
Test Movie, and then click Test.

When you click the Select Your 
Country list arrow, the list will 
open, and a selection can be made 
by clicking on one of the available 
options.

6

6

Use to add, remove and order values

Enter values

5

4 Click to add values
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A check box is simply a square box that the user can select or dese-
lect. When it is selected, a check mark appears in the box. When a 
selected check box is clicked, the check mark is removed. The state of 
a CheckBox component does not change until the mouse is released 
over the component. 

Adding a Check Box

Add a CheckBox Component

Open the Components panel.

Click the User Interface arrow to 
expand the list.

Drag the CheckBox component 
onto the Stage, and then select the 
component.
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CheckBox component

Did You Know?
You can control the state of a 
CheckBox component without the 
mouse. If the CheckBox component 
has focus (selected), pressing the 
Spacebar selects or deselects the 
check mark. 
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Open the Properties panel, and 
then click the Component 
Parameters arrow to expand it.

Select from the following
CheckBox parameters:

◆ enabled (3.0). When you select 
the check box, the items in the 
list can be selected. If you 
select false, the field appears 
grayed out and is not 
selectable.

◆ label. Click the Value field, and 
then enter a label for the check 
box.

◆ labelPlacement. Click the Value 
field, and then select between 
right, left, top, or bottom for the 
placement of the label text.

◆ selected. When you select the 
check box, the field appears 
with a checkmark, or deselect 
the check box, the field 
appears without a check mark.

◆ visible (3.0). When you select 
the check box, the field can be 
viewed. If you select false, the 
field is invisible.

To change the width and height of 
the check box component, select 
the component, and then drag a 
resize handle to change the width 
and height.

Click the Control menu, point to
Test Movie, and then click Test.

Click in the CheckBox component 
to add a check mark, and then 
click a second time to remove the 
check mark.
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The RadioButton component lets you do something that the CheckBox 
component cannot do: force a user to make a single choice within a set 
of choices. The RadioButton component must be used in a group of at 
least two RadioButton instances, and only one member of the group 
can be selected at any given time. Selecting one radio button in a 
group will deselect the currently selected radio button in the group. For 
example, a radio button options for Gender can be Male, Female. There 
can be only one answer to that question, so you would group the two 
items using RadioButton components.

Adding a Radio 
Button

Add a RadioButton Component

Open the Components panel.

Click the User Interface arrow to 
expand the list.

Drag one or more RadioButton 
components onto the Stage, and 
then select one at time.

Open the Properties panel, and 
then click the Component 
Parameters arrow to expand it.
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RadioButton component

Did You Know?
A visitor can control a radio button 
selection with the keyboard. Click the 
Tab key until one of the buttons within 
the group receives focus (is selected), 
and then use the left and right arrow 
keys to change the selection within the 
group. Having the ability to use the 
keyboard makes Flash components 
compliant with the current rules on 
accessibility as set by the U.S. 
Congress.
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Select from the following
RadioButton parameters:

◆ data (2.0) or value (3.0). Click 
the Value field, and then enter a 
value that will be used to 
populate the RadioButton.

◆ groupName. Click the Value 
field, and then enter a group 
name for the button. When you 
associate a group name to 
several RadioButton 
components, the visitor will 
only be able to select one 
button in the group.

◆ label. Click the Value field, and 
then enter a label for the 
RadioButton.

◆ labelPlacement. Click the Value 
field, and then select between 
right, left, top, or bottom for the 
placement of the label text.

◆ selected. When you select the 
check box, the field appears 
selected. If you deselect the 
check box, the field appears 
unselected.

◆ enabled (3.0). When you select 
the check box, the items in the 
list can be selected. If you 
deselect the check box, the 
field appears grayed out and is 
not selectable.

◆ visible (3.0). When you select 
the check box, the field can be 
viewed. If you deselect the 
check box, the field is invisible.

Click the Control menu, point to
Test Movie, and then click Test.

Since the RadioButton 
components both use the same 
Group name, you can only select 
one button.
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The TextArea component works with the ActionScript TextField object. 
Once a TextArea component is added to the Stage, you can use styles 
to customize font, size, and color. In addition, a TextArea component 
can be formatted using HTML. If this sounds similar to the TextInput 
component, you're right. In fact, the major difference between a 
TextInput and a TextArea field is the ability of the TextArea field to gen-
erate multiple lines. TextArea fields can be used to hold information. For 
example, you can use a TextArea component to create a comment or a 
suggestion field on an interactive form.

Adding a Text Area

Add a TextArea Component

Open the Components panel.

Click the User Interface arrow to 
expand the list.

Drag the TextArea component 
onto the Stage, and then select the 
component.

Open the Properties panel, and 
then click the Component 
Parameters arrow to expand it.

Select from the following TextArea 
parameters:

◆ condenseWhite (3.0). When 
you select the check box, it 
removes extra white space 
(spaces, line breaks) in a text 
field. If you deselect the check 
box, the white space remains.

◆ editable. When you select the 
check box, the field can be 
edited. If you deselect the 
check box, the field can be 
selected but not edited.

◆ html (2.0). When you select the 
check box, it allows HTML to 
control the formatting of the 
data. If you deselect the check 
box, the field cannot be 
modified using HTML.

◆ text. Click the Value field, and 
then enter the initial text that 
will appear in the TextArea 
component.
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◆ wordWrap. When you select 
the check box, the text typed by 
the visitor wraps in the 
TextArea box. If you deselect 
the check box, the text will not 
wrap.

◆ maxChars. Click the Value field, 
and then enter the maximum 
number of characters that can 
be typed into the TextArea 
component.

◆ restrict. Click the Value field, 
and then enter any characters 
that cannot be entered into the 
TextArea field. 

◆ enabled. When you select the 
check box, the field can be 
edited. If you deselect the 
check box, the field appears 
grayed out and is not 
selectable, or editable. 

◆ visible. When you select the 
check box, the field can be 
viewed. If you deselect the 
check box, the field is invisible.

◆ minHeight (2.0). Click the Value 
field, and then enter a minimum 
height for the TextArea.

◆ minWidth (2.0). Click the Value 
field, and then enter a minimum 
width for the TextArea.

◆ horizontal or vertical
ScrollPolicy (3.0). Click the 
Value field, and then select 
auto, on, or off to show or hide 
scroll bars.

Click the Control menu, point to
Test Movie, and then click Test.

In the example, visitors can type 
as much information as needed, 
and when the box fills up, scroll 
bars appear to the right of the box; 
allowing them to maneuver up and 
down through the document.

6

6

5

4

 From the Library of Wow! eBook



ptg

442 Chapter 18

The Button component is a clickable rectangular button, which can be 
resized. If you desire, you can add a custom icon to the Button compo-
nent. In addition, you can change the behavior of a Button component 
from push to toggle. A toggle button stays pressed when clicked and 
returns to its up state when clicked again. All of these options are 
accomplished through the Component Inspector panel.

Adding a Button

Add a Button Component

Open the Components panel.

Click the User Interface arrow to 
expand the list.

Drag the Button component onto 
the Stage, and then select the 
component.

Open the Properties panel, and 
then click the Component 
Parameters arrow to expand it.

Select from the following Button 
parameters:

◆ icon (2.0). Click the Value field, 
and then enter the full path 
name to an icon file.

◆ emphasized (3.0). When you 
select the check box, it adds a 
border around the button. If you 
deselect the check box, the 
button is normal.

◆ label. Click the Value field, and 
then enter a label for the 
Button component.

◆ labelPlacement. Click the Value 
field, and then select between 
right, left, top, or bottom for the 
placement of the Button 
component text.

◆ selected. When you select the 
check box, the button appears 
selected. If you deselect the 
check box, the button is normal 
or deselected. 
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◆ toggle. When you select the 
check box, the button, when 
selected, returns a true value. If 
you deselect the check box, the 
button returns false when 
selected.

◆ enabled. When you select the 
check box, the button can be 
clicked. If you deselect the 
check box, the button is grayed 
out and cannot be clicked.

◆ visible. When you select the 
check box, the Button can be 
viewed. If you deselect the 
check box, the Button is 
invisible.

◆ minHeight (2.0). Click the Value 
field, and then enter a minimum 
height for the Button.

◆ minWidth (2.0). Click the Value 
field, and then enter a minimum 
width for the Button.

Click the Control menu, point to 
Test Movie, and then click Test.

In the example, when you click the 
button, it changes color, just like a 
typical rollover button. You could 
now attach an ActionScript to the 
button to load another scene or 
movie.
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The List component is a scrollable box that lets users select one or 
more items in the list. Lists are similar to the ComboBox component, 
except List components can be formatted to display all of the available 
items at once, where as the ComboBox component uses a drop-down 
(or up) feature to display the items only when requested (clicking the tri-
angle button to the right of the list). 

Adding a List

Add a List Component

Open the Components panel.

Click the User Interface arrow to 
expand the list.

Drag the List component onto the 
Stage, and then select the 
component.

Open the Properties panel, and 
then click the Component 
Parameters arrow to expand it.

IMPORTANT The List 
component reduces the clutter of 
a typical data screen by allowing 
you to control the height of a data 
box. For example, if you wanted a 
visitor to select their home State 
from a list, you wouldn't want all
50 States permanently displayed 
on the screen. You would create a 
more manageable box size, and 
make the visitor scroll up or down 
to select the correct State.

Select from the following List 
parameters:

◆ data (2.0) or dataProvider (3.0). 
Click the Edit button, and then 
enter an array in the Values 
dialog box. Click the plus (+) 
sign to add a value, and the 
minus sign (-) to remove a 
value. Data values are used to 
populate the list labels.

◆ enabled (3.0). When you select 
the check box, the field can be 
clicked. If you deselect the 
check box, the field is grayed 
out and cannot be clicked.

5

4

3

2

1 1

2

3

List component

 From the Library of Wow! eBook



ptg

Chapter 18 Adding and Modifying Components 445

◆ labels (2.0). Click the Edit 
button, and then enter an array 
in the Values dialog box. Click 
the plus (+) sign to add a value, 
and the minus sign (-) to 
remove a value. Data values 
are used as the selectable 
items in the list.

◆ multipleSelection (2.0) or 
allowMultipleSelection (3.0). 
When you select the check 
box, the visitor can select more 
than one item in the list. If you 
deselect the check box, the 
visitor can only select a single 
item.

◆ rowHeight (2.0). Click the Value 
field, and then enter a number 
to determine the spacing 
between items in the list. The 
higher the value, the more 
space between items.

◆ horizontal or vertical
ScrollPolicy (3.0). Click the 
Value field, and then select 
auto, on, or off to show or hide 
scroll bars.

◆ horizontal or vertical Line or 
Page ScrollSize (3.0). Click the 
Value field, and then enter a 
number for the scroll size.

◆ visible (3.0). When you click the
Value field, and select true, the 
list can be viewed. If you select 
false the list is invisible.

Click the Control menu, point to
Test Movie, and then click Test.

In the example, click on a Chapter, 
and then select that chapter. You 
can now attach an ActionScript to 
the list to load the correct chapter. 
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A Label component consists of a single line of text. You can specify that 
a label be formatted with HTML. You can also control alignment and 
sizing of a label. Label components do not have borders, nor do they 
contain input that can be changed by the user. They are simply text 
information. Labels can be used to identify data input fields, or they can 
contain visitor information important to the understanding of a form. 
Labels can change what they display, as the Flash movie plays.

Adding a Label

Add a Label Component

Open the Components panel.

Click the User Interface arrow to 
expand the list.

Drag one or more Label 
components onto the Stage, and 
then select the component, one at 
a time.

Open the Properties panel, and 
then click the Component 
Parameters arrow to expand it.

Select from the following Label 
parameters:

◆ autoSize. Click the Value field, 
and then select between left, 
center, right, or none. The 
autoSize parameter uses this 
information when automatically 
resizing the text.

◆ condenseWhite (3.0). When you 
select the check box, it 
removes extra white space 
(spaces, line breaks) in a text 
field. If you deselect the check 
box, the white space remains.

◆ enabled (3.0). When you select 
the check box, the field can be 
edited. If you deselect the 
check box, the field appears 
grayed out and is not 
selectable, or editable.
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◆ html (2.0). When you select the 
check box, it allows HTML to 
control the formatting of the 
text. If you deselect the check 
box, the field cannot be 
modified using HTML.

◆ text. Click the Value field, and 
then enter the text that will 
appear in the field when the 
Flash document opens.

◆ selectable (3.0). When you 
select the check box, the field 
text is selectable. If you 
deselect the check box, the 
field text is not selectable. 

◆ visible. When you select the 
check box, the field can be 
viewed. If you deselect the 
check box, the field is invisible.

◆ minHeight (2.0). Click the Value 
field, and then enter a minimum 
height for the Label.

◆ minWidth (2.0). Click the Value 
field, and then enter a minimum 
width for the Label.

◆ wordWrap (3.0). When you 
select the check box, the text 
typed by the visitor wraps in 
the TextArea box. If you 
deselect the check box, the 
text will not wrap

Click the Control menu, point to
Test Movie, and then click Test.

In the example, the Label 
components represent visitor 
information in which the labeling 
fields require visitor input.
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The DataGrid component allows you to create strong data-enabled dis-
plays and applications. You can use the DataGrid component to create 
a recordset (retrieved from a database query in ColdFusion, Java, or 
.Net) using Adobe Flash Remoting and display it in columns. You can 
also use data from a data set or from an array to fill a DataGrid compo-
nent. The DataGrid component includes horizontal scrolling, event sup-
port (including event support for editable cells), sorting capabilities, 
and performance optimizations. The data for a grid can come from a 
recordset that is fed from a database query in Adobe ColdFusion, Java, 
or .Net using Flash Remoting, a data set or an array. To pull the informa-
tion into a DataGrid, you set the DataGrid.dataProvider property to the 
recordset, data set, or array. 

Adding a Data Grid

Add a DataGrid Component

Open the Components panel.

Click the User Interface arrow to 
expand the list.

Drag the DataGrid component onto 
the Stage, and then select the 
component.

Enter a unique instance name for 
the DataGrid component in the 
Property Inspector.

Select Frame 1 in the actions layer 
in the Timeline.

Open the Actions panel, and then 
enter the script as shown in the 
illustration.

The Flash Remoting recordset 
recordSetInstance is assigned to 
the dataProvider property of 
myDataGrid.
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Did You Know?
You can resize or copy the DataGrid.
Select the Transform tool from the tool-
box, and then use the resize nodes to 
change the width and height. To copy 
the DataGrid, select the Selection tool, 
hold down the Alt key (Win), Option key 
(Mac), and then drag the component. 
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Modify DataGrid Options

Select the DataGrid component.

Open the Properties panel, and 
then click the Component 
Parameters arrow to expand it.

Select from the following DataGrid 
parameters:

◆ editable. When you select the 
check box, the field can be 
edited. If you deselect the 
check box, the field can be 
selected but not edited.

◆ mutipleSelection (2.0) or 
allowMultipleSelection (3.0). 
When you select the check 
box, the visitor can select more 
than one item. If you deselect 
the check box, the visitor can 
only select a single item.

◆ headerHeight (3.0). Click the
Value field, and then enter a 
header height.

◆ rowHeight. Click the Value 
field, and then enter a number 
to determine the spacing 
between items in the list. The 
higher the value, the more 
space between items.

◆ horizontal or vertical
ScrollPolicy (3.0). Click the 
Value field, and then select 
auto, on, or off to show or hide 
scroll bars.

◆ horizontal or vertical Line or
Page ScrollSize (3.0). Click the 
Value field, and then enter a 
number for the scroll size.

◆ resizableColumns (3.0). When 
you select the check box, 
columns are resizeable. 

◆ showHeaders (3.0). When you 
select the check box, headers 
are displayed. 

◆ sortableColumns (3.0). When 
you select the check box, 
columns are sortable. 

3

2

1

Editable field Multiple Selection field

3

2
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Using a Local 
Data Provider

Use a Local Data Provider

Open the Components panel.

Click the User Interface arrow to 
expand the list.

Drag the DataGrid component onto 
the Stage, and then select the 
component.

Enter a unique instance name for 
the DataGrid component in the 
Property Inspector.

Select Frame 1 in the actions layer 
in the Timeline.

Open the Actions panel, and then 
enter the script as shown in the 
illustration.

Click the Control menu, point to 
Test Movie, and then click Test.

The name and home fields are the 
column headings for the DataGrid 
component, and the values fill the 
cells in each row.
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The DataGrid component lets you provide data using a local (embedded 
in the document) data provider. The data is read into the grid from a 
pre-written ActionScript, and since Flash components are on the Stage, 
the ActionScript would typically be entered into the first frame of the 
Flash Timeline. It's smart programming to create a separate layer to 
hold the ActionScript for the DataGrid. That way you have much easier 
access to the script.

1

DataGrid 
component

5

32

Did You Know?
You can use a Data Provider. Data 
Provider, such as adding data within an 
ActionScript, makes the Flash docu-
ment display the same data every time 
the Flash document is displayed. You 
can always modify the data as the 
movie plays, by adding additional 
ActionScript instructions on the 
Timeline, and therefore, create a more 
dynamic Data Provider.

6
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1

Loader component 

4

2 3

Adding a Loader

Add a Loader Component

Open the Components panel.

Click the User Interface arrow to 
expand the list.

Drag the Loader (2.0) or UILoader
(3.0) component onto the Stage, 
and then select the component.

Select the Free Transform tool to 
size the Loader to the dimensions 
of the image file.

Open the Properties panel, and 
then click the Component 
Parameters arrow to expand it.

Enter the path to the JPG or SWF 
file in the contentPath value (2.0) 
or source (3.0) field.

Click the Control menu, point to 
Test Movie, and then click Test.

Flash displays the selected image 
in the Loader component.
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The Loader component is a container that can display a .swf or a .jpg. 
You use the Loader component when you want to pull in external con-
tent into a Flash movie. For example, you can bring in a product intro-
duction (.swf) or a company logo (.jpg) at the beginning of a movie. In 
addition, you can scale the contents of the loader, or resize the loader 
itself, to accommodate the size of the contents. By default, the contents 
are scaled to fit. 
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The NumericStepper component allows a user to step through an 
ordered set of numbers. The component consists of a number displayed 
beside small up and down arrow buttons. You can decide the maximum 
and minimum values along with the step value. When the visitor clicks 
the up or down buttons, the value changes until the maximum or mini-
mums are reached. As its name implies, the numeric stepper compo-
nent only handles numbers, text or special characters are not allowed. 
The NumericStepper component has many uses; for example, a site 
that books rooms for a major hotel chain would use a stepper for letting 
the visitor indicate how many people are staying, or an airline for how 
many people are flying.

Adding a Numeric 
Stepper

Add a NumericStepper 
Component

Open the Components panel.

Click the User Interface arrow to 
expand the list.

Drag the NumericStepper 
component onto the Stage, and 
then select the component.

Open the Properties panel, and 
then click the Component 
Parameters arrow to expand it.

IMPORTANT The 
NumericStepper component can 
be used to change the properties 
of items on the stage. You could 
link a NumericStepper instance to 
the property value of a dynamic 
text box, and then use the stepper 
to change the size of the text. This 
can be useful for people who 
require larger, readable text.

4
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1
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2

3

NumericStepper component
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Select from the following
NumericStepper parameters:

◆ maximum. Click the Value field, 
and then enter the maximum 
value associated with the 
NumericStepper.

◆ minimum. Click the Value field, 
and then enter the minimum 
value associated with the 
NumericStepper.

◆ stepSize. Click the Value field, 
and then enter a numerical 
value for stepping between 
numbers. For example, a 
stepSize value of 2, would 
cause the values to step by 2 
(2, 4, 6, 8).

◆ value. Click the Value field, and 
then enter the first number 
value that appears in the 
NumericStepper.

◆ enabled. When you select the 
check box, the field can be 
selected. If you deselect the 
check box, the field appears 
grayed out and is not 
selectable.

◆ visible. When you select the 
check box, the field can be 
viewed. If you deselect the 
check box, the field is invisible.

◆ minHeight (2.0). Click the Value 
field, and then enter a minimum 
height for the NumericStepper.

◆ minWidth (2.0). Click the Value 
field, and then enter a minimum 
width for the NumericStepper.

Click the Control menu, point to
Test Movie, and then click Test.
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Adding a Progress 
Bar

Add a ProgressBar Component

Open the Components panel.

Click the User Interface arrow to 
expand the list.

Drag the ProgressBar component 
onto the Stage, and then select the 
bar.

Give the ProgressBar component a 
unique instance name in the 
Property Inspector.

Open the Properties panel, and 
then click the Component 
Parameters arrow to expand it.

Click the Mode list arrow, and then 
click Event.
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4

ProgressBar component

Did You Know?
The ProgressBar component doesn’t 
make a good preloader. A preloader is 
a custom progress bar that shows the 
loading status of an entire movie, and 
is usually smaller in file size than the 
ProgressBar component. 

The loading process can be determi-
nate or indeterminate. A determinate 
progress bar is linear, tracking 
progress over time. Use this when the 
amount of content is known. 
Indeterminate progress bar is used 
when the amount of content is 
unknown.

The ProgressBar component is a necessity for Flash documents that 
require a long time to download, because they display the loading 
progress while a user waits. Web designers live under what is called 
the "ten-second rule." What that implies is that visitors to your Web site 
have very little patience, and they want to see things happening. When 
you add a ProgressBar component, the visitor sees a moving represen-
tation (a bar), letting them know the information is being downloaded.
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2

3

6

5
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Drag a Loader component from the 
Components panel onto the Stage.

Give the Loader component a 
unique instance name in the 
Property Inspector.

Select the ProgressBar 
component.

Open the Properties panel, and 
then click the Component 
Parameters arrow to expand it, 
and then enter the instance name 
of the Loader into the Source 
value field.

Select Frame 1 in the actions layer 
in the Timeline.

Open the Actions panel, and then 
enter the script as shown in the 
illustration that will load a .jpg, or 
.swf file into the Loader 
component.

When executed, the ProgressBar 
component will display a 
horizontal bar, and the percentage 
of the file that's loaded.

Click the Control menu, point to 
Test Movie, and then click Test.

When executed, the ProgressBar 
component will display a moving 
horizontal bar, and a percentage 
which displays how much of the 
file has loaded. 

IMPORTANT Notice that 
you're not adding scripts to the 
components on the Stage. The key 
is that these components are 
activated by scripts in Frame 1 on 
the Timeline, and are identified by 
using unique instance names for 
each component.
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The ScrollPane component can be used for displaying large movie 
clips, .jpg files, and .swf files that need a scrollable area to display, or 
that you want to confine to a specific area on the Flash Stage. You have 
the ability to display images in a limited area, using scroll bars, and the 
content loaded into the ScrollPane can be from a local location, or over 
the Internet. 

Adding a Scroll Pane

Add a ScrollPane Component

Open the Components panel.

Click the User Interface arrow to 
expand the list.

Drag the ScrollPane component 
onto the Stage, and then select the 
pane.

Open the Properties panel, and 
then click the Component 
Parameters arrow to expand it.

Select from the following 
ScrollPane parameters:

◆ contentPath (2.0) or source (3.0). 
Click the Value field, and then 
enter the full path name to the 
movie clip, .jpg, or .swf file.

◆ hLineScrollSize (2.0) or 
horizontalLineScrollSize (3.0). 
Click the Value field, and then 
enter the number of pixels to 
move the content when the left 
or right arrow in the horizontal 
scroll bar is pressed.

◆ hPageScrollSize (2.0) or 
horizontalPageScrollSize (3.0). 
Click the Value field, and then 
enter the number of pixels to 
move the content when the 
track in the horizontal scroll bar 
is pressed.

◆ hScrollPolicy (2.0) or 
horizontalScrollPolicy (3.0). 
Click the Value field, and then 
select whether the horizontal 
scroll bar is always present (on), 
never present (off), or appears 
automatically according to the 
image size (auto).
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ScrollPane component
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◆ scrollDrag. Click the Value 
field, and then select whether 
there is scrolling when a user 
presses and drags within the 
ScrollPane (true), or no 
scrolling (false).

◆ vLineScrollSize (2.0) or 
verticalLineScrollSize (3.0). 
Click the Value field, and then 
enter the number of pixels to 
move the content when the up 
or down arrow in the vertical 
scroll bar is pressed.

◆ vPageScrollSize or 
verticalPageScrollSize (3.0). 
Click the Value field, and then 
enter the number of pixels to 
move the content when the 
track in the vertical scroll bar is 
pressed.

◆ vScrollPolicy (2.0) or 
verticalScrollPolicy (3.0). Click 
the Value field, and then select 
whether the vertical scroll bar 
is always present (on), never 
present (off), or appears 
automatically according to the 
size of the image (auto).

◆ enabled. When you select the 
check box, the field can be 
selected. If you deselect the 
check box, the field appears 
grayed out and is not 
selectable.

◆ visible. When you select the 
the check box, the field can be 
viewed. If you deselect the 
check box, the field is invisible.

◆ minHeight (2.0). Click the Value 
field, and then enter a minimum 
height for the ScrollPane.

◆ minWidth (2.0). Click the Value 
field, and then enter a minimum 
width for the ScrollPane.

Click the Control menu, point to
Test Movie, and then click Test.
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Data binding is a simple way of connecting Flash components to each 
other. Components can be viewed as containers that transfer informa-
tion (images, text, numbers, video, graphics) from one to the other. In the 
Component Inspector panel, the Bindings tab controls the two contain-
ers, so that when property X of component A changes, it will copy the 
new value to property Y of component B. You can do data binding within 
the Component Inspector panel using the Bindings tab. The Bindings tab 
lets you add, view, and remove bindings for the selected component. 
Although data binding works with any component, its main purpose is to 
connect Component panel UI components to external data sources. 
These external data sources are available as components with proper-
ties, which you can bind to other component properties. The Component 
Inspector panel is the main tool that is used within Flash for data bind-
ing. It contains a Schema tab for defining the schema for a component 
and a Bindings tab for creating bindings between component properties. 
The following example demonstrates how to create basic data binding 
by connecting one UI component to another.

Creating Bindings

Create Bindings

Open the Components panel.

Click the User Interface arrow to 
expand the list.

Drag the NumericStepper 
component onto the Stage, and 
then select the component.

Give the NumericStepper a unique 
instance name in the Property 
Inspector.

Drag a second NumericStepper 
onto the Stage, and then give it a 
unique instance name.

Select the first NumericStepper 
component.
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Open the Component Inspector 
panel, and then click the 
Bindings tab.

Click the Add Binding (+) button to 
add a binding.

In the Add Binding dialog box, 
select Value.

Click OK.

Move to the Name/Value section, 
located at the bottom of the 
Bindings tab.

Click the Bound To item under 
Name, and then click the 
Magnifying Glass icon.

In the Bound To dialog box, select 
the NumbericStepper component
B.

Click OK.

Click the Control menu, point to 
Test Movie, and then click Test.

When you click the up and down 
buttons on the first 
NumericStepper, the value 
changes automatically in the 
second NumericStepper.

IMPORTANT You can use the 
Bindings tab to link two or more 
components together. If you want 
to add another component, just 
click the Add Binding (+) button to 
bind a second, or third component. 
There is no limit to the number of 
components that can be bound 
together.
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Once you create a binding between two components or between a 
component, such as a DataGrid, and an external file, you can control 
the binding through the binding options. For example, you may not want 
the exchange of data either way, or you may wish to control what type 
of data is entered or received. The Binding options, located on the 
Bindings tab, give you several author-controllable options.

Modifying Bindings

Modify Bindings

Open the Components panel.

Click the User Interface arrow to 
expand the list.

Drag the NumericStepper 
component onto the Stage, and 
then select the component.

Give the NumericStepper a unique 
instance name in the Property 
Inspector.

Drag a TextInput component onto 
the Stage, and then give it a 
unique instance name.

Select the NumericStepper 
component.

Open the Component Inspector 
panel, and then click the 
Bindings tab.

Click the Add Binding (+) button to 
add a binding.

In the Add Binding dialog box, 
select Value.

Click OK.10
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Move to the Name/Value section, 
located at the bottom of the 
Bindings tab.

Click the Bound To item under 
Name, and then click the 
Magnifying Glass icon.

In the Bound To dialog box, select 
the TextInput component.

Click OK.

Click the Control menu, point to 
Test Movie, and then click Test.

If you click the up and down 
arrows on the NumericStepper, 
the value in the TextInput field 
changes. If you enter a value into 
the TextInput field and press 
Return or Tab, the value in the 
NumericStepper changes.

Close the Flash movie, and then 
select the NumericStepper. 

Select Value at the top of the 
Component Inspector panel, click 
the Directions option, and then 
change the value from in/out to 
out.

Click the Control menu, point to 
Test Movie, and then click Test.

If you click the up and down 
arrows on the NumericStepper, 
the value in the TextInput field 
changes. If you enter a value into 
the TextInput field and press 
Return or Tab, the value in the 
NumericStepper no longer 
changes.

IMPORTANT Data binding is 
supported only between 
components that exist in Frame 1 
of the main Timeline, Frame 1 of a 
movie clip, or Frame 1 of a screen.
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To modify the schema of a component, you must first select an instance 
of the component. For example, if you want to modify the schema of a 
DataGrid component panel, you first select the component, open the 
Component Inspector panel, click the Schema tab, and then make the 
changes. Each component has its own unique schema, and changing 
parameters in the Component Inspector panel only changes the 
selected instance.

Modifying Schema

Modify Schema

Select a unique instance of a 
component on the Stage.

Open the Component Inspector 
panel.

Click the Schema tab.

Click the Add A Component 
Property (+) button to add 
additional fields to the schema list.

Click the Add A Field Under The 
Selected Field (+) button to add an 
additional field that's nested within 
the selected field.

Click the Delete The Selected 
Field Or Property (-) button to 
remove the selected field or 
property from the schema.

Select an item in the upper portion 
of the Schema tab, and then 
modify its options in the lower 
portion of the Schema tab.
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New fieldDid You Know?
The Schema tab displays data based 
on the selected component. Although 
all components have properties, by 
default, the Schema tab only displays 
properties that contain dynamic data. 
Dynamic data properties are called 
bindable properties. Flash lets you bind 
to any property by adding it to the 
schema panel yourself (using the Add 
Field (+) button), or using ActionScript 
code.
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You can write ActionScript code to change the properties for any Flash 
component instance. For example, you can change the color of text of a 
label instance named myLabel using the following code: 

myLabel.setStyle("color", "0x990000")

The preceding code would instruct Flash to change the color of the text 
used in the Label component instance named myLabel to red. Changes 
to the properties of a component can be attached to the instance on 
the Stage (influences only the one instance), or they can be used to 
globally change all instances, by placing the script in Frame 1 on the 
Timeline.

Modifying Component 
Attributes

Modify Component Attributes

Open the Actions panel.

Select an instance or Frame 1 on 
the Timeline.

Enter the script as shown in the 
illustration.

Click the Control menu, point to 
Test Movie, and then click Test.

The following table is a list of the 
available ActionScript options for 
changing the attributes of a 
component instance.
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backgroundColor marginLeft

borderColor marginRight

borderStyle scrollTrackColor

buttonColor shadowColor

color symbolBackgroundColor 

disabledColor symbolBackgroundDisabledColor 

fontFamily symbolBackgroundPressedColor 

fontSize symbolColor 

fontStyle symbolDisabledColor 

fontWeight textDecoration

highlightColor textIndent

Available Flash Attributes

1

Did You Know?
You can customize a component. Some 
of the components, such as Scroll 
bars, include a skin, or look and feel, 
which you can customize to suit your 
own artistic nature. See Project 1, 
“Creating and Customizing Scrollable 
Text,” in the Workshops (available on 
the Web at www.perspection.com) for 
a step by step example. 
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Using Components to Build a Form

When you create a form, you're incorporating all the various Flash components onto the Stage. 
Flash components make creating a form easy; however, there are still design considerations to 
be made. For example, what information do you need to extract from your visitors, and how 
will you receive it? Does your audience primarily speak and read English, or do you need to 
make the form multi-lingual (that's possible by creating label components that display text in a 
language selected by the visitor). And what about handicap and accessibility standards, how do 
you handle them? Yes, Flash does make the creation of a form easy, but you are still responsi-
ble for the overall design, and that includes images, backgrounds, colors, fonts and sizes, read-
ability, and accessibility. The following Flash document is an example of incorporating multiple 
components to create an interactive form.

When you create a form, it is a good programming practice to isolate components onto sep-
arate layers. That way, they're easier to locate and edit, and you can always lock the compo-
nent’s layer to prevent accidental tampering.  

ComboBox 
component

CheckBox 
component

Button 
component

TextArea 
component

List 
component

RadioButton 
component
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465

Automating Your Work

Introduction

The History panel helps you work more efficiently in Flash. 
As you work, the History panel tracks all the steps you take in 
Flash. With the History panel, you can undo or redo steps to 
correct mistakes, replay selected steps for new tasks to 
streamline repetitive work, and record steps for replay from 
the Commands menu to automate your work. In addition, 
Flash allows you to use Object-level undo modes. Which 
means you can undo steps to a specific object without hav-
ing to undo the changes made to other main objects on the 
Stage.

You can open the History panel from the Other Panels 
submenu on the Window menu. Each step you take in the 
active document during a work session appears on a sepa-
rate line in the History panel. You can undo or redo a single 
step or series of steps quickly with the Undo/Redo slider, 
which you can drag up to undo a series of steps or drag 
down to redo a series of steps. You can also select a series of 
steps in the History panel and replay them to the same object 
or to a different object in the document. 

Do you often repeat the same series of steps? Rather 
than repeat the same actions, you can work faster by saving 
the entire series of steps as a command on the Commands 
menu, which you can reuse again and again. Flash stores the 
commands you save for future use. After you save steps as a 
command, you can select the command name on the 
Commands menu to run it, or use the Manage Saved 
Command dialog box to rename or delete commands.

Due to the complex nature of some steps, such as adding 
a gradient to a shape or modifying document size, Flash can-
not replay or save (as a command) all steps in the History 
panel. For these steps, a red X appears in the icon for a step 
in the History panel. Even though Flash cannot replay or save 
all steps, it can undo and redo all steps.

What You’ll Do

Examine the History Panel

Use the History Panel

Work with Object-Level Undo Mode

Undo and Redo Steps

Replay Steps

Save Steps and Use Commands

Copy Steps Between Documents
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The History panel helps you automate and 
streamline the way you work in Flash. As you 
work in Flash, the History panel is tracking all 
your steps for the entire document or only on 
individual or all objects behind the scenes. 
With the History panel, you can do any of the 
following:

◆ Undo or redo steps to correct 
mistakes. 

◆ Replay selected steps for new tasks to 
streamline repetitive work.

◆ Record steps for replay from the 
Commands menu to automate your 
work.

The History panel doesn’t replace the 
Undo, Redo, and Repeat commands on the 
Edit menu, it simply tracks every step you per-
form in Flash. When you undo or redo one or 
more commands, the History panel displays 
the results; the Undo/Redo slider moves

according to the commands you select.
You can open the History panel using the 

Window menu like any of the other panels in 
Flash. Each step you take in the active docu-
ment during a work session (since you cre-
ated or opened the document) appears on a 
separate line in the History panel. The first 
step you perform in a work session appears at 
the top of the list and the last step appears at 
the bottom. If a red X appears in the icon for a 
step, it indicates Flash cannot save or replay 
the step. Unlike other panels in Flash, the 
History panel includes a slider on the left side 
that you can use to undo/redo steps; the 
Undo/Redo slider initially points to the last 
step you performed. The bottom of the History 
panel includes buttons to replay selected 
steps, copy selected steps to the Clipboard, 
and create a command from selected steps. 
The Options menu displays commands, such 
as Clear History, specific to the History panel.

Examining the History Panel

Undo/Redo 
slider

Completed 
steps

Replay selected 
steps

Copy selected 
steps to

Clipboard

Create command 
from selected 
steps

Options menu

Completed steps 
in document
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You can use the Window menu to open the History panel like any of the 
other panels in Flash; the History panel appears on the Other Panels 
submenu. Each step you take in the active document during a work ses-
sion appears on a separate line in the History panel. Steps you take in 
other Flash documents don’t appear in other History panel lists. If you no 
longer need the steps in the History panel, you can erase the entire list. 
When you close a document, Flash clears the History panel.

Using the History 
Panel

Open and Close the 
History Panel

◆ To open the History panel, click the 
Window menu, point to Other 
Panels, and then click History.

TIMESAVER Press A+F10 
(Mac) or Ctrl+F10 (Win) to open 
the History panel.

◆ To close the panel, click the Close 
button, or click the Options menu, 
and then click Close Panel.

Clear the History Panel

Open or expand the History panel.

Click the Options menu, and then 
click Clear History.

Click Yes to confirm the operation.

When you’re done, click the Close 
button on the History panel.
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Close button
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1 Options menu
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The History panel allows you to keep track of the changes made in 
Flash on a per-object basis. When this mode is activated in the General 
Preferences dialog box, each object on the Stage and even objects in 
the Library panel have their own undo list. Think about just what this 
means. You can now undo the changes you make to an object without 
having to undo changes to any other object.

Working with Object-
Level Undo Mode

Set Object-Level Undo

Click the Flash (Mac) or Edit (Win) 
menu, and then click Preferences.

Click the General category.

Click the Undo list arrow, and then 
click Object-Level Undo.

Click OK to confirm changing from 
Document to Object level undo will 
delete your current undo history.

Click OK to set object level undo or 
click Cancel to keep document 
level undo.

As you work, Flash keeps a per-
object record of the history of 
each main Flash object.
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Work with Object Level Undo

Set object level undo in General 
preferences, and then open a new 
or existing Flash document.

Begin working with an object.

As you work, Flash keeps a per-
object record of the history of 
each main Flash object.

Open the History panel.

Use the Undo, Redo, or Repeat 
commands on the Edit menu.

TROUBLE? You cannot undo 
some object-level actions, such as 
working in a library or a scene. 
Check Flash Help for specifics.

4
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1 2
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You can undo or redo a single step or a series of steps quickly with the 
History panel. The History panel contains the Undo/Redo slider which 
you can drag up to undo (restore previous steps) a series of steps, or 
drag down to redo (restore steps you’ve undone) a series of steps. You 
can also undo and redo previous steps one at a time using the Undo 
and Redo commands on the Edit menu. When you use these com-
mands, the steps in the History panel change based on the command 
results. The History panel and the Undo command can undo steps up to 
a maximum number (from 2 to 9999) set in the General tab of the 
Preferences dialog box.

Undoing and Redoing 
Steps

Undo Steps with the 
History Panel

Open or expand the History panel.

Drag the Undo/Redo slider up until 
the slider points to the last step 
you want to keep.

TIMESAVER Position the 
pointer in the gray area to the left 
of a step, and then click the gray 
area to make the slider point to 
the step.

Flash undoes and grays out each 
selected step, starting from the 
bottom.

When you’re done, click the Close 
button on the History panel.

3

2

1

31

2

Drawn polygon 
shape removed 
with undo.

Did You Know?
You can undo steps using the Undo 
command. Click the Edit menu, and 
then click Undo, or press A+Z (Mac) 
or Ctrl+Z (Win).

See Also
See “Examining the History Panel” on 
page 466 for information on different 
elements in the History panel.
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Redo Steps with the 
History Panel

Open or expand the History panel.

Drag the Undo/Redo slider down 
until the slider points to the last 
step you want to redo.

Flash redoes and removes the gray 
highlighting for each selected 
step.

When you’re done, click the Close 
button on the History panel.

3

2

1

31

2
Did You Know?

You can redo steps using the Redo 
command. Click the Edit menu, and 
then click Redo, or press A+Y (Mac) 
or Ctrl+Y (Win).

You can change the number of undo 
levels for the Undo command. Click the 
Flash (Mac) or Edit (Win) menu, click 
Preferences, click the General tab, 
enter a number (from 2 to 9999) in the 
Undo Level box, and then click OK.

Saving Documents After Using Undo

When you delete an object in a document, the file size of the docu-
ment doesn’t change. The document still includes the size of the 
object you just deleted to preserve the possibility you might want to 
undo the step and restore the deleted item. If you know that you don’t 
want the steps in the History panel, you can use the Save And 
Compact command on the File menu to clear the History panel, 
reduce the file size, and save the document. If you want to save the 
document and keep the steps in the History panel for the current ses-
sion, use the Save command on the File menu.

For Your Information
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You can replay steps from the History panel to the same object or to a 
different object in the document. You can replay steps only in the order 
in which you performed them; you can’t rearrange the order of the 
steps in the History panel. If a red X appears in the icon for a step, it 
indicates Flash cannot save or replay the step. The Repeat command on 
the Edit menu allows you to apply your previous step to another object. 
For example, if you fill a shape with a color or pattern, you can fill 
another shape with the same color or pattern by selecting the other 
shape and using the Repeat command.

Replaying Steps

Replay Steps to the Same Object 
or Another Object

Open or expand the History panel.

Select the steps you want:

◆ One step. Click a step.

◆ Adjacent steps. Drag from one 
step to another or click the first 
step, hold down the Shift key, 
and then click the last step.

◆ Nonadjacent steps. Hold down 
the A (Mac) or Ctrl (Win) key, 
and then click steps.

Select the same object used in the 
History steps or another object.

Click Replay in the History panel.

The steps are replayed in order, 
and a new step called Replay 
Steps appears in the History panel.

When you’re done, click the Close 
button on the History panel.

5

4

3

2

1

4 2

Single step selection

51

Replays single step

Multiple step selection

Replay multiple steps

See Also
See “Copying Steps Between 
Documents” on page 476 for informa-
tion on replaying steps in a different 
document.
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Repeat the Previous Step on 
Another Object

Select an object, and then perform 
a command.

Select another object to which you 
want to perform the same previous 
command.

Click the Edit menu, and then click 
Repeat.

The command is performed on the 
selected object.

3

2

1

1

Color fill 
from the 
circle 
shape is 
repeated 
on the 
polygon 
shape.

2

Changing the View in the History Panel

The Options menu in the History panel allows you to change the way 
you view steps. You can view steps in the History panel with scripting 
arguments or JavaScript commands. Even if you are not a program-
mer, you can get a better idea about the functionality of each step by 
looking at the scripting argument or JavaScript commands. If you 
want to view scripting arguments or JavaScript commands in the 
History panel as you need it without having to change the view each 
time, you can view the information as a tooltip. To change the view, 
click the Options menu in the History panel, point to View, and then 
click a view option: Default (steps only), Arguments In Panel, 
JavaScript In Panel, Arguments In Tooltip, or JavaScript In Tooltip.

For Your Information
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The History panel records the steps you take in the order in which you 
performed them in Flash. If you perform the same set of steps several 
times while you work on a document, you can save the steps in the 
History panel as a command on the Commands menu, which you can 
reuse again and again. Flash stores the commands you save for future 
use (even if you close the document). Some steps, including selecting a 
frame or modifying a document size, can’t be saved as commands, but 
they can be undone and redone. If a red X appears in the icon for a 
step, it indicates Flash cannot save or replay the step. After you save 
steps as a command, you can run, rename, or delete commands.

Saving Steps and 
Using Commands

Save Steps as a Command

Open or expand the History panel.

Select the steps you want to save.

Click the Save As Command button 
in the History panel. 

Enter a name for the command.

Click OK.

The command is available on the 
Commands menu and saved as a 
JavaScript file with the extension 
JSFL in the Commands folder, 
which is located in Adobe\Flash 
CS5\First Run\.

When you’re done, click the Close 
button on the History panel.

6
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Did You Know?
You can delete a name from the 
Command menu. Click the Commands 
menu, click Manage Saved Commands, 
select the command you want to 
remove, click Delete, click Yes, and 
then click OK.

5
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Run a Command

Click the Commands menu.

Click a command name from 
the list.

Edit the Names of Commands

Click the Commands menu, and 
then click Manage Saved 
Commands.

Select a command to rename.

Click Rename.

Enter a new name for the 
command.

Click OK.

Click OK.6
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1
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6
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2Did You Know?
You can run JavaScript or Flash 
JavaScript commands. Click the 
Commands menu, click Run Command, 
navigate to the script file, and then 
click Open.

Did You Know?
You can download commands from the 
Web. The Flash Exchange Web site 
contains commands developed by 
other users you can download (some 
for a fee) and use in your documents. 
Click the Commands menu, and then 
click Get More Commands to quickly 
access the Adobe Web site.

5
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Each document only tracks its own set of steps in the History panel. 
When you close a document, Flash clears the History panel. If you want 
to use a set of steps in another document, you need to copy them from 
one History panel and paste them to another document. You can use 
the Copy Steps button on the History panel or the same command on 
the Options menu to complete the task. When you paste steps into 
another document, Flash replays the steps and the History panel shows 
the steps as only one step called Paste Steps (Mac) or Paste (Win).

Copying Steps 
Between Documents

Copy Steps Between Documents

Open a document containing the 
steps you want to copy.

Open or expand the History panel.

Select the steps in the History 
panel you want to copy.

Click the Copy Steps button in the 
History panel.

Open the document into which you 
want to paste the steps.

Select the objects to which you 
want to apply the steps.

Click the Edit menu, and then click 
Paste In Center.

The steps play in the document as 
Flash pastes the steps into the 
History panel of the document. The 
steps appear in the History panel 
as a single step called Paste Steps 
(Mac) or Paste (Win).

When you’re done, click the Close 
button on the History panel.
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Steps pasted into the 
History panel of another 
document.
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Publishing a Movie

Introduction

When you design a Flash movie, you're actually working with 
two documents: a source document FLA, and a publish docu-
ment SWF. The source document is the working document 
that the Flash application uses to edit the movie data. The 
published document is the compressed player document 
that, once created, can be inserted into an HTML document, 
burned onto a CD, DVD, or DVS, or played directly from your 
hard drive, external drive, or network drive. 

You can publish a Flash document in one step, by clicking 
the File menu, and then clicking Publish. However, before 
publishing, it's a good idea to first check the publish settings 
by clicking the File menu, and then clicking Publish Settings. 
Using the Publish Settings dialog box, you can easily change 
the way your file is published. For example, the default set-
tings for publishing a Flash document are to publish using 
the latest Flash plug-in, and to create an HTML container doc-
ument to hold and play the published movie. Additional 
options include the ability to generate a JPEG, GIF, or PNG 
image of a selected frame in the Flash source document. You 
can even create a self-running player document for 
Macintosh or Windows. Publishing is not only necessary to 
create a Flash movie; it can be used to test the movie using 
different settings. 

Once the correct publish settings are found, you can 
export the settings into a separate file, and then use them on 
new Flash documents. This not only makes the publishing 
process fast, it gives you consistency between documents. 20

20
What You’ll Do

Publish Considerations

Modify Publish Settings

Specify Flash Options

Specify Adobe AIR Options

Insert File Information

Specify HTML Options

Specify GIF Options

Specify PNG Options

Specify JPEG Options

Create a Projector

Create a Publishing Profile

Edit Profile Properties

Export and Import a Profile

Duplicate a Profile

Preview or Test a Movie

Use the Bandwidth Profiler

Export a Movie to Different Formats

Print from the Flash Player

477
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Publishing a Flash movie is the last step in a 
long journey from inception to the final 
product. Along the publishing road, you’ll 
encounter detours, and stoplights and even 
get lost once in awhile. However, if you've 
had the foresight to plan your project, then 
the journey becomes one more of pleasure 
than pain. 

Planning a project requires knowledge of 
where the final published document is 
headed. You might be designing a Flash 
movie, where the intended audience is the 
Web, or it could be a project where the final 
destination is a CD or DVD. It could be an 
interactive form, or an animated cartoon. It's 
even possible that your goals for this project 
involve more than one destination. 

Called Multi-purposing, Flash will help you 
design a project version that is small enough 
to run efficiently, as well as a higher-quality 
version, intended to run directly off the hard 
drive. It really doesn't matter where the proj-
ect is headed, because Flash's advanced pub-
lishing options will effortlessly guide you 
through the process.

Before you ever open Flash, create your 
first graphic, or write your first piece of text, 
always remember to plan the project. In other 
words, begin the project with the end in mind. 
That's not new, but it bears remembering. If 
you plan for the end of a project, you will cre-
ate a road map that will accurately guide you 
to your final destination.

When you are ready to publish a Flash 
movie, you can use Flash publishing settings 
and tools in this chapter to make the job eas-
ier. You can also use the Adobe Flash deploy-
ment kit to post Flash Player SWF files to your 
Web site and control the experience of visi-
tors who do not have the Flash Player 
installed in their browser. Flash standardizes 
the method used for detection of the plug-in 
on the client-side, reducing the amount of 
code that must be written to implement the 
detection option. If you're interested in work-
ing with the Flash Development Kit, simply 
point your browser to http://www.adobe.com/ 
devnet/devices/development_kits.html. Since 
Flash is always creating new ways for us to 
design great Flash documents, this site is con-
stantly changing to reflect the latest technolo-
gies.

Publishing Considerations
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Once you've determined how your project will be published, it's time to 
let Flash assist you with all the details of getting your project from con-
ception to an output file suited to your needs. Flash's publishing set-
tings go far beyond converting a Flash source file FLA into a published 
movie SWF; they give you the ability to adjust the output to a specific 
version of the Flash player, incorporate specific Flash compression fea-
tures, and even save screen shots of the source file's frames in several 
different formats. And, if a Flash movie is not what you're after, you can 
even publish a Flash source file in other formats, including GIF, JPEG, 
PNG, and Windows or Macintosh Projector. In addition, you can also 
export a Flash source file in a variety of file formats, including a 
QuickTime movie MOV. 

Modifying Publish 
Settings

Modify Publish Settings

Open a Flash source document. 

Generic publish settings are 
initially linked to a specific Flash 
file.

Click the File menu, and then click 
Publish Settings.

Select or clear the option check 
boxes to enable or disable the 
Publish Settings.

Enter a name for the individual 
options in the File name input box.

To revert the names to default, 
click the Use Default Names 
button.

The default name refers to the 
name of the source document.

Click OK to save the changes.

IMPORTANT When you 
publish a Flash movie, the changes 
only affect the published .swf 
document, never the .fla source 
document. If you delete or 
misplace the .fla source document, 
you will never be able to re-edit, or 
republish the movie.
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Publish Settings 
dialog box
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A Flash document is like a fingerprint: no two Flash movies are the 
same. So it stands to reason that different Flash documents would 
require different publish settings. Flash gives you the ability to conform 
a Flash document using specific output settings. Everything from the 
version of the Flash player plug-in and ActionScript to the movie com-
pression and quality of embedded JPEG images are available options in 
the Publish Setting dialog box.

Specifying Flash 
Options

Specify Flash Options

Click the File menu, and then click 
Publish Settings.

Select the Flash check box, and 
then click the Flash tab.

Click the Player list arrow, and 
then select the version of the 
player to publish the Flash 
document.

Click the Script list arrow, and 
then select the version to publish 
the Flash document.

Drag the JPEG Quality slider to 
increase or decrease the amount 
of compression applied to the 
image. The lower the value, the 
more information is removed from 
the image.

Select the Enable JPEG 
deblocking check box to reduce 
the appearance of common 
artifacts found in highly 
compressed JPEG files.

Select from the following options:

◆ Click Set to modify the Audio 
Stream settings for the active 
Flash document.

◆ Click Set to modify the Audio 
Event settings for the active 
Flash document.

◆ Select the Override Sound 
Settings check box to override 
any sound settings applied to 
the individual sound files within 
the active Flash document.
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Select from the following options:

◆ Compress Movie. Compresses 
the movie (only for movies 
played with Flash 7 player).

◆ Include Hidden Layers. 
Includes hidden layers in the 
Flash document.

◆ Include XMP metadata. 
Includes XMP data. Click File 
Info to view the data.

◆ Export SWC. Exports a .swc 
file, which is used for 
distributing components made 
up of ActionScript code.

◆ Generate Size Report. Creates 
a frame-by-frame size report 
for the active document.

◆ Protect From Import. Prevents 
the published Flash document 
from being reopened in the 
Flash application.

◆ Omit Trace Actions. Prevents 
trace actions from being 
carried over to the published 
document.

◆ Permit Debugging. Permits 
debugging of the Flash movie.

Enter a password for the Flash 
document (2.0).

This option is available if Protect 
From Import or Permit Debugging 
are selected in step 10.

Click the Local Playback Security 
list arrow, and then select the 
local only or network only option.

Click the Hardware Acceleration 
list arrow, and then select an 
option to take advantage of 
available hardware for better 
playback performance.

Click OK to save the settings.12

11

10

9

8

10
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9 12

Security Options

The Flash Player 8 and later incorporates a security option that 
allows you to determine the local and network playback security for 
published SWF files. SWF files have read access to local files and 
networks by default, but they cannot communicate with the network. 
In the Flash tab on the Publish Settings dialog box, you can select a 
Local Playback Security option to access network resources, which 
allows the SWF file to send and receive information. If you select the 
option to access network resources, local access is disabled for 
security reasons. Flash also provides buffer overrun protection, which 
prevents misuse of external files, such as a virus. The player also pro-
vides stricter security; SWF files with nonsecure protocols (HTTP) 
cannot access content loaded using secure protocols (HTTPS). 

For Your Information

8
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Adobe AIR is a cross-operating system runtime that allows you to lever-
age your existing web development skills in Flash to build and deliver 
Rich Internet Applications (RIAs) to more devices, including the web, 
mobile, and desktop. You can create a new Flash file for AIR from the 
Welcome page or the New dialog box by clicking Adobe AIR 2 (New!), 
or use an existing Flash file (ActionScript 3.0), and then convert it to an 
Adobe AIR file through the Publish Settings dialog box (New!). Before 
you can publish a file to Adobe AIR, you need to have a digital certifi-
cate that represents the application publisher’s identify. After you pub-
lish an AIR application, you can install it by using the Installer Package 
with the AIR extension and start the program like any other program on 
your system. When you no longer want to use it, you can remove it like a 
normal program too.

Specifying Adobe 
AIR Options

Publish to Adobe AIR

Click the File menu, and then click 
Publish Settings.

◆ You can also access AIR 
Settings by clicking the Edit 
button in the Property Inspector 
or click the File menu, and then 
click AIR Settings.

Select the Flash check box, and 
then click the Flash tab.

Click the Player list arrow, and 
then click Adobe AIR 2.

Click Settings.

Click the General tab.

Select from the following General 
settings:

◆ Output File. Specifies where to 
save the AIR file.

◆ File Information. Enter the 
following file information: File 
name, Name, Version, ID (a 
unique identifier, no spaces or 
special characters), 
Description, Copyright, and 
Window style.

◆ Profiles. Select profiles for the 
application types you want to 
create (New!).
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◆ Included files. Specifies which 
additional files and folders to 
include in the AIR file.

Click the Signature tab.

All Adobe Air applications must be 
signed to be installed on another 
system.

Click an option to select or create 
a digital certificate or use AIR 
Intermediate (AIRI) for temporary 
use that will be signed later.

◆ Create Digital Signature. Click 
Create, specify publisher and 
organization information, 
password, type (use default), 
click Browse to select the 
folder with the FLA file, and 
then click OK. Enter the 
password from the certificate, 
and select the related options 
as desired.

Click the Icons tab, select an 
application icon size, and then 
select an application icon. 

Click the Advanced tab, specify 
any associated file types, initial 
window settings, install and 
program menu folders. 

Click Publish to publish it, and 
then click OK, or click OK, and 
then click OK to save settings.

11

10

9

8

7

Did You Know?
You can use certain versions of Adobe 
AIR with certain versions of Flash. 
Flash CS5 only supports and publishes 
to AIR 2.0, Flash CS4 only supports and 
publishes to AIR 1.1, and Flash CS3 only 
supports and publishes to AIR 1.0.
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When you save a document, you have the ability to save more than just 
Flash information. You can save copyright, camera, and even image cat-
egory information. This data is saved with the file as metadata in the 
XMP format (Extensible Metadata Platform) in SWF files, and can be 
recognized and accessed by any application, such as Adobe Bridge, 
that reads XMP metadata. In addition, if an image is a photograph, you 
can save data specifying the type of image, where it was shot, or the 
camera used. You can even get information on shutter speed and f-stop. 
You can do the same with video and audio data too. That information will 
not only protect your intellectual property, but will supply you with vital 
statistics on exactly how you created that one-of-a-kind image. 

Inserting File 
Information

Insert File Information into 
a Flash Document

Open a document.

Click the File menu, and then click 
File Info.

Click the Description tab, and then 
enter information concerning the 
author and any copyright 
information.

Click the IPTC tab to enter 
information concerning the 
image's creator, description and 
keywords, location where 
photograph was taken, date 
created, copyright, and usage 
terms.

Click the Camera Data tab, which 
reveals information about the 
camera that took the image. 

Click the Video Data tab or Audio 
Data tab to reveal information 
about video and audio data, and 
then enter your video and audio 
data.

Click the Mobile SWF tab or Audio 
Data tab, and then enter file 
information for a mobile SWF.

Click the Categories tab, and then 
enter category keywords for 
search purposes.
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Click the Origin tab, and then 
enter data pertaining to the origin 
of the image. 

Click the DICOM tab, and then 
enter data pertaining to the Digital 
Imaging and Communications in 
Medicine.

Click the History tab to view 
historical information about the 
active document, such as dates 
last opened and saved, and a list 
of image adjustments.

Click the Advanced tab to view 
additional information on the 
active document, such as EXIF, 
and PDF document properties. 

Click the Raw Data tab to view 
raw RDF/XML information.

Click OK.14
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12

11

10

9

Did You Know?
You can add metadata to files saved in 
the PSD, PDF, EPS, PNG, GIF, JPEG, 
and TIFF formats. The information is 
embedded in the file using XMP 
(eXtensible Metadata Platform). This 
allows metadata to be exchanged 
between Adobe applications and 
across operating systems. 

You can use the XMP Software 
Development Kit to customize the 
creation, processing, and interchange 
of metadata. You can also use the XMP 
kit to add fields to the File Info dialog 
box. For information on XMP and the 
XMP SDK, check the Adobe Solutions 
Network.
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The most common way to display a Flash movie is on the Internet, using 
an HTML document as the movie container. HTML creates tags that 
embed the Flash movie in an HTML document for viewing on the Web. 
Flash publish settings give you the ability to create an HTML document 
specifically tailored to the active Flash document; including options to 
use an HTML template, and control the playback and quality of the final 
published document. You can also set options to specify the scale and 
alignment of the movie as well as the way it opens.

Specifying HTML 
Options

Specify HTML Options

Click the File menu, and then click 
Publish Settings.

Select the HTML check box, and 
then click the HTML tab.

Click the Template list arrow, and 
then select a Flash container 
template (including templates for 
PocketPC devices).

Click the Dimensions list arrow, 
and then click Match Movie, 
Pixels, or Percent. If Pixels or 
Percent, enter width and height. 

The Match Movie option matches 
the size of the Flash movie. The 
Pixels option sets the exact size. 
The Percent option allows for 
scaling within a browser.

Select from the following Playback 
options:

◆ Paused At Start. Select this 
option to pause the Flash 
movie, when loaded.

◆ Loop. Select this option to 
cause the Flash movie to loop, 
when loaded.

◆ Display Menu. Select this 
option to have the HTML 
document display a control 
menu for the Flash document.

◆ Device Font. Select this option 
to use device fonts in the Flash 
document.
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Click the Quality list arrow to 
select a quality level for the 
document.

◆ Low No anti-alias.

◆ Auto Low. Starts with no anti-
alias, but changes as needed.

◆ High. Allows anti-alias.

◆ Auto High. Starts with anti-
alias, but changes down as 
needed.

◆ Medium. Anti-aliases most 
items, but does not smooth 
bitmaps.

◆ Best. Anti-aliases everything.

Click the Window Mode list arrow, 
and then select a mode (Window, 
Opaque Windowless, or 
Transparent Windowless) for 
opening the Flash document.

Click the HTML Alignment list 
arrow to select the alignment of 
the HTML page.

Click the Scale list arrow to select 
how to scale the Flash document, 
when loaded into the HTML page.

◆ Default. Shows entire 
document; keeps proportions.

◆ No Border. Fills area to the 
border; keeps proportions.

◆ Exact Fit. Fills entire SWF 
movie; doesn’t keep 
proportions.

◆ No Scale. SWF remains the 
same size if Player window is 
resized.

Click the Horizontal and Vertical 
list arrows to select how the Flash 
document is aligned with in the 
HTML page.

Click OK to save HTML settings.11
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Using Version Detection

Version Detection checks what version of the Flash Player is running 
on your viewer’s computer. If the Flash Player is missing or the ver-
sion number is not high enough to display the movie, you can have 
Flash display a message, link to Adobe’s Web site to download the 
correct version, display an alternative image file, or display a differ-
ent site. To detect a viewer’s Flash Player version, click the File menu, 
click Publish Settings, click the Flash tab, click the Version list arrow, 
click Flash version 4 or higher, click the HTML tab, select the Detect 
Flash Version check box, click Settings, and then specify file names 
(.html) for Detection (detects Flash Player version), Content (displays 
the .swf file), and Alternate (displays a warning and link to download 
the Flash Player). To let Flash create its standard Detection and 
Alternate files, click the Generate Default option, or click Use 
Defaults. This uses SWFObject2 for Flash Player detection (New!). 
To use your own alternate file, click the Use Existing option, and then 
click Browse to select the file.

For Your Information
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When you publish a Flash document, you're not limited to just the cre-
ation of the Flash movie, you can instruct Flash to create a GIF image of 
the Flash movie, based on the currently selected frame. The GIF file for-
mat (Graphics Interchange Format) is used primarily for clipart, text, 
and line art, or for images that contain areas of solid color. Once the 
image is created, you can open and use it in any application that sup-
ports the GIF file format.

Specifying GIF 
Options

Specify GIF Options

Select a specific frame on the
Timeline.

Click the File menu, and then click 
Publish Settings.

Select the GIF check box, and then 
click the GIF tab.

Enter a Width and Height (in 
pixels) for the JPEG image, or 
select the Match Movie check box 
to create a JPEG image that 
matches the size of the Flash 
movie.

Select from the following Playback 
options:

◆ Static. Prevents the GIF 
animation from playing.

◆ Animated. Animates the GIF 
document.

◆ Loop Continuously. Forces the 
animation into a continuous 
loop.

◆ Repeat. Enter a value 
representing the number of 
times the file loops.
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Select from the following Options:

◆ Optimize Colors. Creates an 
optimized (smaller) set of colors 
for the active document.

◆ Interlace. Creates an interlaced 
image where the file, when 
displayed on a Web page, loads 
in three passes.

◆ Smooth. Uses a color dithering 
scheme to create visually 
smoother color transitions.

◆ Dither Solids. Dithers (mixes) 
solid colors if they fall outside 
of the viewable color gamut.

◆ Remove Gradients. Removes 
gradients from the active 
image.

Click the Transparent list arrow, 
and then click Opaque, 
Transparent, or Alpha.

The Alpha transparency mask 
generates transparent areas 
within the GIF image.

Click the Dither list arrow, and 
then click None, Ordered, or 
Diffusion.

Click the Palette Type list arrow, 
and then click Web 216, Adaptive, 
Web Snap Adaptive, or Custom.

Enter a number for the Maximum 
Colors.

This is available for Adaptive and 
Web Snap Adaptive. Flash lets you 
select how many colors are 
available for the image's color 
table.

Click to select a color table file for 
the Custom Palette Type.

Click OK to save the GIF settings.12
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Option Use

Web 216 Creates an image with only Web Safe 
colors.

Adaptive Creates an image where the color table
(CLUT) adapts to the image colors.

Web Snap Adaptive Creates a color table that adheres 
closely to the Web Safe Color palette.

Custom Creates a customized color palette.

Palette Type Options
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When you publish a Flash document, you're not limited to just the cre-
ation of the Flash movie. You can instruct Flash to create a PNG image 
of the Flash movie, based on the currently selected frame. The PNG file 
format (Portable Network Graphic) is a hybrid format designed to save 
clip art, photographic images, text, and line art. Once the image is 
created, you can open and use it in any application that supports the 
PNG file format.

Specifying PNG 
Options

Specify PNG Options

Select a specific Frame on the
Timeline.

Click the File menu, and then click 
Publish Settings.

Select the PNG check box, and 
then click the PNG tab.

Enter a Width and Height (in 
pixels) for the PNG image, or 
select the Match Movie check box 
to create a PNG image that 
matches the size of the Flash 
movie.

Click the Bit Depth list arrow, and 
then select 8-bit, 24-bit, or 24-bit 
With Alpha.

Select from the following Options:

◆ Optimize Colors. Creates an 
optimized (smaller) set of colors 
for the active document.

◆ Interlace. Creates an interlaced 
image where the file, when 
displayed on a Web page, loads 
in three passes.

◆ Smooth. Uses a color dithering 
scheme to create visually 
smoother color transitions.

◆ Dither Solids. Dithers (mixes) 
solid colors, if the colors fall 
outside of the viewable color 
gamut.

◆ Remove Gradients. Remove any 
gradients from the active 
image.

6
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Option Selection

8-bit Maximum of 256 colors

24-bit Maximum of 16.7 million colors

24-bit with Alpha Maximum of 16.7 colors and supports 
the alpha transparency

Bit Depth Choices
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Click the Dither list arrow, and 
then click None, Ordered, or 
Diffusion to dither (mix) colors that 
fall outside the viewable color 
gamut.

Click the Palette Type list arrow, 
and then click Web 216, Adaptive, 
Web Snap Adaptive, or Custom to 
select a specific palette type.

Enter a number for the Maximum 
Colors.

This is available for Adaptive and 
Web Snap Adaptive. Flash lets you 
select how many colors are 
available for the image's color 
table.

Click to select a color table file for 
the Custom Palette Type.

Click the Filter Options list arrow, 
and then select from the available 
filter options to control the filtering 
of the colors in the active image.

Click OK to save the PNG settings.12
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When you publish a Flash document, you're not limited to just the cre-
ation of the Flash movie, you can instruct Flash to create a JPEG image 
of the Flash movie, based on the currently selected frame. The JPEG 
file format (Joint Photographic Experts Group), is used primarily to 
reduce the size of photographic images. Once the image is created, 
you can open and use it in any application that supports the JPEG file 
format. You can select a quality option to compress the file size, which 
reduces download time over the Internet. You can specify a quality 
value between 1 and 100. A higher value preserves image quality, but 
retains a higher file size.

Specifying JPEG 
Options

Specify JPEG Options

Select a specific frame on the
Timeline.

Click the File menu, and then click 
Publish Settings.

Select the JPEG check box, and 
then click the JPEG tab.

Enter a Width and Height (in 
pixels) for the JPEG image, or 
select the Match Movie check box 
to create a JPEG image that 
matches the size of the Flash 
movie.

Drag the Quality slider to increase 
or decrease the amount of 
compression applied to the image.

The lower the value, the more 
information (quality) is removed 
from the image.

Select the Progressive check box 
to create a progressive JPEG 
image. The file, when displayed on 
a Web page, loads in three passes.

Click OK to save the JPEG settings.7
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The Flash publish settings gives you the ability to create a self-contained 
player document for the Macintosh or Windows operating system. When 
you publish a document using the projector options, Flash creates a 
Flash movie according to your setting, and embeds the player application 
into the file. Creating a projector document increases the size of the final 
document by almost 1MB, so this option would not be used to create 
Internet documents, but for movies destined for playing on a hard drive, 
or burned onto a CD or DVD. When you publish using the Projector 
options, there are no additional options.

Creating a Windows 
or Macintosh 
Projector

Create a Windows or 
Macintosh Projector

Click the File menu, and then click 
Publish Settings.

Select the Windows Projector 
(.exe), and/or Macintosh Projector 
check boxes.

Click Publish.

Flash generates the Macintosh or 
Windows Projectors documents, 
and saves them in the same 
location as the original source 
document.

3

2

1

32

Did You Know?
You can play Flash SWF files different 
ways. Besides playing SWF files in a 
stand-alone projector, you can also 
play Flash content in an Internet 
browser, such as Internet Explorer or 
Firefox; in Director, Microsoft Office 
and other ActiveX applications with the 
Flash ActiveX; and as part of a 
QuickTime video.
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Flash lets you generate profiles for often-used publish settings within a 
Flash source file. For example, you're creating a multi-purpose Flash 
document and you need specific settings to create a fast-loading 
Internet version, as well as a version designed to run on a CD or DVD. 
You could create a publishing profile to fit both needs, and save them 
with the source document. The benefits of this are obvious: Not only 
can you quickly publish a Flash document using different profiles; 
you're assured the settings will be accurate every time. Fast and accu-
rate are two words which describe Flash publishing.

Creating a Publishing 
Profile

Create a Publishing Profile

Click the File menu, and then click 
Publish Settings.

Click the Current Profile list arrow 
to select the profile.

Make the necessary changes in 
the Publish Settings dialog box.

Click OK.

Click the Create New Profile 
button.

Enter a unique name in the Profile 
Name box.

Click OK.

IMPORTANT When you save a 
Flash profile, it’s only available to 
that specific document.
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Once you create a unique profile settings file, it's available for use with 
the click of the Current Profile list arrow in the Publish Settings dialog 
box. Unfortunately, not everything is perfect the first time you do it, and 
it's possible that after you create a profile, you discover a mistake in 
the settings. The good news is that you don't have to begin again. All 
you have to do is edit the profile.

Editing Profile 
Properties

Edit Profile Properties

Click the File menu, and then click 
Publish Settings.

Click the Current Profile list arrow, 
and then select the profile you 
want to change.

Make the necessary changes in 
the Publish Settings dialog box.

Click OK.

Select the File menu, and then 
click Save.

Flash profiles are saved when you 
save the Flash source document. 

IMPORTANT Profile properties 
are recorded as you change them, 
and then saved when you save the 
file. If you change your mind after 
modifying the profile, your choices 
include manually changing the 
profile back to its original settings, 
or closing the file without saving. 
However, if you've also made 
changes to the Flash document, 
closing without saving will also 
cause you to lose those changes.
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Saving Flash profiles is a great way to cut down on repetitive publish 
settings. However, the disadvantage is the user-defined settings only 
relate to the original source document. If you open a new file, you're 
starting from scratch. It would be great to be able to create a series of 
setting files, and then use them over and over again on a new Flash 
document. Flash understood this need and gave Flash users the ability 
to create settings files, and then export them as a separate file. Then, if 
you need to use the settings in a new Flash document, all you have to 
do is import the settings file. Exporting Dreamweaver profiles gives you 
the ability to import and use the profile on multiple Flash projects. In 
addition, you can send copies of exported profiles to other Flash users, 
so they can benefit from your efforts. When you export a Flash profile, 
you have the ability to reuse it, via the Import option. It's a good idea to 
save (export) all of your profiles into a single location. That way, when 
you go to import a specific profile, you will know exactly where to point 
your finder.

Exporting and 
Importing a Profile

Export a Profile

Click the File menu, and then click 
Publish Settings.

Click the Current Profile list arrow, 
and then select the profile you 
want to export.

Click the Import/Export Profile 
button, and then click Export.

Navigate to the drive or folder 
location where you want to save 
the exported profile.

Click Save.5
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Import a Profile

Click the File menu, and then click 
Publish Settings.

Click the Current Profile list arrow, 
and then select the profile you 
want to import.

Click the Import/Export Profile 
button, and then click Import.

Navigate to the drive or folder 
where the profile is located. 

Select the file name of the 
exported profile.

Click Open.

IMPORTANT Once a profile is 
imported into a Flash document, it 
becomes a copy of the original 
item. You can use it in the active 
document, or make some minor 
adjustments, and export it out as a 
new profile.
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When you work with a profile, you're creating a time-saving file that 
lets you use the same settings over and over again. Not only does Flash 
make the creation of a profile easy; it will let you create a duplicate of 
the file. In truth, a duplicate file would not serve much of a purpose: 
Why would you want an exact copy of something that already exists? 
Actually, creating a duplicate can be a very smart thing to do. For 
example, say you create a profile for a specific job that involved sev-
eral changes to the default settings, and you name it: Output_A. Then, 
two weeks later you need another profile that's almost exactly the 
same as Output_A, with one or two minor changes. Rather than start 
from scratch, you create a duplicate of Output_A, make the minor 
changes, and Export it using the name: Output_B. It's fast and easy, 
and it means you're working smart.

Duplicating a Profile

Duplicate a Profile

Click the File menu, and then click 
Publish Settings.

Click the Current Profile list arrow, 
and then select the profile you 
want to duplicate.

Click the Duplicate Profile button.

Give the duplicate a new name.

Click OK.5
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See Also
See “Exporting and Importing a 
Profile“ on page 496 for more informa-
tion on how to export a Flash 
publishing profile.

5
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Previewing a Flash movie is an important part of the design process. As 
you work, you should periodically stop and preview the movie. It's also 
a good idea to periodically save your document. In fact, you should 
always save the Flash document before previewing. That way, if there 
happen to be any problems, it's an easy matter of restoring the file from 
the last-saved version. To preview your Flash SWF file with the publish-
ing format and settings you've selected, you can use the Publish 
Preview command. This command exports the file and opens the pre-
view within the default browser.

Previewing a Movie

Preview a Movie

Click the File menu, point to 
Publish Preview, and then select 
from the following options:

◆ Default (HTML). Select this 
option to display the Flash 
document within an HTML 
document.

◆ Flash. Select this option to 
create and play a Flash .swf 
file.

◆ HTML. Same as Default 
(HTML).

◆ GIF. Select this option to create 
a GIF version of the currently 
selected frame in the Timeline.

◆ JPEG. Select this option to 
create a JPEG version of the 
currently selected frame in the 
Timeline.

◆ PNG. Select this option to 
create a PNG version of the 
currently selected frame in the 
Timeline.

◆ Projector. Select this option to 
display the Flash document in a 
self-contained projector file.

1

1

Changing Magnification in Flash Player
In the Flash Player, you can increase or decrease the magnification 
of the current Flash movie (SWF), as well as play, rewind, step for-
ward, or step back. To zoom in or out in a browser, press 
Control+click (Mac) or right-click (Win) anywhere in the movie win-
dow, and then click Zoom In or Zoom Out. Click Show All to see the 
entire Flash movie.

For Your Information
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As you work, you should periodically stop and test your movie as a 
Flash SWF. The Test command allows you to quickly see your movie on 
different devices and players—Flash Professional, Device Central 
(New!) or Air Debug Launcher (Desktop or Mobile) (New!)—without 
leaving the program. The Test command tests the movie based on the 
current test option. Flash uses the document type the default until you 
change it. Each time you test your movie as an SWF, Flash creates a log 
entry in the SWF History in the Property Inspector (New!). The SWF 
History shows you the difference in file size between the different tests. 
If there is over a 50% increase in size, a warning icon appears next to 
the log entry. In the SWF History, you can view or clear the log entries.

Testing a Movie

Test a Movie and View a 
SWF History

Click the Control menu, and then 
point to Test Movie.

Select the option where you want 
to test your movie:

◆ in Flash Professional. Plays the 
movie in a separate window in 
Flash Professional.

◆ in Device Central. Opens 
Adobe Device Central CS5 and 
displays the movie.

◆ in Air Debug Launcher 
(Desktop). Opens Adobe Air 
Player for the desktop and 
displays the movie.

◆ in Air Debug Launcher 
(Mobile). Opens Adobe Air 
Player for mobile devices and 
displays the movie.

◆ Test. Performs a test with the 
currently selected test option.

TIMESAVER Press Ctrl+Enter 
(Win) or A+Return (Mac).

To view and work with the SWF 
History log, click the Window 
menu, and then click Properties to 
open the Property Inspector.

◆ Clear the SWF History. Click 
the Clear button.

◆ View the SWF History Log. 
Click the Log button.
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To view the performance of a Flash document using a graph, use the 
Bandwidth Profiler. The Bandwidth Profiler displays how much data is 
sent for each frame in the active Flash document, according to the 
speed you specify. The Bandwidth Profiler has two windows. The left 
window shows information about the active document and the current 
download settings, and the right window displays information about 
each frame in the document. In addition, the Bandwidth Profiler lets 
you view how the page loads, based on a specific bandwidth. For 
example, you could specify to load the Flash document using a speed 
of 28.8Kbps. To maintain an accurate download test, the Bandwidth 
Profiler compensates for added compression support applied to SWF 
files, which reduces the file size and improves streaming performance.

Using the Bandwidth 
Profiler

Use the Bandwidth Profiler

Click the Control menu, point to 
Test Movie, and then click Test.

Click the View menu, and then 
click Bandwidth Profiler.

Click the View menu, point to 
Download Settings, and then 
select from the available 
bandwidth options, or click 
Customize, and then create a user-
defined setting.

Click the View menu, and then 
click Simulate Download.

This tests the load of the Flash 
movie against the current settings.

4

3

2

1

Test movie
bandwidth
settings.

Timing Rule
A timing rule used in Web design is called the 10-second rule. If doc-
uments load too slowly, there's a good chance that your visitors will 
not wait for the document to load, and will move on to other pages. 
The Bandwidth profiler gives you a real taste of what your visitors 
are going to experience when they download your Flash movies.

For Your Information
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Flash can export an entire movie or frame to several different formats 
that are not included in the Publish Settings dialog box. These formats 
include Adobe FXG, Bitmap, JPEG Image or Sequence, GIF Image or 
Sequence, PNG Image or Sequence, Quick Time (MOV), Animated GIF, 
Windows AVI, and WAV (for Windows only). When you export a movie 
or image (frame), some file formats require you to select additional for-
mat specific options, such as resolution (dots per inch) and number of 
colors or color bit depth, to complete the operation. To set the resolu-
tion to match your monitor, select Match Screen.

Exporting a Movie to 
Different Formats

Export a Movie Frame to 
Different Formats

Open a document.

Select a frame you want to export 
in the Timeline.

Click the File menu, point to 
Export, and then click Export 
Image.

Navigate to the location where 
you want to save the file.

Enter a name in the Save As (Mac) 
or File Name (Win) box.

Click the Format popup (Mac) or 
the Save As Type list arrow (Win), 
and then select a file format.

Click Save.

Some file formats require you to 
select additional format specific 
options to complete the operation. 

If a dialog box appears, select the 
options you want, and then 
click OK.
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Available file formats
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Options vary
depending on
export format
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Export a Movie to Different
Formats

Open a document.

Click the File menu, point to 
Export, and then click Export 
Movie.

TIMESAVER Press Option+ 
Shift+A+S (Mac) or Ctrl+Alt+ 
Shift+S (Win) to export a movie.

Navigate to the location where 
you want to save the file.

Enter a name in the Save As (Mac) 
or File Name (Win) box.

Click the Format popup (Mac) or 
the Save As Type list arrow (Win), 
and then select a file format.

Click Save.

Some file formats require you to 
select additional format specific 
options to complete the operation. 

If a dialog box appears, select the 
options you want.

Click OK or Export.

When you export a movie, Flash 
creates a separate file for each 
frame of the movie and numbers 
them in sequential order.
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In your browser, you can press Control+click (Mac) or right-click (Win) 
a Flash movie in a Flash Player to display a contextual, or shortcut, 
menu. The menu contains Flash Player related commands, such as 
Print. You can give viewers the option to print some, or all of your 
movie. By default, the Print command prints every frame in the movie 
unless you restrict printing to specific frames by labeling them as print-
able in the Flash document before you publish it. You label frames as 
printable by typing #p in the Frame box of the Property Inspector. By 
default, the movie’s Stage size determines the print area.

Printing from the 
Flash Player

Label Frames as Printable and 
Print from the Flash Player

Open a document.

Select the frames or keyframes in 
the Timeline you want to label as 
printable.

Type #p in the Frame box in the 
Property Inspector.

Repeat steps 2 and 3 for each 
keyframe you want to label as 
printable.

Publish your movie using the 
Publish command on the File 
menu, and then view it in your 
browser using the Flash Player.

Press Control+click (Mac) or right-
click (Win) anywhere in the movie 
window, and then click Print.
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#p appears in the selected frames.

2

3

Did You Know?
You can disable printing from the 
Flash Player. Open the Flash docu-
ment, select a frame in the Timeline, 
open the Frame Property Inspector, 
and then type !#p in the Label box.

You can disable the contextual menu 
in the Flash Player. Click the File menu, 
click Publish Settings, click the HTML 
tab, clear the Display Menu check box, 
and then click OK.

Printing with ActionScript
You can also print with ActionScript using the following commands: 
print (target, bounding box), printasBitmap (target, bounding 
box), or Printjob class. The target is the Movie Clip Timeline (or 
specific frames) and bounding box is bmovie (frame with a #b 
used as print area), bframe (each frame used as print area), or 
bmax (one big print area).

For Your Information
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Working with Projects and 
Other Programs

Introduction

Adobe programs are designed to work together so you can 
focus on what you need to do, rather than on how to do it. In 
fact, the Adobe programs share tools and features for your 
most common tasks so you can work uninterrupted and 
move seamlessly from one program to another.  

If you need more advanced scripting features, you can 
use Adobe Flash Builder to work with ActionScript 3.0, yet 
still quickly switch back to Flash Professional as needed. As a 
designer, you can use the Adobe FXG file format to exchange 
graphic content between programs with high fidelity, which 
includes Fireworks, Photoshop CS5, Illustrator, Flash Catalyst, 
and Flash Builder. If you want to create a stand-alone applica-
tion from a Flash document, you can publish it as an Adobe 
AIR application, which you can install or remove like any 
other program. In addition to developing content for comput-
ers, you can also use Flash to develop content for mobile 
devices using Adobe Device Central CS5 to test it.

In Flash, you can manage multiple document files within 
a Flash Project. A Flash Projects lets you group multiple, and 
related files together to help you keep track of complex appli-
cations. Flash lets you apply version-control to ensure that 
the correct file versions are used during editing and to pre-
vent accidental overwriting. 

If you want to access additional resources from Adobe, 
you can use the Adobe CS Live menu. Adobe CS Live is an 
online service that allows you to set up or manage (sign in 
and out) an Adobe account, access the Acrobat.com subscrip-
tion-based Web site or the Adobe ConnectNow Web site 
(Share my screen command) where you can collaborate with 
others, display CS news and resources, and access an Adobe 
Web site with information about CS Live Services. 21

21
What You’ll Do

Work with Adobe Flash Builder

Exchange Content with Adobe FXG

Create an Adobe AIR Application

Create Content for a Mobile Device

Map MIDI Sounds on a Mobile Device

Create and Manage a Project

Manage Project Files

Test a Project

Send a Document Using E-Mail

Explore CS Live Services

Share My Screen

Use Adobe Extension Manager
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Adobe Flash Builder 4 (formerly Adobe Flex Builder) is a stand-alone 
program or plug-in that allows you to develop cross-platform Web appli-
cations using the Flex framework, which includes compilers, component 
library, and debuggers. You can use Flash Builder to work with UI lay-
outs and behaviors, and ActionScript 3.0. With Flash Builder 4 and Flash 
Professional CS5 installed, you can open Flash FLA files and edit 
ActionScript 3.0 in Flash Builder (New!) and test, debug, or publish in 
Flash Professional. You can also create or open ActionScript 3.0 AS files 
(either class or interface) (New!) from Flash Professional for edit in 
Flash Builder.

Working with Adobe 
Flash Builder

Create an ActionScript File and 
Open in Flash Builder

Click the File menu, and then 
click New.

TIMESAVER Click  Action-
Script 3.0 Class or ActionScript 3.0 
Interface on the Welcome screen 
to create a new AS document.

Click the General tab.

Click ActionScript 3.0 Class or 
ActionScript 3.0 Interface.

Click OK.

Click the Flash Professional or 
Flash Builder option.

Enter a class or interface name.

Click OK.

If you selected Flash Builder, the 
program opens, asking you to 
create a new Flash project.

Click Browse, select the target 
FLA or XFL file, and then click 
Open.

Click Finish.

Edit the code in Flash Builder.

To publish, test, or debug back in 
Flash Professional, click the 
Publish, Test Movie, or Debug 
Movie button on the toolbar.

When you’re done, exit Flash 
Builder.
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Open Flash or ActionScript Files 
in Flash Builder

In Flash, open the Flash FLA or 
ActionScript AS document.

Do the following to open a Flash or 
ActionScript file:

◆ Flash FLA. Open the Property 
Inspector, enter a document 
class name in the Property 
Inspector if blank, and then 
click the Edit Class Definition 
button.

◆ ActionScript AS. Control+click 
(Mac) or right-click (Win) a 
symbol associated with the 
class interface, click 
Properties, or click the Edit 
Class Definition button in the 
Symbols Properties dialog box.

If prompted, click the Flash 
Professional or Flash Builder 
option, if prompted, and then click 
OK.

If prompted, click Browse to select 
the target FLA or XFL file (as 
needed), and then click Finish.

Edit the code in Flash Builder.

To publish, test, or debug back in 
Flash Professional, click the 
Publish, Test Movie, or Debug 
Movie button on the toolbar.

When you close the tested or 
debugged movie window in Flash, 
it switches back to Flash Builder.

When you’re done, exit Flash 
Builder.
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Exchanging Content 
with Adobe FXG

Import Content From an Adobe 
FXG File

Open a document.

Click the File menu, point to 
Import, and then click Import to 
Stage or Import to Library.

To open a specific type of Flash 
file, click the File as type list arrow 
(Win), or the File type popup 
(Mac), and then click Adobe FXG
(*.fxg).

Navigate to the drive or folder 
where the file is located.

Click the Adobe FXG graphic file 
you want to open.

Click Open.6
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Adobe FXG (Flash XML Graphics) is a file format based on a subset of 
MXML, the XML-based programming language used by the Flex frame-
work, which you can use to build rich Internet applications. The FXG file 
format allows designers to exchange graphic content between pro-
grams with full fidelity. Flash allows you to import and export your indi-
vidual objects or the entire Stage in the Adobe FXG file format (version
2.0) (New!). You can use the FXG file format in other Adobe programs 
for export (Fireworks, Photoshop CS5, and Illustrator) or for import and 
export (Flash Catalyst and Flash Builder). When you export vector and 
bitmap graphics, a separate folder is created to store the images along 
with the FXG file. Elements without a recognizable tag (such as some 
blends, gradients, masks, and 3D) are exported as bitmap graphics.
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Using Adobe Flash Catalyst
Adobe Flash Catalyst CS5 (New!) is a stand-alone professional 
interaction design tool for rapidly creating expressive interfaces and 
interactive content without writing code. Create interactive proto-
types, portfolios, product guides, microsites, site navigation, and 
interfaces. You can transform artwork created in Adobe Illustrator, 
Photoshop, and Fireworks into interactive designs. For example, you 
can create screen designs or graphics in Illustrator, open the art-
work in Flash Catalyst, and add interactive components to it, yet still 
maintain the ability to make changes back in Illustrator without 
affecting the Flash Catalyst content. For more information about 
Flash Catalyst and where to get it, go to http://labs.adobe.com/ 
technologies/flashcatalyst.

For Your Information

Export Content as an Adobe 
FXG File

Open a Flash document.

To export objects on the Stage, 
select them on the Stage.

Click the File menu, point to 
Export, and then click Export 
Image (for entire Stage) or Export 
Selection (for selected objects on 
the Stage).

Navigate to the location where 
you want to export the file.

Enter a name in the Save As (Mac) 
or File Name (Win) box.

Click the Format popup (Mac) or 
Save as Type list arrow (Win), and 
then click Adobe FXG (*.FXG).

Click Save.

The following constrains apply to 
exporting to the FXG file format:

◆ Scale-9 Grids. Exported, 
however only readable by 
Adobe Illustrator.

◆ Sound and Video. Not exported.

◆ Components. Not exported.

◆ Tweens and Animation with 
Multiple Frame. Not exported; 
however a selected frame can 
be exported as an object.

◆ Embedded Fonts. Not exported.

◆ Button Symbols. Exports only 
the Up state of buttons.

◆ 3D Properties. Not exported.

◆ Inverse Kinematics (IK)
Properties. Not exported.

◆ Text Attributes. Some attributes 
not exported.
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Creating an Adobe 
AIR Application

Create a New Adobe AIR
Document

Click the File menu, and then 
click New.

TIMESAVER Click Adobe AIR 2 
on the Welcome screen to create 
a new blank document.

Click the General tab.

Click Adobe AIR 2.

Click OK.

Create your application in Flash.

Click the File menu, and then click 
Adobe AIR 2 Settings.

Click the General, Signature, 
Icons, and Advanced tabs to 
select or create a digital 
certificate and other AIR 
publishing settings.

Click Publish, and then click OK.8
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Adobe AIR is a cross-operating system runtime that allows you to lever-
age your existing web development skills in Flash to build and deliver 
Rich Internet Applications (RIAs) to more devices, including the web, 
mobile, and desktop. You can create a new Flash file for AIR from the 
Welcome page or the New dialog box by clicking Adobe AIR 2 (New!), 
or use an existing Flash file (ActionScript 3.0), and then convert it to an 
Adobe AIR file through the Publish Settings dialog box (New!). Before 
you can publish a file to Adobe AIR, you need to have a digital certifi-
cate that represents the application publisher’s identify. After you pub-
lish an AIR application, you can install it by using the Installer Package 
with the AIR extension and start the program like any other program on 
your system. When you no longer want to use it, you can remove it like a 
normal program too.

See Also
See “Specifying Adobe AIR Options” 
on page 482 for more information on 
specific publishing settings.
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Install and Start an Adobe AIR 
Application

In Windows Explorer (Win) or 
Finder (Mac), navigate to the 
folder with the published AIR 
application.

Double-click the installer program 
for the AIR application (.air), and 
then follow the installer 
instructions.

Use the Start menu or Windows 
Explorer (Win) or Finder (Mac) to 
start the AIR application.

To remove the AIR application, use 
the Uninstall a program link in the 
Control panel (Win) or drag the 
application folder to the Trash can 
(Mac).
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2

1

12 3

Digital certificate file

Did You Know?
You can access gesture events in 
ActionScript. Adobe’s AIR 2.0, built on 
the same technology framework as 
Flash, introduces a new set of events 
that detect when you touch the screen 
called gestures. Gestures can also be 
used in the new Flash iPhone 
Packager.
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Flash content deployment is expanding from the Web to other mediums, 
such as cell phones, PDAs, and other mobile devices. In conjunction 
with Adobe Device Central CS5, Flash allows you to create and test 
content for mobile devices. You can use the New Document dialog box 
to create a blank Flash document for mobile devices using Adobe 
Device Central. Flash uses the right settings from Device Central to cre-
ate the content you want. To display content on mobile devices, Flash 
uses Flash Lite, a specialized player for mobile devices. After you cre-
ate your mobile content, you can test it using Adobe Device Central and 
Flash Lite. 

Creating Content for a 
Mobile Device

Create a Document for a Mobile
Device

Click the File menu, and then 
click New.

Click the General tab

Click Adobe Device Central.

Click OK.

Adobe Device Central CS5 opens, 
where you can select the device 
and any options you want.
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Select the device you want and 
check the device profile for 
support and compatibility issues.

Click Create.

The new document appears in 
Flash, where you can develop your 
content.

6

5

6

5

Device Library tab with device information
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Every day the world is getting smaller, and mobile devices are getting 
smaller, and smarter. Using Flash, you can include event sounds when 
creating documents for playback on mobile devices. Flash does not 
support sound file formats used for mobile devices (such as MIDI and 
others); when authoring for mobile devices, you must temporarily place 
a proxy sound in a supported format such as MP3 or WAV in the Flash 
document. The proxy sound in the document is then mapped to an 
external mobile device sound, such as a MIDI file. During the document 
publishing process, the proxy sound is replaced with the linked external 
sound. The SWF file generated contains the external sound and uses it 
for playback with Flash Lite on a mobile device. Flash Lite is the Flash 
Player for mobile devices.

Mapping MIDI Sounds 
on a Mobile Device

Map MIDI Sounds on a Mobile 
Device

Click the File menu, point to 
Import, click Import to Library, and 
then import one or more sounds 
into the Flash Library.

Control+click (Mac) or right-click 
(Win) the sound you want to work 
with, and then click Properties.

Enter a path to the location where 
the mobile device sound is 
located.

Click OK.

Add a button instance to the 
Stage.

IMPORTANT You can use a 
pre-made Flash button. Click the 
Window menu, point to Common 
Libraries, and then click Buttons.

Open the button in the Library, and 
then add the linked sound to the 
Hit frame of the button.

Click the File menu, and then click 
Publish Settings.
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Click the Flash tab.

Click the Player list arrow, click 
Flash Lite 1.x thru 3.x (ActionScript
1.0 or 2.0) or Flash Lite 4.x 
(ActionScript 3.0), and then select 
the ActionScript version you want, 
if necessary.

The Export device sounds option is 
automatically selected.

Flash Lite is a player for mobile 
devices.

Click OK.

The SWF file now contains the 
linked mobile device sound.

Click the Control menu, point to 
Test Movie, and then click in 
Device Central.

When you execute a Flash 
document using Flash Lite, Flash 
opens Adobe Device Central CS5 
to emulate the display with the 
currently selected mobile device.

When Adobe Device Central CS5 
opens, its displays an emulator of 
the currently selected mobile 
device, or asks you to select one. 

If necessary, select the device you 
want and check the device profile 
for support and compatibility 
issues.

Use the Device Central controls to 
test out your Flash document on 
the mobile device.

The mobile device sound has been 
modified to emulate the Flash .swf 
file sound.
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Device tab

12 Use to change 
device options

10

 From the Library of Wow! eBook



ptg

516 Chapter 21

In Flash, you can manage multiple document files within a Flash 
Project. A Flash Projects lets you group multiple, and related files 
together to help you keep track of complex applications. Flash lets you 
apply version-control to ensure that the correct file versions are used 
during editing and to prevent accidental overwriting. A Flash Project is 
essentially a collection of any Flash or other file types, including Flash 
SWF and FLA files and even other Flash projects. When you open an 
existing project, the Project panel gives you instant access to all the 
various parts of the project. The Flash Project panel is used to create 
and manage projects. The Project panel displays the contents of a 
Flash Project using a collapsible tree structure. Flash limits you to 
opening or creating one project at a time. Any changes made to the 
project are automatically saved to the project file, so it’s not necessary 
to perform a Save operation.

Creating and 
Managing a Project

Create and Manage a Project

Click the Window menu, point to 
Other Panels, and then click 
Project to open the Project panel.

◆ Quick Project. You can create a 
quick project. A quick project is 
based on the currently open 
FLA file. Click the Projects list 
arrow in the Project panel, and 
then click Quick Project.

Click the Projects list arrow, and 
then click New Project.

Name the new project, locate and 
select a root folder location for the 
project file, and then click OK.

Any folders in the selected root 
folder appear in the Project panel.

Click the ActionScript version list 
arrow, and then click ActionScript
3.0 or ActionScript 2.0.

Click Create Project.5
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5
Did You Know?

You can open a project. Click the 
Projects list arrow in the Project panel, 
and then click Open Project, browse to 
the project folder, and then click OK. 
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Manage a project using any of the 
following options:

◆ Add Folder. Click the New 
Folder button, type the folder 
name, and then click Create 
Folder.

◆ Delete Folder. Select the folder, 
click the Delete button to 
delete a selected project asset.

◆ Close Project. Click the Options 
menu, and then click Close 
Project.

◆ Delete Project. Open the 
project, click the Options menu, 
and then click Delete Project. 
Select a delete content option, 
and then click Yes.

◆ Rename Project. Click the 
Options menu, click Rename 
Project, type a name, and then 
click OK.

◆ Switch Open Projects. Click the 
Project list arrow, and then 
click the open project name. 

◆ Project Properties. Click the 
Options menu, click Project 
Properties, specify options on 
the different tabs (Classes, 
Locations, and Paths), and then 
click OK.

Click the Close button on the 
Project panel.

7

6

Did You Know?
You can convert previous projects to 
the new project format. In previous 
versions of Flash, projects used an 
XML file with a .FLP extension. To con-
vert it, simply open it in Flash CS4. 
Open the Project panel, click the 
Project list arrow, click Open Project, 
navigate to the folder with the project, 
and then click OK.

Delete button

Options menu

Project name

Create Class button
New File button

New Folder button

Create a
new folder

7

Project files

New folder
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A project is a collection of files that you can manage directly from Flash. 
The Project panel displays files by filename extension. By default, the 
Project panel only shows Flash documents type (FLA, SWF, SWC, AS, 
JSFL, ASC, MXML). If you want to display other types, you can change 
settings in Panel Preferences. You can also hide files or folder by pre-
ceding the file or folder name with a special character, such as an 
underscore, and enabling the option in Panel Preferences. When you 
work with the same project, the Project Panel shows all recently 
opened files in the Recent Files folder for easy access. You can create 
files, including Flash and ActionScript, from the Project panel. 

Managing Project 
Files

Manage Project Files

Click the Window menu, point to 
Other Panels, and then click 
Project to open the Project panel.

Manage files using any of the 
following options:

◆ Create File. Select the folder 
where you want the file (no 
selection is the root), click the 
New File button, enter a name, 
select a file type, and then click 
Create File.

◆ Open File. Double-click the file 
in the Project panel. 

◆ Delete File. Select the file, click 
the Delete button, and then 
click Yes to delete a selected 
project asset.

◆ Publish. Select or clear the file 
check box on the right to add or 
remove the file to/from the 
publishing list.

◆ Pin a Directory. Select a folder, 
and then click the Pin Directory 
button; click again to unpin. 

Click the Close button on the 
Project panel.

3

2

1

Did You Know?
You can clear the Recent Files list. In 
the Project panel, click the Options 
menu, and then click Clear Recent Files.

1

Delete button

Options menu

New File button

3

Options menu

Panel Preferences
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Change Project Properties

In the Project panel, click the 
Options menu, and then click 
Project Properties.

Click any of the following tabs:

◆ Classes. Specify the 
ActionScript version, and class 
file folder locations.

◆ Locations. Specify additional 
source folder locations.

◆ Paths. Specify the location Flex 
SDK files for use in Flash to 
create skins and other visual 
elements in Flex. 

Click OK.

Change Panel Preferences

In the Project panel, click the 
Options menu, and then click 
Panel Preferences.

Click any of the following tabs:

◆ Classes. Specify the 
ActionScript version, and class 
file folder locations.

◆ Settings. Change defaults 
filters, hide files or folders 
based on the name, and show 
or hide classes folder, hidden 
files, or recent files.

◆ Locations. Specify additional 
source folder locations.

Click OK.3
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Project 
comes up 
to test.

6

A project is a collection of files that constitute a complex project. For 
example, you can create a Flash project that contains 5 Flash docu-
ments, with interactive buttons on the pages to call the other pages. If 
all of the FLA files are located within the same project, it's an easy mat-
ter to test the entire project. You must first select one of the files as the 
main file, and then simply click the Test Project button. Flash will auto-
matically publish all of the Flash documents in the project, display the 
main file, and then allow you to test its operation. It's that simple.

Testing a Project

Test a Project

Click the Window menu, point to 
Other Panels, and then click 
Project to open the Project panel.

If the project you want to test is 
not open, click the Project list 
arrow, click Open Project in the 
Project panel, and then select the 
appropriate file.

Click Open.

IMPORTANT Since testing a 
project involves moving among 
different Flash movies, your 
published documents will have to 
have interactive buttons linked to 
all the other pages within the 
project, or the test will not work.

Right-click (Win) or Control-click 
(Mac) one of the FLA or HTML files 
in the project.

Click Make Default Document 
from the available options.

Click Test Project.6

5

4

3

2

1

See Also
See Chapter 17, “Debugging a Movie” 
on page 409 for more information on 
how to perform debugging operations 
on a running Flash movie.
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After you finish making changes to a document, you can quickly send it 
to another person for review using e-mail. Flash allows you to send 
documents out for review as an attachment using e-mail from within 
the program so that you do not have to open your e-mail program. An 
e-mail program needs to be installed on your computer before you 
begin. When you send your document out for review, reviewers can 
add comments and then send it back to you. 

Sending a Document 
Using E-Mail 

Send an Office Document 
Using E-Mail

Click the File menu, and then click 
Send.

◆ If prompted, click Yes to save 
your Flash document.

IMPORTANT To complete the 
following steps, you need to have 
an e-mail program installed on 
your computer and an e-mail 
account set-up.

Your default e-mail program opens 
with your document attached.

Enter your recipients and subject 
(appears with document name by 
default).

Enter a message for your reviewer 
with instructions.

Click the Send button.4
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1 Signed in to CS Live online

Sign In to Adobe CS Live

Adobe CS Live (New!) is an online service that allows you to set up or 
manage (sign in and out) an Adobe account, review CS5 documents 
(Illustrator, InDesign, and Photoshop) online, access the Acrobat.com 
subscription-based Web site or the Adobe ConnectNow Web site 
where you can collaborate with others, display CS news and resources 
in a panel within CS5 programs, and access an Adobe Web site with 
information about  CS Live Services. You can access these options 
directly from the CS Live menu on the right side of the menu bar next to 
the Search bar. When the CS Live menu icon includes a bulls eye, you 
are signed in to the online services.

Exploring CS Live 
Services

Explore CS Live Services

Click the CS Live menu (New!), 
and then select any of the following 
commands:

◆ Set Up Your Access To Adobe 
CS Live Online Services, Sign 
In, or Sign Out. Select to set up, 
sign in, or sign out of the CS Live 
online service.

◆ Create New Review or Learn 
More. Creates a CS5 document 
review in Illustrator, InDesign, or 
Photoshop.

◆ Acrobat.com Home. Opens the 
Acrobat.com subscription-based 
Web site that allows you to work 
and collaborate with others.

◆ Share My Screen. Opens the 
Adobe ConnectNow Web site 
where you can start an online 
meeting and collaborate on any 
design project across platforms 
and programs. 

◆ CS News and Resources. Opens 
the CS News and Resources 
panel with news and resources 
from Adobe.

◆ Manage My Account. Opens a 
secure Web site with your 
Adobe account information after 
you sign in.

◆ Explore CS Live Services.
Opens an Adobe Web site that 
describes CS Live Services.

1
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The Share My Screen command on the File or CS Live (New!) menu 
allows you to connect to Adobe ConnectNow, which is a secure Web 
site where you can start an online meeting and collaborate on any 
design project across platforms and programs. You can share and 
annotate your computer screen or take control of an attendee’s com-
puter. During the meeting, you can communicate by sending chat mes-
sages, using live audio, or broadcasting live video. In addition, you can 
take meeting notes, and share files.

Sharing My Screen

Share My Screen

Click the File or CS Live menu, and 
then click Share my screen.

Enter your Adobe ID and 
password.

◆ If you don’t have an Adobe ID 
and password, click the Create 
a Free Adobe ID link, and then 
follow the online instructions.

Click Sign In.

◆ If prompted, sign in to 
ConnectNow.

To share your computer screen, 
click the Share My Computer 
Screen button.

Use the ConnectNow toolbar to do 
any of the following:

◆ Meeting. Use to invite 
participants, share my 
computer screen, upload a file, 
share my webcam, set 
preferences, end a meeting, 
and exit Adobe ConnectNow.

◆ PODS. Use to show and hide 
pod panels.

◆ Help. Use to get help, 
troubleshoot problems, and set 
account and Flash Player 
settings.

Click the participant buttons at the 
bottom to specify roles, remove a 
user, or request control of a user’s 
computer.
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The Adobe Extension Manager is a program you can use to install and 
delete added program functionality, known as extensions, to many 
Adobe programs. The Extension Manager is automatically installed 
when you install Flash, Dreamweaver, InDesign, or Fireworks. You can 
use the Extension Manager to access the Adobe Exchange site, where 
you can locate, research, and download many different types of exten-
sions. Some are free and some are not. After you download an exten-
sion, you can use Extension Manager to install it. Extension Manager 
only displays extensions installed using the Extension Manager; other 
extensions installed using a third-party installer might not appear. After 
you install an extension, you can find and display information about it.

Using Adobe 
Extension Manager

Download and Install an
Extension

Start Adobe Extension Manager 
from the Start menu (Win) or the 
Applications folder (Mac).

TIMESAVER In Flash, 
Dreamweaver, InDesign, or 
Fireworks, click the Help menu, and 
then click Manage Extensions.

Click the Exchange button on the 
toolbar.

Select the extension you want to 
download, and then save it to your 
computer.

In Extension Manager, click the 
Install button on the toolbar.

Locate and select the extension 
(.mxp) you want to install, and then 
click Install.

You can perform any of the 
following:

◆ Sort. Click a column heading.

◆ Enable or Disable. Select or 
clear the check in the Enabled 
check box next to the extension.

◆ Remove. Select the extension, 
and then click Remove.

When you’re done, click the Close 
button in the Extension Manager 
window.
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New! Features

n

n
Adobe Flash Professional CS5
Adobe Flash Professional CS5 means superior results faster, with new features and 
enhancements that help you create and manage your images more easily and effi-
ciently. The indispensable new and improved features help graphic web designers, 
photographers, and video professionals create the highest quality images, with the 
control, flexibility, and capabilities that you expect from the professional standards 
in desktop digital imaging.

Each new release of Flash brings with it new features, improvements, and added 
sophistication. This edition is aimed at the Web designer, interactive media profes-
sional, or subject matter expert developing multimedia content, and the application 
developer.

Only New Features
If you’re already familiar with Flash CS4, you can access and download all the tasks 
in this book with Adobe Flash CS5 New Features to help make your transition to the 
new version simple and smooth. The Flash CS5 New Features as well as other Flash 
CS4 to Flash CS5 transition helpers are available on the Web at 
www.perspection.com.

What’s New
If you’re searching for what’s new in Flash CS5, just look for the icon: New!. The new 
icon appears in the table of contents and throughout this book, so you can quickly 
and easily identify a new or improved feature in Flash CS5. The following is a brief 
description of each new feature and its location in this book.

Flash Professional CS5
◆ Adobe CS Live (p. 4, 522) Adobe CS Live is an online service that allows you 

to set up or manage an Adobe account, and access an Adobe Web site with CS 
Live online services. You can access these options directly from the CS Live 
menu on the right side of the menu bar next to the Search bar.

◆ Welcome Screen (p. 5) You can work in other programs as Flash starts up. 
When you start Flash, the Welcome screen no longer stays in front, so you can 
work in other programs
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n

◆ Packaging Applications for the iPhone (p. 12, 385-408) Flash includes a 
packager for iPhone that allows Flash files to be deployed as iPhone 
applications.

◆ Templates (p. 13) Flash includes a range of new templates that make it easier 
to create common types of projects in Flash. The templates appear in the 
Welcome screen and the New Document dialog.

◆ XFL File Format (p. 14, 20-21) Flash FLA files now contain a new internal 
format called XFL (eXtensible Form Language). This new format is based on 
XML. The new format enables better exchange of data with other Adobe 
applications, and allows you to optionally work in uncompressed XFL format. 

◆ Uncompressed XFL File Format (p. 20-21) The uncompressed XFL file format 
allows you to see each of the separate parts, or sub-files,that make up a Flash 
file. This enables working in team environments with source control systems. 

◆ Adobe Community Help (p. 24-25) When you start Flash Help, the Adobe 
Community Help window opens, displaying help categories and topics. You can 
search product help from Local Help, Community Help, or Adobe.com by using 
keywords or phrases or browsing through a list of categories and topics. 

◆ Adobe Updater (p. 26-27) The Adobe Updater Preferences dialog box allows 
you to set update options for Flash and other installed Adobe products, such as 
Bridge. You can also set an option to have Adobe notify you of updates in the 
menu bar.

◆ Text Layout Framework (TLF) (p. 62, 163, 165-179, 182, 184) The TLF text 
engine provides significantly improved control over text properties and flow. You 
can create columns, rotate text, indent text, change text direction and 
orientation, change text case, adjust the text baseline, and apply text blending 
and color effects in the Property Inspector. 

◆ SWF Size History (p. 65, 500) The Document Property inspector now displays 
the size of all SWF files generated during Test Movie, Publish, a Debug Movie 
operations.

◆ Font Embedding (p. 65, 184-185) Font embedding is FLA file based instead of 
text object based. The Font Embedding dialog box provides quick access to all 
font embedding functions. 

◆ Info Panel (p. 88) The Info panel displays live values while you draw, move, or 
resize an object.

◆ Color Panel (p. 98, 105) The Color panel displays HSB values and changes 
gradient flow options. 

◆ Decorative Drawing Tool Effects (p. 109) Several new effects have been added 
to the Decorative Drawing tool. You can use brushes to draw buildings, flames, 
lightning, trees, and other animations.

◆ Edit with Photoshop CS5 (p. 208) You can perform round-trip editing of bitmap 
graphics in Photoshop CS5. 

◆ Spring Properties for IK Bones (p. 292-293) Strength and Damping properties
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enable IK bones to display realistic physical effects in bone animation. 

◆ Skins (p. 327) The The Video Import Wizard includes additional skins for the 
FLVPlayback component.

◆ FLVPlayback Live Preview on Stage (p. 328-329) When you import a video, 
Flash places the video on the Stage with the first frame and playback controls 
at the bottom. You can use the playback controls on the Stage to play and work 
with the video.

◆ Components Inspector Panel (p. 328-329, 428-431) Component parameters are 
no longer available in the Parameters tab of the Components Inspector panel. 
The parameter options are available in the Property Inspector.

◆ Video Cue Points (p. 332-333) With Flash video, you can create and manage 
ActionScript cue points in the Properties panel. A cue point is a marked 
moment in time within a video clip.

◆ Auto Close-Bracket Insertion (p. 348-349, 371) When you type an open bracket { 
in the Actions panel or Script window, Flash automatically adds the 
corresponding close bracket } to save you time writing code and debugging.

◆ Code Snippets Panel (p. 349, 372-373, 412) The Code Snippets panel allows 
non-programmers to apply ActionScript 3.0 code for common interactions 
without learning ActionScript. 

◆ Flash Builder Workflows (p. 349, 506-507) Flash Professional CS5 and Flash 
Builder 4 work together to make it easier to work with ActionScript code.

◆ Flash Player Detection (p. 368, 487) Flash uses SWObject2 for version 
detection and embedding SWF into Web pages.

◆ Code Hinting for Custom Classes (p. 370-371) Code hinting is enabled for 
custom ActionScript 3.0 classes in addition to the built-in classes. Flash also 
automatically imports custom classes you use.

◆ Compiler Errors Panel (p. 418-419) When a problem is encountered, Flash 
displays the location and description of the warnings and errors in the Compiler 
Errors panel, where you can show or hide warnings or errors, scroll through 
each one, and display/highlight them in the code. 

◆ Reorganized AIR Publishing Settings (p. 482-483, 510-511) The AIR Application 
& Installer Settings dialog box has been reorganized for simpler, easier access to 
the many settings required when publishing for Adobe AIR. 

◆ Test Movie (p. 500) The Test command allows you to quickly see your movie 
on different devices and players—Flash Professional, Device Central or Air 
Debug Launcher (Desktop or Mobile)—without leaving the program. 

◆ FXG File Format (p. 508-509) The FXG file format allows Flash to exchange 
graphics with other Adobe applications with full fidelity. 

◆ Motion Objects JSAPIs Several new JavaScript APIs have been added for 
manipulating motion tweens in the Flash Professional CS5 authoring 
environment. n
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What Happen To ...
◆ Screen-based Flash Documents Flash CS5 can no longer open or create 

Screen-based Flash documents. All JavaScript API related to screens have been 
removed. 

◆ Version Cue Version Cue is not available in Flash CS5. If you want to work with 
a common set of files in a collaborative environment, please use a 3rd party 
source control solution. 

◆ Data Binding Components The ActionScript 2.0 Data components are no longer 
available in the Components panel.

◆ Some File Formats Flash CS5 can no longer import FreeHand, PICT, PNTG, SGI 
and TGA files, and export EMF files, WMF files, WFM image sequences, BMP 
sequences, or TGA sequences.

◆ Save and Compact Command Since the new default FLA file format contains 
XFL formatted data, the Save and Compact command is no longer necessary. 

n
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About the Adobe Certified Expert (ACE) Program
The Adobe Certified Expert (ACE) program is for graphic designers, Web designers, 
systems integrators, value-added resellers, developers, and business professionals 
seeking official recognition of their expertise on Adobe products.

What Is an ACE?
An Adobe Certified Expert is an individual who has passed an Adobe Product Profi-
ciency Exam for a specific Adobe software product. Adobe Certified Experts are eli-
gible to promote themselves to clients or employers as highly skilled, expert-level 
users of Adobe software. ACE certification is a recognized worldwide standard for 
excellence in Adobe software knowledge. There are three levels of ACE certification: 
Single product certification, Specialist certification, and Master certification. To 
become an ACE, you must pass one or more product-specific proficiency exams and 
sign the ACE program agreement. When you become an ACE, you enjoy these spe-
cial benefits:

◆ Professional recognition

◆ An ACE program certificate 

◆ Use of the Adobe Certified Expert program logo

What Does This Logo Mean?
It means this book will prepare you fully for the Adobe Certified Expert exam for 
Adobe Flash Professional CS5. The certification exam has a set of objectives, which 
are organized into broader skill sets. The Adobe Certified Expert objectives and the 
specific pages throughout this book that cover the objectives are available on the 
Web at www.perspection.com.

FL 3.1
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Choosing a Certification Level
There are three levels of certification to become an Adobe Certified Expert. 

◆ Single product certification. Recognizes your proficiency in a single Adobe 
product. To qualify as an ACE, you must pass one product-specific exam. 

◆ Specialist certification. Recognizes your proficiency in multiple Adobe products 
with a specific medium: print, Web, or video. To become certified as a Specialist, 
you must pass the exams on the required products. To review the requirements, 
go online to http://www.adobe.com/support/certification/ace_certify.html.

◆ Master certification. Recognizes your skills in terms of how they align with the 
Adobe product suites. To become certified as a Master, you must pass the exam 
for each of the products in the suite. 

Preparing for an Adobe Certified Expert Exam
Every Adobe Certified Expert Exam is developed from a list of objectives, which are 
based on studies of how an Adobe program is actually used in the workplace. The 
list of objectives determine the scope of each exam, so they provide you with the 
information you need to prepare for ACE certification. Follow these steps to com-
plete the ACE Exam requirement: 

Review and perform each task identified with a Adobe Certified Expert objective 
to confirm that you can meet the requirements for the exam. 

Identify the topic areas and objectives you need to study, and then prepare for 
the exam. 

2

1
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Review the Adobe Certified Expert Program Agreement. To review it, go online 
to http://www.adobe.com/support/certification/ace_certify.html.

You will be required to accept the ACE agreement when you take the Adobe 
Certified Exam at an authorized testing center.  

Register for the Adobe Certified Expert Exam. 

ACE testing is offered at more than a thousand authorized Pearson VUE and 
Thomson Prometric testing centers in many countries. To find the testing center 
nearest you, go online to www.pearsonvue.com/adobe (for Pearson VUE) or 
www.2test.com (for Prometric). The ACE exam fee is US$150 worldwide. When 
contacting an authorized training center, provide them with the Adobe Product 
Proficiency exam name and number you want to take, which is available online 
in the Exam Bulletin at http://www.adobe.com/support/certification/ 
ace_certify.html.

Take the ACE exam.

Getting Recertified
For those with an ACE certification for a specific Adobe product, recertification is 
required of each ACE within 90 days of a designated ACE Exam release date. There 
are no restrictions on the number of times you may take the exam within a given 
period.

To get recertified, call Pearson VUE or  Thomson Prometric. You will need to verify 
your previous certification for that product. If you are getting recertified, check with 
the authorized testing center for discounts.

5

4

3
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Taking an Adobe Certified Expert Exam
The Adobe Certified Expert exams are computer-delivered, closed-book tests con-
sisting of 60 to 90 multiple-choice questions. Each exam is approximately one to 
two hours long. A 15-minute tutorial will precede the test to familiarize you with the 
function of the Windows-based driver. The exams are currently available worldwide 
in English only. They are administered by Pearson VUE and Thomson Prometric, 
independent third-party testing companies. 

Exam Results
At the end of the exam, a score report appears indicating whether you passed or failed 
the exam. Diagnostic information is included in your exam report. When you pass 
the exam, your score is electronically reported to Adobe. You will then be sent an 
ACE Welcome Kit and access to the ACE program logo in four to six weeks. You are 
also placed on the Adobe certification mailing list to receive special Adobe 
announcements and information about promotions and events that take place 
throughout the year.

When you pass the exam, you can get program information, check and update your 
profile, or download ACE program logos for your promotional materials online at:

http://www.adobe.com/support/certification/community.html

Getting More Information
To learn more about the Adobe Certified Expert program, read a list of 
frequently asked questions, and locate the nearest testing center, go online to:

http://www.adobe.com/support/certification/ace.html
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To learn more about other Adobe certification programs, go online to:

http://www.adobe.com/support/certification
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A
Actions panel 

breakpoints, setting, 423 
viewing, 348

ActionScript Editor, debugging with, 
412-413

ActionScript Server files, 14 
ActionScript Virtual Machine (AVM), 350 
ActionScripts, 10, 131, 347. See also

behaviors; components; conditional 
statements; debugging; dot syntax; 
methods; properties

animation, creating, 288 
classes, 375-377

drawing shapes, 384 
clip events, 358-359 
code hints, 370-371 
code snippets, 372-373 
data, controlling, 380 
data types, 353 
DOM event model, 374 
for dynamic text, 186 
expressions, regular, 382 
external SWF files, loading, 451 
files, 14 
frame events, 357 
functions, using, 354 
motion tween as ActionScript, 

copying, 250, 259 
mouse events, 356 
Namespaces, 378-379 
new version, introducing, 350 
preferences, setting, 349 
printing with, 492 
settings, 3.0, 368-369 
similarities between 2.0 and 3.0, 367 
text, controlling, 383 
using, ActionScript 3.0, 366-367

video with, 334-335 
warning preferences, 65 
XML with E4X, 381

activating masks, 301 
Adaptive color palette, 489 
Add Statement, 348 
Adjust Color effect, 246-247 
Adobe AIR, 482-483

create, 482, 510 
install and start, 511 
publish, 483

Adobe After Effects, 340 
Adobe Bridge, 14-15 
Adobe ConnectNow, 523 
Adobe CS Live, 522 
Adobe Extension Manager, 524 
Adobe Fireworks. See Fireworks 
Adobe Flash Builder

create, ActionScript file, 506 
open in, 506-507

Adobe Flash Exchange Web site 
commands, downloading, 475 
Extend link for accessing, 4 
resources on, 27 
updates and support on, 26-27

Adobe Flash Player. See Flash Player 
Adobe Flash Support Online Web site

templates on, 13
updates and support on, 26-27

Adobe Flash Video. See Flash movies; FLV 
files

Adobe FXG 
import and export, 508-509

Adobe Illustrator. See Illustrator 
Adobe Photoshop. See Photoshop 
Adobe Premiere for alpha masks, 342-343 
Adobe Soundbooth, 307, 323 
ADPCM compression, 320
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advanced colors. See colors 
advanced text options, 178-179 
Advertising templates, 13 
alignment

with guide layers, 41 
HTML alignment, setting, 487 
of paragraph text, 172

alpha 
instance alpha, modifying, 158, 160 
masks, working with, 342-343 
motion tween, adding to, classic, 268 
publishing movies, setting on, 489 
shape tween alpha, changing, 285

anchor points, 81 
arrow keys for moving, 116 
corner points to curve points, 

converting, 116-117 
curve points to corner points, 

converting, 116-117 
deleting, 111 
Pen tool using, 110 
types of, 116-117

AND conditional statement, 355 
animations. See also frame-by-frame ani-

mation; GIF files; motion tweening 
anti-aliasing for, 182 
buttons, adding to, 151 
of filters, 247 
masks, animating, 306 
symbols, converting to, 139 
sync sounds, adding, 309

anti-aliasing text, 182 
API (application programming interface)

and components, 427 
Apple Final Cut Pro, 340

alpha masks, working with, 342-343 
Arial font, 182

built-in Flash device fonts for, 185 
armature, 289-294 
Arrange command, 133 
arrow keys, 116 
assets in Library, 134-135 
attachMovie() method, 359 
attributes, list of, 465 
audience, determining, 8 
audio. See sounds 
Audio Video Interleaved (AVI) files. See AVI

files

authoring parameters, 430, 431 
Auto Close Bracket, 348-349, 371 
Auto Format, 348 
Auto Kerning, setting, 171 
AutoCAD DXF. See DXF files 
AVI files

exporting movies to, 502-503 
AvidXpress DV, 340 
AVM, 365

B
Back button on Edit bar, 46 
backgrounds

attributes, 463 
Property Inspector, changing color in, 16

ball animation. See shape tweening 
bandwidth and debugging, 411 
batch processing video encoding, 340-341 
BBEdit, 351 
behaviors, 10-11

adding behaviors, 362 
instance, changing symbol behavior of,

144-145 
sounds with, 314-315 
Start/Stop Dragging Movie clip

Behaviors, 362 
symbol behavior, changing, 144 
video with, 334-335 
warn on behavior symbol conversion, 65

Behaviors panel, 362 
Bevel effect, 246-247 
bevel joins, 75 
Bézier handles, 81

Pen tool using, 110 
Bind tool, 289, 294 
bindings, 431

creating, 458-459 
modifying, 460-461

Bindings tab, Component Inspector, 429, 
430. See also bindings

bit depth options, 490 
bit rate for sounds, 321 
bitmaps

Break Apart for fill patterns, 211 
center point of fill, changing, 212 
compression, setting, 210 
fills
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Break Apart for fill patterns, 211 
center point, changing, 212 
orientation, changing, 212-213 
resizing, 212-213

Find and Replace for, 190 
Fireworks files, importing, 204-205 
graphics, 194 
Illustrator, importing from, 196 
Magic Wand, editing with, 214-215 
orientation of fills, changing, 212-213 
outside editor, editing in, 208-209 
Photoshop import preferences, 198-199 
PNG bitmaps, importing, 204-205 
preferences, setting, 63 
replacing, 209 
resizing fills, 212-213 
Stage, importing bitmap to, 202 
support for, 195 
swapping, 203 
text, 182 
tracing bitmaps, 216

blending 
instance blend, modifying, 159 
shape tween, setting for, 284

Blur effect, 246-247 
BMP files, 193 
Bones tool, 289-294

properties, 292-293 
Boolean data, 353 
borders

for dynamic text, 186 
for input text, 187 
for Label components, 446

Bound To dialog box, 461 
Break Apart, 163, 180-181

bitmap fill pattern, creating, 211 
breaking

instances, 155 
setting breakpoints, 423 
text fields, 180-181

brightness 
instances, modifying brightness of, 158 
motion tween, adding to, classic, 268

Bring to Front/Bring Forward, 133 
browsers

identifying playback browser, 9 
printing from Flash Player, 492

system requirements, 2 
building movies, 10-11 
Button component, adding, 442-443 
button objects, 351 
buttons. See also RadioButton

animation, adding, 151 
creating, 150-151 
enabling/disabling, 152 
invisible buttons, creating, 153 
mouse events, attaching, 356 
window sizing buttons, 19

C
calling functions, 302 
camera data file information, 484-485 
caps, 75 
case-sensitivity in ActionScripts, 347 
cell phones

content for PDA, creating, 512
deployment of Flash movies to, 515

center of gradient fills, changing, 121 
centering text, 172 
characters. See also kerning

breaking text fields into, 180 
for dynamic text, 186 
for input text, 187 
options, setting, 182

circles, creating, 79 
classes

object-oriented programming, 364 
working with ActionScript 3.0, 376-377

Classic text, creating, 
dynamic and input text, 186-187 
static text, 164

classic tween. See motion tweening 
Clear Keyframe function, classic, 264-265 
clip events, 358-359

attaching to movie clips, 359 
Clipboard

pasting images from, 207 
preferences, setting, 63

Close button, 19 
closing

documents, 28 
History panel, 467 
panels, 52
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code hints, 348 
custom classes, 370-371 
in debugging, 413 
setting, 349 
using, 370-371

Code Snippets panel, 349, 372-373, 412 
ColdFusion, 448 
collapsing. See maximizing/minimizing 
Color panel

bitmap fill, selecting, 211 
fill colors, changing, 97 
gradients in, 105 
for shape tween, 285 
specifying colors in, 98 
stroke color, changing, 98 
text colors, changing, 169

color palettes 
importing, 99 
for shape tween, 285 
type options, 489 
Web 216 color palette, 489 
working with, 98-99

Color Picker, 98-99 
colors. See also backgrounds; color

palettes; GIF files; gradients; 
instances; PNG files; RGB colors; 
Swatches panel; syntax-coloring

advanced colors 
motion tween, adding effects to, 

classic, 268 
simultaneously modifying color and

transparency, 160 
attributes, 463 
fill colors, changing, 96-97 
Find and Replace for, 190 
font colors, changing, 169 
highlight color preferences, setting, 162 
instances, modifying color of, 158-159 
Kuler panel, 100-101 
motion tween, adding effects to, classic,

268 
shape tween colors, changing, 285 
stroke color, changing, 98 
TextArea component, adding, 440-441 
tint color of instance, modifying, 158 
values, creating custom colors with, 98

column of vertical text, creating, 175-176 
column text, TLF, 174

ComboBox component, adding, 434-435 
commands, 31

deleting names of, 474-475 
help commands, 25 
History panel, saving steps as command

in, 474-475 
for Onion Skin markers, 235 
running command, 475 
saving steps as, 474-475

comments 
in Actions panel, 348 
with ActionScript Editor, 413 
breakpoints, setting, 423

compatibility of ActionScripts, 365 
Compiler Errors panel, 418-419 
Component Inspector, 429. See also

components; parameters 
authoring parameters, 430 
Bindings tab, 430, 458 
description of, 430 
Schema tab, 430, 462, 462

components, 10-11, 14, 427. See also bind-
ings; DataGrid component; 
parameters; schemas

API (application programming interface) 
in, 427

attributes, modifying, 463
basic components, understanding, 

428-429 
Button component, adding, 442-443 
categories of, 429 
CheckBox component, adding, 436-437 
ComboBox component, adding, 434-435 
forms, building, 464 
Label component, adding, 446-447 
List component, adding, 444-445 
Loader component, adding, 451 
NumericStepper component, adding,

452-453 
preloaders with, 451 
ProgressBar component, adding, 
454-455 
RadioButton component, adding, 

438-439 
ScrollPanel component, adding, 456-457 
TextArea component, adding, 440-441 
TextInput component, adding, 432-433

compression 
bitmap compression, setting, 210
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of Flash movies, 480 
for sounds, 320

conditional statements, 360 
using, 355

connected lines, drawing, 130 
Consumer Devices, 13, 512 
context-sensitive help, 412 
Convert To Symbol dialog box, 139, 149 
Copy Frames command, 226-227 
Copy Steps button, 476 
copying

bitmap images, 207 
files, 21 
frame sequence, 43 
keyframes, 43, 226 
layers or folder contents, 38-39 
motion tweens, 258-259 
other programs, images from, 207 
steps between documents, 476

corner points to curve points, converting, 
116-117

CPU requirements, 9 
CS Live, 522 
CSS (Cascading Style Sheets), 191 
cue points

ActionScript, adding, 332-333 
embedded, 340-341

Current Script tag, 348 
curve points to corner points, converting,

116-117 
curves

drawing smooth curves, 130 
line segments, creating, 112 
Pen tool, drawing with, 112-113 
S-curves, creating, 113 
shapes, optimizing, 77

customizing. See also colors 
color palette, 489 
keyboard shortcuts, 58 
Tools panel, 50-51

D
data binding. See bindings 
data components. See components 
data types, 353 
DataGrid component

adding, 448

local data provider, using, 450 
options, modifying, 449

Debugger, 416-420. See also properties; 
variables

ActionScript 2.0, 420 
ActionScript 3.0, 416-417 
breakpoints, setting, 424 
compiler errors, 418-419 
stepping through code, 425

debugging, 409. See also Debugger 
in Actions panel, 348 
with ActionScript Editor, 412-413 
bandwidth and, 411 
breakpoints, 412 
concepts of, 410-411 
Flash movies, permitting debugging of,

480 
Flash Player, 426 
manual debugging, 426 
with Movie Explorer, 414-415 
planning and, 411 
testing and, 411

Deco tool, 109 
defaults

Snap Align defaults, saving, 95
Toolbar defaults, restoring, 51

delay, setting, 349 
deleting. See also masks; motion tweening

anchor points, 111 
Command menu, name from, 474 
commands, names of, 474-475 
files in dialog box, 22 
font mapping, 183 
frames, 43 
keyboard shortcut sets, 58-59 
keyframes, 224-225 
layers/folders, 34-35 
panel sets, 57 
scenes, 45 
shape tween, keyframes from, 278

delivery computer system, identifying, 9 
deployment

Flash deployment kit, 478 
to other devices, 515

device fonts, setting, 184-185 
DICOM file information, 484-485 
dictionaries, using, 188 
Digital Juice, 308
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direction, text, TLF, 175 
display components. See components 
distorting shapes, 120 
Distribute to Layers command, 129 
dithering on publishing movies, 490 
docking/undocking panels, 54 
Document window, 7, 30-31

frame rates, changing, 262 
documents. See also layers; printing; 

projects 
arranging multiple windows, 18 
blank document, creating, 12 
closing, 28 
copying steps between documents, 

476 
creating

Adobe AIR, 482 
existing documents, opening, 14-15 
general preferences, setting, 60 
languages for, 187 
last saved version, reverting to, 20 
launching, opening documents on, 5 
mouse, resizing windows with, 19 
moving document windows, 19 
multi-language authoring, 187 
projector document, creating, 493 
properties

setting up, 10 
working with, 16-17

recently opened documents, opening, 15 
resizing document windows, 19 
saving, 20

different name/location, saving 
with, 21 

formats for, 22 
multiple documents, 20 
templates, saving as, 23

switching between, 18
templates 

creating new document from, 13 
saving document as, 23

dot syntax 
description of, 352 
movie clips, applying to, 352

Down state for buttons, 150 
downloading

commands, 475 
10-second rule, 504

drag-and-drop 
DataGrids, 448 
keyframes, 227 
Library items, 134-135 
motion tween, keyframes in, 264

drawing 
Line tool for, 75 
masks, 300 
model options, 61 
Oval tool, 78 
Pencil tool for, 76-77 
Polystar tool, 80 
Rectangle tool, 78-79 
rounded rectangle, 79 
selection examples, 81 
settings, changing, 130

Drop Shadow effect, 246-247 
duplicating profiles, 498 
dynamic media, 10 
dynamic text. See text

E
ease properties. See also motion tweening 

shape tween, setting for, 284
ECMAScript, 348 
Edit bar, 7

scenes, selecting, 44 
showing/hiding, 46

Edit in New Window mode, 140 
Edit In Place mode, 140 
Edit Snapping dialog box, 94-95 
editable parameters, 430 
editing. See also bitmaps; outside editors;

symbols 
keyframes, 226-227 
Library, items in, 136-137 
masks, 302 
Onion Skins, 233 
profile properties, 495 
scene for editing, selecting, 47 
sounds, 322 
with Video Encoder, 340-341

effects, sound, 319 
e-mail

sending a document, 521 
embedding. See also fonts

audio files, 309
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data providers, 450
empty keyframe, creating, 220-221

Enable Simple Buttons command, 152 
Enhanced Metafile (EMF)

support for, 195 
EPS files, 193

importing options, 200 
equals (=) statement, 355 
event handlers

clip events, 358-359 
frame events, 357

events. See also ActionScripts; event 
handlers

mouse events, 356 
existing documents, opening, 14-15 
expanding/collapsing. See maximizing

minimizing 
exporting. See importing/exporting 
Extend link, 4 
Eye icon, 36 
Eyedropper tool

for bitmap fills, 211 
fills, editing, 104 
strokes, editing, 104

F
file formats 

exporting movies to different formats,
502-503 

import file formats, 195 
list of existing documents, opening, 

14-15 
files

debugging, file names and, 410 
deleting, 22 
text files, loading, 164

fills. See also bitmaps; gradients 
Selection tool, selecting with, 84 
colors, changing, 96-97 
Eyedropper tool, editing with, 104 
locking gradients, 106 
Paint Bucket, editing with, 103 
text fills, 169

filter effects, applying, 246-247 
Find and Replace, 190

for active script, 348 
Fireworks

importing files, 204-205

pasting images from, 207 
FLA files. See documents 
Flash, 1 
Adobe Flash Builder

create, ActionScript file, 506 
open in, 506-507

Flash deployment kit, 478 
Flash File for mobile devices, 512 
Flash Live Video files. See FLV files 
Flash movies, 14 See also debugging; pub-

lishing movies 
Bandwidth Profiler, working with, 504 
different formats, exporting movie to,

502-503 
exporting

different formats, exporting movies 
to, 502-503

video clips into FLV format, exporting, 
346

Flash Player, optimizing for, 480 
For loops for pausing, 361 
planning, 8 
previewing, 499 
progressive downloads, 346 
search engine searchability, improving,

17 
security for local/network playback, 481 
testing, 501 
video-editing applications, exporting

files from, 340-341 
Flash Player, 2

debugging, 426 
component, 338-339 
frame-by-frame animation, testing, 231 
installation, 3 
magnification, changing, 499 
masking and, 298 
optimizing movies for, 480 
printing from, 492 
support for, 195 
Version Detection, 487

Flash Project files, 14 
Flash Remoting, 448 
Flash Video Import Wizard, 325 
Flash window, 30-31 
FlashType, 182 
flipping instances, 157 
flowcharts, developing, 8
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FLV files, 10, 327. See also Flash movies 
exporting directly to, 346 
Property Inspector, modifying video clips

in, 346 
FLV (Flash Video) QuickTime Export plug-in,

340-341 
FLVPlayback component, 338-339 
folders. See also layers

Library assets, creating folders for, 12 
overlapped root folder warning, 65 
renaming (See naming/renaming)

Font Mapping dialog box, 183 
fonts

ActionScript text, setting for, 349 
anti-aliasing, 182 
attributes, 463 
built-in Flash device fonts, 185 
colors, changing, 168-169 
deleting font mapping, 183 
device fonts, setting, 184-185 
embedded fonts, 184

warning, 64-65 
Find and Replace for, 190 
mapping, 183 
missing font information, 184 
preferences, setting, 62 
size, changing, 169 
substitute fonts, selecting, 183 
symbols to embed font, creating, 

136-137 
TextArea component, adding, 440-441 
type, changing, 168 
warn on missing fonts, 64

For loops, 360 
working with, 361

foreign languages. See languages 
forms

components for building, 464 
45 degree angles, creating, 111 
frame-based selection, 223 
frame-by-frame animation, 217. See also

Onion Skinning 
Controller, playing with, 230 
description of, 218-219 
exporting to Flash movie, 230 
Flash Player, testing in, 231 
keyframes, 217

clearing, 224

converting frames to, 222 
copying, 226 
creating, 220-221 
deleting, 224-225 
drag-and-drop, 227 
editing, 226-227 
empty keyframe, creating, 220-221 
pasting, 226 
removing content from, 220 
selecting frames, 223 
span of keyframe, increasing, 221

multiple frames, editing, 236 
playing animation, 230-231 
selecting frames, 223 
simple animation, creating, 228-229

frame events, 357 
frame rate, 16

motion tween, changing in, 262 
Property Inspector, changing in, 16

frames. See also keyframes; scenes 
copying frame sequence, 43 
deleting, 43 
inserting, 43 
moving frame sequence, 43 
selecting, 42 
warn on inserting frames when import-

ing content, 64 
Windows, setting in, 68

Free Transform tool 
distorting shapes in, 120 
instances, working on, 156-157 
scale of object, changing, 118 
for text, 181

Free Transform tool 
envelope of shape, changing, 120 
rotating object with, 119 
skewing object with, 119

functions, using, 354 
FXG file format

importing and exporting, 508-509

G
general preferences, setting, 60-61 
Generator content, warn on reading, 64 
geometric forms for shape tweening, 276 
GIF files, 193

lossless compression with, 210
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publishing movies, specifying options 
when, 488-489

support for, 195 
Global Transform, 3D, 122-123 
Glow effect, 246-247 
Gradient Bevel effect, 246-247 
Gradient Transform tool, 121

for bitmap fills, 212-213
gradients 

locking, 106 
multi-color gradient, creating, 105 
publishing movies, settings on, 490 
quality, setting, 63 
transforming gradient fills, 121

graphic symbols, 148-149 
graphics, 73. See also bitmaps; drawing;

importing/exporting; layers; symbols; 
vector graphics

bitmap graphics, 194 
filter effects, applying, 246-247 
grouping/ungrouping, 132 
pasting objects between layers, 126-127 
symbols, converting to, 149 
vector graphics, 194 
warning preferences, setting, 65

greater than (>) statement, 355 
greater than or equal to (>=) statement, 355 
grids and guides. See motion tweening

creating guides, 91 
guide layers, 40-41 
locking/unlocking, 91 
modifying, 92-93 
showing/hiding, 90 
snap to grid, locking/unlocking, 91 
turning on/off, 91

grouping/ungrouping, 131 
artwork, 132 
Illustrator import preferences, 197 
panels, 55 
Photoshop import preferences, 198-199 
stacking order, changing, 133

guides. See grids and guides

H
Hand tool, 47, 88 
hardware requirements, 9 
help, 24-25

in Actions panel, 348 
commands, 25 
context-sensitive help, 412

Helvetica font, 182 
built-in Flash device fonts for, 185

hidden layers. See publishing movies 
hiding. See showing/hiding 
highlight color preferences, setting, 162 
hints. See also code hints

for shape tween, 286-287 
Stroke hinting, 75

History file information, 484-485 
History panel, 465

clearing, 467 
command, saving steps as, 474-475 
copying steps between documents, 

476 
description of, 466 
object level undo, working with, 468-469 
opening/closing, 467 
Options button, 466 
repeating previous steps with, 466, 470 
replaying steps with, 472-473 
undoing/redoing with, 466, 470-471 
view, changing, 473

horizontal lines, creating, 111 
HTML (Hypertext Markup Language). See

also publishing movies 
CSS (Cascading Style Sheets), 191 
keyboard shortcuts as HTML, 

exporting, 59 
text rendered as, 186

HTTP/HTTPS security, 481

I
IK animations and bones, 289-293 
Illustrator, 193

converting layers options, 201 
exporting Flash movies to, 502-503 
file information, 484-485 
import preferences, setting, 196-197 
options for importing files, 200-201 
Pen tool, 110 
support for, 195

Import dialog box, 206 
Import Script, 412 
Import To Stage method, 202
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importing/exporting. See also Flash movies; 
publishing movies; video; specific file 
formats

color palettes, importing, 98-99
different formats, exporting movie to,

502-503 
file formats for, 195 
Fireworks PNG files, 204-205 
FLV format, exporting directly to, 346 
frame-by-frame animation , 

exporting, 230 
keyboard shortcuts as HTML, 

exporting, 59 
media elements, 10 
multiple files, importing, 206 
profiles, 496-497 
scripts, 412 
sequence of files, importing, 206 
sounds, 308-309 
warning preferences, setting, 64-65

incompatibility warning preferences, 65 
indents for text, setting, 173 
inequality statement, 355 
Info panel, 88 
inheritance, 377 
Ink Bottle tool, 102 
iPhone, 385-408

Accelerometer, in App, 394 
App ID, creating, 389 
Camera Roll, saving images, 395 
Device ID, 397 
Developer, becoming, 386-387 
Geolocation, in App, 407 
limits of Flash, 396 
Multitouch, in App, 408 
Profiles

Developer Provisioning, 390-391 
Ad Hoc Distribution

Publishing/Packaging 
Ad Hoc, 399 
iPhone App, 392-393 
iTunes App Store, 400-401 
iTunes Connect, 402-405

registering an iPhone or testing device, 
388

Screen Orientation, in App, 406 
input method, setting, 62 
input text. See text

IPTC file information, 484-485 
inserting file information, 484-485 
Insert Target Path, 348 
installation

preparation for, 2 
standard application install, 3

instances 
advanced color options, 160 
behavior, changing, 144-145 
blend, modifying, 159 
breaking, 155 
brightness, modifying, 158 
for dynamic text, 186 
flipping, 157 
for graphic symbols, 148-149 
for input text, 187 
movie clip instances, 154 
multiple instances, working on, 156 
properties, changing, 431 
rotation, modifying, 156-157 
scale, modifying, 146-157 
simultaneously modifying color and

transparency, 160 
Stage, placing on, 142 
swapping, 146-147 
tint color, modifying, 158 
transparency, modifying, 159, 160

Integrated Script window, 413 
interlacing on publishing movies, 490 
Inverse Kinematics, 289-294 
invisible buttons, creating, 153

J
Java recordsets, 448 
JavaScript, 14

commands, running, 475 
History panel steps, viewing, 473

joins, 75 
JPEG files, 10,193

publishing movies, specifying options 
when, 492

Quality slider, dragging, 481 
support for, 195

JSFL language, 51 
justifying text, 172
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K
kerning 

adjusting, 170-171 
Auto Kerning, setting, 171 
preferences, setting, 62

keyboard controlling radio buttons, 438 
keyboard shortcuts, 31

adding, 59 
deleting, 58-59 
HTML, exporting as, 59 
open path, ending, 110 
sets, creating, 58 
Toolbar, identifying for, 51

keyframes, 42. See also frame-by-frame 
animation; motion tweening; shape 
tweening

copying, 43, 226 
moving, 43

Kuler panel, 100-101

L
Label component, adding, 446-447 
labels

Label component, adding, 446-447 
landscape orientation

Macintosh, setting in, 66 
Windows, setting in, 68

languages 
ActionScript language, setting, 349 
character options, setting, 182 
multi-language authoring, 187

Lasso tool 
general preferences, setting, 61 
with Magic Wand, 215 
in polygon mode, 85 
selecting with, 85

launching 
Flash, 4-5 
preferences on launch, setting, 60

Layer Properties dialog box, 40, 303 
layers, 40. See also masks; motion 

tweening 
copying layers or folder contents, 38-39 
deleting layers/folders, 34-35 
distributing graphics to, 129 
expanding/collapsing folders, 38

guide layers, 40-41 
height, changing, 40 
Illustrator import preferences, 197 
inactive layers, editing object on, 128 
layer folder, creating, 34 
locking/unlocking, 36, 40 
moving layers/folders, 38 
multiple layers, selecting, 35 
naming/renaming, 34, 35, 40 
new layers/folders, creating, 34 
outlines, viewing contents as, 36-37 
pasting objects between, 126-127 
Photoshop import preferences, 198-199 
pose, 289 
properties, changing, 40 
renaming, 34, 35, 40 
selecting, 34-35 
separate layers, placing objects on, 129 
showing/hiding, 36, 40 
types of, 40

layout 
designing, 8-9 
Windows, setting in, 68

leaf of Tree component, 426 
left-aligning text, 172 
less than (<) statement, 355 
less than or equal to (<=) statement, 355 
Library, 123. See also importing/exporting;

sounds; symbols; video 
accessing options, 137 
bitmaps, importing, 202-203 
items, 350 
opening, 134-135 
organizing item, 136 
other libraries, opening, 134-135 
sample common libraries, 134-135 
sounds, importing, 308-309

line segments
Selection tool, converting with, 115 
Pen tool, creating with, 112

line spacing, setting, 173 
Line tool, 75 
linear gradients, 105 
lines. See also line segments

connected lines, drawing, 130 
45 degree angles, creating, 111 
horizontal lines, creating, 111 
recognize lines option, 130
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lines (continued) 
vertical lines, creating, 111 
width, changing, 75

linked layers. See masks 
linking Library assets, 137 
linking text, TLF, 166-167 
List component, adding, 444-445 
Loader component, adding, 451 
Lock Fill feature, 106 
Lock icon, 36 
locking/unlocking

gradients, 106 
grids and guides, 91 
layers, 36, 40 
masks, 302

loops 
creating, 360 
exceptions, working with, 360 
for graphic symbols, 148 
sounds, looping, 319

lossless compression, 210 
lossy compression, 210

M
Macintosh computers 

keyboard commands on, 1 
launching Flash, 5 
margins, setting, 66-67 
page setup, working with, 66-67 
printing documents, 70-71 
projector, creating, 493 
system requirements for, 2

Magic Wand bitmaps, editing, 214-215 
magnification

Flash Player, changing in, 499 
Magnifying Glass, 86-87

Magnifying Glass, 86-87 
Main toolbar, 30-31

showing/hiding, 48 
mapping MIDI device sounds, 514-515 
margins

attributes, 463 
Macintosh, setting in, 66-67 
text margins, setting, 173 
Windows, setting in, 68

markers. See Onion Skinning 
mask layers, 40

masked layers, 40 
masks, 295

activating, 301 
adding layers to, 304 
alpha masks, working with, 342-343 
animating, 306 
creating mask layers, 298-299 
deleting

linked layers, 305
mask layers, 303

description of, 296-297 
drawing masks, 300 
editing, 302 
linked layers

activating masks, 301 
deleting, 305 
order, changing, 304

Lock Layer column, 302 
master symbols. See symbols 
Maximize button, 19 
maximizing/minimizing

in Actions panel, 348 
with ActionScript Editor, 413 
layer folders, 38 
panels, 52-53 
Tools panel, 50

media components, 429 
Media Controller

for frame-by-frame animation, 230 
media elements, 10 
menus, 31 
Merge Drawing, 61, 73

converting to Object Drawing shape, 74 
Metadata, 351

file information, 484-485 
methods, 364, 350. See also ActionScripts;

parameters 
applying, 351

MIDI device sounds, mapping, 514-515 
Minimize button, 19 
minimizing. See maximizing/minimizing 
miter joins, 75 
Mobile SWF file information, 484-485 
mobile devices. See cell phones; PDAs 

(personal data assistants) 
monitor resolution requirements, 9 
Motion Editor, 244-249
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motion tweening 
adding color effects and filters, 246-247 
adding frames to tween, 260 
adjusting, motion, 243 
creating,

classic, 251 
motion, 242

color effects, adding, classic, 268 
copying tween, 258-259 
deleting

frames from tween, 260-261 
keyframes, classic, 264-265

ease in/out properties 
customizing, classic, 272 
setting, classic, 257

edit path, motion, 249 
frame properties, classic, 253 
frame rate, changing, 262 
instance properties, 253 
keyframes

adding, 255, 264 
deleting, classic, 264-265 
moving, 255 
work with, motion, 248

length of tween, changing, 260-261 
Motion Editor, 244-249 
motion guides

animating along, classic, 270 
creating, classic, 269 
orienting objects along, classic, 271

pasting tween, 258-259 
presets, motion tween, 240-241 
properties

ease properties, setting, classic, 257
frame and instance properties com-

pared, 253 
pasting properties, 259 
setting, classic, 256-257

reversing frames, 263 
rotation, changing, classic, 266-267 
scale

changing, classic, 266 
rotate and scale, working with, 119

simple motion tween, creating, classic, 
254-255

smoother animation, adding frames for, 
261

target object, 237

understanding, 
classic, 238-239, 252 
differences, 238 
motion, 237, 238-239

working with, classic, 252 
mouse

events, 356 
resizing windows with, 19

movie clips, 154. See also components 
clip events, 358-359 
controlling video through, 336-337 
dot syntax, applying, 352 
Illustrator import preferences, 196-197 
9-slice scaling, using, 161 
Photoshop import preferences, 198-199 
placing video in, 331 
scaling, 161 
ScrollPanel component for, 456-457 
Start/Stop Dragging Movie clip

Behaviors, 362 
symbols, 154 
Timeline, referencing to, 335

Movie Explorer, debugging with, 414-415 
moving

document windows, 19 
files, 21 
frame sequence, 43 
keyframes, 43 
layers/folders, 38 
Tools panel, 50

MPG/MPEG files, 327 
MP3 files, 10

compression, 321 
streaming MP3 file, loading, 316-317

multi-language authoring, 187 
multi-purposing, 478 
music. See sounds

N
named anchor on scene, setting, 61 
naming/renaming

Command menu, deleting name from, 
474

command names, deleting, 474-475 
debugging, file names and, 410 
folders, 21 
keyboard shortcut sets, 58
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naming/renaming (continued)
layers, 34, 35, 40 
with Movie Explorer, 414 
panel sets, 57 
scenes, 44-45 
smart conventions, using, 410-411

navigating 
in help topics, 24 
planning for, 10-11

.Net recordsets, 448 
nodes of Tree component, 426 
normal layers, 40 
Normal selection mode, 81 
number data, 353 
NumericStepper component, adding, 452-

453

O
object data, 353 
objects

working with ActionScript 3.0, 376-377 
Object Drawing, 61, 73

warning preferences, 65 
working with, 74

objects, 364. See also ActionScripts; 
properties

tracking per-object changes, 468-469 
On2 VP6 codec, 346 
onClipEvent(), 358, 359 
Onion Skinning, 217

activating, 232 
manually setting markers, 234 
Modify Onion Markers Window, setting

markers in, 235 
outlines, using, 233

online activation requirement, 3 
opaque setting for publishing movies, 489 
Open dialog box, 21 
open path, Pen tool for, 110 
opening

existing documents, 14-15 
History panel, 467 
launching, opening documents on, 5 
panels, 52 
Scene panel, 44

Options menu, 348 
OR conditional statement, 355

orientation. See also Landscape orientation; 
Portrait orientation 

bitmap fill orientation, changing, 212-213 
text orientation, 176-177

Outline icon, 36 
outlines of layer contents, 36-37 
outside editors

ActionScript code, editing, 351 
bitmaps, editing, 208-209

Oval tool, 78 
ovals, creating, 61, 70 
Over state for buttons, 150 
overlapped root folder warning, 65

P
page setup 

in Macintosh, 66-67 
Windows, working in, 68-69

Page Setup dialog box 
in Macintosh, 66-67 
in Windows, 68-69

page size settings, 68 
Paint Behind mode, 107 
Paint Bucket

fills, editing, 103 
fills with, 98 
sensitivity, setting, 103

Paint Fills mode, 107 
Paint Inside mode, 107 
Paint Normal mode, 107 
Paint Selection mode, 107 
Paintbrush tool, 98, 107 
panel sets

creating, 56 
deleting, 57 
displaying, 56 
renaming, 57

Panel windows, 6 
panels, 30

auto-collapsing, 60 
docking/undocking, 54 
expanding/collapsing, 52 
grouping/ungrouping, 55 
opening/closing, 52

Panels Options menu, 53 
paper size settings, 66-67
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parameters 
authoring parameters, 430, 431 
editing, 430-431 
video, 328-329 
working with, 431

Parameters tab, Component Inspector, 429 
parameters to functions, passing, 302 
password parameters, 430 
Paste Frames command, 226-227 
Paste In Center, 126-127 
Paste In Place, 126-127 
Pasteboard. See Work Area 
pasting

Clipboard, pasting images in, 207 
keyframes, 226 
layers, objects between, 126-127 
motion tweens, 258-259

paths 
bitmap, preserving paths on importing,

208 
in debugging, 410 
Illustrator import preferences, 197

pausing movie with For loops, 361 
PDAs (personal data assistants)

content for PDA, creating, 512
deployment of Flash movies to, 515

PDF files, 193 
importing options, 200 
Macintosh documents, printing, 71

Pen tool, 
closed path, creating, 111 
curves, drawing, 112-113 
deleting anchor points with, 111 
description of, 111 
open path, creating, 110 
options, 130 
S-curves, creating, 113 
selection with, 81 
Show Precise Cursors option, 112

Pencil tool, 
in Smooth mode, 76-77 
in Straighten mode, 76

perspective angle, 3D, 124 
photo compression, 210 
Photo Slideshows, 13 
Photoshop, 193

converting layers options, 201

editing in, 207 
file import preferences, setting, 198-199 
options for importing files, 200-201 
pasting images from, 207 
support for, 195

Pin Script, 348 
pinning multiple scripts, 413 
pixels, 194

document, setting for, 16-17 
planning

debugging and, 411 
movies, 8 
project plans, creation, 8-9

Play Once for graphic symbols, 148 
playhead, 42 
playing

frame-by-frame animation, 230-231 
PNG files, 193

importing, 204-205 
lossless compression with, 210 
publishing movies, specifying options

when, 490-491 
support for, 195

polygons
Lasso tool for, 85 
with Polystar tool, 80

polymorphism, 377 
Polystar tool, 80 
portrait orientation

Macintosh, setting in, 66 
Windows, setting in, 68

pose layer, 289 
preferences

ActionScript preferences, setting, 349 
Clipboard preferences, setting, 63 
general preferences, setting, 60-61 
text preferences, setting, 62 
warning preferences, setting, 64-65

Preferences dialog box. See drawing 
preloaders, 451

ProgressBar component as, 454 
previewing, 11

Flash movies, 499 
Macintosh documents, 71

Primitive mode, 61 
primitive rectangles/ovals, creating, 61, 79 
Primitive shapes, 78

 From the Library of Wow! eBook



ptg

550

printers
Macintosh, setting properties in, 67 
Windows, setting properties in, 69

printing. See also margins 
with ActionScripts, 492 
from Flash Player, 492 
general preferences, setting, 61 
help topics, 25 
Macintosh documents, 70-71 
Windows documents, 72

product updates. See updates 
profiles. See publishing movies 
ProgressBar component, adding, 454-455 
progressive downloads, 346 
Project panel, 516-519 
projector document, creating, 493 
projects

creating and managing, 518-519 
general preferences, setting, 61, 519 
plans, creating, 8-9 
testing, 520

properties, 350. See also documents; 
motion tweening; parameters

applying, 351 
instance properties, changing, 431 
layer properties, changing, 40 
of movie clip symbols, 154 
shape tween properties, setting, 284 
viewing, 423

Property Inspector, 6, 30-31. See also 
behaviors; motion tweening

background color, changing, 16 
bitmaps, swapping, 203 
Color list arrow, 158 
fill colors, changing, 96-97 
Flash FLV video clips, modifying, 346 
frame rate, changing, 16 
kerning, adjusting, 170 
motion tweens, adjusting, classic, 256 
stroke color, changing, 98 
text, rotating, 176

Publish Preview command, 499 
Publish Settings dialog box, 346, 477

security options, 481 
publishing movies, 11, 477 

Adobe AIR, 482-483 
Bandwidth Profiler, working with, 504 
considerations for, 478

duplicating profiles, 498 
editing profile properties, 495 
GIF options, specifying, 488-489 
hidden layers

exporting, 481 
viewing, 37

HTML files, 11 
options, specifying, 486-487

importing/exporting 
different formats, exporting movie to,

502-503 
hidden layers, exporting, 481 
profiles, 496-497 
protecting from import, 480

iPhone 
Ad Hoc, 399 
iPhone App, 392-393 
iTunes App Store, 400-401 
iTunes Connect, 402-405

JPEG options, specifying, 492 
modifying publish settings, 479 
options, specifying, 480-481 
Photoshop import preferences, 199 
PNG options, specifying, 490-491 
previewing movies, 499 
profiles

creating, 494 
duplicating, 498 
editing properties of, 495 
importing/exporting, 496-497

projector document, creating, 493 
sound documents, 320-321 
testing movies, 501

purpose of project, determining, 8 
PushButton type, 151

Q
QuickTime Export Settings dialog box, 

344-345
QuickTime Image support, 195 
QuickTime/QuickTime Pro

exporting movies to, 344-345, 502-503 
FLV Export Plug-in support, 340 
version requirements, 2 
video file support, 327

quitting Flash, 28

 From the Library of Wow! eBook



ptg

Index 551

R
radial gradients, 105 
RadioButton, 151

component, adding, 438-439 
RAM requirements, 9 
raw data file information, 484-485 
raw sounds, 321 
readability, anti-aliasing for, 182 
recordsets, DataGrid component for, 448 
Rectangle Settings dialog box, 79 
Rectangle tool, 78-79

rounded rectangle, drawing, 79 
rectangles

Selection tool, selecting with, 84 
primitive rectangles, creating, 61, 79

redoing. See undoing/redoing 
registration point, creating, 139 
renaming. See naming/renaming 
repeating previous steps with History

panel, 466, 470 
Replace. See Find and Replace 
replaying steps with History panel, 466,

467-470 
resizing

bitmap fills, 212-213 
bitmap graphics, 194 
document windows, 19 
fonts, 168 
gradient fills, 121 
text boxes, 164 
Timeline display, 32

Restore Down button, 19 
Reverse Frames command, 263 
RGB colors

instances, modifying colors of, 160 
values, entering, 98

right-aligning text, 172 
Rotate Text button, 177 
rotation

with Free Transform tool, 119 
gradient fills, 121 
instance, modifying rotation of, 156-157 
motion tween, changing during, classic,

266-267 
Rotation tool, 3D, 122-123 
of text, 175-177 
working with, 119

round joins, 75 
rounded rectangle, drawing, 79 
rulers. See also grids and guides

showing/hiding, 89 
unit of measure, specifying, 17, 89

S
S-curves, creating, 113 
sample rate for sounds, 321 
sans serif fonts, 182

built-in Flash device fonts for, 185 
Save As dialog box

formats for files, 22 
saving Flash FLA file, 20-21 
saving Flash uncompressed XFL file, 21

saving. See also documents
Snap Align defaults, 95 
undo, saving documents after, 471 
warning preferences, setting, 64

scale. See also motion tweening
Free Transform tool for changing, 118 
instance, modifying scale of, 156-157 
Macintosh, setting in, 66-67 
movie clips, 161 
9-slice scaling, using, 161 
Windows, setting in, 68 
working with, 119

Scene button, 46 
Scene panel, 44 
scenes

adding scenes, 44 
deleting, 45 
edit, selecting scene to, 47 
named anchor on scene, setting, 61 
naming/renaming, 44-45 
playback, 45 
reordering, 45 
selecting, 44-45 
testing, 45

Schema tab, Component Inspector, 429, 
430, 462, 431. See also schemas

schemas 
description of, 462 
modifying, 462

schematic flowcharts, 8 
script, developing, 8 
Script Assist, 412, 448
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Script Navigator, 348, 413 
Script pane, 348 
scroll bars, 456-457 
scrolling

DataGrid component with, 448 
text, creating, 187

ScrollPanel component, adding, 456-457 
scrubbing, 230 
search engines, 17 
searching

with Find and Replace, 190 
for help information, 25 
with spell-checking, 188

security for local/network playback, 481 
Selection tool, 81

connected stroke segments, selecting, 83 
fills, selecting, 84 
line segments, converting, 115 
multiple stroke segments, selecting, 83 
rectangles, selecting, 84 
shapes, modifying, 114 
strokes, selecting, 82-83

selecting 
with Selection tool, 82-83 
contact-sensitive selection, setting, 61 
frames, 42, 223 
with Lasso tool, 85 
layers, 34-35 
scenes, 44-45 
span based selection, 61 
text, 172

Send to Back/Send Backward, 133 
sending a document, e-mail, 521 
serial number for installation, 3 
serif fonts, built-in Flash device fonts for,

185 
shape hints, 286-287 
shape tweening, 273

alpha, changing, 285
ball animation

combining tweening and movement 
in, 282-283 

creating, 280-281 
blending properties, setting, 284 
colors, changing, 285 
combining tweening and movement in

ball animation, 282-283
creating shape tween form, 276-277

deleting keyframes, 278-279 
hints, setting, 286-287 
keyframes

adding, 278 
deleting, 278-279

properties, setting, 284 
working with, 274-275

shapes. See also masks; shape tweening 
Selection tool, modifying with, 114 
breaking text fields into, 180-181 
distorting shapes, 120 
envelope of shape, changing, 120 
optimizing, 77 
recognize shapes option, 130 
with Rectangle tool, 78-79 
rough shapes, converting, 76 
Stage, creating shapes on, 448 
Subselection tool, modifying with,

116-117 
shared audio libraries, working with, 312-

313 
Sharing My Screen, 523 
shortcuts. See also keyboard shortcuts

Macintosh, shortcut to Flash on, 5 
Show Precise Cursors, 112 
showing/hiding

Edit bar, 46 
grids and guides, 90 
layers, 36, 40 
Main toolbar, 48 
rulers, 89 
Tools panel, 50 
Welcome screen, 4

Single Frame for graphic symbols, 148 
site maps, 8 
size reports, generating, 480 
skewing with Free Transform tool, 119 
Skinning component, 326 
skins, 326 
smooth curves. See curves 
Smooth mode, Pencil tool in, 76-77 
Snap Align, 94-95 
snap to grid, locking/unlocking, 91 
Snap to Object command, 95 
Sorensen codec, 346 
sound card requirements, 9 
Soundbooth, 307, 323
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sounds, 307 
with ActionScript 3.0, 314-315 
with ActionScript behaviors, 314-315 
with behaviors, 314-315 
bit rate for, 321 
editing, 322, 323 
effects, 319 
embedded audio files, 309 
external library, adding audio with, 

310-311 
Find and Replace for, 190 
importing, 308-309 
Library

external library, adding audio with, 
310-311

importing sounds to, 308-309 
shared audio libraries, working with,

312-313 
Timeline, adding sounds to, 310-311

looping sounds, 319 
MIDI device sounds, mapping, 514-515 
MP3 file, loading, 316-317 
publishing sound documents, 320-321 
quality, changing, 321 
shared audio libraries, working with,

312-313 
Soundbooth, 323 
stopping sounds

all sounds, 317 
streaming MP3 file, loading, 316-317 
sync sounds

animation, adding to, 309 
Timeline, adding to, 318

Timeline 
animation, adding sounds to, 309 
Library, transferring file from, 310-311 
sync sounds, adding, 318

timing of, 322 
types, 307 
zooming on, 322

span-based selection, 61, 223 
Spanish text, displaying, 187 
Spray Brush tool, 108 
speech files, 321 
spell-checking, 188-189 
Spelling Setup dialog box, 188-189 
squares, creating, 79 
stacking order, changing, 133

Stage, 7, 29, 30-31. See also frames; import-
ing/exporting; layers; sounds; Work 
Area

bitmap to Stage, importing, 202 
components, adding, 429 
dimensions, setting, 17 
Hand tool, moving with, 47, 88 
shapes directly on stage, creating, 448 
Snap Align, 94-95 
video files on, 330 
view size, changing, 47 
zooming specific area on, 86-87

Start menu, 15 
Start/Stop Dragging Movie clip Behaviors,

362 
startup preferences, customizing, 4 
static media, 10 
static text. See text, Classic text, and 

TLF text 
stepping through code, 425 
steps. See History panel 
stopping sounds. See sounds 
Straighten mode, Pencil tool in, 76 
streaming MP3 file, loading, 316-317 
streaming video. See video 
string data, 353 
Stroke hinting, 75 
strokes. See also lines

colors, changing, 98 
Eyedropper tool, editing with, 104 
Ink Bottle tool, editing with, 102

Subselection tool, 81 
anchor points and vectors, editing, 110 
corner points to curve points, 

converting, 116-117 
curve points to corner points, 

converting, 116-117 
shapes, modifying, 116-117

supplies for Macintosh printing, 71 
Swap dialog box, 146-147 
Swap Symbol feature, 146-147 
swapping bitmaps, 203 
Swatches panel

fill colors, changing, 97 
for shape tween, 285 
stroke color, changing, 98 
text colors, changing, 169

SWC files. See components
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SWF files. See Flash movies 
SWF History

warning, 64-65 
SWF Size History, 65, 500 
switching between documents, 18 
Symbol button, 46 
symbols. See also buttons; instances;

motion tweening; movie clips 
animations to symbol, converting, 139 
attributes, 463 
behavior, changing, 144 
duplicating during swap, 147 
editing

entering/exiting editing mode, 
140-141

master symbols, editing, 142-143 
existing artwork to symbol, converting,

138 
exiting editing mode, 141 
Find and Replace for, 190 
font symbols, creating, 136-137 
graphic symbols, 148-149 
IK animations, 289-293 
master symbols

breaking instances from, 155 
editing, 142-143

new symbols creating, 138 
registration point, creating, 139 
warning preferences, setting, 65

syntax. See also dot syntax 
ActionScript 3.0, 377 
checking, 348 
indentation, 349

syntax-coloring 
in debugging, 413 
schemes, 349

system requirements, 2

T
tab size, setting, 349 
telephones. See also cell phones

activation requirement, 3 
templates. See also documents

for mobile device content, 512 
saving documents as, 23

10-second rule, 504

Test Movie, 217, 500. See also masks; 
motion tweening; shape tweening

debugging with, 416-420 
general preferences, setting, 60

testing. See also debugging 
in AIR, 500 
debugging and, 411 
in Device Central, 500 
in Flash, 500 
frame-by-frame animation, 231 
preview, 499 
projects, 520

text, 153. See also characters; fonts; kerning 
aligning paragraph text, 172 
anti-aliasing, 182 
bitmap text, 182 
breaking text fields, 180-181 
columns, 174 
colors, changing, 169 
ComboBox component, adding, 434-435 
CSS (Cascading Style Sheets), working

with, 191 
direction, 175 
dynamic text

character options for, 182 
creating, 186

Illustrator, importing from, 196 
input text, 163

character options for, 182 
component, adding, 432-433 
creating, 186-187 
parameters, editing, 430-431

line spacing, setting, 173 
margins, setting, 173 
orientation, 176-177 
Photoshop import preferences, 198-199 
preferences, setting, 62 
rotation of, 176-177 
scrolling text, creating, 187 
selecting, 172 
shapes, breaking text fields into, 180-181 
single column of vertical text, creating,

175-176 
spell-checking, 188-189 
static text, 163

creating, 164 
TextArea component, adding, 440-441
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tracking, adjusting, 170 
transforming, 181 
vertical text, 175-177

block, creating, 177 
direction, 175 
options, setting, 62 
orientation, 176-177

text boxes, creating, 164 
text files, loading, 164 
Text tool, 164-165 
TextArea component, adding, 440-441 
TextInput component, adding, 432-433 
3D Space

Global Transform, 122-123 
perspective angle, 124 
Rotation, tool, 122-123 
vanishing point, 125 
Translation, tool, 122

thread and unthread text, TLF, 167 
TIFF file support, 195 
Timeline, 7, 30-31. See also effects; frames;

sounds; video 
changing display, 32 
elements, adding motion to, 11 
frames display, changing, 32-33 
movie clips, referencing, 335 
resizing display, 32 
sync sounds to animation, adding, 309

timing rule, 504 
tint color

instance tint color, modifying, 158 
motion tween, adding to, 246

TLF text 
advanced options, 178-179 
columns, creating, 174 
creating, 165 
direction, 175 
linking text, 166-167 
orientation, 176

toggle buttons, adding, 442-443 
Toolbar, 6, 29, 30-31. See also Main toolbar

customizing, Tools panel, 50-51 
expanding/collapsing, 49, 50 
moving, 50 
showing/hiding, 48-50, 52-53 

Toolbox, 348 
Tools, creating, 51

Tools panel. See Toolbar 
tooltip preferences, 61 
trace actions, protecting from, 480 
Trace Bitmap dialog box, 216 
tracing bitmaps, 216 
tracking, adjusting, 170 
Transformation panel, 156-157 
transformation point, working with, 118 
transition settings, 490 
Translation tool, 3D, 122-123 
transparency

instance transparency, modifying, 159, 
160

publishing movies, setting on, 489 
turning on/off

grids and guides, 91 
Work Area visibility, 88

tweening. See motion tweening; shape 
tweening 

typewriter fonts, 185

U
UI components, connecting, 458 
uncompressed XFL file format, 20-21 
Undo command, 470

saving documents after using, 471 
undoing/redoing

general preferences, setting, 60 
History panel for, 466, 470-471 
number of levels, changing, 48 
object level undo, working with, 468-469 
scene deletions, 45 
text transformations, 181 
Transform effects, 158

unlocking. See locking/unlocking 
Up state for buttons, 150 
updates

online updates/support, 26-27 
previous Flash versions, 3 
registering to receive, 26

URLs changes warning, 64 
user interface components, 429

V
variable names 

for dynamic text, 186 
for input text, 187

 From the Library of Wow! eBook



ptg

556

vanishing point, 3D, 125 
variables, 364. See also ActionScripts

viewing, 421 
Watch list, adding to, 422

vector graphics, 73, 194 
tracing bitmaps to creating, 216

vectors, 73 
Version Detection, 487 
vertical lines, creating, 111 
vertical text. See text 
video, 299. See also Media Display; movie

clips; QuickTime/QuickTime Pro 
with behaviors, 334-335 
components, 429 
controlling from Timeline, 334-335 
cue points (ActionScript), adding, 332-

333 
file formats for, 327 
Find and Replace for, 190 
FLV format, exporting clips into, 346 
parameters, 328-329 
Stage, moving file on, 328-330 
Video Import wizard, using, 326-327

video card requirements, 9 
Video Encoder, 340-341 
Video Import wizard, using, 326-327 
views and viewing

document properties, 16 
History panel, changing view in, 473 
Stage, changing view size of, 46

Virtual Machine, 365

W
warning preferences, setting, 64-65 
Watch list variables, adding, 422 
WAV files, exporting movies to, 502-503 
Web 216 color palette, 489

Welcome screen, 4, 6 
While loops, 360

working with, 360 
width of gradient fills, changing, 121 
Windows Metafile (WMF)

support for, 195 
Windows PCs

keyboard commands on, 1 
launching Flash, 4 
printing documents, 72 
projector, creating, 493 
system requirements for, 2

word wrapping, 412 
Work Area, 88

storing graphics in, 126 
Workspaces. See Panel Set.

X
XFL

Opening, 14 
Saving, 20-21 
uncompressed file format, 20-21

XML (Extensible Markup Language), 187 
CSS (Cascading Style Sheets), 191 
ECMAScript, 348 
projects as, 518 
saving, 20-21

XMP file information, 484-485

Z
Zoom button, 19 
zooming

on bitmap images, 202 
changing magnification area, 87 
with Magnifying Glass, 86-87 
on sounds, 322
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