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Read Me First 
Welcome to Take Control of PDFpen 7, version 1.0, published in 
February 2015 by TidBITS Publishing Inc. This book was written 
by Michael E. Cohen and edited by Kelly Turner. 

This book tells you how create, edit, and enhance PDF documents on 
the Mac with Smile’s PDFpen 7 and PDFpenPro 7, and on the go with 
PDFpen for iPad & iPhone. 

If you want to share this ebook with a friend, we ask that you do so 
as you would with a physical book: “lend” it for a quick look, but ask 
your friend to buy a copy for careful reading or reference. Discounted 
classroom and Mac user group copies are also available. 

Copyright © 2015, Michael E. Cohen. All rights reserved. 

Sponsored by Smile 

This book was sponsored by Smile. Special thanks for an enjoyable 
project to Philip Goward, Greg Scown, Éric Trépanier, and Maia Olson. 

Updates and More
 

You can access extras related to this ebook on the Web (use the link in 
Ebook Extras, near the end; it’s available only to purchasers). On the 
ebook’s Take Control Extras page, you can: 

•	 Download any available new version of the ebook for free, or buy 
any subsequent edition at a discount. 

•	 Download various formats, including PDF, EPUB, and Mobipocket. 
(Learn about reading on mobile devices on our Device Advice page.) 
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•	 Read the ebook’s blog. You may find new tips or information, links 
to author interviews, and update plans for the ebook. 

If you bought this ebook from the Take Control Web site, it has been 
added to your account, where you can download it in other formats 
and access any future updates. However, if you bought this ebook 
elsewhere, you can add it to your account manually; see Ebook Extras. 

Note: To review background information that might help you under-
stand this book better, such as finding System Preferences, handling 
contextual menus, and working with files in the Finder, read Tonya 
Engst’s free ebook Read Me First: A Take Control Crash Course. 

What’s New in This Edition
 

There are two kinds of newness involved in this new edition: what is 
new in the software itself, and what is new in the environment in which 
PDFpen runs. 

New and changed features: 
•	 PDFpen provides an OCR layer that you can view; what’s more, you 

can Edit the OCR Layer in PDFpenPro. 

•	 The app has changed how you Navigate with Search Results. 

•	 A Control-click provides a contextual menu with editing and 
navigation commands applicable to whatever you’ve clicked; see 
Understand the Tools. 

•	 You can now Draw Attention with free-form highlighting. 

•	 PDFpenPro offers Excel and PowerPoint options when you Export 
to Microsoft Formats. 

•	 PDFpenPro gives you the ability to Make an Interactive Signature 
field in forms, and you can sign such fields with PDFpen (including 
PDFpen for iPad & iPhone). 
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Changes in the Apple environment: 
•	 PDFpen requires OS X 10.10 Yosemite, and its user interface has

been redesigned to match Yosemite’s style.

•	 When you Get Your Hands on PDFpen directly from Smile, you can
access documents stored in iCloud Drive; I provide more details in
Head in the iCloud.

•	 PDFpen for iPad & iPhone has been completely revised, and it is
now a single app that runs on the iPhone, iPod touch, and iPad. See
Use PDFpen in iOS to learn mobile editing techniques and find the
tools you need, and for advice on how to Get PDFs in and out of
PDFpen in iOS.

Note: My descriptions of the various Mac versions of PDFpen are 
based upon version 7.0.1. I suggest you update to that version or a 
later one if you haven’t already done so. This book should work with 
any subsequent updates to PDFpen, but I suggest that you check the 
blog for this book occasionally (a link can be found in Ebook Extras); 
we often provide information about updates there. 
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Introduction 
My office is something of a Vault of Antiquity. To the left of my desk is 
an old three-drawer metal file cabinet bursting with paper documents, 
many of them typed long before the advent of word processing technol-
ogy. Another desk has drawers full of floppy disks and data cartridges 
dating back to the dawn of personal computing. (I even have a box of 
punch cards in the closet.) 

As far as the paper files are concerned, they remain as easy to read as 
the day they were typed; their major drawback is they take up so much 
storage space for so little data. And if I did want them in digital form, 
I could easily scan and OCR them with PDFpen (in this book I explain 
how—in fact, one of those typed relics makes a guest appearance). 

The documents stored on my floppy disks and data cartridges are 
another matter. Even if I could MacGyver together some hardware 
combination to access their contents on my Mac, most of the docu-
ments stored on these artifacts of another age are in obsolete formats 
that render them almost completely indecipherable. 

There is one exception: the PDF documents on my antique storage 
media. If I could get those on my Mac, they likely would be as readable 
as the day they were created. After all, one of the main selling points 
of PDF is that the format was designed to be readable across platforms 
and almost impervious to the ravages of time. And that’s great. 

Unless, that is, you want to edit your PDFs or reuse their contents. 
PDF was not designed for that. 

And that’s where PDFpen comes in. The PDFpen family of apps can 
open and edit nearly any PDF you throw at it with ease, and can even 
export its contents into modern word processing formats. If a PDF is 
like a locked museum display case of content labeled “Look but don’t 
touch,” PDFpen is your set of picklocks. 

The following pages explain how to use them. 
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PDFpen Quick Start 
Use this Quick Start to get to the information you need about how to 
edit PDF documents with PDFpen and PDFpenPro. 

Get familiar with PDFs and PDFpen: 
•	 Read Get Your Hands on PDFpen to understand the differences 

between PDFpen and PDFpenPro, and why where you obtain it 
matters. 

•	 Next, acquire some essential background in Learn about PDF Files, 
where you’ll learn about the objects that PDF files can contain and 
the all-important concept of imprints. 

•	 Become familiar with the tools you have and when to use them in 
Understand the Tools, and then learn the different ways you can 
move around in a PDF document in Navigate a PDF Document. 

Make and modify PDFs: 
•	 To use PDFpen, you need to have a PDF to work on; see how to 

Make PDFs from Scratch, to Print to PDF, to Import from Scans 
and Graphic Files, to Make PDFs from HTML (Pro Feature), and 
to Combine Existing PDFs. 

•	 Many changes you make to a PDF take place within the confines 
of a single page: learn how to Add, Edit, and Remove Text and Add 
and Alter Pictures. 

•	 If you need to reuse the contents of a PDF in other documents, you 
can Export to Microsoft Formats to create a word processing docu-
ment, spreadsheets or presentation. 

•	 Make large-scale changes when you Search and Replace or Redact 
Text, or when you Rearrange, Rotate, and Crop Pages. 

•	 Wrangle your PDFs on the go when you Use PDFpen in iOS: learn 
how to Find Tools and Commands when you need them, and how 
you Get PDFs in and out of PDFpen in iOS. 

7
 

www.allitebooks.com

http://www.allitebooks.org


          
    

    

   
       

      

        
         
          

        
    

         
            

     

          
        

           
           

         
   

      

            

             
  

•	 A PDF is not necessarily a read-only document when you Make an 
Interactive PDF Form (Pro Feature). 

•	 Use The Scripts for batch processing power. 

Review and distribute PDFs: 
•	 Communicate with co-authors and colleagues when you Take Notes 

on a PDF and Copyedit and Review a PDF. 

•	 Finally, understand your saving and printing options in Publish 
Your PDFs. This chapter describes several important points about 
using PDFpen that you may not already be aware of, including: 

‣	 An explanation of why the Export to Microsoft Formats features 
work only with an Internet connection 

‣	 Details on not only password-protecting a PDF entirely (Save 
Securely), but also on restricting who can print or edit a PDF, 
in Protect Your PDFs (Pro Feature) 

‣	 Converting a PDF to black-and-white, reducing its file size, or 
saving it in other special formats with Save with Quartz Filters 

‣	 Using preset (or your own) workflows to open a PDF from other 
software directly in PDFpen or to open a PDF from PDFpen 
directly in other software (such as iTunes or Scrivener) when you 
Save with the Print Dialog 

‣	 Why PDFpen provides a Save to Evernote command 

‣	 Printing a PDF form with only the text you filled in (Print Your 
PDFs) 

‣	 Printing a summary of all your annotations at the end of a PDF 
(Print Your PDFs) 
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Get Your Hands on PDFpen 
PDFpen 7 comes in two varieties for the Mac—a standard version and 
a pro version—and is available from two different sources: the Mac 
App Store and Smile’s Web site. What’s more, there is also a version of 
PDFpen for iOS. 

If you haven’t yet purchased PDFpen, use this short chapter to learn 
the differences between each version so you can choose the right one 
for your needs. And even if you’ve already bought PDFpen, you can use 
this chapter to learn more about the flavor you chose. 

Standard or Pro
 

Both the standard and pro versions of PDFpen for the Mac are great 
for a vast number of tasks. You can use either to create PDFs, edit 
PDFs, combine PDFs, split PDFs, perform OCR on PDFs, manipulate 
images in PDFs, export PDFs, mark them up many ways, and more. 

What sets PDFpenPro apart are the following additional features: 

•	 Import Web pages: You can make a PDF from a single Web page 
or an entire site, complete with clickable links. See Make PDFs from 
HTML (Pro Feature). 

•	 Export to Excel, PowerPoint, and PDF/A archive formats: 
See Save or Export Your PDFs. 

•	 Correct OCRed text: After you OCR a document, you can correct 
any recognition errors; see Edit the OCR Layer in PDFpenPro. 

•	 Make forms: PDFpenPro provides tools to construct and edit 
interactive forms in a PDF, including interactive signature fields 
that users can sign using a trackpad; it also can automatically create 
interactive form fields from a non-interactive PDF form. Make an 
Interactive PDF Form (Pro Feature) describes what you can do with 
forms in PDFpenPro. 
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•	 Build a table of contents: You can construct a clickable table 
of contents that automatically includes page numbers and organize 
it as you like; see Make a PDF Table of Contents (Pro Feature). 

•	 Apply security provisions: With PDFpenPro you can enable or 
disable the standard security features that PDFs provide, such as 
restricting printing and preventing marking up or copying content. 
Protect Your PDFs (Pro Feature) tells you what you can lock down 
in your PDFs and how to do it. 

If you need any of the above features, you should buy PDFpenPro. 

Note: In this book, everything I say about PDFpen also applies to
 

PDFpenPro; when I do describe features that are exclusive to PDF-
penPro, however, I make that clear.
 

Smile or Mac App Store
 

You can purchase PDFpen or PDFpenPro either directly from Smile 
or from Apple’s Mac App Store. 

There are slight differences between versions of PDFpen and 
PDFpenPro purchased from Smile and those purchased from the 
App Store. Those differences fall into three categories: 

•	 Updates: When Smile fixes bugs and makes improvements to 
PDFpen, you can download those updates immediately in copies 
purchased directly from Smile—choose PDFpen (or PDFpenPro) > 
Check for Update. 

This menu choice is not available in copies from the App Store. 
Instead, the update must first be approved by Apple (a process 
that can take days or even weeks), after which it appears in the 
App Store app on your Mac: choose  > App Store and then click 
Updates to check if the approved update is ready to be installed. 

•	 Upgrades: Apple policy doesn’t allow Smile to offer upgrade 
pricing through the Mac App Store. If, for example, you previously 
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purchased PDFpen 6 from the App Store, you can’t pay a reduced 
upgrade price in the App Store to upgrade to PDFpen 7: you have 
to pay full price in the App Store for PDFpen 7, whether you have 
a previous version or not. 

Fortunately, the Smile Store recognizes PDFpen 6 and PDFpenPro 6 
licenses from versions that have been obtained via the App Store, so 
you can upgrade at a reduced price directly from Smile. 

•	 Full iCloud access: Although any copy of PDFpen can open PDFs 
stored in iCloud Drive (see Head in the iCloud), full access to iCloud 
is available to PDFpen only when you buy it through the App Store. 
For example, the Favorites sidebar in PDFpen’s file dialog provides 
a direct link to the PDFpen app library in iCloud Drive making it 
easier to get to your iCloud files. More importantly though, with 
iCloud access, PDFpen’s Library can share and sync custom objects 
via iCloud with the Library in PDFpen for iPad & iPhone (see The 
Library) and with copies of PDFpen on any other Macs you own. 

As far as files are concerned, iCloud isn’t the only cloud sharing 
option available to PDFpen on the Mac: for example, because both 
the Mac and iOS versions of PDFpen can open and save files on 
Dropbox, you can store PDFs on that service and access them with 
PDFpen from any of your devices. However, to share your Library 
with PDFpen on your other devices, you need iCloud access. 

If you need full iCloud access, and can live with the upgrade and 
update limitations that Apple imposes, the App Store is where you 
want to go. Otherwise, buy your copy from Smile. 

To purchase from Smile: 
1. Go to the appropriate page on Smile’s Web site to purchase either 

PDFpen or PDFpenPro. 

2. On the page that appears, do one of the following: 

‣	 Click Download Free Trial to get a version of PDFpen you can try 
out. You can purchase the non-trial version from within the trial 
version. 
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‣	 Hover over the Buy Now button and then, in the menu that 
appears, click Smile Store. Follow the instructions that appear. 

Tip: If you’ve purchased PDFpen directly from Smile and discover 
that you need PDFpenPro features, you can choose PDFpen > 
Upgrade to PDFpenPro and you’ll have the upgraded software in a 
matter of moments. (Sadly, Apple policy prohibits Smile from offering 
this feature in copies of PDFpen from the Mac App Store; you can, 
however, upgrade to PDFpenPro directly from Smile if you have an 
App Store version of PDFpen.) 

To purchase from the Mac App Store: 
You can purchase from the Mac App Store by choosing  > App Store 
and then navigating in the App Store to PDFpen or PDFpenPro. 
However, you can go directly to the right place in the App Store from 
a link on Smile’s site: 

1. Go to the appropriate page on Smile’s site for PDFpen or 
PDFpenPro. 

2. On the page that appears in your browser, hover over the Buy Now 
button and then, in the menu that appears, click App Store. 

The product page from the App Store appears first in your browser, 
and then automatically opens the App Store itself directly on the 
product’s page. 

Note: You need an Apple ID to make purchases from the App Store. 
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Head in the iCloud 
As mentioned just above, only versions of PDFpen and PDFpenPro 
purchased from the Mac App Store provide full access to Apple’s 
iCloud service. However, as Smile’s blog post Sync PDF Documents 
with PDFpen 7 and iCloud Drive points out, PDFpen 7 or PDFpenPro 7 
purchased directly from Smile can access documents stored in iCloud 
Drive by PDFpen for iPad & iPhone (see Use PDFpen in iOS). 

If you have upgraded from a Mac App Store version of PDFpen 6 to 
a version of PDFpen 7 sold by Smile, however, you no longer have 
access to your iCloud-stored Library (see The Library). Once again, 
though, Smile has your back: choose PDFpen (or PDFpenPro) > Copy 
Library from iCloud. This takes you to the Copy Library from iCloud 
page on Smile’s site, where you can download an AppleScript from 
Smile that will copy your Library from iCloud and install it in your 
app. 

PDFpen for iPad & iPhone
 

In addition to PDFpen and PDFpenPro for the Mac, Smile also pro-
duces a version of PDFpen for iOS devices. This app, which runs on 
the iPhone, iPad, and iPod touch, is compatible with the Mac versions 
and features the bulk of the powerful PDF editing capabilities provided 
by its Mac siblings. Although this book is primarily about the Mac 
versions of PDFpen, I do provide an overview of the iOS version in Use 
PDFpen in iOS. 

PDFpen for iPad & iPhone is available only from the iOS App Store. 
Upgrades from the previous versions of PDFpen for iPad and PDFpen 
for iPhone are available as described in this TidBITS article, PDFpen 2 
for iOS Offers New Features along Paid Upgrade Path. 
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Learn about PDF Files 
It seems like PDF files have been around for a long time—in fact, if 
you’re young enough, they may have been around for your entire life. 
Nonetheless, PDFs are younger than the Mac platform, and, in their 
short time on this planet, they have (just like you) gone through more 
than a few changes. 

You don’t need to know most of the information in this chapter to 
use PDFpen productively. If you are eager to get going, feel free to 
jump ahead to the next chapter, Understand the Tools. But if you like 
to understand why as well as how, this brief chapter gives you back-
ground on how the PDF file format evolved, what it can contain, and 
what you can reasonably expect to be able do with it. 

A Short History of the PDF Format
 

Interestingly, HTML and PDF both originated from similar dreams at 
roughly the same time: the late 1980s. In the case of HTML’s creator, 
Tim Berners-Lee, the dream was to make the scientific papers being 
developed at the CERN particle physics lab in Switzerland available 
to all the CERN scientists using the lab’s computer network, regardless 
of the type of computer attached to the network. In the case of John 
Warnock, PDF’s creator and one of the founders of Adobe Systems, it 
was the dream of “being able to send full text and graphics documents 
(newspapers, magazine articles, technical manuals, etc.) over electron-
ic mail distribution networks,” regardless of the type of computer 
receiving them. 

Adobe had already achieved major success with its invention of 
PostScript, a computer language designed to describe the contents and 
layout of document pages in such a way that a printer (most notably, 
the first Apple LaserWriter printer) could print those documents 
faithfully at any resolution. PostScript, a device-independent language, 
became one of the foundations of PDF. 
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What Does PDF Stand For? 
PDF stands for Portable Document Format. Therefore, saying “PDF 
format” is as redundant as saying “the La Brea Tar Pits” or the “NBC 
broadcasting company.” However, human nature being delightfully 
perverse, the description of the file format has become synonymous 
with files that use the format, so that now the terms “PDF,” “PDF 
document,” and “PDF file” all refer to the same thing. 

In 1991, the same year that HTML 1.0 was unleashed upon the world, 
Adobe introduced something at the Seybold conference that it called 
Interchange PostScript, or IPS—the first public mention of what would 
become PDF. IPS became known as PDF 1.0 at Comdex in late 1992. 
By the middle of the following year, Adobe released the first tool for 
editing and viewing PDF documents: Acrobat 1.0 (which Adobe origi-
nally called Carousel). 

Since that time, the nature and capabilities of PDF have been 
inextricably linked to the current version of Acrobat. Almost every 
major release of Acrobat has been tied to a major revision of the PDF 
specification. A Wikipedia article summarizes the high points. 

Note: PDF version 1.7 became an official ISO standard (ISO
 

32000-1:2008) in January 2008. Nonetheless, Adobe continues to
 

enhance both the PDF specification and Acrobat.
 

A Peek at What Is Inside
 

I said that PostScript became one of the foundations of the portable 
document format. That’s true, as far as it goes; however a PDF file 
doesn’t contain actual PostScript code. Instead, it contains page-
drawing instructions that are like PostScript instructions, but simpli-
fied and designed for efficient processing. PDF instructions manipulate 
the objects displayed on a page, which roughly fall into three types: 

•	 Graphic path objects: These objects contain information about 
the lines, rectangles, and curves on a page, and how they are to be 
placed, drawn, and filled. 
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•	 PDF image objects: You can also think of these objects as raster 
images—a stream of pixels, in specific colors, at a specific 
resolution, presented in a specific rectangular area (the display on 
your computer screen is a raster image, even if the items depicted 
there started out as something else). The PDF image object is 
unique unto the PDF specification. When you make a PDF file by, 
say, saving a Web page to PDF in Safari, the images on that Web 
page are converted into PDF image objects. 

•	 Text objects: These objects contain the text, font, and location 
information (and a number of other textual attributes) needed to 
represent text on a PDF page. The running text you see on a PDF 
page may consist of a lot of different text objects assembled together 
for viewing. These are just a stream of drawing instructions: Text 
objects don’t include the concept of words, paragraphs, and so on; 
they contain only information about how they are supposed to look, 
where they are to be placed, and the characters that are to be drawn. 

Objects and Imprints 
Text, image, and graphic objects modified by or added to a PDF with
 

PDFpen are called imprints, and they contain additional information
 

which PDFpen employs to facilitate editing and positioning. The PDF
 

specification allows PDFs to contain this program-specific extra
 

information, which is, by convention, ignored by other PDF viewing 

and printing programs.
 

Holding it all together is a great big tree structure from which hang the 
individual pages (each containing a bunch of objects) and all the other 
information that is necessary to print or display the PDF document. It 
is up to the PDF rendering program (such as Preview, Acrobat Reader, 
Safari, or PDFpen) to work its way down the tree, assemble the objects 
and related information that belong to each page, and draw those 
objects on some device, such as a screen or a printer. 

This is a simplified view, to be sure; there are all sorts of other objects, 
such as form elements and annotations, that a PDF can contain as well. 
Such objects can (and often do) contain one or more of the three basic 
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objects described here: a form object for a checkbox, for example, 
includes graphic path objects that describe its appearance. 

On Having Realistic Expectations
 

As a quick look at the history of PDF and its internal structure reveals, 
PDF is not an editing format. PDF was designed to be a delivery format 
intended, ultimately, for the eyes of human readers. 

Although the format has over time developed features that make 
machine parsing, analysis, and even editing more practical, PDF files 
are primarily intended to maintain their look across a wide range of 
devices: they are meant to be exact visual representations of printed 
pages, and almost everything about them is designed to make that 
representation more exact and efficient. Any information within the 
PDF specification that enhances editing was added as an afterthought 
and was not one of the original goals of the format’s developers. 

Here’s a quick guide to some of the edits you can make within the 
limits of the format: 

•	 Touch up text: You can make small text revisions, such as fixing 
typos. However, don’t expect to add whole paragraphs within an 
existing text block (other than in PDFpen-created text imprints), or 
to move paragraphs seamlessly from one text block to another: the 
PDF specification doesn’t include a definition for paragraphs. Also, 
keep in mind that a PDF may use fonts that you don’t have on your 
Mac; this may affect the appearance of edited text. See Add, Edit, 
and Remove Text for more details. 

•	 Adjust images: You can’t edit the details of an existing image 
(which is stored in a special PDF image format), but you can move 
it around, crop it, and delete it. You can also adjust its colors, make 
portions of it transparent (great for scans of signatures), and 
straighten it. See Add and Alter Pictures for more. 

17
 



   
    
         

      
     

      
    

        
             

             
           
  

         
            

       
       

          
           

     

           
             

               
           

        

Line Art Is Special 
PDFpen doesn’t support editing or repositioning of line art created 

outside of PDFpen. Such art is drawn on the page using the instruc-
tions within a graphic path object and does not lend itself to casual
 
modification. Drawing imprints created within PDFpen contain extra
 

information to support editing (similar to how PDFpen handles text 

imprints), so you can edit them.
 

•	 Add new text imprints and images: Although editing existing 
text within a PDF can be tricky, adding an entirely new, editable text 
imprint is far easier. Same goes for images: you can always plop a 
new one down on a page. See Add, Edit, and Remove Text and Add 
and Alter Pictures for more. 

•	 Annotate: You can add notes, comments, and various graphic 
objects to mark up a PDF document. You can also highlight text 
with colors, underscores, strikethroughs, and squiggles. See Take 
Notes on a PDF and Copyedit and Review a PDF. 

•	 Move pages around: You can modify the order in which pages 
appear, as well as add or remove them. See Create a PDF and 
Rearrange, Rotate, and Crop Pages for more details. 

From the foregoing you might think that PDF editing resembles Dr. 
Johnson’s description of a dog walking on two legs: “It is not done 
well; but you are surprised to find it done at all.” That’s not really true: 
with a tool like PDFpen the dog can walk much more gracefully than 
you might expect: it might even dance for you. 
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Understand the Tools 
PDFpen provides a rich assortment of tools for modifying PDF docu-
ments. Learning the tools you have at your command is one of the first 
steps of taking control of PDFpen. You can access many of these tools 
in a variety of ways: from a toolbar, from menus, and from the key-
board. Which method you use may depend on what is most convenient 
for you, or it may be a matter of personal preference. 

The tools at your beck and call fall into these general categories: 

• The Selection Tools 

• The Markup Tools 

• The Drawing Tools 

• The Form Creation Tools (Pro Feature) 

In addition to these tools, PDFpen provides an Inspector that you use 
to modify objects in a PDF, and a Library, where you can store graph-
ics and text for reuse. 

The following sections describe where you can find the tools, The 
Inspector, and The Library; they also briefly explain some of the 
circumstances in which you might want to find them. 

Tip: You can find a number of commands at your fingertips with a 
Control-click, which produces a contextual menu offering various 
navigation and editing commands applicable to whatever you clicked. 
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Where to Find Tools
 

PDFpen has an Editing Bar that appears at the top of each document 
window. All of the PDFpen tools—the selection, drawing, markup, and 
form tools—are available from the Editing Bar (Figure 1). At the far 
left of the Editing Bar are the selection and highlight tools, which are 
always present. To their right is a segmented button that controls 
which set of tools appears to its right. The active tool set is always 
highlighted in this tool-selection button. For example, in Figure 1 
the markup tools are currently selected. 

Figure 1: The Editing Bar at the top of a PDFpen document window 
provides selection and highlight tools at the far left, followed by a 
segmented button that controls which tools appear to its right. Here, 
the markup tools have been selected. The other choice in the seg-
mented button is the drawing tools. In PDFpenPro, the button in-
cludes a third segment for the interactive form creation tools (not 
shown here). At the far right are the object property tools. 

Tip: Hover your pointer over any tool in the Editing Bar to see a help 
tag appear that tells you what the tool is. 

The tools are also available from PDFpen’s Tools menu, grouped as 
they are on the Editing Bar. 

Notice the Keyboard Shortcuts 
Even if you prefer to use the Editing Bar, note the Command-key 
equivalents of some of the tools on the Tools menu; these can come 
in handy. 

For those tools that don’t have Command-key equivalents, you can 
create your own shortcuts in System Preferences: go to  > System 
Preferences > Keyboard > Shortcuts > App Shortcuts and click the 
plus sign. 
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The Selection Tools
 

For brevity’s sake, I’m calling the first group of tools in the Editing Bar 
“selection tools,” even though not all of them select objects within a 
PDF. Here’s what each selection tool does: 

• Select Text : Use this tool to select runs of text within existing 
text blocks for correction or copying (such text blocks are to be 
distinguished from text imprints created within PDFpen, as 
described in Objects and Imprints). In some cases—such as when 
you have the Edit tool selected—PDFpen switches to the Select Text 
tool automatically when you click text within a PDF. 

Note: The Select Text tool does not make the selected text editable
 

by itself; you must choose to correct the text once it is selected in
 

order to make changes (see Add, Edit, and Remove Text).
 

• Edit : Use this tool to select images, text imprints, or other 
objects you want to move, resize, or delete. Keep in mind that not 
all objects on a page can be selected. Generally, text objects and 
graphic path objects created by another program cannot be selected 
and moved within PDFpen: you can select only those text and 
graphic imprints that you have added with PDFpen. However, you 
can select, move, resize, and delete most PDF image objects within 
a PDF, whether or not you added them in PDFpen. 

• Highlight Text : With this tool you can select text and highlight 
it with the current highlight color, which is visible in the Highlight 
control on the window’s toolbar. Once the highlight is applied, the 
text remains selected, so you can copy and correct it as well (see 
Take Notes on a PDF). You can drag over non-text portions of a 
page with this tool to draw free-form highlight marks; your pointer 
becomes a highlight pointer when it isn’t over text. 

• Select Rectangle : Use this tool to select a rectangular area on 
the currently displayed page. You can then copy this area and paste 
it on a page (as a graphic object), or you can crop the current page 
to the selected area. 
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The Markup Tools
 

A common thing you can do with a PDF (other than read it or print 
it, of course) is mark it up with notes, comments, and additional text 
blocks. To that end, PDFpen provides a variety of tools in the Editing 
Bar. To reveal the markup tools in the Editing Bar, click the leftmost 
segment of the Editing Bar’s tool-selection button. 

Single-use Tools 
The markup tools, and, in fact, all the tools other than the selection 
tools, are multiple-use by default. That is, if you select one and use 
it, PDFpen keeps it selected. For example, if you choose the Text 
tool (see below) and click on a page, a new text box is created where 
you clicked and the Text tool remains selected in the Editing Bar so 
the next click on the page produces another text box. 

You can change this default behavior with PDFpen’s Editing prefer-
ences by unchecking Keep Tools Selected after Use. If you do so,
 
you can then lock a tool for repeated use by double-clicking it in the
 

Editing Bar.
 

We’ll take a look at how to mark up a PDF later, in Take Notes on a 
PDF and in Copyedit and Review a PDF, but, for now, here are the 
tools you use for marking up a PDF: 

• Text : This tool creates a text box wherever you click on the page. 
PDFpen refers to these boxes as imprints. You can resize the box, 
adjust the appearance of both the text in the box and the back-
ground color of the box, and move the box where you like. Text 
imprints are always visible in the PDF, no matter what program you 
view them in, and they are always editable in PDFpen. 

• Scribble : As you drag with this freehand drawing tool, it draws 
a line that follows the dragged path. You can select, resize, and 
move these scribbles with the Edit tool (see The Selection Tools). 

• Note : This tool adds a note icon to the page along with an 
associated note window to which you can add text. You can position 
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both the note icon and its window where you want. If you close the 
note window, you can click the note icon to re-open the window. 
Most PDF viewing programs, such as Preview, allow you to show or 
hide note icons and their windows, although they may look some-
what different than they do in PDFpen. 

• Comment : Use this tool to make a comment text box. Comment 
boxes are visually indistinguishable from text imprints. Unlike text 
imprints, however, comment boxes don’t contain rich text; they’re 
restricted to a single font, size, and style. Comment boxes, also 
unlike text imprints, can be given borders, and have borders by 
default (that’s why I call them comment boxes). Many PDF viewing 
programs allow you to hide or show comment boxes and move them 
around; text imprints, on the other hand, can’t be hidden. 

• URL Link and Page Link : You use these tools to create 
transparent rectangular link objects that, when clicked, go to a 
Web location or to another page within the PDF (see Create Links). 
You can position and resize these objects. By default, they have no 
borders, though you can add them—and choose their colors and 
thickness—with The Object Property Tools at the right end of the 
Editing Bar. 

Tip: It is a kindness to your PDF’s readers to provide some sort of
 
visual clue that a link is present, so consider providing your links 

with borders or some other indication that a link is present, such as 

colored text (like on Web pages) or a button-like icon.
 

The Drawing Tools
 

As I pointed out earlier in Line Art Is Special, modifying standard 
PDF graphic path objects is currently beyond PDFpen’s capabilities. 
However, you can use PDFpen’s drawing tools to add new graphic 
objects to a PDF. PDFpen’s graphic objects contain additional editing 
information so you can modify them in PDFpen, even though they 
appear and behave as regular graphic path objects in other PDF 
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viewers. You can use the Edit tool to select, move, and resize graphic 
objects created by the drawing tools (see The Selection Tools). 

PDFpen’s drawing tools are similar to those in many other programs, 
and probably look familiar to you. Click the right side of PDFpen’s 

button (in PDFpenPro, click the middle section 
button) to reveal them in the Editing Bar (Figure 2). 

You can also choose any drawing tool from the Tools menu. 

tool-selection 
of the 

Figure 2: The PDFpen Editing Bar with the drawing tools visible. 

Here are the kinds of graphic objects you can create in PDFpen: 

• Polygon : Use this to create simple or complex objects made 
of connected line segments. Each click adds a line segment to the 
polygon (Figure 3); click the endpoint of a line segment to close 
the polygon. 

Figure 3: A polygon being drawn, segment by segment. 

• Rectangle , Oval , and Round-Edged Rectangle : Click 
and drag with these tools to insert the respective shaped objects. 

• Line : Drag with this tool to draw a line object. 

Tip: You can adjust the line thickness, line color, line style, and fill
 
color of any object made with the drawing tools (see The Object 

Property Tools). You can also specify the endpoint style of line
 

objects; for example, you can place arrowheads at either end.
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The Form Creation Tools (Pro Feature) 

In PDFpenPro, click the right side of the Editing Bar’s tool-selection 
button to reveal the form creation tools (Figure 4). You 

use these tools to add interactive form elements to a PDF; see Make an 
Interactive PDF Form (Pro Feature), which describes how to set the 
elements’ names, values, behaviors, and other characteristics. (You 
might also want to check out Fill Out PDF Forms.) 

Figure 4: Use PDFpenPro’s form creation tools (shown in the Editing 
Bar at center) to make an interactive PDF form. 

Select a form creation tool and then click on the page to create a form 
element at its default size; drag to create an element of custom size. 
You can also resize elements after you create them. 

Form Elements and Compatibility 
When viewed in PDF apps other than PDFpen and PDFpenPro, the
 

appearance of the form elements will vary, and some PDF apps may
 

not support all of the form elements that PDFpenPro can add. The
 

PDF form specification leaves the appearance of form elements and 

support for them up to each PDF app’s developer.
 

Here are the form creation tools PDFpenPro provides: 

• Text Field : Use this to create a field into which the user can 
enter text. The default field includes a 1-point border, but you can 
set the border width, style, and stroke color with the object property 
tools (see The Object Property Tools). 

• Check Box : You can add a checkbox and an associated label 
text imprint with this tool. The size and placement of both the box 
and its label are separately adjustable. 

• Radio Button : Use this to make a radio button with an associ-
ated label text imprint. Radio buttons are never solitary, since they 
present a set of mutually exclusive choices, so if you add one, you 
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should add at least one more. All the buttons in a radio button 
group should share the same name but have different values, which 
you can set in the Form Element Properties tab of The Inspector. 

•	 Choice : Use this to create a drop-down menu element (on the 
Mac) with multiple menu choices. This element can look significant-
ly different in apps other than PDFpen and on other platforms. So 
it goes. 

•	 List : This tool inserts a list box, which contains a list of text 
items from which the user can choose. Depending on how you set 
the list’s properties, a user can be restricted to a single choice, or 
can choose multiple items. 

• Signature Field : Insert an interactive signature field with this 
tool. Users tap the field on a trackpad or touchscreen and then write 
their signatures by fingertip. The image of the signature is included 
with the form when it is submitted. 

•	 Submit Button : Use this to create a Submit button, which, 
when clicked, submits form data either via email or to a Web app. 

The Object Property Tools
 

The object property tools are the rightmost items in the Editing Bar 
(Figure 5). 

Figure 5: The object property tools are three pop-up menus from 
which you can control the visual appearance of objects in a PDF. 

From left to right, the object property tools control these properties: 

•	 Colors: This menu allows you to specify the stroke color of a 
selected object (that is, the color of the lines that make up or enclose 
an object), the color of selected text, the color that fills the interior 
region of a graphic object, and the opacity of the object’s stroke and 
fill (Figure 6). Click the selector at the top of the menu to choose 
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the color property you want to set; the available color properties 
depend on the type of object selected. 

Figure 6: Shown from left to right are the settings for the text color, 
stroke color, fill color, and opacity of the comment box at far left. 

•	 Line attributes: Use this tool to specify how the lines that make 
up or surround an object appear. For example, you can specify 
dotted or dashed lines for boxes and ellipses, or the kinds of end-
points that appear on lines, such as arrowheads. 

•	 Stroke width: Click this tool to choose the width of the lines that 
make up or surround a selected object. 

See Draw Attention for more about using the object property tools. 

PDFpenPro note: You can use the object property tools to control 
the appearance of form elements. However, different PDF viewing 
apps almost certainly will render your form elements differently than 
you specify, or completely ignore your customization choices. 

The Inspector
 

The Inspector’s name understates its power: with it, you can do more 
than merely inspect things in a document—you can also change things. 

To display the Inspector, choose Window > Inspector (Command-
Option-I) or click the Inspector icon in the document window’s 
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toolbar. You can also display any desired tab in the Inspector by 
choosing the tab’s name from the Window menu. 

The PDFpen Inspector contains the following tabs, from left to right: 

• Alignment (Command-Option-1): When two or more 
objects are selected, use this tab to align them horizontally or verti-
cally, by their edges or by their centers. When three or more objects 
are selected, you can also distribute the distance between them 
evenly, both horizontally and vertically. 

• Form Element Properties (PDFpenPro feature; 
Command-Option-2): You can set the name, value, appearance, 
and behavior of a selected form element here. The active controls 
that appear in the tab vary depending on the form elements chosen. 

• Document Information (Command-Option-3): Use this 
tab to apply metadata to the document and to view additional 
data. You can specify the document’s title (which is distinct from 
its filename), author, subject, and one or more keywords that apply 
to its content or purpose. You can see, but not change, the date and 
time the document was created, the date and time it was last modi-
fied, and the file and page size. You can also see both the name of 
the app and the producer of the PDF document (these are explained 
in the sidebar just ahead). 

• Document Permissions (PDFpenPro feature; Command-
Option-4): You can specify a document password and enable or 
disable various document permissions on this tab. See Protect Your 
PDFs (Pro Feature) for more about document permissions. 
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Application? Producer? What?! 
The distinction between Application and Producer in the Inspector’s 
Document Information tab can be confusing, so here’s an example. 

Suppose you export a Pages document to PDF. When you view the 
PDF in PDFpen, the Inspector’s Document Information tab shows 
the Application as “Pages” and the Producer as something like “Mac 
OS 10.10.1 Quartz PDFcontext” (this is the name of the underlying 
system software that generates PDFs from the Print dialog). 

You can use this information to figure out the source of a PDF, which 
might be useful especially if the PDF has problems or visual oddities 
(“Dan, I see that you created the PDF you sent me with Acrobat 6 in 
Windows—maybe you should upgrade!”). 

By the way: Apple’s Preview has an Inspector as well, and it uses the 
terms Content Creator and PDF Producer instead of Application and 
Producer. To-may-to, to-mah-to… 

The Library
 

PDFpen’s Library is like the junk drawer that all of us have somewhere 
in our homes. (What? You don’t? What kind of person are you, 
anyway?) Like a junk drawer, the Library contains useful items that 
you may need from time to time. 

To open the Library, choose Window > Library (Command-Y), or click 
Library in the toolbar at the top of the document window. 

The Library comes with some items already in it, but you can add 
your own, including graphic images, objects you draw with PDFpen’s 
drawing tools, and text imprints. Unlike the typically chaotic junk 
drawer, however, the Library has separate collections for each type of 
object it contains (Figure 7). 
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Figure 7: The Library window has separate collections for each kind 
of item: Built-ins, Custom, Proofreading Marks, and Stamps. 

You access each of the collections by clicking its tab at the top of the 
Library window. Here’s what each collection contains: 

•	 Built-ins : This collection has the four standard drawing shapes 
you can create with the drawing tools. You cannot add items to this 
collection (if you could, they wouldn’t be built-in, now would they?). 
Why use the built-ins? Sometimes, dragging an object from the 
Library to the PDF is faster than switching tools to draw it. 

•	 Custom : This collection is for objects that you might want to 
place on a page in the future: text imprints, graphic objects made 
with the drawing tools, comments, and images. Anything you add 
to the Library goes into this collection. 

• Proofreading Marks : This collection contains a large variety 
of proofreading marks. You cannot add items to this collection. 

• Stamps : This collection contains various types of stamps and 
stickers used for business purposes. You can choose from three sets 
of stamps with the pop-up menu that appears below the collection: 

‣	 Standard Business: These include stamps like “Confidential” 
and “Draft”. 
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‣ Sign Here: Use these to indicate where someone should sign or
 
initial the PDF. 

‣	 Dynamic: These are similar to the Standard Business stamps, 
but they include your name, date, and time. 

Note: You can set the name used in Dynamic stamps by editing the 
Name field in PDFpen’s Editing preferences. 

To use a Library item, drag it from the Library window to the page. 

To add items to the Custom collection, do the following: 

1. With the Edit tool, select an item on a page in the PDF. 

2. From the pop-up menu at the lower left of the Library window, 
choose Add Selected Imprint. 

PDFpen automatically puts the selected item in the Custom collection. 

Tip: The Library’s pop-up menu contains another item: Add File. 
You can use this to select any graphic file on your Mac to add it to the 
Custom collection. 

You can also remove any of the items you have added to the Custom 
collection: select it in the Library and click the minus button. You 
can’t remove any of the items in the other Library collections, but why 
would you want to? 
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Navigate a PDF Document 
Some PDFs you encounter consist of just one page, such as an 
advertising flyer. Navigating those kinds of PDFs is simple, because 
there’s really nowhere to navigate to. 

But a PDF of, say, a software manual or a yearly financial report is 
another matter. PDFpen provides several ways to navigate a large 
document. This brief chapter shows you how to get around quickly 
so you can get on with your work. 

Display Pages
 

Those of us who spend a lot of time on the Web have become comfort-
able with the idea of pages that contain endlessly flowing text. In the 
Web world, we expect everything to exist on a single page, and become 
annoyed when, for example, we read a news story that is “continued on 
page 2,” forcing us to click and wait for a page to load. How primitive! 
How 20th century! 

But, unlike HTML, PDF was designed to replicate the physical, pagi-
nated world of books, magazines, pamphlets, and reports. Fundamen-
tal to the PDF specification (see Learn about PDF Files) is the concept 
that PDFs are composed of pages: rectangular areas on which text, 
images, and graphic objects are placed. 

PDFpen provides several ways to arrange and view the pages in a PDF 
to suit your needs and personal proclivities. 

Facing Pages 
Although we tend to read one page at a time, it can be very helpful to 
see pages spread out, side by side (or “two-up”), the way they appear 
in books, such as in Figure 8. This is especially true with today’s wide-
screen, high-resolution monitors where there’s room to see two pages 
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at a time clearly. It’s also useful when you want to get a better idea of 
how a page design works in the context of other pages. 

Figure 8: A PDF is displayed in a facing pages view. 

There are two ways you can switch from single page view to facing 
pages view: 

• Choose View > Facing Pages. 

• In the toolbar, click Sidebar , and then choose Facing Pages. 

Facing Pages Preferences 
Two PDFpen General preferences are associated with facing pages: 

✦ You can set Default View to Single Page or to Facing Pages. 

✦ You can set Facing Pages to Start with Cover (which shows the 
PDF’s first page on its own as in a printed book) or to Start with 2-
Page Spread (which begins the display with a two-page spread, as 
in Figure 8, above). 
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Tip: If you have a PDF in a language that ordinarily presents pages 
in right-to-left order, such as Japanese or Arabic, you can choose 
View > Pages Right-to-Left. 

Magnifying Pages 
Sometimes, such as when you want to select text set in very small type, 
it’s useful to see a page in a magnified view. Other times, such as when 
you want a general overview of a page layout, you may want to zoom 
out so you can view an entire page, or even several pages, at once. 

You can use the following commands on the View menu to set the 
magnification of the page view: 

•	 Actual Size (Command-Zero): PDFpen obtains the pixel densi-
ty of the Mac’s display from OS X and uses that information to scale 
the document to its full size on screen. 

•	 Zoom In (Command-Plus): This magnifies the view of the 
page by a small percentage, which varies depending on the current 
magnification. For example, at 100% magnification (actual size), 
this command increases the magnification to 110%. At 110% magni-
fication, however, the same command increases it to 121%. In other 
words, the higher the current magnification, the larger the percent-
age of increased magnification the command delivers. 

•	 Zoom Out (Command-Hyphen): This reduces the magnifica-
tion by a percentage relative to the current magnification, much like 
the way that Zoom In works. 

•	 Zoom to Fit (Command-Option-Zero): This adjusts the 
magnification so an entire page fits within the viewing area of the 
window. If you have facing pages displayed, the command adjusts 
the magnification so two pages fit in the viewing area. 

Tip: If you have a trackpad, you can change the magnification using 
the pinch-in and pinch-out gestures. 
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A Matter of Scale 
In PDFpen’s General preferences you can choose what 100% scale 
(actual size) means (Figure 9). 

Figure 9: You can choose how PDFpen interprets “100% scale.” 

The first choice makes PDFpen pretend that the screen has a resolu-
tion of 72 DPI: on a high resolution screen, the PDF will look smaller 
at 100% scale than on a lower resolution screen. The second choice 
makes PDFpen take the screen resolution into account, so that 
something that is, say, one inch tall on the screen when magnified 
to 100% scale, will be one inch tall when printed. 

Continuous vs. Non-continuous Page Display 
PDFpen can display pages in a continuous stream, or restrict the 
viewing area to display just the current page (or set of facing pages) 
by itself. What’s the difference? Mostly a matter of personal choice 
and how you want to focus your attention. 

If you are reading a book in PDF form, you may not want to see a 
continuous page display so you can focus on just the current page. If 
you are browsing through the same book, though, the continuous view 
makes it easier to see where you are among the pages that make up 
the document. Figure 10 shows a continuous page display. 
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Figure 10: Continuous page display gives you an overview of where 
you are in the document. 

You can enable or disable continuous page display by choosing View > 
Continuous; you can also choose Continuous from the Sidebar 
pop-up menu at the left of the document window’s toolbar. 

Navigate Pages
 

PDFpen gives you several different ways to move through a PDF 
document. How they work sometimes depends on whether you have 
enabled continuous page display (see the previous section). 

Here are the ways to move from page to page: 

• Toolbar Up/Down controls : Click these to scroll up 
and down either by the height of the document display area or by 
a complete page, depending on whether you are viewing the docu-
ment with continuous page display enabled or not. 
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•	 Page box on the toolbar: To go to a specific page, select the page 
number displayed in the box and enter a new page number. PDFpen 
doesn’t let you enter page numbers that don’t exist in a document. 

• Go menu: You have a number of navigation commands here: 

‣	 Next Page and Previous Page: These work the same as the
 
toolbar Up/Down controls
 , described just above. 

‣	 Go to Page: Like the toolbar’s Page box, this presents a dialog 
where you enter the page number to which you want to go. 

‣	 First Page and Last Page: These go, respectively, to the first page 
and last page in the document. 

‣	 Back and Forward: You can choose Go > Back (Command-[) to 
retrace your most recent navigation moves, and Go > Forward 
(Command-]) to un-retrace them, much like the Back and For-
ward commands in a Web browser. (The keyboard shortcuts 
work exactly the same way in Apple’s Preview app.) This feature 
is especially handy when you navigate using page links within 
a document (page links are described in The Markup Tools). 

•	 Gestures or scrollbar: If continuous page display is enabled, 
you can use trackpad or mouse gestures to scroll quickly through 
a document; if you have scrollbars displayed on your Mac (set this 
in System Preferences > General), you can also use the scrollbar on 
the right to move through the document. 

If continuous page display is disabled and the page is too large to fit 
in the document viewing area, gestures or the scrollbar only adjust 
the position of the current page in the document viewing area. 

•	 Keyboard: Press the Page Up or Page Down key to move up or 
down by screen or page, depending on the continuous page display 
setting and whether the complete page fits within the document 
display area. On keyboards that lack these keys, such as laptop 
keyboards and the Apple wireless keyboard, Page Up is Fn-Up 
arrow and Page Down is Fn-Down arrow. Use the Home or End 
keys to go to the first or last page. 
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Tip: To help you find your place, choose View > Page Numbers to 
display a non-printing page number at the bottom right of each page 
(visible, for example, in Figure 10, a page or so back). 

Navigate with the Sidebar
 

One of PDFpen’s most valuable navigation tools is the sidebar, which 
you can display at the side of the document window, as shown in 
Figure 11. 

Figure 11: The sidebar, on the left of the window, can show page 
thumbnails, annotations, search results, or the table of contents. 
At the bottom of the Thumbnail sidebar shown here is the thumbnail 
magnification slider. 

You can make the sidebar visible by choosing View > Show Sidebar 
(Command-Shift-D), or you can use the Sidebar pop-up menu 
on the document window’s toolbar and choose a sidebar display 
option. The width of the sidebar is adjustable: position your pointer 
on the border between the sidebar and the document, and then, when 
the resize pointer icon appears, drag left or right. 
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The sidebar display options available from the toolbar’s Sidebar 
pop-up menu include hidden (no sidebar showing), page thumbnails, 
annotations, and the document’s table of contents (if it has one). Note 
that these commands also appear on the menu bar’s View menu. 

Navigate with Thumbnails 
Thumbnails provide miniature views of the pages in the PDF docu-
ment. You can control the size of thumbnails to see more detail in 
them with the thumbnail magnification slider at the bottom of the 
sidebar. PDFpen can display multiple thumbnails side by side if the 
sidebar is wide enough and the thumbnails are small enough. 

To use the thumbnails for navigation, click a thumbnail in the sidebar: 
the page that the thumbnail represents is displayed in the document 
viewing area of the window. 

Tip: When a thumbnail is selected in the sidebar, you can use the
 

keyboard’s arrow keys to move from page to page.
 

Navigate with Annotations 
You saw how to add notes, comments, and text imprints to a document 
in The Markup Tools. The sidebar’s Annotations display can list all of 
the notes, comments, text imprints, links, and highlights you’ve added 
to the document (Figure 12). 

Figure 12: The Annotations sidebar with a selected highlight 
displayed. 

You can click any entry in the Annotations sidebar to navigate to the 
page that contains the corresponding item. PDFpen also selects the 
item so you can immediately work on it. For example, if you click a 
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note entry, PDFpen displays the page that contains the note icon, and 
also opens the associated note window. 

You can limit the kinds of annotations displayed in the sidebar by 
clicking the Show pop-up at the bottom of the Annotations sidebar 
and choosing a type of annotation to show or hide. 

Navigate with a Table of Contents 
Not all PDF documents contain a table of contents, but, for those that 
do (like all Take Control ebooks!), PDFpen’s sidebar can display them. 

PDFpenPro Note: You can also use the sidebar to create and modify 
a document’s table of contents, as described later in Make a PDF 
Table of Contents (Pro Feature). 

You can see part of the Table of Contents sidebar in Figure 13. The 
table of contents shown in the figure has several main entries that 
contain sub-entries; these appear indented below their main entry. 

Figure 13: A table of contents in the sidebar can display sub-
entries. 

Click any entry or sub-entry to navigate to the associated page in the 
document. 

If, as in Figure 13, a table of contents entry has sub-entries, you can 
hide or reveal them in the list by clicking the triangle beside the 
main entry. 
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Navigate with Search Results
 

In PDFpen, you perform text searches with the Find window. Click 
the Find button in the toolbar, or choose Edit > Find > Find 
(Command-F) to display the Find window (Figure 14). 

Figure 14: PDFpen has a separate Find window. 

As soon as you begin typing in the window’s search field, PDFpen 
begins searching and displays the first match beyond your current 
position in the document. Click the Show Results button to list each 
match with some surrounding context, arranged by page. Click any 
line in the list of results to display the page that contains the search 
term with the term selected (Figure 15). 

Figure 15: Click a search result to see the search term selected 
on the document page. 

Once PDFpen has produced some search results (whether you choose 
to display them or not), you can navigate through the document using 
the next and previous buttons in the Find window. You can 
also use commands on the Edit > Find submenu as follows: 

•	 Find Next (Command-G): Choose this to jump forward to the 
next search result. 

•	 Find Previous (Command-Shift-G): Jump back to the preced-
ing search result. 
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•	 Jump to Selection (Command-J): This command displays the 
currently selected text within the PDF document, whether or not 
it is a search result, and it can be useful if you have been browsing 
through the document and want to get back to the page containing 
your most recent selection. 

Tip: You can use these commands whether or not the Find window is 
currently displayed. So, if you hide the Find window to give yourself 
more screen space in which to work, you don’t have to open it to 
navigate to other search results. 

Search Based on the Selection 
There is one more way to initiate a search: select some text in the 
PDF document, and then choose Edit > Find > Use Selection for Find 
(Command-E). This command also places the selected text in the 
Find window’s search field and lists the results when the Find window 
is open. 
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Create a PDF 
Chances are good that you have a bunch of PDFs scattered around 
your Mac’s hard drive right now—and you can use PDFpen with any 
of them. 

But real chefs cook up their own PDFs: 

•	 If you’re a complete do-it-yourselfer, you can make a PDF entirely 
from scratch (see below). 

•	 If you prefer to work with prepared ingredients, you can make a 
PDF from anything your Mac can print. See Print to PDF. 

•	 If you like imported delicacies, you can Import from Scans and 
Graphic Files to make a new PDF, and even perform optical charac-
ter recognition (OCR) on them. 

•	 If you like to work with leftovers, you can make a new PDF from 
the bits and pieces of other PDFs you have hanging around. Read 
Combine Existing PDFs. 

•	 Or, if you like to order take-out, you can go online and convert Web 
pages into PDFs. See Make PDFs from HTML (Pro Feature). 

And, when you’re done cooking, you can write up the menu…er… Make 
a PDF Table of Contents (Pro Feature). 

Make PDFs from Scratch
 

It’s easy enough to make a completely empty PDF with no pages. This 
isn’t as daft as it sounds. You want to do this when you need to specify 
the page dimensions and orientation of a new PDF. 

Here are the steps for making a pageless PDF: 

1. Choose File > New > Blank Document. 

PDFpen creates a completely empty PDF. 
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2. Choose File > Page Setup (Command-Shift-P) and then, in the Page 
Setup dialog, specify the page dimensions and orientation that you 
want your PDF to have. 

3. Choose Edit > Insert Blank Page (Command-Option-B). 

The new blank page matches the initial Page Setup settings. 

If the default page dimensions (set them in System Preferences > 
Printers & Scanners) are what you want, though, you can create a PDF 
that contains a single page with those dimensions in a single step: 
choose File > New > One Page Document (Command-N). 

With blank page in hand (virtually), you can now populate your PDF 
with text imprints, drawings, and images. The Markup Tools and The 
Drawing Tools explain how to add text imprints and drawings, but you 
can also drag text, drawings, and images from most other programs 
directly onto a PDFpen page. 

Note: PDFpen may convert text dragged from some programs, such 
as from older versions of Microsoft Word, into a graphic image when 
you drop it on a PDFpen page. 

By the way, there’s yet another way to create a PDF from scratch—well, 
almost from scratch: use a page from an existing PDF as your model: 

1. Open a PDF that has a page you want to use as the model for your 
new PDF. 

2. Select that page in the Thumbnail sidebar (if you need help, read 
Navigate with Thumbnails), and then choose File > New > From 
Selection (Command-Shift-N). 

PDFpen creates a new, untitled PDF with the selected page as its only 
page. Now customize it to your heart’s content. 

Tip: You can also drag one or more selected page thumbnails to the
 

Finder to create a new PDF containing those pages.
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One More Thing... 
There’s a variation on the last-mentioned method of creating a PDF 
from an existing page: you can make a PDF from part of a page: 

1. With the Select Rectangle tool, drag to create a rectangle 
around the area that you want to use as your model. 

2. Choose File > New > From Selection (Command-Shift-N). 

Voilà! A new PDF appears with a single appropriately sized page 
containing the contents of the rectangle you selected. 

Print to PDF
 

It’s no secret that you can save a document as a PDF in the standard 
Print dialog. It’s an easy way to create a PDF on which you can then 
work in PDFpen. Use this technique to turn a document created in 
another program, such as a report or manuscript, into a PDF. 

Here’s how to create a PDF from almost any application on your Mac: 

1. Choose File > Print. 

2. In the lower-left corner of the Print dialog, click PDF, and then 
choose Save as PDF from the pop-up menu (Figure 16). 

Figure 16: You can create a PDF document with the Print dialog’s 
PDF pop-up menu. 

3. In the Save dialog, give the document a name, choose where to save 
it, optionally specify PDF metadata and security options, and then 
click Save. 
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Note: The PDF metadata includes the document name, the author, 
the document’s subject, and keywords associated with the document 
(if you read about the Document Information tab in The Inspector, 
these metadata items should be familiar to you). 

Once you have the PDF, it’s easy enough to open it with PDFpen 
and make any changes and enhancements you require. But what if 
you want to save a document as a PDF and work on it immediately 
in PDFpen? Simple: Smile provides two PDF workflows—Open with 
PDFpen and Open with PDFpenPro—that you can download and 
install in the Print dialog’s PDF menu. Once that’s done, you can 
choose the appropriate workflow from the PDF menu to save the 
document as a PDF and open it in PDFpen or PDFpenPro. 

Import from Scans and Graphic Files 

PDFpen can scan documents and create PDFs from the scans. It can 
also create PDFs from graphic files. If you have printed copy or graphic 
files that you need to make into PDFs, use the techniques in this 
section. 

You don’t have to forgo PDFpen’s text editing capabilities just because 
the PDFs you make with these techniques start out as graphic images: 
PDFpen can recognize text in the images and perform optical character 
recognition (OCR) to make the text editable. 

Use a Scanner to Make a PDF 
PDFpen supports any scanner that the Mac’s Image Capture software 
recognizes. 

When you scan a document with PDFpen, the program creates a new 
PDF document. You can save the resulting document as a separate 
PDF, or add its pages to an existing PDF—or do both. 

You use PDFpen’s scanning capabilities as follows: 

1. Choose File > Import from Scanner. 
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A Scan window appears (Figure 17).
 

Figure 17: The Scan window has several scanner-specific options. 

2. Near the top-right of the Scan window, click the Kind pop-up menu 
and choose the kind of scan: 

‣	 Text: This choice scans the document in 1-bit black and white, 
which is suitable for text-only documents. 

‣	 Black & White: Sometimes known as grayscale, this choice, 
depending on the scanner, may offer several grayscale options 
with various levels of gray. This choice is suitable for documents 
that combine text with black-and-white photos or diagrams. 

‣	 Color: This is best for documents that contain color images. 
There can be several color choices available, depending on your 
scanner’s capabilities. 

3. Choose a resolution from the Resolution pop-up menu. 

The higher the resolution, the more detail the scan contains, but 
the larger the file is. The resolution you choose depends on how the 
PDF is to be used; for viewing online, 150 to 300 dpi is more than 
adequate, but if the PDF is to be printed the scan resolution should 
match the printer’s resolution. 
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4. Choose a scan format from the Format pop-up menu. 

The scan format determines the kind of image encoding in the PDF, 
and it affects the file size: for text-only documents, TIFF is a good 
choice; for photos, JPEG provides good results; otherwise, choose 
PDF. 

5. Set any other scan options you require, and then click Scan. 

A new PDFpen document opens containing the scanned page. The 
Scan window remains open so you can perform additional scans to 
add to the document. 

6. When you have finished scanning, close the Scan window. 

More Help with the Scan Options 
The PDFpen Help has an excellent summary of the scanning options 
and their uses in the “Scanning a Document” topic, and it’s well worth 
consulting. The same Help topic is also available on Smile’s site. 

Open Graphic Files as PDFs 
You can also create new PDFs directly from graphic files, such as 
JPEG, TIFF, or GIF files. Turning a graphic file into a PDF file is 
simple: 

1. Choose File > Open to display the Open dialog. 

2. Select a graphic file and click Open. 

PDFpen creates a new PDF document with a single page that contains 
the graphic. 

Use OCR on Scans and Graphic Files 
When PDFpen creates a scanned document, or when it opens a graphic 
file as a PDF, it can perform OCR on it to make the text editable. It’s 
useful to make text editable even if you don’t intend to edit it. Editable 
text can be searched (see Navigate with Search Results), and it can be 
highlighted (see Highlight Text). 
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To instruct PDFpen to perform OCR on a scanned document, choose 
Edit > OCR Page. 

If Your OCR Page Menu Item Is Disabled 
If PDFpen doesn’t detect a full-page graphic on the page, it disables 
the Edit > OCR Page menu item. That said, if a page has an image 
that contains text, you can hold down Command when you choose 
the Edit menu to enable the OCR Page menu item. 

Bonus tip: Hold down both Command and Option to display an OCR 
Document command on the Edit menu. 

You can set PDFpen to perform OCR automatically upon opening a 
scanned document, or when you make a selection on a scanned page 
that appears to contain text. You turn on these settings in the OCR 
pane of the PDFpen preferences (Figure 18). 

Figure 18: Set how and when PDFpen performs OCR with
 
PDFpen’s OCR preferences.
 

When you create a PDF from a graphic file and you’ve set PDFpen’s 
preferences to prompt for OCR when opening a scanned document, 
the program presents a dialog asking if you want OCR performed 
(Figure 19). 
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Figure 19: When PDFpen detects a full-page image, it may present 
this dialog, depending upon the OCR preference settings. 

About OCR Accuracy and the OCR Layer 
In my experience, PDFpen provides very good character recognition, 
even from documents that appear problematic. Nonetheless, you 
should check the results. Even 99.9% accuracy means there could 
be one mistake every 1,000 characters, which, if you think about it, 
means that mistakes are still likely. When OCR has been completed, 
the PDF’s appearance doesn’t change. You can view the OCR results 
by choosing View > OCR Layer (Command-Shift-O), as in Figure 20. 

Figure 20: The first image above shows the scanned text as 
it appears in the PDF; below it is the OCR layer. 

You can correct OCRed text with PDFpen’s Correct Text tool; such 
corrections modify the appearance of the scan by creating a text 
imprint (see Add, Edit, and Remove Text, later). PDFpenPro, 
however, provides the additional capability of making corrections 
directly in the OCR layer without creating a text imprint and changing 
the scan’s appearance (see Edit the OCR Layer in PDFpenPro). 
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Combine Existing PDFs
 

Combining pages from multiple PDFs is a matter of drag and drop 
between documents. If you have separate PDF files that contain pages 
you wish to use in another PDF, this technique is what you want. 

Here’s how to create a new PDF from one or more existing PDFs: 

1. Create a new, empty PDF document (see Make PDFs from Scratch). 

2. Choose File > Open or File > Open Recent to open one or more 
existing PDF documents. 

3. Show the Thumbnail sidebar in all open document windows (de-
scribed in Navigate with the Sidebar). 

4. Drag one or more thumbnails from the sidebar of an open docu-
ment to the empty document area of the blank document. 

You don’t have to start with a blank PDF file as shown in the steps 
above, of course: you can drag pages from any PDF into the Thumbnail 
sidebar of any other PDF with PDFpen (Figure 21). 

Figure 21: Add pages by dropping their thumbnails in a document’s 
Thumbnail sidebar. The dragged thumbnails have a red badge that 
indicates how many pages are being added; a black bar in the 
sidebar shows after which page the added pages will be inserted. 
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You needn’t drag pages one by one: you can Shift-click or Command-
click to select multiple page thumbnails from the sidebar and then 
drag them all at once. Or you can add a PDF’s entire contents to a 
document by dragging that PDF into the Thumbnail sidebar from the 
Finder. You can use of one or more of the supplied AppleScripts to 
combine PDFs (see Appendix A: The PDFpen AppleScripts). 

Make PDFs from HTML (Pro Feature) 

If there is a Web site that you want in PDF form, you can always use 
the Print to PDF technique described earlier. However, that requires 
that you print each page on the site separately, which will quickly 
become tedious. PDFpenPro, on the other hand, can follow the links 
on a Web page and add the linked pages to a PDF: 

1. Choose File > New > From HTML. 

The New From HTML dialog appears (Figure 22). 

Figure 22: You can create a PDF from one or more Web pages. 

2. Do one of the following, depending on whether the Web site is 
located on the Internet or stored locally: 

‣	 On the Internet: Enter the URL of the Web page that is the 
starting point for the PDF. 

‣	 Stored locally: Click Select Index File and then, from the 
standard file dialog that appears, navigate to the starting page. 
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3. In the Levels field, enter how many levels of links to include. 

A setting of 1 produces a PDF from the page that you’ve specified 
but doesn’t follow any links to produce more pages. A setting of 2 
follows each link on the first Web page and produces PDF pages 
from those linked Web pages. A setting of 3, as you might expect, 
follows links on the linked Web pages to produce more PDF pages, 
and so on. In theory, you could include almost every page linked 
on the Internet in a single PDF by choosing a high enough level 
number—if your Mac didn’t run out of memory or melt first. 

4. Choose an item from the Follow Links To pop-up menu: 

‣	 Subtree: This choice restricts the followed links to those 
that lead to pages within the same directory hierarchy as the 
Web page’s URL. For example, if the starting URL is http:// 
www.example.com/dir1/index.html, then the linked pages http:// 
www.example.com/dir1/somepage.html and http:// 
www.example.com/dir1/dir2/apage.html would be included in 
the PDF, but a linked page at http://www.example.com/dir3/ 
apage.html would not, because it’s not in the same directory 
as the starting URL. 

‣	 Server: This choice restricts the followed links to those that lead 
to pages on the same server as the Web page’s URL. For example, 
if http://www.example.com/dir1/index.html is the URL for the 
first page in the PDF, the linked page http://www.example.com/ 
dir2/apage.html would be included in the PDF, but a linked page 
at http://www.smilesoftware.com/ would not. 

‣	 Any: This choice allows PDFpenPro to follow links to any
 
directory or site and include those pages in the PDF.
 

5. Optionally, specify the maximum number of pages to include in the 
PDF. This is useful for preventing your Mac from being tied up for 
hours when you accidentally ask PDFpenPro to turn the entire 
Google index into a PDF. 

6. Optionally, set the margins for the pages that will be created. 
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7. Optionally, click Open Page Setup, and set the dimensions and 
orientation of the pages to be created. 

8. Click Create, and stand back as PDFpenPro does its magic. 

Before you know it (depending on the speed of your Internet connec-
tion and the complexity of the pages involved), you’ll have a PDF 
version of a Web site. 

Make a PDF Table of Contents 
(Pro Feature) 

Not every PDF needs a table of contents, but if you have a PDF that is 
more than a few pages long, providing a table of contents is a courtesy 
to your readers. In PDFpen and PDFpenPro, as with Apple’s Preview, 
you view a PDF’s table of contents in the document window’s sidebar 
(see Navigate with the Sidebar). 

In PDFpenPro, you can also edit a PDF’s table of contents. With the 
table of contents displayed (choose View > Table of Contents or select 
it from the Sidebar pop-up menu), use the action menu at the 
bottom of the sidebar (Figure 23) to fine-tune the document’s table 
of contents. 

Figure 23: Use PDFpenPro’s Table of Contents action menu to edit 
a document’s table of contents. 

Note: The same menu items appear on the Edit > Table of Contents 
submenu in PDFpenPro. 
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To add a table of contents entry, do the following:
 

1. Choose View > Table of Contents. 

This command has the virtue of both displaying the sidebar if it is 
hidden and showing the table of contents in one step. 

2. Go to a page that has a heading or content that you want to include 
in the table of contents, and then, with the Edit tool, click any-
where on that page. 

3. On the Table of Contents action menu, choose Add Entry. 

PDFpenPro puts the new entry in the table of contents, and names the 
entry Page # where # is the number of the currently displayed page. 
The entry name is selected so you can easily change it. 

You can also add entries hierarchically: Add Aunt adds an entry one 
level above the current level (unless you are at the top level already); 
Add Child adds an entry nested within the current one. 

Tip: If you select text on the page with the Select Text tool before 
you choose Add Entry, the selected text becomes the entry name. 

Here’s how to rename a table of contents entry: 

1. In the sidebar, double-click the entry. 

2. Type the new name and then press Return. 

As you work on a PDF, you may find yourself rearranging the order of 
the pages (see Rearrange Pages). In such cases, you may find it neces-
sary to reorganize the Table of Contents. You can arrange the order in 
which entries appear, remove entries, and nest entries hierarchically. 
This last capability is useful for structured documents that have head-
ings and subheadings (much like this book, in fact); see Navigate with 
a Table of Contents for an example of nested entries. 
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Here are the methods by which you organize a table of contents: 

•	 Change where an entry appears: Drag the entry up or down 
the table of contents to the desired position. 

As you drag, a translucent image of the entry follows your pointer, 
and a line appears to show you where the entry will be placed when 
you release the mouse (Figure 24). 

Figure 24: Drag to reposition a table of contents entry. 

•	 Delete an entry: Click the entry to select it and then press Delete. 
You can also click it and then choose Remove Entry from the Table 
of Contents action menu. 

•	 Nest or un-nest an entry: While dragging an entry you can 
control whether it is nested under another entry—pay attention to 
the location of the blue line and drag directly onto another item to 
nest the entry under it. Or you can do one of the following: 

‣	 To nest an entry beneath the entry above it, click the entry and 
then choose Demote from the Table of Contents action menu. 

‣	 To un-nest an entry, click the entry and then choose Promote 
from the Table of Contents action menu. 
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Take Notes on a PDF 
People (especially students) love to write in books, scribble in the 
margins, put sticky notes on pages to flag them, use highlighter pens 
to call attention to important passages, draw circles and arrows to 
connect margin notes to text, and generally make a glorious mess of 
things as they attempt to comprehend the contents of their books. 

As you already saw in The Markup Tools, PDFpen has an assortment of 
tools you can use to perform similar actions on the contents of a PDF. 

In this chapter, you’ll see how to take notes for a research paper by 
using these tools to mark up PDFs. 

Highlight Text
 

It is a rare student who doesn’t use a highlighter pen to mark up text. 
Highlights draw attention without obscuring the text. In fact, many 
students color-code their highlights: a student might use yellow for 
important facts, blue for quotable passages, and so on. PDFpen has 
four standard colors for highlighting, as well as a fifth, customizable 
color. You can also highlight text with three kinds of lines. 

Highlight in Color 
As you learned in The Selection Tools, you use the Highlight Text 
tool to select text and simultaneously apply the current highlight color. 
The current highlight color is both displayed in, and selectable from, 
the Highlight pop-up menu in the document window’s toolbar. 

Here’s one way to highlight text: 

1. Choose Tools > Highlight Text Tool. 

2. In the document window toolbar, from the Highlight pop-up menu, 
choose a highlight color. 

3. Select some text in the PDF. 
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The selected text takes on the chosen highlight color. Every additional 
selection you make with the Highlight Text tool applies the chosen 
highlight color. 

However, you don’t need to use the Highlight Text tool to highlight 
text. Instead, you can use a keyboard shortcut. This is how I prefer to 
highlight text, because I don’t have to switch to the Highlight Text 
tool. To apply a highlight color to selected text, type Command-Shift-
Option-(a number from 1 to 5). You can see the highlighting keyboard 
shortcuts by choosing the Format > Highlight submenu, a piece of 
which is shown in Figure 25. 

Figure 25: The Format > Highlight submenu shows the keyboard 
shortcuts for applying a highlight to the currently selected text. 

Remove a Highlight 
Obviously, being able to remove highlights is important. Aside from 
aesthetic considerations, when a page has too many highlights it’s hard 
to know which highlights are really important. Besides, even the best 
of us make mistakes and highlight a passage in error. 

Here’s how to remove a highlight: 

1. With the Select Text tool, select any portion of the highlighted 
text you want to remove. You don’t have to select the entire high-
lighted passage; any portion will do. 

2. From the Highlight pop-up menu in the toolbar, choose Remove. 

The entire highlight is removed. 

Tip: I prefer to remove highlights with a keyboard shortcut: I select 

a bit of the highlighted text with the Select Text
 tool and then
 

type Command-Shift-Option-Zero. (The Remove command with that 

shortcut appears on the Format > Highlight submenu.)
 

58
 



   
            

            
           

        
      

       

     

           
 

        

            
      

        
     

 
           

           
          

          
          

    

      

Set a Custom Highlight Color 
If the four standard highlight colors don’t appeal to you, you can 
specify a custom highlight color. This color is set in the PDFpen 
Editing preferences and, once set, is available in all documents you 
subsequently open. 

Note: If you change the custom highlight color, any text highlights 
that use the former custom color retain that color. 

Here’s how to set the custom highlight color: 

1. Choose PDFpen > Preferences > Editing. 

2. Near the bottom of the Editing pane, click the Custom Highlight 
Color swatch. 

3. In the Colors panel that appears, select a color. 

PDFpen applies a 40% opacity to the chosen color, regardless of the 
Opacity slider setting in the Colors panel. 

Tip: Changes to the Custom Highlight Color take immediate effect, 
so you can try various settings without closing the Preferences 
window. 

Underline Passages 
If the five different highlight colors aren’t enough to suit your needs, 
you can also mark text with various kinds of lines, although these are 
usually used for copy-edit purposes (read Copyedit and Review a PDF). 

Like highlight colors, the line highlights are available from the 
toolbar’s Highlight pop-up menu. The highlight lines appear in indigo, 
as shown in Figure 26. 

Figure 26: You can use three kinds of lines to highlight text. 
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Here are the three kinds of line highlights available to you: 

•	 Underline: This is a simple text underline. If the PDF contains 
underlined text (using underlines to indicate italics is a standard 
manuscript convention), you probably want to avoid using it. 
Otherwise, an underline is a subtle way to highlight a passage that’s 
not as obvious as a colored highlight. You can underline selected 
text by typing Command-Shift-Option-6. 

•	 Strikethrough: This draws a line through, rather than under, the 
text. Strikethroughs are often used to mark passages for deletion, 
and are, therefore, not a very good choice for highlighting text. You 
can type Command-Shift-Option-7 to strike through selected text. 

•	 Squiggle: This draws a wavy line under the selected text, and is 
useful for highlighting purposes, although the squiggle underline 
is often used to indicate passages that should be set in bold type. 
Command-Shift-Option-8 is the keyboard shortcut for applying a 
squiggle underline to selected text. 

Add Commentary
 

When you think about it, highlights provide a secret coded commen-
tary to a PDF: you may know what the different highlight colors you’ve 
used mean, but everyone else has to guess. You can, however, add 
textual commentary that anyone can understand. 

PDFpen has two different tools for adding textual commentary to a 
PDF: the Note tool and the Comment tool. 

Add Pop-up Notes 
Notes are useful for when you have a large amount of commentary to 
add: the note window can be closed to remove clutter, and opened by 
clicking the note icon. When you reopen a note window, it retains the 
shape and position it had when you last closed it. 
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A note comes in two parts: a small, balloon-shaped icon that you can 
position on the page, and a note window (Figure 27). 

Figure 27: A note consists of an icon and its associated window. 

Notes are also useful when more than one person is commenting on 
the PDF. As you can see in Figure 27, above, the note window con-
tains the name of the person who added it, and the date that the note 
was added. You can choose whether or not to show a name, and specify 
the name to use, in PDFpen’s Editing preferences. 

Tip: You can change the color of the note icon by selecting the note
 

and changing the fill color with The Object Property Tools.
 

To add a note to a page, do the following: 

1. In the Editing Bar, click the markup tools segment of the 
tool-selection button, and then click the Note tool. 

2. Click on the page where you wish the icon to go. 

You can drag the icon wherever you like with the Edit tool. 

3. In the note window, type your note (or paste it from the Clipboard), 
and adjust the window’s size and location as desired. 

4. Optionally, close the note window; if you need to reopen it, click the 
note icon. 
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Tip: Consider placing the note icons near the left or right margins 
of text objects instead of over the text itself. This makes them more 
visible, and avoids obstructing the text. Also, try to position the note 
windows so they don’t obstruct the information to which they refer. 

Add Comment Boxes 
When you need to add short commentary that always remains visible 
on the page, add a comment box (Figure 28). 

Figure 28: A comment box always stays on the page. 

Comment boxes use the default font (set in PDFpen’s Editing prefer-
ences), and, by default, are black with a thin border. However, you can 
set the color and border thickness with the Editing Bar’s object proper-
ty tools (see The Object Property Tools), as demonstrated by the blue 
comment box shown in Figure 28, just previously. 

To add a comment to a PDF page, do the following: 

1. In the Editing Bar, click the markup tools segment of the 
tool-selection button, and then click the Comment tool. 

2. Click on the page to add a comment box at the default size, or click 
and drag to create a comment box with a custom size and shape. 

3. Select the text within the box (the default text is “Text”), and type 
your comment. 

4. Optionally, choose the Edit tool, and reposition or resize the 
comment. 
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Tip: Remember that you can quickly review all the comments, notes, 
and text imprints you’ve added to the PDF, and go to each one, by 
using the Annotations sidebar (see Navigate with Annotations).

Print Notes and Comments
When you print a PDF, you have control over whether the notes and 
comments print. Figure 29 shows the relevant portion of PDFpen’s 
Print dialog; you may have to click Show Details in the dialog to see it.

Figure 29: You can control whether notes or comments print using 
these options on the Print dialog.

Here’s what the options do:

• Print Comments: Select this to have the comments print in the 
exact location where you placed them on the page. By default, the 
option is unchecked.

• Print Notes: Select this to have the note window contents print 
at the bottom of the page as numbered footnotes. PDFpen reduces 
the page size so that the notes fit, and it adds a note number to each 
note icon on the page. This option is unchecked by default.

Note: When you print, any other markup you’ve added to a PDF—
squiggles, highlights, underlines, text imprints, and so on—does 
print, no matter what.

Draw Attention

Sometimes you need to call attention to an item. For example, you 
can draw an arrow from a comment box to point at a particular part 
of a graphic, or call out part of an image or line of text with one of the 
drawing shapes (see The Drawing Tools) or the Highlight  tool.
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You can easily create elaborate eye-catching graphics with PDFpen’s 
drawing and object property tools. For example, Figure 30 shows a 
portion of a musical score that I’ve highlighted by superimposing a 
rounded rectangle, which has a custom fill color (yellow at 25% 
opacity) and a custom stroke (green, with a 2-point width).

Figure 30: Draw attention to important information with the 
drawing and object property tools. The drawn object shown 
here is selected, showing its bounding box with control points 
at the corners.

And since I’ve been nattering on about the object property tools, 
Figure 31 shows them in the Editing Bar:

Figure 31: The object property tools control how an object’s 
fill and stroke appear; from left to right they control fill and 
stroke colors, line attributes, and stroke width.

Each tool is a pop-up menu that changes appearance to show its 
current setting, as described earlier in The Object Property Tools.

Note: Each drawing tool retains the object property settings you 
made the last time you used that tool.

With the Edit  tool you can select and drag drawn objects around, 
and resize and reshape them by dragging the edges of their bounding 
boxes or their control points. 

Should you wish to use a drawn object again, you can copy and paste it, 
and add it to your Library (see The Library).
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Another way to draw attention is with the Highlight  tool. Though 
the tool is normally used to highlight text, as described earlier in The 
Selection Tools, when you position the tool over a non-text portion 
of the page, you can draw freeform highlights in the current highlight 
color (Figure 32). Note, however, that freeform highlights are locked 
in place when you draw them; to unlock them so you can select and 
delete them, choose Arrange > Unlock All.

Figure 32: You can draw freeform highlights.



             
            

           
 

             
             

            
        

             
    

  

            
          

         
 

           
       

            
          

           
               

               
            

          
           

            
          

Copyedit and Review a PDF 
When you take notes on a PDF, the notes are usually intended for 
you and you alone. Copyedit notes and review notes, by contrast, are 
intended to be read by someone else: usually a writer, collaborator, 
or editor. 

That’s not to say that the techniques used to copyedit and review a 
PDF are different from those you use when you take notes. In fact, 
many of the techniques are the same: what differs are the audience 
for the notes and the purpose of the notes. 

So, take note: before you read the following brief section, I urge you 
to read Take Notes on a PDF. 

Learn about Copyediting
 

In today’s modern society today (as a poorly written student paper I 
once received said), writers and editors seldom exchange printed copy 
marked up with handwritten notes and queries. Instead, they often 
exchange PDFs. 

The advantages of speed and cost are obvious: shipping a 500-page 
set of galley proofs (an unbound preliminary printed version) can take 
days and cost many dollars compared to the few minutes and few 
pennies that emailing a PDF of the same material might involve. 

There are disadvantages to the digital method, of course: it’s more 
pleasant to sit in a comfy lawn chair on a mild summer day with a red 
pencil and a stack of galleys and mark things up than it is to hunker 
down at a desk in a stuffy office, wrestling with mouse and keyboard. 
But those digitally imposed discomforts have begun to dwindle as 
technology advances: with a lightweight laptop or a tablet, a copy of 
PDFpen, and maybe a Long Island Iced Tea, the act of digital copyedit-
ing can be almost as enjoyable as the traditional manual method. 
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What Is Copyediting? 
Copyediting is the act of marking up a text to make suggestions 
for improving its style, format, and accuracy. Although it’s often 
separate from a proofreading pass over the text, where typographical 
errors are corrected, it is just as often combined with proofreading 
(although, in those cases, a second proofreading pass usually occurs 
following the initial copyedit/proofing pass). 

In this section, I treat the proofreading and copyedit stages of 
manuscript preparation as combined. 

Use the Proofing Marks 
Most copyeditors use a standard set of proofing marks, and follow 
certain conventions in their use. The goals are these: 

•	 Indicate where there are problems in the document. 

•	 Indicate the type of each problem. 

•	 Indicate what to do to fix each problem. 

•	 Make those indications as visible as possible. 

•	 Take up as little of the page’s limited space as possible when doing 
all of these things. 

Each textual problem usually has two marks associated with it: a small 
mark that is placed within the text and an associated mark that is 
placed next to the line in the margin. 

The purpose of the margin marks is to alert you to the problem, its 
general location, and its type. The purpose of the mark in the text is 
to show exactly where the problem is and to help indicate the solution. 

Figure 33 shows a copyedited page with proofreading marks; notice 
how much easier it is to spot the margin marks than those in the text. 
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Figure 33: Proofreading marks indicate insertions, deletions, and 
format changes. 

Tip: You can see an extensive list of proofreading marks with exam-
ples of their use in context on this page at EEI Communications. 

PDFpen’s Library has a rich assortment of proofreading marks. You 
can use these marks when you edit a text. 

To access PDFpen’s proofreading marks, do the following: 

1. Choose Window > Library or click Library in the document window 
toolbar. 

2. In the Library window, click the Proofreading Marks tab 

(Figure 34).
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Figure 34: The Library has an extensive collection of proofreading 
marks; the names of some are available when you hover the pointer 
over them. 

When you want to add a mark to a page, drag it from the Library to the 
page with the Edit tool. When it’s on the page, you can adjust its size 
if necessary by dragging the mark’s handles with the Edit  tool. 

Most of the proofreading marks in the Library have three forms, as you 
can see in Figure 34, above. From left to right the forms are: 

•	 Editing marks: You place these in the text itself when you 
copyedit a draft document. Drafts are commonly double-spaced (as 
in Figure 33, above) and have more room for markup. Therefore, 
editing marks tend to be slightly larger than proofreading marks 
(described next). 

•	 Proofreading marks: You place these in the text itself during a 
final proofreading pass. These marks tend to require less space than 
editing marks, and space is at a premium for material that is typeset 
in (nearly) final form. 

•	 Margin marks: You place these in the margin to call attention to 
the editing or proofreading marks that you’ve placed in text. Not all 
editing or proofreading marks have margin mark equivalents. 

Note: Generally, you should use either the editing marks or the 
proofreading marks in a document and not mix the two—although the 
proofreading police won’t arrest you if you do. 
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Learn the Copyediting Best Practices 
While I’m not about to teach you all of the fine points of copyediting 
(folks, there are whole books about this stuff!), here’s a short list of 
best practices that cover some basics: 

•	 Use the editing/proofreading marks within the text to indicate 
requested changes and corrections, and place the associated margin 
marks in the margin. 

•	 When adding text, place a comment box containing the text above 
an insertion mark in the margin, and use an insertion mark within 
the text to mark the new text’s location (Figure 33, above, shows 
several examples). 

•	 Use a deletion mark in the margin to indicate deletions, and use the 
Strikethrough line highlight in the text to indicate deletions of more 
than one character; for a single character deletion, use a deletion 
mark in the text instead of a strikethrough line. 

•	 Use the Underline highlight to indicate italics within the text, and a 
margin mark to indicate it in the margin. 

•	 Use the Squiggle line highlight to indicate bold within the text, and 
a margin mark to indicate it in the margin. 

•	 Use comment boxes in the margin to indicate brief suggestions, but 
make them a different color than any comment boxes used for 
inserted text. 

•	 Place note icons in the margin for queries to the writer or the editor; 
write the query in the note window, and make sure to close the 
window when you finish writing. 
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Learn about Review Practices
 

PDFs are commonly used when circulating a document for review. 
Reviews can have a number of purposes: 

•	 To solicit opinions and suggestions from colleagues (for example, 
a draft document on a proposed business method) 

•	 To evaluate whether a document should be published (for example, 
peer review of papers submitted to academic journals) 

•	 To verify a document’s accuracy (for example, recipes in a cookbook 
or procedures in software documentation) 

There are no special tools designed specifically for document reviews. 
Rather, the tools and techniques described in Take Notes on a PDF— 
highlights, notes, comments, and drawings—can be, and often are, all 
used in reviews. What differs, as I’ve said, is the audience for and the 
purpose of the notes. 

Choose How to Circulate a Document 
How you circulate a document for review depends on the number of 
people involved, the need for confidentiality, and the schedule. There 
are two common circulation methods: 

•	 Star review: Copies of the document are sent from the editor to 
all reviewers at once (like the rays emanating from a star). Each 
reviewer supplies her own notes and returns the copy to the editor. 
This method is quick, and ensures that each reviewer’s notes are 
confidential, since only the reviewer and editor see them. However, 
a star review requires more work on the editor’s part to integrate 
the notes and suggestions, and can result in many redundant notes. 

•	 Round-robin review: The document is sent to each reviewer in 
sequence, accruing notes as it circulates. This allows later reviewers 
to see the notes of previous reviewers and can eliminate redundant 
notes. However, a round-robin review takes more time than the star 
method, since only one reviewer at a time works on the document. 
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It might also lead to instances of “false consensus” if later reviewers 
are influenced or intimidated by notes from earlier reviews. 

Follow Best Review Practices 
Finally, here are some best practices to follow when participating in a 
review: 

•	 Be polite: Even if the review is confidential, there is no guarantee 
that the author might not see your notes, even if your name isn’t 
associated with them. Rants and derogatory terms are never appro-
priate. 

•	 Question or suggest, don’t dictate: This goes along with being 
polite—unless you are the editor, you don’t have final say (and most 
good editors tend to question or suggest rather than wield the 
Awesome Hammer of Authority). 

•	 Be brief: Even if a note window with a scroll bar gives you ample 
room to expand upon your thoughts, be succinct. The editor and 
the writer both have to deal with comments from many reviewers, 
and, as a manuscript nears completion, time is usually a precious 
commodity. 

•	 Stay on topic: Don’t get sidetracked by copyediting or proofread-
ing issues; that’s usually not what a review is for. Focus on the 
issues on which the editor or author has asked you to comment. 

Which leads to this last best practice…. 

•	 (For the review organizer) Give clear instructions: Let 
the reviewers know what they should be concentrating on as they 
review the document, and let them know what they can ignore. If 
you have specific requirements for the form of the comments (for 
example, use notes rather than comment boxes, recommended 
highlight colors), state them explicitly. Make sure that all reviewers 
know the date by which the review must be completed. 
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Fill Out PDF Forms 
You live in a world of forms. Forms for filing taxes. Forms for ordering 
goods. Forms for applying for jobs. Forms for supplying medical 
information. Forms for ordering more forms. 

Often, forms come to you as PDFs, whether downloaded from the Web 
or arriving as email attachments. And, if you’re really Old School, you 
can print those forms out and then fill them in by hand. 

But you don’t have to be Old School: with PDFpen, filling out a PDF 
form is a piece of cake, no printing required. You can even add a digital 
scan of your signature directly to the PDF. 

So whether you have an interactive PDF form that lets you fill it out 
onscreen, or a PDF containing a digital image of a classic printed form, 
PDFpen has the tools that you need to make quick work of it. 

Fill Out an Interactive Form
 

Since version 1.2 of the PDF standard back in the last century, PDFs 
have been able to include interactive form elements. Filling out such 
a form is so easy to do with PDFpen that it’s hardly worth mentioning 
(but, of course, I will—I’m here for you). 

Most interactive PDF forms look indistinguishable from their non-
interactive counterparts. This raises the question: how can you tell 
if a PDF form is interactive? 

Here’s how: With the Select Text tool, click a form element, such as 
a text entry area or a checkbox. When you click an interactive text area, 
PDFpen outlines it with a blue box and places your cursor in the box 
so you can type your information directly into the form (Figure 35). 
If you click a checkbox on an interactive form, PDFpen places a check 
mark in the box for you; click it again to remove the check mark. 
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Figure 35: You can fill out an interactive form with PDFpen. 

As I said, easy. 

You may be allowed to return a form by email as a normal attachment. 
Other interactive forms might need to be printed when you finish 
filling them out, and then physically sent to the recipient by mail, fax, 
or some other method. 

Tip: Many interactive forms include instructions for how to fill them 
out and submit them. You can save yourself some time and trouble if 
you first look for, and read, any such instructions before you attempt 
to fill it out. 

You may encounter interactive forms that take advantage of an Inter-
net connection, and that can submit the form information directly over 
the Internet (you can design such forms with PDFpenPro; see Make an 
Interactive PDF Form (Pro Feature)). Forms that send their informa-
tion over the Internet normally have a Submit button, or a button with 
a similar label, that you click when you’ve completed the form. 

The form may also have a Clear or Reset button that you can click to 
clear all of your entries if you need to start over. If it doesn’t, you can 
choose Edit > Reset Form. 

Note: Not all PDF apps support sending form information over the
 

Internet. For example, PDFpen does; Apple’s Preview app doesn’t.
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Fill Out a Non-interactive Form
 

Filling out non-interactive PDF forms is more work than interactive 
forms—but not much more. With few exceptions, non-interactive 
forms only have two kinds of form element with which you need to 
deal: checkboxes and text entries. 

Fill Out a Text Entry 
The key to filling out a text entry on a non-interactive PDF is to put 
a text imprint over the text entry area (Figure 36). 

Figure 36: Place a text imprint over a text entry area in a non-
interactive PDF form. 

It only takes a couple of steps to create a text imprint and fill it out: 

1. With the Text tool, drag out a text imprint that fits over a text 
entry area on the PDF. 

The default text in the imprint is selected automatically when you 
create the imprint. 

Tip: Click to create an imprint if the text entry area is a single line. 
See Set Wrapping in a Text Imprint. 

2. Type your entry.
 

Your text appears in PDFpen’s default font.
 

Tip: If PDFpen switches to another tool after you create an imprint, 
you can double-click the Text tool to keep it selected so you can 
quickly create additional text imprints on the form. 
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Unless you have changed it, the default font in PDFpen is 12-point 
Helvetica. If this font is impractical (for example, the text area on the 
form is too small to accommodate a 12-point font), you can change the 
imprint’s font and font size. 

To change a text imprint’s font and font size, do the following: 

1. If the Fonts panel is not already visible, choose Format > Font > 
Show Fonts (Command-T). 

2. With the Edit tool, select the text imprint. 

3. In the Fonts panel, click a font in the Family column, and then click 
a size in the Size column. 

The text imprint takes on the font, style, and size you have chosen. 

Tip: You can use the Fonts panel’s search field to find a font quickly, 
and you can type a font size directly into the Size field at the top of 
the Size column. 

The above steps for changing the font are fine if you have only a few 
text areas to fill out, but they can quickly become cumbersome if the 
form has a lot of text entries. In that case, you can change PDFpen’s 
default font, as follows: 

1. Choose PDFpen > Preferences > Editing. 

2. Near the top right of the Editing preference pane, click Select to 
display the Fonts panel (Figure 37). 
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Figure 37: Set PDFpen’s default font in the Editing preferences. 

3. In the Fonts panel, select a new default Family and Size. 

If you wish, you can select a new default Typeface style as well. 

4. (Optional) Close the Fonts panel and the Preferences window. 

Preference changes take effect immediately, so you don’t have to close 
the Preferences window. You may want to leave the window open so 
you can reset the default font when you finish filling out the form. 

Tip: If you’d rather not change the default font in PDFpen, you can 
also create a text imprint, customize its font, and then Option-drag 
it to place an identically formatted copy elsewhere on the form. Or 
consider adding a properly formatted text imprint to your Library (see 
The Library). 

Fill Out a Checkbox 
There are several ways to fill out a checkbox in a non-interactive form. 
For example, you could put a small text imprint over the checkbox and 
type an X or √ (Option-V in many fonts), use the Scribble tool to 
hand-draw a check mark, or use the Polygon tool to make a check 
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mark. Remember that once you’ve placed a check mark, you can 
Option-drag it to a new location to place a copy there. 

Personally, I like to use the Library, because it comes with a ready-
made check mark in the Proofreading Marks collection (Figure 38). 

Figure 38: Steal a check mark from the Library’s Proofreading 
Marks collection to check off boxes in a form. 

Follow these steps to use the Library to fill out checkboxes: 

1. Choose Window > Library or click Library in the document 
window’s toolbar, and then, in the Library window, click the 
Proofreading Marks tab. 

2. Scroll down to find the check mark. It’s about two-thirds of the way 
down in the collection. 

3. For each checkbox that you want to check, drag the check mark 
from the Library window to the checkbox on the form. 

Add a Scanned Signature
 

Ordinarily, when a non-interactive PDF form requires a signature, you 
can fill out the form with PDFpen, print it, and sign the printed copy. 
Sometimes, though, the party that sent you the form may allow you to 
send a PDF of a signed form back via email. If so, you can add a signa-
ture to a PDF form within PDFpen and avoid the printing step. 
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Warning! A signature image, like any other image in a PDF, can 
easily be copied and reused. Make sure you send PDFs containing 
images of your signature only to trusted parties. Of course, a 
scoundrel receiving your signature on paper could scan it too, so it’s 
not as though avoiding a digital format is a guarantee of safety. 

Figure 39 shows an example of a signature imprint placed in a PDF.
 

Figure 39: Sign a PDF form with a signature image. 

The general steps are these: 

1. Obtain an image of your signature. This can be from a scan, a digital 
photo, or from some other source like a drawing program. 

2. Place the image on the form in PDFpen (see Add and Alter 
Pictures). 

3. Crop and resize the image to fit (see Resize and Crop an Image). 

4. Make the image transparent so only the pen-strokes are visible 
(read Make a Transparent Image). This makes your signature sit on 
top of a horizontal line, making it look like you wrote over the line. 

5. Optionally, save the transparent signature in The Library so you can 
reuse it in other forms. 

Tip: The PDFpen Help also has extensive instructions for all these
 

steps; see “Adding Signatures” in PDFpen’s Help, or see the Web 

version.
 

Tip: If you need to print your form entries on a pre-printed form, use 
the Print Imprints Only option in the Print dialog; see Print Your PDFs. 

79
 

http://www.smilesoftware.com/help/PDFpen/images.html
http://www.smilesoftware.com/help/PDFpen/images.html


           
            

 

              
            

           
         

     

          

      

    

    

           

             

           
      

    

                
                
           

          

         

Edit a PDF 
The conventional wisdom is that PDF documents are great to share 
because, unlike word processing files, PDFs are in final form and can’t 
be modified. 

Yeah, right. If you’ve read any part of this book, you know that PDFs 
are far from unmodifiable. Nonetheless, it is true that PDFs are not 
easily modifiable—that is, not unless you have a tool like PDFpen. 
Armed with PDFpen, you can make all sorts of changes, such as: 

• Fix typos in a magazine article. 

• Update an old flyer, even if you don’t have the original. 

• Sharpen and stylize pictures on the page. 

• Redact sensitive or confidential material. 

• Crop pages or rotate them. 

• Create links to other pages in the PDF or to Web pages. 

In this chapter, you’ll learn how to do all of these things and more. 

Warning! When you edit a PDF, never edit the original. Make a copy 
and edit that. Trust me, you’ll thank me for saying this. 

Add, Edit, and Remove Text
 

You’ve already seen how to add a text imprint to a PDF in Fill Out a 
Text Entry: select the Text tool and click or drag on a page in the 
PDF. Each time you create an imprint, it contains the sample text, 
“Text,” which is selected so you can quickly replace it by typing. 

Tip: To duplicate an imprint, Option-drag it with the Edit tool. 
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Set Wrapping in a Text Imprint 
Whether text wraps in an imprint depends initially on whether you 
created the imprint by clicking or by dragging: 

• Clicking: When you click with the Text tool to make an imprint, 
the text box expands horizontally as you type. The text doesn’t wrap, 
so you may find yourself typing a long line of text that extends 
beyond the edge of the page. Similarly, if you paste a lengthy chunk 
of text into the imprint, the text ends up on a single line. 

You can change this behavior by enabling text wrapping before the 
text imprint becomes too wide. When text wrapping is enabled, 
typed text wraps when it reaches the right border of the box. To turn 
on text wrapping, do the following: 

1. Place the cursor within the imprint, or select the imprint with the 
Edit tool. 

2. Choose Edit > Wrap Text. 

•	 Dragging: When you drag to create an imprint, the text that you 
subsequently type wraps automatically to the width of the imprint, 
and the imprint expands vertically once the text reaches the bottom. 
This is because the Wrap Text command is enabled for imprints 
that you create by dragging. If you choose Edit > Wrap Text on such 
an imprint, Wrap Text is disabled, and the text imprint behaves like 
one that was created by clicking. 

Whether the text wraps or not, you can adjust the size of a text imprint: 

1. Choose the Edit tool and click the imprint. 

2. Drag a handle at a corner of the imprint to resize and reshape it. 

When Non-wrapping Imprints Wrap 
When you resize a non-wrapping imprint, the text does wrap, but 

as soon as you attempt to add text to the imprint, it unwraps again,
 
and can leave you with a short, wide, and possibly unwieldy imprint.
 
Always remember to turn on wrapping as soon as you resize a non-


wrapping imprint to avoid an unpleasant surprise.
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Tip: Click to create an imprint when you know its text needs to be on 
a single line. Drag to create an imprint if you know the text has to fit 
within a specific horizontal space. 

Change the Appearance of Text 
A newly created text imprint uses PDFpen’s current default font 
(described in Fill Out a Text Entry). But the text imprint doesn’t have 
to remain in that font. In fact, you can mix fonts and text colors within 
an imprint, and you can set the font, text color, and background color 
for the imprint as a whole. 

Note: By “font” I mean the font family, typeface, and size, as chosen 
in the Fonts panel. 

By default, imprints are transparent, but you can give them a back-
ground color. You can make an imprint’s background color completely 
opaque, or you can adjust the color’s opacity so that objects behind the 
imprint can be seen. 

Here’s how you change the background color of an imprint: 

1. With the Edit tool, click to select the imprint. 

2. In the Editing Bar, click the Colors property tool, click the Back-
ground Color tool at the top of the pop-up menu, and then click 
the Other Colors button at the bottom of the menu. 

3. In the Colors panel that appears, choose a color and, optionally, 
adjust the color’s opacity with the Opacity slider. 

Note: You cannot give a range of selected text a background color; 
the background color always affects the entire imprint. 

You can set the formatting for a range of selected text in an imprint or 
for the imprint as a whole. 
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Here are the text formatting settings you can make: 

•	 Text styles and relative sizes: Choose Format > Font and an 
appropriate submenu item. The submenu items include Bold, Italic, 
Underline, Smaller, Larger, Kern, Ligature, and Baseline. Note that 
you can set kerning, ligature, and baseline only for text selections, 
not for a selected imprint. 

•	 Text alignment: Choose Format > Text, and then choose either 
Align Left, Center, Justify, or Align Right. 

•	 A specific font (family, typeface, and size): Choose Format > 
Font > Show Fonts, and then specify a font with the Fonts panel. 

•	 Text color: Choose Format > Show Colors, and then choose a color 
in the Colors panel. 

Tip: Also see the sidebar, A Wise and Benevolent Ruler (a few pages 

ahead), for another way to perform text layout tasks. Some of these
 

tasks, such as setting line spacing and paragraph indents, are avail-
able only from the ruler.
 

Here are explanations of the less common formatting terms: 

•	 Kern: The commands on this submenu control the amount of 
space between individual characters. Here are your choices: 

‣	 Tighten and Loosen: These two commands, respectively, bring 
the characters closer together or send them farther apart. Place 
the cursor between two characters to adjust the kerning between 
them, or select a range of text to adjust the kerning for the entire 
selection. 

‣	 Use Default: Select this to use the kerning pairs built into the 
font. The available kerning pairs vary from font to font. 

‣	 Use None: Choose this to ignore the default kerning pairs and 
space the characters equally. 

Ordinarily, Use Default is the best choice unless you have specific 
typography needs. 
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•	 Ligature: Some fonts have special characters that are designed 
to replace specific character combinations. For example, “ff” and 
“fl” are frequently replaced with ligatures that combine the two 
characters to make them fit together more attractively. Moreover, 
some decorative fonts include less common ligatures, such as 
ligatures for “ct” and “st.” Which character combinations PDFpen 
replaces by ligatures depends on the ligatures available in the 
selected text’s fonts. 

Here are the Ligature submenu choices: 

‣	 Use Default: This command substitutes the common ligatures for 
matching character combinations in the selected text. 

‣	 Use All: This command substitutes any available ligature, com-
mon or not, for matching character combinations in a selection. 

‣	 Use None: This command does not do any ligature substitution, 
and removes ligatures placed by the other two commands. 

Use Default is ordinarily the best choice. 

Note: Even if ligatures are substituted, you can still easily edit the 
text: for example, you can place your text cursor between the “f” and 
the “l” in the “fl” ligature just as if the two characters have not been 
replaced by a ligature. 

•	 Baseline: The commands on this submenu affect the amount of 
vertical spacing between selected characters and the baseline: 

‣	 Superscript and Subscript: These commands raise or lower the 
selected characters about half the character height each time you 
apply them. You might use these when typing formulas. 

‣	 Raise and Lower: These commands raise or lower the selected 
characters a small amount (about 1 point) from the rest of the 
characters on the line each time you apply them. Use these 
commands to make fine adjustments, such as when you correct 
text on a page. 

‣	 Use Default: This puts the characters back where they belong. 
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A Wise and Benevolent Ruler 
For heavy duty text formatting, PDFpen supplies a ruler (Figure 40). 
Choose Format > Text > Show Ruler (Command-Control-R) to see it. 

Figure 40: The ruler can set indents, tabs, alignment, and more. 

The ruler spans the top of the document window, and the settings 

it displays are those for the currently selected text. If you have ever
 

used Apple’s TextEdit, you have seen this ruler.
 

The ruler provides most of the text layout controls you would find in
 

a word processing application, and is the only tool in PDFpen with
 

which you can easily do things like create numbered or bulleted lists 

or set specific amounts of line spacing.
 

You can copy and paste ruler settings from one text imprint to anoth-
er or between text selections in an imprint with the Format > Text > 
Copy Ruler (Command-Control-C) and Format > Text > Paste Ruler 
(Command-Control-V) commands. 

Correct or Remove Text on a Page 
It’s easy enough to edit text that you put on the page, but what about 
text that the PDF already contains? Here’s how to correct text: 

1. With the Select Text tool, select the text you want to change. 

2. On the document window toolbar, click Correct Text, or choose 
Format > Correct Text. 

Depending on the underlying structure of the text object in the PDF, 
the text you’ve selected and a varying amount of surrounding text 
appear within a text imprint (Figure 41). 

Figure 41: PDFpen puts your selection and surrounding text into an 
imprint when you use the Correct Text command. 
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3. Type your changes, or use a formatting or editing command, such as 
Format > Font > Bold, or Edit > Cut. 

Your changes take effect. What’s more, you can now move the imprint 
around, resize it, and do all the other stuff that you can do with the text 
imprints that you make. Zounds! 

Here’s how text correction works: PDFpen analyzes the various PDF 
text objects that contain your text selection, removes the text from 
those objects, and puts the text into a similarly sized imprint, matching 
the original objects’ layout and formatting as best as it can. “As best as 
it can” is key here—your Mac, for example, might not have the same 
fonts installed that were used to create the document. Or maybe the 
text was created from OCR (see Use OCR on Scans and Graphic Files). 
In those cases, PDFpen has to “fake it” when it makes the imprint. 

There are two kinds of “faking it” (these are gross oversimplifications— 
the processes belong in the realm of You Really Don’t Want to Know): 

•	 The font is not on your Mac: PDFpen examines whatever layout 
information it can scrounge up about the font and looks for the 
closest fit it can find on your Mac. The imprint will look similar, but 
not identical, to the original text. You may have to manipulate the 
imprint slightly to smooth out the differences. 

•	 The text object is the result of OCR analysis: PDFpen looks 
for a font that lays out with roughly the same dimensions as the 
scanned text, but doesn’t try to match the original font’s look in the 
imprint that it creates (Figure 42). You may have to work hard to 
make the imprint come close to matching the original’s appearance. 

Figure 42: This text imprint was derived from an OCR analysis of 
a low-resolution JPEG image that was scanned from a decades-old 
typed letter. Note the default font, Helvetica 12, was used in the 
imprint, and that the imprint does not quite align with the underlying 
text image, which was scanned at a slight angle. 
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Fortunately, to make the corrected text imprint look as much like 
the original as possible, you have access to PDFpen’s full range of 
text formatting capabilities: fonts, colors, sizes, baseline adjustments, 
kerning adjustments, line spacing, and so on. Learn them, and use 
them (see Change the Appearance of Text). 

Tip: Don’t try to correct huge amounts of text at once, especially 
in documents that have OCR text. The best use of the Correct Text 
feature is for minor touch-up work and careful, incremental changes. 

Edit the OCR Layer in PDFpenPro 
As described in About OCR Accuracy and the OCR Layer, you can 
view the hidden text created when you perform OCR. In PDFpenPro, 
you can also correct text directly on the OCR layer instead of with the 
Correct Text feature (which creates a text imprint, as described just 
previously). 

To correct text in the OCR layer, choose View > OCR Layer, and then 
click a word that you wish to correct, or drag to select several words 
to correct. A Correct OCR Text panel appears (Figure 43). 

Figure 43: Use this panel to correct text in the OCR layer. 

Enter your correction and click Apply. OCR layer corrections don’t 
appear in the PDF: the underlying text image remains. However, text 
searches of the PDF will search the OCR layer, including corrections. 

There’s another kind of text correction you can make that doesn’t 
require as much work: you can remove text completely. That is, in 
PDFpen terminology, you can redact it. 
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If there are confidential passages in your document, here’s how you 
can remove each one with PDFpen’s redaction capabilities: 

1. With the Select Text tool, select the text you want to remove. 

2. Do one of the following: 

‣ Choose Format > Redact Text – Block. 

‣ Choose Format > Redact Text – Erase. 

Here is how the two commands differ: 

•	 Redact Text – Block: This command removes the text from the 
underlying text object, and places a black rectangle where the text 
was (Figure 44). In the case of scanned text, it also deletes the part 
of the image from which the scan was derived. 

Figure 44: The names in this manuscript have been redacted 

to protect the innocent.
 

The black redaction rectangles are separate objects that you can 
move, fill with a different color, or resize—just on the off-chance you 
want to make your redactions a cheerful rainbow. 

•	 Redact Text – Erase: This command removes the text from the 
underlying text object, and, in the case of scanned text, it deletes the 
part of the image from which the scan was derived. 

Tip: You can also select a rectangular area of the page with the
 

Select Rectangle tool and then choose Format > Redact Text – Block
 

or Format > Redact Text – Erase to redact everything within the
 

selection.
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No Redaction for Imprints 
If you select text in a text imprint, the Redact Text menu items are 
disabled. Similarly, if a rectangular selection includes an imprint, 
redacting the selection leaves the imprint untouched. You can redact 
only text that is in a PDF text object embedded in a page. 

Search and Replace or Redact Text 
If you’ve been reading this book from front-to-back, you’ll have read 
that you can navigate in a PDF with PDFpen’s Find feature (see 
Navigate with Search Results if you are of the non-linear reading 
persuasion). Find, though, is only one-third of that feature: it’s really 
Find, Find and Replace, and Find and Redact. 

You can search and replace text like this: 

1. Choose Edit > Find > Find and Replace (Command-Option-F). 

The Replace window opens if it is not already visible, and the cursor 
is positioned in the Find field. 

2. Enter some text in the Find field. 

As you type, matching results appear in the window (Figure 45). 

Figure 45: Use the window to perform Find and Replace operations. 

3. Enter some text in the Replacement field. 

4. Do one of the following: 

‣	 Click a result in the Replace window and then click Replace— 
no, not the first Replace menu button to the left of the Find field 
(shown in the figure above), but the second one, between the 
Replacement field and the Replace All button. 
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‣	 Click Replace All. 

When you choose Replace, the following actions happen so quickly 
that you may not notice all the steps. First, the document displays the 
result that you clicked and selects the matched text. Then, that text is 
replaced with the contents of the Replacement field, after which the 
search result that you clicked vanishes from the window. Finally, the 
window selects the next search entry, if any. The end result is that 
everything is set up so that you can click Replace again to replace the 
new currently selected search entry. Lather, rinse, repeat. 

On the other hand, when you choose Replace All, PDFpen replaces 
every occurrence of the text that matches the Find field with the 
Replacement field’s contents. Depending on the size and complexity 
of the PDF document, this can take a few seconds. When the process 
finishes, no search results remain in the window, and the document 
shows the final replacement selected. 

Here are some important points to keep in mind when you perform 
a search-and-replace: 

•	 The search is both case-insensitive and word-boundary insensitive. 
If, for example, you search for the name Alf and replace it with 
Sigurd, not only will all occurrences of the name be replaced, but 
words containing the search term receive the replacement as well: 
halfway, for example, becomes hSigurdway. 

•	 If the found text is not already in a text imprint (that is, if it is in 
a PDF text object embedded in the page), the act of replacing it 
creates a text imprint, just as though you had selected the text and 
chosen Format > Correct Text (read Correct or Remove Text on a 
Page). It even works with OCR text in a scanned image (as is about 
to take place in Figure 45, a page or so back). 

The steps to perform a search-and-redact operation are similar to 
those for a search-and-replace: 

1. Choose Edit > Find > Find and Redact (Command-Shift-F). 
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The Redact window shows its Find field and includes a menu with 
redaction options (Figure 46). 

Figure 46: The Redaction Style menu gives you the option of
 
blocking out or erasing search results.
 

2. From the Redaction Style pop-up menu, choose a redaction style. 

You have the same two choices as for manual redactions: Erase or 
Block (these are described in Correct or Remove Text on a Page, a 
few pages earlier). 

3. Do one of the following: 

‣	 Click Redact (the button to the left of Redact All in the figure 
above) to redact matching results one by one. 

‣	 Click Redact All to redact every occurrence of the search term in 
the text. 

Keep these points in mind when you search and redact: 

•	 Redaction searches are also case and word-boundary insensitive, 
matching the search string no matter where it occurs in the PDF. 

•	 As with manual redaction operations, the redact operation only 
redacts text that is in a PDF text object embedded in the page; it 
does not redact any text that occurs within text imprints. Instead, 
you can perform a find-and-replace on those occurrences and 
remove the text from imprints that way (you will have to create the 
black redaction box by hand if you want to indicate a redaction). 

•	 Find and Redact doesn’t search a PDF’s metadata. (For instructions 
on modifying a PDF’s metadata, read the bullet item on “Document 
Info” in The Inspector.) 
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Add and Alter Pictures
 

PDFpen can import a number of image formats, including all the usual 
suspects: JPEG, TIFF, GIF, PNG, and Photoshop. When images are 
imported, PDFpen converts them silently to PDF image objects. 

You can import image files simply by dragging them from a Finder 
window or your Desktop directly onto the page currently displayed in 
the PDFpen document window. 

You can also drag an image file to the Thumbnail sidebar, in which 
case PDFpen creates a new page and centers the document on that 
page. 

Or, if you prefer, you can follow these steps, which use the standard 
Open dialog and help you if you need to search for the file by name: 

1. Click Insert on the document window toolbar. 

The standard Open dialog slides down. 

2. In the dialog, optionally use the search field to locate the file, and 
then select the file and click Open. 

The image appears centered on the page currently displayed in the 
document window. In a new, blank document, a page is created and 
the image placed on it. 

Once the image is in PDFpen, it can be moved from one page to anoth-
er by cutting or copying it from its current page and pasting it onto a 
different page. 

Pay Attention to the Selection 
When you paste an image, make sure that the document area of the 
PDFpen window is active rather than a thumbnail in the sidebar. If 
a thumbnail is selected and active (that is, it is highlighted in color), 
pasting creates a new page comprising just the Clipboard contents 
instead of putting those contents on the page shown in the document 
area of the window. 
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Resize and Crop an Image 
It’s rare that an image you insert into a PDF is exactly the right size 
and shape. However, you can resize and crop them painlessly. 

To resize an image, do the following: 

1. With the Edit tool, click the image. 

2. Drag any corner of the image to resize it; hold down Shift as you 
drag to maintain the image’s proportions. 

Cropping an image is not much more difficult: 

1. With the Edit tool, click the image and then choose Edit > Crop 
Image. 

A cropping control panel appears at the bottom of the document 
window and the image is highlighted with its current dimensions 
indicated at the top left and bottom left (Figure 47). A cropping 
rectangle is superimposed on the image. 

Figure 47: This image is on the verge of being cropped. 

2. Drag within the image boundaries to move the cropping rectangle; 
drag from any corner or edge to resize it. 

93
 



           
         

            

    

         

             
        

  

           
            

           
  

    
            

         
   

  

            
   

           
   

    
       

As you move the cropping rectangle, the area outside of the crop-
ping rectangle appears with reduced contrast to highlight the area 
to be cropped, and the size indicators change to reflect the current 
dimensions. 

3. Do one of the following: 

‣ Click Crop to crop the image to the highlighted area. 

‣	 Click Crop and Scale to Fit to crop the image but have the 
cropped image scale to match either the original horizontal 
or vertical dimension. 

If the horizontal dimension of the cropped image is the largest dimen-
sion, the image scales to fit the original horizontal dimension; if the 
vertical dimension is largest, the cropped image scales to fit the origi-
nal vertical dimension. 

Straighten and Adjust an Image 
When an inserted image is slightly skewed or is poorly exposed, you 
can compensate—within limits, of course: PDFpen can work minor 
wonders, but not miracles. 

Follow these steps: 

1. With the Edit tool, click the image and then choose Edit >
 
Deskew and Adjust Image.
 

The Deskew and Adjust controls appear at the bottom of the docu-
ment window (Figure 48). 

Figure 48: The Deskew and Adjust controls can affect the selected 
image or all of the images in the document. 
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2. Drag the Skew slider left or right to adjust the tilt of the image so 
that it appears straight. The Skew slider is limited to about 20 
degrees of adjustment. 

3. Drag the Exposure slider left or right to decrease or increase the 
exposure (brightness) of the image; drag the Contrast slider left or 
right to decrease or increase the image’s contrast. 

4. Click Apply. 

Tip: You can click Apply to Entire Document if all the images in your 
document suffer from the same shortcomings, which might happen if 
they all come from the same source, such as a misadjusted scanner. 

You can make more complex image adjustments as well with PDFpen’s 
Image Edit panel: 

1. With the Edit tool, click the image and choose Edit > Adjust 
Image. 

The Image Edit panel appears with its Adjust tab selected (see
 
Figure 49).
 

Figure 49: The Image Edit panel provides controls similar to those 
found in iPhoto and many other image-editing applications. 
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2. Drag the various sliders to adjust the image’s appearance; if things 
get out of hand, click Reset All and try again. 

3. Close the Image Edit panel or click another tab in the panel to make 
your changes take effect. 

You can apply some preset effects with the Effects tab of the Image 
Edit panel as well, such as blurring the image, applying an “antique” 
effect, and inverting all of the colors to make a color negative of the 
image. The Effects tab displays thumbnails showing the various effects 
so you can preview before you try them. Unlike the controls in the 
Adjust tab, they don’t take effect when you switch tabs: to apply an 
effect, select it and then close the Image Edit window. 

The Image Edit panel’s Details tab displays statistics about the image. 
It has no controls that you can adjust. 

Resample an Image 
When you know that your PDF is going to be reproduced on a black-
and-white printer, or if the size of your PDF file is too large because of 
all the color images in it, you can resample the images to change their 
color depth and resolution. 

To resample an image, click the image with the Edit tool and choose 
Edit > Resample Image. The Resample controls appear at the bottom 
of the document window (Figure 50). 

Figure 50: Reduce the resolution and color depth of an image 
with the Resample controls. 
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Here are the resampling actions you can take: 

•	 Type a different DPI value: Lower values make the image 
appear blurrier but reduce how much storage the image requires. 
(Higher values have no visual effect but increase the storage re-
quirements.) 

•	 Change the compression type: Here’s what the choices on the 
pop-up menu mean: 

‣	 Color JPEG Compression: This is the standard format for color 
PDF image objects in PDFpen. 

‣	 Grayscale: Grayscale will make your image look like a black-and-
white photo. 

‣	 1-Bit Threshold: Every pixel in the image that is more than 50% 
gray is made white and all the others black, creating a silhouette 
effect. 

‣	 1-Bit Dither: Black-and-white dot patterns simulate levels of 
gray; the resulting image has less detail and resembles a low-
resolution fax. 

Note: Grayscale uses less storage space than color, and 1-bit images 
use the least storage. 

•	 Choose a quality percentage: This pop-up menu is available 
only for Color JPEG and Grayscale compression. Generally, the 
higher the quality percentage, the more storage space the image 
requires. Reducing the percentage can make a color or grayscale 
image look dithered or banded, but saves storage space. 

Click Resample to have your settings take effect; click Resample Entire 
Document to apply the settings to every image in the document. 

Tip: Unfortunately, the Resample controls don’t give you a preview 
of how they effect the image, but you can choose Edit > Undo Edit 
Image if the results are not to your liking. 
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Make a Transparent Image 
PDFpen can select a color or color range in an image and “knock it out” 
so that any objects behind the image on the page can be seen through 
the knocked-out holes. This is exactly what you need when you make 
a signature to use on forms (see Add a Scanned Signature), and it is 
useful for decorative purposes, such as for creating a border on a page. 

You can knock out a color range in an image to make it transparent in 
three quick steps: 

1. With the Edit tool, click the image and choose Edit > Make
 
Transparent Image.
 

2. In the dialog that slides down, click the eyedropper on the color you 
want to knock out (Figure 51), and then slide the Tolerance slider 
until the image shows the desired transparency (Figure 52). 

Figure 51: This image is about to have the sky knocked out. 
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Figure 52: Excuse me while I lose the sky... 

3. Click Make Transparent. 

Colors that fall within the range you specified disappear, and anything 
behind the image can be seen through the no-longer-visible parts of 
the picture. 

Tip: When you select an image, shortcut buttons for deskewing,
 
cropping, adjusting, resampling, and making transparent images 

appear in the Edit Bar—if the document window is wide enough to
 

display them.
 

Rearrange, Rotate, and Crop Pages
 

When you create a PDF out of bits and pieces of other PDFs (see 
Combine Existing PDFs), you may want to adjust the pages that you’ve 
brought together. For example, a page may consist of a full-page 
graphic and need to be rotated from landscape to portrait orientation, 
or a range of pages may need to be reordered, or some legal-size pages 
may need to be cut down to letter-size. 

PDFpen can help you with all of those tasks. 
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Rearrange Pages 
The Thumbnail sidebar and your preferred pointing device are the 
tools you need to rearrange pages in a PDF. Follow these steps to move 
a page from one place to another in a PDF: 

1. Choose View > Thumbnails to show the Thumbnail sidebar if it isn’t 
already visible. 

2. Drag the thumbnail of the page you want to move to its new location 
in the sidebar. 

As you drag the thumbnail, a black line appears to the right of each 
thumbnail you pass over, indicating that, were you to drop the dragged 
thumbnail at that moment, the page would be placed at that point. 

Note: To move a page to the very beginning of the PDF, drag to the 
left of the very first thumbnail. 

Tip: You can widen the Thumbnail sidebar to see more thumbnails at 
once, which is helpful when you need to do a lot of page rearranging. 

But suppose you need to move a small group of pages to a new location 
in a very, very long PDF. Dragging could quickly become tedious in 
that situation. The following steps explain how to do big moves over 
long distances in a PDF: 

1. In the Thumbnail sidebar, Shift-click or Command-click to select 
the pages you want to move. 

2. Choose Edit > Cut. 

3. Scroll to the thumbnail of the page after which you want place the 
pages you’ve cut, click it, and then choose Edit > Paste. 

The pages appear following the page you clicked. 

Note: If you need to move a selection containing multiple pages a 
short distance, you can drag them just as you do a single page. 
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Rotate a Page 
When a page doesn’t match the orientation of the others in a PDF 
document, hilarity can ensue when the document is printed. Some 
programs, like PDFpen, can automatically rotate such pages, but not 
everyone (yet) uses PDFpen. A recipient of your PDF might have a 
program that crops the disorientated page to fit when it prints. 

To reorient a disorientated page, follow these steps: 

1. Navigate to the page that is oriented differently from the others. An 
easy way to find such pages is by viewing them in the Thumbnail 
sidebar (Figure 53). 

Figure 53: One of these pages is not like the others. 

2. Click the page and then do one of the following: 

‣	 To rotate the page 90 degrees clockwise, choose View > Rotate 
Right (Command-R). 

‣	 To rotate the page 90 degrees counterclockwise, choose View > 
Rotate Left (Command-Shift-R). 

Which direction depends on your needs (and maybe the direction in 
which your head tilts best), but, in either case, the page is reoriented. 
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Tip: If you plan to edit any text on the page, do so before you rotate 
it. Although you can select and correct text on a rotated page, it can 
be awkward. 

Crop a Page 
As common as 8½-by-11 pages are in the United States, not everyone 
uses pages with those dimensions, and, when it comes to PDFs that are 
to be printed in a book or pamphlet, the page dimensions can differ 
significantly. 

When you have a PDF that must be cut down to size, PDFpen can help: 

1. Navigate to the page you wish to crop. 

2. In the Editing Bar, click the Select Rectangle tool. 

3. On the page, drag to select the proper dimensions. 

As you drag, the current dimensions of the selection rectangle
 
appear along its sides (Figure 54).
 

Figure 54: This page is getting a much-needed trim. 
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Tip: You can change the units used when displaying dimensions— 
say, from typographer’s points to inches—in PDFpen’s Editing 
preferences. 

4. Choose Edit > Crop Page to Selection or click Crop Page to Selection 
on the Editing Bar. 

The page is cropped to the dimensions you chose. 

Tip: Hold down the Option key to change the menu command to Crop 
Document to Selection. This crops every page to the same dimen-
sions and is handy when you want to crop an entire document. 

Insert Page Numbers
 

After you have changed and rearranged the pages in your PDF as 
described elsewhere in this chapter, you may want to put page num-
bers on its pages. PDFpen has a command for that: Edit > Insert Page 
Numbers. This command produces the dialog shown in Figure 55. 

Figure 55: Use this dialog to configure how PDFpen numbers pages. 

Most of the options in the dialog need no explanation, but here are the 
ones that might puzzle you: 

•	 Inside, Outside: These options appear on the Alignment pop-up 
menu and are useful when the PDF will be printed double-sized and 
bound. When you choose Outside, page numbers appear aligned 
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with the right margin on recto pages (pages on the right in bound 
books) and with the left margin on verso pages (the left-hand pages 
in bound books). Inside places the number on the left for recto 
pages and on the right for verso pages. 

Tip: Choose View > Facing Pages when using the Inside or Outside 
settings to see what they do; you can always choose Edit > Undo 
immediately after issuing the Insert Page Numbers command if its 
results are not what you want. 

•	 Bates Numbering: This option, found on the Format pop-up 
menu, is a numbering system often used for legal and business 
purposes. With this kind of numbering, each page of the document 
is given a unique page identifier, for example “Exhibit 5A00034”. 
You supply a prefix for the page number and the number of digits 
to be used for the page number in the two fields that appear. 

The Insert Page Numbers command creates an imprint containing 
a page number on each page of the PDF. The imprint is placed and 
formatted as you have specified. 

Multiple Sections and Page Numbering Tip 
Sometimes a long document might have sections, each with its own 
page numbering. Although PDFpen doesn’t provide that functionality, 
you can work around that relatively easily. Use the techniques de-
scribed in Combine Existing PDFs to make each section into a sepa-
rate PDF document and then use the Insert Page Numbers command 
on each document. Then, simply combine those documents into a 
single document again. 

Create Links
 

Sometimes you want to direct your readers to a different page in a 
PDF, or to a Web page that has useful information. In fact, if you are 
reading this book in PDF form (and many of you are), you have already 
seen, and probably used, some of the links that appear within it. 
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Unlike HTML links, which are attached to text or objects on a Web 
page, PDF links consist of transparent rectangular objects that you 
place on top of some text, an image, or, in fact, any area of the page 
that you want to link to another location. 

As I described in The Markup Tools (←oh, look: a link!), there are two 
tools for creating links: a Page Link tool and a URL Link tool. 

You can move and reshape link objects with the Edit tool. You can 
also change their appearance: by default, PDFpen makes them com-
pletely transparent with no border stroke, but you can change that with 
the object property tools in the Editing Bar (see Draw Attention). You 
may, in fact, want to give link objects a stroke or a semi-transparent fill 
color because, otherwise, they are impossible to see once you have 
created them! 

Tip: To test a link object after you create it, click it with the Select 
Text tool. 

Page Link 

To link to another page in a PDF, do the following: 

1. Choose Tools > Page Link, or, in the Editing Bar, click the markup 
tools	 segment of the tool-selection button and then click the 

tool. 

2. With the Page Link tool, drag a rectangle over the text, image, or 
page region that you want to link to another page in the document. 

3. In the Set Link dialog that appears, enter a page number in the Page 
Number field, and then click OK. 

When you set a page link and then add pages to the document so that 
the page to which you linked moves, the page link still works. For 
example, if you set a link on page 1 to go to page 4, and then you add a 
page between pages 1 and 4 so that page 4 becomes page 5, the link on 
page 1 still works as intended, taking you to page 5. 

Warning! If you manually move a page after you place page links on 
it, its page links are deleted. 
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Note: If you accidentally specify a page in the Set Link dialog that 
does not exist in the document, PDFpen assigns the link to the page 
number of the last page in the document. 

URL Link 

A URL link, when clicked, opens a Web browser (usually the default 
browser on the device displaying the PDF), and loads the Web page 
pointed to by the link. 

You add a URL link that goes to a Web address like this: 

1. Choose Tools > URL Link, or, in the Editing Bar, click the markup 
tools	 segment of the tool-selection button and then click the 

tool. 

2. With the URL Link tool, drag a rectangle over the text, image, or 
page region that you want to link to a Web address. 

3. In the Set Link dialog that appears, enter a Web address in the URL 
field, and then click OK. 

Use Complete URLs 
Partial URLs do not work. For example, if you enter the address 

www.smilesoftware.com into the Set Link dialog, the URL link does 

nothing when you click it. However, http://www.smilesoftware.com
 

does open your browser and load the page at that address.
 

How to Edit Links 
Page links and URL links use the same Set Link dialog. You can
 

change a link object from one kind of link to another by clicking 

either Page or URL in the segmented button near the top of the
 

dialog.
 

You can also change the link destination of any link object: double-


click the link object with the Edit
 tool and enter a new location
 

in the Set Link dialog.
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Make an Interactive PDF 
Form (Pro Feature) 

“You can talk all you want […] But you gotta know the territory!” 
chants a salesman in the first scene of The Music Man. But how do 
you get to know the territory? 

You ask questions, that’s how. 

One way to ask questions is with a form. PDFpenPro has tools for 
making interactive PDF forms. With these tools, you can ask questions 
to get the information you need. And, with the email and Web submis-
sion capabilities that you can build into a form, you don’t have to go 
out to the territory to get that information—it comes to you. 

So, you can talk, you can talk, you can bicker, you can talk, but with 
an interactive form, you can get to know the territory. 

Build a Form
 

A form can be as simple as a single checkbox, or as complicated as 
an IRS Schedule C. But, as you saw in Fill Out PDF Forms, all forms 
consist of only a few simple elements—such as text fields and check-
boxes. You can use these elements repeatedly and in combination. 

I’ve made a form that demonstrates each form element available in 
PDFpenPro (Figure 56). In the following pages, I use my example 
form, “Wizard_Tim.com User Survey,” to explain each form element. 
I started with a new blank one-page PDF (see Create a PDF), but you 
can add form elements to any PDF. 

Tip: If all you need are checkboxes and text fields in your form, you 
can create a form almost automatically; skip ahead to Let PDFpenPro 
Build Your Form. 
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Figure 56: The Wizard Tim needs to know a few things, and he uses 
this form, which contains each form element available in PDFpenPro, 
to learn them. Heck, it’s less work than casting a spell. 

To access form elements, click the Form tools segment, located on the 
right end of the Editing Bar’s tool-selection button. Each 
individual form element has a group of properties you can set in the 
Inspector to name the element and describe how it operates. As we 
proceed, I’ll explain the properties associated with each form element. 
Before we begin this guided tour, though, you may want to refer back 
to The Form Creation Tools (Pro Feature) to refresh your memory. 

One Form per PDF 
Unlike Web pages, which can have multiple forms on a single page, 
you can have only one interactive form in a PDF made by PDFpenPro. 
Another way to think about it is that the PDF is the form. 
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Make a Text Field 
The Name field in Wizard Tim’s form represents that staple of the 
interactive form, the text field. Use a text field when you want free-
form information from your respondents that you can’t anticipate. 

To make a text field, drag it out on the page with the Text Field tool. 

Once you have the field in place, you set its properties in the Form 
Element Properties tab of the Inspector (Figure 57). 

Figure 57: The Inspector shows the properties of a text form field. 

To see a field’s properties, click it with the Edit tool (if you use the 
Select Text tool, PDFpenPro assumes you want to enter information 
into the field). 

Here is some advice for customizing the properties of a text field: 

•	 Name: Every text field should have a distinct name. PDFpenPro 
gives each new field a unique name, but you should change it to 
reflect the type of information the field is for. As you can see by the 
size of the Name field in the Inspector, names are expected to be 
short. 

Note: Good element names are important. When you receive form
 

data from an interactive form, the name of the element labels the
 

data from that element. A short, descriptive name can help you
 

interpret the data you get back more easily.
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•	 Default Value: This property can be empty. If you put text in it, 
that text appears in the form element as its default value, although 
the respondent can change it; if you leave the Default Value blank, 
the element is empty until the respondent fills it in. 

Tip: To check the default value of a form element as you are building 
the form, choose Edit > Reset Form. 

•	 Character Limit: You can enable this property and then specify 
the maximum number of characters the respondent can put in 
the field. For example, you might limit a field for a telephone area 
code in the United States to three characters. When this property 
is disabled, respondents can type only as many characters as will 
fit in the field visibly unless Scroll Text or Size to Fit is enabled (see 
below). 

•	 Required: Select this checkbox if the field must be filled in before 
the form is submitted. Most programs that allow respondents to fill 
out PDF forms display an error dialog if a required field is empty 
when the respondent submits it. 

•	 Multi-line: When this property is enabled, text typed in the field 
can wrap when the text reaches the edge of the field. 

•	 Size to Fit or Scroll Text: If you select one of these boxes and the 
other is already selected, the other is automatically deselected: 

‣	 Select Size to Fit if you want text the user enters scaled in size so 
that it fills the field. The text that the respondent types becomes 
smaller once the field’s boundaries are reached. 

‣	 Select Scroll Text to allow text to scroll beyond the borders of the 
field. 

Note: Both Size to Fit and Scroll Text can be deselected. In that 
case, the field can contain only as much text as can fit within its 
borders at the field’s default text size. 
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Offer a Single Choice 
A choice element allows the respondent to choose one item from a 
set of items. In PDFpenPro a choice element resembles a drop-down 
menu, such as the Quest item shown in the survey (Figure 56, a few 
pages back), although other PDF programs may display a choice 
element quite differently. A choice element can optionally allow the 
respondent to type in an item that isn’t among those provided. 

To place a choice element on the page, drag with the Choice tool. 

Note: You can drag a rectangle as tall and as wide as you like when 
placing a choice element, but the visual components of the element 
have a fixed height, so any extra space above or below it on the page 
is wasted space on the form. 

Use a choice element when you have several mutually exclusive choices 
to offer and a limited amount of room in which to present them. 
Figure 58 shows the properties associated with the choice element. 

Figure 58: You can add and remove choice element properties. 
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You can modify these choice element properties: 

•	 Name: Each choice element requires a unique name. As with the 
text-field element, enter a short descriptive name so you can identi-
fy the data when it is returned. 

•	 Required: Enable this property if the respondent must make a 
choice before submitting the form. 

•	 Custom Text: Select this to allow the respondent to type in a 
choice that doesn’t appear among those that you have provided. 
A choice element that allows custom text shows a text cursor when 
the respondent clicks the body of the element; the respondent must 
click the arrow controls at the right of the element to display the 
choices you have offered. 

•	 Name-Value box: Recall that a choice element offers the user 
a list of choices. Name-Value pairs supply those choices. Click the 
add button to add an empty Name-Value pair, and then click the 
selected pair in the list box to add a name and a value. The name is 
what the user sees and can choose in the choice element; the value 
is the data returned when the form is submitted. For example, in 
the choice element whose properties are shown in Figure 58, 
earlier, if the respondent chooses To Storm the Castle Anthrax, the 
form will return the value of Castle. 

If you don’t supply a value, the name is returned. In such cases, you 
may want to use short names. 

To remove a Name-Value pair, select it and then click the remove 
button. 

Make Checkboxes 
The data from checkboxes is returned only when the respondent 
checks a box on the form; you never receive data from unchecked 
boxes. 

You use checkboxes to provide a respondent with what amounts to a 
true-false question. For example, in Wizard Tim’s survey (Figure 56, 
back a few pages), the Knights checkboxes allow the user to answer 
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the implied question “Is this knight accompanying you?” for each listed 
knight (Brave Sir Robin must have turned his tail and bravely fled 
when the form was filled out). 

Click with the Check Box tool to create both a default-size checkbox 
and a label (a text imprint) for it. Or, you can instead drag with the 
Check Box tool to create a checkbox that has a custom size. To edit 
the label text, use the Select Text tool. 

You can customize the following checkbox properties (Figure 59): 

Figure 59: Checkboxes return a value only when checked. 

•	 Name: Each checkbox should have a unique name; if two or more 
checkboxes have the same name, they behave like radio buttons (see 
the section about radio buttons, just after this list), which violates 
normal user-interface conventions and can confuse the respondent. 
The best practice is to use the same name as the one in the checkbox 
label, or a shortened version of it. 

•	 Checked Value: By default, the value returned from a checked 
checkbox is TRUE, but you can use a different value if you have a 
special need. 

•	 Required: Enable this property if the respondent must check 
the checkbox before submitting the form. Unless you are using 
the checkbox like a radio button, you should leave this property 
disabled. 

•	 Check by Default: Enable this property to have the checkbox 
checked when the form is first opened or when it is reset. 
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Offer Radio Button Choices
 

In Wizard Tim’s survey (Figure 56, shown near the start of this 
chapter), the Favorite Colors are presented as radio buttons. Radio 
buttons offer a small set of mutually exclusive choices. When the user 
clicks a radio button in a group, the other buttons in the group are 
deselected. It’s good user-interface practice to restrict the number of 
radio buttons in a group to five items or fewer. 

Click with the Radio Button tool to create both a default-size radio 
button and a text imprint label. You can drag with the tool to create a 
radio button that has a custom size. 

When you add a radio-button group, you should add an additional text 
imprint with the Text tool to label the entire group, as Wizard Tim 
does in his survey. You can use that label, or a shortened form of it, 
as the Name property for each of the radio buttons in the group. For 
example, the name of the three Favorite Color buttons in Wizard Tim’s 
survey is Color (Figure 60). 

Figure 60: All radio buttons in a group share the same
 
Name property but have different Checked Value properties.
 

You need to set at least the first two of these radio-button properties: 

•	 Name: Each radio button in a button group should share the same 
name so that clicking one deselects the others that share that name. 

•	 Checked Value: The best practice is to use a short version of the 
text that labels the individual button. If the form is submitted with 
this radio button selected, the name assigned to the button group 
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will return the value in this field. Although all buttons in a group 
should have the same Name property, they should each have a 
different Checked Value property. 

•	 Required: Enable this property if the respondent must select one 
of the buttons in the radio-button group before submitting the form. 
If you enable this property for one button in the group, you should 
enable it for all buttons in the group, since they are treated as a unit. 

•	 Check by Default: Enable this property to have the button appear 
selected when the form is first opened or reset. You should set this 
property for only one button in the group, because, by convention, 
no more than one radio button in a group can be selected at a time. 

Make a List 
You use a list element to display a list of items from which the respon-
dent can choose. Wizard Tim uses a list element to list the supplies 
that the respondent possesses in the survey form shown near the 
beginning of this chapter (Figure 56). 

A list can allow the respondent to select only one item, or it can allow 
the respondent to select multiple items by Shift-clicking a range of 
adjacent items, or by Command-clicking non-contiguous items 
(Windows users can Control-click to choose non-contiguous items). 
Wizard Tim’s list allows multiple items to be selected. 

Use the List tool to drag a rectangle out on the page. If the number 
of items is longer than can be displayed within the list’s area, the 
respondent can scroll through the list. 
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You can set the following properties for a list element (Figure 61):
 

Figure 61: List element properties resemble choice element 

properties, but you can select more than one choice.
 

• Name: Each list element requires a unique name. 

•	 Required: Enable this property if the respondent must select at 
least one item before submitting the form. 

•	 Select Multiple: Enable this to allow the respondent to choose 
more than one item in the list. 

•	 Name-Value box: I explain this box in more detail a few pages 
earlier where I describe the choice element. As with a choice ele-
ment, you use Name-Value pairs to supply the list element with 
content. The add button and the remove button work the same 
way as they do in a choice element’s properties. And, like choice 
elements, if you don’t supply a value in a Name-Value pair, the 
name is returned. 

Make an Interactive Signature 
An interactive signature allows respondents to sign an interactive form 
by hand. When respondents click the field, a dialog appears in which 
they can scribble their signatures using a trackpad, stylus, or similar 
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pointing device (they can even use a mouse or a trackball if they are 
sufficiently dexterous)—or they can drag a signature graphic (see Add a 
Scanned Signature) directly into the interactive signature dialog, as in 
Figure 62. 

Figure 62: Sign an interactive signature field with your finger, or 
drag a graphic into the field’s dialog. 

To create an interactive signature field, drag out a rectangular area 
on the form with the Signature Field tool. The field has markers at 
each corner to indicate the field’s dimensions, and it includes a graphic 
“Sign Here” stamp. When the respondent signs the field, the stamp 
goes away and the signature appears within the field’s boundaries. The 
submitted form includes the signature graphic. 

The Inspector provides no properties that you can set for interactive 
signature fields. However, you can set the color of the signature and 
the thickness of the signature stroke with the two controls
the bottom-left of the signature field dialog. 
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Make a Submit Button 
Respondents use a submit button to send the information on the form, 
and, optionally, the form itself back to the form’s originator; e.g., you. 
The Wizard Tim’s survey shown near the beginning of this chapter 
(Figure 56) has such a button at the bottom, but you can put it 
anywhere you like. 

Tip: In fact, you can have multiple submit buttons in the same PDF,
 
and each can be designed to send the form content to a unique
 

destination, which could be useful for allowing the user to choose
 

which of several people should receive the form content.
 

With the Submit Button tool, click the page to create a default-size 
submit button or drag to create a button with a custom size. 
PDFpenPro displays a dialog with submission options (Figure 63). 
Use the options to specify the destination for the form’s data. 

Figure 63: Send the form’s data to either an email address or 
a Web address. The Web address should point to a script that 
can process the form’s data, as the built-in example implies. 

The form can be set up to submit data by email to a specific address or 
via the Web to a specific URL: 

•	 In the case of email, you can choose whether the PDF is included; 
the XFDF form is always attached (XFDF is a forms data XML 
format, the full name of which is XML Forms Data Format). The 
message is sent with the respondent’s default email program. 
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• When a form submits data to a URL, it is sent as XFDF data.
 

Note: You can find out more about XFDF from Adobe, which curates 
the format. 

If you later want to edit the submission options, double-click the 
submit button with the Edit tool, or access the submission options 
in the button’s form element properties in the Inspector (Figure 64). 

Figure 64: The submit-button element’s properties include 
a name, a label, and the submission options. 

Aside from the submission options, the other properties you can set 
are minimal: 

•	 Name: Like any other form element, the submit button needs a 
name. It should be a unique name within the document. 

•	 Label: Enter the text you want seen on the button. 

About Forms Processing 
You can find scripts for processing form data, and get additional 
information, at Smile’s Web site. In addition, I suggest you consult 
the advanced topic in PDFpenPro’s Help, “Backend Processing of PDF 
Forms.” 

Also, you can use the Export Form Data script that comes with
 

PDFpen to see the values that are returned from a form (see The
 

Scripts).
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Let PDFpenPro Build Your Form 
Very often, all you need on a form are text fields and checkboxes; this 
is especially true of forms that are designed to be printed and filled out 
by hand but that could also be filled out on screen. PDFpenPro’s Create 
Form Fields command is perfect for such forms. 

For example, consider the word processing document shown in 
Figure 65, a job application that contains only lines and checkboxes. 
It can be saved as a PDF (see Print to PDF) and brought into 
PDFpenPro, where the static form elements can be brought to life. 

Figure 65: Start with a form created in a word processor (in this 
case, Apple’s Pages) and saved as a PDF. 

To turn the static form elements on the current page into interactive 
elements, choose Edit > Create Form Fields for Page. 

Tip: To turn static form elements into interactive ones throughout 
a multipage document, hold down Option and choose Edit > Create 
Form Fields for Document. 
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Figure 66 shows the result of running the Create Form Fields for 
Page command on the PDF created from the document in Figure 65. 

Figure 66: This is a portion of the “automagically” created 

form, along with the Inspector showing the details for one of
 
the form elements.
 

PDFpenPro examines the PDF for line and box elements and uses 
those to generate interactive form elements that overlay the static 
ones found in the PDF. PDFpenPro proceeds from left to right and 
top to bottom so that in most cases the tab order for the created 
elements matches what most users will expect, but if it doesn’t produce 
the tab order you want, you can change it (see Set the Tab Order). 

In addition, PDFpenPro turns on highlighting of form fields when it 
creates a form automatically so that the newly created elements are 
immediately obvious. You can turn form highlighting on and off by 
choosing View > Highlight Form Fields; this command works with 
forms that you create by hand and with automatically generated forms. 

Tip: You can mix things up, too: begin by using a word processor 
to give you a running start when creating a form, generate the initial 
form elements automatically with PDFpenPro, and then add any 
additional form elements you need with the PDFpenPro form tools. 
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Polish the Layout
 

It’s not hard to slap a bunch of form elements on a page, but you’ll get 
more responses and better ones if you design the form so that it is easy 
to read and use. At the very least, you should align the elements neatly 
and label them so that the respondent can see which elements go 
together, and so that they can figure out what information is actually 
being requested. The controls on the Inspector’s Alignment tab can 
help you align form elements (see The Inspector). 

Use a Grid 
To further help you precisely line up form elements, labels, and any 
other explanatory text, you can turn on a grid overlay and specify that 
new items, and dragged items, should snap to that grid (Figure 67). 

Figure 67: The grid is visible behind this application form. 

To turn on the grid and have items snap to it, do the following: 

1. Choose Arrange > Show Grid. 

2. Choose Arrange > Snap to Grid. 

Set the Tab Order 
You should also consider that people with keyboards often prefer to 
navigate without having to resort to a pointing device. PDFpenPro 
creates a tabbing order for form elements automatically. The person 
filling out the form can press the Tab key to “tab” from one form 
element to the next without reaching for a pointing device. 

122
 



              

               
       

     

         
           

 

      

         
   

         
   

            
 

            
 

          

The tab order by default follows the way you read English: left to right, 
top to bottom. 

You can see the tab order, change it, and, if necessary, reset it so it 
follows the left-to-right, top-to-bottom convention again, with the 
following commands on the Arrange menu: 

•	 Show Tab Order: Small number boxes are superimposed on each 
element (Figure 68) so you can see the order in which you can tab 
through them. 

Figure 68: Display the tab order to see where tabbing takes you. 

•	 Move Forward: Increase the selected element’s position in the 
tabbing order by one. 

•	 Move Backward: Decrease the selected element’s position in the 
tabbing order by one. 

•	 Move to Front: Make the selected element the final one in the 
tabbing order. 

•	 Move to Back: Make the selected element the first one in the tab-
bing order. 

•	 Reset Tab Order: Set the tab order to follow English reading 
convention. 
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Publish Your PDFs 
A PDF that’s on your hard drive only is a lonely thing: it wants to go 
out into the world and meet people. It was born to go out into the 
world. If you love your PDFs, let them go. 

You can make your PDFs public (because that’s what “publish” means 
in the broadest sense) in many ways, including: 

• Emailing them
 

• Posting them on the Web
 

• Printing them on your printer
 

• Sending them to a professional print service
 

• Sending them to your publisher as camera-ready copy
 

With the exception of printing them on your printer, all of these start
 
with saving or exporting your PDF in one way or another.
 

So let’s start there, too.
 

Save or Export Your PDFs
 

When you create or modify a PDF with PDFpen, sooner or later you 
are going to save it. You may not notice that you are saving it: saving is, 
by default, automatic in PDFpen. That is, you can create a new PDF in 
PDFpen, edit it, quit PDFpen, and when you open PDFpen again, the 
untitled-but-edited document reappears even though you never explic-
itly saved it (unless you’ve enabled Ask to Keep Changes When Closing 
Documents in System Preferences > General). 

Nonetheless, just because PDFpen saves documents automatically 
doesn’t mean that the traditional command, File > Save, has gone 
missing. It’s still around, and it is key to some saving options. 
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Here’s a brief summary of how saving works in relation to auto-save:
 

•	 Closing a new untitled document: When you attempt to close 
a new PDF you’ve made with PDFpen, you are asked to name the 
document, choose a location for it, and set some saving options 
(which I describe in just a little bit). 

•	 Saving a new document: When you choose File > Save 
(Command-S), you get to name the document, specify where it gets 
saved, and set the options I describe below. 

•	 Saving a previously saved document: When you choose File > 
Save (Command-S), PDFpen saves the document as a separate 
version to which you can later revert. No dialog or options are 
presented. To go back to a previous version of the document, use 
File > Revert To and choose the version you want. 

•	 Using Save As with a previously saved document: To save 
a copy of the document with a new name and in a location of your 
choice, use the File > Save As command (Command-Shift-Option-
S): to access the command, hold down the Option key as you open 
the File menu. You also get to set your saving options, described just 
ahead. When you complete this command, PDFpen saves and closes 
the current document and creates a copy, with its new name, for you 
to keep working on. 

•	 Using Duplicate with any document: Choose File > Duplicate 
(Command-Shift-S) to create and open an untitled document with 
the same content as the one on which you were working; the origi-
nal document remains open. Closing the duplicate elicits the same 
Save dialog that you see when you close a new untitled document. 

No matter how you reach a Save dialog, the options it presents are 
these: 

•	 Encryption: You can secure your PDF at one of several levels 
of encryption so it can’t be casually opened. See Save Securely for 
more about this capability, as well as its limits. 

•	 Quartz Filters: You can apply a Quartz filter as you save (if you 
don’t know what a Quartz filter is, read Save with Quartz Filters). 
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In addition to saving, you can export your PDF to different formats, 
using the File > Export command in PDFpen and PDFpenPro: 

•	 Images: You can export every page in the PDF to a multi-page 
TIFF document in one of several resolutions (see Export as TIFF). 

•	 Microsoft Word: This export option converts your PDF into a 
standard old-style Word document (.doc file) or a more modern 
Word document format (.docx). See Export to Microsoft Formats. 

•	 Plain Text and Rich Text: These options export only the textual 
contents of a PDF. Plain Text strips off all formatting; Rich Text 
retains characteristics like size, typeface, and typestyle. 

Users of PDFpenPro can export documents in these additional 
formats: 

•	 Microsoft Excel and Microsoft PowerPoint: These two export 
options require an Internet connection and a fully licensed copy of 
PDFpenPro. See Export to Microsoft Formats for details. 

•	 PDF/A: This PDF format is optimized for archival storage, and 
requires that PDF documents embed all the components, such as 
fonts, necessary to faithfully reproduce them. The Wikipedia article 
on PDF/A describes it more completely; PDFpenPro currently 
exports into the PDF/A-1b version of the archive format. Note that 
PDF/A export requires an Internet connection and a licensed 
version of PDFpenPro. 

Finally, you can save your PDFs from PDFpen by printing them; see 
Save with the Print Dialog. 

Save to Evernote 
PDFpen has yet another alternative Save command, one that you
 

might not be familiar with: File > Save to Evernote. Evernote is 

a cloud-based service that stores notes, photos, and documents,
 
including PDFs. If you use this service, the Save to Evernote feature
 

is very convenient; login to the service at this URL to enable the
 

capability and to find out more: https://www.evernote.com/
 

Registration.action?code=pdfpen.
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Export as TIFF 
TIFF, the aged and venerable Tagged Image File Format, has been a 
standard for over a hundred years—on the planet Mercury, that is; on 
Earth it’s been around for about a quarter of a century. As you proba-
bly already know, TIFF is widely used as a standardized way of storing 
image files that almost any image application worthy of the name can 
open. 

What you may not know is that TIFF can store multi-page documents, 
in which each “page” is a TIFF image. If you need to convert your 
document to an image, or set of images, this option is what you need. 

There are a few drawbacks to exporting a PDF as a TIFF, however: 

•	 TIFFs are not text: When you save a PDF as a TIFF, you can 
no longer select its text to copy or edit it. That’s because the text 
becomes just a picture of text. As with any image, you would need 
to perform OCR if you want to convert the picture of text into 
editable text again. Needless to say, PDF features like notes and 
tables of contents don’t survive the TIFF conversion either. 

•	 TIFFs are bulky: Text, even text stored in a PDF along with its 
font information, is almost always much more compact than full-
page images. For example, a 27-page plain-text typescript I happen 
to have on hand makes a 74 KB PDF file, but a 170 MB uncom-
pressed TIFF file. Even a compressed TIFF file of that manuscript 
requires 7 MB: nearly 100 times the size of the PDF version. 

•	 TIFF has size limits: The TIFF standard supports a maximum 
file size of 4 GB. While that might seem like a lot, remember what 
you just read above—TIFF files are bulky. It is quite possible to 
reach this limit when saving a book-length PDF as a TIFF file. 

•	 Multi-page TIFFs are unusual: Not all software that can display 
a TIFF knows what to do with multiple images within a single TIFF 
file. That may cause confusion and consternation for recipients. 
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PDFpen offers three TIFF options under the Export To pop-up menu 
in the Export dialog when you choose File > Export: 

•	 TIFF (Print, 300 dpi): Use this when you need to send a docu-
ment to a print service, and the print service wants to deal only with 
plain unadorned image files and doesn’t want to hassle with fonts 
and all the other stuff that can make printing other people’s files 
so much excruciating fun. A resolution of 300 dpi isn’t all that high, 
of course—modern home laser printers snicker at it, and it’s an even 
lower resolution than that of the iPhone Retina display—but it’s 
high enough that all but the most eagle-eyed will find it nice and 
sharp. 

•	 TIFF (Fax, 200 dpi): Use this when fax quality is good enough. 
If you need to send a document via fax, this is the perfect format 
to store it in: most fax modem software and online fax services can 
handle TIFF files. 

•	 TIFF (Web, 72 dpi): This choice produces the most compact TIFF 
files, and is quite good enough for viewing online. Just don’t expect 
to magnify a page beyond its normal size without seeing lots of fuzzy 
pixels. 

Export to Microsoft Formats 
Yes, as Edit a PDF makes abundantly clear, PDFpen is fully capable 
of editing PDFs. However, you’ll never confuse PDFpen for a word 
processor, nor are PDFs, as you learned way back in Learn about PDF 
Files, designed with editing in mind. Nonetheless, sometimes a PDF 
needs more extensive editing than is feasible in PDFpen. Or maybe 
you need to extract the contents of a PDF to use in a word processing 
document, spreadsheet, or presentation. 

When you choose File > Export, the Export To menu in the dialog 
offers two Word file format choices. If you use PDFpenPro, you also 
see three other Microsoft format choices: two for Microsoft Excel, and 
one for PowerPoint. 
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Here’s what the choices mean: 

•	 Word 2007 Document (DOCX) and Word Document 
(DOC): Choose the first of these if you plan to edit the document 
with a recent version of Microsoft Word; choose the second to edit 
it with an older version of Microsoft Word, or to send the file to 
others but don’t know what versions of Word they have. Note that 
you can edit documents in either Word format with Apple’s Pages, 
though Smile recommends the Word 2007 format for best results. 

•	 Excel 2007 Spreadsheet (XLSX) and Excel Sheet (XLS): 
Similar to the Word formats, the first of these is for more recent 
versions of Excel and the second for older versions. Excel export 
is intended for documents that consist primarily of spreadsheet-like 
data; that is, rows and columns of text and numbers. Smile recom-
mends using the Excel 2007 Spreadsheet (XLSX) format if you 
intend to open the exported document with Apple’s Numbers app. 

•	 PowerPoint 2007 Presentation (PPTX): This format works 
best for PDFs that consist of landscape-oriented pages each con-
taining a few items in large type, and with a background image or 
color. The exported files can also be opened in Apple’s Keynote app. 

Note: Smile provides more details about PDFpen’s and PDFpenPro’s 

Microsoft format exports on its Word Export page, along with exam-
ples and tips for using the export options.
 

The Microsoft export options require an Internet connection: PDFpen 
securely transmits your PDF to the Nuance OmniPage Cloud 
Document Conversion Service for conversion. Depending on the size 
of the PDF to be converted, this can take only a few seconds or several 
minutes. PDFpen presents a dialog showing how long it estimates the 
conversion will take. Although you can work on other PDFs in PDFpen 
while conversion is occurring, you cannot work on the document being 
converted until the process concludes. 

Note that the conversion service, while quite good, is not perfect: 
between the complex internal structure that PDFs can have, and the 
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ways in which the Microsoft apps lay out their documents, you proba-
bly won’t end up with an exported document that looks exactly like the 
original PDF. Nonetheless, the results are usually remarkably good. 

Is Submitting PDFs to an Outside Service Safe? 
In this case, the answer is “pretty safe”—the conversion service uses 
a secure connection for transmitting and receiving files, deletes its 
copy of the PDF as soon as the conversion is complete, and retains 
the converted copy for only 12 hours. The service is also used by 
many legal firms, and you know how picky lawyers can be. 

Save Securely 
The PDF standard supports file encryption that you unlock using a 
password as the decryption key. This user password, in theory, pre-
vents anyone without the password from opening the PDF. In practice, 
of course, PDF encryption can be cracked by those with the right tools 
and the determination. Nonetheless it’s still worthwhile to apply a user 
password to a PDF that you don’t want just anyone to be able to open. 

In PDFpen’s Save dialog, you can choose a level of encryption ranging 
from None to Strongest. This last, obviously, is the hardest to crack, 
but is also the least compatible with older PDF-viewing software. 

If you choose an encryption level higher than None, you then give the 
file a user password (twice, for verification purposes). From that point 
on, each time you try to open the file, you must provide the password— 
but more to the point, anyone else who tries to open the PDF file must 
enter it, too. (The topic of how best to share a password for gaining 
access to sensitive documents is beyond the scope of this book.) 

Warning! Choose a good password. A 2- or 3-character password 
is easy to crack; a 16-character password with upper- and lowercase 
letters, symbols, and numbers is much more difficult. Not that the 
NSA might not be able to crack it, given time, but it should be good 
enough for all but the most security-minded users. Just don’t forget 
it, or you are out of luck! (For much more about passwords, check 
out Joe Kissell’s Take Control of Your Passwords.) 
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Protect Your PDFs (Pro Feature) 
The PDF standard offers permission controls that can, for example, 
restrict users from printing or editing a PDF. The standard version 
of PDFpen respects the permission controls on PDFs that it opens, 
but it provides no capability to apply them to new PDFs. However, 
PDFpenPro has an Inspector pane (Figure 69) that does allow you 
to apply permission controls to a PDF; these permissions can be 
overridden only by supplying an owner password (as distinct from 
the encryption-related user password described just previously). 

Figure 69: You can set any combination of these permissions. 

For example, if you set a PDF’s permissions to prohibit printing, 
others can still open your PDF, but when they try to print it, they’ll 
first have to enter the owner password—without it, they can only 
view it onscreen. 

Alas, just about every lock has a locksmith, and you can readily find 
programs for sale that can strip permission restrictions from a PDF 
blithely. However, just because someone can smash in a locked door 
is no reason to prop the door open: if you need to set up ground 
rules for how a given PDF is to be used, the Document Permissions 
feature in PDFpenPro gives you that capability. 
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Save with Quartz Filters 
Quartz is the name Apple uses for one of the key graphics services 
of OS X. Quartz has several separate components for different purpos-
es—onscreen compositing of animation, for example—but the Quartz 
2D component is tailor-made for dealing with PDFs. In fact, Quartz 
itself was originally based upon PDF. 

Because of the close relationship between PDF and Quartz, developers 
can create filters that modify the look or structure of a PDF document 
in various ways. I won’t detail all of the available Quartz filters as 
there’s no telling which ones you have on your Mac (anyone can make 
a Quartz filter with the ColorSync utility that comes with OS X). 

However, here are a few standard ones that you might find useful: 

•	 Black & White: This filter removes all color information, leaving 
you with a grayscale document in one simple step. You might use 
it if your document will be printed on a grayscale device. See Re-
sample an Image for more about grayscale. 

•	 Reduce File Size: This reduces the quality of all images in the file 
to medium-quality JPEG. If you need a smaller file more than you 
need highest quality images, use this filter. 

•	 Create Generic PDFX-3 Document: PDF/X is a subset of the 
PDF specification, designed to facilitate the use of PDFs in pre-print 
environments. Among other things, the format specifies that the 
document must embed all of the fonts that are used within the 
document. (If you want to know more about PDF/X and its reason 
for being, you can start with the summary by Laurens Leurs.) 

I encourage you to explore the Quartz filters—on copies of files, of 
course: never, ever experiment with originals! 

Warning! Although Quartz and PDF are closely related, saving a file 
with a Quartz filter can result in some data loss. In particular, if you 
have a table of contents in your PDF, a Quartz filter discards it. Also, 
you can’t save a file with a Quartz filter and secure the file with a 
password at the same time. 
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Save with the Print Dialog 
There’s one somewhat unusual way to save your PDF that doesn’t 
involve a Save command on the File menu: you can choose File > Print, 
and then click the PDF button at the lower left of the Print dialog. This 
button pops-up a menu of PDF-related choices (Figure 70). 

Figure 70: The Print dialog provides many choices under the
 
PDF button.
 

The menu shown in Figure 70, above, almost certainly doesn’t look 
like yours beyond the first three standard items. The other items are 
workflows, automated tasks you can create with Automator, a stan-
dard part of OS X. 

Tip: You don’t need to use the Mail PDF workflow in the Print dialog’s 
PDF menu to email a PDF from PDFpen. Instead, you can choose 
File > Mail Document to attach your PDF to an email message in your 
default email program. 

Warning! Saving a PDF with a workflow strips annotations and tables 
of contents from the PDF. 
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Workflows can end up in this menu in several ways. One way is when 
you run an application that installs its own workflows; another way is 
for you to run an installer that adds them. 

The Open with PDFpen workflow, for example, can be installed with 
the free Install PDFpen Workflow app that you can download from 
Smile. Once you’ve installed the workflow, it’s available from the 
Print dialog’s PDF menu in other programs on your Mac. Building 
a Numbers spreadsheet that you want to turn into a PDF and modify 
with PDFpen? Print the spreadsheet and choose Open in PDFpen from 
the PDF menu: in seconds your spreadsheet is in PDFpen, available 
for editing. 

Where Are Workflows Stored? 
The workflows that appear on the PDF menu are stored in one of two 
locations. One location is in your Home folder’s Library: ~/Library/ 
PDF Services/. That’s where the Install PDFpen Workflow app puts 
its workflows. The other is /Library/PDF Services/. 

As always when it comes to a Library folder—either your Home 
folder’s Library or the main Library for your Mac—don’t mess directly 
with the files in it unless you know what you’re doing. Really, I mean 
it. I’m watching you. 

As the final item on the menu, Edit Menu, might lead you to think, you 
can create your own workflows and add them to this menu. Automator 
has a special template for creating PDF workflows that appear in the 
Print dialog: Print Plugin. This workflow receives PDF files from the 
print system and performs the Automator actions on it that you 
specify. Automator has more than a dozen actions designed to act upon 
PDFs. 

When you choose the Edit Menu command on the PDF menu, you see 
the dialog shown in Figure 71. Use this dialog to add any Automator 
workflows that you create to the PDF menu. You can also use it to 
remove any workflows you don’t want. 
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Figure 71: Add or remove workflows from the PDF menu in the Print 
dialog here. Choose Edit Menu from the PDF menu to bring it up. 

Print Your PDFs
 

Earlier in this book, in Print Notes and Comments, I described the 
note- and comment-related print options PDFpen offers. Figure 72 
shows all the PDFpen options in the Print dialog (you may have to click 
a Show Details button in the dialog to reveal them). 

Figure 72: In PDFpen, choose File > Print to access these options. 

Most of these options require no explanation, or I’ve already described 
them elsewhere (for example, Automatically Adjust Printing 
Orientation for Best Fit comes up in Rotate a Page). But Print Imprints 
Only deserves a little discussion. 
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In Fill Out a Non-interactive Form I described how to place text and 
images (such as check marks and signatures) on a form in a PDF. The 
text and images you create to do that are imprints (recall that any text 
objects, graphic objects, or images you add to a PDF with PDFpen are 
imprints). If, for some reason, you need to print that information on 
a pre-printed form (for example, the form may include a watermark 
or other security features), you can load that pre-printed form in your 
printer and use the Print Imprints Only feature to have PDFpen print 
only the imprints contained in the PDF file. A specialized feature, I’ll 
grant you, but for those who need it, a very useful one. 

Tip: You might also find the Append Annotations Summary option 
useful. When it’s checked, PDFpen adds one or more pages to the 
printed output with a list of all the annotations and imprints you have 
added to the PDF, including each imprint PDFpen creates when you 
correct text in the PDF. 

136
 



              
              
           

          
           
 

             
       

         
        
            

       

         
           

              
          

            
         

             

   

             
           

           
         

          
           

            
         

Use PDFpen in iOS 
If you’ve read the rest of this book, you should have a pretty good 
idea of what PDFpen can do on a Mac. You’ll be pleased to know 
that PDFpen for iPad & iPhone provides most of the same PDF-
manipulating capabilities as its Mac sibling. However, the first time 
you open PDFpen for iPad & iPhone, you’re likely to say, “Hmm… 
this looks…different!” 

Of course it does. Any app rebuilt for a mobile device you control 
with your fingertips—instead of with a traditional pointing device 
and keyboard combination—can’t help but undergo a sea change 
into something rich and strange. Nonetheless, the rich and strange 
app you see really is PDFpen. After a few minutes with it you’ll 
recognize your old friend in its new guise. 

Much of what I’ve said about PDFpen’s tools and capabilities else-
where also applies to PDFpen in iOS, and throughout this chapter 
I refer you to the relevant sections of this book for those details. This 
chapter addresses the two most common concerns that people have 
upon first diving into the strange richness of PDFpen for iPad & 
iPhone: where to find tools and commands (discussed just below) 
and the myriad ways to Get PDFs in and out of PDFpen in iOS. 

Find Tools and Commands
 

Because screen real estate is limited on iPads, and even more so on 
iPhones and iPod touches, you won’t see an ever-present toolbar or 
Editing Bar in PDFpen for iPad & iPhone. Instead, these both come 
and go depending on whether you need them or not. 

Take the toolbar: although PDFpen for iPad & iPhone displays its 
toolbar (Figure 73) when you open a PDF, just tap the screen and 
it goes away. It remains hidden as you page through the PDF so 
you can see as much of the document as possible. 
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To bring the toolbar back, tap the screen again.
 

Figure 73: The toolbar in PDFpen for iPad & iPhone hides when 
you don’t need it (top, the iPad toolbar; bottom, the more compact 
iPhone version). 

Similarly, the Editing Bar, and, for that matter, all the other controls 
and options in PDFpen for iPad & iPhone, show up when you need 
them and go away when you don’t. 

In addition, the multi-touch interface in PDFpen for iPad & iPhone 
provides some gestures that affect the way you interact with docu-
ments and objects: 

•	 Zooming: Instead of a View menu, you use the standard pinch and 
reverse pinch gestures to zoom in and out. Also, a quick double-tap 
on a zoomed-in page zooms out to show the whole page. 

•	 Selecting: Instead of clicking an object to select it, you tap it. To 
select text, you touch and hold a word briefly until it is selected, and 
then drag the selection controls to extend or reduce the selection. 

•	 Scrolling: Rather than use scroll bars or page-up and page-down 
keys to go from page to page, you swipe left to go to the next page in 
a document and right to go to the previous page. 

With those general tips out of the way, read on to find out where 
PDFpen for iPad & iPhone has stashed its tools and commands. 

Navigation Tools 
You can find the navigation tools on the left side of the toolbar (see 
Figure 74). 

Figure 74: The navigation tools live on the left side of the toolbar 
in PDFpen. 
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Here’s a brief description of what these tools provide: 

• Back : Tap this button to save the current document and return 
to the Document Manager screen. Read the next section, Get PDFs 
in and out of PDFpen in iOS, for more about accessing documents. 

• Undo : Use this button to undo the most recently performed 
change. You can tap multiple times to undo a series of recent 
changes. Why is this classed as a navigation button? It makes sense 
if you think of it as providing a way to travel back through time. 

• Show Sidebar and Hide Sidebar : These buttons appear 
only on the iPad. Tap Show Sidebar to reveal The Sidebar, with 
its thumbnails that you can tap to move quickly through a docu-
ment. Tap Hide Sidebar to dismiss it. Though you don’t have 
these buttons on the iPhone, you do have a sidebar—swipe right 
from just beyond the left edge of the screen to show it and drag the 
sidebar to the left to hide it (these gestures also work on the iPad). 

• Thumbnails : Tap this to see thumbnails, with page numbers, of 
the pages that comprise your entire document. The Thumbnail view 
is powerful; I describe it next. 

Thumbnail View 
At its simplest, the Thumbnail view (Figure 75) is an easy way to get 
to any page in your PDF quickly: just tap the thumbnail of the page you 
wish to view. 

Figure 75: Tap a thumbnail in Thumbnail view to go to that page. 
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However, its power is revealed when you tap Edit to see its various 
editing options appear in the toolbar (Figure 76). 

Figure 76: The Thumbnail view editing options give you control over 
the pages in your PDF. 

With the editing options visible, you can select one or more thumbnails 
by tapping them, and then drag selected pages to move them in the 
document. You can also do the following with selected thumbnails: 

• Delete pages: Tap the Delete icon to remove the thumbnails 
you have selected and the pages they represent; you have to confirm 
the deletion. 

•	 Rotate pages: By tapping the appropriate icon you can flip select-
ed pages 180 degrees ( ), 90 degrees clockwise ( ), or 90 degrees 
counterclockwise ( ). 

You can add a page to your document—either blank, lined, with a 
graph-paper grid, or from a photo in your device’s Photos collection— 
by tapping the Add button and then tapping an option in the 
popover that appears. New pages are added to the end of the PDF. You 
also have the option of duplicating the selected pages in the Thumbnail 
view, or creating a new document from them. 

Note: The Add button also appears in the main Thumbnail view, 
allowing you to add new pages to your PDF without first tapping Edit. 

Tap Done to dismiss the thumbnail-editing toolbar and return to the 
main Thumbnail view. Then, to return to viewing and working on 
individual pages in your document, tap the thumbnail for the page you 
want to view or work on next. 
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The Sidebar 
The sidebar in PDFpen for iPad & iPhone provides four different ways 
of navigating your PDF (Figure 77). Tap an icon at the sidebar’s top to 
change what it displays. Tap an item in the sidebar to navigate to that 
item in the PDF. 

Figure 77: Tap an icon at the top of the sidebar to change what 
it displays. 

Here are the four sidebar views: 

• Thumbnails: Tap the Thumbnails icon to see numbered page 
thumbnails. 

• Search: Tap the Search icon to see a search field at the top of 
the sidebar. Type in the search field to see a list of hits. 

• Table of Contents: A tap of the Table of Contents icon dis-
plays the top-level headings of the PDF’s table of contents (if it has 
one). Tap the information icon to the right of a heading to see 
its subheadings. 

• Annotations: Tap the Annotations icon to list the annotations 
you have made in the PDF. An icon to the left of each entry tells you 
what kind of annotation it is (Figure 78). 
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Figure 78: The icon beside each annotation listed in the sidebar 
indicates the type of annotation; listed here is one (empty) note 
and one highlighted passage. 

Editing Tools and Other Commands 
The editing tools—and many of the other commands you know from 
PDFpen on the Mac—can be found by tapping the buttons on the right 
side of the toolbar (Figure 79). The toolsets, in left-to-right order, are 
the Highlight tools, the Drawing tools, and the Text tools. These are 
followed by the Library (see The iOS Library Popover), and the Tools 
icon; this last produces a popover containing an assortment of com-
mands (see The iOS Tools Popovers). 

Figure 79: The right side of the toolbar is where many tools and 
commands live. 

Tap any of the first three icons to bring up the Editing Bar, which 
shows the tools in the currently selected toolset along with tool-specific 
options (see The iOS Tool Options). To close the Editing Bar, tap the 
Close icon that appears at its right. 

Note: To conserve screen space, the Editing Bar on the iPhone shows 
only the current tool icon; tap it to access a popover showing the 
other tools in the currently selected toolset. 

The iOS Highlight Tools 
The Highlight tools comprise a set of tools similar to the ones de-
scribed in Highlight Text: a Highlight Text tool, an Underline 
tool, a Strikethrough tool, and a Squiggle  tool. 
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Tap the Highlight tools icon to see the Editing Bar with the most 
recently used Highlight tool selected (Figure 80). 

Figure 80: The Highlight tools appear on the Editing Bar with 
the most recently used tool selected (here, the Highlight Text 
tool is selected). 

The iOS Drawing Tools 
The Drawing tools (Figure 81) are made up of tools that correspond 
to those described in The Drawing Tools along with the Scribble 
tool described in The Markup Tools. 

Figure 81: The Drawing tools offer similar capabilities to those 
offered by their Mac counterparts. 

Like the Highlight tools, when you tap the Drawing tools icon, the 
Editing Bar shows the most recently used Drawing tool selected. 

The iOS Text Tools 
The Text tools (Figure 82) correspond to three of the tools described 
in The Markup Tools: a Text tool for creating imprints, a Comment 

tool for creating comment boxes, and a Note tool for placing 
note icons, with their associated pop-up note windows, on the page. 

Figure 82: Use the Text tools to add text imprints, comments, 
and notes to your PDF. 

The iOS Tool Options 
Each tool you select provides one or more tool options that appear as 
icons in the center of the Editing Bar (Figure 83). They are used for 
setting colors, fonts, line styles, and so on. 
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Figure 83: The tool options vary by tool. The first three sets of 
options shown above are provided by the Text tool and, starting 
from the left, allow you to choose a font, text color, and line spacing 
and text alignment. The rightmost popover shown above, provided 
by the Comment tool, sets border width and border line style. 

An additional tool option can be found on the Editing Bar when you 
use any Highlight tool or the Scribble tool: the Palm tool. When you 
tap this tool, overlays temporarily protect most of the screen against 
touches (Figure 84) that can occur when you draw with your finger or 
a stylus and your palm accidentally brushes the screen. 

Figure 84: The Palm guard is active: only screen touches in the 
unguarded area between the two overlays affect the document. 

To move the protection overlays, drag their arrow icons. 

Note: Palm protection automatically ends after a few seconds of 
inactivity. To manually dismiss the protection, tap the Palm tool 
again, or drag the top and bottom overlays together. 
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The iOS Library Popover 
Like its Mac siblings, PDFpen for iPad & iPhone offers a Library with 
collections of objects that you can add to a PDF (Figure 85). To see 
the popover, tap the Library icon on the toolbar. The Library’s con-
tents are similar to those described in The Library, though there are 
some differences. 

Figure 85: The PDFpen Library popover in iOS offers features 
similar to those in the PDFpen Library on the Mac, but there are 
some differences, such as the Photos collection, shown here. 

Here’s what you can find in the PDFpen for iPad & iPhone Library: 

• Custom : As on the Mac, this collection contains objects that 
you might want to place on a page in the future: text imprints, 
graphic objects made with the drawing tools, comments, and im-
ages. To add an object to the Custom collection, select the object in 
the PDF and then tap the Custom collection’s Add  button. Tap 
the Edit button to rearrange the items in the collection or to delete 
items from it. 

Note: If your Mac copy of PDFpen was purchased from the Mac App 
Store, your PDFpen Library on the Mac and on iOS can synchronize 
their Custom collections via iCloud. See Smile or Mac App Store. 
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• Media : Tap this to browse the Photos library on your iOS 

device—select a photo to add it to a PDF. Tap the Camera
  button 
to take a photo with your device’s camera and add that photo to the 
PDF. Tap the Info button in the Editing Bar when you add a picture 
to a PDF to adjust its transparency and its layer order among any 
other drawn objects and imprints (annotations like comments and 
notes always display above such objects). 

• Stamps : In this collection you’ll find the various types of busi-
ness stamps and stickers as in PDFpen on the Mac. 

• Proofreading Marks : The proofreading marks in this 
collection mirror the ones available on the Mac; swipe left and right 
to view them all. 

The iOS Tools Popovers 
Yes, popovers, plural. There are two versions (Figure 86): one on 
the Documents screen’s toolbar, and the other on the document editing 
toolbar. Tap the Tools icon on each toolbar’s right side to see it. 

Figure 86: The Tools popover offers different options on the 
Documents screen (left) and on the PDF editing screen (right). 
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The Tools popover on the Documents screen is where you go to config-
ure PDFpen’s settings (described in The iOS Settings), to contact Smile 
for support, and to view help. 

Tip: Spend some time with the Help and Video Tutorial options 

available from the Documents screen’s Tools popover if you have
 

the chance.
 

The Tools popover on a PDF editing screen also provides access to 
PDFpen’s settings, but the rest of its offerings pertain to the currently 
open document: 

•	 Share: Here, “share” means to share a copy—tap Share to open 
a copy of the document in other apps; to email a copy; to send a 
copy to a location in iCloud Drive, or to Dropbox, Evernote, the file-
sharing pane for your device in iTunes, and various other remote 
destinations. You can specify whether the copy has editable annota-
tions, which some PDF viewers may not display. 

•	 Print: If your device has access to one or more printers, tap this to 
print the document. You can specify the range of pages to print and 
the number of copies. 

•	 Insert Page Numbers: Although the layout of the dialog is 
different, it provides the same capabilities as the Insert Page 
Numbers command on the Mac. 

•	 Encryption: Use this to encrypt your PDF using one of several 
encryption standards, ranging from relatively weak to very strong. 
When you choose to encrypt a PDF, you must specify a password, 
and you must enter that password each time you open the docu-
ment. Keep in mind that some of the available encryption standards 
are incompatible with some PDF viewers; generally, the weaker the 
encryption used, the more compatible the document is with other 
PDF viewers. 

•	 Document Info: Tap this to see the same information provided 
by the Document Information tab described in The Inspector. 
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The iOS Settings 
The Settings popover, accessed from the Tools popover described 
just above, provides configuration options for the PDFpen iOS app 
(Figure 87). It’s also a quick way to find out which version of the 
app is currently installed. 

Figure 87: Use this popover to set app-wide configuration options. 

Note: The iOS Settings app also has an entry for PDFpen, but it 
merely contains a few switches to permit PDFpen to access your 
device’s features, such as the camera or cellular data. 

Here are the available Settings options: 

•	 Annotation Author: Tap this to enter the name with which your 
annotations are labeled. 

•	 TextExpander: If you use Smile’s TextExpander touch app, enable 
this to use your TextExpander snippets with the standard iOS 
keyboard instead of having to switch to the custom TextExpander 
touch keyboard. 
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•	 Update Snippets: If you use TextExpander touch and make 
changes to your snippets, tap this option to update the snippets 
available in PDFpen to include those changes. 

•	 Stylus: Use this option to set up a pressure-sensitive stylus to use 
with PDFpen. The app supports several such styli. 

•	 iCloud: Enable this option to store your PDFpen documents in 
iCloud instead of locally on your device. See Use the Documents 
Screen with and without iCloud. 

•	 Automatically Sync: This option is for users of the Dropbox file 
sharing service. It controls whether PDFpen automatically syncs 
documents with Dropbox or whether you must do so manually. See 
Set Up Syncing Folders. 

•	 Wi-Fi Transfer: Tap this option to set up document sharing with 
other devices on your local Wi-Fi network, as explained in Wi-Fi 
Transfer a little later. 

•	 Sign Up for PDFpen Tips: Tap this and then enter your email 
address to have Smile send you occasional email messages contain-
ing PDFpen tips and related announcements. 

Note: Based upon my experience, Smile’s PDFpen Tips mailings 

really are occasional and don’t inundate your email inbox.
 

The iOS Context Menu 
When you select text or an object in your PDF, a context menu appears 
above or below the selection (Figure 88). 

Figure 88: The context menu appears when you select something 
in the PDF. 
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The commands available on the menu vary depending on the selected 
item (that’s why it’s called a context menu). Typically, but not always, 
this is where you find commands like Copy and Paste. When a single 
word is elected, you also get a Definition item that, when tapped, looks 
the word up in your device’s built-in dictionary. 

Need to Correct Text or Remove a Highlight? 
The context menu is the place to go: when you select text in a PDF,
 
you can find the Correct Text item on the context menu. Tap it and 

you can enter corrections in the imprint that is created for you.
 

To delete a highlight that you’ve previously placed on a PDF, touch 
and hold briefly on the highlight to select it. The context menu 
provides a Delete item that, when tapped, whisks the highlight away. 

Get PDFs in and out of PDFpen in iOS 

Pundits and press have often referred to Apple’s iOS as a “walled 
garden” and the metaphor is apt, especially when it comes to apps 
and their documents. Compared to the open file system on a Mac, for 
example, in which apps can access documents stored in almost any 
user folder, and where users can arrange their documents howsoever 
they like, the iOS file system is almost completely closed. In fact, from 
a user’s point of view, there doesn’t appear to be a file system at all. 

Instead, each app maintains jealous control over its own documents: 
when you look at the Documents screen in an iOS app like Pages, 
for example, you see only those documents belonging to Pages, even 
though your iOS device may have all sorts of other Pages-compatible 
documents in their own private storehouses. 

Nonetheless, in the following sections, I point out the gaps in the 
hedges through which you can move documents into and out of 
PDFpen for iPad & iPhone: 

•	 Use the Documents Screen with and without iCloud: This section 
covers the walled garden in which PDFpen normally stores 
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documents, and describes how you can extend its boundaries with 
iCloud Drive. I use the iCloud Drive capability to share personal 
PDFs I’m working on between my iPhone, iPad, and iMac. 

•	 Send and Receive with Open In: Look here to find out how to send 
PDFs to PDFpen from other apps, and how to send PDFs to other 
apps from PDFpen. This is how I get PDFs into PDFpen from email 
attachments and Web links, and it’s how I put them into my iBooks 
library or GoodReader when I’m done tweaking them. 

•	 Use File Servers: Find out how to copy PDFs between file servers 
and PDFpen in this section. For example, when I need to post a PDF 
on the Web, I use this capability to upload it to my site. 

•	 Set Up Syncing Folders: You can set certain services, such as 
Dropbox, to sync PDFs automatically with PDFpen for iPad & 
iPhone; this section provides details and advice. I use syncing 
folders with Dropbox to collaborate on PDFs with my Take Control 
colleagues. 

•	 Share with Your Computer: If you don’t use iCloud but want to ex-
change PDFs between your iOS device and your Mac (or even a PC), 
you can use either iTunes or a direct Wi-Fi transfer, as this section 
explains. Even when the Internet is down (yes, it can happen), these 
methods allow me to move PDFs from my Mac to my iPad and back. 
I don’t often use these capabilities but I’m very glad to have them 
available. 

Use the Documents Screen with and 
without iCloud 
Every app that keeps documents has its own name for that mysterious 
place in iOS where they’re kept. In the case of PDFpen for iPad & 
iPhone, the name is Documents (Figure 89). 
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Figure 89: The Documents screen is where you choose
 
documents to edit.
 

Without iCloud 
Absent any other method, to put a PDF in Documents tap the Add 
Document icon on the toolbar. A popover gives choices for creating 
a new document or for importing one (Figure 90). I describe some 
of these choices ahead; in particular, see Use File Servers and Share 
with Your Computer. Also, Documents is where copies of PDFs go if 
you Send and Receive with Open In. 

Figure 90: This popover provides a number of sources from 
which you can add documents to PDFpen. 
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Without iCloud access, the documents on the Documents screen are 
as walled-in as they can be: although PDFs can be copied in and out 
of PDFpen, no app other than the PDFpen app running on your device 
can touch them while they are in there. 

With iCloud 
With iCloud Drive access enabled for PDFpen, Documents becomes 
a larger walled-garden, and that garden is now located in the clouds 
(that is, on Apple’s iCloud servers with a local copy on your device). 

Here is how you enable iCloud storage in PDFpen (assuming you 
already have signed in to iCloud on your iOS device; see Apple’s site 
for iCloud setup instructions): 

1. On the toolbar, tap the Tools icon and then tap Settings. 

2. In Settings, under Document Storage, tap the iCloud switch to turn 
it on. 

When you enable iCloud storage, PDFpen for iPad & iPhone syncs 
all the PDFs in its Documents storage on the device with the PDFpen 
app library in your iCloud Drive. You may see network activity for a bit 
as data moves over the Internet. If you have any PDFpen files already 
stored in iCloud Drive, they appear in Documents along with the PDFs 
that are already there. If you have no other PDFpen documents in 
iCloud Drive, the only thing you’ll notice other than network activity is 
that the icon at the top of the Documents screen looks like a cloud 
instead of an iOS device . 

iCloud Drive becomes more useful if you also have PDFpen on your 
Mac, since you can access your iCloud Drive storage from it, too. In 
addition, any other iOS devices that are signed in to the same iCloud 
account can access those same PDFs with PDFpen for iPad & iPhone. 

Although you can share PDFs only within a single iCloud account 
(which means you’re just sharing PDFs with yourself), using iCloud 
has its benefits: just recently, I had to mark up page proofs from a 
book project, and, by storing the proof PDFs in iCloud, I could work 
on them whether I was at my desk or reclining on my couch. 
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What happens if you turn off iCloud document storage? Nothing too 
bad: the documents you had in Documents when it was connected to 
iCloud Drive remain on your iOS device. You can continue to work on 
them there, though any changes won’t be synced to other devices. 

Use Folders in Documents 
You can create folders in Documents. The process is much the same 
as when you create folders on the Home screen of your iOS device: 
drag one PDF thumbnail onto another to create a folder containing 
both PDFs. After that, you can add PDFs to the folder by dragging 
them onto the folder. You can tap the folder name to edit it, and you 
can tap the folder to open it. 

When a folder is open, you can return to the top level of Documents 
by tapping the folder name at the top of the screen. On the menu 
that appears, tap Documents (Figure 91). 

Figure 91: Tap the folder name at the top of the screen
 
to navigate back to Documents.
 

Moving a PDF out of a folder back to the top level of Documents can 
be done by dragging a PDF thumbnail to the folder name at the top 
of the screen and briefly holding it there: when the menu appears, 
drag down to Documents so it lights up, and then lift your finger to 
complete the move. 

Note that, as with folders on your Home screen, you can’t put folders 
into folders in Documents: two levels is the limit. Also note that the 
folders you create in Documents appear in iCloud Drive and on other 
devices connected to the same iCloud account. 

Send and Receive with Open In 
You can also copy documents from one app to another in the walled 
garden on your iOS device through a commonly used hole in the 
hedge: Open In. If, for example, you get a PDF as an email attachment 
on your iOS device, you can view the document in Mail and then tap 
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the Open In button. This displays all the apps your device knows about 
that can handle PDFs: tap the icon for PDFpen and a copy of the 
document lands in Documents. You have a similar Open In option 
available when you view a PDF in Safari on your device. 

The reverse capability is also true. For example, if you finish prettying 
up a PDF and want to save it your iBooks library, you can send a copy 
to iBooks from PDFpen: 

1. On the Documents screen, tap Edit at the right of the toolbar. 

2. Tap a PDF to select it. (To use Open In, only one PDF at a time can 
be selected.) 

3. Tap the Share button on the toolbar and, in the popover that 
appears, tap Open In. An Open In popover appears. 

4. In the Open In popover, tap the icon of the app to which you want 
to copy the PDF. The app opens with your PDF in it. 

Keep in mind that this is a copy; if you change the PDF in PDFpen for 
iPad & iPhone, those changes won’t appear in the copied PDF. 

Tip: If you have other iOS devices, or a newer Mac that supports 

AirDrop, you can tap Open In and then tap AirDrop to send a copy
 

to any of those devices when they are on the same Wi-Fi network
 

as your device.
 

Use File Servers 
It’s a great big Internet out there, shimmering with all sorts of services 
for storing and sharing files. PDFpen for iPad & iPhone can access 
many of them via the Add Document icon on the toolbar (and it 
can more fully integrate with one of them via its handy Sync Folders 
feature, discussed just ahead). If you cast your eye back to Figure 90, 
a few pages previously, you can see them listed in the Copy From 
section of the popover. 

Such document sources usually require a login ID and password or 
similar credentials for you to access their files. Therefore, the first time 
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you select a service that requires credentials, such as FTP or Dropbox, 
PDFpen gives you the opportunity to log in. If successful, you see a 
dialog with a list of PDFs available for you to add to Documents. If the 
service has folder hierarchies, you can navigate through the hierarchy 
by tapping a folder name; Figure 92 shows a folder deep in my 
Dropbox hierarchy with an available PDF. When you tap a PDF in the 
file list, the PDF is copied to Documents. 

Figure 92: PDFpen shows a list of files and folders on a file
 
sharing service (in this case Dropbox). Only PDFs and folders 

can be opened in the list.
 

PDFpen remembers the login credentials for each service to which 
it provides access, so the next time you access it you don’t have to 
login in again. However, you can tap Sign Out to make PDFpen forget 
your credentials if you feel insecure leaving the keys to your data in 
PDFpen’s pockets. 

Copying an edited PDF from Documents back to an Internet server 
is similar to the Open In steps described previously: 

1. On the Documents screen, tap Edit at the right of the toolbar. 

2. Tap one or more PDFs to select them. 

3. Tap the Share button on the toolbar and, in the popover that 
appears, tap the name of the destination service. 

4. To place the PDF within an existing folder, tap the folder in the file-
list dialog that appears. Tap Export at the lower right of the dialog 
to save a copy of the file. 
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Set Up Syncing Folders
The Dropbox service is designed to be an always-on sharing service: 
on your Mac, for example, your Dropbox folder is shared with the 
Dropbox service, so any documents you put into it on your Mac end 
up on Dropbox’s servers while still appearing in the Finder. Those 
documents are then accessible from any other Mac, PC, or mobile 
device logged in to the same Dropbox account. You can create some-
thing similar in PDFpen for iPad & iPhone with the Sync Folders 
capability.

If you have an account on such a service, here is how you can set up 
a sync folder that you can access from Documents:

1. Tap the heading at the top of the Documents screen and then tap 
Edit Sync Folders in the menu that appears (Figure 93).

Figure 93: The Edit Sync Folders menu item is your key 
to managing syncing folders.

2. In the Edit Sync Folders dialog that appears, tap the name of the 
service from which you want to create a sync folder (Figure 94).

Figure 94: Add and remove sync folders in this dialog.

3. In the list of folders that appears, tap the one you want to sync to 
PDFpen for iPad & iPhone. The folder is added to the menu at the 
top of the Documents screen.



             
             

                
 

       
             

        

     
        
        

       
      

     

    

         
           

               
           

           
      

      

    
            

So long as you have an Internet connection, sync folders keep the PDFs 
you edit in sync between your iOS device and the service. To see the 
contents of a sync folder, just choose it from the menu at the top of the 
Documents screen. 

Note: The title at the top of the Documents screen always reflects 

the name of the folder you are viewing. To return to the main Docu-
ments screen, tap the menu at the top of the screen and then tap 

Documents.
 

Sync Folders Don’t Always Sync Automatically 
You can control automatic folder syncing from the Settings pane of 
the Tools popover: use the Automatically Sync switch to turn syncing 
on or off for your selected service. Turning off automatic syncing 
saves bandwidth and can speed things up if you are changing a lot 
of shared documents and don’t want to sync them until you finish. 

Some tips about syncing folders: 

•	 Don’t sync everything: Because syncing copies the contents of 
a folder to your iOS device, you can quickly exhaust your device’s 
storage if you sync a folder full of large files. I suggest you set up 
specific folders in your storage service that contain only the PDFs 
you want to sync with PDFpen for iPad & iPhone (such as the 
PDFpen syncing folder shown in Figure 95). 

Figure 95: Sync folders appear in the menu on the
 
Documents screen.
 

•	 Make folders within syncing folders: You can make folders 
in a syncing folder the same way you can in Documents (described 
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in Use Folders in Documents). What’s more, syncing folders don’t 
have a depth limit like Document folders do: you can make folders 
within folders within folders. And you can have empty folders, too. 

•	 Make sure you’re synced: When automatic syncing is on, 
PDFpen for iPad & iPhone attempts to sync whenever you have an 
active Internet connection (you can still edit shared PDFs on your 
device when you don’t have a connection or when automatic syncing 
is off). You can tell when a shared PDF isn’t synced: it has a gray 
arrow in the upper-right corner of its thumbnail. You can make a 
document sync by tapping that arrow, or make the whole folder 
sync by tapping the Sync button on the toolbar when you have 
an Internet connection. 

Warning! Watch your data limits. Syncing works both over Wi-Fi 
and over cellular connections. If you are going to be out of range of 
a Wi-Fi connection and you have a limited data plan from your mobile 
service provider, consider doing a full folder sync before you go out 
on the road and then turn off automatic syncing until you reach a 
reliable Wi-Fi connection. You can still manually sync a document or 
folder even when automatic syncing is off. 

Keep in mind that you can still access files from other folders in the 
sharing service even when you have set up syncing folders using the 
techniques described in Use File Servers. 

Share with Your Computer 
You can also share PDFs between your Mac and PDFpen for iPad & 
iPhone using two techniques. The first involves iTunes and the second 
employs PDFpen’s Wi-Fi Transfer method. 

iTunes Transfer 
For this method, you work with the File Sharing interface available at 
the bottom of the Apps pane for your device in iTunes (Figure 96). 
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Figure 96: You use the File Sharing area at the bottom of 
your device’s Apps pane iTunes to share files with your Mac. 

This capability is available both when your iOS device is connected 
directly to your computer via USB and when it is connected using 
wireless syncing. 

To move files to your device from your computer, do the following: 

1. Make sure your device is connected to iTunes, either via cable or 
wirelessly. 

2. In iTunes, go to your device’s settings pane and click Apps under 
the Settings heading in the sidebar (Figure 97). 

Figure 97: In iTunes, select your device and then click Apps 

under Settings to get access to the File Sharing area.
 

3. Near the bottom of the Apps settings pane, in the File Sharing area, 
click PDFpen in the Apps list. 

4. Drag documents into and out of the PDFpen Documents list from 
the Finder or click the Add or Save To buttons that appear at the 
bottom of the list. 

Documents are moved immediately to a hidden storage area on your 
device; no need to sync the device. However, it doesn’t show up on the 
Documents screen yet. 
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To edit a PDF shared this way in PDFpen for iPad & iPhone, tap the 
Add button on the Documents screen, tap iTunes in the popover, 
then tap the file in the iTunes dialog that appears. The file is copied to 
your Documents screen from the hidden storage area on your device. 

To move a document from your device to the File Sharing area in 
iTunes, use the same techniques for sending a document to a file server 
with the Sharing button, described in Use File Servers, but tap 
iTunes in the popover instead of the name of a file server. 

Wi-Fi Transfer 
You don’t have to go through iTunes, though, to move files between 
a nearby computer (even a Windows computer) and your iOS device: 
you can share files with any computer on a local Wi-Fi network by 
turning your iOS device into a temporary Web server on that network: 

1. In the Tools popover, tap Settings > Wi-Fi Transfer. 

2. Tap the Wi-Fi Transfer switch to turn it on. PDFpen for iPad & 
iPhone becomes a temporary file server that you can access via 
a Web browser; the address of the server is listed in the popover 
(Figure 98). 

Figure 98: Make your device into a temporary file server. 
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To move files between your Mac and your device, do the following: 

1. Open a Web browser on your computer and enter the address sup-
plied by PDFpen for iPad & iPhone. 

2. On the Web page that appears (Figure 99), click a file to copy it 
to your computer, or click the Choose File button at the bottom of 
the Web page to copy a file to your device. 

Figure 99: Transfer files using a Web browser interface. 
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Appendix A: The PDFpen 
AppleScripts 

PDFpen and PDFpenPro come with a set of useful AppleScripts that 
appear on PDFpen’s AppleScript menu when you run PDFpen or 
PDFpenPro. You can use and modify these scripts for your needs. They 
perform bulk repetitive actions on one or more PDFs: almost always 
stuff that you could do by hand but which would be tedious and prone 
to error. 

The Scripts
 

so: 

To use PDFpen’s scripts, you must first populate PDFpen’s AppleScript 
menu. This menu appears to the right of PDFpen’s Help menu, like 

. However, because of Apple security restrictions, it doesn’t 
contain any scripts when you first install PDFpen. To add the scripts, 
choose AppleScript > Populate Scripts Menu. You only need to use 
this command once: the Populate Scripts Menu command goes away 
once you have populated the menu with PDFpen’s scripts. 

Use the Appropriate Script Menu 
Apple provides a different, black Script menu that can appear 
among the other systemwide menu icons on the right side of the 
menu bar; this menu is present in every app if you’ve enabled it in 
Script Editor app’s General preferences. Neither the PDFpen scripts 
nor the Populate Scripts Menu command appear on Apple’s Script 
menu. The Script menu you want is next to PDFpen’s Help menu 
and only appears in the PDFpen app. 
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The following are the scripts that come with PDFpen and PDFpenPro, 
along with some brief notes about what they do and how to use them: 

•	 Combine PDFs: This script combines two or more PDFs into 
a single document. When you run it from the Scripts menu, the 
documents must be on the same volume because the script displays 
an Open dialog in which you Command-click to choose the files. 

•	 Cover Fax Header: This script covers up the unwanted header 
of a fax. You can choose the amount of space below the top of the 
page that needs to be covered; you specify how much space is to 
be covered in 1/72-inch increments. The fax header is not actually 
erased, but merely covered with an opaque white rectangle. 

•	 Export Form Data: When you receive an interactive PDF form 
back from someone to whom you sent it, you can use this script 
to get the data out of the filled form. The script exports the data to 
a .csv text file, which can be read by Excel or Numbers. If you know 
your way around AppleScript, you can change the script to export 
the data in a different format (see Where to Find the Scripts). 

•	 Imprint All Pages as First: This places copies of all the imprints 
on the first page of a document on every subsequent page. The 
imprints can be text imprints or graphic imprints; they are placed in 
the same location as the originals on all the other pages. You might 
use this to place a logo or a running header on every page. 

•	 Imprint All Pages with Image: This script presents an Open 
dialog so you can select an image file to place on every page. The 
image is centered on each page (unless you modify the script). 

•	 Imprint All Pages with Text: When you run this script, it 
displays a dialog into which you can enter a short piece of text. The 
script creates a text imprint that contains the text you entered, and 
places that imprint, centered, on every page. 

•	 Merge Every Other: This script interleaves the pages from two 
PDFs into a single new PDF. For example, suppose you have two 
PDFs: one with a text in Latvian, and one with the same text in 
French. With the Latvian PDF open, run this script and, in the Open 
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dialog that appears, select the French translation. The result is a 
PDF with Latvian-French facing-page translations. Or suppose you 
are scanning a bound book, first scanning the odd-numbered pages 
into a PDF, and then the even-numbered pages. With this script, 
you can put those pages into the proper order. 

•	 Number Pages Using Bates Numbering: Bates numbering is 
a convention used for legal and business purposes, in which each 
page of a collection of documents has a unique page identifier. You 
supply a page number prefix for a document (for example, “Exhibit 
15a”), and the script combines that prefix with a five-digit page 
number, which it places at the bottom left of each page. This script 
is rarely needed for an individual PDF, given the Bates Numbering 
option in PDFpen’s Edit > Insert Page Numbers command, but can 
come in handy should you write workflows to process lots of PDFs. 

•	 Number Pages: Run this script to place consecutive page num-
bers at the bottom left of each page. As with the Bates Numbering 
script described just above, this script is more useful as part of a 
workflow; otherwise, use the Edit > Insert Page Numbers command 
for more flexibility. 

•	 Remove All Imprints: This removes any imprints you’ve added. 
It’s useful if you’ve modified a PDF and saved over the original. 
Keep in mind, however, that any edited text objects become im-
prints, and this script removes them as well, along with any moved 
or resized image objects. Moral: always keep backups. 

•	 Reverse Pages: Run this script to reverse the order of the pages 
in a document. This could be helpful when printing to a printer that 
doesn’t collate properly, or for a document that is to be bound in 
right-to-left reading order (such as a Japanese or Hebrew text). 

•	 Split PDF: Use this script to break a PDF apart, page by page. This 
script creates a new folder with the same name as the current PDF 
document, but with ƒ appended to the name, and places the folder 
in the directory you specify. The script then puts PDF files in that 
folder, each with a page from the current document. The files have 
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the same name as the original document, but with a five-digit 
number appended. The original document is left intact. 

Where to Find the Scripts
 

If you want direct access to PDFpen’s scripts—say, you want to copy 
them or to view them in the Script Editor when PDFpen isn’t open— 
you need to find them. The PDFpen family of applications stores its 
AppleScripts in a folder in your Home directory’s hidden Library 
folder. The scripts are placed there when you choose the Populate 
Scripts Menu command from the AppleScript menu. 

Tip: To open your Home directory’s Library folder in the Finder, hold 
down Option and choose Go > Library. To view the contents of a 
script or change how a script operates, you don’t need to open the 
hidden Library folder: hold down the Option key when you choose a 
script from PDFpen’s Script menu to see the script in Script Editor. 

Where the scripts go in the Library folder depends on which version 
of PDFpen you purchased: 

•	 PDFpen from the Mac App Store: ~/Library/Application Scripts/ 
com.smileonmymac.PDFpen7.MacAppStore 

•	 PDFpenPro from the Mac App Store: ~/Library/Application 
Scripts/com.smileonmymac.PDFpenPro7.MacAppStore 

•	 PDFpen from Smile: ~/Library/Application Scripts/com.smileonmy‐
mac.PDFpen 

•	 PDFpenPro from Smile: ~/Library/Application Scripts/ 
com.smileonmymac.PDFpenPro 

Make Copies before Altering Scripts 
It is always a good practice to copy the original versions of scripts 

before you modify them so you can always get back to where you
 

started. Sure, Time Machine is a dandy tool for helping you revert 

to previous versions of files, but making a backup of important files 

(and these are important) leaves you doubly protected.
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Learn More 
Here’s a list of useful Web sites and ebooks for learning more about 
PDFs and PDFpen: 

•	 Smile’s PDFpen Support and FAQ page: You can find answers to 
common questions, and instructions on how to contact Smile for 
individual support questions. 

•	 Smile’s Help for PDFpen for iPad & iPhone: This PDF, also viewable 
from within the app, is good to have on-hand. (Tip: save a copy that 
you can mark up with your own notes and additions.) 

•	 PDFtools.com’s PDF Primer: This white paper summarizes of the 
technological underpinnings of the PDF standard and the reasons 
that PDF was developed. 

•	 Planet PDF: This site, run by Nitro PDF software, contains a num-
ber of useful technical articles about PDF, and hosts a forum of PDF 
users and developers. 

•	 Prepressure.com: Customer support engineer Laurens Leurs main-
tains this site, which specializes in useful articles about prepress 
topics, including PDF. 

•	 Going Paperless: This entry on Jeffrey Inscho’s StaticMade blog 
tells you how to use a variety of tools, including PDFpen, to reduce 
the amount of paper in your life. 

•	 The MacSparky Paperless Field Guide: This book contains lots of 
information about going paperless, and it provides even more ways 
to use PDFpen in that endeavor. 

•	 Take Control of Your Paperless Office: This book, by Joe Kissell, is 
the seminal work on paperless PDF workflows. 
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About This Book 
Thank you for purchasing this Take Control book. We hope you find 
it both useful and enjoyable to read. We welcome your comments. 

Sponsored by Smile 

This book was sponsored by Smile. Special thanks for an enjoyable 
project to Philip Goward, Greg Scown, Éric Trépanier, and Maia Olson. 

Ebook Extras
 

You can access extras related to this ebook on the Web. Once you’re on 
the ebook’s Take Control Extras page, you can: 

•	 Download any available new version of the ebook for free, or buy a 
subsequent edition at a discount. 

•	 Download various formats, including PDF, EPUB, and Mobipocket. 
(Learn about reading on mobile devices on our Device Advice page.) 

•	 Read the ebook’s blog. You may find new tips or information, links 
to author interviews, and update plans for the ebook. 

If you bought this ebook from the Take Control Web site, it has been 
automatically added to your account, where you can download it in 
other formats and access any future updates. However, if you bought 
this ebook elsewhere, you can add it to your account manually: 

•	 If you already have a Take Control account, log in to your account, 
and then click the “access extras…” link above. 

•	 If you don’t have a Take Control account, first make one by follow-
ing the directions that appear when you click the “access extras…” 
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link above. Then, once you are logged in to your new account, add 
your ebook by clicking the “access extras…” link a second time. 

Note: If you try these directions and find that your device is incom-
patible with the Take Control Web site, contact us. 

About the Author
 

Michael E. Cohen lives on the southwest corner 
of the intersection of technology and the liberal 
arts. He’s taught writing and literature courses, 
programmed for the Deep Space Network, de-
signed and implemented instructional word 
processors, and advised dozens of humanities 
professors on all matters digital. 

As a young man, Michael set out to be a professional dilettante and, 
after years of struggle, succeeded beyond his wildest dreams. 

Other Take Control ebooks by Michael include: 

•	 Type more with fewer keystrokes. Find out how with Take Control 
of TextExpander! 

•	 Learn how to make an interactive book and have fun doing it! Take 
Control of iBooks Author shows you how to plan, produce, and 
publish with Apple’s free ground-breaking ebook construction app. 

•	 The only book we know of that covers all of Apple’s Pages apps— 
Mac, iOS, and the Web app—is Take Control of Pages. Plus it has 
a delicious chocolate-colored cover. 

Deep thanks to Philip Goward, Greg Scown, Éric Trépanier, and Maia 
Olson for answering my endless questions quickly and accurately— 
even while they were scurrying to release PDFpen 7. Thanks, as well, 
to Kelly Turner, who probably had no idea what she was getting into 
when she signed on as my editor. And, of course, thanks to Adam and 
Tonya for all their help and kind words. 
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About the Publisher
 

TidBITS Publishing Inc., publisher of the Take Control ebook series, 
was incorporated in 2007 by co-founders Adam and Tonya Engst. 
Adam and Tonya have been creating Apple-related content since they 
started the online newsletter TidBITS in 1990. In TidBITS, you can 
find the latest Apple news, plus read reviews, opinions, and more. 

Credits 
• Publisher: Adam Engst 
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• Editor: Kelly Turner 
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• Cover design: Sam Schick of Neversink 
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Thanks to Smile for helping to make this book possible! 

More Take Control Books 
This is but one of many Take Control titles! Most of our books focus 
on the Mac and OS X, but we also publish titles that cover iOS, along 
with general technology topics. 

You can buy Take Control books from the Take Control online catalog 
as well as from venues such as Amazon and the iBooks Store. 

Our ebooks are available in three formats: PDF, EPUB, and the
 

Kindle’s Mobipocket. All are DRM-free.
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Copyright and Fine Print 
Take Control of PDFpen 7 

ISBN: 978-1-61542-450-4
 

Copyright © 2015, Michael E Cohen. All rights reserved.
 

TidBITS Publishing Inc. 50 Hickory Road, Ithaca NY 14850, USA 

Why Take Control? We designed Take Control electronic books to help readers regain 
a measure of control in an oftentimes out-of-control universe. With Take Control, we also 
work to streamline the publication process so that information about quickly changing 
technical topics can be published while it’s still relevant and accurate. 

Our books are DRM-free: This ebook doesn’t use digital rights management in any 
way because DRM makes life harder for everyone. So we ask a favor of our readers. If you 
want to share your copy of this ebook with a friend, please do so as you would a physical 
book, meaning that if your friend uses it regularly, he or she should buy a copy. Your 
support makes it possible for future Take Control ebooks to hit the Internet long before 
you’d find the same information in a printed book. Plus, if you buy the ebook, you’re 
entitled to any free updates that become available. 

Remember the trees! You have our permission to make a single print copy of this 
ebook for personal use, if you must. Please reference this page if a print service refuses 
to print the ebook for copyright reasons. 

Caveat lector: Although the author and TidBITS Publishing Inc. have made a reasonable 
effort to ensure the accuracy of the information herein, they assume no responsibility for 
errors or omissions. The information in this book is distributed “As Is,” without warranty 
of any kind. Neither TidBITS Publishing Inc. nor the author shall be liable to any person 
or entity for any special, indirect, incidental, or consequential damages, including without 
limitation lost revenues or lost profits, that may result (or that are alleged to result) from 
the use of these materials. In other words, use this information at your own risk. 

It’s just a name: Many of the designations in this ebook used to distinguish products 
and services are claimed as trademarks or service marks. Any trademarks, service marks, 
product names, or named features that appear in this title are assumed to be the property 
of their respective owners. All product names and services are used in an editorial fashion 
only, with no intention of infringement. No such use, or the use of any trade name, is 
meant to convey endorsement or other affiliation with this title. 

We aren’t Apple: This title is an independent publication and has not been authorized, 
sponsored, or otherwise approved by Apple Inc. Because of the nature of this title, it uses 
terms that are registered trademarks or service marks of Apple Inc. If you’re into that sort 
of thing, you can view a complete list of Apple Inc.’s registered trademarks and service 
marks. 
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